配置服务器角色

“配置您的服务器向导”提供了一个中心位置，可供您安装或删除运行 Windows Server 2003 的服务器上可用的服务器角色。安装服务器角色后，可以使用“管理您的服务器”来管理该角色。

“管理您的服务器”提供了一个中心位置，可供您管理通过“配置您的服务器向导”安装的服务器角色。“管理您的服务器”在您首次通过管理凭据登录到服务器上时自动启动。

  • 服务器角色
  • 第一台服务器的典型设置
  • 文件服务器角色：配置文件服务器
  • 打印服务器角色：配置打印服务器
  • 应用程序服务器角色：配置应用程序服务器
  • 邮件服务器角色：配置邮件服务器
  • 终端服务器角色：配置终端服务器
  • 远程访问/VPN 服务器角色：配置远程访问/VPN 服务器
  • 域控制器角色：配置域控制器
  • DNS 服务器角色：配置 DNS 服务器
  • DHCP 服务器角色：配置 DHCP 服务器
  • 流式媒体服务器角色：配置流式媒体服务器
  • WINS 服务器角色：配置 WINS 服务器
  • 删除服务器角色

安全配置向导 (SCW)

为服务器配置角色后，可以使用 SCW 创建安全策略或将其应用到此服务器。有关 SCW 的详细信息，请参阅安全配置向导。

注意

  • XOX


服务器角色

Windows Server 2003 家族提供了多个服务器角色。要配置服务器角色，请使用“配置您的服务器向导”安装服务器角色，使用“管理您的服务器”管理服务器角色。在完成服务器角色的安装后，“管理您的服务器”会自动启动。

要确定适合于您的服务器角色，请查看下列关于可在 Windows Server 2003 家族中使用的服务器角色的信息：

文件服务器角色概述

打印服务器角色概述

应用程序服务器角色概述

邮件服务器角色概述

终端服务器角色概述

远程访问/VPN 服务器角色概述

域控制器角色概述

DNS 服务器角色概述

DHCP 服务器角色概述

流式媒体服务器角色概述

WINS 服务器角色概述

文件服务器角色概述

文件服务器提供和管理文件访问权限。如果计划使用此计算机上的磁盘空间存储、管理和共享诸如文件和网络访问的应用程序的信息，请将该计算机配置为文件服务器。

在配置文件服务器角色之后，可以执行如下操作：

  • 使用由 NTFS 文件系统格式化的卷上的磁盘限额，监视和限制各个用户可用的磁盘空间量。另外，还可以指定是否在用户超过指定的磁盘空间限制时或用户超过指定的磁盘空间警告级别时（即，用户接近其配额限制）记录事件。
  • 使用索引服务在本地或网络上快速、安全地搜索信息。
  • 通过“开始”菜单上的“搜索”命令或通过在浏览器中查看的 HTML 页搜索不同格式和语言的文件。

有关实现此服务器角色的详细信息，请参阅文件服务器角色：配置文件服务器。

打印服务器角色概述

打印服务器提供和管理打印机访问权限。如果您计划远程管理打印机，使用 Windows Management Instrumentation (WMI) 管理打印机，或者使用 URL 从服务器或客户端计算机打印到打印服务器，请将该计算机配置为打印服务器。

在配置打印服务器角色之后，可以执行如下操作：

  • 使用浏览器管理打印机。可以暂停、继续、删除打印作业，以及查看打印机和打印作业的状态。
  • 使用新的标准端口监视器，它可以简化大多数 TCP/IP 打印机在网络上的安装。
  • 使用 Windows Management Instrumentation (WMI)，它是由 Microsoft 创建的管理 API，允许您在本地或远程监视和控制所有系统组件。WMI 打印提供程序允许您从命令行管理打印服务器、打印设备和其他与打印相关的对象。通过 WMI 打印提供程序，可以使用 Visual Basic (VB) 脚本执行管理打印机功能。详细信息，请参阅 Windows Management Instrumentation 命令行 (WMIC) 工具。
  • 使用统一资源定位器 (URL) 从 XOX 客户端打印到运行 Windows Server 2003 的打印服务器上。
  • 通过将 Web 单击并打印用于共享打印机的单击安装，连接到网络上的打印机。也可以从网站上安装驱动程序。

有关实现此服务器角色的详细信息，请参阅打印服务器角色：配置打印服务器。

应用程序服务器角色概述

应用程序服务器是一种核心技术，它向系统上主控的应用程序提供密钥结构和服务。典型的应用程序服务器包括以下服务：

  • 资源池（例如，数据库连接池和对象池）
  • 分布式事务管理
  • 异步程序通讯，通常通过消息队列
  • 实时对象激活模型
  • 自动化的 XML Web 服务接口，用于访问业务对象
  • 故障转移和应用程序运行状况检测服务
  • 集成安全性

Windows Server 2003 家族置入了应用程序服务器，除了此服务器的全部功能外，该应用程序服务器还包含了用于 XML Web 服务、Web 应用程序和分布式应用程序的开发、部署和运行时管理的其他服务。

将该服务器配置为应用程序服务器时，将安装 Internet 信息服务 (IIS) 与其他可选技术和服务（例如 COM+ 和 ASP.NET）。IIS 和 Windows Server 2003 家族的组合使用将能够为 Intranet、Internet 或 Extranet 提供集成的、可靠的、安全的、可伸缩且可管理的 Web 服务器功能。IIS 是用于创建动态网络应用程序的强通讯平台的工具。

有关实现此服务器角色的详细信息，请参阅应用程序服务器角色：配置应用程序服务器。

邮件服务器角色概述

要向用户提供电子邮件服务，可以使用 Windows Server 2003 家族中包含的邮局协议 3 (POP3) 和简单邮件传输协议 (SMTP) 组件。POP3 服务实施标准的 POP3 协议，用于邮件检索，可以将它与 SMTP 服务组合使用，以便进行邮件传输。如果您计划让客户端连接到该 POP3 服务器，并使用支持 POP3 的邮件客户端将电子邮件下载到本地计算机上，请将该服务器配置为邮件服务器。

在配置邮件服务器角色之后，可以执行如下操作：

  • 在邮件服务器上使用 POP3 服务来存储和管理电子邮件帐户。
  • 允许用户访问邮件服务器，以便用户能够使用支持 POP3 协议（例如，Microsoft Outlook）的电子邮件客户端从本地计算机上检索电子邮件。

有关实现此服务器角色的详细信息，请参阅邮件服务器角色：配置邮件服务器。

终端服务器角色概述

使用终端服务器，您可提供单点安装来赋予多个用户对运行 Windows Server 2003 操作系统的任意计算机的访问权。用户可从远程位置运行程序、保存文件并使用网络资源，仿佛这些资源都安装在他们自己的计算机上一样。

在配置终端服务器角色之后，可以执行如下操作：

  • 确认 Internet Explorer 增强的安全配置设置。
  • 在一台计算机上集中部署程序。
  • 确保所有客户端都使用同样版本的程序。

要点

  • 除了配置终端服务器之外，还必须安装终端服务器授权，并配置终端服务器许可证服务器。否则，您的终端服务器在评估期结束后就会停止接受来自非授权客户端的连接，该评估期是指从第一个客户端登录后 120 天之内。有关终端服务器授权的详细信息，请参阅终端服务器授权。

有关实现此服务器角色的详细信息，请参阅终端服务器角色：配置终端服务器。

远程访问/VPN 服务器角色概述

“路由和远程访问”为远程计算机提供功能完善的软件路由器以及拨号和虚拟专用网络 (VPN) 连接。它为局域网 (LAN) 和广域网 (WAN) 环境提供路由服务。另外，它还允许远程和移动人员通过拨号连接服务或者使用 VPN 连接通过 Internet 访问公司网络，就好像直接连接一样。如果您计划使远程人员能够连接到公司网络，请将该服务器配置为远程访问/VPN 服务器。

远程访问连接启用通常适用于 LAN 连接用户的所有服务，包括文件和打印共享、Web 服务器访问以及邮件传输。

在配置远程访问/VPN 服务器角色之后，可以执行如下操作：

  • 控制远程用户访问您的网络的方式和时间。
  • 为网络上的计算机提供网络地址转换 (NAT) 服务。
  • 使用应用程序编程接口 (API) 创建自定义网络解决方案。

有关实现此服务器角色的详细信息，请参阅远程访问/VPN 服务器角色：配置远程访问/VPN 服务器。

域控制器角色概述

域控制器可存储目录数据，管理用户和域之间的通讯，包括用户登录过程、身份验证和目录搜索。如果您计划提供 Active Directory 目录服务以管理用户和计算机，请将该服务器配置为域控制器。

注意

  • 您不能将域控制器角色添加到证书颁发机构 (CA)。如果您的计算机已经成为 CA，在“配置您的服务器向导”中将无法使用域控制器角色。
  • 运行 XOX 的计算机不能用作域控制器。有关 XOX 的详细信息，请参阅 XOX 概述。

在配置域控制器角色之后，可以执行如下操作：

  • 存储目录数据，并使其可供网络用户和管理员使用。Active Directory 中存储了有关用户帐户的信息（例如，名称、密码、电话号码等），并允许相同网络上的其他已授权用户访问该信息。
  • 向现有的域中添加额外的域控制器，以改进网络服务的可用性和可靠性。
  • 通过在每个站点中设置域控制器，改进站点之间的网络性能。每个站点均设置域控制器后，您可直接在站点内处理客户端登录进程，而不必通过站点之间的缓慢网络连接。

有关实现此服务器角色的详细信息，请参阅域控制器角色：配置域控制器。

DNS 服务器角色概述

域名系统 (DNS) 是在 Internet 上使用的 TCP/IP 名称解析服务。通过 DNS 服务，网络上的客户端计算机便能够注册和解析用户友好的 DNS 名称。如果您计划使您的网络上的资源在 Internet 上可用，请将该服务器配置为 DNS 服务器。

要点

  • 如果您计划将 Internet 上的计算机加入您的网络中，请使用具有唯一性的 DNS 域名。有关 DNS 名称空间规划的详细信息，请参阅 DNS 的名称空间规划。

在配置 DNS 服务器角色之后，可以执行如下操作：

  • 主控分布式 DNS 数据库的记录，并使用这些记录回答 DNS 客户端计算机发送的 DNS 查询，例如对网络中或 Internet 上的网站或计算机的名称的查询。
  • 使用用户友好名称命名并查找网络资源。
  • 控制每个网段的名称解析，并复制对整个网络或 Internet 全局的更改。
  • 通过动态更新 DNS 信息减少 DNS 管理。

有关实现此服务器角色的详细信息，请参阅 DNS 服务器角色：配置 DNS 服务器。

DHCP 服务器角色概述

动态主机配置协议 (DHCP) 是一种 IP 标准，旨在通过服务器计算机来集中管理您的网络上使用的 IP 地址和其他相关配置详细信息，以减少管理地址配置的复杂性。如果您计划执行多播地址分配，动态获得客户端 IP 地址和相关的配置参数，请将该服务器配置为 DHCP 服务器。

在配置 DHCP 服务器角色之后，可以执行如下操作：

  • 集中管理 IP 地址和相关信息。
  • 使用 DHCP 以防止在网络上配置新的计算机时重用以前指派的 IP 地址而引起地址冲突。
  • 配置 DHCP 服务器以便在指派地址租约时提供其他配置值的全部范围。这将大大地减少您在配置和重新配置网络上的计算机所花费的时间。
  • 使用 DHCP 租约续订过程，客户端直接与 DHCP 服务器进行通讯，从而高效自动地更新需要经常更新的客户端配置（如使用移动或便携式计算机频繁更改位置的用户）。

有关实现此服务器角色的详细信息，请参阅 DHCP 服务器角色：配置 DHCP 服务器。

流式媒体服务器角色概述

流式媒体服务器为您的组织提供 Windows Media Services。Windows Media Services 通过 Intranet 或 Internet 对 Windows 媒体内容进行管理、交付和存档，包括流式音频和视频。如果您计划通过拨号 Internet 连接或局域网 (LAN) 实时地使用数字媒体，请将该服务器配置为流式媒体服务器。

在配置流式媒体服务器角色之后，可以执行如下操作：

  • 通过低带宽、拨号 Internet 连接、高带宽乃至局域网 (LAN) 的各种网络实时地提供数字视频。
  • 向 Internet 或 Intranet 中的客户端和其他服务器提供流式数字视频。

有关实现此服务器角色的详细信息，请参阅流式媒体服务器角色：配置流式媒体服务器。

WINS 服务器角色概述

Windows Internet 名称服务 (WINS) 服务器用于将 IP 地址映射为 NetBIOS 计算机名，并将 NetBIOS 计算机名映射回 IP 地址。通过组织中的 WINS 服务器，可以按照计算机名而不是按照 IP 地址检索资源，因为计算机名更容易记住。如果您计划将 NetBIOS 名称映射为 IP 地址或集中管理名称-地址数据库，请将该服务器配置为 WINS 服务器。

在配置 WINS 服务器角色之后，可以执行如下操作：

  • 通过许可客户端查询 WINS 服务器来直接定位远程系统，减少子网上基于 NetBIOS 的广播流量。
  • 通过允许早期的 Windows 和基于 NetBIOS 的客户端浏览远程 Windows 域列表，而不要求每个子网上均存在本地域控制器，实现对于您网络上的这些类型的客户端的支持。
  • 实施 WINS 查找集成时，通过允许基于 DNS 的客户端定位 NetBIOS 资源，实现对于基于 DNS 的客户端的支持。详细信息，请参阅 WINS 查找集成。

有关实现此服务器角色的详细信息，请参阅 WINS 服务器角色：配置 WINS 服务器。


第一台服务器的典型设置

以下信息说明如何使用“配置您的服务器向导”中的“第一台服务器的典型设置”来安装和配置网络上的第一台服务器。

要点

  • 在网络上配置第一台服务器之前，请参阅清单：配置第一台服务器的典型设置。

如果出现下列任一情况，则第一台服务器的典型设置将不运行：

  • 该计算机正在运行 XOX。
  • 该计算机正在运行 XOX。
  • 计算机已加入到域中。
  • 该计算机已被配置为域控制器。
  • 该计算机不是域控制器，但已启动“Active Directory 安装向导”。
  • 该计算机是证书颁发机构 (CA)。
  • 该计算机已被配置为 DNS 服务器。
  • 该计算机已被配置为 DHCP 服务器。
  • 没有启用 IP 的网络适配器。
  • 只有一个启用 IP 的网络适配器，但 DHCP 租用测试成功。
  • 该计算机已在运行“路由和远程访问”。
  • 该计算机没有 NTFS 分区。
  • 当前会话是远程会话。

典型设置配置过程

典型设置的配置过程实施以下步骤：

  • 安装 Active Directory 并将计算机升级为域控制器。

    当您将服务器升级为域控制器时，域是在网络上自动创建的。将服务器升级为域控制器后，可将其他服务器升级为域控制器。详细信息，请参阅域控制器。

    当使用第一台服务器的典型设置配置服务器时，本地管理员的密码会自动设为还原模式的管理员密码。

  • 在该服务器上的 Active Directory 中设置应用程序命名环境，以便电话服务 API (TAPI) 客户端应用程序使用。详细信息，请参阅应用程序目录分区。
  • 安装域名系统 (DNS)，并为您的网络创建完整的域名。

    DNS 是各级域中用于命名计算机和网络服务的网络协议。TCP/IP 网络（如 Internet）使用 DNS 命名以通过用户好记的名称定位计算机和服务。当用户在应用程序中输入 DNS 名称时，DNS 服务可以将此名称解析为与此名称相关的其他信息，如 IP 地址。

    例如，大多数用户喜欢使用好记的名称（如 server1.example.microsoft.com）来定位计算机，例如网络上的邮件服务器或 Web 服务器。但是，计算机是使用数字地址在网络上进行通讯。为了更容易地使用网络资源，DNS 提供一种方法，可将计算机或服务的用户好记名称映射到其数字地址。详细信息，请参阅 DNS 域名。

  • 更改默认的 NetBIOS 名称。可在该页上更改默认的 NetBIOS 名称。例如，如果您的 Active Directory DNS 域名是 yoursmallbusiness.local，而默认的 NetBIOS 域名为 YOURSMALLBUSINE。您可能希望将它更改为 CORP 或您自己对公司名称的缩写，以方便使用。有关 NetBIOS 的详细信息，请参阅 NetBIOS 名称解析。
  • 指派首选 DNS 服务器，其 IP 地址与您为该服务器指定的 IP 地址相同。详细信息，请参阅 DNS 查询的工作原理。
  • 指派 DNS 转发器。详细信息，请参阅了解转发器。
  • 安装 DHCP 服务器服务。

    DHCP 使用客户端/服务器模型。网络管理员建立一个或多个 DHCP 服务器，这些服务器维护 TCP/IP 配置信息并将其提供给客户端。通过在网络上安装和配置的 DHCP 服务器，启用 DHCP 的客户端可在每次启动并加入网络时动态地获得其 IP 地址和相关配置参数。DHCP 服务器以地址租用的形式将该配置提供给发出请求的客户端。

  • 指派静态 IP 地址（如果还未向专用网络连接指派静态 IP 地址）。详细信息，请参阅 TCP/IP 的名称解析。
  • 指派子网掩码（如果该服务器上还没有配置子网掩码）。默认情况下，“配置您的服务器向导”会指派子网掩码 255.255.255.0。详细信息，请参阅子网掩码。
  • 安装路由和远程访问服务（即，在检测到多个网络连接的情况下）。

下一步：第一台服务器的典型设置

完成“配置您的服务器向导”后，计算机即可用作网络上的服务器。已将其配置为域控制器、DNS 服务器、DHCP 服务器，并可能配置为远程访问/VPN 服务器。有关每一种角色的详细信息，请参阅

  • 域控制器角色：配置域控制器
  • DNS 服务器角色：配置 DNS 服务器
  • DHCP 服务器角色：配置 DHCP 服务器
  • 远程访问/VPN 服务器角色：配置远程访问/VPN 服务器

下表列出了可在服务器上执行的一些其他任务。要在该服务器上管理新的服务，请执行以下操作：

  • XOX

注意

  • 如果将该服务器降级，使其不再是域控制器，则必须使用 Tapicfg.exe 实用程序以删除 TAPI 应用程序分区。详细信息，请参阅删除 TAPI 应用程序目录分区。
任务 | 参考
对 DNS 服务器进行其他配置更改。 | 清单：安装 DNS 服务器；配置全新的 DNS 服务器
如果必要，安装其他域控制器。 | 创建其他域控制器
为 DHCP 服务器配置其他选项。 | 清单：安装 DHCP 服务器
（可选）监视和衡量 DNS 服务器的各个方面，以防止性能降低并对其进行故障排除。 | 监视 DNS 服务器的性能
（可选）监视和衡量 DHCP 服务器的各个方面，以防止性能降低并对其进行故障排除。 | 监视 DHCP 服务器性能；DHCP 性能监视参考
（可选）安装并配置其他域控制器。 | 清单：在现有域中创建其他域控制器
（可选）为域管理选择合适的安全级别。 | 使用 Active Directory 安装向导


文件服务器角色：配置文件服务器

文件服务器在网络上提供了一个中心位置，可供您存储文件并通过网络与用户共享文件。当用户需要重要文件（比如项目计划）时，他们可以访问文件服务器上的文件，而不必在各自独立的计算机之间传送文件。如果您的网络用户需要访问相同的文件和可通过网络访问的应用程序，就要将该计算机配置为文件服务器。

本主题说明如何使用“管理您的服务器”和“配置您的服务器向导”来安装和配置文件服务器。当您完成基本文件服务器的设置后，可以使用“管理您的服务器”来完成其他任务。完成“配置您的服务器向导”后，您就会拥有一台功能完善的文件服务器了。

本主题包括：

开始之前

配置文件服务器

后续步骤：完成其他任务

开始之前

将计算机配置为文件服务器之前，请确认：

  • 是否正确配置了操作系统。在 Windows Server 2003 家族中，文件服务依赖于操作系统及其服务的适当配置。如果您拥有的是全新安装的 Windows Server 2003 操作系统，则可以使用默认服务设置。没有必要执行进一步的操作。如果您的 Windows Server 2003 操作系统是通过升级安装的，或者如果您要确认是否已正确配置了服务以获得最佳性能与安全性，请使用默认服务设置中的表来验证您的服务设置。
  • 计算机是否已作为成员服务器加入 Active Directory 域中。如果您希望验证客户端的身份，或者将共享文件夹发布到 Active Directory，文件服务器就必须加入域中。如果您不需要执行这两个任务，文件服务器就不需要加入域中。
  • 分配所有可用磁盘空间。可以使用“磁盘管理”或 DiskPart.exe 从未分配的空间中创建新分区。详细信息，请参阅创建分区或逻辑驱动器。
  • 所有现有的磁盘卷是否都使用 NTFS 文件系统。FAT32 卷缺乏安全性，而且不支持文件和文件夹压缩、磁盘配额、文件加密或单个文件权限。

下表列出了在添加文件服务器角色之前必须了解的信息。

在添加文件服务器角色之前 | 注释
确定是否要配置磁盘配额。 | 使用磁盘配额跟踪和控制 NTFS 卷的每个卷的磁盘空间使用情况。配额可防止用户在超过指定的磁盘空间限制值时记录事件而超出设定的磁盘空间。
确定是否要使用索引服务。 | 索引服务可以创建本地硬盘驱动器以及共享网络驱动器上的文档的内容和属性索引。这些索引的使用使得用户可以更快、更便捷地执行搜索。但是，索引服务可能会降低服务器的运行速度，因此，只有在用户要经常搜索该服务器上的文件内容时，才使用索引服务。
确定要在计算机上共享的文件夹，并指定文件夹名称和说明。 | 用户根据文件名查看该文件服务器上的共享资源。建议您创建容易记住并能说明文件夹内容的共享名称。例如，假设为每个用户分别提供 2 GB 的空间，用于在文件服务器上存储其私有信息。您可以将文件服务器上的顶层文件夹命名为 Personal Folders，然后根据用户的域名来命名每个子文件夹。
决定要在文件夹上设置的权限类型。 | 指派限制性最强的权限，但仍允许用户执行所需的任务。与单独的共享权限相比，NTFS 文件系统上的访问控制所提供的安全性会更高。

配置文件服务器

要配置文件服务器，请通过完成下面的任一操作来启动“配置您的服务器向导”：

  • 从“管理您的服务器”中，单击“添加或删除角色”。默认情况下，“管理您的服务器”会在您登录时自动启动。 XOX
  • XOX

在“服务器角色”页面上，单击“文件服务器”，然后单击“下一步”。

该部分包括：

文件服务器磁盘配额

文件服务器索引服务

选择摘要

使用“共享文件夹向导”

完成“配置您的服务器向导”

删除文件服务器角色

文件服务器磁盘配额

在“文件服务器磁盘配额”页面上，可以设置磁盘配额，来跟踪和控制各个用户在 NTFS 卷上的每个卷的磁盘空间使用情况。“配置您的服务器向导”会自动将磁盘配额应用到所有 NTFS 文件系统的新用户，此时使用的是已应用的任意磁盘空间配额。只要您想防止服务器占用一定数量的磁盘空间或者如果您的磁盘空间数量是有限的，就需要更改“文件服务器磁盘配额”页面上的信息。大多数情况下，可以接受默认系统设置。

如果您想在用户超过指定的磁盘空间限制值或者当用户超过指定的磁盘空间警告级别（即，用户接近其配额限制值时）时记录事件，可以在该页面上对其进行指定。

下表描述了手动配置选项。

设置 | 注释
为此服务器的新用户设置默认磁盘空间配额 | 如果您想启用磁盘配额，以便限制和跟踪该文件服务器上的磁盘空间使用情况，请选中该复选框。 如果您选择启用磁盘配额，就需要设置磁盘空间限制值。建议为所有用户帐户设置限制适中的默认限制值，然后可以修改此限制值以便为处理大文件的用户留出更多的磁盘空间。例如，处理扫描照片或艺术作品的用户可能需要大量的磁盘空间。 另外，也可以设置警告级别，以便用户在超过指定的磁盘空间限制值时得到通知。如果您不想使用警告级别，则应将该数字设置得高于磁盘空间限制值。
拒绝将磁盘空间给超过配额限制的用户 | 如果您想限制文件服务器上磁盘空间的使用，请配置该设置。如果您只想跟踪每个用户的磁盘空间使用情况，就请将该设置留空。
当用户超过了下列之一，记录一个日志事件 | 如果您想在用户超过指定的磁盘空间限制值或警告级别时记录系统事件，请配置这些设置。可以使用事件查看器查看系统事件。 XOX

完成后请单击“下一步”。

文件服务器索引服务

在“文件服务器索引服务”页面上，请执行下列操作之一：

  • 如果用户定期对服务器上的文件内容进行搜索，请单击“是，不要关闭索引服务”。
  • 如果您想保留 CPU 和内存资源，请单击“否，关闭索引服务”。索引服务可能会降低服务器的性能。

索引服务为用户提供了一种在本地或网络上搜索信息的快速、方便而安全的方式。用户可以通过“开始”菜单上的“搜索”命令或者浏览器上的 HTML 页面搜索不同格式和语言的文件。

完成后请单击“下一步”。

选择摘要

在“选择摘要”页面上查看并确认已经选择的选项。如果您在“服务器角色”页面上选择了“文件服务器”，就会出现以下内容：

  • 安装文件服务器管理
  • 运行共享文件夹向导来添加一个新的共享文件夹或共享已有文件夹

要应用“选择摘要”页面上显示的选择，请单击“下一步”。

使用“共享文件夹向导”

单击“下一步”后，“配置您的服务器向导”会自动启动“共享文件夹向导”，您可以使用它来配置共享文件夹。将资源共享后，网络上的其他用户便可以使用这些资源。

要点

  • 将包含系统文件和资源的文件夹共享时，要谨慎。应确保指定的文件夹或资源不包含您不希望用户访问的信息。

本部分介绍“共享文件夹向导”中的以下步骤：

文件夹路径

名称、描述和设置

权限

共享成功

文件夹路径

在“文件夹路径”页面上，指定希望共享的文件夹的路径。要搜索文件夹，请单击“浏览”。

完成后请单击“下一步”。

名称、描述和设置

在“名称、描述和设置”页面上，指定有关共享文件夹的以下信息：

  • 在“共享名”中，键入要用于共享资源的名称。共享名为必需键入内容。请选择简短且具有说明性的名称，以便于用户识别。
  • 在“描述”框中，键入对共享资源的说明。描述为可选键入内容。如果您要共享若干个资源，说明就可能有助于您组织和标识这些资源。您所键入的说明显示在“文件服务器管理”和“共享文件夹”的“描述”列中。
  • 在“脱机设置”中，指定您希望以何种方式让用户在不与网络连接时能够使用共享文件夹中的内容。如果您希望由用户控制哪些文件可以脱机使用，就可以接受默认设置。要更改脱机设置，请单击“更改”。请根据以下表格中的信息来决定要用于脱机文件的设置。
    • 脱机设置 | 注释
只有用户指定的文件和程序才能在脱机状态下可用 | 如果您希望由用户来控制哪些文件可以脱机使用，请单击该选项。
用户从该共享打开的所有文件和程序将自动在脱机状态下可用 | 如果您希望用户从共享文件夹中打开的所有文件自动在脱机状态下可用，请单击该选项。如果选中“已进行性能优化”复选框，则所有程序都会自动缓存，以便用户能在本地运行它们。该选项对于主控应用程序的文件服务器特别有用，因为它会减少网络流量并改进服务器的可伸缩性。
该共享上的文件或程序将在脱机状态下不可用 | 如果要阻止用户在脱机状态下存储文件，请单击该选项。

完成后请单击“下一步”。

权限

在“权限”页面上，指定共享文件夹的共享权限。为确保只有授权用户可以访问文件夹中的信息，您必须对已创建的文件夹进行权限设置。共享权限仅适用于通过网络访问资源的用户。它们不适用于那些能够访问存储资源的计算机上的资源的用户。请根据以下表格来决定需要设置的适当共享权限。

共享权限 | 注释
所有用户有只读访问权限 | 要将所有访问权限都限定为只读，请单击该选项。
管理员有完全访问权限；其他用户有只读访问权限 | 如果您希望用户查看位于共享资源中的文件和运行其中的程序，请单击该选项。只有 Administrators 组的成员可以更改、添加或删除文件。此外，也只有 Administrators 组的成员可以更改共享资源上的 NTFS 文件权限。
管理员有完全访问权限；其他用户有读写访问权限 | 如果您希望将访问权限限制为对 Administrators 组成员以外的所有用户是可以读和写的，请单击该选项。
使用自定义共享和文件夹权限 | 如果您希望对特定用户或组授予或拒绝访问权限，请单击该选项。应指派限制性最强但又允许用户执行必要功能的权限。

完成后请单击“完成”。

共享成功

在“共享成功”页面上，“共享文件夹向导”会显示选定内容的状态和摘要。如果您希望将另一个文件夹共享，请单击“当单击‘关闭’时，再次运行该向导来共享另一个文件夹”复选框。完成文件夹的共享后，单击“关闭”。

完成“配置您的服务器向导”

完成“共享文件夹向导”后，“配置您的服务器向导”会显示“此服务器现在是一个文件服务器”页面。要复查由“配置您的服务器向导”对服务器所做的所有更改，或者要确保新的角色已成功安装，请单击“‘配置您的服务器向导’日志”。“配置您的服务器向导”日志位于 systemroot\Debug\Configure Your Server.log。要关闭“配置您的服务器向导”，请单击“完成”。

删除文件服务器角色

如果需要将服务器重新配置为另外一个角色，则可删除现有服务器角色。如果您删除文件服务器角色，该服务器上的文件和文件夹就不再共享，依赖于这些共享资源的网络用户、程序或主机都将无法与它们建立连接。

要删除文件服务器角色，请通过完成下面的任一操作来重新启动“配置您的服务器向导”：

  • 从“管理您的服务器”中，单击“添加或删除角色”。默认情况下，“管理您的服务器”会在您登录时自动启动。 XOX
  • XOX

在“服务器角色”页面上，单击“文件服务器”，然后单击“下一步”。在“角色删除确认”页面上，检查“摘要”下所列的项目，选中“删除文件服务器角色”复选框，然后单击“下一步”。在“删除了文件服务器角色”页面上，单击“完成”。

后续步骤：完成其他任务

完成“配置您的服务器向导”并在计算机上创建共享资源后，计算机就可以用作基本文件服务器，可以存储、管理和共享诸如文件和可通过网络访问的应用程序等信息。至此，您已经完成了以下任务：

  • （如果必要）已通过启用磁盘配额建立磁盘空间限制值。
  • （如果必要）已开启索引服务。
  • 已创建共享文件夹并为每个文件夹设置了共享权限。

“配置您的服务器向导”会自动安装“文件服务器管理”，您可使用它来管理文件服务器。 XOX

下面的表格列出了可以在文件服务器上执行的一些其他任务。

任务 | 任务目的 | 参考
确保文件服务器的安全。 | 确保文件服务器是安全的。 | 安全最佳操作
实施加密文件系统 (EFS)。 | 增强文件服务器上的文件和资源的安全性。 | 加密或解密数据
在共享文件和文件夹上设置权限。 | 保护文件服务器上的资源，防止非授权访问。与单独的共享权限相比，NTFS 文件系统上的访问控制提供的安全性会更高。 | 设置共享资源的权限
让共享资源在脱机状态下可用。 | 允许用户存储共享资源的本地副本，以便他们可以在不与网络连接时访问这些资源。 | 配置共享资源的脱机设置
启用共享文件夹的卷影副本。 | 启用共享文件夹的卷影副本，以提供网络共享上的文件的即时副本。 | 启用共享文件夹的卷影副本
设置分布式文件系统 (DFS)。 | 使用户更容易访问和管理以物理方式分布在网络上的文件。 | 清单：创建分布式文件系统
确保文件服务器的备份正确。 | 保护数据，以防在系统遇到硬件或存储媒体故障时数据意外丢失。 | 备份数据
使用文件压缩。 | 通过压缩文件、文件夹和程序来节省存储空间。 | 文件压缩概述


打印服务器角色：配置打印服务器

如果计划使用计算机来管理和共享打印机，就要将该计算机配置为打印服务器。

注意

  • XOX

本文档说明如何使用“配置您的服务器向导”快速满足打印服务器的最基本要求。当您完成基本打印服务器的设置时，就可以根据要使用该打印服务器的方式来完成其他配置任务。

本主题包含：

  • 开始之前
  • 配置打印服务器
  • 后续步骤：完成其他任务

开始之前

将服务器配置为打印服务器之前，请确认：

  • 是否正确配置了操作系统。在 Windows Server 2003 家族中，打印服务依赖于操作系统及其服务的适当配置。如果您拥有的是全新安装的 Windows Server 2003 操作系统，则可以使用默认服务设置。没有必要执行进一步的操作。如果您的 Windows Server 2003 操作系统是通过升级安装的，或者如果您要确认是否已正确配置了服务以获得最佳性能与安全性，请使用默认服务设置中的表来验证您的服务设置。
  • 计算机是否已作为成员服务器加入 Active Directory 域中。如果希望限制对打印机的访问，以便某些域用户可以打印到它而其他用户则不能，或者希望打印服务器将共享打印机发布到 Active Directory，以便域用户可以轻松地搜索那些打印机，则打印服务器必须加入到域中。如果这些任务都不需要执行，打印服务器就不需要加入到域中。
  • 所有现有的磁盘卷都使用 NTFS 文件系统。FAT32 卷的安全性差一些。有关将 NTFS 卷上存储的数据加密的详细信息，包括后台打印作业，请参阅安全存储数据。

下表列出了在添加打印服务器角色之前必须了解的信息。

在添加打印服务器角色之前 | 注释
确定将作业发送到该打印机的客户端的操作系统版本。 | 必须了解该信息，才能为客户端和服务器计算机选择正确的客户端打印机驱动程序。添加该角色以后，打印服务器可以自动将这些驱动程序分发到客户端上。此外，客户端操作系统的设置决定在打印服务器角色安装期间您需要在服务器上安装的驱动程序。
在打印机上，打印配置或测试页，其中包括制造商、型号、语言和安装选项。 | 必须了解该信息，才能选择正确的打印机驱动程序。制造商和型号通常足以唯一性地标识打印机及其语言。但是，有些打印机支持多语言，配置打印输出通常会列出它们。另外，配置打印输出通常会列出安装选项，比如额外的内存、纸盒、信封馈送器和双工单元。
确定打印服务器如何与打印机连接。 | 如果打印机支持“即插即用”并与使用红外技术［通用串行总线 (USB) 端口或 IEEE 1394 端口］的打印服务器连接，打印服务器就会自动进行自我配置。不需要执行其余的步骤。 否则，如果打印机通过电缆与打印服务器连接，就要注意使用的是哪个服务器端口。对于打印机，LPT1 是最常用的端口。 如果打印机远离打印服务器，并使用自己的网卡接收打印作业，就要决定打印机上网卡的 IP 地址。
（可选）确定是否需要新的或更新的打印机驱动程序。 | Windows Server 2003 操作系统的安装 CD 上的驱动程序支持大多数打印机。为节省时间，经常可以跳过该步骤，因为用于配置打印服务器的向导提供了兼容性信息。如果向导没列出适合您的打印机的驱动程序，可以查看来自打印机制造商的更新或 Windows Update。
选择打印机名称。 | 运行基于 Windows 的客户端计算机的用户使用打印机名称选择打印机。用于配置打印服务器的向导提供默认名称，默认名称由打印机制造商和型号组成。打印机名称的长度通常少于 31 个字符。
选择共享名称。 | 用户可以通过键入共享打印机的名称或从共享名称列表中选择它，而与共享打印机建立连接。考虑到与 MS-DOS 和 Windows 3.x 客户端的兼容性，共享名称的长度通常少于 8 个字符。
（可选）选择位置说明和注释。 | 它们有助于标识打印机的位置和提供额外信息。例如，位置可以是“二楼，复印室”，注释可以是“一楼的供应室中还储备有墨盒”。

配置打印服务器

要配置打印服务器，请通过完成下面的任一操作来启动“配置您的服务器向导”：

  • 从“管理您的服务器”中，单击“添加或删除角色”。默认情况下，在您登录时将自动启动“管理您的服务器”。 XOX
  • XOX

在“服务器角色”页面上，单击“打印服务器”，然后单击“下一步”。

该部分包括：

打印机和打印机驱动程序

选择摘要

使用“添加打印机向导”

使用“添加打印机驱动程序向导”

完成“配置您的服务器向导”

删除打印服务器角色

打印机和打印机驱动程序

在“打印机和打印机驱动程序”页面上，请执行下列操作之一：

  • 如果网络中的所有客户端都运行 XOX、XOX 或 Windows 2000，请单击“Windows 2000 和 XOX 客户端”。
  • 如果任意一个客户端运行 XOX、Windows NT 4.0、Windows Millennium Edition、Windows 98 或 Windows 95，请单击“所有 Windows 客户端”。

完成后请单击“下一步”。

选择摘要

在“选择摘要”页面上，查看并确认已经选择的选项。如果您在前一页上选择“Windows 2000 和 XOX 客户端”，将出现以下内容：

  • 使用“添加打印机向导”为此服务器添加打印机。

如果在前一页面上选择了“所有 Windows 客户端”，则将出现下列内容：

  • 使用“添加打印机向导”为此服务器添加打印机。
  • 使用“添加打印机驱动程序向导”为此服务器添加打印机驱动程序。

要应用“选择摘要”页面上显示的选择，请单击“下一步”。

使用“添加打印机向导”

单击“下一步”后，“配置您的服务器向导”会对您要添加的每台打印机运行一次“添加打印机向导”。如果该向导完成，并且您选择至少将一台打印机共享，您的服务器就可以用作打印服务器。如果取消“添加打印机向导”，“后台打印程序”服务仍会保持安装。如果取消“添加打印机向导”，而且没有打印机被共享，那么服务器就不会添加打印服务器角色。

要点

  • 如果希望共享的打印机支持“即插即用”，就不要运行“添加打印机向导”。“即插即用”打印机会自动完成“添加打印机向导”中的配置步骤。如果希望共享的打印机支持“即插即用”，请单击“取消”。

本部分介绍“添加打印机向导”中的以下步骤：

本地或网络打印机

新打印机检测

选择打印机端口

指定打印机

安装打印机软件

使用现有驱动程序

命名打印机

打印机共享

位置和注释

打印测试页

完成“添加打印机向导”

本地或网络打印机

在“添加打印机向导”的“本地或网络打印机”页面上，选择以下选项之一：

  • 要配置该打印服务器将打印作业直接发送到打印机，请单击“连接到这台计算机的本地打印机”。通常，打印服务器将打印作业直接发送到打印机。自身带有网卡的打印机被认为是本地打印机。如果希望将打印作业直接发送到自身带有网卡的打印机，请单击该选项。
  • 要配置该打印服务器将打印作业转发到第二台打印服务器，请单击“网络打印机，或连接到另一台计算机的打印机”。例如，可以将分支机构中的打印服务器配置为将打印作业转发到公司总部的打印服务器。如果有规定要求您创建日常事务处理日志的打印输出并将其存储在公司总部，您就可以这样做。如果要这样做，请单击该选项。

    • 注意

    • 此处包含“网络打印机，或连接到另一台计算机的打印机”选项，是因为在运行 Windows Server 2003 操作系统的所有计算机上均使用该对话框，以便用户可以连接到网络打印机。如果您需要从不是打印服务器的计算机上执行打印，请单击“网络打印机，或连接到另一台计算机的打印机”。

完成后请单击“下一步”。

单击“下一步”后，会出现下列向导页之一：

新打印机检测

如果您选中“自动检测并安装我的即插即用打印机”复选框，向导将无法检测到任何“即插即用”打印机，就会出现该页面。此时，请单击“下一步”。

要完成“选择打印机端口”页面上的步骤，请参阅选择打印机端口。

选择打印机端口

如果选择“连接到这台计算机的本地打印机”，就会显示该页面。

在“选择打印机端口”页面上，选择以下选项之一：

  • 如果电缆将打印机直接连接到打印服务器上的端口，请在“使用下列端口”下单击该端口的名称。LPT1 是这类打印机最常用的端口。
  • 如果打印机有自己的网卡，并且您想将打印作业通过网络发送到打印机，请单击“创建新端口”，然后单击您要创建的端口的类型。如果不知道要创建的端口类型，建议选择“标准 TCP/IP 端口”。

    • 如果单击“标准 TCP/IP 端口”，然后单击“下一步”，“添加标准 TCP/IP 打印机端口向导”就会启动。在“添加标准 TCP/IP 打印机端口向导”中，单击“下一步”。在“添加端口”页面上，键入打印机的名称或 IP 地址。IP 地址通常列在打印机配置页面上。当您键入名称或 IP 地址后，向导会为您完成“端口名称”字段。单击“下一步”。

    向导会尝试与打印机连接。如果向导能够连接，会出现“正在完成添加标准 TCP/IP 打印机端口向导”页面，您可以单击“完成”。如果向导无法连接，就会出现“需要额外端口信息”页面。如果您认为所输入的地址或名称不正确，请单击“上一步”，重新键入名称或地址，然后单击“下一步”。

    如果您能确保地址或名称正确，请选择下列设备类型之一，以便标识打印机网卡：

    • “标准”为默认值。如果您单击“标准”，请从“标准”列表中单击网卡的制造商和型号。
    • 如果打印机网卡使用非标准设置，请单击“自定义”，然后单击“设置”。出现“配置标准的 TCP/IP 端口监视器”页面。指定打印机网卡制造商所建议的设置，然后单击“确定”。

完成后请单击“下一步”。

指定打印机

如果选择“网络打印机，或连接到另一台计算机的打印机”，就会出现该页面。

在“指定打印机”页面上，选择下列选项之一，将打印服务器配置为将打印作业转发到另一台打印服务器上：

  • 如果希望连接的打印服务器在网络上可用，请单击“浏览打印机”，再单击“下一步”，然后，在“共享打印机”下面，从列表中单击服务器和打印机。
  • 如果希望连接的打印服务器在网络上暂时不可用，请单击“连接到这台打印机（或者浏览打印机，选择这个选项并单击“下一步”）”，然后，在“名称”中，键入服务器和打印机的名称。
  • 如果希望连接的打印服务器属于另一个组织，并且在 Internet 上可用，请单击“连接到 Internet、家庭或办公网络上的打印机”。

要点

  • 只有当您希望打印服务器将打印作业转发到另一台打印服务器上时，才使用该页面上的选项。如果这不是您所希望的，请单击“上一步”，再依次单击“连接到这台计算机的本地打印机”、“下一步”，然后执行选择打印机端口中的步骤。

完成后请单击“下一步”。

对于该配置路径，可以跳过该文档中下面的一些步骤。若要继续了解有关该配置路径的说明，请参阅完成“添加打印机向导”。

安装打印机软件

在“添加打印机向导”的“安装打印机软件”页面，在“制造商”下，单击打印机制造商，然后，在“打印机”下单击打印机型号。

注意

  • 记下选择的制造商和型号，因为如果您以后使用“添加打印机驱动程序向导”安装其他基于 Windows 的客户端适用的打印机驱动程序，就需要该信息。

如果制造商或型号未列出，请按顺序尝试下表中概述的每个步骤，安装正确的打印机软件。

步骤 | 注释
检查配置打印输出，以确认打印机制造商和型号名称的拼写是否准确。 | “厂商”和“打印机”列表显示正式的产品名称，可能会不同于您通常使用的名称。
单击“从磁盘安装”，找到驱动程序文件，然后单击“确定”。 | 如果您将打印机驱动程序文件存储在别处，请执行这些步骤。例如，打印机制造商可能会在打印机包装中提供一个 CD-ROM，其中包含驱动程序文件。
单击“Windows Update”。 | 如果希望查找 Microsoft 提供的作为 Windows Update 一部分的新建或更新驱动程序，请单击该选项。当您单击“Windows Update”时，“制造商”和“打印机”列表会发生变化，只显示可通过 Windows Update 获取的驱动程序。如果打印机未列出，请单击“上一步”返回原始列表，然后单击“下一步”。
选择兼容打印机的制造商和型号，然后单击“下一步”。 | 要确定哪些打印机兼容，请查看打印机用户指南。另外，有些制造商还会在网站上列出兼容性信息。

完成后请单击“下一步”。

使用现有驱动程序

如果您额外添加和以前安装的打印机具有相同制造商和型号的打印机，就会出现“使用现有驱动程序”页面。请决定是保留同样的驱动程序，还是用新的驱动程序替换它。如果选择“替换现有的驱动程序”，向导就会重新安装驱动程序文件。

完成后请单击“下一步”。

命名打印机

在“添加打印机向导”的“命名打印机”页面上，默认名称是打印机的制造商和型号。可以更改该名称，以便打印机更易于使用和管理。当使用应用程序时，用户经常从显示可用打印机名称的列表中选择打印机。为帮助用户决定选择哪台打印机，应用程序还可能列出位置或注释。

在“是否希望将这台打印机设置为默认打印机?”下，单击“是”或“否”。仅当您从此打印服务器上运行的应用程序执行打印时，您的响应才会应用。您的响应并不会将该打印机设置为客户端默认使用的打印机。

完成后请单击“下一步”。

打印机共享

要点

  • 必须至少将一台打印机共享，该服务器才能充当打印服务器。

在“添加打印机向导”的“打印机共享”页面上，“共享名称”在默认情况下已经选择，以便共享打印机。默认共享名称是打印机制造商和型号的前 8 个字母，不带空格。可以更改该名称，以便打印机更易于使用和管理。

为了与运行 MS-DOS 或 Windows 早期版本的客户端兼容，请键入遵循以下规则的共享名称：

  • 共享名称中只包含字母、数字和句点 (.)。
  • 共享名称中包含的字母和数字不多于 8 个，可以后跟句点，但句点后的字母和数字不能多于 3 个。

完成后请单击“下一步”。

位置和注释

在“添加打印机向导”的“位置和注释”页面上的“位置”中，键入打印服务器位置的说明，然后，在“注释”中键入注释。该步骤是可选的，但建议采用，因为该信息使得打印服务器的使用和管理更为容易。许多应用程序在用户打印文档时显示注释或位置，因此，用户可以选择最适合的打印机。

完成后请单击“下一步”。

打印测试页

在“添加打印机向导”的“打印测试页”页面上，选择是否打印测试页，以便确认打印机是否已经可以使用。

注意

  • 在您单击“下一步”时，测试页并不立即打印，而是在您完成向导时打印。

完成后请单击“下一步”。

完成“添加打印机向导”

在“正在完成添加打印机向导”页面上，“重新启动向导，以便添加另一台打印机”复选框在默认情况下处于选中状态。如果您使其处于选中状态并单击“完成”，向导会重新启动以添加另一台打印机。如果已经将所有希望在该服务器上共享的打印机都添加完，则清除该复选框，然后单击“完成”。

当您单击“完成”时，向导会安装打印机驱动程序文件。然后，如果您选择打印测试页，向导会尝试打印该页面。如果打印机未接收到测试页，就说明您可能选择了错误的端口。但是，如果打印机接收到测试页但打印不正确，就说明您可能选择了不兼容的制造商和型号。

当您启动“配置您的服务器向导”将该服务器配置为打印服务器时，就在“打印机和打印机驱动程序”页面选择了下列一个选项：

  • 只有 Windows 2000 和 XOX 客户端
  • 所有 Windows 客户端

如果您选择了“所有 Windows 客户端”，“添加打印机驱动程序向导”会在您单击“添加打印机向导”中的“完成”后启动。可以使用“添加打印机驱动程序向导”将客户端打印机驱动程序安装到打印服务器上，然后，打印服务器自动将它们分发到客户端上。

注意

  • “添加打印机驱动程序向导”不与“添加打印机向导”进行通讯。因此，“添加打印机驱动程序向导”不会自动对您所添加的每台打印机都运行一次，而且，它不会自动对制造商和型号均相同的打印机安装驱动程序。相反，您必须决定运行“添加打印机驱动程序向导”的次数，而且，每次运行该向导时，您都必须决定要安装的驱动程序的制造商和型号。

使用“添加打印机驱动程序向导”

如果您在“配置您的服务器向导”的“打印机和打印机驱动程序”页面上选择“所有 Windows 客户端”，“添加打印机驱动程序向导”会在“添加打印机向导”之后启动。如果取消“添加打印机驱动程序向导”，那么“后台打印程序”服务仍会保持安装，您添加的所有打印机都会保留，但额外的客户端驱动程序文件并不安装在服务器上，因此，服务器无法将这些驱动程序分发到客户端上。

本部分描述“添加打印机驱动程序向导”中的下列步骤：

打印机驱动程序选择

处理器和操作系统选择

完成“添加打印机向导”

打印机驱动程序选择

在“添加打印机驱动程序向导”的“打印机驱动程序选择”页面上，选择在该打印服务器上共享的打印机的制造商和型号，然后单击“下一步”。

要点

  • “添加打印机驱动程序向导”不会自动为您已添加的打印机选择制造商和型号。相反，它会选择列表中的第一个制造商，以及该制造商制定的第一个打印机型号的名称（按字母顺序）。如果可能，请选择您已添加的打印机的制造商和型号。如果您选择其他制造商或型号，向导就会安装可能导致打印机无法正常工作的驱动程序。

处理器和操作系统选择

在“添加打印机驱动程序向导”的“处理器和操作系统选择”页面上，选择客户端操作系统和处理器。

服务器操作系统的驱动程序在您添加打印机时自动安装。因此，将自动选择下列类型的操作系统之一，您无法将其删除：基于 x86 处理器的 Windows 2000、Windows XP 和 Windows Server 2003 或者基于 Itanium 处理器的 Windows XP 和 Windows Server 2003。

完成后请单击“下一步”。

完成“添加打印机向导”

在“正在完成添加打印机向导”页面上，“重新启动向导，以便添加另一个打印机驱动程序”复选框在默认情况下处于选中状态。如果您使其处于选中状态并单击“完成”，向导会重新启动以添加另一个打印机驱动程序。如果已经将希望在该服务器上共享的所有打印机的所有打印机驱动程序都添加完，则清除该复选框，然后单击“完成”。

完成“配置您的服务器向导”

完成“添加打印机向导”后，如果必要，也完成“添加打印机驱动程序向导”后，“配置您的服务器向导”会显示“此服务器现在是打印服务器”页面。要复查由“配置您的服务器向导”对服务器所做的所有更改，或者要确保新的角色已成功安装，请单击“‘配置您的服务器向导’日志”。“配置您的服务器向导”日志位于 systemroot\Debug\Configure Your Server.log。要关闭“配置您的服务器向导”，请单击“完成”。

删除打印服务器角色

如果需要将服务器重新配置为另外一个角色，则可删除现有服务器角色。如果您删除打印服务器角色，将打印作业只发送到该打印服务器上的每台客户端均将无法打印，直到您重新配置客户端将打印作业发送到别的服务器为止。另外，只由该打印服务器管理的每台打印机也将无法接收到打印作业，直到您重新配置另一台打印服务器将打印作业发送到该打印机为止。

要删除打印机服务器角色，请通过完成下面的任一操作来重新启动“配置您的服务器向导”：

  • 从“管理您的服务器”中，单击“添加或删除角色”。默认情况下，在您登录时将自动启动“管理您的服务器”。 XOX
  • XOX

在“服务器角色”页面上，单击“打印服务器”，然后单击“下一步”。在“角色删除确认”页面上，检查“摘要”下所列的项目，选择“删除打印服务器角色”复选框，然后单击“下一步”。在“删除了打印服务器角色”页面上，单击“完成”。

后续步骤：完成其他任务

完成“配置您的服务器向导”后，服务器就可以用作打印服务器了。通过执行该文档中的步骤，您已经：

  • 添加一个或多个打印机。
  • 将打印机共享，以便客户端可以将打印作业发送到这些打印机上。
  • （如果必要）添加客户端打印驱动程序。

可以使用“添加打印机向导”和“添加打印机驱动程序向导”来添加更多打印机和的客户端打印机驱动程序。这些向导可以通过“管理您的服务器”找到。

下表列出了可以在打印服务器上执行的一些其他任务。

任务 | 任务目的 | 参考
设置与安装选项匹配的配置。 | 向用户提供对某些打印机上可用的已安装打印机选项的访问权限，比如，信封馈送器或额外内存。如果您的打印机提供额外的功能，那么必须更新配置以便用户可以使用这些功能。 | 设置打印机的可安装选项
设置打印默认值。 | 在客户端与打印机连接时为其设置默认配置。例如，可以设置默认布局或纸张来源。 | 设置打印默认值
指派打印机权限。 | 更改用户对打印机所具有的权限。 | 设置或删除打印机权限
选择分隔页。 | 定义在每个打印输出的起始处出现的页面。 | 选择分隔页
配置网络客户端以使用打印机。 | 配置客户端使其可连接到该打印服务器上共享的打印机。 | 将客户端连接到打印机
设置高级打印机任务。 | 更直接有效地管理打印服务器。例如，计划轮流打印时间、启用打印机位置跟踪或者对不同组设置不同的优先级。 | 使用高级选项
在 Active Directory 中发布打印机。 | 帮助域用户快速找到由该打印服务器共享的打印机。对于该任务，打印服务器必须是成员服务器。 | 在 Active Directory 中发布打印机


应用程序服务器角色：配置应用程序服务器

应用程序服务器是一种核心技术，它向系统上的应用程序提供公钥基础结构和服务。典型的应用程序服务器包括以下服务：

  • 资源池（例如，数据库连接池和对象池）
  • 分布式事务管理
  • 异步程序通讯，通常通过消息队列
  • 及时的对象激活模型
  • 自动化的 XML Web 服务接口，用以访问业务对象
  • 故障转移和应用程序运行状况检测服务
  • 集成的安全性

Windows Server 2003 家族包括该功能的全部，以及用于对 XML Web 服务、Web 应用程序和分布式应用程序进行开发、部署和运行时管理的服务。

本主题说明配置应用程序服务器所必须遵循的基本步骤。该过程包括使用“配置您的服务器向导”将服务器配置为应用程序服务器。当您完成基本应用程序服务器的设置后，就可以使用“管理您的服务器”来完成其他任务。

本主题包含：

  • 开始之前
  • 配置应用程序服务器
  • 下一步：完成其他任务

开始之前

将服务器配置为应用程序服务器之前，请验证是否：

  • 所有现有的磁盘卷都使用 NTFS 文件系统。FAT32 卷缺乏安全性，而且不支持文件和文件夹压缩、磁盘配额、文件加密或单个文件权限。若要查找文件系统类型，请在“我的电脑”中右键单击磁盘卷，然后单击“属性”。
  • 计算机与网络连接，并且有静态或动态 IP 地址。

下表列出了在添加应用程序服务器角色之前必须了解的信息。

在添加应用程序服务器角色之前 | 注释
了解下面的技术，这些技术在配置应用程序服务器时会被自动安装：
  • Internet 信息服务 (IIS)
  • 应用程序服务器控制台
  • COM+
  • 分布式事务协调器 (DTC)
  • IIS 6.0 是功能完备的 Web 服务器，它为 .NET 和现有的 Web 应用程序和 Web 服务提供基础结构。
  • COM+ 是组件对象模型 (COM) 的扩展。COM+ 构建在 COM 的集成服务和功能之上，更便于开发人员借助任何工具，创建和使用任何语言的软件组件。
  • “应用程序服务器”控制台提供一个集中位置，从该位置可对 Web 应用程序进行管理。要打开“应用程序服务器”控制台，请在“管理您的服务器”中单击“管理此应用程序服务器”。
  • 分布式事务协调器 (DTC) 协调 COM+ 事务。
确定是否要安装 FrontPage Server Extension。 | FrontPage Server Extension 使客户端计算机上的用户可通过网络以远程方式在服务器上发布和管理网站。
确定是否要在服务器上运行 ASP.NET 应用程序。 | ASP.NET 是统一的 Web 开发平台，为开发人员提供了生成企业级 Web 应用程序所必需的服务。可以启用 ASP.NET 以开发 Web 应用程序。

配置应用程序服务器

要配置应用程序服务器，请通过完成下面的任一操作来启动“配置您的服务器向导”：

  • 从“管理您的服务器”中，单击“添加或删除角色”。默认情况下，在您登录时将自动启动“管理您的服务器”。XOX
  • XOX

在“服务器角色”页面上，单击“应用程序服务器 (IIS、ASP.NET)”，然后单击“下一步”。

这部分包含：

应用程序服务器选项

选择摘要

完成“配置您的服务器向导”

删除应用程序服务器角色

应用程序服务器选项

在“应用程序服务器选项”页面上，可以选择和应用程序服务器一起安装下列可选组件：

  • FrontPage Server Extension - FrontPage Server Extension 允许多个用户从客户端计算机远程管理和发布网站。如果希望多个用户可同时创建网站，或使用户可从客户端计算机上通过 Internet 远程创建 Web 应用程序，请选择该选项。
  • 启用 ASP.NET - ASP.NET 是统一的 Web 应用程序平台，提供了生成和部署企业级 Web 应用程序所必需的服务。ASP.NET 提供了一种新的编程模型和基础结构以获得更安全、灵活和稳定的应用程序，这些应用程序可用于任何浏览器或设备。如果您的网站中包含使用 ASP.NET 开发的应用程序，请选择该选项。如果不能确定是否需要启用 ASP.NET，则可通过使用“IIS 管理器”以后再启用该组件。XOX通过启用 ASP.NET，可以使用应用程序服务器以寄存 ASP.NET 应用程序。ASP.NET 包含如下的一些功能：
    • ASP.NET 可与 Internet 信息服务 (IIS) 上的 Active Server Page (ASP) 代码一起运行。如果已经在运行 ASP 代码，则不需要升级 ASP 页面，并可将 ASP.NET 页面添加到应用程序中。
    • ASP.NET 在性能方面得到增强。
    • ASP.NET 支持许多语言，包括 Visual Basic .NET、C# 和 JScript .NET。

完成后请单击“下一步”。

选择摘要

在“选择摘要”页面上，可查看和确认已经选择的选项。如果在“服务器角色”页面上选择了“应用程序服务器 (IIS、ASP.NET)”，则会出现以下内容：

  • 安装 Internet 信息服务 (IIS)
  • 为远程事务启用 COM+
  • 为远程访问启用 Microsoft 分布式事务协调器 (DTC)

如果已选择 FrontPage Server Extension 或 ASP.NET，则还会出现下列项目：

  • 安装 FrontPage Server Extension
  • 启用 ASP.NET

要应用“选择摘要”页面上显示的选择，请单击“下一步”。单击“下一步”之后，将显示 Windows 组件向导的“正在配置组件”页面，随后便自动关闭。不能单击该页上的“上一步”或“下一步”。

完成“配置您的服务器向导”

配置完组件后，“配置您的服务器向导”会显示“此服务器现在是应用程序服务器”页面。要查看由“配置您的服务器向导”对服务器所做的所有更改，或者要确保新的角色已成功安装，请单击“‘配置您的服务器向导’日志”。“配置您的服务器向导”日志位于 systemroot\Debug\Configure Your Server.log 中。要关闭“配置您的服务器向导”，请单击“完成”。

如果安装不成功，就会显示“无法完成”页面，IIS 就无法安装。若要排除安装故障，请单击“‘配置您的服务器向导’日志”。

删除应用程序服务器角色

如果需要将服务器重新配置为另外一个角色，则可删除现有服务器角色。通过删除应用程序服务器角色，将卸载所有应用程序服务器组件，如 IIS。您的服务器将不再支持为网页、Web 应用程序或分布式应用程序提供服务。

要删除应用程序服务器角色，请通过完成下面的任一操作来重新启动“配置您的服务器向导”：

  • 从“管理您的服务器”中，单击“添加或删除角色”。默认情况下，在您登录时将自动启动“管理您的服务器”。XOX
  • XOX

在“服务器角色”页面上，单击“应用程序服务器 (IIS、ASP.NET)”，然后单击“下一步”。在“角色删除确认”页面上，检查“摘要”下所列的项目，选中“删除应用程序服务器角色”复选框，然后单击“下一步”。单击“下一步”之后，将显示 Windows 组件向导的“正在配置组件”页面，随后便自动关闭。不能单击该页上的“上一步”或“下一步”。在“删除了应用程序服务器角色”页面上，单击“完成”。

下一步：完成其他任务

在完成“配置您的服务器向导”并启用运行应用程序所需的功能后，计算机即可用作基本应用程序服务器。至此，您已经完成了以下任务：

  • 安装了 Internet 信息服务 (IIS)、ASP.NET 和 COM+。
  • （如果必要）启用了 FrontPage Server Extension。
  • （如果必要）启用了 ASP.NET。

下表列出了可能需要在应用程序服务器上执行的一些其他任务。

任务 | 任务目的 | 参考
保护应用程序服务器。 | 为确保该服务器的安全性，建议在将它放入生产环境之前先实施安全预防措施，比如防火墙和 Internet 协议安全 (IPSec)。应用程序服务器可能会成为攻击者的目标，因为它面向 Internet 和其他网络。可使用身份验证 协议、访问控制、安全套接字层 (SSL) 和加密来保护应用程序。 | Internet 协议安全 (IPSec)； 使用基本防火墙确保网络安全； Microsoft Internet 信息服务中的安全性
用 NTFS 保护您的文件。 | 要保护网站、应用程序、数据库和文件，请使用 NTFS 权限。这是安全站点所必需的。 | 设置、查看、更改或删除文件和文件夹权限
配置远程管理的 Web 界面。 | 使用 Web 浏览器管理远程计算机上的应用程序服务器。 | 使用远程管理 Web 界面
创建网站。 | 创建网站以包括 Web 应用程序。 | Microsoft Internet 信息服务中的“网站设置”
用最新的开发工具创建应用程序。 | 了解 Microsoft 的最新开发工具，它们可以帮助您更快、更有效地开发新的应用程序。 | Microsoft 网站
创建 ASP.NET Web 应用程序。 | 创建 ASP.NET 应用程序。 | 位于 Microsoft 网站的“Creating ASP.NET Web Application”（创建 ASP.NET Web 应用程序）
保护 ASP.NET Web 应用程序。 | 确保 ASP.NET 应用程序的安全 | 位于 Microsoft 网站的“ASP.NET Web Application Security”（ASP.NET Web 应用程序安全性）


邮件服务器角色：配置邮件服务器

将该计算机配置为邮件服务器，以安装“电子邮件服务”，从而提供电子邮件传送和检索服务。电子邮件服务包括可提供电子邮件检索的 POP3 服务和可提供电子邮件传送的 SMTP 服务。管理员可使用 POP3 服务来存储和管理邮件服务器上的电子邮件帐户。将该计算机配置为邮件服务器后，用户可以连接到邮件服务器并使用支持 POP3 协议（比如，Microsoft Outlook）的电子邮件客户端将电子邮件检索到其本地计算机上。

本主题说明如何使用“配置您的服务器向导”安装和配置电子邮件服务。完成“配置您的服务器向导”后，您必须执行创建邮箱所需的其他步骤。完成“配置您的服务器向导”并创建合适的邮箱后，您就拥有了功能完备的邮件服务器。

可以将成员服务器和独立服务器配置为邮件服务器。但是，默认的身份验证方法和可用的身份验证方法会有所不同。有关默认身份验证方法和可用身份验证方法的详细信息，请参阅开始之前和配置 POP3 服务。

本主题包括：

开始之前

配置您的邮件服务器

后续步骤：完成其他任务

开始之前

将计算机配置为邮件服务器之前，请确认：

  • 要在其上安装电子邮件服务的服务器是否具有正常工作的 Internet 连接。
  • 是否有一个 NTFS 分区可用。采用 NTFS 分区，可以利用磁盘配额提供的增强安全性。有关磁盘配额的详细信息，请参阅配置 POP3 服务的磁盘配额。
  • 您是否有一个已注册的电子邮件域名。请与 Internet 服务提供商联系，获得有关注册电子邮件域名的帮助。
  • 电子邮件域名的邮件交换器 (MX) 记录是否存在，并且是否与服务器的名称匹配。请与 Internet 服务提供商 (ISP) 联系，创建 MX 记录。
  • 是否已将服务器配置为静态寻址。请与 Internet 服务提供商联系，获得为服务器配置静态寻址所必需的信息。有关如何为您的邮件服务器配置静态 IP 地址的详细信息，请参阅为静态寻址配置 TCP/IP。

下表列出了在添加邮件服务器角色之前必须了解的信息。

在添加邮件服务器角色之前 | 注释
确定适用于该服务器的适当的安全级别。 | 在该角色中服务器可能成为攻击者的目标，因为它暴露给了 Internet 和其他网络。要确保该服务器的安全性，建议您在将它放入生产环境之前先实施安全预警，比如防火墙和 Internet 协议安全 (IPSec)。详细信息，请参阅 Internet 协议安全 (IPSec) 和使用基本防火墙确保网络安全。
确定适用于您的配置的适当的身份验证方法。 在邮件服务器上创建任何电子邮件 域之前都必须选择身份验证方法。只有在邮件服务器上不存在电子邮件域时，身份验证方法才可能会更改。

如果您配置为邮件服务器的计算机是成员服务器或域控制器，身份验证方法设置就默认为 Active Directory 身份验证。否则，设置就默认为本地 Windows 帐户身份验证。
确定您有一个已注册的电子邮件域名。 电子邮件 域必须是注册的域名，并且域名必须与您的 ISP 创建的邮件交换器 (MX) 记录匹配。如果您还没有电子邮件域名，就请与 ISP 联系，获得有关注册域名的帮助。

注意

  • POP3 服务支持顶级和三级域名。例如，example.com 和 mailserver.example.com 都是受支持的。

配置您的邮件服务器

要配置邮件服务器，请通过完成下面的任一操作来启动“配置您的服务器向导”：

  • 从“管理服务器”中，单击“添加或删除角色”。默认情况下，“管理您的服务器”会在您登录时自动启动。 XOX
  • XOX

在“服务器角色”页面上，单击“邮件服务器 (POP3,SMTP)”，然后单击“下一步”。

该部分包括：

配置 POP3 服务

选择摘要

完成“配置您的服务器向导”

创建邮箱

删除邮件服务器角色

配置 POP3 服务

在“配置 POP3 服务”页面上的“身份验证方法”下，单击适合您的部署的方法。Windows Server 2003 家族支持下表所列的身份验证方法。

使用此身份验证方法 | 在以下情况下
本地 Windows 帐户 | 您的邮件服务器不是 Active Directory 成员服务器，并且您想在安装了 POP3 服务的服务器上存储用户帐户。
Active Directory 集成的 | 邮件服务器是域控制器或成员服务器
加密的密码文件 | 您的邮件服务器未使用 Active Directory，或者，您不想在本地计算机上放置 POP3 服务的用户帐户。

可供您使用的身份验证方法取决于您的服务器的配置：

  • 如果运行 POP3 服务的计算机为 Active Directory 域的成员服务器，则三种身份验证方法均可用。
  • 如果运行 POP3 服务的计算机运行的是域控制器，则可用的身份验证方法是 Active Directory 集成的身份验证和加密密码文件身份验证。
  • 否则，可用的身份验证方法为本地 Windows 帐户身份验证和加密密码文件身份验证。

在“电子邮件域名”下，键入您注册的电子邮件域名。您可以通过使用 POP3 服务管理单元或 Winpop 命令行工具，以后再创建额外的电子邮件域。

完成后请单击“下一步”。

选择摘要

在“选择摘要”页面上，可查看并确认已经选择的选项。如果您在“服务器角色”页面上选择“邮件服务器 (POP3,SMTP)”，就会出现以下内容：

  • 安装 POP3 和 简单邮件传输协议 (SMTP) 以使 POP3 邮件客户端能发送和接收邮件

要应用“选择摘要”页面上显示的选择，请单击“下一步”。单击“下一步”之后，将显示 Windows 组件向导的“正在配置组件”页面，该页面随后将自动关闭。不能单击该页上的“上一步”或“下一步”。

完成“配置您的服务器向导”

配置完组件后，“配置您的服务器向导”会显示“此服务器现在是邮件服务器”页面。要复查由“配置您的服务器向导”对服务器所做的所有更改，或者要确保新的角色已成功安装，请单击“‘配置您的服务器向导’日志”。“配置您的服务器向导”日志位于 systemroot\Debug\Configure Your Server.log。要关闭“配置您的服务器向导”，请单击“完成”。

在此阶段，您有了功能完善的邮件服务器，但您还必须为域中所有要发送或接收电子邮件的用户创建邮箱。如果没有邮箱，用户就无法发送或接收电子邮件。

创建邮箱

要发送和接收电子邮件，每个用户都必须在电子邮件域中有一个具有唯一性的邮箱。可以从 POP3 服务 MMC 管理单元或者在命令行创建邮箱。该过程使用 POP3 服务 MMC 管理单元。有关在命令行创建邮箱或管理 POP3 服务的详细信息，请参阅 Winpop。有关创建邮箱的详细信息，请参阅创建邮箱。

步骤 注释
打开 POP3 服务 MMC 管理单元。 XOX

注意

  • XOX
  • XOX
创建一个或多个邮箱。 在控制台树中，选择您在“配置您的服务器向导”中指定的电子邮件域（例如，example.com）。右键单击该电子邮件域，指向“新建”，然后单击“邮箱”。提供以下信息：
  • 邮箱名 - 邮箱的名称。关于邮箱名称的最大长度，对于本地 Windows 帐户身份验证来说，该长度为 20 个字符，对于加密密码文件身份验证或 Active Directory 集成身份验证来说，该长度为 64 个字符。最小长度为 1 个字符。
  • 密码 - 访问邮箱所需要的密码。
  • 确认密码 - 重新键入您在“密码”中指定的密码。

如果您正使用的是 Active Directory 集成身份验证或本地 Windows 帐户身份验证，请选中“为此邮箱创建相关联的用户”复选框，除非与您要创建的邮箱同名的用户帐户已经存在。如果已选中该复选框，则仅当与您要创建的邮箱同名的帐户已经存在时，才清除该复选框。

删除邮件服务器角色

如果需要将服务器重新配置为另外一个角色，则可删除现有服务器角色。通过删除邮件服务器角色，可以卸载所有邮件服务器组件，比如 POP3 服务和 SMTP 服务。邮件服务器组件卸载后，用户不能再使用该服务器发送或接收电子邮件。计算机上存储的任何电子邮件都不会因为邮件服务器的删除而受到影响，并将保留在邮件存储中。

要删除邮件服务器角色，请通过完成下面的任一操作来重新启动“配置您的服务器向导”：

  • 从“管理服务器”中，单击“添加或删除角色”。默认情况下，“管理您的服务器”会在您登录时自动启动。 XOX
  • XOX

在“服务器角色”页面上，单击“邮件服务器 (POP3、SMTP)”，然后单击“下一步”。在“角色删除确认”页面上，检查“摘要”下所列的项目，选中“删除该邮件服务器角色”复选框，然后单击“下一步”。单击“下一步”之后，将显示 Windows 组件向导的“正在配置组件”页面，该页面随后将自动关闭。不能单击该页上的“上一步”或“下一步”。在“删除了邮件服务器角色”页面上，单击“完成”。

后续步骤：完成其他任务

完成“配置您的服务器向导”并创建邮箱后，计算机就可以用作邮件服务器了。至此，您已经完成了以下任务：

  • 安装了 POP3 服务和 SMTP 服务。
  • 配置了 POP3 服务以使用身份验证方法。
  • 创建了电子邮件域。
  • 创建了邮箱。

“配置您的服务器向导”会自动安装 POP3 服务 MMC 管理单元，以便您用来管理您的邮件服务器。 XOX

下表列出了您可能会在邮件服务器上执行的其他任务。

任务 | 任务目的 | 参考
为用户提供用以配置电子邮件客户端以使用邮件服务器的过程。 | 要连接到邮件服务器，必须专门针对邮件服务器配置用户的电子邮件客户端。 | 配置电子邮件客户端
实施磁盘配额。 | 磁盘配额可确保邮件存储不使用过多的或非预期量的磁盘空间，否则，可能影响运行 POP3 服务的服务器的性能。您必须具有 NTFS 分区才能实施磁盘配额。采用 NTFS 分区可以实现更高的目录和文件夹安全性，从而更好地保护本地硬盘上存储的电子邮件。 | 配置 POP3 服务的磁盘配额
配置您的邮件服务器以要求安全的电子邮件客户端身份验证。 | 对于 Active Directory 集成的身份验证和本地 Windows 帐户身份验证来说，POP3 服务支持安全密码验证 (SPA)。“安全密码验证”要求所有的电子邮件客户端都使用安全的身份验证来传输用户名和密码。“安全密码验证”比明文这一默认设置更安全，因此，建议采用这种验证方法。必须在运行电子邮件服务的服务器以及将连接到邮件服务器的每个电子邮件客户端上配置“安全密码验证”。 | 将邮件服务器配置为要求安全密码身份验证；为实现安全密码身份验证配置 Outlook Express


终端服务器角色：配置终端服务器

通过安装能提供集中式应用程序部署的终端服务器组件，将该计算机配置为终端服务器。

通过使用终端服务器，远程位置的用户可以运行程序、保存文件，以及使用网络资源，就好像这些资源是安装在用户自己的计算机上一样。通过在终端服务器上安装程序，可以确保所有用户都使用同样版本的程序。如果您计划使用该计算机允许多个用户同时从单个安装点访问某个程序，就要将该计算机配置为终端服务器。

但是，如果您计划将该计算机用于 Windows Server 2003 操作系统上的远程管理，就不需要安装终端服务器。您可以改用“管理远程桌面”（以前称为“远程管理模式中的终端服务”），默认情况下安装在运行一个 Windows Server 2003 操作系统的计算机上。启用远程连接后，“管理远程桌面”允许您从 LAN、WAN 或拨号连接上的任一客户端远程管理服务器。在不需要终端服务器授权的情况下，同时可以访问最多两个远程会话，以及控制台会话。有关“管理远程桌面”的详细信息，请参阅使用终端服务进行远程管理。

本主题说明如何使用“配置您的服务器向导”安装和配置终端服务器。完成“配置您的服务器向导”之后，必须执行以下额外步骤才能拥有基本终端服务器。

  • 确认 Internet Explorer 增强的安全配置设置。
  • 配置终端服务器许可证服务器。对于小型部署，可以在一台计算机上同时安装终端服务器和终端服务器授权服务。但对于大型部署，建议在单独的服务器上安装终端服务器授权。

    • 要点

    • 该步骤是必需的。如果您不安装“终端服务器授权”，终端服务器就会在评估期结束时停止接受来自非授权客户端的连接，评估期是指从第一次客户登录后的 120 天。
  • 在终端服务器许可证服务器上安装客户端访问许可证 (CAL)。
  • 在终端服务器上安装程序。
  • 将最新版本的“远程桌面连接”分发到运行用于 Windows 的“远程桌面连接”早期版本的客户端上。
  • 指定哪些用户具有与终端服务器连接的权限。

完成“配置您的服务器向导”和这些额外的必需任务后，您就拥有了一台基本终端服务器。

本主题包括：

开始之前

配置终端服务器

后续步骤：完成其他任务

开始之前

将计算机配置为终端服务器之前，请确认：

  • 是否正确配置了操作系统。在 Windows Server 2003 家族中，终端服务器依赖于操作系统及其服务的适当配置。如果您拥有的是全新安装 Windows Server 2003 的操作系统，则可以使用默认服务设置。没有必要执行进一步的操作。如果您的 Windows Server 2003 操作系统是通过升级安装的，或者如果您要确认是否以正确配置了服务已获得最佳性能与安全性，请使用默认服务设置中的表来验证您的服务设置。
  • 该计算机是网络上或域中的服务器，但不是域控制器。在域控制器上安装终端服务器会影响性能，因为需要额外的内存、网络流量和处理器时间来执行域中域控制器的任务。
  • 计算机要满足处理器和内存的需要，才能支持由于不同用户登录而发生的多个并发会话。终端服务器需要最少 128 MB RAM，再加上用于每个用户额外的 RAM 以支持在服务器上运行每个用户的程序。建议为每个轻量级用户额外提供 10 MB RAM，这些用户通常一次运行一个程序；为每个重量级用户额外提供最多 21 MB RAM，这些用户通常同时运行三个或更多程序。此外，如果您计划在终端服务器上安装 16 位应用程序，就要知道它们在 32 位环境（如 Windows Server 2003 操作系统）下运行时会消耗额外的资源。
  • 计算机上没安装任何程序。在安装您希望用户访问的程序之前，应先添加终端服务器角色。如果计算机上已经安装了程序，您必须重新安装它们以确保它们在终端服务器环境中正常工作。
  • 没有用户能远程登录到该计算机上。只有在您安装了程序，对其安装进行了测试，并为使程序在多会话环境中工作而进行必要的调整之后，才允许用户访问终端服务器。有关暂时禁用终端服务连接的信息，请参阅禁用终端服务连接。
  • 所有现有的磁盘卷都使用 NTFS 文件系统。FAT32 卷既不提供用户在多会话环境中所必需的安全性级别，也不提供设置文件权限的能力。

配置终端服务器

要配置终端服务器，请通过执行以下任一操作来启动“配置您的服务器向导”：

  • 从“管理服务器”中，单击“添加或删除角色”。默认情况下，在您登录时将自动启动“管理您的服务器”。XOX
  • XOX

在“服务器角色”页面上，单击“终端服务器”，然后单击“下一步”。

该部分包括：

选择摘要

完成“配置您的服务器向导”

确认 Internet Explorer 增强的安全配置设置

配置终端服务器许可证服务器

在终端服务器许可证服务器上安装客户端访问许可证

在终端服务器上安装程序

部署客户端软件

为用户提供访问终端服务器的权限

删除终端服务器角色

选择摘要

在“选择摘要”页面上，查看和确认已经选择的选项。如果在“服务器角色”页面上选择“终端服务器”，将出现以下内容：

  • 安装终端服务器

要应用“选择摘要”页面上显示的选择，请单击“下一步”。出现以下消息：“在此过程中，“配置您的服务器向导”将会重新启动您的计算机。继续此过程之前，请先关闭所有打开的程序。”如果您需要关闭打开的程序，并且希望同时取消终端服务器角色的配置，必须立即单击“取消”。单击“取消”后，“配置您的服务器向导”将显示“无法完成”页面。要关闭“配置您的服务器向导”，请单击“完成”。否则，如果您单击“确定”，“配置您的服务器向导”就会开始配置过程。

接下来，“配置您的服务器向导”会显示消息“正在安装终端服务器”。显示“Windows 组件向导”的“正在配置组件”页面，然后又自动关闭。不能单击该页上的“上一步”或“下一步”。然后，“配置您的服务器向导”会关闭并重新启动计算机，以接受此配置更改从而使计算机成为终端服务器。

重新启动过程中会出现一个对话框以显示进度消息，例如，“Windows 正在启动”与“正在准备网络连接”。根据网络规模大小的不同，准备网络连接可能需要一些时间。当出现“欢迎使用 Windows”对话框时，请按下 Ctrl+Alt+Del。在“登录到 Windows”对话框中的“密码”框中，键入您的密码。要完成此过程，请等待“配置您的服务器向导”出现在屏幕上。

完成“配置您的服务器向导”

服务器重新启动后，“配置您的服务器向导”将显示“此服务器现在是终端服务器”页面。要检查由“配置您的服务器向导”对服务器所做的所有更改，或者要确保新的角色已成功安装，请单击“‘配置您的服务器’日志”。“配置您的服务器向导”日志位于 systemroot\Debug\Configure Your Server.log。要关闭“配置您的服务器向导”，请单击“完成”。

接着，您必须完成下面的步骤，服务器才能充当基本终端服务器：

  • 确认 Internet Explorer 增强的安全配置设置。
  • 配置终端服务器许可证服务器。
  • 在终端服务器许可证服务器上安装客户端访问许可证 (CAL)。
  • 在终端服务器上安装程序。
  • 将“远程桌面连接”的 .msi 文件部署到未运行 XOX 或 Windows Server 2003 操作系统的客户端上。
  • 为用户提供访问终端服务器的权限。

一个单独的窗口显示清单，以提供有关这些额外要求的信息。此文档中也包含同样的信息。

要运行终端服务器，就需要配置终端服务器授权。对于小型部署，可以在与终端服务器相同的计算机上配置终端服务器授权。对于大型部署，应当在单独的服务器上安装终端服务器授权。如果已经安装终端服务器许可证服务器，可以跳过配置终端服务器许可证服务器和安装 CAL 的步骤，并开始在终端服务器上安装程序。否则，如果“管理您的服务器”页面显示一条消息，表明未找到终端服务器许可证服务器，则您必须先配置终端服务器许可证服务器，才能使用终端服务器。

确认 Internet Explorer 增强的安全配置设置

在完成“配置您的服务器向导”并安装了终端服务器之后，您就可以配置 Internet Explorer 增强的安全配置设置。

激活这些设置时，Internet Explorer 会将以下安全设置应用到以管理员身份登录的用户：

  • 对于 Internet 和本地 Intranet 安全区域的高安全级设置
  • 对于受信任站点区域的中安全级设置

通过将高安全级设置应用到 Internet 和本地 Intranet 安全区域，您可以对这些区域中的 HTML 内容禁用脚本、Microsoft ActiveX® 控件以及 Microsoft 虚拟机 (Microsoft VM)。您也可以禁止用户下载这些区域中的文件。

通过将中安全级设置应用到受信任的站点区域，您可以设置标准浏览功能。如果在应用这些设置后，您将某些站点用于执行管理员无法访问的管理任务和基于 Web 的应用程序时，则可将这些站点地址添加到受信任的站点区域的站点列表中。

要查看或更改 Internet Explorer 增强的安全配置设置，请在“管理您的服务器”中，单击“Internet Explorer 增强的安全配置”。

在 Windows Server 2003 家族中，您可以为所有用户的 Internet Explorer 执行增强的安全设置，从而减少某些网站对服务器构成的安全隐患。有关详细信息，请参阅 Internet Explorer 增强的安全配置。

配置终端服务器许可证服务器

在已为其配置终端服务器角色的同一台计算机上（对于小型部署）或另一台计算机上（建议对于大型部署）配置终端服务器许可证服务器。终端服务器许可证服务器管理终端服务客户端连接所需的许可证。只需激活终端服务器许可证服务器一次，终端服务器许可证服务器即可成为终端服务器客户许可证的储存库。只有在注册过程完成后，您的终端服务器许可证服务器才能够颁发客户端所需的临时许可证。

要点

  • 该步骤是必需的。如果您不配置终端服务器许可证服务器，终端服务器就会在评估期结束时停止接受来自非授权客户端的连接，评估期是指从第一次客户登录后的 120 天。

要激活终端服务器许可证服务器，最容易且最快速的方法是使用“自动”方法。要使用该方法，运行终端服务许可证服务的计算机必须与 Internet 直接连接。有关未与 Internet 连接的计算机的激活方法的信息，请参阅使用 Web 浏览器激活终端服务器许可证服务器和使用电话激活终端服务器许可证服务器。

下表显示了使用“自动”方法配置和激活终端服务器许可证服务器必须执行的步骤。

任务 注释
安装终端服务器授权服务。 在“控制面板”中打开 添加或删除程序，然后单击“添加/删除 Windows 组件”。在“Windows 组件向导”中，选择“终端服务器授权”复选框，然后单击“下一步”。如果网络中包括多个域，或者如果您正在成员服务器上安装终端服务器授权服务，请选择“您的整个企业”。如果您想对每个域都单独维护一个终端服务器许可证服务器，或者如果您的网络中包含工作组或 Windows NT 4.0 域，请选择“您的域或工作组”。如果您想更改许可证服务器数据库的位置，请指定新的位置，然后单击“下一步”。“正在配置组件”页面显示配置更改的进度。在“完成 Windows 组件向导”页面上，单击“完成”，然后单击“关闭”。

注意

  • XOX
激活终端服务器许可证服务器。 打开 终端服务器授权，右键单击您要激活的终端服务器许可证服务器，单击“激活服务器”。将启动“终端服务器许可证服务器激活向导”。在“连接方法”页面上的“激活方法”下，单击“自动连接”，然后单击“下一步”。在“公司信息”页面上，提供以下必需信息：
  • 名字
  • 姓氏
  • 公司名称
  • 国家（地区）
确认您键入的信息是正确的，然后单击“下一步”。在“公司信息”页面上，可以提供以下可选信息：
  • 电子邮件地址
  • 组织单位
  • 公司地址
  • 城市
  • 州或省
  • 邮政编码
确认您键入的信息是正确的，然后单击“下一步”。在“正在完成终端服务器许可证服务器激活向导”页上的“状态”下面，会显示以下消息："“已成功激活许可证服务器。”如果您想立即安装客户端许可证，请单击“下一步”。如果您想推迟客户端许可证的安装，请清除“立即启动终端服务器客户端授权向导”复选框，然后单击“完成”。

注意

  • XOX

在终端服务器许可证服务器上安装客户端访问许可证

激活终端服务器许可证服务器后，下一步是在终端服务器许可证服务器上安装客户端访问许可证 (CAL)。

要点

  • 终端服务器许可证服务器可以颁发临时许可证，以允许客户端在评估期内使用终端服务器，评估期是指从第一次客户登录后的 120 天。如果不在终端服务器许可证服务器上安装 CAL，非授权的客户端在评估期结束后就无法连接到终端服务器。

CAL 是每个客户端本地存储的数字签名证书。所有 CAL 都安装在终端服务器许可证服务器上。当客户端第一次尝试登录到终端服务器时，终端服务器能识别出该客户端是否颁发有 CAL，并找到终端服务器许可证服务器以便为该客户端颁发新的许可证。有关特定许可证要求的详细信息，请参阅 Microsoft 网站。(http://www.microsoft.com/)

在安装 CAL 之前，您必须准备好许可协议号码，知道购买它们所使用的方法。

要在终端服务器许可证服务器上安装 CAL 最容易且最快速的方法是使用“自动”方法。要使用该方法，运行终端服务授权服务的计算机必须与 Internet 直接连接。有关为没有与 Internet 连接的计算机安装 CAL 的信息，请参阅使用 Web 浏览器安装客户端许可证密钥包和使用电话安装客户端许可证密钥包。

下表显示了使用“自动”方法在终端服务器许可证服务器上安装 CAL 必须执行的步骤。

任务 注释
在终端服务器许可证服务器上安装 CAL。 在终端服务器许可证服务器上，打开 终端服务器授权。确认将终端服务器许可证服务器的安装方法设置为“自动”，方法是通过右键单击要为其安装 CAL 的终端服务器许可证服务器，然后单击“属性”。如果需要，请在“安装方法”选项卡上，将安装方法更改为“自动连接”，然后单击“确定”。

在“终端服务器授权”控制台树中，右键单击要在其上安装 CAL 的终端服务器许可证服务器，单击“安装许可证”，然后单击“下一步”。将启动“终端服务器 CAL 安装向导”。在“授权计划”页面上，选择您购买许可证所遵循的许可证计划，然后单击“下一步”。在“许可证代码”页面上，为您所购买的每个许可证键入许可证代码，每次输入完后都单击“添加”。在键入所有许可证代码之后，单击“下一步”。“正在完成终端服务器 CAL 安装向导”页面显示一条消息，表明 CAL 已安装成功。要关闭向导，请单击“完成”。

注意

  • XOX

在终端服务器上安装程序

在此阶段，您已经完成了以下任务：

  • 完成“配置您的服务器向导”，并在服务器上配置终端服务器角色。
  • 安装终端服务器授权。
  • 激活终端服务器许可证服务器。
  • 在终端服务器许可证服务器上安装 CAL。

现在，您可以在终端服务器上安装程序了。“控制面板”中的“添加或删除程序”是程序安装的首选方法，只要可能，就应使用该方法。本部分说明如何使用“添加或删除程序”在终端服务器上安装程序。

还有其他的程序安装方法，例如 change user 命令、Windows 安装服务程序包（.msi 文件）和“组策略软件安装”。有关 change user 命令的详细信息，请参阅使用 change user 命令安装程序。有关使用 Windows 安装服务的详细信息，请参阅指派和发布的程序。有关组策略的详细信息，请参阅组策略。

为改进性能和减少网络流量，请在终端服务器的本地驱动器上而不是文件服务器上安装程序。确保有足够的空间在 NTFS 文件系统驱动器上而不是 FAT32 驱动器上安装程序。您可以在 NTFS 驱动器上设置文件权限，而在 FAT32 驱动器上无法做到。

如果您要安装已发布程序，就必须使用另一种安装方法，例如“组策略软件安装”。

考虑到性能和安全性，应尽可能使用 32 位程序。大多数 32 位程序都使用注册表读取和写入程序设置，而且只需要写入特定的注册表值。运行 16 位程序会使处理器支持的用户数量减少 40%，并使每个用户需要的内存增加 50%。另外，某些 16 位程序必须能够写入到存储程序的 .ini 文件所在的目录。

RAM 和 CPU 的要求随着运行会话数量的变化几乎是线性变化的。要减少 RAM 和 CPU 的要求，不妨考虑限制用户或组对某些程序类型的访问、禁用不必要的程序功能或者在单独的终端服务器上安装程序。

某些程序在多会话环境中存在已知的安装问题。有关需要安装脚本以便在多会话环境中正常工作的程序的信息，请参阅 Microsoft 网站上的“Optimizing Applications for Windows 2000 Terminal Services and Windows NT Server 4.0, Terminal Server Edition”（优化适用于 Windows 2000 Terminal Services 和 Windows NT Server 4.0, Terminal Server Edition 的应用程序）。(http://www.microsoft.com/)

应用程序兼容性注意事项

应该从终端服务器的控制台会话安装程序。可以从远程控制台会话安装程序，但这不是安装程序的首选方法。

有些程序要求应用程序兼容性脚本在程序安装之后运行。这些脚本存储在终端服务器上的 systemroot\Application Compatibility Scripts\Install 目录中。

应该了解终端服务器运行的安全模式的含义。有两种安全模式：

  • “完整安全模式”提供最安全的环境，以便用户连接到终端服务器。要在此模式下运行，必须将应用程序编写为在一般用户的安全上下文中运行。对于 Windows Server 2003 操作系统和 Windows 2000，“完整安全模式”为默认设置。
  • “宽松安全模式”允许您运行在更为严格的“完整安全模式”下可能无法工作的程序。但是，在“宽松安全模式”（也称为 Windows NT 4.0/Terminal Server Edition 权限兼容模式）下，系统上的任何用户都可以在系统的多个位置更改文件和注册表设置，尽管其他用户的数据文件可能不可见。恶意用户可能会通过使用同名且有害的程序替换已知可信的程序，来利用这种情况。如果终端服务器上的操作系统是使用“升级”方法安装的，则可以将此安全模式设置为“宽松安全模式”。如果担心此设置的安全性，则应选择“完整安全模式”，在该模式下对应用程序进行测试，只有在测试结果表明需要更改安全模式时才进行更改。

下表显示了使用“添加或删除程序”在终端服务器上安装程序必须执行的步骤。

任务 | 注释
确保没有用户登录到终端服务器上。 | 向所有登录到终端服务器上的用户发送消息。程序安装通常要求重新启动计算机，因此，用户的会话将会被断开。在程序安装和测试之前，不应允许用户访问终端服务器。
暂时禁用终端服务连接。 | 右键单击“我的电脑”，单击“属性”，再单击“远程”选项卡，然后清除“允许用户远程连接到您的计算机”复选框。
指定“完整安全模式”作为安全模式。 打开 终端服务配置。在控制台树中，单击“服务器设置”，右键单击“权限兼容性”，然后单击“属性”。在“权限兼容性”对话框中，单击“完整安全模式”，然后单击“确定”。

注意

  • XOX
从光盘或软盘安装程序。 确保您以 Administrators 组成员的身份登录到终端服务器。在“控制面板”中打开 添加或删除程序，然后单击“添加新程序”。单击“光盘或软盘”。将光盘或软盘插入适当的驱动器，然后单击“下一步”。确认在“运行安装程序”页面上的“打开”框中正确指定了安装文件，然后单击“完成”。按照程序的安装向导中的说明操作。程序安装后，编辑和运行任何适用的脚本以调整多会话环境的程序。

注意

  • XOX
对安装进行测试。

确保事件记录是通过在“管理工具”中打开“服务”而启用的。创建一个临时用户帐户，以模仿用户的设置或要访问程序的用户，并且使用该帐户登录到终端服务器。启动程序并按步骤执行一些基本任务。然后，使用事件查看器确定哪些文件或目录需要写访问权限，以及哪些注册表项需要该用户的读访问权限以便进行正确的操作。请注意，此过程找到的可能不是应用程序在所有用户方案中需要访问的所有文件、目录和注册表项。确保满足所有访问需求的唯一方法是手动执行任务。

某些程序允许用户启动其他程序。例如，Microsoft Access 有一个可用来启动其他 Microsoft Office 程序的工具栏。如果您希望用户在登录到终端服务器时只有访问指定程序的权限，就应从您在终端服务器上安装的程序中禁用工具栏访问权限。

注意

  • XOX
为多会话使用调整应用程序。 | 使用文本编辑器（比如“记事本”）修改脚本，然后运行这些脚本以调整需要它的程序。要获得脚本，请参阅 Microsoft 网站上的“Optimizing Applications for Windows 2000 Terminal Services and Windows NT Server 4.0, Terminal Server Edition”（优化适用于 Windows 2000 Terminal Services 和 Windows NT Server 4.0, Terminal Server Edition 的应用程序）。(http://www.microsoft.com/)
运行应用程序兼容性脚本。 | 导航到终端服务器上的 systemroot\Application Compatibility Scripts\Install 目录，为需要脚本的程序运行脚本。
在终端服务器上启用远程连接。 右键单击“我的电脑”，单击“属性”，再单击“远程”选项卡，然后选中“允许用户远程连接到您的计算机”复选框。

注意

  • 根据您的桌面设置，“我的电脑”可能未出现在桌面上。XOX

部署客户端软件

“远程桌面连接”（以前称为“终端服务客户端”）自动安装在运行 XOX 和 Windows Server 2003 操作系统的计算机上。考虑到性能和安全性，运行 Microsoft Windows 早期版本（包括 Windows 2000 Server、Windows 2000 Professional、Windows NT 4.0、Windows 98 和 Windows 95）的计算机应该安装最新版本的“远程桌面连接”。

部署客户端软件的方法有多种：

  • 共享 Msrdpcli.msi 文件，使用 Microsoft IntelliMirror 将其分发到运行 Windows 2000 的工作站上。
  • 直接从 Microsoft 网站下载“远程桌面连接”。(http://www.microsoft.com/downloads)
  • 将该 .msi 文件放在位于网络上某台服务器上的共享文件夹中。

本主题说明如何从位于网络上某台服务器上的共享文件夹中安装客户端软件。

在部署客户端软件之前，首先决定您希望安装的软件将用于单个用户还是使用客户端计算机的任何人。在部署过程中将要进行这种选择。

下表显示了将最新版本的“远程桌面连接”部署到运行早期 Windows 或“远程桌面连接”的客户端上必须执行的步骤。

任务 | 注释
共享客户端安装文件夹 在运行 Windows Server 2003 操作系统的计算机上，打开 Windows 资源管理器。导航到 systemroot\System32\Clients\Tsclient\win32 文件夹，右键单击 win32 文件夹，单击“共享和安全”。在“共享”选项卡上，单击“共享该文件夹”，然后单击“确定”。

注意

  • XOX
安装远程桌面连接。 | 在客户端计算机上，依次单击“开始”、“运行”，然后在“打开”中键入 \\ServerName\win32，其中，ServerName 是共享文件夹所在的计算机的名称。双击 msrdpcli.msi 文件以启动“远程桌面连接”的 InstallShield 向导，然后单击“下一步”。阅读“许可协议”，单击“我接受许可协议中的条款”，然后单击“下一步”。在“客户信息”页面中键入您的姓名和组织，单击“任何使用这台计算机的人（所有用户）”，然后单击“下一步”。在“可以安装程序了”页面上，单击“后退”检查或更改安装设置，或者单击“安装”开始安装。要完成安装，请单击“完成”。

为用户提供访问终端服务器的权限

默认情况下，在 Windows Server 2003 操作系统上，Administrators 和 Remote Desktop Users 组的成员可以使用终端服务连接与远程计算机连接。Remote Desktop Users 组在默认情况下未被导入，因此，您必须决定哪些用户和组有权限进行远程登录，然后手动将他们添加到该组中。

要点

  • 必须使用 Remote Desktop Users 组向选定用户和组授予必要的权限以便对远程计算机进行终端服务连接。
  • Remote Desktop Users 组中的成员身份并不将用户放入本地 Users 组中。根据本地 Users 组的内容，可能还需要将用户添加到该组中。

在为用户提供访问终端服务器的权限之前，必须：

  • 检查 Administrators 组的成员身份，确保您知道谁有访问终端服务器的权限。
  • 决定哪些用户具有访问终端服务器的权限。
  • 决定还必须将哪些用户添加到本地 Users 组中。

下表显示了为用户提供访问终端服务器的权限必须执行的步骤。

任务 注释
将用户添加至 Remote Desktop Users 组。 打开 计算机管理（本地），并单击控制台树中的“本地用户和组”。在详细信息窗格中，双击“组”文件夹，双击 Remote Desktop Users，然后单击“添加”。在“选择用户”对话框中，单击“位置”指定搜索位置。要指定希望搜索的对象类型，请单击“对象类型”。在这种情况下，请选择您想寻找的用户或组。在“输入对象名称来选择（示例）”框中，键入要添加的名称，然后单击“检查名称”。找到名称后，单击“确定”。

注意

  • XOX
如果用户还不是成员，请将他们添加到本地“用户”组中。 打开 计算机管理（本地），并单击控制台树中的“本地用户和组”。在详细信息窗格中，双击“组”文件夹，双击“用户”，然后单击“添加”。在“选择用户”对话框中，单击“位置”指定搜索位置。要指定希望搜索的对象类型，请单击“对象类型”。在这种情况下，请选择您想寻找的用户或组。在“输入对象名称来选择（示例）”框中，键入要添加的名称，然后单击“检查名称”。找到名称后，单击“确定”。

注意

  • XOX

删除终端服务器角色

如果需要将服务器重新配置为另外一个角色，则可删除现有服务器角色。如果您删除终端服务器角色，就需要重新安装所有软件，检查并更新您已更改默认值的文件或注册表项，检查并更新用于控制在终端服务器上运行的程序的软件限制策略。

要删除终端服务器角色，请通过执行以下任一操作来重新启动“配置您的服务器向导”：

  • 从“管理服务器”中，单击“添加或删除角色”。默认情况下，在您登录时将自动启动“管理服务器”。XOX
  • XOX

在“服务器角色”页面上，单击“终端服务器”，然后单击“下一步”。在“角色删除确认”页面上，检查“总结”下所列的项目，选中“删除终端服务器角色”复选框，然后单击“下一步”。出现以下消息：“在此过程中，“配置您的服务器向导”将会重新启动您的计算机。继续此过程之前，请先关闭所有打开的程序。”如果您需要关闭打开的程序，并且希望同时取消终端服务器角色的删除，必须立即单击“取消”。当您单击“取消”时，“配置您的服务器向导”将显示“无法完成”页面。要关闭“配置您的服务器向导”，请单击“完成”。否则，如果您单击“确定”，“配置您的服务器向导”就会开始删除过程。

接下来，“配置您的服务器向导”会显示消息“正在删除终端服务器”。将会显示“Windows 组件向导”的“正在配置组件”，并显示一条关于对计算机做配置更改的消息，然后关闭。“配置您的服务器向导”会关闭并重新启动计算机，以接受删除该角色的配置更改。

重新启动过程中会出现一个对话框以显示进度消息，例如，“Windows 正在启动”与“正在准备网络连接”。根据网络规模大小的不同，准备网络连接可能会需要一些时间。当出现“欢迎使用 Windows”对话框时，请按下 Ctrl+Alt+Del。在“登录到 Windows”对话框中的“密码”框中，键入您的密码。要完成此过程，请等待“配置您的服务器向导”显示在屏幕上。在“删除了终端服务器角色”页面上，单击“配置服务器日志”以查看更改记录，然后单击“完成”。

删除终端服务器角色后，应该：

  • 重新安装所有软件。
  • 检查默认值已更改的所有文件或注册表权限，如果必要，进行更改。
  • 检查用于控制在终端服务器上运行的程序的软件限制策略，如果必要，进行更改。

后续步骤：完成其他任务

完成“配置您的服务器向导”和关联任务后，计算机就可以用作基本终端服务器了，它可以接受来自远程客户端的多个连接。至此，您已经完成了以下任务：

  • 运行“配置您的服务器向导”。
  • 激活终端服务器许可证服务器。
  • 在终端服务器许可证服务器上安装 CAL。
  • 在终端服务器上安装应用程序。
  • 将“远程桌面连接”的 .msi 文件部署到未运行 XOX 或 Windows Server 2003 操作系统的客户端上。
  • 配置允许用户访问终端服务器的用户权限。

下表列出了在终端服务器上可能要执行的一些其他任务。

任务 | 任务目的 | 参考
管理终端服务连接。 | 启用、禁用、重命名或删除连接。 | 管理终端服务连接
指定连接权限。 | 将终端服务器访问权限只授予选定的用户和组。 确定哪些用户和组被授权可以在终端服务器上执行给定任务。 | 管理终端服务用户；管理连接权限
使用“组策略”或“终端服务配置”配置终端服务器设置。 | 为各个用户配置诸如“活动桌面”、临时文件夹和会话限制等设置。 | 配置服务器设置
部署远程桌面 Web 连接。 | 允许用户在 Internet Explorer 内创建远程桌面连接，即使远程桌面连接客户程序未安装在他们的计算机上。 | 关于远程桌面 Web 连接
控制在终端服务器会话中运行的程序。 | 保护终端服务器和用户免受未知或可能恶意的程序的攻击。 | Microsoft 网站上的“Using Software Restriction Policies in XOX and the Windows Server 2003 family to Protect Against Unauthorized Software”（在 XOX 和 Windows Server 2003 家族产品中使用软件限制策略以免受非授权软件的攻击）。(http://www.microsoft.com/)
配置“会话目录”设置。 | 确保用户以透明方式重新连接到宿主其断开的终端服务器会话的原始服务器上。该任务应用于作为终端服务器群集一部分的终端服务器，要求运行 XOX 或 XOX 的服务器在网络上可见，并且启用会话目录服务。该会话目录服务器不应是在其中配置终端服务器角色的服务器。 | 负载平衡和终端服务器


远程访问/VPN 服务器角色：配置远程访问/VPN 服务器

可以将服务器配置为允许远程用户通过拨号连接或虚拟专用网络 (VPN) 连接访问专用网络上的资源。这类服务器称为远程访问/VPN 服务器。远程访问/VPN 服务器还可以提供网络地址转换 (NAT)。通过 NAT，您专用网络上的计算机可以共享到 Internet 的单个连接。通过 VPN 和 NAT，您的 VPN 客户端可以确定专用网络上计算机的 IP 地址，但 Internet 上的其他计算机则不能。

本主题说明使用“管理您的服务器”、“配置您的服务器向导”和“路由和远程访问服务器安装向导”配置远程访问/VPN 服务器的基本步骤。完成基本远程访问/VPN 服务器的配置后，可根据使用远程访问/VPN 服务器的方式完成其他配置任务。

本主题包含：

开始之前

配置远程访问/VPN 服务器

下一步：完成其他任务

开始之前

将服务器配置为远程访问/VPN 服务器之前，请验证是否：

  • 正确配置了操作系统。在 Windows Server 2003 家族中，远程访问/VPN 取决于操作系统及其服务的适当配置。如果您的 Windows Server 2003 家族产品采用的是全新安装，则可以使用默认服务设置。没有必要执行进一步的操作。如果您采用的是升级到 Windows Server 2003 家族产品，或者如果您要确认是否为最佳性能和安全性正确配置了服务，则可通过将它们与服务的默认设置中的表格进行比较以验证服务设置。
  • 为满足网络所需要的最佳安全性正确配置了服务器。由于您的远程访问/VPN 服务器将与专用网络、Internet 和远程客户端连接，因此，必须确保服务器是安全的。专用网络的安全性取决于远程访问/VPN 服务器的安全性。详细信息，请参阅远程访问的安全信息。
  • 该计算机有两个网络接口，一个接口连接到 Internet，另一个连接到专用网络。与 Internet 的连接必须是专用连接，有足够的带宽供 VPN 用户连接到专用网络，并且专用网络上的用户可以连接到 Internet。与专用网络上计算机的连接必须是通过硬件设备实现的，如网络适配器。
  • 已为网络接口安装了所有需要的网络协议。详细信息，请参阅网络接口。

下表列出了在配置远程访问/VPN 服务器之前需要了解的信息。

在添加远程访问/VPN 服务器角色之前 | 注释
确定要连接到 Internet 的网络接口以及连接到专用网络的网络接口。 | 在配置期间，会要求您选择连接到 Internet 的网络接口。如果指定的接口不正确，则远程访问/VPN 服务器将无法正常操作。
确定远程客户端是从专用网络上的动态主机配置协议 (DHCP) 服务器接收 IP 地址，还是从要配置的远程访问/VPN 服务器接收 IP 地址。 | 如果您在专用网络上有 DHCP 服务器，则远程访问/VPN 服务器就可以从 DHCP 服务器租用 10 个地址，并将这些地址指派给远程客户端。如果专用网络上没有 DHCP 服务器，则远程访问/VPN 服务器可自动生成 IP 地址并将它们指派给远程客户端。如果希望远程访问/VPN 服务器从指定的范围指派 IP 地址，则必须确定该范围。
确定来自 VPN 客户端的连接请求是由远程身份验证拨号用户服务 (RADIUS) 服务器进行身份验证，还是由您要配置的远程访问/VPN 服务器进行验证。 | 如果计划在专用网络上安装多个远程访问/VPN 服务器、无线访问点或其他 RADIUS 客户端，则添加 RADIUS 服务器非常有用。详细信息，请参阅 Internet 验证服务。
确定 VPN 客户端是否能向专用网络上的 DHCP 服务器发送 DHCP 消息。 | 如果 DHCP 服务器和远程访问/VPN 服务器在同一个子网上，则来自 VPN 客户端的 DHCP 消息在 VPN 连接建立之后将可到达 DHCP 服务器。如果 DHCP 服务器和远程访问/VPN 服务器不在同一个子网上，则请确保子网之间的路由器能够在客户端和服务器之间中继 DHCP 消息。如果路由器正在运行 Windows Server 2003 操作系统，则可以在路由器上配置 DHCP 中继代理服务，以在子网之间转发 DHCP 消息。
确认所有用户都有为拨号访问而配置的用户帐户。 | 在用户能够与网络连接之前，他们必须在远程访问/VPN 服务器上或 Active Directory 中具有用户帐户。独立服务器或域控制器上的每个用户帐户都包含用于确定该用户能否连接的属性。在独立服务器上，可以通过右键单击“本地用户和组”中的用户帐户并单击“属性”来设置这些属性。在域控制器上，可以通过右键单击“Active Directory 用户和计算机”控制台中的用户帐户并单击“属性”来设置这些属性。详细信息，请参阅用户帐户的拨号属性和 Active Directory 用户和计算机。

配置远程访问/VPN 服务器

要配置远程访问/VPN 服务器，请通过完成下面的任一操作来启动“配置您的服务器向导”：

  • 从“管理您的服务器”中，单击“添加或删除角色”。默认情况下，在您登录时将自动启动“管理您的服务器”。
  • XOX

在“配置选项”页面上，单击“自定义配置”，然后单击“下一步”。在“服务器角色”页面上，单击“远程访问/VPN 服务器”，然后单击“下一步”。

本节说明在“路由和远程访问服务器安装向导”中配置远程访问/VPN 服务器的步骤，这里的远程访问/VPN 服务器既非 Active Directory 域的一部分，也不属于带 DNS 或 DHCP 服务器的网络。如果执行这些步骤，则将远程访问/VPN 服务器配置为向远程访问客户端提供拨号和 VPN 访问、为专用网络上的计算机提供 NAT、为远程访问客户端生成和指派 IP 地址，并可在本地对连接请求进行身份验证。

这部分包含：

选择摘要

使用“路由和远程访问服务器安装向导”

完成“配置您的服务器向导”

完成“路由和远程访问”中的配置

删除远程访问/VPN 服务器角色

选择摘要

在“选择摘要”页面上，可查看和确认已经选择的选项。如果在“服务器角色”页面上单击了“远程访问/VPN 服务器”，则会出现下行：

  • 运行“路由和远程访问服务器安装向导”来设置路由和 VPN

要应用“选择摘要”页面上显示的选择，请单击“下一步”。“配置您的服务器向导”会启动“路由和远程访问服务器安装向导”。如果取消“路由和远程访问服务器安装向导”，则远程访问/VPN 服务器将不会被配置，且路由和远程访问服务将不会启动，“配置您的服务器向导”将显示“无法完成”页面。

完成“路由和远程访问服务器安装向导”和“配置您的服务器向导”后，路由和远程访问服务会自动启动。

使用“路由和远程访问服务器安装向导”

选择远程访问/VPN 角色并通过单击“配置您的服务器向导”中的“下一步”确认选择摘要后，“路由和远程访问服务器安装向导”就会启动。

本节说明在“路由和远程访问服务器安装向导”中的以下步骤：

配置

VPN 连接

IP 地址指派

名称和地址转换服务

地址指派范围

管理多个远程访问服务器

完成“路由和远程访问服务器安装向导”

配置

在“配置”页面上，单击“虚拟专用网络 (VPN) 访问和 NAT”，再单击“下一步”。

要点

  • 本文档只对“虚拟专用网络 (VPN) 访问和 NAT”配置进行说明。如果决定选择其他配置，则请先查看路由和远程访问的文档，然后再完成“路由和远程访问服务器安装向导”。该文档将无法帮助完成除“虚拟专用网络 (VPN) 访问和 NAT”以外的其他任何角色。有关其他配置的详细信息，请参阅远程访问服务器的常规配置。

VPN 连接

在“VPN 连接”页面上，单击将该计算机连接到 Internet 的网络接口。所选的网络接口将配置为接收来自 VPN 客户端的连接。未选择的所有接口将被配置为到专用网络的连接。

在网络接口中，“通过设置基本防火墙来对选择的接口进行保护”复选框将已处于选中状态。不要清除该复选框。该选项配置基本防火墙，它是一种动态数据包筛选服务，有助于保护专用网络，使其避免未经请求的网络通讯。

完成后请单击“下一步”。

IP 地址指派

在“IP 地址指派”页面上，已自动选择“自动”选项。不要更改所做出的选择。该选择会配置服务器以生成 IP 地址并将其指派给远程客户端。

完成后请单击“下一步”。

名称和地址转换服务

在“名称和地址转换服务”页面上，已自动选择“启用基本的名称和地址服务”选项。不要更改此选择。该选择将服务器配置为自动将 IP 地址指派给专用网络上提出请求的任何计算机。此外，该选择还会配置服务器将名称解析请求转发给 Internet 上的 DNS 服务器。

完成后请单击“下一步”。

地址指派范围

“地址指派范围”页面显示定义的地址范围，用于指派给网络上请求地址的计算机。该范围是根据在“VPN 连接”页面上选择的网络适配器的 IP 地址生成的。请仔细查看显示的信息。

完成后请单击“下一步”。

管理多个远程访问服务器

在“管理多个远程访问服务器”页面上，已自动选择“否，使用路由和远程访问来对连接请求进行身份验证”选项。不要更改此选择。该选择将服务器配置为使用 Windows 身份验证、Windows 记帐和本地存储的远程访问策略，在本地对连接请求进行身份验证。

完成后请单击“下一步”。

完成“路由和远程访问服务器安装向导”

在“正在完成路由和远程访问服务器安装向导”页面上，查看摘要信息。请验证是否：

  • 配置了正确的网络接口以提供 VPN 访问。
  • 已为专用网络指派了拨号和 VPN 客户端以进行寻址。
  • 通过使用该远程访问/VPN 服务器的远程访问策略，接受并验证了客户端连接。
  • 为正确的网络接口配置了 NAT。
  • 将为客户端指派正确范围内的 IP 地址。

如果摘要信息有任何不正确之处，请单击“上一步”，然后更改信息。

如果单击“完成”，将无法再次打开“路由和远程访问服务器安装向导”，除非从“配置您的服务器向导”内删除远程访问/VPN 服务器角色，或从“路由和远程访问”管理单元中禁用“路由和远程访问”。

在确保摘要信息正确后，单击“完成”。将出现一条消息，通知您若要支持 DHCP 消息从远程访问客户端中继到 DHCP 服务器，则必须打开远程访问/VPN 服务器上的“路由和远程访问”，并且将“DHCP 中继代理”配置为 DHCP 服务器的 IP 地址。单击“确定”。将会自动启动路由和远程访问服务，“配置您的服务器向导”将会重新显示。

完成“配置您的服务器向导”

在完成“路由和远程访问服务器安装向导”后，“配置您的服务器向导”会显示“此服务器现在是远程访问/VPN 服务器”页面。要查看由“配置您的服务器向导”对服务器所做的所有更改，或者要确保新的角色已成功安装，请单击“‘配置您的服务器向导’日志”。“配置您的服务器向导”日志位于 systemroot\Debug\Configure Your Server.log。要关闭“配置您的服务器向导”，请单击“完成”。

您现在可以在“路由和远程访问”中完成远程访问/VPN 服务器的配置了。

完成“路由和远程访问”中的配置

要打开“路由和远程访问”，请从“管理您的服务器”中单击“管理此远程访问/VPN 服务器”。还可以从“管理工具”中打开“路由和远程访问”。 XOX

在“路由和远程访问”中，双击刚配置的服务器，然后单击“远程访问策略”。默认的远程访问策略设为拒绝每个人的所有访问。在编辑默认策略以允许访问或者用自己的策略替换默认策略之前，用户将无法连接到您的远程访问/VPN 服务器。请通过双击来查看默认策略，然后编辑它以指定希望对用户允许的访问。

如果该服务器以前就被配置为远程访问/VPN 服务器，或如果该服务器上已配置了 IAS，则远程访问策略或“路由和远程访问”中出现的策略可以按照与默认远程访问策略不同的方式进行配置。请仔细检查所有的远程访问策略，以确保根据网络需要确定允许和拒绝的远程访问。请确保您没有因意外操作而允许或拒绝超出预计对您网络的远程访问。

详细信息，请参阅添加远程访问策略、远程访问策略简介和重新创建默认远程访问策略。

在配置了远程访问策略后，就完成了远程访问/VPN 服务器在不含 DHCP 服务器的网络上的所有必要配置。如果您的网络使用 DHCP 服务器，则在完成配置前还必须配置“DHCP 中继代理”。在“路由和远程访问”中，双击“IP 路由”，右键单击“DHCP 中继代理”，再单击“属性”。在“服务器地址”中键入网络中 DHCP 服务器的 IP 地址，单击“添加”，然后单击“确定”。

删除远程访问/VPN 服务器角色

如果需要将服务器重新配置为另外一个角色，则可删除现有服务器角色。当您删除远程访问/VPN 服务器角色时，服务器将不再为远程访问客户端提供拨号或 VPN 访问。另外，服务器也不再为专用网络上的计算机提供 NAT。远程用户将无法连接到您的专用网络，而专用网络上的计算机可能也无法连接到 Internet。基本防火墙将不再保护专用网络上的计算机。在删除远程访问/VPN 服务器角色后，请考虑添加另一个防火墙以保护专用网络上的计算机（如果您的网络中还没有的话）。测试专用网络以确保专用网络上的计算机具有对 Internet 的访问，其级别由业务需要所决定。在 IAS 中重新配置远程访问策略，以拒绝所有远程访问尝试。

若要删除远程访问/VPN 服务器角色，请通过完成下面的任一操作来重新启动“配置您的服务器向导”：

  • 从“管理您的服务器”中，单击“添加或删除角色”。默认情况下，在您登录时将自动启动“管理您的服务器”。XOX
  • XOX

在“服务器角色”页面上，单击“远程访问/VPN 服务器”，然后单击“下一步”。在“角色删除确认”页面上，检查“摘要”下所列的项目，选中“删除远程访问/VPN 服务器角色”复选框，然后单击“下一步”。在要求确认是否要禁用路由器并删除远程访问配置的对话框中，单击“是”。在“删除了远程访问/VPN 服务器角色”页面上，单击“完成”。

下一步：完成其他任务

在完成“配置您的服务器向导”和完成“路由和远程访问”中的配置以后，您的服务器就可以用作可提供 VPN 访问和 NAT 的远程访问/VPN 服务器。至此，您已经完成了以下任务：

  • 启动路由和远程访问服务。
  • 将服务器配置为接受 VPN 连接和拨号连接。
  • 配置服务器，使其为专用网络提供 NAT。
  • 配置远程访问策略以允许用户连接到运行“路由和远程访问”的服务器。
  • 如果网络使用 DHCP 服务器，则配置 DHCP 中继代理以便将 DHCP 消息从远程访问客户端转发到 DHCP 服务器。

如果已完成所有这些任务，则创建了一个基本远程访问/VPN 服务器，它将允许远程计算机通过拨号或 VPN 连接来连接到您的服务器，并为专用网络提供网络地址转换 (NAT)。

下表列出了可能要在远程访问/VPN 服务器上执行的其他任务。

任务 | 任务目的 | 参考
配置静态数据包筛选器。 | 添加静态数据包筛选器以便更好地保护网络。 | 添加本地主机筛选器
配置服务和端口。 | 选择专用网络上远程访问用户可用的服务。 | 配置服务和端口
调整路由协议的日志级别。 | 配置要记录的事件详细信息的级别。可决定要在日志文件中跟踪的信息。 | 记录路由协议的详细信息
配置 VPN 端口数。 | 添加或删除 VPN 端口。 | 添加 PPTP 或 L2TP 端口
为用户创建“连接管理器”配置文件。 | 为用户管理客户端连接体验并简化客户端连接的故障排除。 | 连接管理器管理工具包
添加“证书服务”。 | 在服务器上配置和管理证书颁发机构 (CA)，以便在公钥基础结构 (PKI) 中使用。 | 证书服务；L2TP/IPSec VPN 连接的计算机证书
增强远程访问安全性。 | 通过强制使用安全的身份验证方法、要求更高级别的数据加密等等，保护远程用户和专用网络。 | 远程访问的安全信息
增强 VPN 安全性。 | 通过要求使用安全的路由和隧道协议、配置帐户锁定等等，保护远程用户和专用网络。 | VPN 的安全信息


域控制器角色：配置域控制器

域控制器存储数据并管理用户和域的交互，包括用户登录过程、身份验证和目录搜索。如果您计划使用该服务器向网络用户和计算机提供 Active Directory 目录服务，就请将该服务器配置为域控制器。

要将服务器配置为域控制器，就要在服务器上安装 Active Directory。在“Active Directory 安装向导”中有四个选项可用。您可以在现有的域中创建额外的域控制器，一个域控制器用于新的子域，一个域控制器用于新的域树，或者一个域控制器用于新的林。如果您无法确定自己需要哪个角色，请单击角色选项阅读有关每个角色的描述。

注意

  • 如果您已经安装了一个域控制器角色，并且希望查看后面的步骤，请在下面的列表中，单击您所安装的域控制器配置，然后单击“后续步骤：完成其他任务”。
  • 如果需要将服务器重新配置为另外一个角色，则可删除现有服务器角色。通过删除域控制器角色，您将从该服务器卸载 Active Directory。卸载 Active Directory 之后，该服务器将不再参与目录对象的复制和基于域的用户身份验证请求。详细信息，请参阅以下部分。
单击您想创建的域控制器角色的类型：
为现有的域创建额外的域控制器
为新的林创建域控制器
为新的子域创建域控制器
为新的域树创建域控制器

为现有的域创建额外的域控制器

当您希望改进网络服务的可用性和可靠性时，可创建额外的域控制器。添加额外的域控制器，可以提供容错，平衡现有域控制器的负载，向站点提供额外的结构支持，并能使客户端在登录到网络时更易于连接到域控制器上，从而提高性能。例如，在下面的图示中可以看到，向 microsoft.com 域中添加一个新的域控制器 (DC2)，有助于抵消其他域控制器上的负载。

额外的域控制器用于平衡负载和提供容错。

本主题说明要在组织中创建额外的域控制器而必须执行的基本步骤。

此过程包括使用“配置您的服务器向导”和“Active Directory 安装向导”在此服务器上安装 Active Directory。完成设置域控制器后，可以完成其他配置任务。

本主题包括：

开始之前

配置域控制器

后续步骤：完成其他任务

开始之前

将服务器配置为域控制器之前，请确认：

  • 该服务器的 TCP/IP 配置设置是否正确，特别是用于 DNS 名称解析的设置是否正确。详细信息，请参阅配置 TCP/IP 以使用 DNS
  • 所有现有磁盘卷是否都使用NTFS 文件系统。Active Directory 要求至少有一个 NTFS 卷用于存储 SYSVOL 文件夹及其内容。FAT32 卷缺乏安全性，而且不支持文件和文件夹压缩、磁盘配额、文件加密或单个文件权限。

下表列出了在添加额外的域控制器之前必须了解的信息。

在添加额外的域控制器角色之前 | 注释
确定哪些站点要求域控制器。 | 如果您的网络划分为多个站点，一种较好的做法是在每个站点中至少配置一个域控制器以提高网络性能。当用户登录到网络时，作为登录过程的一部分，必须与域控制器联系。如果客户端必须连接位于不同站点的域控制器，那么登录过程可能会需要很长的时间。
确定是在网络上还是通过现有域控制器中的备份媒体来添加额外的域控制器。 | 采用 Windows Server 2003 家族，您可使用运行 Windows Server 2003 的域控制器中的还原的备份，在成员服务器上安装 Active Directory。可以将该备份存储在任何备份媒体（例如，磁带、光盘或 DVD）或共享网络资源上。通过使用还原的备份文件来创建额外的域控制器，可以大大降低在共享网络资源上安装 Active Directory 时所使用的网络带宽。此时，您还需要网络连接性，以便将所有的新对象和现有对象的最新更改复制到新的域控制器。有关从备份媒体创建额外域控制器的详细信息，请参阅创建额外的域控制器。
确定是否希望新的域控制器主持全局编录。 | 全局编录存储林中主持域的目录中所有对象的完全副本，以及所有其他域中所有对象的部分副本。要优化多站点环境的网络性能，请考虑为选定站点添加全局编录。在单站点环境中，通常单个全局编录可包含 Active Directory 公用查询。然而，在多站点环境中，建议您在每一个站点都使用全局编录。有关在多站点环境中何时添加全局编录的详细信息，请参阅全局编录和站点。
运行 Windows 2000 或 Windows Server 2003 的域控制器可用。 | 域中必须至少有一个运行 Windows 2000 或 Windows Server 2003 的其他域控制器，才能添加额外的域控制器。Active Directory 域控制器不能配置为 Windows NT 域的备份域控制器 (BDC)。
获取添加域控制器所需的管理凭据。 | 要向现有域中添加其他域控制器，您必须成为 Active Directory 中 Domain Admins 组或 Enterprise Admins 组的成员，或者必须已被委派适当的权限。
确定您希望将额外的域控制器添加到 Active Directory 域的 DNS 域名。 | 在使用“Active Directory 安装向导”时，需要提供 DNS 域名。

配置域控制器

要配置额外的域控制器，请通过完成下面的任一操作来启动“配置您的服务器向导”：

  • 从“管理服务器”中，单击“添加或删除角色”。默认情况下，“管理您的服务器”会在您登录时自动启动。 XOX
  • XOX

在“服务器角色”页，单击“域控制器 (Active Directory)”，然后单击“下一步”。

本部分描述了该过程中的所有步骤，并概述了在配置域控制器期间必需做出的选择和决定。下列部分包含了这些配置步骤：

选择摘要

使用“Active Directory 安装向导”

完成“配置您的服务器向导”

删除域控制器角色

选择摘要

在“配置您的服务器向导”的“选择摘要”页上，可查看并确认已选择的选项。如果在上一页面上选择了“域控制器 (Active Directory)”，将会出现下列内容：

  • 运行 Active Directory 安装向导将此服务器设置成域控制器

要应用“选择摘要”页面上显示的选择，请单击“下一步”。

使用“Active Directory 安装向导”

单击“下一步”后，“Active Directory 安装向导”将自动启动。如果这是第一次在服务器上安装 Active Directory，请单击“Active Directory 帮助”以获得有关 Active Directory 的详细信息。

仔细阅读 Active Directory 的相关信息之后，请单击“下一步”。在最后一页单击“完成”之前，您可以从向导中的任何位置返回该页。在“操作系统兼容性”页，请仔细阅读相关信息。然后单击“下一步”。如果这是首次在运行 Windows Server 2003 的服务器上安装 Active Directory，请单击“兼容帮助”以获得更多信息。

本部分描述“Active Directory 安装向导”中的下列步骤：

域控制器类型

网络凭据

额外域控制器

数据库和日志文件夹

共享的系统卷

目录服务还原模式的管理员密码

摘要

域控制器类型

在“Active Directory 安装向导”的“域控制器类型”页面上，单击“现有域的额外域控制器”。

作为创建额外域控制器的部分过程，该向导将删除服务器上的所有本地帐户、加密密钥和加密数据，如加密文件和电子邮件。要防止数据丢失，请先按照“域控制器类型”页上的建议进行操作，然后再继续到下一页。

完成后请单击“下一步”。

网络凭据

在“网络凭据”页面上，键入要使用的用户帐户的用户名、密码和域。

选项 | 注释
用户名 | 键入具有必要管理凭据的用户帐户的名称。用户帐户必须是目标域的 Domain Admins 组的成员，或者必须是 Enterprise Admins 组的成员，或者必须被委派适当的权限。
密码 | 键入用户帐户的密码。该密码应始终为强密码。详细信息，请参阅强密码。
域 | 键入该用户名和密码有效的域的完整 DNS 名称（例如，child.microsoft.com）。这也是您要在其中添加额外域控制器的域。

完成后请单击“下一步”。

额外域控制器

在“额外的域控制器”页面上，键入要将该域控制器添加到其中的域的完整 DNS 名称。完整的 DNS 名称也称为完全限定的域名 (FQDN)。Active Directory 域以 DNS 名称命名并使用与 DNS 相同的层次结构。

完成后请单击“下一步”。

数据库和日志文件夹

在“数据库和日志文件文件夹”页面上，键入要安装数据库和日志文件夹的位置，或单击“浏览”选择位置。要避免安装或删除 Active Directory 过程中的任何问题，请确保您有足够的磁盘空间来容纳目录数据库和日志文件。“Active Directory 安装向导”需要 250 MB 的磁盘空间用于 Active Directory 数据库，50 MB 用于日志文件。建议将这些文件保存在 NTFS 分区上。

完成后请单击“下一步”。

共享的系统卷

在“共享的系统卷”页面上，接受要安装 Sysvol 文件夹的默认位置，或单击“浏览”选择位置。Sysvol 文件夹必须保存在 NTFS 卷上，因为它包含了域或林中的域控制器之间彼此复制的文件。这些文件包括 Windows NT 4.0 及更早版本的脚本、系统策略，Netlogon 和 Sysvol 共享文件夹，以及“组策略”设置。

完成后请单击“下一步”。

目录服务还原模式的管理员密码

在“目录服务还原模式的管理员密码”页面上，键入并确认要指派给该服务器的还原模式的管理员帐户的密码。您应该使用强密码作为目录还原模式密码。详细信息，请参阅强密码。

要点

  • 您必须知道为该域控制器还原系统状态的备份副本的密码。

当域控制器以目录服务还原模式启动时，需使用该密码。如果是第一次在服务器上安装 Active Directory，请单击“Active Directory 帮助”以获得有关还原模式密码的详细信息。

完成后请单击“下一步”。

摘要

阅读“摘要”页上的信息，然后单击“下一步”。

完成安装后，请单击“完成”按钮。要重新启动计算机并实施更改，请单击“立即重新启动”。

完成“配置您的服务器向导”

服务器重新启动后，“配置您的服务器向导”将显示“此服务器现在是域控制器”页面。要查看“配置您的服务器向导”对服务器进行的所有更改或确保新角色已成功安装，请单击“‘配置您的服务器向导’日志”。“配置您的服务器向导”日志位于 systemroot\Debug\Configure Your Server.log。要关闭“配置您的服务器向导”，请单击“完成”。

删除域控制器角色

如果需要将服务器重新配置为另外一个角色，则可删除现有服务器角色。通过删除域控制器角色，您将从该服务器卸载 Active Directory。卸载 Active Directory 之后，该服务器将不再参与目录对象的复制和基于域的用户身份验证请求。

要删除域控制器角色，请执行以下操作之一重新启动“配置您的服务器向导”：

  • 从“管理您的服务器”，单击“添加或删除角色”。默认情况下，“管理您的服务器”在您登录时自动启动。 XOX
  • XOX

在“服务器角色”页面上，请单击“域控制器 (Active Directory)”，然后单击“下一步”。在“角色删除确认”页面上，检查“摘要”下列出的项目，选中“删除域控制器角色”复选框，单击“下一步”，然后按照 Active Directory 安装向导中的步骤进行操作。

后续步骤：完成其他任务

完成 Active Directory 安装向导后，服务器即被配置为域控制器。可使用域控制器来存储数据，管理对象并为用户、计算机和应用程序提供信息。至此，您已经为现有的域创建了一个额外的域控制器。

下表列出了可能需要在域控制器上执行的一些其他任务。

任务 | 任务目的 | 参考
将新域控制器放置在上锁的房间内。 | 确保无人能够通过物理方式触及该域控制器。 | 域控制器；保护 Active Directory
使用强加密技术保护帐户密码。 | 确保新域控制器的帐户密码信息的安全性。 | 系统密钥实用程序

为新的林创建域控制器

当您要将 Windows NT 域升级为新的林中的第一个域，为管理自治而将网络分段，提供安全边界以保护敏感数据，将目录复制范围隔离开来，或者使用与网络上现有林不同的非连续 DNS 名称空间时,就要为新的林创建域控制器。例如，在下面的插图中可以看到，microsoft.com 林是组织中的第一个 Active Directory 域。

林可以用作组织中的第一个 Active Directory 域。

本主题说明为组织中的新林配置域控制器必须执行的基本步骤。

此过程包括使用“配置您的服务器向导”和“Active Directory 安装向导”在此服务器上安装 Active Directory。完成设置域控制器后，可以完成其他配置任务。

本主题包括：

开始之前

配置域控制器

后续步骤：完成其他任务

开始之前

将服务器配置为域控制器之前，请确认：

  • 该服务器的 TCP/IP 配置设置是否正确，特别是用于 DNS 名称解析的设置是否正确。详细信息，请参阅配置 TCP/IP 以使用 DNS
  • 所有现有的磁盘卷是否都使用 NTFS 文件系统。Active Directory 要求至少有一个 NTFS 卷用于存储 SYSVOL 文件夹及其内容。FAT32 卷缺乏安全性，而且不支持文件和文件夹压缩、磁盘配额、文件加密或单个文件权限。

下表列出了在为新的林添加域控制器之前必须了解的信息。

在为新的林添加新的域控制器之前 | 注释
确认组织已配置了正确的 DNS。 | 需要确认网络上已正确配置了 DNS，而且它支持动态更新和服务 (SRV) 资源记录。如果您是首次在组织中安装 Active Directory，而且当前没有配置 DNS 结构，“Active Directory 安装向导”会在 Active Directory 安装过程中在该服务器上设置并配置 DNS。Active Directory 要求 DNS 运行并与其共享相同的域层次结构。例如，microsoft.com 既是一个 DNS 域，同时还是一个 Active Directory 域。
获取创建林所必需的管理凭据。 | 要创建新的林，您必须是本地计算机上 Administrators 组的成员，或者您必须被授予适当的权限。

配置域控制器

要配置域控制器，请通过完成下面的任一操作来启动“配置您的服务器向导”：

  • 从“管理服务器”中，单击“添加或删除角色”。默认情况下，“管理您的服务器”在您登录时自动启动。 XOX
  • XOX

在“服务器角色”页面上，请单击“域控制器 (Active Directory)”，然后单击“下一步”。

本部分描述了该过程中的所有步骤，概述了在配置域控制器期间必需做出的选择和决定。下列部分包含了这些配置步骤：

选择摘要

使用“Active Directory 安装向导”

完成“配置您的服务器向导”

删除域控制器角色

选择摘要

在“配置您的服务器向导”的“选择摘要”页上，可查看并确认已选择的选项。如果在上一页面上选择了“域控制器 (Active Directory)”，将会出现下列内容：

  • 运行 Active Directory 安装向导将此服务器配置成域控制器

要应用“选择摘要”页面上显示的选择，请单击“下一步”。

使用“Active Directory 安装向导”

单击“下一步”后，Active Directory 安装向导将自动启动。如果这是第一次在服务器上安装 Active Directory，请单击“Active Directory 帮助”以获得有关 Active Directory 的详细信息。

仔细阅读 Active Directory 的有关信息之后，请单击“下一步”。当在最后一页单击“完成”之前，您可以从向导的任何位置返回到该页。在“操作系统兼容性”页，仔细阅读相关信息，然后单击“下一步”。如果这是首次在运行 Windows Server 2003 的服务器上安装 Active Directory，请单击“兼容帮助”以获得更多信息。

本部分描述 Active Directory 安装向导中的下列步骤：

域控制器类型

创建新域

新的域名

NetBIOS 域名

数据库和日志文件夹

共享的系统卷

DNS 注册诊断

权限

目录服务还原模式的管理员密码

摘要

域控制器类型

单击“域控制器类型”页上的“新域的域控制器”。

完成后请单击“下一步”。

创建新域

在“创建一个新域”页面上，单击“在新林中的域”。

完成后请单击“下一步”。

新的域名

在“新的域名”页面上，键入新域的完整 DNS 名称。为您要创建的新 Active Directory 林提供完整的 DNS 名称（例如，headquarters.example.microsoft.com）。完整的 DNS 名称也称为完全限定的域名 (FQDN)。Active Directory 域以 DNS 名称命名并使用与 DNS 相同的层次结构。当选择用于 Active Directory 林的 DNS 名称时，请以组织所保留的用于 Internet 的已注册 DNS 域后缀开始，比如 microsoft.com。

完成后请单击“下一步”。

NetBIOS 域名

验证“NetBIOS 域名”页上的 NetBIOS 名称。尽管 Active Directory 域是根据 DNS 命名标准来命名的，在您创建 Active Directory 域时仍需要定义 NetBIOS 名称。NetBIOS 名称应尽可能与 DNS 域名的第一个标签相匹配。当 Active Directory 域的某个 DNS 名的第一个标签与其 NetBIOS 名称不同时，FQDN 将使用 DNS 域名，而不是 NetBIOS 名称。例如，如果完整的 DNS 域名中的第一个标签是“child”（child.microsoft.com 是 FQDN），而 NetBIOS 域名为“sales”，那么 FQDN 仍保持为“child.microsoft.com”。

完成后请单击“下一步”。

数据库和日志文件夹

在“数据库和日志文件文件夹”页面上，键入要安装数据库和日志文件夹的位置，或单击“浏览”选择位置。要避免在安装和删除 Active Directory 时出现问题，请确保您有足够的磁盘空间容纳目录数据库和日志文件，这一点非常重要。“Active Directory 安装向导”要求有 250 MB 的磁盘空间用于 Active Directory 数据库，50 MB 用于日志文件。建议将这些文件保存在 NTFS 分区上。

完成后请单击“下一步”。

共享的系统卷

在“共享的系统卷”页面上，键入要安装 Sysvol 文件夹的位置，或单击“浏览”选择位置。Sysvol 文件夹必须存储在 NTFS 卷上，因为它包含的文件将在域或林中的域控制器之间进行复制。这些文件包括脚本、Windows NT 4.0 和更低版本的系统策略、NETLOGON 和 SYSVOL 共享以及组策略设置。

完成后请单击“下一步”。

DNS 注册诊断

在“DNS 注册诊断”页面上，确认 DNS 设置是正确的。

如果“诊断结果”下出现诊断错误，请单击“帮助”以获得如何解决错误的详细信息。

完成后请单击“下一步”。

权限

在“权限”页中，单击要用于 Windows 2000 之前版本的操作系统、Windows 2000 或 Windows Server 2003 操作系统的应用程序兼容性级别。

在运行 Windows NT 4.0 及更低版本的服务器上，系统会将用户和组信息的读取权限指派给匿名用户，这样，现有的应用程序（包括 Microsoft BackOffice、SQL Server 和一些非 Microsoft 应用程序）就能正常工作。在 Windows 2000 和 Windows Server 2003 家族中，只有当 Anonymous Logon 组被添加到 Pre-Windows 2000 Compatible Access 组中时，Anonymous Logon 组的成员才具有读取该信息的权限。

选项 | 注释
与 Windows 2000 之前的服务器操作系统兼容的权限 | 如果您要将 Anonymous Logon 组与 Everyone 安全组添加至 Pre-Windows 2000 Compatible Access 组，请单击此选项。
只与 Windows 2000 或 Windows Server 2003 操作系统兼容的权限 | 单击该选项可防止 Anonymous Logon 组成员获得对用户或组信息的读权限。

选择这些选项之一后，您可以手动在 Active Directory 对象的向后兼容性设置和高安全性设置之间进行切换。为此，请打开“Active Directory 用户和计算机”，然后将 Anonymous Logon 安全组添加到 pre-Windows 2000 Compatible Access 安全组。

完成后请单击“下一步”。

目录服务还原模式的管理员密码

在“目录服务还原模式的管理员密码”页面上，键入并确认要指派给该服务器的还原模式管理员帐户的密码。您应该使用强密码作为目录还原模式密码。详细信息，请参阅强密码。

要点

  • 您必须知道为该域控制器还原系统状态备份副本的密码。

当域控制器以目录服务还原模式启动时，需要使用该密码。如果是第一次在服务器上安装 Active Directory，请单击“Active Directory 帮助”以获得有关还原模式密码的详细信息。

完成后请单击“下一步”。

摘要

阅读“概要”页上的信息，然后单击“下一步”。

完成安装后，请单击“完成”按钮。要重新启动计算机并实施更改，请单击“立即重新启动”。

完成“配置您的服务器向导”

服务器重新启动后，“配置您的服务器向导”将显示“此服务器现在是域控制器”页面。要查看“配置您的服务器向导”对服务器进行的所有更改或确保新角色已成功安装，请单击“‘配置您的服务器向导’日志”。“配置您的服务器向导”日志位于 systemroot\Debug\Configure Your Server.log。要关闭“配置您的服务器向导”，请单击“完成”。

删除域控制器角色

如果需要将服务器重新配置为另外一个角色，则可删除现有服务器角色。通过删除域控制器角色，您将从该服务器卸载 Active Directory。卸载 Active Directory 之后，该服务器将不再参与目录对象的复制和基于域的用户身份验证请求。

要删除域控制器角色，请执行以下操作之一重新启动“配置您的服务器向导”：

  • 从“管理您的服务器”中，单击“添加或删除角色”。默认情况下，“管理您的服务器”在您登录时自动启动。 XOX
  • XOX

在“服务器角色”页面上，单击“域控制器 (Active Directory)”，然后单击“下一步”。在“角色删除确认”页面上，检查“摘要”下列出的项目，选中“删除域控制器角色”复选框，单击“下一步”，然后按照 Active Directory 安装向导中的步骤进行操作。

后续步骤：完成其他任务

完成 Active Directory 安装向导后，服务器即被配置为域控制器。可使用域控制器存储数据，管理对象并为用户、计算机和应用程序提供信息。至此，您已经为新的林创建了一个域控制器。

下表列出了可能需要在域控制器上执行的一些其他任务。

任务 | 任务目的 | 参考
将新域控制器放置在上锁的房间内。 | 确保无人能够通过物理方式触及该域控制器。 | 域控制器；保护 Active Directory
使用强密码加密技术。 | 确保新域控制器的帐户密码信息的安全性。 | 系统密钥实用程序
检查并验证每个用户的有效性。 | 使用公钥加密来增强整个林中的安全性。 | 公钥结构
要求所有域用户使用强密码。 | 防止对组织进行未经授权的访问。 | 强密码
启用审核策略。 | 接收那些可能会造成安全隐患的操作的通知。 | 审核策略
对用户帐户强制实施帐户锁定。 | 减小攻击者通过重复登录企图危及您所在域安全的可能性。 | 用户和计算机帐户
对用户帐户强制实施密码历史。 | 减小攻击者危及您所在域安全的可能性。 | 强制实施密码历史
对用户帐户强制实施密码最长使用期限和密码最短使用期限。 | 减小攻击者危及您所在域安全的可能性。 | 密码最短使用期限；密码最长使用期限
实施 SID 筛选。 | 防止企图将提升的用户权限授予其他用户帐户的恶意用户的攻击。 | 位于 Microsoft 网站 (http://www.microsoft.com/) 上的“Using Security Identifier (SID) Filtering to Prevent Elevation of Privilege Attacks”（使用安全标识符 (SID) 筛选来防止权限提升攻击）
使用智能卡。 | 提供防篡改的用户身份验证和电子邮件安全。 | 智能卡概述
限制用户、组和计算机访问共享资源并筛选组策略设置。 | 确保资源安全。 | 安全组
创建林信任（必要时）。 | 管理两个林之间的安全关系并简化跨林的安全管理和身份验证。 | 林信任
为新的安全组指派用户权限。 | 明确定义域中成员的管理角色。 | 将用户权限分配到 Active Directory 中的安全组

为新的子域创建域控制器

当您想创建与一个和多个现存域共享连续名称空间的域时，就要为新的子域创建域控制器。这意味着新域的名称中包含父域的完整名称。例如，在下面的插图中可以看到，child.microsoft.com 是 microsoft.com 的子域。最好是将新域创建成为林根域的子域。

子域用于形成具有其父域的连续的名称空间。

本主题说明为组织中的新子域配置域控制器必须执行的基本步骤。

此过程包括使用“配置您的服务器向导”和“Active Directory 安装向导”在此服务器上安装 Active Directory。完成设置域控制器后，可以完成其他配置任务。

本主题包括：

开始之前

配置域控制器

后续步骤：完成其他任务

开始之前

将服务器配置为域控制器之前，请确认：

  • 该服务器的 TCP/IP 配置是否正确，特别是用于 DNS 名称解析的设置是否正确。详细信息，请参阅配置 TCP/IP 以使用 DNS。
  • 所有现有的磁盘卷是否都使用 NTFS 文件系统。Active Directory 要求至少有一个 NTFS 卷用于存储 SYSVOL 文件夹及其内容。FAT32 卷缺乏安全性，而且不支持文件和文件夹压缩、磁盘配额、文件加密或单个文件权限。

下表列出了在添加域控制器之前必须了解的信息。

添加域控制器角色之前 | 注释
确定您希望将域控制器添加到的 Active Directory 域的 DNS 域名。 | 需要提供这个新子域的父域的 DNS 域名。
在安装 Active Directory 时确认网络速度合适。 | 要在其上安装 Active Directory 并创建子域的服务器应拥有通过高速连接访问网络的权限。
确定哪些站点需要域控制器。 | 如果您的网络划分为多个站点，一种较好的做法是在每个站点中至少配置一台域控制器以提高网络性能。当用户登录到网络时，作为登录过程的一部分，必须与域控制器联系。如果客户端必须连接位于不同站点的域控制器，那么登录过程可能需要很长的时间。
确定是否希望新的域控制器主持全局编录。 | 全局编录存储域控制器上林中的所有 Active Directory 对象的副本。全局编录存储林中其宿主域的目录中所有对象的完全副本，以及所有其他域中所有对象的部分副本。要优化多站点环境的网络性能，请考虑为选定站点添加全局编录。在单站点环境中，通常单个全局编录可包含 Active Directory 公用查询。然而，在多站点环境中，建议您在每一个站点都使用全局编录。有关在多站点环境中何时添加全局编录的详细信息，请参阅全局编录和站点。
获取创建子域所必需的管理凭据。 | 要添加新的子域，您必须为 Active Directory 中 Domain Admins 组（在父域中）或 Enterprise Admins 组的成员，或者您必须被委派了适当的权限。

配置域控制器

要配置域控制器，请通过完成下面的任一操作来启动“配置您的服务器向导”：

  • 从“管理服务器”中，单击“添加或删除角色”。默认情况下，“管理您的服务器”在您登录时自动启动。 XOX
  • XOX

在“服务器角色”页面上，单击“域控制器 (Active Directory)”，然后单击“下一步”。

本部分描述了该过程中的所有步骤，概述了在配置域控制器期间必需做出的选择和决定。下列部分包含了这些配置步骤：

选择摘要

使用“Active Directory 安装向导”

完成“配置您的服务器向导”

删除域控制器角色

选择摘要

在“配置您的服务器向导”的“选择摘要”页上，可查看并确认已选择的选项。如果在上一页面上选择了“域控制器 (Active Directory)”，将会出现下列内容：

  • 运行 Active Directory 安装向导将此服务器配置成域控制器

要应用“选择摘要”页面上显示的选择，请单击“下一步”。

使用“Active Directory 安装向导”

单击“下一步”后，Active Directory 安装向导将自动启动。如果是第一次在服务器上安装 Active Directory，请单击“Active Directory 帮助”以获得有关 Active Directory 的详细信息。

仔细阅读 Active Directory 的有关信息之后，请单击“下一步”。当在最后一页单击“完成”之前，您可以从向导的任何位置返回到该页。在“操作系统兼容性”页，仔细阅读相关信息，然后单击“下一步”。如果这是首次在运行 Windows Server 2003 的服务器上安装 Active Directory，请单击“兼容帮助”以获得更多信息。

本部分描述“Active Directory 安装向导”中的下列步骤：

域控制器类型

创建新域

网络凭据

子域安装

NetBIOS 域名

数据库和日志文件夹

共享的系统卷

DNS 注册诊断

权限

目录服务还原模式的管理员密码

摘要

域控制器类型

单击“域控制器类型”页上的“新域的域控制器”。

完成后请单击“下一步”。

创建新域

在“创建一个新域”页面上，单击“在现有域树中的子域”。

完成后请单击“下一步”。

网络凭据

在“网络凭据”页面上，键入要使用的用户帐户的用户名、密码和域。

选项 | 注释
用户名 | 键入具有必要管理凭据的用户帐户的名称。用户帐户必须是父域的 Domain Admins 组的成员，或者必须是 Enterprise Admins 组的成员，或者必须被委派适当的权限。
密码 | 键入用户帐户的密码。该密码应始终为强密码。详细信息，请参阅强密码。
域 | 键入该用户名和密码有效的域的完整 DNS 名称。

完成后请单击“下一步”。

子域安装

在“子域安装”页面上，检查父域，然后是新子域的名称。Active Directory 域以 DNS 名称命名并使用与 DNS 相同的层次结构。当选择要用于子域的 DNS 名称时，请考虑采用包含组织中的地理或部门范围的名称（例如，newyork.microsoft.com 或 sales.microsoft.com）。

按照 DNS 标准，域名为完全限定的域名 (FQDN)，它由域名后跟父域名和根域名构成，其中每两个域名之间均用点 (.) 字符进行分隔。例如，对于名为“child”的 Active Directory 域和名为“microsoft.com”的父域，其 FQDN（也称为完整 DNS 名称）为“child.microsoft.com”。

完成后请单击“下一步”。

NetBIOS 域名

验证“NetBIOS 域名”页上的 NetBIOS 名称。尽管 Active Directory 域是根据 DNS 命名标准来命名的，在您创建 Active Directory 域时仍需要定义 NetBIOS 名称。NetBIOS 名称应尽可能与 DNS 域名的第一个标签相匹配。当 Active Directory 域的某个 DNS 名的第一个标签与其 NetBIOS 名称不同时，FQDN 将使用 DNS 域名，而不是 NetBIOS 名称。例如，如果完整的 DNS 域名中的第一个标签是“child”（child.microsoft.com 是 FQDN），而 NetBIOS 域名为“sales”，那么 FQDN 仍保持为“child.microsoft.com”。

数据库和日志文件夹

在“数据库和日志文件文件夹”页面上，键入要安装数据库和日志文件夹的位置，或单击“浏览”选择位置，然后单击“下一步”。要避免在安装和删除 Active Directory 时出现问题，请确保您有足够的磁盘空间容纳目录数据库和日志文件，这一点非常重要。Active Directory 安装向导要求有 250 MB 的磁盘空间用于 Active Directory 数据库，50 MB 用于日志文件。建议将这些文件保存在 NTFS 分区上。

完成后请单击“下一步”。

共享的系统卷

在“共享的系统卷”页面上，键入要安装 Sysvol 文件夹的位置，或单击“浏览”选择位置。Sysvol 文件夹必须存储在 NTFS 卷上，因为它包含的文件将在域或林中的域控制器之间进行复制。这些文件包括脚本、Windows NT 4.0 和更低版本的系统策略、NETLOGON 和 SYSVOL 共享以及组策略设置。

完成后请单击“下一步”。

DNS 注册诊断

在“DNS 注册诊断”页面上，确认 DNS 设置是正确的。

如果“诊断结果”下出现诊断错误，请单击“帮助”以获得如何解决错误的详细信息。

完成后请单击“下一步”。

权限

在“权限”页中，单击要用于 Windows 2000 之前版本的操作系统、Windows 2000 或 Windows Server 2003 操作系统的应用程序兼容性级别。

在运行 Windows NT 4.0 及更低版本的服务器上，系统会将用户和组信息的读取权限指派给匿名用户，这样，现有的应用程序（包括 Microsoft BackOffice、SQL Server 和一些非 Microsoft 应用程序）就能正常工作。在 Windows 2000 和 Windows Server 2003 家族中，只有当 Anonymous Logon 组被添加到 Pre-Windows 2000 Compatible Access 组中时，Anonymous Logon 组的成员才具有读取该信息的权限。

选项 | 注释
与 Windows 2000 之前的服务器操作系统兼容的权限 | 如果您要将 Anonymous Logon 组与 Everyone 安全组添加至 Pre-Windows 2000 Compatible Access 组，请单击此选项。
只与 Windows 2000 或 Windows Server 2003 操作系统兼容的权限 | 单击该选项可防止 Anonymous Logon 组成员获得对用户或组信息的读权限。

选择这些选项之一后，您可以手动在 Active Directory 对象的向后兼容性设置和高安全性设置之间进行切换。为此，请打开“Active Directory 用户和计算机”，然后将 Anonymous Logon 安全组添加到 pre-Windows 2000 Compatible Access 安全组。

完成后请单击“下一步”。

目录服务还原模式的管理员密码

在“目录服务还原模式的管理员密码”页面上，键入并确认要指派给该服务器的还原模式管理员帐户的密码。您应该使用强密码作为目录还原模式密码。详细信息，请参阅强密码。

要点

  • 您必须知道为该域控制器还原系统状态备份副本的密码。

当域控制器以目录服务还原模式启动时，需要使用该密码。如果是第一次在服务器上安装 Active Directory，请单击“Active Directory 帮助”以获得有关还原模式密码的详细信息。

完成后请单击“下一步”。

摘要

阅读“摘要”页上的信息，然后单击“下一步”。

完成安装后，请单击“完成”按钮。要重新启动计算机并执行更改，请单击“立即重新启动”。

完成“配置您的服务器向导”

服务器重新启动后，“配置您的服务器向导”将显示“此服务器现在是域控制器”页面。要查看“配置您的服务器向导”对服务器进行的所有更改或确保新角色已成功安装，请单击“‘配置您的服务器向导’日志”。“配置您的服务器向导”日志位于 systemroot\Debug\Configure Your Server.log。要关闭“配置您的服务器向导”，请单击“完成”。

删除域控制器角色

如果需要将服务器重新配置为另外一个角色，则可删除现有服务器角色。通过删除域控制器角色，您将从该服务器卸载 Active Directory。卸载 Active Directory 之后，该服务器将不再参与目录对象的复制和基于域的用户身份验证请求。

要删除域控制器角色，请执行以下操作之一重新启动“配置您的服务器向导”：

  • 从“管理您的服务器”中，单击“添加或删除角色”。默认情况下，“管理您的服务器”在您登录时自动启动。 XOX
  • XOX

在“服务器角色”页面上，单击“域控制器 (Active Directory)”，然后单击“下一步”。在“角色删除确认”页面上，检查“摘要”下列出的项目，选中“删除域控制器角色”复选框，单击“下一步”，然后按照 Active Directory 安装向导中的步骤进行操作。

后续步骤：完成其他任务

完成 Active Directory 安装向导后，服务器即被配置为域控制器。您可以使用域控制器存储数据、管理对象以及为用户、计算机和应用程序提供信息。此时，您已经创建了一个新域或为现有域创建了额外的域控制器。

下表列出了您可能要在域控制器上执行的一些其他任务。

任务 | 任务目的 | 参考
将新域控制器放置在上锁的房间内。 | 确保任何人都无法通过物理方式触及该域控制器。 | 域控制器；保护 Active Directory
使用强密码技术。 | 确保新域控制器的帐户密码信息的安全性。 | 系统密钥实用程序
要求所有域用户都使用强密码。 | 防止对组织未经授权的访问。 | 强密码
启用审核策略。 | 接收那些可能会造成安全隐患的操作的通知。 | 审核策略
对用户帐户强制实施帐户锁定。 | 减小攻击者通过重复登录企图危及您所在域安全的可能性。 | 用户和计算机帐户
对用户帐户强制实施密码历史。 | 减小攻击者危及您所在域安全的可能性。 | 强制实施密码历史
对用户帐户强制实施密码最长使用期限和密码最短使用期限。 | 减小攻击者危及您所在域安全的可能性。 | 密码最短使用期限；密码最长使用期限
实施 SID 筛选。 | 防止企图将提升的用户权限授予其他用户帐户的恶意用户的攻击。 | 位于 Microsoft网站 (http://www.microsoft.com/) 上的“Using Security Identifier (SID) Filtering to Prevent Elevation of Privilege Attacks”（使用安全标识符 (SID) 筛选来防止权限提升攻击）
使用智能卡。 | 提供防篡改用户身份验证和电子邮件安全。 | 智能卡概述
限制用户、组和计算机访问共享资源并筛选组策略设置。 | 确保资源安全。 | 安全组
将用户权限分配到新的安全组。 | 专门定义域中成员的管理角色。 | 将用户权限分配到 Active Directory 中的安全组

为新的域树创建域控制器

当您想创建一个具有与林中的其他域不相关的 DNS 名称空间的域时，就要为新的域树创建一个域控制器。这意味着树根域（及所有子域）的名称可以不必包含父域的完整名称。一个林中可以包含一个或多个域树。例如，在下面的插图中可以看到，msn.com 是 microsoft.com 林中新的域树。

域树用于形成林中的非连续名称空间。

本主题说明为组织中的新域树配置域控制器必须执行的基本步骤。

此过程包括使用“配置您的服务器向导”和“Active Directory 安装向导”在此服务器上安装 Active Directory。完成设置域控制器后，可以完成其他配置任务。

本主题包括：

开始之前

配置域控制器

后续步骤：完成其他任务

开始之前

将服务器配置为域控制器之前，请确认：

  • 该服务器的 TCP/IP 配置是否正确，特别是用于 DNS 名称解析的设置是否正确。详细信息，请参阅配置 TCP/IP 以使用 DNS
  • 所有现有的磁盘卷是否都使用 NTFS 文件系统。Active Directory 要求至少有一个 NTFS 卷用于存储 SYSVOL 文件夹及其内容。FAT32 卷缺乏安全性，而且不支持文件和文件夹压缩、磁盘配额、文件加密或单个文件权限。

下表列出了在添加域控制器之前必须了解的信息。

添加域控制器角色之前 | 注释
在安装 Active Directory 时确认网络速度合适。 | 要在其上安装 Active Directory 的服务器应拥有通过高速连接访问网络的权限。
确定是否希望新的域控制器主持全局编录。 | 全局编录存储域控制器上林中的所有 Active Directory 对象的副本。全局编录存储林中其宿主域的目录中所有对象的完全副本，以及所有其他域中所有对象的部分副本。要优化多站点环境的网络性能，请考虑为选定站点添加全局编录。在单站点环境中，通常单个全局编录可包含 Active Directory 公用查询。然而，在多站点环境中，建议您在每一个站点都使用全局编录。有关在多站点环境中何时添加全局编录的详细信息，请参阅全局编录和站点。
获取添加新域树所需的管理凭据。 | 若要创建新的域树，您必须为 Active Directory 中 Domain Admins 组（在林根域中）或 Enterprise Admins 组的成员，或者您必须被委派了适当的权限。

配置域控制器

要配置域控制器，请通过完成下面的任一操作来启动“配置您的服务器向导”：

  • 从“管理服务器”中，单击“添加或删除角色”。默认情况下，“管理您的服务器”在您登录时自动启动。 XOX
  • XOX

在“服务器角色”页面上，单击“域控制器 (Active Directory)”，然后单击“下一步”。

本部分描述了该过程中的所有步骤，并概述了在配置域控制器期间必需做出的选择和决定。下列部分包含了这些配置步骤：

选择摘要

使用“Active Directory 安装向导”

完成“配置您的服务器向导”

删除域控制器角色

选择摘要

在“配置您的服务器向导”的“选择摘要”页上，可查看并确认已选择的选项。如果在上一页面选择了“域控制器 (Active Directory)”，将会出现下列内容：

  • 运行 Active Directory 安装向导将此服务器配置成域控制器

要应用“选择摘要”页面上显示的选择，请单击“下一步”。

使用“Active Directory 安装向导”

单击“下一步”后，Active Directory 安装向导将自动启动。如果是第一次在服务器上安装 Active Directory，请单击“Active Directory 帮助”以获得有关 Active Directory 的详细信息。

仔细阅读 Active Directory 的有关信息之后，请单击“下一步”。当在最后一页单击“完成”之前，您可以从向导的任何位置返回到该页。在“操作系统兼容性”页，仔细阅读相关信息，然后单击“下一步”。如果是首次在运行 Windows Server 2003 的服务器上安装 Active Directory，请单击“兼容帮助”以获得更多信息。

本部分描述 Active Directory 安装向导中的下列步骤：

域控制器类型

创建新域

网络凭据

新域树

NetBIOS 域名

数据库和日志文件夹

共享的系统卷

DNS 注册诊断

权限

目录服务还原模式的管理员密码

摘要

域控制器类型

单击“域控制器类型”页上的“新域的域控制器”。

完成后请单击“下一步”。

创建新域

在“创建一个新域”页面上，单击“在现有的林中的域树”。

完成后请单击“下一步”。

网络凭据

在“网络凭据”页面上，键入要使用的用户帐户的用户名、密码和用户域。

选项 | 注释
用户名 | 键入具有必要管理凭据的用户帐户的名称。用户帐户必须是林根域的 Domain Admins 组的成员，或者必须是 Enterprise Admins 组的成员，或者必须被委派适当的权限。
密码 | 键入用户帐户的密码。该密码应始终为强密码。详细信息，请参阅强密码。
域 | 键入该用户名和密码有效的域的完整 DNS 名称。

新域树

在“新的域名”页面上，键入新域树的完整 DNS 名称。提供要创建的新域树的完整 DNS 名称。Active Directory 域以 DNS 名称命名并使用与 DNS 相同的层次结构。

按照 DNS 标准，域名为完全限定的域名 (FQDN)，它由域名后跟父域名和根域名构成，其中每两个域名之间均用点 (.) 字符进行分隔。建议不要将单标签 DNS 名称用于 Active Directory 域名。单标签 DNS 名称是无父域或根域名的名称。

完成后请单击“下一步”。

NetBIOS 域名

验证“NetBIOS 域名”页上的 NetBIOS 名称。尽管 Active Directory 域是根据 DNS 命名标准来命名的，在您创建 Active Directory 域时仍需要定义 NetBIOS 名称。NetBIOS 名称应尽可能与 DNS 域名的第一个标签相匹配。当 Active Directory 域的某个 DNS 名的第一个标签与其 NetBIOS 名称不同时，FQDN 将使用 DNS 域名，而不是 NetBIOS 名称。例如，如果完整 DNS 域名中的第一个标签是“child”（child.microsoft.com 是 FQDN），而 NetBIOS 域名为“sales”，那么 FQDN 仍保持为“child.microsoft.com”。

完成后请单击“下一步”。

数据库和日志文件夹

在“数据库和日志文件文件夹”页面上，键入要安装数据库和日志文件夹的位置，或单击“浏览”选择位置。要避免安装或删除 Active Directory 过程中的任何问题，请确保您有足够的磁盘空间来容纳目录数据库和日志文件。“Active Directory 安装向导”需要 250 MB 的磁盘空间用于 Active Directory 数据库，50 MB 用于日志文件。建议将这些文件保存在 NTFS 分区上。

完成后请单击“下一步”。

共享的系统卷

在“共享的系统卷”页面上，键入要安装 Sysvol 文件夹的位置，或单击“浏览”选择位置。Sysvol 文件夹必须存储在 NTFS 卷上，因为它包含的文件将在域或林中的域控制器之间进行复制。这些文件包括脚本、Windows NT 4.0 和更低版本的系统策略、NETLOGON 和 SYSVOL 共享以及组策略设置。

完成后请单击“下一步”。

DNS 注册诊断

在“DNS 注册诊断”页面上，确认 DNS 设置是正确的。

如果“诊断结果”下出现诊断错误，请单击“帮助”以获得如何解决错误的详细信息。

完成后请单击“下一步”。

权限

在“权限”页面上，单击您所希望的与 Windows 2000 以前版本、Windows 2000 或 Windows Server 2003 操作系统的应用程序兼容性的级别。

在运行 Windows NT 4.0 及更低版本的服务器上，系统会将用户和组信息的读取权限指派给匿名用户，这样，现有的应用程序（包括 Microsoft BackOffice、SQL Server 和一些非 Microsoft 应用程序）就能正常工作。在 Windows 2000 和 Windows Server 2003 家族中，只有当 Anonymous Logon 组被添加到 Pre-Windows 2000 Compatible Access 组中时，Anonymous Logon 组的成员才具有读取该信息的权限。

选项 | 注释
与 Windows 2000 之前的服务器操作系统兼容的权限 | 如果您要将 Anonymous Logon 组与 Everyone 安全组添加至 Pre-Windows 2000 Compatible Access 组，请单击此选项。
只与 Windows 2000 或 Windows Server 2003 操作系统兼容的权限 | 单击该选项可防止 Anonymous Logon 组成员获得对用户或组信息的读权限。

选择这些选项之一后，您可以手动在 Active Directory 对象的向后兼容性设置和高安全性设置之间进行切换。为此，请打开“Active Directory 用户和计算机”，然后将 Anonymous Logon 安全组添加到 pre-Windows 2000 Compatible Access 安全组。

目录服务还原模式的管理员密码

在“目录服务还原模式的管理员密码”页面上，键入和确认要指派给该服务器的还原模式管理员帐户的密码。您应该使用强密码作为目录还原模式密码。详细信息，请参阅强密码。

要点

  • 您必须知道为该域控制器还原系统状态备份副本的密码。

当域控制器以目录服务还原模式启动时，需要使用该密码。如果是第一次在服务器上安装 Active Directory，请单击“Active Directory 帮助”以获得有关还原模式密码的详细信息。

完成后请单击“下一步”。

摘要

阅读“摘要”页上的信息，然后单击“下一步”。

完成安装后，请单击“完成”按钮。要重新启动计算机并执行更改，请单击“立即重新启动”。

完成“配置您的服务器向导”

服务器重新启动后，“配置您的服务器向导”将显示“此服务器现在是域控制器”页面。要查看“配置您的服务器向导”对服务器进行的所有更改或确保新角色已成功安装，请单击“‘配置您的服务器向导’日志”。“配置您的服务器向导”日志位于 systemroot\Debug\Configure Your Server.log。要关闭“配置您的服务器向导”，请单击“完成”。

删除域控制器角色

如果需要将服务器重新配置为另外一个角色，则可删除现有服务器角色。通过删除域控制器角色，您将从该服务器卸载 Active Directory。卸载 Active Directory 之后，该服务器将不再参与目录对象的复制和基于域的用户身份验证请求。

要删除域控制器角色，请执行以下操作之一重新启动“配置您的服务器向导”：

  • 从“管理您的服务器”中，单击“添加或删除角色”。默认情况下，“管理您的服务器”在您登录时自动启动。 XOX
  • XOX

在“服务器角色”页面上，单击“域控制器 (Active Directory)”，然后单击“下一步”。在“角色删除确认”页面上，检查“摘要”下列出的项目，选中“删除域控制器角色”复选框，单击“下一步”，然后按照 Active Directory 安装向导中的步骤进行操作。

后续步骤：完成其他任务

完成 Active Directory 安装向导后，服务器即被配置为域控制器。您可以使用域控制器存储数据、管理对象以及为用户、计算机和应用程序提供信息。此时，您已经创建了一个新域或为现有域创建了额外的域控制器。

下表列出了您可能要在域控制器上执行的一些其他任务。

任务 | 任务目的 | 参考
将新域控制器放置在上锁的房间内。 | 确保任何人都无法通过物理方式触及该域控制器。 | 域控制器；保护 Active Directory
使用强密码加密技术。 | 确保新域控制器的帐户密码信息的安全性。 | 系统密钥实用程序
要求所有域用户都使用强密码。 | 防止对组织未经授权的访问。 | 强密码
启用审核策略。 | 接收那些可能会造成安全隐患的操作的通知。 | 审核策略
对用户帐户强制实施帐户锁定。 | 减小攻击者通过重复登录企图危及您所在域安全的可能性。 | 用户和计算机帐户
对用户帐户强制实施密码历史。 | 减小攻击者危及您所在域安全的可能性。 | 强制实施密码历史
对用户帐户强制实施密码最长使用期限和密码最短使用期限。 | 减小攻击者危及您所在域安全的可能性。 | 密码最短使用期限；密码最长使用期限
实施 SID 筛选。 | 防止企图将提升的用户权限授予其他用户帐户的恶意用户的攻击。 | 位于 Microsoft网站 (http://www.microsoft.com/) 上的“Using Security Identifier (SID) Filtering to Prevent Elevation of Privilege Attacks”（使用安全标识符 (SID) 筛选来防止权限提升攻击）
使用智能卡。 | 提供防篡改用户身份验证和电子邮件安全。 | 智能卡概述
限制用户、组和计算机访问共享资源并筛选组策略设置。 | 确保资源安全。 | 安全组
将用户权限分配到新的安全组。 | 专门定义域中成员的管理角色。 | 将用户权限分配到 Active Directory 中的安全组


DNS 服务器角色：配置 DNS 服务器

域名系统 (DNS) 服务器主控分布式 DNS 数据库的记录，并使用它们主控的记录来解析 DNS 客户端计算机所发送的 DNS 名称查询，比如网站的名称查询或者网络或 Internet 上的计算机的查询。如果您计划使用该计算机来为网络中的计算机应答 DNS 查询，则请添加 DNS 服务器角色。

本主题说明为小型组织或大型组织的分支机构配置 DNS 服务器必须执行的基本步骤。对于这两种情况，本主题说明配置 DNS 服务器和根据网络 DNS 区域配置它必须执行的基本步骤。另外，本主题还将说明如何将外部资源的查询转发到由 Internet 服务提供商 (ISP) 运行的 DNS 服务器（如小型组织的情况），或由大型组织的总部运行的 DNS 服务器（如分支机构的情况）。

这个过程包括使用“配置您的服务器向导”、“配置新建 DNS 服务器向导”和“管理您的服务器”将服务器配置为 DNS 服务器。完成 DNS 服务器的设置后，可以根据想使用 DNS 服务器的方式来完成其他配置任务。

注意

  • DNS 服务器在小型组织中一般是不必要的，因为 Windows Internet 名称服务 (WINS) 名称解析方法用于找到网络资源，Internet 上的资源是使用 ISP 所运行的 DNS 服务器找到的。但是，由于越来越多的网络与 Internet 集成，DNS 在小型网络中也日益常见。

    在网络中使用 DNS 未必会要求您管理 DNS 结构。如果您拥有的是小型网络，其中的信息可以可靠地进行维护，您就可以选择让另一个精通 DNS 管理（比如政府或 ISP）的组织来管理您的 DNS 名称空间。在这种情况下，这个另外的组织就会托管您的 DNS 信息，或者将您的计算机和其网络中主控的现有 DNS 服务器集成在一起。

本主题包括：

开始之前

配置 DNS 服务器

后续步骤：完成其他任务

开始之前

将您的计算机配置为 DNS 服务器之前，请确保：

  • 正确配置操作系统。在 Windows Server 2003 家族中，DNS 服务器服务依赖于操作系统及其服务的适当配置，如 TCP/IP。如果您拥有的是全新安装的 Windows Server 2003 操作系统，则可以使用默认服务设置。没有必要执行进一步的操作。如果您的 Windows Server 2003 操作系统是通过升级安装的，或者如果您要确认是否已正确配置了服务以获得最佳性能与安全性，请参阅默认服务设置。
  • 分配所有可用磁盘空间。可以使用“磁盘管理”或 DiskPart.exe 从未分配的空间创建新的分区。详细信息，请参阅创建分区或逻辑驱动器。
  • 所有现有的磁盘卷都使用 NTFS 文件系统。FAT32 卷缺乏安全性，而且不支持文件和文件夹压缩、磁盘配额、文件加密或单个文件权限。

下表列出了在添加 DNS 服务器角色之前必须了解的信息。

对于所有组织
添加 DNS 服务器角色之前 | 注释
确定您是否要添加 DNS 服务器角色以支持 Active Directory。 | 如果您打算部署 Active Directory，那么，用于支持 Active Directory 的 DNS 服务器将由“Active Directory 安装向导”自动安装和配置。详细信息，请参阅第一台服务器的典型设置和域控制器角色：配置域控制器。
盘查您的网络和公司的安全策略，确定在 Internet 上传播 DNS 数据时可以如何维护这些策略。 | DNS 最初用作开放协议，因此容易受到攻击。Windows Server 2003 DNS 可以提供极其安全的 DNS 结构功能。要配置 DNS 以支持这些安全策略，请在设计和部署 DNS 服务器、区域和资源记录时确保公司的安全策略可行。详细信息，请参阅 DNS 的安全信息。
检查 DNS 清单。 | 请在清单：安装 DNS 服务器中复查该信息。
对于小型组织
添加 DNS 服务器角色之前 | 注释
为公司选择第一个 DNS 域名。 | 为公司选择第一个 DNS 域名时，应选择一个在 Internet 的 DNS 名称空间中唯一的域名。 如果您的组织有网站，请使用现有的网站名作为 DNS 域名的起始点。如果网站的名称是 www.humongousinsurance.com，则使用子域名“corp”对该名称进行扩展，创建出第一个域名，例如，corp.humongousinsurance.com。
检查 ISP 以确定网络 Internet 协议 (IP) 地址已在 Internet 注册机构中进行了注册。 | 为使 DNS 部署在 Internet 上能够运行，网络所使用的 IP 地址和 DNS 域名必须在授权的 Internet 注册机构中进行注册。这些组织负责分配 IP 地址和 DNS 域名以及保存分配的公共记录。 如果您连接到 Internet，您公司的网络很可能是 ISP 网络的子网。在这种情况下，子网的 IP 地址应事先已在 Internet 注册机构中进行了注册。
将 DNS 域名在 Internet 注册机构中进行注册。 | 注册公司将要使用的 DNS 域名，即使您将在私有网络中部署 DNS 也是如此。如果您不注册名称，并且随后尝试在 Internet 上使用它，或者连接到与 Internet 连接的网络，您可能会发现，由于其他公司已经注册了该名称，因此，您无法使用该名称。另外，您还可以让 ISP 为您注册 DNS 域名。 决定要采用的 DNS 域名后，请使用授权的 Internet 注册机构提供的一个网站，对 Internet 进行搜索以查看该域名是否可用。要在 Internet 中搜索可用的域名，请参阅 Internet 网络信息中心 (InterNIC) 网站。 XOX
确保该 DNS 服务器将主控的第一个 DNS 区域的名称与您注册的 DNS 域名相同。 | 配置 DNS 服务器角色时，需使用网络的 DNS 域的域名来定义该 DNS 服务器将主控的第一个 DNS 区域，比如，corp.humongousinsurance.com。
获得 ISP 主控的一台或多台 DNS 服务器的 IP 地址以便将其用作转发器。 | 为 DNS 服务器配置一个转发器，以便将不在您的网络中的名称查询发送到 ISP 的 DNS 服务器。
对于大型组织中的分支机构
添加 DNS 服务器角色之前 | 注释
从总部获得网络的 DNS 域名。 | 分支机构的第一个 DNS 域名是在总部的网络中所使用的域的子域。例如，如果总部使用域名 corp.humongousinsurance.com，则分支机构的 DNS 域名可以是 seattle.corp.humongousinsurance.com。始终都要确认 DNS 域名已经由总部正确指派。

配置 DNS 服务器

要配置 DNS 服务器，请通过完成下面的任一操作来启动“配置您的服务器向导”：

  • 从“管理服务器”中，单击“添加或删除角色”。默认情况下，“管理您的服务器”会在您登录时自动启动。 XOX
  • 要打开“配置您的服务器向导”，请单击“开始”，依次指向“所有程序”、“管理工具”，然后单击“配置您的服务器向导”。

在“服务器角色”页面上，单击“DNS 服务器”，然后单击“下一步”。

该部分包括：

选择摘要

设置静态 DNS 服务器 IP 地址

使用“配置 DNS 服务器向导”

完成“配置您的服务器向导”

删除 DNS 服务器角色

选择摘要

在“选择摘要”页面上查看和确认已经选择的选项。如果您在“服务器角色”页面上选择了“DNS 服务器”，就会出现下列内容：

  • 安装 DNS 服务器
  • 运行配置 DNS 服务器向导来配置 DNS

如果“选择摘要”页面列出这两个项目，请单击“下一步”。如果“选择摘要”页面没列出这两个项目，请单击“上一步”返回“服务器角色”页面，单击“DNS 服务器”，然后单击“下一步”。

设置静态 DNS 服务器 IP 地址

单击“下一步”后，“配置您的服务器向导”将会安装 DNS 服务器服务。在 DNS 服务器服务安装期间，“配置您的服务器向导”会决定该服务器的 IP 地址是静态的还是自动配置的。DNS 服务器是由 DNS 客户端使用静态 IP 地址定位的，自动配置的 IP 地址在 IP 地址更改时可能会导致 DNS 客户端出现问题。

如果该服务器当前被配置为自动获取其 IP 地址，“Windows 组件向导”的“正在配置组件”页面就会出现，提示您用静态 IP 地址配置该服务器。在“局域连接属性”对话框中，单击“Internet 协议 (TCP/IP)”，然后单击“属性”。在“Internet 协议 (TCP/IP) 属性”对话框中，单击“使用下面的 IP 地址”，然后键入该服务器的静态 IP 地址、子网掩码和默认网关。在“首选 DNS 服务器”中，键入该服务器的 IP 地址。在“备用 DNS 服务器”中，键入 ISP 或总部主控的 DNS 服务器的 IP 地址。当完成对 DNS 服务器静态地址的设置时，单击“确定”，然后单击“关闭”。

注意

  • 对于小型组织来说，该服务器的静态 IP 地址将用于向授权的 Internet 注册机构注册公司的 DNS 域名。Internet 注册机构将公司的 DNS 域名连同 IP 地址一起映射，以便 Internet 上对网络计算机进行搜索的计算机知道您网络的 DNS 服务器的 IP 地址。
  • 对于分支机构而言，该服务器的静态 IP 地址将用在组织总部的 DNS 服务器所配置的域名指派中。组织内和 Internet 上对您网络的计算机进行搜索的计算机会将 DNS 服务器的 IP 地址用于您的网络。因此，在添加了 DNS 服务器角色后千万不要更改该服务器的 IP 地址。

使用“配置 DNS 服务器向导”

单击“关闭”后，“配置 DNS 服务器向导”即启动。如果您取消“配置 DNS 服务器向导”，DNS 服务器服务仍保持安装，但它不能将 IP 地址分发给客户端，直到您创建了作用域为止。如果您选择以后创建作用域，则可以使用 DNS 控制台完成该操作。

本部分介绍“配置 DNS 服务器向导”中的以下步骤：

选择配置操作

主服务器位置

区域名称

动态更新

转发器

完成“配置 DNS 服务器向导”

选择配置操作

在“选择配置操作”页面上，选择“创建正向查找区域”，然后单击“下一步”。

主服务器位置

若要指定由该 DNS 服务器主控包含网络资源的 DNS 资源记录的 DNS 区域，请在“主服务器位置”页面上，选择“这台服务器维护该区域”，然后单击“下一步”。

区域名称

在“区域名称”页面上的“区域名”中，指定网络的 DNS 区域的名称，然后单击“下一步”。区域的名称与小型组织或分支机构的 DNS 域的名称相同。

动态更新

在“动态更新”页面上，单击“允许不安全和安全的动态更新”，然后单击“下一步”。这样，网络中资源的 DNS 资源记录便会自动更新。

转发器

在“转发器”页面上，单击“是，应当将查询转送到有下列 IP 地址的 DNS 服务器上”，然后单击“下一步”。选择该配置，就会将您网络之外的 DNS 名称的所有 DNS 查询都转发到位于 ISP 或总部的 DNS 服务器。键入由 ISP 或总部运行的 DNS 服务器所使用的一个或多个 IP 地址。

完成“配置 DNS 服务器向导”

在“配置 DNS 服务器向导”的“正在完成配置 DNS 服务器向导”页面上，可以单击“上一步”对设置进行任意更改。要应用您所选择的内容，请单击“完成”。

完成“配置您的服务器向导”

完成“配置 DNS 服务器向导”后，“配置您的服务器向导”会显示“此服务器现在是一个 DNS 服务器”页面。要复查由“配置您的服务器向导”对服务器所做的所有更改，或者要确保新的角色已成功安装，请单击“‘配置您的服务器向导’日志”。“配置您的服务器向导”日志位于 systemroot\Debug\Configure Your Server.log。要关闭“配置您的服务器向导”，请单击“完成”。

删除 DNS 服务器角色

如果需要将服务器重新配置为另外一个角色，则可删除现有服务器角色。如果您从该服务器中删除 DNS 服务器角色，就应该用其他 DNS 服务器的 IP 地址来配置该服务器的 TCP/IP 设置和所有用该服务器作为 DNS 服务器的客户端。

要删除 DNS 服务器角色，请通过完成下面的任一操作来重新启动“配置您的服务器向导”：

  • 从“管理服务器”中，单击“添加或删除角色”。默认情况下，“管理您的服务器”会在您登录时自动启动。 XOX
  • XOX

在“服务器角色”页面上，单击“DNS 服务器”，然后单击“下一步”。在“角色删除确认”页面上，检查“摘要”下所列的项目，选择“删除 DNS 服务器角色”复选框，然后单击“下一步”。单击“下一步”后，将出现 Windows 组件向导的“配置组件”页面，然后该页面将自动关闭。不能单击该页上的“上一步”或“下一步”。在“删除了 DNS 服务器角色”页面上，单击“完成”。

后续步骤：完成其他任务

完成“配置您的服务器向导”和“配置新建 DNS 服务器向导”的配置后，您的服务器就可以用作 DNS 服务器了。至此，您已经完成了以下任务：

  • 将 DNS 服务器设置为使用静态 IP 地址。
  • 为网络配置了 DNS 区域。
  • 将 DNS 服务器配置为将网络之外的 DNS 名称的所有 DNS 查询都转发到位于 ISP 或总部的 DNS 服务器。

完成“配置您的服务器向导”时，它会自动安装 DNS 控制台，您可使用该控制台来管理 DNS 服务器。 XOX

下表列出了可能需要在 DNS 服务器上执行的一些其他任务。

任务 | 任务目的 | 参考
将网络中的计算机配置为使用该 DNS 服务器作为其首选 DNS 服务器。 | 将 DNS 客户端与 DNS 服务器连接，并用名称解析所需要的 DNS 资源记录动态更新区域。 | 配置 TCP/IP 使用 DNS；动态更新
如果该服务器是多主计算机，就将 DNS 服务器服务配置为只对本地网络 IP 地址的查询进行响应。 | 保护 DNS 服务器不受外部查询的影响。例如，充当代理服务器的服务器可以有两个网络适配器，一个用于 Intranet，一个用于 Internet。如果该服务器还同时运行 Windows Server 2003 DNS 服务器服务，就可以将该服务配置为只使用 Intranet 网络适配器。通过将该服务器配置为只对本地网络 IP 地址的查询进行响应，能够保护服务器免受不必要的 Internet 查询的影响。 | 限制 DNS 服务器只侦听选定的地址
检查服务器配置。 | 确保使用“配置新建 DNS 服务器向导”所执行的 DNS 配置是正确的。 | 验证服务器配置
使用“nslookup”命令验证 DNS 服务器响应。 | 验证 DNS 服务器能够解析对网络资源的 DNS 查询。 | 使用 nslookup 命令验证 DNS 服务器的响应
确认资源记录在 DNS 中是否存在。 | 确认可以在网络中找到使用 DNS 服务器的计算机。 | 确认资源记录在 DNS 中是否存在


DHCP 服务器角色：配置 DHCP 服务器

DHCP 服务器集中管理 IP 地址和相关信息，并自动将其提供给客户端。这样，您就可以在服务器上配置客户端网络设置，而不是在每台客户端计算机上配置它们。如果您希望该计算机将 IP 地址分发给客户端，就要将该计算机配置为 DHCP 服务器。

本主题说明配置 DHCP 服务器所须执行的基本步骤。当您完成基本 DHCP 服务器的设置时，就可以根据希望使用 DHCP 服务器的方式，完成额外的配置任务。

本主题包括：

开始之前

配置 DHCP 服务器

后续步骤：完成其他任务

开始之前

将您的计算机配置为 DHCP 服务器之前，请确保：

  • 熟悉 DHCP 的一些概念，如作用域、租约和选项。详细信息，请参阅 DHCP 术语。
  • 正确配置操作系统。在 Windows Server 2003 家族中，DHCP 依赖于操作系统及其服务的适当配置。如果您拥有的是全新安装的 Windows Server 2003 操作系统，则可以使用默认服务设置。没有必要执行进一步的操作。如果您的 Windows Server 2003 操作系统是通过升级安装的，或者如果您要确认是否已正确配置了服务以获得最佳性能与安全性，请使用默认服务设置中的表来验证您的服务设置。
  • 此计算机有一个静态 IP 地址。详细信息，请参阅为静态寻址配置 TCP/IP。
  • 所有现有的磁盘卷都使用 NTFS 文件系统。FAT32 卷缺乏安全性，而且不支持文件和文件夹压缩、磁盘配额、文件加密或单个文件权限。

当您添加 DHCP 服务器角色时，会创建一个作用域，该作用域将定义 DHCP 服务器向一个子网上的客户端分发的 IP 地址范围。对于每个包含要用 DHCP 管理的客户端的子网，都需要创建一个作用域。下表列出了在添加 DHCP 服务器角色以便创建第一个作用域之前需要了解的信息。您需要为每个额外的作用域收集同样的信息。

添加 DHCP 服务器角色之前 | 注释
查阅 DHCP 的安全问题。 | 安全问题可能会影响您部署 DHCP 服务器的方式。有关 DHCP 安全性最佳操作的详细信息，请参阅 DHCP 的安全信息。
确定 DHCP 服务器应分发给客户端的 IP 地址范围。 | 使用组成本地 IP 子网的连续 IP 地址的全部范围。在许多情况下，专用地址范围是最佳选择。有关详细信息以及批准用于专用网络的所有 IP 地址范围的列表，请参阅位于 Internet 工程任务组网站上的 RFC 1918：“Address Allocation for Private Internets”（专用 Internet 的地址分配）。 XOX
为客户端确定正确的子网掩码。 | 当 DHCP 服务器将 IP 地址租借给客户端时，服务器可以指定其他配置信息，包括子网掩码。
确定 DHCP 服务器不应向客户端分发的所有 IP 地址。 | 例如，服务器或者与网络连接的打印机经常有静态的 IP 地址，DHCP 服务器不能将该地址提供给客户端。
决定 IP 地址的租用期限。 | 默认值为 8 天。通常，租用期限应等于该子网上的客户端的平均活动时间。例如，如果客户端是很少关闭的桌面计算机，理想的期限可以比 8 天长，如果客户端是经常离开网络或在子网之间移动的移动设备，该期限可以少于 8 天。
（可选）确定客户端应用来与其他子网上的客户端进行通讯的路由器（默认网关）的 IP 地址。 | 当 DHCP 服务器将 IP 地址租借给客户端时，服务器可以指定其他配置信息，包括路由器的 IP 地址。
（可选）确定客户端的 DNS 域名。 | 当 DHCP 服务器将 IP 地址租借给客户端时，服务器可以指定其他配置信息，包括客户端所属的 DNS 域的名称。
（可选）确定客户端应使用的 DNS 服务器的 IP 地址。 | 当 DHCP 服务器将 IP 地址租借给客户端时，服务器可以指定其他配置信息，包括客户端为解析其他计算机名称而应联系的 DNS 服务器的 IP 地址。
（可选）确定客户端应使用的 WINS 服务器的 IP 地址。 | 当 DHCP 服务器将 IP 地址租借给客户端时，服务器可以指定其他配置信息，包括客户端为解析其他计算机的 NetBIOS 名称而应联系的 WINS 服务器的 IP 地址。

配置 DHCP 服务器

要配置 DHCP 服务器，请通过完成下面的任一操作来启动“配置您的服务器向导”：

  • 在“管理您的服务器”中，单击“添加或删除角色”。默认情况下，“管理您的服务器”会在您登录时自动启动。 XOX
  • XOX

在“服务器角色”页面上，单击“DHCP 服务器”，然后单击“下一步”。

该部分包括：

选择摘要

使用“新建作用域向导”

完成“配置您的服务器向导”

删除 DHCP 服务器角色

选择摘要

在“选择摘要”页面上查看和确认已经选择的选项。如果在上一页面上选择了“DHCP 服务器”，则将出现下列内容：

  • 安装 DHCP 服务器
  • 运行新建作用域向导来配置一个新的 DHCP 作用域

要应用“选择摘要”页面上显示的选择，请单击“下一步”。单击“下一步”之后，将显示 Windows 组件向导的“正在配置组件”页面，随后该页面将自动关闭。不能单击该页上的“上一步”或“下一步”。

使用“新建作用域向导”

单击“下一步”后，“配置您的服务器向导”会安装 DHCP 服务器服务，然后启动“新建作用域向导”来收集信息并添加 DHCP 服务器角色。如果您取消“新建作用域向导”，DHCP 服务器服务仍处于已安装状态，但它不能将 IP 地址分发给客户端，直到您创建了作用域为止。如果您选择以后创建作用域，则可以使用 DHCP 控制台完成该操作。

该部分描述“新建作用域向导”中的下列步骤：

作用域名

IP 地址范围

添加排除的 IP 地址

租约期限

配置 DHCP 选项

路由器（默认网关）

域名和 DNS 服务器

WINS 服务器

激活作用域

完成“新建作用域向导”

作用域名

在“作用域名”页面上的“名称”中，键入要创建的作用域的名称。在“描述”框中，键入说明文字（可选）。大多数网络都具有若干个子网，每个子网都需要自己的作用域，因此，DHCP 服务器通常管理多个作用域。选择名称和描述将有助于区分多个作用域。

完成后请单击“下一步”。

IP 地址范围

在“IP 地址范围”页面上，通过键入该范围的起始 IP 地址和结束 IP 地址，定义此作用域中的 IP 地址范围。该向导使用您键入的 IP 地址来确定正确的子网掩码。正确的子网掩码会自动出现在“子网掩码”中。

在特殊情况下，即该子网上的客户端需要使用非向导提供的子网掩码时，您就必须在“子网掩码”中键入子网掩码，或者必须在“长度”中键入子网掩码的位数。

完成后请单击“下一步”。

添加排除的 IP 地址

在“添加排除”页面上，可以定义 DHCP 服务器不应分发给客户端的 IP 地址。例如，DHCP 服务器自身具有不可以分发给客户端的静态 IP 地址。默认网关和各种网络设备都如此，比如与网络连接的打印机。必须排除这些 IP 地址，DHCP 服务器才不会将它们分发给客户端。

建议排除的 IP 地址的数量应多于当前需要排除的数量，因为缩小排除范围比扩大排除范围容易。排除 IP 地址要从可能的 IP 地址范围的开头和结尾处进行，而不是从中间进行。例如，如果该子网上的 IP 地址范围是 10.0.0.1 到 10.0.0.255，并且您希望排除 10 个 IP 地址，则可按照如下两种方案之一定义排除范围：

  • 10.0.0.1 到 10.0.0.10
  • 10.0.0.245 到 10.0.0.255

对于每个要排除的 IP 地址范围，请在“起始 IP 地址”中键入位于范围起始处的 IP 地址，在“结束 IP 地址”中键入位于范围结尾处的 IP 地址，然后单击“添加”。

该步骤方便了客户端管理，但它是可选的。如果您将该页的所有字段留空并单击“下一步”，客户端将仍然能够从 DHCP 服务器获得 IP 地址。

完成后请单击“下一步”。

租约期限

在“租约期限”页面上，可以定义客户端可使用该作用域的 IP 地址的时间。

DHCP 服务器将 IP 地址租借给它的客户端。每个租约都有到期日和到期时间。如果客户端要继续使用该 IP 地址，就必须续订租约。默认的租约期限是 8 天。

该步骤方便了客户端管理，但它是可选的。如果您将该页的所有字段留空并单击“下一步”，客户端将仍然能够从 DHCP 服务器获得 IP 地址。

完成后请单击“下一步”。

配置 DHCP 选项

在“配置 DHCP 选项”页面上，可以指定是否配置 DHCP 选项。

建议您接受默认设置，即“是，我想现在配置这些选项”，单击“下一步”，即使您不想配置这些选项也是如此。 如果您选择“否，我想稍后配置这些选项”，则会发生下列情况：

  • “新建作用域向导”创建作用域，但不会激活它，您必须使用 DHCP 控制台来激活作用域，这样客户端才能接收来自该作用域的 IP 地址。有关如何使用 DHCP 控制台激活作用域的信息，请参阅激活作用域。
  • 下面描述的后续四个向导页您是看不见的。请继续阅读完成“新建作用域向导”。

路由器（默认网关）

在“路由器（默认网关）”页面上，可以指定客户端使用的路由器（也称为默认网关）。可以添加和该子网上的路由器数量一样多的 IP 地址。

该步骤方便了客户端管理，但它是可选的。如果您将该页的所有字段留空并单击“下一步”，客户端将仍然能够从 DHCP 服务器获得 IP 地址。

完成后请单击“下一步”。

域名和 DNS 服务器

在“域名称和 DNS 服务器”页面上，可以指定该子网上的客户端在解析 DNS 名称时应使用的域的名称。

也可以指定客户端解析 DNS 名称应使用的 DNS 服务器。可以键入 DNS 服务器的 IP 地址，也可以键入其名称并单击“解析”，向导将为您确定 IP 地址。可以添加多个 DNS 服务器。

该步骤方便了客户端管理，但它是可选的。如果您将该页的所有字段留空并单击“下一步”，客户端将仍然能够从 DHCP 服务器获得 IP 地址。

完成后请单击“下一步”。

WINS 服务器

在“WINS 服务器”页面上，可以指定客户端为注册和解析 NetBIOS 名称与之通讯的 WINS 服务器。可以键入 WINS 服务器的 IP 地址，也可以键入其名称并单击“解析”，向导将为您确定 IP 地址。可以添加多个 WINS 服务器。

该步骤方便了客户端管理，但它是可选的。如果您将该页的所有字段留空并单击“下一步”，客户端将仍然能够从 DHCP 服务器获得 IP 地址。

完成后请单击“下一步”。

激活作用域

在“激活作用域”页面上，可以激活作用域或选择以后激活它。大多数情况下，应接受默认设置并立即激活作用域。如果您选择以后激活作用域，可以使用 DHCP 控制台完成该操作。激活作用域之后，该作用域的子网上的客户端才能从 DHCP 服务器获得 IP 地址。

完成后请单击“下一步”。

完成“新建作用域向导”

在“正在完成新建作用域向导”页面上，可以单击“上一步”以更改任何设置。要应用您选择的内容，请单击“完成”。

完成“配置您的服务器向导”

完成“新建作用域向导”后，“配置您的服务器向导”会显示“此服务器现在是 DHCP 服务器”页面。要复查由“配置您的服务器向导”对服务器所做的所有更改，或者要确保新的角色已成功安装，请单击“‘配置您的服务器向导’日志”。“配置您的服务器向导”日志位于 systemroot\Debug\Configure Your Server.log。要关闭“配置您的服务器向导”，请单击“完成”。

删除 DHCP 服务器角色

如果需要将服务器重新配置为另外一个角色，则可删除现有服务器角色。如果您删除 DHCP 服务器角色，就必须重新配置客户端才能从其他 DHCP 服务器获得 IP 地址。另外，如果您希望客户端继续使用该服务器分发的 IP 地址，就必须配置另一台 DHCP 服务器来分发这些地址。

要删除 DHCP 服务器角色，请通过完成下面的任一操作来重新启动“配置您的服务器向导”：

  • 从“管理服务器”中，单击“添加或删除角色”。默认情况下，“管理您的服务器”会在您登录时自动启动。 XOX
  • XOX

在“服务器角色”页面上，单击“DHCP 服务器”，然后单击“下一步”。在“角色删除确认”页面上，检查“摘要”下所列的项目，选中“删除 DHCP 服务器角色”复选框，然后单击“下一步”。单击“下一步”之后，将显示 Windows 组件向导的“正在配置组件”页面，该页面随后将自动关闭。不能单击该页上的“上一步”或“下一步”。在“删除了 DHCP 服务器角色”页面上，单击“完成”。

后续步骤：完成其他任务

完成“配置您的服务器向导”后，计算机就可以用作管理 IP 地址和相关信息的基本 DHCP 服务器了。至此，您已经安装了 DHCP 服务器服务，并创建了一个用于管理一个子网上的客户端的 IP 地址和相关信息的作用域。如果您想管理其他子网上的客户端，必须创建额外的作用域。如果您还未激活作用域，则必须激活它，以便该作用域的子网上的客户端能够从 DHCP 服务器获得 IP 地址。

完成“配置您的服务器向导”时，它会自动安装 DHCP 控制台，您可使用该控制台来管理 DHCP 服务器。 XOX

下表列出了可能需要在 DHCP 服务器上执行的一些其他任务。

任务 | 任务目的 | 参考
激活现有的作用域。 | 激活用“新建作用域向导”创建、但目前不处于活动状态的作用域。 | 激活作用域
在 Active Directory 中授权 DHCP 服务器。 | 检测未授权的 DHCP 服务器并防止这些服务器在网络上启动或运行。 | 授权 DHCP 服务器
添加对路由网络的支持。 | 允许 DHCP 服务器充当中继代理，在子网之间转发 DHCP 消息。 | 配置 DHCP 中继代理
指派基于服务器的作用域选项。 | 通过设置所有新作用域均将继承的默认值来简化管理。 | 指派基于服务器的选项
更改或查看作用域属性。 | 更改或查看现有作用域的属性。 | 更改或查看作用域属性
创建新作用域。 | 创建支持其他子网上客户端的作用域。 | 新建作用域
添加客户端保留的 IP 地址。 | 定义因另一台客户端永久使用致使 DHCP 服务器不应分发给客户端的 IP 地址。 | 添加客户端保留的 IP 地址


流式媒体服务器角色：配置流式媒体服务器

可以使用 Windows Media Services 将流式音频和视频内容通过 Internet 或 Intranet 传输到客户端。客户端可以是使用播放机（例如，Windows Media Player）播放内容的计算机或设备，也可以是运行 Windows Media Services 的计算机（称为 Windows Media 服务器），它们代理、缓存或重新分发内容。另外，客户端还可以是用 Windows Media 软件开发工具包 (SDK) 开发的自定义应用程序。

如果希望该计算机将音频和视频内容流提供给客户端和其他 Windows Media 服务器，那么可将该计算机配置为流式媒体服务器。

注意

  • XOX
  • XOX

本主题说明配置流式媒体服务器必须执行的基本步骤。完成这些基本步骤后，您就可以根据需要来使用流式媒体服务器完成其他配置任务。

本主题包括：

开始之前

配置流式媒体服务器

后续步骤：完成其他任务

开始之前

将计算机配置为流式媒体服务器之前，请确认：

  • 是否正确配置了操作系统。在 Windows Server 2003 家族中，Windows Media Services 依赖于操作系统及其服务的适当配置。如果您拥有的是全新安装的 Windows Server 2003 操作系统，则可以使用默认服务设置。没有必要执行进一步的操作。如果您的 Windows Server 2003 操作系统是通过升级安装的，或者如果您要确认是否已正确配置了服务以获得最佳性能与安全性，请使用默认服务设置中的表来验证您的服务设置。
  • 所有现有的磁盘卷都使用 NTFS 文件系统。FAT32 卷缺乏安全性，而且不支持文件和文件夹压缩、磁盘配额、文件加密或单个文件权限。

配置流式媒体服务器

要配置流式媒体服务器，请通过执行以下任一操作来启动“配置您的服务器向导”：

  • 从“管理您的服务器”中，单击“添加或删除角色”。默认情况下，登录时将自动启动“管理您的服务器”。 XOX
  • XOX

在“服务器角色”页面上，单击“流式媒体服务器”，然后单击“下一步”。

该部分包括：

选择摘要

完成“配置您的服务器向导”

完成流式媒体服务器角色配置

删除流式媒体服务器角色

选择摘要

在“选择摘要”页面上，查看和确认已经选择的选项。如果在“服务器角色”页面上选择“流式媒体服务器”，将出现以下内容：

  • 安装 Windows Media Services

要应用“选择摘要”页面上显示的选择，请单击“下一步”。单击“下一步”之后，将显示“Windows 组件向导”的“正在配置组件”页面，随后便自动关闭。不能单击该页上的“上一步”或“下一步”。

在“选择摘要”页面上单击“下一步”后，“配置您的服务器向导”将安装 Windows Media Services。与许多其他服务不同，Windows Media Services 无需管理员进行任何输入就可以安装。

完成“配置您的服务器向导”

组件配置完之后，“配置您的服务器向导”将显示“此服务器现在是流式媒体服务器”页面。要复查由“配置您的服务器向导”对服务器所做的所有更改，或者要确保新的角色已成功安装，请单击“‘配置您的服务器’日志”。“配置您的服务器向导”日志位于 systemroot\Debug\Configure Your Server.log。要关闭“配置您的服务器向导”，请单击“完成”。

完成流式媒体服务器角色配置

完成“配置您的服务器向导”之后，计算机就可以用作基本的流式媒体服务器，它可以将内容提供给客户端和其他流式媒体服务器。通常需要其他配置，具体步骤取决于您的需求。本部分说明为配置流式媒体服务器所必须采取的基本决策。

注意

  • 如果已在该计算机上安装了 Windows Media Services，就可以查看 Windows Media Services 帮助。要打开 Windows Media Services 帮助，请依次单击“开始”、“运行”，然后键入 hh wmserver.chm。

流式媒体服务器角色支持多个方案，在 Windows Media Services 帮助中有详细描述。详细信息，请参阅 Windows Media Services 帮助中的“方案”。大多数方案都要求重新配置现有的发布点或创建新的发布点。您需要作出一个决策，也可能是两个，最终取决于您使用三个主要发布点配置中的哪个。下表显示了决策与配置的相关性。

如果您 | 您希望使用 | 使用该发布点配置
希望客户端控制播放 | 每个客户端一个服务器连接 | 点播、单播
不希望客户端控制播放 | 每个客户端一个服务器连接 | 单播广播
不希望客户端控制播放 | 所有客户端共享一个服务器连接 | 多播广播

播放控制

播放控制意味着客户端应能够执行开始、停止、暂停、倒带和快进操作。使用点播、单播和客户端控制播放，用户的体验类似于通过 VCR 或 DVD 播放机播放电影。此类播放需要点播发布点。点播发布点分发预先记录的内容，例如音频和视频文件。添加流式媒体服务器角色时，该向导会创建名为“<Default>”的点播发布点。可以在该发布点分发媒体文件，也可以创建发布点。点播发布点的配置步骤与 indows Media Services 帮助中的“根据点播传输 Windows Media 文件”中所描述的步骤类似。如果选择使用点播发布点，就必须使用单播传递。

如果客户端不控制播放，用户的体验就类似于观看电视节目。此类播放需要广播发布点。广播发布点分发预先记录和实况转播的内容。当添加流式媒体服务器角色时，该向导会创建名为“Sample_Broadcast”的广播发布点，其中包含示例内容。请不要对该示例进行任何改动，并创建一个新的广播发布点。如果选择创建广播发布点，请参阅服务器连接。

有关点播和广播发布点类型的详细信息，请参阅 Windows Media Services 帮助中的“关于发布点类型”。

服务器连接

通过单播广播，服务器将对每个客户端创建一个单独的连接。由此可能导致单播传递消耗大量的网络带宽。例如，将同样的内容传递给 100 个客户端所消耗的网络带宽是传递给一个客户端的 100 倍。但是，单播传递不需要对网络路由器和交换器进行任何配置。以这种方式配置发布点的步骤与 Windows Media Services 帮助中的“使用服务器发布来自 Windows Media Encoder 的实况内容”中所描述的步骤类似。有关单播传递的详细信息，请参阅 Windows Media Services 帮助中的“以单播流方式传递内容”。

通过多播广播，服务器不会创建与任何客户端的连接。相反，服务器会将内容传递到网络上的 D 类 Internet 协议 (IP) 地址，网络上的任何客户端均可接收到此内容。这样会节省网络带宽。例如，多播传递给 100 个客户端所消耗的带宽仅相当于传递给一个客户端所消耗的带宽。但是，默认情况下，许多网络不支持多播传递。要支持多播传递，必须将服务器和客户端之间的网络路由器和交换器配置为传输 D 类 IP 地址并能解释多播信息包。以这种方式配置发布点的步骤与 Windows Media Services 帮助中的“使用服务器广播由 Windows Media Encoder 发布的流”中所描述的步骤类似。有关多播传递的详细信息，请参阅 Windows Media Services 帮助中的“以多播流方式传递内容”。

删除流式媒体服务器角色

如果需要将服务器重新配置为其他角色，则可删除现有服务器角色。如果删除流式媒体服务器角色，客户端将无法再与该服务器的发布点连接，并且编码器也将无法再通过服务器发送媒体流。只有在该服务器上存储或分发的内容才不可用。

要删除流式媒体服务器角色，请通过执行以下任一操作来重新启动“配置您的服务器向导”：

  • 从“管理服务器”中，单击“添加或删除角色”。默认情况下，在您登录时将自动启动“管理您的服务器”。 XOX
  • XOX

在“服务器角色”页面上，单击“流式媒体服务器”，然后单击“下一步”。在“角色删除确认”页面上，检查“摘要”下面所列的项目，选择“删除流式媒体服务器角色”复选框，然后单击“下一步”。单击“下一步”之后，将显示“Windows 组件向导”的“正在配置组件”页面，随后便自动关闭。不能单击该页上的“上一步”或“下一步”。在“删除了流式媒体服务器角色”页面上，单击“完成”。

后续步骤：完成其他任务

至此，您已安装了 Windows Media Services。此次安装将 Windows Media Services 添加到您的服务器、安装了帮助文件并且创建了两个包含示例内容的发布点。

下表列出了可能需要在流式媒体服务器上执行的一些其他任务。

任务 | 任务目的 | 参考
配置安全选项。 | 控制对流式媒体服务器及其内容的访问。 | Windows Media Services 帮助中的“配置安全选项”
浏览。 | 进一步熟悉 Windows Media Services 的功能。 | 依次单击“开始”、“运行”，然后键入 %systemroot%\system32\windows media\server\admin\mmc\hta\tour_.hta。
查看流式媒体服术语和概念。 | 进一步熟悉流式媒体的概念，例如单播和多播、点播和广播，以及存档、发布点和发布内容。 | Windows Media Services 帮助中的“了解术语”
确定所需的流式媒体服务器数量 | 提前计划需要安装的服务器数量。 | Windows Media Services 帮助中的“设置流式媒体系统”、“规划您的能力”
识别端口冲突。 | 防止 Windows Media Services 在尝试使用和 Web 服务器同样的 TCP 端口时发生问题。 | Windows Media Services 帮助中的“在同一计算机上使用 HTTP 流式播放和其他服务”
查看有关升级 Windows Media Services 早期版本的说明。 | 确保您了解如何升级运行 Windows Media Services 早期版本的其他服务器。 | Windows Media Services 帮助中的“升级 Windows Media Services”
启用 Windows Audio 服务。 | 默认情况下，在全新安装的 XOX 或 XOX 上禁用 Windows Audio 服务。这样不会阻止服务器将流式音频传送给客户端，但为了在服务器上测试内容播放，应启用音频。 | 为硬件配置文件启用或禁用服务
启动 Windows Media Services 的管理界面。 | 配置流式媒体服务器。 | 依次单击“开始”、“运行”，然后键入 %systemroot%\system32\windows media\server\admin\mmc\wmsadmin.msc。
管理流式媒体服务器。 | 配置流式媒体服务器，以便通过 Intranet 或 Internet 传送内容。在开始传送内容之前，必须为运行 Windows Media Services 的服务器配置设置，添加并配置发布点，设置内容。 | Windows Media Services 帮助中的“管理 Windows Media 服务器
记录数据和事件。 | 记录与您的内容连接的客户端活动。 | Windows Media Services 帮助中的“记录数据和事件”
管理和生成内容。 | 不同项目的内容管理方法和优先级会有所不同，具体取决于多种因素（例如，观众人数统计、内容类型、可用设备和部署者经验）。 | Windows Media Services 帮助中的“内容管理和生成”
确定如何从 Windows Media 编码器中获取内容。 | 决定是配置编码器以便向服务器发送流，还是配置服务器从编码器中拉出流。 | Windows Media Services 帮助中的“源自编码器”
实施缓存/代理系统。 | 存储最近传送的内容，以供寻找同样资料的其他客户端使用。在实况广播中，缓存/代理服务器可以执行称为“流拆分”的任务，该任务允许许多单播客户端在只有单个流从源服务器中发送时接收内容。 | Windows Media Services 帮助中的“实施缓存/代理系统”


WINS 服务器角色：配置 WINS 服务器

Windows Internet 名称服务 (WINS) 服务器将 IP 地址动态地映射到计算机名称（NetBIOS 名称）。这允许用户通过计算机名而不是通过 IP 地址来访问资源。如果希望该计算机跟踪网络中其他计算机的名称和 IP 地址，那么请将该计算机配置为 WINS 服务器。

本主题说明配置 WINS 服务器必须执行的基本步骤。当您完成基本 WINS 服务器的设置后，就可以根据要使用 WINS 服务器的方式来完成其他配置任务。

本主题包含：

开始之前

配置 WINS 服务器

下一步：完成其他任务

开始之前

将服务器配置为 WINS 服务器之前，请验证是否：

  • 熟悉 WINS 概念，比如 NetBIOS 名称、WINS 服务器、WINS 客户端和复制伙伴。详细信息，请参阅了解 WINS。
  • 正确配置操作系统。在 Windows Server 2003 家族中，WINS 依赖于操作系统及其服务的适当配置。如果您的 Windows Server 2003 家族产品采用的是全新安装，则可以使用默认服务设置。没有必要执行进一步的操作。如果您采用的是升级到 Windows Server 2003 家族产品，或者如果您要确认是否为最佳性能和安全性正确配置了服务，则可使用服务的默认设置中的表格验证服务设置。
  • 您知道需要安装多少台 WINS 服务器以及在网络上每台服务器的位置。当添加 WINS 服务器角色时，配置该服务器以维护计算机名称和 IP 地址的数据库。在大型网络中，可能需要将 WINS 服务器角色添加到其他服务器上，以确保客户端计算机总是可以访问至少一台 WINS 服务器。详细信息，请参阅规划 WINS 网络。
  • 该计算机有一个静态 IP 地址。详细信息，请参阅为静态寻址配置 TCP/IP。
  • 所有现有的磁盘卷都使用 NTFS 文件系统。FAT32 卷缺乏安全性，而且不支持文件和文件夹压缩、磁盘配额、文件加密或单个文件权限。

配置 WINS 服务器

要配置 WINS 服务器，请通过完成下面的任一操作来启动“配置您的服务器向导”：

  • 从“管理服务器”中，单击“添加或删除角色”。默认情况下，在您登录时将自动启动“管理您的服务器”。XOX
  • XOX

在“服务器角色”页面上，单击“WINS 服务器”，然后单击“下一步”。

选择摘要

完成“配置您的服务器向导”

删除 WINS 服务器角色

选择摘要

请在“选择摘要”页面上查看和确认已经选择的选项。如果在上一页面上选择了“WINS 服务器”，则将出现下列内容：

  • 安装 WINS

要应用“选择摘要”页面上显示的选择，请单击“下一步”。单击“下一步”后，将出现 Windows 组件向导的“正在配置组件”页面，然后自动关闭。不能单击该页上的“上一步”或“下一步”。“配置您的服务器向导”将会安装 WINS Server 服务。和许多其他服务不同，WINS 服务无需管理员进行任何输入就可以安装。

如果取消“配置您的服务器”，则 WINS Server 服务就不会安装。若要以后安装它，则需要重新启动“管理您的服务器”并添加 WINS 角色。

完成“配置您的服务器向导”

组件配置完成后，“配置您的服务器向导”会显示“此服务器现在是一个 WINS 服务器”页面。要查看由“配置您的服务器向导”对服务器所做的所有更改，或者要确保新的角色已成功安装，请单击“‘配置您的服务器向导’日志”。“配置您的服务器向导”日志位于 systemroot\Debug\Configure Your Server.log 中。要关闭“配置您的服务器向导”，请单击“完成”。

删除 WINS 服务器角色

如果需要将服务器重新配置为另外一个角色，则可删除现有服务器角色。如果删除 WINS 服务器角色，并且该服务器是客户端可用来注册和解析计算机名的唯一 WINS 服务器，则需要将 WINS 角色添加到另一台服务器上。而且，如果该服务器配置为与其他 WINS 服务器一起复制 WINS 数据库信息，则必须在那些其他 WINS 服务器上重新配置复制。

要删除 WINS 服务器角色，请通过完成下面的任一操作来重新启动“配置您的服务器向导”：

  • 从“管理您的服务器”中，单击“添加或删除角色”。默认情况下，在您登录时将自动启动“管理您的服务器”。XOX
  • XOX

在“服务器角色”页面上，单击“WINS 服务器”，然后单击“下一步”。在“角色删除确认”页面上，检查“摘要”下所列的项目，选中“删除 WINS 服务器角色”复选框，然后单击“下一步”。在“删除了 WINS 服务器角色”页面上，单击“完成”。

下一步：完成其他任务

在完成“配置您的服务器向导”后，计算机即可用作基本 WINS 服务器。它可以跟踪服务器 IP 地址，在客户端提出请求时提供该信息。至此，您已经在一台服务器上安装了 WINS Server 服务。如果希望在复杂的网络上支持 WINS 客户端，则可能需要在其他子网上安装其他 WINS 服务器。

下表列出了可能需要在 WINS 服务器上执行的一些其他任务。

任务 | 任务目的 | 参考
查看在服务器上注册的 WINS 名称记录。 | 验证 WINS 服务器是否正常工作。 | 查找并查看 WINS 记录
修改 WINS 服务器默认设置。 | WINS 使用几个默认服务器配置参数，决定如何在 WINS 服务器数据库中管理 NetBIOS 名称记录。这些参数通常是可接受的。在特殊环境下，比如当必须更改主机名或者当您重新对网络编号以使客户端和服务器使用另外一组 IP 地址时，可能需要修改它们。 | 修改服务器默认值
在首选和辅助 WINS 服务器上配置复制设置。 | WINS 服务器将数据库更改互相复制，以便每台 WINS 服务器都有关于网络上的服务器及每台服务器的 IP 地址的相同信息。 | 配置 WINS 复制；配置复制


删除服务器角色

Microsoft Windows 图形

删除服务器角色

  1. 打开 管理您的服务器。
  2. 在“管理您的服务器角色”下，单击“添加或删除角色”。
  3. 在“配置您的服务器向导”中的“预备步骤”页面上，单击“下一步”。
  4. 在“服务器角色”页面上，单击您要删除的角色，然后单击“下一步”。
  5. 在“角色删除确认”页面上，选中“删除服务器角色”复选框，然后单击“下一步”。
  6. 在“删除了服务器角色”页面上，单击“完成”。

要点

  • 当您删除服务器角色时，可能会破坏服务器角色和其他程序之间存在的依赖关系。在网络中删除服务器角色之前，请确保先在测试环境中对服务器角色的删除进行测试。

注意

  • XOX
  • XOX
  • 有关删除具体服务器角色和可能影响的依赖关系的详细信息，请参阅以下内容：

    删除文件服务器角色

    删除打印服务器角色

    删除应用程序服务器角色

    删除邮件服务器角色

    删除终端服务器角色

    删除远程访问/VPN 服务器角色

    删除域控制器角色

    删除 DNS 服务器角色

    删除 DHCP 服务器角色

    删除流式媒体服务器角色

    删除 WINS 服务器角色


清单：配置第一台服务器的典型设置

步骤 | 参考
了解 Active Directory 的重要概念。 | Active Directory 概述
了解 DNS 的重要概念。 | DNS 概述
了解 DHCP 的重要概念。 | DHCP 概述
了解“路由”和“远程访问”的重要概念。 | 路由概述；远程访问概述
了解 Active Directory 中应用程序目录分区的重要概念。 | 应用程序目录分区
决定 DNS 域名称空间规划。因为 Active Directory 和名称空间有同样的结构，名称空间计划对于 Active Directory 的顺利部署至关重要。另外，如果您的网络需要出现在 Internet 上，请确认您是否有一个已注册的 Internet 域名。 | DNS 的名称空间规划
确认服务器有 NTFS 分区。 | 查看卷的属性
决定服务器可以管辖的 DNS 区域名称。如果您正在设置有多台计算机与 Internet 连接的小型网络（比如，家庭办公室），您还需要为 Internet 服务提供商提供 DNS 服务器的 IP 地址。 | 了解区域和区域传送；动态更新；使用转发器
对 DNS 服务器进行额外的配置更改或安装额外的 DNS 服务器。 | 清单：安装 DNS 服务器；配置全新的 DNS 服务器
为 DHCP 服务器配置额外的选项。 | 清单：安装 DHCP 服务器
（可选）监视和衡量 DNS 服务器的各个方面，以防止性能降低并对其进行故障排除。 | 监视 DNS 服务器的性能
（可选）监视和衡量 DHCP 服务器的各个方面，以防止性能降低并对其进行故障排除。 | 监视 DHCP 服务器的性能；DHCP 性能监视参考
（可选）安装和配置额外的域控制器。 | 清单：在现有域中创建其他域控制器
（可选）为域管理选择合适的安全级别。 | 使用 Active Directory 安装向导


预备步骤：配置服务器角色

下面的链接提供了有关在配置服务器角色前需要执行的预备步骤的详细信息。

步骤 | 参考
安装所有调制解调器和网卡。 | 安装调制解调器；安装设备概述
连接所有必要的电缆。 | 参照服务器制造商提供的文档。
连接到 Internet。 | 建立 Internet 连接
打开所有外围设备，比如打印机或外部驱动器。 | 添加与您的计算机连接的打印机；安装设备概述
具有随 Windows Server 2003 操作系统一起提供的安装 CD，或者知道网络安装路径。 | 如果您使用网络路径远程安装操作系统，而不是使用随 Windows Server 2003 操作系统一起提供的安装 CD，则在配置服务器时需要使用同样的网络路径。


管理备份作业

“管理备份作业”任务板允许您使用 Windows Backup Utility 在 Windows Server 计算机上添加和管理备份作业。也可使用该实用程序将已归档的数据恢复到服务器计算机上。

任务 | 描述
启动备份向导 | 启动 Windows Backup Utility，它允许您指定数据备份或进行恢复。

有关详细信息，请参阅联机帮助中的备份概述。


管理共享文件夹

使用“管理共享文件夹”任务板可以在 Windows Server 计算机上查看和管理共享文件夹。以下部分将详细介绍此任务板上可用的任务。有些任务只对选定的共享文件夹可用。

任务 | 描述
添加共享文件夹 | 启动“添加共享文件夹向导”，该向导会在 Windows 服务器计算机上添加新的共享文件夹，并在其上设置访问权限。
更改共享文件夹属性 | 允许您修改选定文件夹的属性，如名称、路径、连接限制和权限。还允许您在 Active Directory 中发布文件夹。
停止共享 | 停止共享选定的文件夹。将无法删除该文件夹和所有附带的数据。

有关详细信息，请参阅联机帮助中的共享文件夹。


管理打印机

使用“管理打印机”任务板可以管理网络上的打印机。下面的部分将详细介绍此任务板上可用的任务。有些任务只对选定的打印机可用。

任务 | 描述
添加打印机 | 启动“添加打印机向导”，它允许您向 Windows Server 计算机添加本地或网络打印机。打印设备必须已经连接好。
更改打印机属性 | 允许您修改选定打印机的选项，如名称、路径、权限和其他高级属性。
管理打印机作业 | 允许取消、暂停或恢复所选打印机的队列中的打印作业。

有关详细信息，请参阅联机帮助中的打印概述。


服务器管理

服务器管理基于 Microsoft Management Console 2.0，专供域管理员使用，它包含基本日常管理所必需的管理单元和工具。使用控制台树，可以从菜单栏或通过右键单击菜单来导航管理单元结构和访问工具。在详细信息窗格中，可通过使用任务板任务或右键单击菜单来访问工具。

服务器管理预先配置有以下管理工具：

工具 | 描述
主页 | 为服务器管理中的主控制台工具提供图标快捷方式。
共享文件夹 | 允许您管理服务器上的共享文件夹。
用户 | 允许您添加和管理网络用户帐户。
打印机 | 允许您管理本地和网络打印机。
备份 | 允许您对服务器进行备份。


管理用户

使用“管理用户”任务板可以管理、创建和修改 Windows Server 用户帐户。以下部分将详细介绍此任务板上可用的任务。有些任务只对选定的用户帐户可用。

任务 | 描述
添加用户 | 启动“添加用户向导”，它允许从一处指定若干帐户选项，从而简化用户帐户的创建。
更改密码 | 允许为选定用户更改或重新设置网络密码。
将用户添加到组中 | 允许为选定用户指定其他安全性或分布式组成员身份。
启用帐户 | 启用选定的用户帐户。当已禁用的用户帐户被启用时，用户将能够登录网络并访问网络资源，如电子邮件或打印机。
禁用帐户 | 禁用选定的用户帐户。当帐户被禁用时，用户无法登录网络或访问网络资源，如电子邮件或打印机。用户帐户并未被删除。
更改用户属性 | 允许您查看和修改选定用户的属性，如帐户信息、配置文件和远程访问。
删除用户 | 永久删除选定的用户帐户。帐户一旦删除，就无法恢复。系统会要求您进行确认。

有关详细信息，请参阅联机帮助中的用户和组帐户。