入门

“入门”主题提供了有关新功能的信息，此外，还提供了可帮助您安装或升级具有 1 到 5 台服务器以及 100 台或略少客户端的网络的信息。

本指南内容

  • 有关部署的分步指导
  • Microsoft Windows Server 2003 R2 中的新功能
  • 新功能
  • 安装和升级操作系统
  • 在群集节点上安装和升级
  • 配置服务器角色
  • Windows 产品激活

如果您是大型服务器集合的管理员，请参阅位于 Microsoft Windows 资源工具包网站的“Windows Server 2003 Deployment Kit”（Windows Server 2003 部署工具包）。(http://www.microsoft.com/)

有关获得“Windows 部署和资源工具包”的信息，请参阅 Windows 部署和资源工具包。

要访问有关使用和维护 Windows Server 操作系统的其他资源和服务，请参阅 Windows Server 2003 TechCenter。(http://go.microsoft.com/fwlink/?LinkID=34402)


有关部署的分步指导

Microsoft 网站提供了可用于了解和部署操作系统的教程。这些技术演练提供了安装和配置关键功能的分步指导和插图。

可从 Microsoft 网站 (http://www.microsoft.com/) 访问这些分步指导。

以下列表包括了这些指导中的一些主题：

结构

  • 构建常见的网络结构

Active Directory

  • 设置额外的域控制器
  • 委派对象控制
  • 管理 Active Directory
  • 管理复制拓扑
  • 使用 LDAP 和 VBScript 来管理 Active Directory
  • 使用架构和显示指定器来扩展 Active Directory

管理服务

  • 了解组策略
  • 管理操作系统的远程安装
  • 管理用户组和计算机组的应用程序部署
  • 管理用户数据和用户设置

安全服务

安装和配置证书

  • 安装证书颁发机构
  • 将域配置为信任外部证书颁发机构
  • 管理证书服务
  • 获得和管理证书
  • 配置自动证书申请

使用证书

  • 使用网页来申请证书
  • 将证书映射到将在 Web 站点上使用的用户帐户

其他安全功能

  • 配置单个计算机的本地安全策略
  • 管理企业网络中的安全性
  • 加密文件
  • 使用 Kerberos V5
  • 使用 Internet 协议安全 (IPSec) 来加密 IP 网络通信

文件和打印服务

  • 创建目录和文件的逻辑视图

群集

  • 在 Windows Server 2003, Enterprise Edition 和 Windows Server 2003, Datacenter Edition 上安装典型的双节点群集


Microsoft Windows Server 2003 R2 中的新功能

Microsoft Windows 图形

Windows Server 2003 R2 中的新功能

以下主题说明新的 Windows Server 2003 R2 组件以及如何安装这些组件：

  • 了解有关新的 Windows Server 2003 R2 组件的更多信息
  • 安装可选组件和服务器角色

要访问有关使用和维护 Windows Server 操作系统的其他资源和服务，请参阅 Windows Server 2003 TechCenter。(http://go.microsoft.com/fwlink/?LinkID=34402)


了解有关新的 Windows Server 2003 R2 组件的更多信息

Microsoft® Windows Server™ 2003 R2 是 Windows Server 2003 操作系统的软件更新，可以更容易并且更经济地扩展对整个组织以及组织以外的身份、位置、数据和应用程序的连接和控制能力。

Windows Server 2003 R2 基于带有 Service Pack 1 (SP1) 的 Windows Server 2003 构建，在利用代码库的稳定性和安全性的同时，将连接和控制能力扩展到新的领域。使用 Windows Server 2003 R2 可以在以下方面得到增强：

  • 身份管理和访问管理
  • 分支机构服务器管理
  • 存储设置和管理
  • 组织的传统边界内部和外部的应用程序开发

有关 Windows Server 2003 R2 的详细信息，请访问 Microsoft 网站。(http://go.microsoft.com/fwlink/?LinkId=45560)

本主题说明可以随 Windows Server 2003 R2 安装的下列新组件。本主题还提供有关每个组件的更多信息的链接。

服务器可管理性

  • 管理工具包

  • 硬件管理

  • MMC 3.0

Active Directory 功能

  • Active Directory 应用程序模式 (ADAM)

  • Active Directory 联合身份验证服务

磁盘和文件管理功能

  • 分支机构

  • 分布式文件系统 (DFS)

  • 公用日志文件系统 (CLFS)

  • 文件服务器管理

  • 文件服务器资源管理器

  • Microsoft Network File System 服务

  • SAN 存储管理

打印机和协议支持

  • 打印管理

Microsoft .NET Framework

  • Microsoft .NET Framework 版本 2.0

Internet 与电子邮件服务和功能

  • Windows Sharepoint Services

UNIX 互操作性

  • UNIX 身份管理

  • 基于 UNIX 的应用程序的子系统

服务器可管理性

为了帮助您管理服务器，Windows Server 2003 R2 提供管理工具包以及硬件管理和 Microsoft 管理控制台 (MMC) 3.0 的下列增强功能。

管理工具包

为了便于远程管理您的服务器，可以安装光盘 2 上 \mgmttls 目录中的 Windows Server 2003 R2 管理工具包。以下每个组件均包含管理工具包：

  • Microsoft 管理控制台 (MMC) 3.0
  • 打印管理
  • 文件服务器资源管理器
  • DFS 复制
  • UNIX 身份管理
  • 文件服务器管理

要管理组件，必须先安装 MMC 3.0 管理工具包。管理工具包可以安装在运行带有 Service Pack 2 (SP2) 的 Windows® XP 的计算机上。有关具体的安装说明，请访问 Microsoft 网站。(http://go.microsoft.com/fwlink/?LinkId=54293)

硬件管理

可以使用 Windows 远程管理 (WinRM) 来跨防火墙远程管理服务器硬件以及监视脱机服务器上的情况。

Windows Server 2003 R2 中的这项新功能使用 WS-Management 实现，WS-Management 是行业标准的、基于 Web 服务的远程处理协议。WS-Management 使用 HTTPS 作为启用防火墙穿越功能的安全传输。

WinRM 为常见管理任务提供命令行界面，为编写基于 Windows Script Host 的系统管理脚本提供脚本应用程序编程接口 (API)。

使用 WinRM 可以编写脚本，用于通过与 Baseboard 管理控制器 (BMC) 通信来监视和控制服务器硬件的状态。BMC 是具有自己的网络适配器的独立微控制器，该网络适配器连接到服务器的处理器板上，即使服务器关闭或出现故障，也可以监视服务器上的情况。用于智能平台管理接口 (IPMI) 的新 Windows 管理接口 (WMI) 提供程序提供六个新的 WMI 类，用于通过脚本访问 BMC 信息。

默认情况下，WinRM 不随 Windows Server 2003 R2 一起安装。要安装 WinRM，从“控制面板”中打开“添加或删除程序”，然后单击“添加/删除 Windows 组件”。

有关硬件管理的详细信息，请参阅 Microsoft 网站上的“Hardware Management in Microsoft Windows Server 2003 R2”（Microsoft Windows Server 2003 R2 中的硬件管理）。(http://go.microsoft.com/fwlink/?LinkId=45204)

返回页首

MMC 3.0

Microsoft 管理控制台 (MMC) 3.0 在为 MMC 3.0 基础结构设计的管理单元中支持更丰富的功能。此外，下列增强功能适用于所有 MMC 3.0 控制台：

  • “操作”窗格。“操作”窗格出现在管理单元控制台的右侧。该窗格根据树中或结果窗格中当前所选的项目列出您当前可用的操作。

    要显示或隐藏“操作”窗格，单击工具栏上的“显示/隐藏操作窗格”按钮，该按钮与“显示/隐藏控制台树”按钮类似。

  • 新的“添加或删除管理单元”对话框。新的“添加或删除管理单元”对话框可以使添加、组织和删除管理单元更加容易。可以控制哪些扩展可用以及是否自动启用以后可能安装的管理单元。可以嵌套管理单元以及在树中重新安排管理单元。

    要在此试用版中使用此功能，必须手动设置注册表项。

  • 增强的错误处理。MMC 3.0 会通知您管理单元中可能造成 MMC 失败的错误，并提供多个响应这些错误的选项。

MMC 3.0 在安装 Windows Server 2003 R2 时自动安装。

有关详细信息，请参阅 Microsoft 管理控制台。

返回页首

Active Directory 功能

现在，Windows Server 2003 R2 中包含下列 Active Directory 组件。

Active Directory 应用程序模式 (ADAM)

Active Directory 应用程序模式 (ADAM) 是 Active Directory® 目录服务的一种独立模式，没有基础结构功能，为应用程序提供目录服务。该模式为访问数据存储提供数据存储和服务。它使用标准的应用程序编程接口 (API) 访问应用程序数据。ADAM 可以作为独立的数据存储使用，也可以与复制配合使用。其独立性启用对特定应用程序的目录服务的本地控制和自治。还便于使用独立、灵活的架构和命名上下文。

有关详细信息，请参阅 Active Directory 应用程序模式 (ADAM)。

返回页首

Active Directory 联合身份验证服务

Active Directory 联合身份验证服务 (ADFS) 的基本目的是利用单一用户登录，在单一联机会话生存期内，在多个相关的 Web 应用程序上对用户进行身份验证。ADFS 通过跨安全和企业边界安全地共享数字标识和权限来实现此功能。

有关详细信息，请参阅 Active Directory 联合身份验证服务 (ADFS)。

返回页首

磁盘和文件管理功能

Server 2003 R2 具有下列磁盘和文件管理功能。

分支机构

分支机构是指某个组织的通过广域网 (WAN) 连接到总部或集线器的远程（办公）场所。Windows Server 2003 R2 中包含的技术可以简化对分支机构中的各种活动和任务的管理。这些活动和任务包括：

  • 将文件从中央集线器发布到分支机构。
  • 从分支机构复制文件，以便进行备份、容错或交叉发布。
  • 协作处理在分支机构之间或在集线器与分支机构之间共享的文档。
  • 有效地管理分支机构中的打印机、打印机驱动程序和打印队列。

Windows Server 2003 R2 中的增强型打印管理工具支持这些改进。Windows Server 2003 R2 中的分布式文件系统 (DFS) 也支持这些改进。

有关 Windows Server 2003 R2 中的这些技术的详细信息，请访问 Microsoft 网站。(http://go.microsoft.com/fwlink/?LinkId=51679)

返回页首

分布式文件系统 (DFS)

Windows Server 2003 R2 中的分布式文件系统 (DFS) 解决方案提供简化的具有容错能力的文件访问和 WAN 友好复制。分布式文件系统包含两项技术：

  • DFS 命名空间。DFS 命名空间以前称为分布式文件系统，允许管理员对位于不同服务器上的共享文件夹进行分组并将其作为虚拟文件夹树（称为命名空间）提供给用户。命名空间可以提供很多好处，包括提高数据的可用性、负载共享和简化数据迁移。
  • DFS 复制。DFS 复制（前身是文件复制服务 (FRS)）是一个基于状态的新型多主机复制引擎，支持复制计划和带宽限制。DFS 复制使用一种称为远程差分压缩 (RDC) 的新的压缩算法。RDC 是一种“线上差分”协议，可用于在带宽受限的网络上有效地更新文件。RDC 检测文件中数据的插入、删除和重新排列，使“DFS 复制”能够在文件更新时仅复制增量（更改）。

有关 Windows Server 2003 R2 中的分布式文件系统的详细信息，请访问 Microsoft 网站。(http://go.microsoft.com/fwlink/?LinkId=51679)

返回页首

公用日志文件系统 (CLFS)

公用日志文件系统 (CLFS) 是可加载的驱动程序，提供具有强大日志记录子系统的内核模式或用户模式应用程序。CLFS 是可以用于开发依靠不断写入和读取序列数据的应用程序和中间件的独特 Windows 技术。例如复制代理、审核代理、数据库以及其他事务资源管理器。

功能包括可以使用单一数据流或多个数据流创建日志文件，供一个或多个客户端共享使用；循环和线性日志记录；通过预留日志中空间，确保可以刷新缓存的数据；基于策略的日志大小和空间管理；内核客户端和用户客户端共享一个日志；使相同日志中的不同用户可以协调日志使用的通知机制；灵活地将日志数据存入缓冲区；存档 API 不会影响正常运行；原子多扇区写入；不完整写入检测。

CLFS 对性能进行了优化。对日志文件的所有写入将存入缓存区，直到进行显式刷新、可以与其他客户端共享写入或缓冲区已满。日志数据直接从日志缓冲区写入硬盘，而不复制。在同一个 I/O 操作期间，可以写入多个数据流，使通常需要多次寻道和写入的情况只需要一次磁盘寻道。读取将存入高速缓存，在正常操作或读取活动突发期间减少磁盘访问次数。

有关详细信息，请参阅位于 Microsoft 网站的“Platform SDK”。(http://go.microsoft.com/fwlink/?LinkId=44489)

返回页首

文件服务器管理

使用“文件服务器管理”可以执行许多任务，如格式化卷、创建共享资源、对卷进行碎片整理、创建和管理共享资源、设置配额限制、创建存储使用状况报告、将数据复制到文件服务器或从文件服务器复制数据、管理存储区域网络 (SAN) 以及与 UNIX 和 Macintosh 系统共享文件。

有关详细信息，请参阅文件服务器管理概述。

返回页首

文件服务器资源管理器

随着对存储资源需求的增加，因为组织比以往更加依赖数据，IT 管理员面临着检查更大并且更复杂的存储结构的挑战，同时还面临跟踪存储结构中可用信息类型的挑战。

文件服务器资源管理器是新的 Microsoft 管理控制台 (MMC) 管理单元，提供使管理员可以了解、控制和管理服务器上存储的数据的数量和类型的一套工具。通过使用 File Server Resource Manager，管理员可以为文件夹和卷设置配额，主动屏蔽文件，并生成全面的存储报告。

文件服务器资源管理器配额与 NTFS 磁盘配额

Windows 2000 和 Windows Server 2003 操作系统支持磁盘配额，用于跟踪和控制 NTFS 卷上的每个用户的磁盘使用率。下表概述使用文件服务器资源管理器中的配额管理工具的好处。

配额功能 | 文件服务器资源管理器 | NTFS 磁盘配额
配额跟踪 | 按文件夹或按卷 | 按卷上的用户
磁盘使用率计算 | 实际磁盘空间 | 逻辑文件大小
通知机制 | 电子邮件、自定义报告、命令执行、事件日志 | 仅限事件日志

有关详细信息，请参阅文件服务器资源管理器。

返回页首

Microsoft Network File System 服务

Microsoft 网络文件系统服务 (NFS) 是 Windows Server 2003 R2 的一个组件，为具有混合 Windows 和 UNIX 的环境的企业提供文件共享解决方案。Microsoft NFS 服务使用户可以使用网络文件系统 (NFS) 协议在 Windows Server 2003 R2 与 UNIX 计算机之间传输文件。

Microsoft NFS 服务是以前在 UNIX 服务 3.5 中可用的 NFS 组件的更新。Microsoft NFS 服务具有下列新功能：

  • 支持 64 位

    Microsoft NFS 服务组件可以安装在所有版本的 Windows Server 2003 R2 上，包括 64 位版本。

  • 更新的“Microsoft 管理控制台 (MMC) Microsoft NFS 服务管理”管理单元
  • 增强的可靠性。
  • 支持 UNIX 特殊设备 (mknod)

通过 Microsoft NFS 服务可以支持基于 Windows 和基于 UNIX 的操作系统的混合环境。在过渡阶段，还可以在支持较旧技术的同时更新组织的计算机。下列方案是企业如何可以从部署 Microsoft NFS 服务中受益的示例。

  • 使 UNIX 客户端可以访问运行 Windows Server 2003 R2 的计算机上的资源。公司中可能有访问 UNIX 文件服务器上的资源（例如文件）的 UNIX 客户端。要利用 Windows Server 2003 的新功能，例如共享文件夹的卷影副本，可以将 UNIX 服务器上的资源移动到运行 Windows Server 2003 R2 的计算机上，然后设置 Microsoft NFS 服务，允许运行 NFS 软件的 UNIX 客户端访问。所有 UNIX 客户端不需要任何更改，即可使用 NFS 协议访问资源。
  • 允许运行 Windows Server 2003 R2 的计算机访问 UNIX 文件服务器上的资源。公司中的资源可能有混合的 Windows 和 UNIX 环境，包含存储在 UNIX 文件服务器上的资源（例如文件）。文件服务器运行 NFS 软件时，使用 Microsoft NFS 服务可以使运行 Windows Server 2003 R2 的计算机访问这些资源。

有关详细信息，请参阅 Microsoft Network File System　服务。

SAN 存储管理

SAN 存储管理器是新的 Microsoft 管理控制台 (MMC) 管理单元，可帮助创建和管理存储区域网络 (SAN) 中光纤通道和 iSCSI 磁盘驱动器子系统上的逻辑单元号 (LUN)。SAN 存储管理器可以在支持虚拟磁盘服务器 (VDS) 的存储子系统上使用。

使用 SAN 存储管理器可以创建和分配 LUN，管理 LUN 与 SAN 中的服务器之间的连接，以及设置 iSCSI 存储子系统的安全属性。

有关详细信息，请参阅 SAN 存储管理器。

返回页首

打印机和协议支持

Windows Server 2003 R2 为打印管理提供更新的 MMC 管理单元。

打印管理

打印管理是更新的 Microsoft 管理控制台 (MMC) 管理单元，可以用于查看和管理组织中的打印机和打印服务器。可以从运行 Windows Server 2003 R2 的任何计算机使用“打印管理”，并且可以管理运行 Windows 2000 Server、Windows Server 2003 或 Windows Server 2003 R2 的打印服务器上的所有网络打印机。

打印管理提供实时的详细信息，例如队列状态、打印机名称、驱动程序名称和服务器名称。还可以使用打印管理的筛选功能设置自定义视图。例如，可以创建只显示处于特定错误状态的打印机的视图。还可以通过配置打印管理，在打印机或打印服务器需要用户参与时发送电子邮件通知或运行脚本。使用筛选功能还可以批量编辑打印作业，例如同时取消所有打印作业。还可以同时删除多个打印机。

管理员可以使用自动检测功能远程安装打印机，自动检测功能在本地子网上查找打印机并安装到本地打印服务器上。管理员可以使用远程桌面登录到分支机构的本地服务器，然后即可很容易远程安装打印机。

如果某个打印机型号具有网页功能，打印管理可以显示疑难解答详细信息，例如卡纸位置或打印机墨粉量。某些打印机型号具有提供远程控制功能选项的网页，可以帮助解决分支机构的问题。

有关详细信息，请参阅位于 Microsoft 网站上的“Print Management Step-by-Step Guide”（打印管理循序渐进指南）。(http://go.microsoft.com/fwlink/?LinkId=50141)

返回页首

Microsoft .NET Framework

.NET Framework 2.0 的新功能可以在 Windows Server 2003 R2 中使用。

Microsoft .NET Framework 版本 2.0

.NET Framework 版本 2.0 是 .NET Framework 的最新版本，是用于构建、部署和运行应用程序的 Windows 组件。.NET Framework 2.0 主要用于提高开发人员工作效率，使运行更加出色，并且可以保留和增强现有的软件投资。核心增强功能包括支持 64 位处理器（可以提高性能和扩展性），事务增强和优化，ASP.NET 中工作效率的提高, 支持包含 Web 服务的 WS-I BP 1.1 和 SOAP 1.2。

有关新的 .NET Framework 2.0 功能的完整列表，请访问 Microsoft 网站。(http://go.microsoft.com/fwlink/?LinkId=50322)

返回页首

Internet 与电子邮件的服务和功能

Windows Server 2003 R2 中包含 Windows SharePoint Services。

Windows Sharepoint Services

Microsoft Windows® SharePoint® 服务是一套综合的协作和通信服务，用于连接组织防火墙内部和外部的用户、信息、进程和系统。此版本的 Windows Server 2003 中包含 Windows SharePoint Services Service Pack 2。现在，您可以直接从“配置您的服务器”向导或“管理您的服务器”中安装 Windows SharePoint Services。安装 Windows SharePoint Services 后，可以使用下列功能：

SharePoint 站点 – 文件存储和协作

基于 Microsoft Windows SharePoint Services 2.0 的网站提供一个空间，团队可以在其中通信、共享文档和协作同一个项目。SharePoint 站点包括：

  • 团队协作功能，例如事件日历、联系人、Web 链接、讨论、问题列表、声明等。
  • 文档库，用户可以在其中存储和检索文档，同时利用丰富的功能，例如检入和检出、版本历史记录、自定义元数据以及灵活的可自定义视图。
  • Web 部分，可以为 SharePoint 站点提供数据访问、Web 服务以及许多其他应用程序和内容。

站点用户仅需一个 Web 浏览器即可参与到该站点中。但是，如果用户的计算机上安装有与 Windows SharePoint Services 兼容的客户端程序，例如 Microsoft Office 2003，则可以通过该站点无缝地工作，将文件保存到库中，编辑客户端程序中的文档，以及将信息移动或链接到该站点。

SharePoint 集中管理 – 用于管理服务器的 Web 浏览器界面

可以从称为“SharePoint 集中管理”的 Web 浏览器界面中管理运行 Windows SharePoint Services 的单个服务器或整个服务器场。使用 SharePoint 集中管理可以扩展虚拟服务器，创建站点或启用“站点创建自助服务”，使用户可以创建自己的站点，管理安全设置，管理服务器场中的服务器列表等。如果愿意，还可以使用 Stsadm.exe 命令行实用程序管理运行 Windows SharePoint Services 的服务器。

Windows SharePoint Services 应用程序 – 下载并安装可直接使用的应用程序，以提高工作效率

通过下载和安装 Windows SharePoint Services 应用程序提高员工工作效率。这些应用程序是为满足特定的进程或任务而定制的。有多种应用程序可供选择，包括恢复、项目管理、技术支持问题跟踪、时间表和计划、事件规划及其他。安装或为进一步满足组织特定需求和要求而自定义应用程序之后，即可使用这些应用程序。

有关详细信息，请参阅 Microsoft 网站上的“Applications for Windows SharePoint Services”（Windows SharePoint Services 应用程序）。(http://go.microsoft.com/fwlink/?LinkId=47987)

支持高级 Extranet 配置

使用 URL 区域映射功能（Windows SharePoint Services Service Pack 2 中的新增功能）可以更容易与代理服务器或防火墙进行交互。Windows SharePoint Services 使用绝对 URL 在其网页和电子邮件中生成一些超级链接。这样，在 Windows SharePoint Services 服务器前面部署反向代理服务器的环境中，将使 Windows SharePoint Services 无法支持某些高级 Extranet 配置（例如 SSL 终止、主机头修改和端口转换）。现在，可以设置 URL 区域（例如 Internet、Intranet 和 Extranet），并将传入和传出 URL 映射到这些区域上，使这些配置可以正常工作。

有关 Windows Server 2003 R2 中的 Windows SharePoint Services 的详细信息，请访问 Microsoft 网站。(http://go.microsoft.com/fwlink/?LinkId=45560)

返回页首

UNIX 互操作性

为了提高与 UNIX 的互操作性，Windows Server 2003 R2 中提供了下列功能。

UNIX 身份管理

Windows UNIX 服务提供 Windows 和 UNIX 与更新的身份管理解决方案的集成。下列解决方案有助于为跨操作系统的网络资源提供不间断的用户访问和有效的管理：

  • NIS 服务器。通过允许 Active Directory 域控制器充当一个或多个 NIS 域的主 NIS 服务器，帮助集成基于 Windows 和基于 UNIX 的网络信息服务 (NIS) 服务器
  • 密码同步。通过简化维护安全密码的过程，帮助集成 Windows 和 UNIX 服务器。通过密码同步，用户不需要为其 Windows 和 UNIX 帐户维护单独的密码，也不需要记住在多个位置更改密码。

有关详细信息，请参阅 UNIX 身份管理概述。

返回页首

基于 UNIX 的应用程序的子系统

基于 UNIX 的应用程序的子系统 (SUA) 是一个源代码兼容子系统，用于在运行 Windows 服务器级操作系统的计算机上编译和运行自定义的、基于 UNIX 的应用程序。在 SUA 中，可以使 UNIX 应用程序与 Windows 完全可互操作，很少需要或完全不需要更改原始源代码。

基于 UNIX 的应用程序的子系统为可移植操作系统接口 (POSIX) 进程提供操作系统。SUA 与它的支持实用程序包（例如解释器和 Telnet 客户端）一起提供完整的 UNIX 环境。支持实用程序包包括一套完整的脚本实用程序和一个软件开发套件 (SDK)，可以完全支持 SUA 的开发功能。

SUA 还支持区分大小写的文件名、作业控制、编译工具以及使用 300 多个 UNIX 命令、实用程序和解释器脚本。因为该子系统从 Windows 内核单独安装，所以，提供的是真正的 UNIX 功能，没有任何模拟。

此版本中的新功能包括：

  • 数据库 (OCI/ODBC) 库连接能力。SUA 支持使用 Oracle 调用接口 (OCI) 和开放式数据库连接 (ODBC) 标准从数据库应用程序连接到 Oracle 和 SQL Server。
  • 用于调试 POSIX 应用程序的 Microsoft® Visual Studio® 调试程序扩展。SUA 支持使用 Visual Studio IDE 调试 POSIX 进程。
  • 基于 SVR-5 和 BSD UNIX 环境的实用程序。SUA 下载程序包支持两个不同的 UNIX 环境：SVR-5 和 BSD。
  • 支持 64 位应用程序。使用称为 thunking 的进程，SUA 不仅支持在 64 位操作系统上运行的 64 位应用程序，还默认支持在 64 位操作系统上运行的 32 位二进制文件。

要下载支持实用程序，请参阅位于 Microsoft 网站的“Installing and Using Utilities and SDK for UNIX-based Applications”（安装和使用基于 UXIX 的应用程序的实用程序和 SDK）。(http://go.microsoft.com/fwlink/?LinkId=38959)

有关详细信息，请参阅基于 UNIX 的应用程序的子系统。

返回页首


安装可选组件和服务器角色

安装完成后，可以通过使用“控制面板”中的“添加/删除 Windows 组件”来安装可选组件。也可以通过使用“管理您的服务器”选择添加或升级服务器角色。

有关详细信息，请参阅安装可选组件和服务器角色。


新功能

Windows Server 2003, Enterprise Edition 包括 Windows Server 2003, Standard Edition 的完整功能集，此外，它还支持大于 4 GB 的内存和多个处理器，同时还支持群集。扩展内存和处理器支持意味着服务器应用程序能够以更快的速度运行，从而能够为网络上的用户提供更快的响应。Windows 群集包括多个群集技术：网络负载平衡群集和服务器群集。您可以将这些群集技术设置为协同工作，为网络应用程序提供可伸缩性和高可用性。详细信息，请参阅 Windows 群集。

  • 有关 Windows Server 2003 R2 中组件的信息，请参阅 Windows Server 2003 R2 中的新增功能。
  • 有关已经更改名称或位置的功能和组件信息，请参阅执行常见任务的新方法。
  • 要查看此版本中的功能与以前版本中的功能比较表格，请参阅功能比较：Windows NT、Windows 2000 和 Windows Server 2003 家族。如果您要从 Windows NT 4.0 或 Windows 2000 上升级并且希望检查功能之间的差异，则此表格尤其有用。
  • 要了解更多关于特定功能或管理任务要用到的功能信息，请参阅选择对于服务器最有用的功能。
  • 有关按字母顺序排列的功能简明列表，请参阅按字母顺序排列的功能列表。
  • 对于这些主题中的功能概述，请参阅功能概述。


功能比较：Windows NT、Windows 2000 和 Windows Server 2003 家族

下表提供了基于升级途径的功能比较。例如，如果从 Windows NT 4.0 升级，请选择下面的“Windows NT 4.0 到 Windows Server 2003 家族”选项。有关指向此版本中这些功能详细信息的链接，请参阅新功能。

该表按功能区域进行分类，显示了有关在早期操作系统中引入的改进功能以及此版本中的新功能的信息。

某些功能在 Windows Server 2003 家族中的一些产品上不可用。详细信息，请单击下表中的链接。有关 Windows Server 2003, Web Edition 的信息，请参阅 Windows Server 2003, Web Edition 概述。有关 Windows Server 2003 家族 64 位版本中的功能限制的信息，请参阅 Windows Server 2003 家族 64 位版本中不可用的功能。

单击符合您的升级途径的选项：

Windows NT 4.0 到 Windows Server 2003 家族

功能区 自 Windows NT 4.0 以后添加的功能和此版本中更新的功能 Windows Server 2003 家族的新功能
服务器可靠性
  • 改进的内存管理
  • 稳健的系统体系结构
  • 诊断工具
  • 安全模式启动
  • 故障恢复控制台
  • Windows 文件保护
  • 增强的备份实用程序
  • 自动系统故障恢复 (ASR)
  • 兼容模式
服务器可用性
  • 服务器群集
  • 网络负载平衡群集
  • 服务器重新启动次数更少
  • 即插即用
  • 从镜像卷启动
  • 用户状态迁移工具
  • 紧急管理服务
服务器可伸缩性
  • 硬件可伸缩性
  • I2O 支持
  • 对称多重处理增强功能
  • 网络负载平衡
  • 服务器群集
  • 企业内存体系结构
  • Internet 信息服务 (IIS) 6.0
服务器可管理性
  • IntelliMirror
  • Windows Management Instrumentation (WMI)
  • 远程安装服务 (RIS)
  • 管理您的服务器
  • 管理远程桌面
  • 远程管理的服务器支持
  • 用户状态迁移工具
  • 紧急管理服务
  • 策略的结果集 (RSoP)
  • 授权管理器
性能和调节
  • Winsock Direct
  • I2O 支持
  • 对于 Web 应用程序或站点的 CPU 限制
  • 对于 Web 应用程序或站点的进程记帐
  • 可预计的端对端服务质量 (QoS)
  • 网络负载平衡
  • 新性能工具
  • 磁盘碎片整理程序
  • 事件跟踪增强功能
  • 性能选项
  • 用于系统监视器的新命令行实用程序
身份验证和智能卡支持
  • Kerberos V5 协议的完全支持
  • 公钥结构 (PKI)、证书服务和智能卡
  • 虚拟专用网
  • 安全灵活的身份验证和授权
  • Internet 验证服务 (IAS)
  • 路由和远程访问
  • 存储用户名和密码
  • 通过终端服务器的智能卡访问
安全
  • 加密文件系统 (EFS)
  • Internet 协议安全 (IPSec)
  • TCP/UDP 端口所有权
  • 软件限制策略
远程管理
  • Microsoft 管理控制台 (MMC)
  • 用 Windows Script Host 编写
  • 远程安装服务 (RIS)
  • 管理远程桌面
  • 远程协助
  • 远程管理的 Web 界面（仅限于 Windows Server 2003, Web Edition）
维护和产品更新
  • Windows Update
 —
国际化
  • 多语言支持
  • 多区域支持
  • 新的繁体中文拼音输入法编辑器 (IME)
Active Directory
  • 简化了用户和网络资源管理
  • 安全灵活的身份验证和授权
  • 目录合并
  • 启用目录应用程序和基础结构
  • 容易实现的可伸缩性
  • Internet 标准的使用
  • 功能强大的开发环境
  • 复制和信任监视
  • 消息队列通讯组列表
  • 有关此版本中 Active Directory 新功能的列表，请参阅 Active Directory 的新功能。
磁盘和文件管理功能
  • 磁盘管理
  • 磁盘配额支持
  • 分布式文件系统
  • 分布式链接跟踪
  • 分布式创作和版本管理 (DAV)
  • 高性能的内容索引
  • 加密文件系统 (EFS)
  • 可移动存储和远程存储
  • 远程文档共享
  • 磁盘管理的命令行支持
  • GUID 分区表 (GPT)（仅限于 64 位版本）
  • 共享文件夹的卷影副本
打印机和协议支持
  • 在 Active Directory 中发布的打印机
  • 广泛的设备和协议支持
  • 即插即用
  • Internet 打印协议
  • 打印机管理功能
  • 网络打印功能
  • 打印的新的命令行支持
  • 在服务器群集上安装打印机驱动程序更加轻松
Internet 与电子邮件服务和功能
  • Active Server Pages (ASP)
  • Windows Media Services
  • Web 分布式创作和版本管理 (WebDAV)
  • 应用程序回收
  • Microsoft .NET Framework 组件
  • Internet 信息服务 (IIS) 6.0
  • 通用描述、发现和集成 (UDDI) 服务
  • 电子邮件服务 (POP3、SMTP)
  • Windows Management Instrumentation (WMI) 提供程序
协作
  • Windows Media Services
  • 可预计的端对端服务质量 (QoS)
  • 异步传输模式 (ATM)
  • Microsoft .NET Framework
  • 远程访问服务器上的音频加速
对现有系统的支持
  • 工业标准
  • 对现有的服务器应用程序的支持
  • 与现有的操作系统集成
  • 兼容模式
  • 程序兼容性向导
应用程序支持
  • 范围最广泛的交钥匙应用程序
  • 全面的 Internet 应用程序服务
  • Microsoft Active Accessibility
  • TAPI 3.1
  • 事务服务
  • 消息队列
  • 组件服务
  • 作业对象
  • 主数据集成
  • 兼容模式
  • Internet 信息服务 (IIS) 中的 Web 园
管理和部署
  • 使用组策略进行更改和配置管理
  • Active Directory 中的目录合并
  • IntelliMirror
  • 远程安装服务 (RIS)
  • Windows Management Instrumentation (WMI)
  • 相邻组件共享
  • 添加或删除程序
  • Windows 安装程序
  • 应用程序管理
  • 远程管理的服务器支持
  • 策略的结果集 (RSoP)
终端服务器
  • 程序的集中部署
  • 对应用程序的远程访问
  • 单应用程序访问
  • 终端服务管理器
  • 远程控制
  • 音频重定向
开发支持
  • Visual Studio .NET
  • 多语言技术
  • 链接 ID 的自动生成
  • 后台智能传输服务 (BITS)
网络协议和技术
  • Winsock Direct
  • DHCP 与 DNS 和 Active Directory 协作
  • Internet 连接共享 (ICS)
  • 网络地址转换 (NAT)
  • 虚拟专用网
  • 路由和远程访问
  • 异步传输模式 (ATM)
  • 简单对象访问协议 (SOAP)
  • 纤维管道支持
  • 多个网络的自动配置
  • Web 数字创作和版本控制 (WebDAV) 重定向程序
  • 作为 RADIUS 代理的 Internet 验证服务 (IAS)
  • 无线网络
  • IP 版本 6 (IPv6)

Windows 2000 到 Windows Server 2003 家族

功能区 在 Windows 2000 中添加功能和在此版本中更新的功能 Windows Server 2003 家族的新功能
服务器可靠性 —
  • 自动系统故障恢复 (ASR)
  • 兼容模式
服务器可用性
  • 存储区域网络 (SAN) 和网络访问服务器 (NAS) 支持
  • 网络负载平衡增强功能
  • 用户状态迁移工具
  • 紧急管理服务
服务器可伸缩性
  • 网络负载平衡增强功能
  • Internet 信息服务 (IIS) 6.0
服务器可管理性
  • Windows Management Instrumentation (WMI) 改进功能
  • 远程安装服务 (RIS) 改进功能
  • 管理远程桌面
  • 远程管理的服务器支持
  • 用户状态迁移工具
  • 紧急管理服务
  • 策略的结果集 (RSoP)
  • 授权管理器
性能和调整
  • 系统监视器增强功能
  • 性能日志和警报改进功能
  • 性能选项
  • 用于系统监视器的新的命令行实用程序
身份验证和智能卡支持
  • 从属证书颁发机构 (CA) 改进功能
  • 存储用户名和密码
  • 通过终端服务器的智能卡访问
安全
  • 加密文件系统 (EFS) 改进功能
  • Internet 协议安全 (IPSec) 监视改进功能
  • TCP/UDP 端口所有权
  • 软件限制策略
远程管理
  • 远程安装服务 (RIS) 改进功能
  • 管理远程桌面
  • 远程协助
  • 远程管理的 Web 界面（仅限于 Windows Server 2003, Web Edition）
维护和产品更新
  • Windows Update 增强功能
 —
国际化
  • 改进的日语输入法编辑器 (IME)
  • 改进的朝鲜语 IME
  • 改进的简体中文 IME
  • 新的繁体中文拼音 IME
Active Directory
  • 有关此版本中 Active Directory 新功能的列表，请参阅 Active Directory 的新功能。
  • 有关此版本中 Active Directory 新功能的列表，请参阅 Active Directory 的新功能。
磁盘和文件管理功能
  • 文件管理改进功能
  • 远程文档共享
  • 对磁盘管理的命令行支持
  • GUID 分区表 (GPT)（仅限于 64 位版本）
  • 共享文件夹的卷影副本
打印机和协议支持
  • 在服务器群集上安装打印驱动程序更加轻松
  • 打印的新的命令行支持
Internet 与电子邮件服务和功能 —
  • Microsoft .NET Framework 组件
  • Internet 信息服务 (IIS) 6.0
  • 通用描述、发现和集成 (UDDI) 服务
  • 电子邮件服务 (POP3、SMTP)
  • 用于 IIS 的 Windows Management Instrumentation (WMI) 提供程序
协作
  • NetMeeting 增强功能
  • Microsoft .NET Framework
  • 远程访问服务器上的音频加速
对现有的系统的支持 —
  • 兼容模式
  • 程序兼容性向导
应用程序支持 —
  • 兼容模式
  • Internet 信息服务 (IIS) 中的 Web 园
管理和部署
  • Windows Management Instrumentation (WMI) 改进功能
  • 脚本支持
  • 远程安装服务 (RIS) 改进功能
  • 远程管理的服务器支持
  • 策略的结果集 (RSoP)
终端服务器
  • 分辨率和颜色增强功能
  • 组策略集成
  • 音频重定向
开发支持 —
  • 链接 ID 的自动生成
  • 后台智能传输服务 (BITS)
网络协议和技术
  • 连接管理器改进功能
  • 简单对象访问协议 (SOAP)
  • 纤维管道支持
  • 多个网络的自动配置
  • Web 数字创作和版本控制 (WebDAV) 重定向程序
  • 作为 RADIUS 代理的 Internet 验证服务 (IAS)
  • 无线网络
  • IP 版本 6 (IPv6)


选择对于服务器最有用的功能

要根据您的服务器功能了解对服务器最有用的功能的详细信息，请参阅下表。有关此版本中这些功能详细信息的链接，请参阅新功能。

功能 功能描述
或支持类型 		有关如何使用该功能的信息
文件服务器
  • Active Directory
  • 磁盘和文件管理功能
  • 管理 Active Directory
  • 磁盘和数据
  • 客户端计算机
打印服务器
  • Active Directory
  • 打印机和协议支持
  • 管理 Active Directory
  • 打印
  • 打印机和传真
Web 服务器
  • Windows Server 2003, Web Edition 概述
  • Internet 与电子邮件服务和功能
  • 应用程序支持

    • 相关领域：
    应用程序服务器
    网络/通讯
    服务器安全
  • Internet 和电子邮件服务
  • Internet 信息服务 (IIS) 6.0
  • 应用程序和开发支持
多媒体
服务器
  • 用于协作的功能
  • 使用 Windows Media Services
  • 服务质量 (QoS)
  • Windows ATM 服务
应用程序
服务器
  • Microsoft .NET Framework
  • 对现有系统的支持
  • 终端服务器功能
  • 应用程序支持
  • 管理和部署
  • 性能和调节功能
  • 开发支持
  • 管理远程桌面
  • 组策略
  • IntelliMirror
  • 监视和状态工具
  • 服务质量 (QoS)
  • Windows ATM 服务
  • 企业内存体系结构（Windows Server 2003, Enterprise Edition 和 Windows Server 2003, Datacenter Edition，不包括 64 位版本）
  • 网络负载平衡群集
  • Windows 群集（仅限于 Windows Server 2003, Enterprise Edition 和 Windows Server 2003, Datacenter Edition）
  • 应用程序和开发支持
    另请参阅 Microsoft Platform SDK。可从 Platform SDK Update 网站 (http://www.microsoft.com/) 下载 SDK。
网络/
通讯
  • 网络协议和技术
  • 对现有系统的支持
  • 性能和调节功能
  • 网络服务
  • 配置通信链接
  • 监视和状态工具
  • 服务质量 (QoS)
  • Windows ATM 服务
服务器可靠性、
可用性、
可伸缩性和易管理性
  • 服务器可靠性
  • 服务器可用性
  • 服务器可伸缩性
  • 服务器可管理性
  • 磁盘和数据
  • 监视和状态工具
  • 即插即用概述
  • 网络负载平衡群集
  • Windows 群集（仅限于 Windows Server 2003, Enterprise Edition 和 Windows Server 2003, Datacenter Edition）
服务器
安全
  • 身份验证和智能卡支持
  • 其他安全功能
  • 安全
  • 新增安全功能
  • 身份验证
  • Internet 验证服务 (IAS)（在 Windows Server 2003, Web Edition 上不可用）
  • Internet 协议安全 (IPSec)
配置
与
管理
  • Active Directory
  • 终端服务器功能
  • 远程管理

  • 磁盘和文件管理功能
  • 国际化功能

    • 相关领域：
    文件服务器
  • 客户端计算机
  • Active Directory 概述
  • IntelliMirror
  • 远程管理
  • 管理和脚本撰写工具
  • 远程安装服务 (RIS)（在 Windows Server 2003, Web Edition 上不可用）


按字母顺序排列的功能列表

Windows Server 2003 家族中包含内容广泛的功能集，下表仅列出其中的部分功能。有关此版本中这些功能详细信息的链接，请参阅新功能。

Active Directory

Active Directory 是用于 Windows Server 2003, Standard Edition、Windows Server 2003, Enterprise Edition 和 Windows Server 2003, Datacenter Edition 的目录服务。它存储有关网络上的对象的信息，并使管理员和用户更方便地查找和使用这种信息。Active Directory 使用结构化的数据存储区，作为目录信息的逻辑分层结构的基础。详细信息，请参阅 Active Directory。

异步传输模式

异步传输模式 (ATM) 是一种面向高速连接的协议，旨在通过网络传输多种类型的通信。它适用于局域网 (LAN) 和广域网 (WAN)。您可利用 ATM 功能在网络中同时传输各种网络通讯：语音、数据、图像以及视频。

自动系统故障恢复

自动系统故障恢复 (ASR) 帮助用户在硬盘发生故障或系统严重受损的情况下恢复系统。可以通过“备份”中的多种向导，轻松地为 ASR 准备必要的备份材料。通过使用 ASR 并与标准备份（数据和应用程序备份）结合，可以将系统还原到备份之前的状态。有关 ASR 的详细信息，请参阅自动系统故障恢复 (ASR) 概述。有关其他系统恢复选项的详细信息，请参阅故障恢复。

证书服务

使用证书服务和证书管理工具，可以部署自己的公钥结构 (PKI)。通过 PKI 可以实现基于标准的技术，如智能卡登录功能、客户端身份验证 [通过安全套接字层 (SSL) 和传输层安全性 (TLS)]、安全的电子邮件、数字签名以及安全连接 [使用 Internet 协议安全 (IPSec)]。使用“证书服务”可以设置并管理颁发和吊销 X.509 v3 证书的证书颁发机构 (CA)。这表示尽管您可以选择将商业客户端身份验证集成到 PKI 中，却无需依赖商业客户端身份验证服务。详细信息，请参阅证书服务。

群集

群集是一组独立的计算机，它们一起协作运行公共的应用程序集，并向客户端和应用程序提供单一系统的映像。详细信息，请参阅该列表中的“网络负载平衡群集”或“服务器群集”。

服务器群集只在 Windows Server 2003, Enterprise Edition 和 Windows Server 2003, Datacenter Edition 上可用。

兼容模式

新的兼容模式功能可确保许多流行的应用程序的绝好的兼容性。“兼容模式”技术提供了一种可更加准确地反映 Windows 95、Windows 98、Windows NT 4.0 或 Windows 2000 操作系统行为的环境。这些模式解决了阻止早期的应用程序正常工作的若干最常见问题。迁移之后遇到问题的应用程序，可以在其中某一兼容环境中启动后受益。高级用户还可以利用此项技术，为他们自己的应用程序创建解决方案。

组件服务

“组件服务”是一组基于组件对象模型 (COM) 扩展和 Microsoft Transaction Server（基于组件的事务处理系统的早期版本）的服务。组件服务提供了线程处理和安全性、事务管理、对象共用、队列组件，应用程序管理和包装。

要查看 COM+ 应用程序和组件服务的完整帮助文档，请单击“开始”，依次指向“所有程序”、“管理工具”，然后单击“组件服务”。在组件服务中，单击“帮助”，然后单击“帮助主题”。

连接管理器

通过使用访问点网络，如通过 Internet 服务提供商 (ISP) 全球范围内可用的访问点，“连接管理器”可提供对您的服务的本地和远程连接的支持。详细信息，请参阅连接管理器管理工具包。

DHCP 与 DNS 和 Active Directory 协作

动态主机配置协议 (DHCP) 在“Internet 协议 (IP)”网络上与 DNS 和 Active Directory 协作，有助于减轻您指派和跟踪静态 IP 地址的工作。DHCP 动态地给连接到 IP 网络的计算机或其他资源分配 IP 地址。详细信息，请参阅网络服务。

磁盘管理

磁盘管理是用于管理磁盘存储的图形工具，具有下列功能：

  • 支持动态卷，突破了每个磁盘四个分区的限制。
  • 联机磁盘管理（重新启动次数较少）。
  • 本地和远程驱动器管理。
  • 卷的装入点，可使用它在本地 NTFS 格式的卷上的任何空文件夹中连接或装入本地驱动器。

详细信息，请参阅磁盘管理。

磁盘配额支持

可以在以 NTFS 文件系统格式化的卷上使用磁盘配额监视和限制单个用户可以使用的磁盘空间量。可以定义当用户超过指定的阈值时产生的响应。详细信息，请参阅磁盘配额。

电子邮件服务 (POP3、SMTP)

POP3（邮局协议 3）服务提供电子邮件传输和检索服务。管理员可以使用 POP3 服务，存储并管理邮件服务器上的电子邮件帐户。简单邮件传输协议 (SMTP) 支持服务器间电子邮件的传输。详细信息，请参阅 POP3 服务和简单邮件传输协议 (SMTP) 服务。

加密文件系统

加密文件系统 (EFS) 补充了其他访问控制手段，并为数据提供了更高层次的保护。EFS 作为集成系统服务运行，使管理更方便，使系统难以被攻击，并且对用户是透明的。详细信息，请参阅加密文件系统。

组策略（Active Directory 的组成部分）

可以使用策略定义用户和计算机的设置以及允许的操作。与本地策略相比，可以使用组策略设置跨 Active Directory 中的给定站点、域或组织单位应用的策略。基于策略的管理简化了各种管理任务，例如系统更新操作、应用程序安装、用户配置文件、桌面系统锁定。详细信息，请参阅组策略。

索引服务

索引服务提供快速、方便和安全的方式，供用户搜索本地或网络上的信息。用户可以通过“开始”菜单上的“搜索”命令，或者通过在浏览器中查看超文本标记语言 (HTML) 页，在不同格式和语言的文件中进行搜索。

Internet 验证服务

Internet 验证服务 (IAS) 为拨号网络或虚拟专用网络 (VPN) 的身份验证管理、授权、记帐和审核，提供了一个中心点。IAS 使用名为远程身份验证拨号用户服务 (RADIUS) 的 Internet 工程任务组 (IETF) 协议。详细信息，请参阅 Internet 验证服务。

运行 Microsoft® Windows® Server 2003, Web Edition 操作系统的计算机不包括该功能。有关详细信息，请参阅 Windows Server 2003 Web Edition 概述。在 Windows Server 2003, Standard Edition 中，您可以配置 IAS，最多配置 50 个 RADIUS 客户端和 2 个远程 RADIUS 服务器组。有关这些限制的详细信息，请参阅 Internet 验证服务。

Internet 连接共享

通过“网络连接”的 Internet 连接共享 (ICS) 功能，可以将家庭网络或小型办公网络连接到 Internet。例如，可以建立通过拨号连接连接到 Internet 的家庭网络。通过在使用拨号连接的计算机上启用 Internet 连接共享，可以为网络上的所有计算机提供网络地址转换、寻址和名称解析服务。详细信息，请参阅 Internet 连接共享和网络地址转换。

此功能只在 Windows Server 2003, Standard Edition 和 Windows Server 2003, Enterprise Edition 上可用，并且只在基于 x86 的计算机上可用。

Internet 信息服务 6.0

Internet 信息服务 (IIS) 6.0 是一种功能齐全的 Web 服务器，为 Windows Server 2003 家族和现有 Web 应用程序及 Web 服务提供了基础。IIS 6.0 提供了专用的应用程序模式，该模式在独立环境中运行所有应用程序代码。IIS 6.0 还支持 Web 园，在 Web 园中，计算机上的一组等效进程中的每个进程都接收共同的请求（通常由单一进程提供服务），从而获得更佳的多处理器可伸缩性。详细信息，请参阅 Internet 信息服务 (IIS) 6.0。

注意

  • 默认情况下，IIS 不与全新安装的 Windows Server 2003, Standard Edition、Windows Server 2003, Enterprise Edition 和 Windows Server 2003, Datacenter Edition 一起安装。您可以使用“配置您的服务器向导”或控制面板中的 添加或删除程序安装该服务。

Internet 协议安全支持

可以用 Internet 协议安全 (IPSec) 来保证 Intranet 中的通讯安全，也可以用它来创建跨 Internet 的安全虚拟专用网络 (VPN) 解决方案。IPSec 是 Internet 工程任务组 (IETF) 设计的，它是用于加密 TCP/IP 通信的工业标准。详细信息，请参阅 Internet 协议安全 (IPSec)。

Kerberos V5 协议支持

Kerberos V5 是一个成熟的并已成为业界标准的网络身份验证协议。有了 Kerberos V5 支持，用户可以通过快速、单一的登录过程访问所需的企业资源以及支持此协议的其他环境。对 Kerberos V5 的支持还包括其他优点，如相互进行身份验证（客户端和服务器都必须提供身份验证）和受委派的身份验证（从头至尾跟踪用户的凭据）。详细信息，请参阅 Kerberos V5 身份验证。

第二层隧道协议支持

第二层隧道协议 (L2TP) 是点对点隧道协议 (PPTP) 的更安全版本，它用于隧道操作、地址分配和身份验证。详细信息，请参阅第二层隧道协议。

轻型目录访问协议支持

轻型目录访问协议 (LDAP) 作为业界标准，是对 Active Directory 的主要访问协议。LDAP 版本 3 是由 Internet 工程任务组 (IETF) 定义的。详细信息，请参阅目录访问协议。

消息队列

消息队列功能可帮助开发人员构建和部署更可靠地在网络（包括 Internet）上运行的应用程序。这些应用程序可以与在不同的平台（如大型机和基于 UNIX 的系统）上运行的应用程序互操作。详细信息，请参阅使用消息队列。

Microsoft 管理控制台

可以使用 Microsoft 管理控制台 (MMC) 在单一界面内组织管理工具和进程。还可以通过为特定用户创建预配置的 MMC 控制台给他们委派任务。控制台为用户提供了您选择的工具。详细信息，请参阅 Microsoft 管理控制台。

网络地址转换

网络地址转换 (NAT) 通过将专用内部地址转换为公用外部地址，使外部网络不显示内部管理的 IP 地址。通过让您在内部使用专用 IP 地址，并转换为数量较少的已注册的对外 IP 地址，便可以降低 IP 地址注册的成本。同时也隐藏了内部网络结构，从而降低了内部系统受到攻击的风险。详细信息，请参阅了解网络地址转换。

网络负载平衡群集

以前被称为 Windows NT 负载平衡服务 (WLBS) 的网络负载平衡在多个服务器中分布传入的 TCP/IP 通信。群集应用程序，特别是 Web 服务器应用程序，可以处理更多通信，并提供更高的可用性和更快的响应时间。详细信息，请参阅网络负载平衡群集。

操作系统迁移、支持和集成

Windows Server 2003 产品家族可实现与现有系统的无缝集成，它还支持早期的 Windows 操作系统，以及其他常用操作系统。包括了下面的支持：

  • 与 Windows NT Server 3.51 和 4.0 的互操作性。
  • 支持运行多种操作系统（包括 Windows 3.x、Windows 95、Windows 98、Windows 2000 和 Windows NT Workstation 4.0）的客户端。
  • UNIX 互操作性，这种互操作性是通过名为 Windows Services for UNIX 的附加包提供的。Telnet 服务（用于远程访问和管理）包含在 Windows Server 2003 家族中，以及附加软件包中。
  • 大型机和中型机连接，使用 S/390 和 AS/400 事务并通过 Host Integration Server 2000 排队网关。

  • Macintosh 文件服务器，允许 Macintosh 客户端使用 TCP/IP 协议（IP 上的 AFP）共享文件，访问在运行 Windows Server 2003, Standard Edition、Windows Server 2003, Enterprise Edition 或 Windows Server 2003, Datacenter Edition 的服务器上的共享文件。详细信息，请参阅 Macintosh 服务。

    运行 Microsoft® Windows® Server 2003, Web Edition 操作系统的计算机不包括该功能。有关详细信息，请参阅 Windows Server 2003 Web Edition 概述。

即插即用

通过即插即用（一种硬件和软件支持的组合），服务器可以自动识别和适应硬件配置更改，无需用户的干预和重新启动。详细信息，请参阅即插即用概述。

公钥结构和智能卡基础结构

使用证书服务和证书管理工具，可以部署自己的公钥结构 (PKI)。通过 PKI 可以实现基于标准的技术，如智能卡登录功能、客户端身份验证 [安全套接字层 (SSL) 和传输层安全性 (TLS)]、安全的电子邮件、数字签名以及安全连接 [使用 Internet 协议安全 (IPSec)]。使用“证书服务”可以设置并管理颁发和吊销 X.509 v3 证书的证书颁发机构 (CA)。这表示尽管您可以选择将商业客户端身份验证集成到 PKI 中，却无需依赖商业客户端身份验证服务。详细信息，请参阅证书服务和智能卡。

服务质量

基于服务质量 (QoS) 的服务和协议，提供了有保证的跨网络端对端快速信息传递系统。详细信息，请参阅服务质量 (QoS)。

故障恢复控制台

通过故障恢复控制台，可以在有软件问题（如驱动程序或文件发生的问题）妨碍系统启动的系统上，启动命令行控制台。从故障恢复控制台中，可以使用基本命令尝试恢复系统。详细信息，请参阅故障恢复控制台概述。

远程协助

可使用“远程协助”来远程管理计算机。如果您收到邀请，远程协助可以使您轻松地从运行 Windows XP 或 Windows Server 2003 家族中任意产品的计算机连接到远程计算机。连接上之后，即可查看远程计算机的屏幕而且可进行实时聊天。如果请求协助的人允许，您甚至可以使用鼠标和键盘在远程计算机上进行操作。详细信息，请参阅远程协助。

XOX

管理远程桌面

通过管理远程桌面（以前被称为远程管理模式下的终端服务），几乎可以从网络上的任何计算机对其他计算机进行管理。管理远程桌面基于终端服务技术，是为进行服务器管理而专门设计的。有关此功能的详细信息，请参阅管理远程桌面。

远程安装服务

通过远程安装服务 (RIS)，可以创建操作系统的安装映像，甚至也可以创建完整的计算机配置（包括桌面设置和应用程序）的安装映像。然后可以使客户端计算机上的用户可以使用这些映像。客户端计算机必须支持使用预启动执行环境 (PXE) ROM 的远程启动，或者它们必须用远程启动软盘启动。详细信息，请参阅远程安装服务。

运行 Microsoft® Windows® Server 2003, Web Edition 操作系统的计算机不包括该功能。有关详细信息，请参阅 Windows Server 2003 Web Edition 概述。

远程存储

远程存储根据您指定的条件将很少使用的文件自动复制到可移动媒体。如果硬盘空间降到了一定的级别，“远程存储”会从硬盘上移走（缓存的）文件内容。如果以后需要该文件，文件的内容又会自动从存储中重新调回。详细信息，请参阅远程存储。

“远程存储”在 Windows Server 2003, Web Edition 或 Windows Server 2003, Standard Edition 上不可用。有关 Windows Server 2003, Web Edition 的详细信息，请参阅 Windows Server 2003, Web Edition 概述。

可移动存储

可移动存储使用户可以更方便地跟踪可移动存储媒体（磁带和光盘），更方便地管理包含这些媒体的硬件库，例如转换器和自动唱片点唱机。由于可移动光盘和磁带的每兆字节 (MB) 的成本比硬盘便宜，因此使用可移动存储和远程存储可以降低成本。详细信息，请参阅可移动存储。

路由和远程访问

“路由和远程访问”代替了 Windows NT 4.0 中的“路由和远程访问服务 (RRAS)”和“远程访问服务 (RAS)”功能。路由和远程访问是单一的集成服务，终止来自拨号或虚拟专用网络 (VPN) 客户端的连接，或者提供路由（IP、IPX 和 Macintosh 服务），或两者同时提供。通过路由和远程访问，服务器可用作远程访问服务器、VPN 服务器、网关或分支机构路由器。详细信息，请参阅路由和远程访问。

安全模式

通过安全模式，可以启动具有最少驱动程序和服务集的 Windows 操作系统，然后查看显示启动时的事件顺序的日志。使用“安全模式”可以诊断出可能导致系统无法正常启动的驱动程序和其他组件的问题。详细信息，请参阅启动选项。

安全配置向导

“安全配置向导”减小了运行带有 Service Pack 1 (SP1) 的 Windows Server 2003 的计算机的受攻击面。该向导询问用户一系列问题以确定服务器的功能要求。然后禁用该服务器正在执行的角色不需要的功能。除了作为一项重要的安全最佳做法外，攻击面的减小增加了 Windows 环境的多样性，还可以在出现安全问题时减少需要立即更新的系统的数量。详细信息，请参阅 Microsoft 网站。(http://www.microsoft.com/)

服务器群集（仅用于 Windows Server 2003, Enterprise Edition 和 Windows Server 2003, Datacenter Edition）

服务器群集为重要的资源和应用程序提供了高可用性、可伸缩性和可管理性。群集中的多台服务器（节点）的通信持续不断。如果群集中的一个节点由于故障或维护而无法使用，另一个节点就会立即开始提供服务（该过程称为故障转移）。访问群集的用户会持续地与基于服务器的资源连接。

通过 Windows Server 2003, Enterprise Edition 和 Windows Server 2003, Datacenter Edition，可以根据您的要求以三种群集模式中的一种配置服务器群集。详细信息，请参阅服务器群集。

智能卡基础结构

使用证书服务和证书管理工具，您可以部署自己的公钥结构 (PKI)。通过 PKI 可以实现基于标准的技术，如智能卡登录功能、客户端身份验证 [通过安全套接字层 (SSL) 和传输层安全性 (TLS)]、安全的电子邮件、数字签名以及安全连接 [使用 Internet 协议安全 (IPSec)]。详细信息，请参阅证书服务和智能卡。

软件限制策略

使用软件限制策略，通过标识并指定允许哪些应用程序运行，您可以保护计算机环境免受不可信代码的侵扰。详细信息，请参阅软件限制策略。

TAPI 3.1

TAPI 3.1 统一了 Internet 协议 (IP) 和传统的电话服务，使开发人员可以创建计算机电话服务应用程序，该程序在 Internet 或 Intranet 上的运行与在传统的电话网络上运行一样有效。详细信息，请参阅电话服务。

终端服务器

通过使用终端服务器，用户可以从各种旧式设备访问在服务器上运行的程序。例如，用户可以通过无法在本地运行软件的硬件访问虚拟 Windows XP Professional 桌面和基于 x86 的 Windows 应用程序。终端服务器为 Windows 客户端设备和其他客户端设备提供该功能。（其他设备需要 Citrix Systems 提供的附加软件。）有关更多详细说明，请参阅终端服务器功能。

运行 Microsoft® Windows® Server 2003, Web Edition 操作系统的计算机不包括该功能。详细信息，请参阅 Windows Server 2003 Web Edition 概述。注意：“管理远程桌面”在 Windows Server 2003, Web Edition 上是可用的。

通用描述、发现和集成服务

通用描述、发现和集成 (UDDI) 是发布和查找有关 Web 服务信息的行业规范。Windows Server 2003 家族中的一些产品包含 UDDI 服务，该服务是一种在企业内部或组织之间提供 UDDI 功能的 Web 服务。详细信息，请参阅 UDDI 服务概述。

Windows Server 2003, Web Edition 中不包括“UDDI 服务”。此外，Windows Server 2003, Standard Edition 仅支持“UDDI 服务”的独立安装。Windows Server 2003, Enterprise Edition 和 Windows Server 2003, Datacenter Edition 中提供了对分布式安装的支持。在“UDDI 服务”的独立安装中，UDDI Web 服务器组件和 UDDI 数据库组件都可安装在单个服务器上。在分布式安装中，UDDI 组件分布在多个服务器上。

有关 Windows Server 2003, Web Edition 的详细信息，请参阅 Windows Server 2003, Web Edition 概述。

虚拟专用网络

实施虚拟专用网络 (VPN) 可以使用户随时访问单位的网络（即使他们不在办公室），并可降低这种访问的成本。VPN 连接将创建跨 Internet 进入专用网络的安全隧道。

Windows Server 2003 家族中包含有两种类型的 VPN 技术：

  • 点对点隧道协议 (PPTP)，该协议使用用户级的点对点协议 (PPP) 身份验证方法和用于数据加密的 Microsoft 点对点加密 (MPPE)。
  • 第二层隧道协议 (L2TP) 与 Internet 协议安全 (IPSec)。L2TP 在数据加密方面使用用户级的 PPP 身份验证方法和具有 IPSec 的计算机级证书。

XOX

有关虚拟专用网络的详细信息，请参阅虚拟专用网络。

Windows 防火墙

Windows 防火墙采用的是一种宿主防火墙技术。作为宿主防火墙，Windows 防火墙运行在各个客户端和服务器上。它可以保护客户端和服务器免受通过外围网络或起源于组织内部的网络攻击（如特洛伊木马攻击、端口扫描攻击以及蠕虫病毒）。像许多防火墙技术一样，Windows 防火墙也是一种基于状态检测的防火墙。同时，Windows 防火墙还能够检测并筛选 Internet 协议版本 4 (IPv4) 和 Internet 协议版本 6 (IPv6) 通讯。不请自到的入站通讯会被丢弃，除非它是对主机请求的响应（被请求的通讯），或者是经过特别允许的（例外）通讯。可以通过配置 Windows 防火墙设置，根据端口号、应用程序名或服务名来指定例外通讯。除了某些 Internet 控制消息协议 (ICMP) 消息，Windows 防火墙允许所有其他出站通讯。

Windows Media Services

Windows Media Services 提供在公司的内部网和 Internet 中对音频分流和视频分流的支持。在 Windows Server 2003, Enterprise Edition 或 Windows Server 2003, Datacenter Edition 上，Windows Media Services 提供高级流式播放功能，如多播、无线网络支持、Internet 身份验证、服务器插件和缓存/代理 API。

Windows Server 2003, Web Edition 或 Windows Server 2003 家族的 64 位版本中未包含 Windows Media Services。

Windows Script Host

通过使用 Windows Script Host (WSH)，可以自动进行诸如创建快捷方式和连接到网络服务器以及与网络服务器断开连接之类的操作。WSH 与语言无关：可以使用常用的脚本语言（例如 Microsoft Visual Basic Scripting Edition 和 Jscript）来编写脚本。详细信息，请参阅 Windows Script Host。

Windows Update

Windows Update 是 Windows 的联机扩展，可检测过时的 Windows 系统文件并用最新版本进行替换。Windows Update 可以在长时间内大大地提高计算机系统的稳定性。它还可以减轻负责维护生产性操作环境的管理员和支持人员的负担。Windows Update 需要 Internet 连接。详细信息，请参阅 Windows Update 和使用 Windows Update。

Winsock Direct

现在已经在所有服务器版本上提供了 Winsock Direct，它能使使用 Winsock 的应用程序在跨系统区域网 (SAN) 通信时运行速度更快并且开销较少。如果有 SAN，那么 Winsock Direct 会具有简化分布式组件之间通信的效果。有关 Winsock Direct 的详细信息，请参阅“Internetworking Guide”中的“附录 B：Windows Server 2003 网络体系结构”，位于 Windows 部署和资源工具包网站 (http://www.microsoft.com/)。


功能概述

本部分提供有关 Microsoft® Windows® Server 2003 家族操作系统中的新功能和改进功能的信息。有关指向此版本中这些功能详细信息的链接，请参阅新功能。

本部分包括：

  • 用于管理、提高安全性和提供最佳性能的功能
  • 提供文件、打印和协作服务的功能
  • Internet、应用程序和网络服务功能

注意

  • 有关 Windows Server 2003 R2 中组件的信息，请参阅 Windows Server 2003 R2 中的新增功能。


用于管理、提高安全性和提供最佳性能的功能

Windows Server 2003 家族中的功能可以确保在提供强大的安全和性能的同时，数据访问、存储和交换能够满足您的需要。

有关指向此版本中这些功能详细信息的链接，请参阅新功能。

本部分包括：

  • 服务器可靠性
  • 服务器可用性
  • 服务器可伸缩性
  • 服务器可管理性
  • 性能和调节功能
  • 身份验证和智能卡支持
  • 其他安全功能
  • 远程管理
  • 维护和产品更新
  • 国际化功能

注意

  • 有关 Windows Server 2003 R2 中组件的信息，请参阅 Microsoft Windows Server 2003 R2 中的新增功能。


服务器可靠性

本主题概述了支持服务器可靠性的功能。它包括以下两部分内容：自 Windows NT 4.0 以后的新功能与更新功能以及自 Windows 2000 以后的新功能与更新功能。

有关指向此版本中这些功能详细信息的链接，请参阅新功能。

可靠性是指计算机系统或设备在给定的时间段内和指定的状况下持续运行的可能性。有关与可用性（与可靠性密切相关）相关的功能说明，请参阅服务器可用性。

自 Windows NT 4.0 以后的新功能与更新功能

Windows Server 2003 家族提供了以下改进功能（与 Windows NT 相比），这些功能有助于提供更高的服务器可靠性：

改进的内存管理
Windows 2000 和 Windows Server 2003 家族中对内存管理的改进将使服务器具有更快的速度、更高的可靠性和灵活性。
稳健的系统体系结构
系统越稳健，其可靠性就越大，即使一个应用程序或服务遇到了问题，也是如此。例如，通过对没有响应的应用程序进行了更好的处理，可以移动、最小化、关闭没有响应的应用程序的窗口，并可调整其大小。此外，在更新的驱动程序不能正常运行的情况下，还可以还原旧的驱动程序。系统的支持结构可以确保在早期 Windows 操作系统上正常运行的应用程序能够继续在 Windows Server 2003 家族产品上运行。
诊断工具
可以使用此版本中包括的经过改进的诊断工具来监视系统状态并防止发生问题。详细信息，请参阅监视和状态工具。
安全模式启动
使用安全模式可以启动具有最小驱动程序和服务集的操作系统，然后查看显示启动时的事件序列的日志。使用安全模式可以诊断出可能导致系统无法正常启动的驱动程序和其他组件的问题。详细信息，请参阅故障恢复。
故障恢复控制台
通过故障恢复控制台，可以在由于软件问题（如驱动程序或文件发生的问题）阻止系统启动的系统上启动命令行控制台。可以使用基本命令从故障恢复控制台对系统进行恢复。详细信息，请参阅故障恢复控制台概述。
Windows 文件保护
Windows 文件保护可防止受保护的系统文件（如 .sys、.dll、.ocx、.ttf、.fon 和 .exe 文件）被替换。Windows 文件保护在后台运行并阻止其他程序更改操作系统需要的文件。详细信息，请参阅 Windows 文件保护。
增强的备份实用程序
可以将数据备份到各种各样的存储媒体，如磁带机、外部硬盘，以及 Zip 磁盘。详细信息，请参阅备份和还原数据。

自 Windows 2000 以后的新功能与更新功能

Windows Server 2003 家族提供了以下改进功能（与 Windows 2000 相比），这些功能有助于提供更高的服务器可靠性：

自动系统故障恢复
自动系统故障恢复 (ASR) 可帮助您在硬盘发生故障或系统严重受损的情况下恢复系统。可以通过“备份”中的多种向导轻松地为 ASR 准备必要的备份资料。通过使用 ASR 并与标准备份（数据和应用程序备份）结合，可以将系统还原到备份之前的状态。有关 ASR 的详细信息，请参阅自动系统故障恢复 (ASR) 概述。有关其他系统恢复选项的详细信息，请参阅故障恢复。
兼容模式
新的兼容模式功能可确保许多常用的应用程序最佳的兼容性。“兼容模式”技术提供了一种可更加紧密地反映 Windows 95、Windows 98、Windows NT 4.0 或 Windows 2000 操作系统行为的环境。这些模式解决了阻止早期的应用程序正常工作的许多最常见问题。迁移后出现问题的应用程序可能会通过在其中某个兼容性环境中启动而受益。高级用户还可以利用此技术为他们自己的应用程序创建解决方案。


服务器可用性

本主题概述了支持服务器可用性的功能。它包括以下两部分内容：自 Windows NT 4.0 以后的新功能与更新功能以及自 Windows 2000 以后的新功能与更新功能。

有关指向此版本中这些功能详细信息的链接，请参阅新功能。

可用性是应用程序、服务或系统提供的服务级别。不管是计划内的或计划外的故障时间，高度可用的系统具有最小的故障时间。Windows Server 2003 家族对您的关键业务解决方案提供服务器高可用性支持。此外，该操作系统还提供了群集、高级容错和文件系统恢复功能。

自 Windows NT 4.0 以后的新功能与更新功能

Windows Server 2003 家族提供了以下改进功能（与 Windows NT 相比），这些功能有助于提供更高的服务器可用性：

服务器群集（仅用于 Windows Server 2003, Enterprise Edition 和 Windows Server 2003, Datacenter Edition）
服务器群集为重要资源和应用程序提供了高可用性、可伸缩性和可管理性。群集中的多台服务器（节点）保持持续通信。如果群集中的某个节点由于故障或维护而不可用，另一个节点就会立即开始提供服务（该过程称为故障转移）。访问群集的用户会持续地与基于服务器的资源连接。详细信息，请参阅 Windows 群集。
网络负载平衡
网络负载平衡增强了执行关键任务的服务器上 Internet 服务器程序的可用性和可伸缩性。网络负载平衡的两个主要功能是为 Web 服务器程序提供高可用性以及提高服务器性能。通过将两台或多台计算机组合到一个群集中，网络负载平衡通过对传入的网络通信进行分布式处理提高了可靠性和性能。详细信息，请参阅网络负载平衡概述。
服务器重新启动次数更少
配置硬件和软件的工作变得更加方便，因为无须重新启动服务器便可以完成许多任务。这些任务包括但不仅限于：
  • 扩展存储卷
  • 配置网络协议
  • 动态地管理存储（动态卷管理）
  • 重新配置外围组件互连 (PCI) 和其他即插即用硬件上的设置
即插即用
通过即插即用（一种硬件和软件支持的组合），服务器可以自动识别和适应硬件配置更改，无需用户的干预和重新启动。通过即插即用，计划的系统重新启动次数减少 90% 以上。
从镜像卷启动
通过相应的准备，可以从在镜像卷上的冗余数据副本中启动服务器，这样会提高系统在服务器恢复或计划的维护期间的可用性。详细信息，请参阅使用镜像卷。

自 Windows 2000 以后的新功能与更新功能

Windows Server 2003 家族提供了以下改进功能（与 Windows 2000 相比），这些功能有助于提供更高的服务器可用性：

用户状态迁移工具
用户状态迁移工具 (USMT) 通过捕获和还原用户设置、文件和文档有助于进行部署。用户不必为诸如电子邮件服务器、代理服务器、桌面配色方案和桌面墙纸等重新配置桌面设置。
紧急管理服务
通过紧急管理服务，并与相应的硬件结合，即使在无法通过标准远程管理工具和机制访问服务器时，也可以完成远程管理和系统恢复任务。详细信息，请参阅紧急管理服务。
存储区域网络和网络访问服务器支持
Windows Server 2003 家族中的存储区域网络 (SAN) 和网络访问服务器 (NAS) 支持具有许多新的系统增强功能，以提高服务器的可用性。这些改进功能包括容错、网络连接方案，如连接到 SAN 和 NAS 服务器。连接到 SAN 时，Windows Server 2003 家族支持多路径故障转移，即从主服务器（运行 Windows 2000 Server、Windows 2000 Advanced Server、Windows 2000 Datacenter Server 或 Windows Server 2003 家族中的任何产品）到 SAN 卷启用冗余路径。Windows Server 2003 家族还支持连接到 NAS 以及用作 NAS。
网络负载平衡增强功能
在此版本中对网络负载平衡进行了多项改进：
  • 网络负载平衡现在可以绑定到多个网络适配器，以便可以在每一台主机上配置多个独立的群集。有关虚拟群集的详细信息，请参阅虚拟群集。
  • 网络负载平衡使用 Internet 组管理协议 (IGMP) 支持限制交换流，以使流向网络负载平衡群集的流量只经过那些用于群集主机的端口，而不经过所有交换端口。
  • 通过网络负载平衡管理器，可以创建新的网络负载平衡群集，并可以从一台远程或本地计算机对群集和群集中的所有主机进行配置和管理。


服务器可伸缩性

本主题概述了支持服务器可伸缩性的功能。它包括以下两部分内容：自 Windows NT 4.0 以后的新功能与更新功能以及自 Windows 2000 以后的新功能与更新功能。

有关指向此版本中这些功能详细信息的链接，请参阅新功能。

可伸缩性是度量计算机、服务或应用程序如何更好地增长以满足持续增长的性能需求的标准。对于服务器群集而言，它是指当群集的全部负载超过其能力时逐步将一个或多个系统添加到现有群集中的能力。Windows Server 2003 家族中的产品具有可伸缩性，可适应从小型工作组到企业数据中心部署的各种需求，并支持多达 64 个处理器以及高级输入/输出。Windows Server 2003 家族还为您的业务应用程序集成了网络负载平衡和多处理器优化。

自 Windows NT 4.0 以后的新功能与更新功能

Windows Server 2003 家族提供了以下改进功能（与 Windows NT 相比），这些功能有助于提供更强的服务器可伸缩性：

硬件可伸缩性
通过选择 Windows Server 2003 家族产品，您可以充分利用数量持续增加的低价位多处理器计算机。
I2O 支持
I2O（也称为智能输入/输出）体系结构将某些 I/O 操作卸载到辅助处理器，从而为服务器提供更高的 I/O 性能。I2O 提高了高带宽应用程序中的 I/O 性能，如网络视频、组件和客户端/服务器处理。
对称多重处理增强功能
Windows Server 2003 家族支持符合对称多重处理 (SMP) 标准的单个或多个 CPU。操作系统可以通过 SMP 运行任何可用处理器上的线程，这使得当需要额外处理能力来提高系统的功能时应用程序可以使用多个处理器。新功能包括 SMP 锁定性能、已改进的注册表性能和性能已提高的终端服务器会话。
网络负载平衡
网络负载平衡 [以前称为 Windows NT 负载平衡服务 (WLBS)] 在多个服务器之间分发传入的 TCP/IP 通信。群集应用程序（特别是 Web 服务器应用程序）可以处理更多通讯，并提供更高的可用性和更快的响应时间。
服务器群集（仅限于 XOX 和 XOX）
服务器群集为重要资源和应用程序提供了高可用性、可伸缩性和可管理功能。群集中的多台服务器（节点）保持持续通信。如果群集中的某个节点由于故障或维护而不可用，则另一个节点将立即开始提供服务（称为故障转移过程）。访问群集的用户会持续地与基于服务器的资源连接。详细信息，请参阅 Windows 群集。
企业内存体系结构（XOX 和 XOX，不包括 64 位版本）
使用企业内存体系结构可运行那些利用 XOX 上的大量物理内存的应用程序。如果使用用地址窗口化扩展 (AWE) API 编写的应用程序，则可以将更多的物理内存映射到应用程序的虚拟地址内存空间以提高性能。对于使用 2 GB 到 4 GB 内存的系统，也可以使用应用程序内存调整，也称为 4 GB 地址空间调整 (4GT)。通过为操作系统提供较少的内存，可为应用程序提供高达 3 GB 的虚拟地址内存空间。

自 Windows 2000 以后的新功能与更新功能

Windows Server 2003 家族提供了如下改进功能（与 Windows 2000 相比），这些功能有助于提供更强的服务器可伸缩性：

Internet 信息服务 6.0
Internet 信息服务 (IIS) 6.0 是一种功能齐全的 Web 服务器，为 Windows Server 2003 家族和现有 Web 应用程序及 Web 服务提供了基础。IIS 6.0 提供了专用应用程序模式，该模式在隔离环境下运行所有的应用程序代码。IIS 6.0 还支持 Web 园，在 Web 园中，计算机上的等效进程均接收通常由单个进程服务的请求共享，从而取得了更好的多处理器可伸缩性。详细信息，请参阅 Internet 信息服务 (IIS) 6.0。

注意

  • 默认情况下，IIS 不与全新安装的 XOX、XOX 和 XOX 一起安装。您可以使用“配置您的服务器向导”或控制面板中的“添加或删除程序”安装该服务。
网络负载平衡增强功能
在此版本中对网络负载平衡进行了多项改进：
  • 网络负载平衡现在可以绑定到多个网络适配器，以便可以在每一台主机上配置多个独立的群集。有关虚拟群集的详细信息，请参阅虚拟群集。
  • 网络负载平衡使用 Internet 组管理协议 (IGMP) 限制切换流，以使流向网络负载平衡群集的流量只经过那些用于群集主机的端口，而不经过所有交换端口。
  • 通过网络负载平衡管理器，可以创建新的网络负载平衡群集，并可以从一台远程或本地计算机对群集和群集中的所有主机进行配置和管理。


服务器可管理性

本主题概述了支持服务器可管理性的功能。它包括以下两部分内容：自 Windows NT 4.0 以后的新功能与更新功能以及自 Windows 2000 以后的新功能与更新功能。

有关指向此版本中这些功能详细信息的链接，请参阅新功能。

Windows Server 2003 家族中改进的可管理性使得部署和维护 Windows 应用程序和系统变得非常简单。

自 Windows NT 4.0 以后的新功能与更新功能

Windows Server 2003 家族提供了以下改进功能（与 Windows NT 相比），这些功能有助于提供更高的服务器可管理性：

IntelliMirror
为帮助降低成本，管理员需要对于便携系统和桌面系统拥有最高级别的控制权。IntelliMirror 在运行 Windows 2000 Professional 或 Windows XP Professional 的客户端系统上提供了这种控制。可以使用 IntelliMirror 基于业务角色、组成员身份和位置定义策略设置。为了满足特定用户的要求，系统会在该用户每次登录到网络时（不管用户在哪里登录）使用这些策略设置对 Windows 2000 Professional 桌面和 Windows XP Professional 桌面自动进行重新配置。有关 IntelliMirror 的详细信息，请参阅 IntelliMirror。
Windows Management Instrumentation
Windows Management Instrumentation (WMI) 是一种可伸缩的管理基础结构，它以基于 Web 的企业管理 (WBEM) 倡议为基础。通过 WMI（包括命令行和脚本功能），可以监视、跟踪和控制与软件应用程序、硬件组件和网络相关的系统事件。WMI 包含统一的脚本应用程序编程接口 (API)，该 API 定义了基于一般信息模型 (CIM) 的公用对象框架下的所有受管理的对象。WMI 通过枚举可用的类使应用程序和脚本发现哪些信息对系统可用。WMI 可以提交查询，以便筛选对非常特定信息的请求，并可以根据您的特殊兴趣订阅 WMI 事件，而不是仅限于原始开发人员预定义的那些事件。有关 WMI 的详细信息，请参阅 WMI 概述。
Active Directory 迁移工具
Active Directory 迁移工具 (ADMT) 有助于将 Windows NT 4.0 域中的用户帐户、组和计算机帐户迁移到 Active Directory 域中（也就是其域控制器运行 Windows 2000 或 Windows Server 2003 的域）。详细信息，请参阅 Active Directory 支持工具以及 Microsoft Windows 资源工具包网站上的“Designing and Deploying Directory and Security Services”（设计和部署目录及安全服务）(http://www.microsoft.com/)。
远程安装服务
通过远程安装服务 (RIS)，可以创建操作系统的安装映像，甚至也可以创建完整的计算机配置（包括桌面设置和应用程序）的安装映像。然后可以使客户端计算机上的用户可以使用这些映像。客户端计算机必须支持使用预启动执行环境 (PXE) ROM 的远程启动，或者它们必须可以用远程启动软盘启动。详细信息，请参阅远程安装服务。

运行 Microsoft® Windows® Server 2003, Web Edition 操作系统的计算机不包括该功能。详细信息，请参阅 Windows Server 2003 Web Edition 概述。

管理您的服务器
“管理您的服务器向导”为您提供了一个设置各种服务器角色和执行每日管理任务的中央位置。详细信息，请参阅为服务器配置角色。

自 Windows 2000 以后的新功能与更新功能

Windows Server 2003 家族提供了以下改进功能（与 Windows 2000 相比），这些功能有助于提供更高的服务器可管理性：

管理远程桌面
通过管理远程桌面（以前被称为“远程管理模式下的终端服务”），您可以从网络上的任何计算机对计算机进行管理。管理远程桌面基于终端服务技术，是为进行服务器管理而专门设计的。有关此功能的详细信息，请参阅管理远程桌面。
远程管理的服务器支持
远程管理的服务器支持提供了对没有监视器、VGA 显示适配器、键盘或鼠标的计算机进行安装和管理的能力。该功能还包括“紧急管理服务”，它提供了一种在操作系统不运行时 [例如计算机重新启动、网络上的服务器不可用或使用“远程安装服务 (RIS)”期间] 管理远程受控服务器的机制。
用户状态迁移工具
用户状态迁移工具 (USMT) 通过捕获和还原用户设置、文件和文档有助于进行部署。用户不必为诸如电子邮件服务器、代理服务器、桌面配色方案和桌面墙纸等重新配置桌面设置。
紧急管理服务
通过紧急管理服务，并与相应的硬件结合，即使在无法通过标准远程管理工具和机制访问服务器时，也可以完成远程管理和系统恢复任务。详细信息，请参阅紧急管理服务。
策略的结果集
可以使用策略的结果集 (RSoP) 模拟和测试通过组策略应用到计算机或用户的策略设置。RSoP 是一个查询引擎，可以轮询现有策略（也是计划的策略），然后报告查询结果。它根据站点、域、域控制器和组织单位轮询现有策略。RSoP 从 Windows Management Instrumentation (WMI) 收集该信息。详细信息，请参阅策略的结果集。
Windows Management Instrumentation 改进功能
Windows Management Instrumentation (WMI) 筛选功能通过帮助您确定组策略对象 (GPO) 的效果增强了组策略基础结构。
远程安装服务改进功能
远程安装服务 (RIS) 的增强包括对 Windows Server 2003 家族与 Windows XP 产品的安装支持，对 RIS 安装中应答文件处理的进一步控制，以及对恢复模式中网络文件的访问权限。

运行 Microsoft® Windows® Server 2003, Web Edition 操作系统的计算机不包括该功能。详细信息，请参阅 Windows Server 2003 Web Edition 概述。

授权管理器
授权管理器是一个用于执行与授权相关的任务的新工具。对于在应用程序中使用授权服务的应用程序开发人员，以及对于那些负责定义组并指派安全主体来担任角色并执行需要相应用户权利和权限的任务的管理员，该工具十分有用。详细信息，请参阅授权管理器。


性能和调节功能

本主题概述了 Windows Server 2003 家族中的性能和调节功能。它分为两部分：自 Windows NT 4.0 以后的新功能与更新功能以及自 Windows 2000 以后的新功能与更新功能。

Windows Server 2003 家族中的新功能提供了更好的性能，并提供了按照您的需要和环境对服务器进行调整的功能。有关此版本中这些功能详细信息的链接，请参阅新功能。

自 Windows NT 4.0 以后的新功能与更新功能

Windows Server 2003 家族提供了如下改进功能（与 Windows NT 4.0 相比），这些功能有助于提供更高的服务器性能：

Winsock Direct
Winsock Direct 使采用 Winsock 的应用程序能够执行得更快，并且当它们跨系统区域网 (SAN) 通讯时使用较少的 CPU 开销。Winsock Direct 可在 SAN 到位的情况下简化分布式组件之间的通讯。
I2O 支持
I2O（又称智能输入/输出）体系结构通过将某些输入/输出 (I/O) 操作卸载到辅助处理器，从而可为您的服务器提供更高的 I/O 性能。I2O 提高了高带宽应用程序（如网络视频、组件和客户端/服务器处理）中的 I/O 性能。
对于 Web 应用程序和站点的 CPU 限制
CPU 限制将限制 Web 应用程序或站点所能使用的 CPU 时间量。这将确保其他网站和非 Web 应用程序可以使用处理器时间。
对于 Web 应用程序和站点的进程记帐
使用进程记帐，您可以获得有关网站如何使用 CPU 资源的信息。该信息对于决定更改或改进硬件或应用程序可能至关重要。当使用脚本或应用程序监视或诊断故障时，它也非常重要。
可预计的端对端服务质量
基于“服务质量 (QoS)”的服务与协议为由跨越一个网络或跨越多个不同网络的程序（已启用 QoS）生成的通讯提供了一个有保证的端对端快速传送系统。详细信息，请参阅服务质量 (QoS)。
网络负载平衡
网络负载平衡以前称为“Windows NT 负载平衡服务 (WLBS)”，它在多台服务器之间分发传入的 TCP/IP 通讯。群集应用程序，特别是 Web 服务器应用程序，可以处理更多通信，并提供更高的可用性和更快的响应时间。
新性能工具
许多新性能工具有助于诊断和解决内存、注册表、驱动程序和其他系统问题。
磁盘碎片整理程序
磁盘碎片整理程序的增强包括 Defrag.exe，这是一个新的命令行工具。现在，磁盘碎片整理程序和 Defrag.exe 都可以整理 NTFS 卷上的主文件表 (MFT) 的碎片。详细信息，请参阅磁盘碎片整理程序。
事件跟踪增强功能
事件跟踪提供了一种管理数据的机制，该机制对性能监视器、容量规划工具和其他用于对系统资源使用状况相关信息进行分析的应用程序十分有用。新的命令行工具控制本地和远程计算机上的事件跟踪日志计划、收集和分析。

自 Windows 2000 以后的新功能与更新功能

Windows Server 2003 家族提供了如下改进功能（与 Windows 2000 相比），这些功能有助于提供更高的服务器性能：

性能选项
性能选项是合并了处理器、内存和虚拟内存等设置的工具，从而可以快速简便地将计算机配置为最佳性能。
用于系统监视器的新的命令行实用程序
新的命令行工具可以在不使用系统监视器 (Sysmon) 的情况下控制性能计数器和事件跟踪日志计划以及对本地和远程计算机的收集和分析。这些命令行工具包括 logman、relog、tracerpt 和 typeperf。详细信息，请参阅 Logman、Relog、Tracerpt 和 Typeperf。
系统监视器增强功能
Windows Server 2003 家族支持同时从多个日志文件查看数据，并支持查看通过使用“性能日志和警报”服务收集并存储在 SQL 数据库中的数据。从性能日志文件或 SQL 数据库中选定的数据可以保存到新文件中以便日后分析。显示增强使选择多个计数器对象以及显示直接从列表窗口选定的计数器的数据属性页变得更为方便。
性能日志和警报改进功能
Windows Server 2003 家族支持使用新的日志文件格式且大于 1 GB 的日志文件，性能数据目前可以附加到现有的日志文件中。可以通过开放式数据库连接 (ODBC) 数据连接直接将数据记录到 SQL 数据库中。
Windows 内存管理器增强功能
作为 Windows Server 2003 开发的一部分，已经对该内存管理器进行了更改以改善分页操作。该内存管理器总是试图尽可能灵活地保留已使用的物理内存。因此，只要时间允许，在内存中所做的所有更改都将写入到磁盘中，这样便使得此部分的物理内存可用于系统中所有运行的组件。此操作称为“页面输出”操作，即使不是在系统运行在内存不足的情况下也会主动发生此操作。

在 Windows Server 2003 中，分页操作的效率已经得到了增强。因此，很大程度上依赖分页操作的应用程序将运行得更快，而且到附加硬盘的分页操作的速率将会提高。

可以通过性能监视对象 "Memory / Pages Output/s." 来监视页面退出操作。此计数器的高峰值仅指示系统的较高内存活动，而不指示低内存状况。

如果需要监视系统的低内存状况，“Memory / Available Bytes”计数器与反向分页操作计数器“Memory / Pages Input/s”可以一起展示系统总体的内存状况。

详细信息，请参阅 Windows Server 技术中心。(http://www.microsoft.com/)


身份验证和智能卡支持

本主题概述了此版本中的身份验证和智能卡支持功能。它分为两部分：自 Windows NT 4.0 以后的新功能与更新功能以及自 Windows 2000 以后的新功能与更新功能。

有关此版本中这些功能详细信息的链接，请参阅新功能。

Windows Server 2003 家族包含多种身份验证技术，包括使用智能卡的技术。有关新的安全功能的详细信息，请参阅新增安全功能。

自 Windows NT 4.0 以后的新功能与更新功能

Windows Server 2003 家族进行了以下改进（与 Windows NT 4.0 相比），从而有助于更好地支持身份验证，以及智能卡的使用：

Kerberos V5 协议的完全支持
利用 Kerberos V5 支持，用户可以通过快速的单一登录过程访问 Windows 2000 或 Windows Server 2003 家族产品上运行的企业资源。对 Kerberos V5 的支持还包括其他优点，如相互进行身份验证（客户端和服务器都必须提供身份验证）和受委派的身份验证（从头至尾跟踪用户的凭据）。详细信息，请参阅 Kerberos V5 身份验证。
公钥结构、证书服务和智能卡
使用证书服务和证书管理工具，您可以部署自己的公钥结构 (PKI)。通过 PKI 可以实现基于标准的技术，如智能卡登录功能、客户端身份验证 [通过安全套接字层 (SSL) 和传输层安全性 (TLS)]、安全的电子邮件、数字签名以及安全连接 [通过 Internet 协议安全 (IPSec)]。使用“证书服务”可以设置并管理颁发和吊销 X.509 v3 证书的证书颁发机构 (CA)。这意味着不必依赖于商业的客户端身份验证服务，虽然如果选择，也可以将商业的客户端身份验证集成到公钥结构中。
虚拟专用网络
可以通过实现虚拟专用网络 (VPN) 使用户很方便地访问您单位的网络（即使他们不在办公室，也可以访问），并且降低访问成本。VPN 连接将创建跨 Internet 进入专用网络的安全隧道。

Windows Server 2003 家族中包含有两种类型的 VPN 技术：

  • 点对点隧道协议 (PPTP)，该协议使用用户级别点对点协议 (PPP) 身份验证方法和用于数据加密的 Microsoft 点对点加密 (MPPE)。
  • 第二层隧道协议 (L2TP) 与 Internet 协议安全 (IPSec)。L2TP 在数据加密方面使用用户级 PPP 身份验证方法和具有 IPSec 的计算机级证书。

XOX

安全灵活的身份验证和授权
安全灵活的身份验证和授权服务，在使通过 Internet 进行商务活动的壁垒最小化的同时，提供数据保护功能。Active Directory 支持多个身份验证协议，如 Kerberos V5、安全套接字层 (SSL) v3、使用 X.509 v3 证书的传输层安全性 (TSL)，以及有效跨越多个域的安全组。
Internet 验证服务
Internet 验证服务 (IAS) 为拨号网络或虚拟专用网 (VPN) 的身份验证管理、授权、记帐和审核，提供了一个中心点。IAS 使用名为远程身份验证拨号用户服务 (RADIUS) 的 Internet 工程任务组 (IETF) 协议。

运行 Microsoft® Windows® Server 2003, Web Edition 操作系统的计算机不包括该功能。详细信息，请参阅 Windows Server 2003 Web Edition 概述。在 Windows Server 2003, Standard Edition 中，您可以配置 IAS，最多配置 50 个 RADIUS 客户端和 2 个远程 RADIUS 服务器组。有关这些限制的详细信息，请参阅 Internet 验证服务。

路由和远程访问
“路由和远程访问”代替了 Windows NT 4.0 中的“路由和远程访问服务 (RRAS)”和“远程访问服务 (RAS)”功能。路由和远程访问是单一的集成服务，可以终止来自拨号或虚拟专用网 (VPN) 客户端的连接，或者提供路由（IP、IPX 和 AppleTalk），或者两种服务都提供。通过“路由和远程访问”，服务器可用作远程访问服务器、VPN 服务器、网关或分支机构办公室路由器。详细信息，请参阅路由和远程访问。

自 Windows 2000 以后的新功能与更新功能

Windows Server 2003 家族进行了以下改进（与 Windows 2000 相比），从而有助于更好地支持身份验证，以及智能卡的使用：

存储用户名和密码
存储用户名和密码存储了用户凭据，包括密码和 X.509 v3 证书，以使它们可以与远程计算机关联并可自动重复使用。这就为用户（包括漫游用户）提供了一致的、单一的登录体验。
通过终端服务器的智能卡访问
使用终端服务器时，可以通过存储在智能卡上的受信任的 X.509 V3 证书从“远程桌面连接”登录到 Windows Server 2003 域。例如，可以使用智能卡登录到终端服务器上的 Active Directory。
从属证书颁发机构改进功能
从属证书颁发机构 (CA) 现在支持合格的部属，它允许公钥结构 (PKI) 管理器使用合格的从属 CA，以实现比标准 CA 更精确的安全与管理目的，例如，只允许合格的从属 CA 向某些域（仅由特定软件应用程序使用）中的主题颁发证书。详细信息，请参阅合格的部属。


其他安全功能

本主题概述了 Windows Server 2003 家族中的其他安全功能。它包括以下三部分内容：自 Windows Server 2003（不带 SP1）以来的新功能与更新功能、自 Windows NT 4.0 以来的新功能与更新功能以及自 Windows 2000 以来的新功能与更新功能。

有关身份验证和智能卡支持功能的信息，请参阅身份验证和智能卡支持。有关新增安全功能的详细信息，请参阅新增安全功能。有关指向此版本中这些功能详细信息的链接，请参阅新功能。

Windows Server 2003 家族提供了多种功能，您可以使用这些功能来创建稳健、灵活的安全系统。这些功能包括内置到 Active Directory 中的文件加密和安全功能。有关可用的身份验证种类的信息，请参阅身份验证和智能卡支持。

自 Windows Server 2003（不带 SP1）以后的新功能与更新功能

带有 SP1 的 Windows Server 2003 提供了以下改进功能（与不带 SP1 的 Windows Server 2003 相比），这些功能有助于提供更强的安全性支持：

安全配置向导
安全配置向导 (SCW) 通过如下方法可降低 Microsoft Windows 服务器的攻击面：即向用户询问一系列旨在确定服务器功能要求的问题，然后禁用该服务器正在执行的角色不需要的功能。降低攻击面除了作为一种基本安全性最佳操作，它还有助于增加多个 Windows 系统，以及减少在出现安全问题的情况下需要立即更新的系统数量。详细信息，请参阅安全配置向导。
Windows 防火墙
Windows 防火墙采用的是一种宿主防火墙技术。作为宿主防火墙，Windows 防火墙可运行在各个客户端和服务器上。它可以保护客户端和服务器免受通过外围网络或起源于组织内部的网络攻击（如特洛伊木马攻击、端口扫描攻击以及蠕虫病毒）。像许多防火墙技术一样，Windows 防火墙也是一种基于状态检测的防火墙。同时，Windows 防火墙还能够检测并筛选 Internet 协议版本 4 (IPv4) 和 Internet 协议版本 6 (IPv6) 通讯。除非未经请求的传入通讯是对主机发出的请求的响应（请求的通讯）或者是经特别许可的通讯（例外通讯），否则它将被丢弃。可以通过配置 Windows 防火墙设置，根据端口号、应用程序名或服务名来指定例外通讯。除了某些 Internet 控制消息协议 (ICMP) 消息，Windows 防火墙允许所有其他出站通讯。

Windows Server 2003 的原始发行版中未包含 Windows 防火墙。带有 SP1 的 Windows Server 2003 的所有版本中包含有 Windows 防火墙。

只有 Windows Server 2003, Standard Edition 的原始发行版和 32 位版本的 Windows Server 2003, Enterprise Edition 的原始发行版中包含有 Internet 连接防火墙。

有关详细信息，请参阅 Windows Server 技术中心。(http://www.microsoft.com/)

数字身份管理服务 (DIMS) 和凭据漫游
DIMS 和凭据漫游可使用户在登录到任何加入域且运行带有 SP1 的 Windows Server 2003 计算机时，拥有可供应用程序和服务使用的所有证书和私钥，同时获得无缝且隐性式用户体验。管理员可以使用组策略来启用凭据漫游，从而可以自动与 Active Directory 用户对象同步用户证书和私钥，并复制这些用户证书和私钥。有关详细信息，请参阅 Windows Server 技术中心。(http://www.microsoft.com/)。
Windows Server 2003 保密信息
带有 SP1 的 Windows Server 2003 提供初始版本的 Windows Server 2003 中所没有的组策略设置。您可以在称为“Internet 通信管理”的新节点下的组策略对象编辑器中找到专用于帮助保护您隐私的新设置。在“Internet 通信管理”下的设置用于帮助您控制 Windows 组件与 Internet 通信的方式。带有 SP1 的 Windows Server 2003 的新增设置之一是“限制 Internet 通信”，您可以使用此设置来同时控制多个与隐私有关的设置。有关隐私的详细信息，请参阅 TechNet 网站上的“Using Windows Server 2003 in a Managed Environment”（在受管环境中使用 Windows Server 2003）。(http://www.microsoft.com/)
为终端服务连接启用身份验证
使用带有 SP1 的 Windows Server 2003，您可以配置终端服务连接以使用用于服务器身份验证和加密的传输层安全性 (TLS)。TLS 通常是指安全套接字层/传输层安全性 (SSL/TLS)。默认情况下，在安装 SP1 时不启用 TLS。有关详细信息，请参阅 Microsoft 网站上的“Terminal Services Security”（终端服务安全）。

自 Windows NT 4.0 以后的新功能与更新功能

Windows Server 2003 家族提供了如下改进功能（与 Windows NT 4.0 相比），这些功能有助于提供更强的安全性支持：

加密文件系统
加密文件系统 (EFS) 补充了其他访问控制方式，并为数据提供了更高水平的保护。EFS 作为集成的系统服务运行，便于进行管理，使系统难以遭攻击，并且对用户是透明的。详细信息，请参阅加密文件系统。
Internet 协议安全
可以用 Internet 协议安全 (IPSec) 来保证 Intranet 中的通讯安全，也可以用它来创建跨 Internet 的安全虚拟专用网络 (VPN) 解决方案。IPSec 是由 Internet 工程任务组 (IETF) 设计、用于加密 TCP/IP 通信的工业标准。详细信息，请参阅 Internet 信息服务。

自 Windows 2000 以后的新功能与更新功能

Windows Server 2003 家族提供了如下改进功能（与 Windows 2000 相比），这些功能有助于提供更强的安全性支持：

TCP/UDP 端口所有权
新的 netstat 命令选项显示了拥有传输控制协议/用户数据报协议 (TCP/UDP) 端口的进程。可用此功能来配置安全服务器、安全审核和性能改进。
加密文件系统改进功能
已经用多种方法改进了加密文件系统 (EFS)。要使用较大的密钥才能获得更强大的加密算法。可以授予多个用户共享加密文件的权限。可以通过 EFS 加密脱机文件，以便保护本地缓存的文档。详细信息，请参阅加密文件系统。
软件限制策略
使用软件限制策略，通过标识并指定允许哪些应用程序运行，您可以保护计算机环境免受不可信代码的侵扰。详细信息，请参阅软件限制策略。
Internet 协议安全监视改进功能
Internet 协议安全 (IPSec) 监视改进功能包括 Microsoft 管理控制台 (MMC) 管理单元，此管理单元提供有关 IPSec 策略配置和活动安全状态的详细信息。此功能替换了 Windows 2000 中的 Ipsecmon.exe 监视程序。详细信息，请参阅 Internet 协议安全 (IPSec)。


远程管理

本主题概述了 Windows Server 2003 家族中的远程管理功能。它分为两部分：自 Windows NT 4.0 以后的新功能与更新功能以及自 Windows 2000 以后的新功能与更新功能。

有关此版本中这些功能详细信息的链接，请参阅新功能。

Windows Server 2003 家族包含多种远程管理功能。有关如何使用这些功能的详细信息，请参阅远程管理。

自 Windows NT 4.0 以后的新功能与更新功能

Windows Server 2003 家族进行了以下改进（与 Windows NT 4.0 相比），从而有助于更好地支持远程管理：

Microsoft 管理控制台
可使用 Microsoft 管理控制台 (MMC) 来排列在单个界面内需要的管理工具和进程。还可通过创建包含所选工具的预配置 MMC 来向特定用户委派任务。详细信息，请参阅 Microsoft 管理控制台。
使用 Windows Script Host 编写脚本
通过使用 Windows Script Host (WSH)，可自动处理诸如创建快捷方式、连接到网络服务器以及与网络服务器断开连接这样的操作。WSH 与语言无关。可使用常用的脚本语言来编写脚本，如 Microsoft Visual Basic® Scripting Edition (VBScript) 和 JScript。详细信息，请参阅 Windows Script Host。
远程安装服务
通过远程安装服务 (RIS)，可以创建操作系统的安装映像，甚至也可以创建完整的计算机配置（包括桌面设置和应用程序）的安装映像。然后可以使客户端计算机上的用户使用这些映像。客户端计算机必须支持使用预启动执行环境 (PXE) ROM 的远程启动，或者它们必须可以用远程启动软盘启动。详细信息，请参阅远程安装服务。

运行 Microsoft® Windows® Server 2003, Web Edition 操作系统的计算机不包括该功能。详细信息，请参阅 Windows Server 2003 Web Edition 概述。

自 Windows 2000 以后的新功能与更新功能

Windows Server 2003 家族进行了以下改进（与 Windows 2000 相比），从而有助于更好地支持远程管理：

管理远程桌面
通过管理远程桌面（以前被称为远程管理模式下的终端服务），几乎可以从网络上的任何计算机对计算机进行管理。管理远程桌面基于终端服务技术，是为进行服务器管理而专门设计的。可使用管理远程桌面来远程登录到服务器，就好像从本地登录一样。另外，管理远程桌面现在可支持更高的颜色深度和屏幕分辨率。有关此功能的详细信息，请参阅管理远程桌面。
远程协助
可使用“远程协助”来远程管理计算机。如果您收到邀请，远程协助可以使您轻松地从运行 Windows XP 或 Windows Server 2003 家族中任意产品的计算机连接到远程计算机。连接之后，即可查看远程计算机的屏幕而且可进行实时聊天。如果请求协助的人允许，您甚至可以使用鼠标和键盘对远程计算机进行操作。详细信息，请参阅远程协助。

XOX

远程管理的 Web 界面（仅限于 Windows Server 2003, Web Edition）
在 Windows Server 2003, Web Edition 上，用于远程管理的 Web 界面是基于超文本标记语言 (HTML) 的应用程序，用于从远程客户端配置和管理服务器。单个的服务器、整个服务器场和每个服务器的多个站点都可以从单个远程工作站进行管理。

用于远程管理的 Web 界面提供了执行常见 Web 服务器配置任务的简单方法，包括：

  • 创建和删除 Web 站点
  • 配置网络设置
  • 管理本地用户帐户
  • 重新启动 Web 服务器
远程安装服务的改进功能
远程安装服务 (RIS) 的增强包括对 Windows Server 2003 家族与 Windows XP 产品的安装支持，对 RIS 安装中应答文件处理的进一步控制，以及对恢复模式中网络文件的访问权限。

运行 Microsoft® Windows® Server 2003, Web Edition 操作系统的计算机不包括该功能。详细信息，请参阅 Windows Server 2003 Web Edition 概述。


维护和产品更新

本主题概述了 Windows Server 2003 家族中的维护和产品更新功能。它分为两部分：自 Windows NT 4.0 以后的新功能与更新功能以及自 Windows 2000 以后的新功能与更新功能。

有关此版本中这些功能详细信息的链接，请参阅新功能。

Windows Server 2003 家族提供了多种功能，这些功能有助于保持系统具有最新的系统文件和产品更新。

自 Windows NT 4.0 以后的新功能与更新功能

Windows Server 2003 家族提供了如下改进功能（与 Windows NT 4.0 相比），这些功能有助于使用最新的系统文件对系统进行更新：

Windows Update
Windows Update 是 Windows 的联机扩展，它可检测出过时的 Windows 系统文件并用最新的版本来替换它们。Windows Update 可以在较长时间内极大地提高计算机系统的稳定性。它还减少了管理人员和支持人员（这些人员必须维持有效的操作环境）的工作负荷。Windows Update 要求 Internet 连接。详细信息，请参阅位于 Microsoft 网站的 Windows Update。(http://www.microsoft.com/) 同时，请参阅使用 Windows Update。

Windows Update 包括动态更新，它可在安装过程中获得。如果在运行安装程序的计算机上具有有效的 Internet 连接，则可使用动态更新来获取最新的安装文件，包括驱动程序和其他文件。详细信息，请参阅使用动态更新获取更新的驱动程序和其他安装文件。

自 Windows 2000 以后的新功能与更新功能

Windows Server 2003 家族提供了如下改进功能（与 Windows 2000 相比），这些功能有助于使用最新的系统文件对系统进行更新：

Windows Update 增强功能
Windows Update 目前可提供其他选择：
  • 在“Windows Update 目录”下，您可以选择计划随后部署的更新，即您可以控制如何以及何时部署更新。详细信息，请参阅位于 Microsoft 网站的“Windows Update Catalog”（Windows Update 目录）。(http://www.microsoft.com/)
  • 使用自动更新（内置于 Windows XP 和 Windows Server 2003 家族产品中），操作系统可从 Windows Update 站点自动下载与安装重要的更新。详细信息，请参阅 Windows 自动更新。
  • 使用 Windows Server Update 服务，可以在防火墙内部署 Windows Update 站点的受限版本。可控制更新的部署方式和部署时间，而且可通过 Intranet 将更新传递给用户，而不是直接通过 Internet 进行更新。有关详细信息，请参阅位于 Microsoft 网站的“Windows Server Update Services”（Windows Server 更新服务）。(http://www.microsoft.com/)


国际化功能

本主题概述了 Windows Server 2003 家族产品中的国际化功能。它分为两部分：自 Windows NT 4.0 以后的新功能与更新功能以及自 Windows 2000 以后的新功能与更新功能。

有关此版本中这些功能详细信息的链接，请参阅新功能。

自 Windows NT 4.0 以后的新功能与更新功能

Windows Server 2003 家族进行了以下改进（与 Windows NT 4.0 相比），从而有助于更好地支持国际化：

多语言支持
Windows Server 2003 家族支持在单一系统中使用多种语言。作为系统体系结构的结果，操作系统、实用程序和正确编写的应用程序可以转换并修改为数百种语言的本地版本。因此本地管理员可以不需要精通科技英语。
多区域支持
在此版本中也包括了对更多区域设置及区域和语言选项的支持，使得访问相关的内容更方便。

自 Windows 2000 以后的新功能与更新功能

Windows Server 2003 家族中的众多产品进行了以下改进（与 Windows 2000 相比），从而有助于更好地支持国际化。其中的某些语言可能在某些产品上不可用：

繁体中文新注音输入法编辑器
新注音输入法编辑器 (IME) 是基于最先进的中文键盘输入技术的新设计。它是 Microsoft 注音 IME 98a CHT 版的更新版。
改进的日文输入法编辑器
日文 IME 版本 8 接收字母键盘字符，将它们转换为日文字符，然后将结果输入到应用程序中。此新功能还支持通过网络使用日文 IME 词典。IME 将用户定义的单词和转换规则保存在用户词典中，该词典可以在用户的本地计算机上进行编辑。（此词典在 Windows 2000 中是只读的。）
改进的朝鲜语输入法编辑器
朝鲜语 IME 将按键顺序映射到朝鲜语字母，然后将它们转换为朝鲜语音节。新的朝鲜语 IME 支持朝鲜文和朝鲜文汉字的手写输入。
改进的简体中文输入法编辑器
MSPY3.0 IME 提供增大的 IME 词典（大约 100,000 个词和词组）与更新的 IME 规则，具有较高的 IME 准确性与性能的改进的语言模型，以及无模式输入（中文/英文混合输入）。


目录、文件、打印和协作服务的功能

Windows Server 2003 家族包含对目录、文件、打印以及协作服务的改进支持。本部分中的主题描述了支持这些服务器类型的功能。

Windows Server 2003, Web Edition 不适用于文件或打印服务器。在 Windows Server 2003, Web Edition 操作系统上对文件和打印服务的支持是有限的。

有关指向此版本中这些功能详细信息的链接，请参阅新功能。

本部分包括：

  • Active Directory
  • 用于协作的功能
  • 磁盘和文件管理功能
  • 打印机和协议支持

注意

  • 有关 Windows Server 2003 R2 中组件的信息，请参阅 Microsoft Windows Server 2003 R2 中的新增功能。


Active Directory

本主题概述了 Windows Server 2003 家族中的 Active Directory 目录服务功能。它分为三部分： 带有 Service Pack 1 (SP1) 的 Windows Server 2003 的新功能和更新功能， 自 Windows NT 4.0 以后的新功能与更新功能， 和 自 Windows 2000 以后的新功能与更新功能。

有关此版本中这些功能详细信息的链接，请参阅新功能。有关 Active Directory 的详细信息，请参阅 Active Directory。要进一步获得有关 Active Directory 新功能的详细信息，请参阅 Active Directory 的新功能。

Active Directory 是一种企业级的目录服务，它规模可变，基于 Internet 标准技术构建，并完全集成到操作系统级别上。Active Directory 简化了管理，使用户很容易找到各种资源。Active Directory 提供了非常广泛的特性和功能。

注意

  • 运行 XOX 操作系统的计算机不能用作域控制器。有关 XOX 的详细信息，请参阅 XOX 概述。

Windows Server 2003 with Service Pack 1 (SP1) 中的新功能与更新功能

带有 Service Pack 1 (SP1) 的 Windows Server 2003 操作系统提供了以下改进功能（与不带 SP1 的 Windows Server 2003 相比），这些功能有助于提供更强的　Active Directory　支持：

复制能力与 DNS 诊断测试能力均得以改善
Active Directory® 中也有许多更新功能，例如目录服务自动备份提醒，增强的保护措施从而避免复制错误，“从媒体安装”中的增强功能（对于既是域控制器又是 DNS 服务器的计算机来说，其添加过程更为简便），增强的 DNS 诊断测试能力，以及对全新平台（在 Microsoft® Virtual Server 2005 虚拟机器上运行的域控制器）的访问权限。详细信息以及 Active Directory 中其他新增与增强功能的信息，请参阅 New features for Active Directory（Active Directory　的新功能）。

自 Windows NT 4.0 以后的新功能与更新功能

Windows Server 2003 家族进行了以下改进（与 Windows NT 4.0 相比），从而有助于更好地支持 Active Directory：

简化了用户和网络资源管理
用 Active Directory，可构建分层的信息结构，从而可以更轻松地控制管理凭据和其他安全设置，还可使用户更容易定位网络资源，例如文件和打印机。
安全灵活的身份验证和授权
安全灵活的身份验证和授权服务，在使通过 Internet 进行商务活动的壁垒最小化的同时，提供数据保护功能。Active Directory 支持多种身份验证协议 [例如，Kerberos V5 协议、安全套接字层 (SSL) v3、使用 X.509 v3 证书的传输层安全性 (TLS)] 以及有效跨越域的安全组。
目录合并
可以整理并简化对用户、计算机、应用程序和设备的管理，且能使用户方便地查找到所需的信息。可以利用通过基于轻型目录访问协议 (LDAP) 的接口实现的同步支持，并可处理针对应用程序的目录合并要求。
启用目录的应用程序和基础结构
Active Directory 功能便于用户配置和管理应用程序以及其他启用目录的网络组件。
容易实现的可伸缩性
Active Directory 可在每个域内容纳多达数百万的对象，并使用索引技术和高级复制技术提高运行速度。
Internet 标准的使用
Active Directory 提供通过 LDAP 的访问，并使用基于域名系统 (DNS) 的名称空间。
功能强大的开发环境
Active Directory 通过 Active Directory 服务接口 (ADSI) 提供了一个强大的开发环境，ADSI 为 Active Directory 提供了一个面向对象的接口。ADSI 使程序员和管理员不必担心不同名称空间之间的潜在差异，就可以用高级工具（如 Microsoft Visual Basic、Java、C 或 Visual C++）轻松创建目录程序。详细信息，请参阅编程接口。
复制和信任监视
Active Directory 提供了 Windows Management Instrumentation (WMI) 类，以便监视域控制器是否成功地复制 Active Directory 信息以及信任是否正常起作用。
消息队列通讯组列表
消息队列（也称为 MSMQ）能使您向 Active Directory 中主持的分发列表发送消息。

自 Windows 2000 以后的新功能与更新功能

Windows Server 2003 家族进行了多处改进（与 Windows 2000 相比），从而有助于更好地支持与管理 Active Directory。有关此版本中新的 Active Directory 功能的列表，请参阅 Active Directory 的新功能。


用于协作的功能

本主题概述了 Windows Server 2003 家族中的协作功能（包括多媒体支持）。它包括以下两部分内容：自 Windows NT 4.0 以后的新功能与更新功能以及自 Windows 2000 以后的新功能与更新功能。

有关指向此版本中这些功能详细信息的链接，请参阅新功能。

Windows Server 2003 家族通过工作组协作工具以及在广泛的连接设备上的安全实时通信、移动数据和流式媒体，改善了员工之间的通信和协作。由于服务器可持续访问，员工可以随时、随地使用任何设备访问信息，从而可以提高整个组织的工作效率。

自 Windows NT 4.0 以后的新功能与更新功能

Windows Server 2003 家族进行了以下改进（与 Windows NT 4.0 相比），从而有助于更好地支持协作：

Windows Media Services
Windows Media Services 提供在企业 Intranet 和 Internet 中的流式音频和视频的支持。在 Windows Server 2003, Enterprise Edition 和 Windows Server 2003, Datacenter Edition 中，Windows Media Services 提供高级流式传输功能，例如多播、无线网络支持、Internet 身份验证、服务器插件和缓存/代理 API。

Windows Media Services 的核心组件是用组件对象模型 (COM) 开发的，从而创建了一种灵活的体系结构，该体系结构可以轻松地针对特定的应用程序进行自定义。许多功能是通过使用插件来实现的。通过此平台，开发人员可以轻松地扩展 Windows Media Services 功能，并可与现有系统和解决方案（如存储系统、记帐应用程序和日志记录应用程序）集成。

Windows Server 2003, Web Edition 或 Windows Server 2003 家族的 64 位版本中未包含 Windows Media Services。

可预测的端对端服务质量
基于服务质量 (QoS) 的服务和协议可通过网络或跨越多个不同的网络，为已启用 QoS 的程序生成的通信提供有保证的端对端快速传递系统。详细信息，请参阅服务质量 (QoS)。
异步传输模式
异步传输模式 (ATM) 是一种高速且面向连接的协议，用于通过网络传输多种类型的通信。它适用于局域网 (LAN) 和广域网 (WAN)。使用 ATM 的网络可以同时传输各种网络通讯：语音、数据、图像以及视频。

自 Windows 2000 以后的新功能与更新功能

Windows Server 2003 家族进行了以下改进（与 Windows 2000 相比），从而有助于更好地支持协作：

Microsoft .NET Framework
Microsoft .NET Framework 提供了最广泛且功能最强大的手段来构建、部署和管理 XML Web 服务。XML Web 服务允许应用程序（不管使用何种操作系统或编程语言）通过 Internet 进行通信和共享数据。Windows Server 2003 家族是 Microsoft .NET 战略的基础，它为各种规模的组织提供了一种前所未有的 .NET 计算基础。详细信息，请参阅 Microsoft .NET Framework。
远程访问服务器上的音频加速功能
音频加速功能可以使多媒体通讯的优先级高于其他数据流，从而提供更好的性能（特别是对于低速网络）。远程访问服务器上的音频加速功能可确保流式音频和视频通讯的质量。
NetMeeting 增强功能
可以使用 NetMeeting 与其他人进行通信，具体是使用 Microsoft Exchange 多播会议功能，它允许在 Intranet 和 Internet 上实时进行通信和协作。NetMeeting 还提供了用于实时通信的平台，这样软件供应商便可以将 Internet 会议功能集成到他们的应用程序和服务中。详细信息，请参阅使用 NetMeeting。

XOX


磁盘和文件管理功能

本主题概述了 Windows Server 2003 家族中的磁盘和文件管理功能。它包括以下两部分内容：自 Windows NT 4.0 以后的新功能与更新功能以及自 Windows 2000 以后的新功能与更新功能。

有关指向此版本中这些功能详细信息的链接，请参阅新功能。

此版本中的磁盘、卷和文件管理功能使其成为用作文件服务器的灵活平台，并可使用户更方便地查找和访问信息。

自 Windows NT 4.0 以后的新功能与更新功能

Windows Server 2003 家族进行了以下改进（与 Windows NT 4.0 相比），从而有助于更好地支持磁盘和文件管理：

磁盘管理
磁盘管理程序是用于管理硬磁盘以及硬盘所包含的卷或分区的系统实用程序。使用磁盘管理程序，可以初始化磁盘、创建卷、使用 FAT、FAT32 或 NTFS 文件系统格式化卷以及创建具有容错能力的磁盘系统。磁盘管理程序使您可以执行多数与磁盘有关的任务，而不需要关闭系统或中断用户，大多数配置更改将立即生效。详细信息，请参阅磁盘管理。
磁盘配额支持
可以在以 NTFS 文件系统格式化的卷上使用磁盘配额监视和限制单个用户可以使用的磁盘空间量。可以定义当用户超过指定的阈值时产生的响应。详细信息，请参阅磁盘配额。
分布式文件系统
通过分布式文件系统 (DFS)，可以在一个组、部门或企业创建包括多个文件服务器和文件共享的单目录树。这样可使用户很轻松地查找分布在网络上的文件或文件夹。DFS 共享还可以作为 Active Directory 中的卷对象来发布。详细信息，请参阅分布式文件系统 (DFS)。
分布式链接跟踪
使用分布式链接跟踪和 NTFS，您可以使您的客户端应用程序跟踪已经移动的链接资源。例如，客户端应用程序始终能够访问已链接的数据库，即使数据库的位置已更改。
分布式创作和版本管理
通过分布式创作和版本管理，远程作者可以通过超文本传输协议 (HTTP) 连接编辑、移动或删除服务器上的文件、文件属性、目录和目录属性。
高性能的内容索引
可以使用索引服务为用户提供在本地或在网络上搜索信息的快速、方便和安全的方式。用户可以通过“开始”菜单上的“搜索”命令或通过在浏览器中查看“超文本标记语言 (HTML)”页来搜索不同格式和语言的文件。
加密文件系统
加密文件系统 (EFS) 补充了其他访问控制方式，并为数据提供了更高级别的保护。EFS 作为集成系统服务运行，从而使管理工作更容易，系统难以受到攻击，并且对用户是透明的。详细信息，请参阅加密文件系统。
可移动存储和远程存储
可移动存储使用户可以更方便地跟踪可移动存储媒体（磁带和光盘），以及管理包含这些媒体的硬件库，例如转换器和自动唱片点唱机。远程存储根据您指定的条件自动将很少使用的文件复制到可移动媒体。如果硬盘空间降到了指定的级别，“远程存储”会从硬盘上移走（缓存的）文件内容。如果以后需要该文件，文件的内容又会自动从存储中重新调回。由于可移动光盘和磁带的每兆字节 (MB) 的成本比硬盘便宜，因此可移动存储和远程存储可以降低成本。有关可移动存储的详细信息，请参阅可移动存储。有关远程存储的详细信息，请参阅远程存储。

“远程存储”在 Windows Server 2003, Web Edition 或 Windows Server 2003, Standard Edition 上不可用。有关 Windows Server 2003, Web Edition 的详细信息，请参阅 Windows Server 2003, Web Edition 概述。

自 Windows 2000 以后的新功能与更新功能

Windows Server 2003 家族进行了以下改进（与 Windows 2000 相比），从而有助于更好地支持磁盘和文件管理：

远程文档共享
新的 Web 分布式创作和版本管理 (WebDAV) 重定向程序支持用于通过 HTTP 进行远程文档共享的 WebDAV 协议。WebDAV 重定向程序支持使用现有的应用程序，并可实现跨 Internet（通过防火墙、路由器等）到 HTTP 服务器的文件共享。通过 WebDAV 重定向程序，可以建立能在 Internet 上的任何位置使用任何应用程序（不仅仅是那些解释 Web 发布协议的应用程序）进行访问的 Web 储备库。
磁盘管理的命令行支持
通过新的 DiskPart 命令，可以从命令行执行许多磁盘管理任务。详细信息，请参阅从命令行管理磁盘和卷和 DiskPart。
GUID 分区表（仅限于 64 位版本）
Windows XP 64-Bit Edition 和 Windows Server 2003 家族的 64 位版本（64 位版本 Windows Server 2003, Enterprise Edition 和 64 位版本 Windows Server 2003, Datacenter Edition）支持新的磁盘分区样式 － GUID 分区表 (GPT)。与主启动记录 (MBR) 分区磁盘不同的是，对于平台操作至关重要的数据位于分区中而不是位于尚未划分的或隐藏的扇区中。另外，GPT 分区磁盘拥有多余的主要及备份分区表来提高分区数据结构的完整性。详细信息，请参阅 GUID 分区表。
共享文件夹的卷影副本
通过共享文件夹的卷影副本，可以打开、查看和保存存储在共享网络文件夹中的文件的即时点版本。例如，如果意外从网络共享中删除某个文件，您可使用卷影副本功能检索以前版本的文件。详细信息，请参阅共享文件夹的卷影副本。
文件管理改进功能
通过改进的文件夹选项，可以更有效地管理文件。例如，可以自定义文件夹视图以显示文件和文件夹的常见任务，这样便可以更方便地通过电子邮件发送文件或让用户访问 Web 服务器上的位置。增大的缩略图使得识别文档更容易。
存储区域网络支持 (SAN)
在存储区域网络 (SAN) 环境中，为了获得更好的互操作性，在 Windows Server 2003, Enterprise Edition 和 Windows Server 2003, Datacenter Edition 中，将新磁盘上的卷添加到系统中时，默认情况下将不会自动安装及指派驱动器号。


打印机和协议支持

本主题概述了 Windows Server 2003 家族中的打印机和协议支持功能。它分为两部分：自 Windows NT 4.0 以后的新功能与更新功能以及自 Windows 2000 以后的新功能与更新功能。

Windows Server 2003 家族为打印服务器提供了多种打印机和协议支持功能。有关此版本中这些功能详细信息的链接，请参阅新功能。

自 Windows NT 4.0 以后的新功能与更新功能

Windows Server 2003 家族提供了如下改进功能（与 Windows NT 4.0 相比），这些功能有助于提供更强的打印服务器支持：

在 Active Directory 中发布的打印机
用户可以通过直观的用户界面来快速搜索和定位最方便的打印资源。
广泛的设备和协议支持
可从成百上千个打印机中进行选择。
即插即用
通过即插即用（一种硬件和软件支持组合），服务器可以自动识别和适应硬件配置更改，无需干预和重新启动。
Internet 打印协议
采用 Internet 打印协议 (IPP)，用户可以直接通过 Intranet 或 Internet 打印到统一资源定位器 (URL)。此外，运行 Windows Server 2003 家族产品的服务器可自动生成超文本标记语言 (HTML) 格式的打印作业信息，这样用户便可以使用浏览器查看该信息。
打印机管理功能
可使用系统监视器来监视本地和远程打印机的运行状况。可将计数器设置成各种不同的标准，如 Bytes Printed/Second、Job Errors 和 Total Pages Printed。
网络打印功能
可使用“Microsoft 管理控制台 (MMC)”从网络上的任意位置远程管理运行 Windows Server 2003 的打印服务器。另外，如果客户端计算机正在运行 Windows 2000 或 Windows XP，则不必为该客户端计算机安装打印机驱动程序以使用打印机。当客户端连接到打印服务器时，可自动下载驱动程序。这简化了跨网络的打印工作。

自 Windows 2000 以后的新功能与更新功能

Windows Server 2003 家族提供了如下改进功能（与 Windows 2000 相比），这些功能有助于提供更强的打印服务器支持：

用于打印的新命令行支持
通过新的命令行实用程序，可使用 Windows Management Instrumentation (WMI) 提供程序来管理打印机和打印队列。还可以开发脚本或批处理文件来更有效地管理打印机。
在服务器群集上安装打印机驱动程序更加轻松（仅限于 Windows Server 2003, Enterprise Edition 和 Windows Server 2003, Datacenter Edition）
在 Windows 2000 中，必须在服务器群集的每个节点上手动安装每个打印机驱动程序。对于 Windows Server 2003, Enterprise Edition 和 Windows Server 2003, Datacenter Edition，在群集上安装打印机驱动程序时，驱动程序将被自动传播到所有节点。


Internet、应用程序和网络服务功能

Windows Server 2003 家族包括各种 Internet 功能、应用程序和应用程序开发支持以及网络和通信功能。

有关指向此版本中这些功能详细信息的链接，请参阅新功能。

本部分包括：

  • Microsoft .NET Framework
  • Internet 与电子邮件服务和功能
  • 应用程序和开发支持
  • 网络协议和技术

注意

  • 有关 Windows Server 2003 R2 中组件的信息，请参阅 Microsoft Windows Server 2003 R2 中的新增功能。


Microsoft .NET Framework

Microsoft Windows 图形

Microsoft .NET Framework 版本 2.0

.NET Framework 版本 2.0 是 .NET Framework 的最新版本，是用于构建、部署和运行应用程序的 Windows 组件。.NET Framework 2.0 主要用于提高开发人员工作效率，使运行更加出色，并且可以保留和增强现有的软件投资。核心增强功能包括支持 64 位处理器（可以提高性能和扩展性），事务增强和优化，ASP.NET 中工作效率的提高, 支持包含 Web 服务的 WS-I BP 1.1 和 SOAP 1.2。

有关新的 .NET Framework 2.0 功能的完整列表，请访问 Microsoft 网站。(http://go.microsoft.com/fwlink/?LinkId=50322)


Internet 与电子邮件服务和功能

Windows Server 2003 家族包含对多种 Internet 功能的改进支持。本主题概述了此版本中的 Internet 与电子邮件服务和功能。它包括以下三部分内容：自 Windows Server 2003（不带 SP1）以后的新功能与更新功能、自 Windows NT 4.0 以后的新功能与更新功能以及自 Windows 2000 以后的新功能与更新功能。

有关指向此版本中这些功能详细信息的链接，请参阅新功能。

自 Windows Server 2003（不带 SP1）以后的新功能与更新功能

带 Service Pack 1 (SP1) 的 Windows Server 2003 操作系统提供了以下改进功能（与不带 SP1 的 Windows Server 2003 相比），这些功能有助于更好地支持 Internet 服务：

“Internet Communication Management”下的“组策略”附加组件
带有 SP1 的 Windows Server 2003 包含 Windows Server 2003 的原始版本中未提供的组策略设置。其中某些设置可在称为“Internet Communication Management”键下面的组策略中找到。此键位于 GPMC 的 Computer Configuration\Administrative Templates\System 以及 User Configuration\Administrative Templates\System 中。

“Internet Communication Management”键下面的设置旨在帮助您控制 Windows Server 2003（带 SP1）中的组件与 Internet 通信的方式。

自 Windows NT 4.0 以后的新功能与更新功能

Windows Server 2003 家族提供了以下改进功能（与 Windows NT 4.0 相比），这些功能有助于更好地支持 Internet 服务：

Active Server Pages
Active Server Pages (ASP) 是创建动态、交互 Web 服务器应用程序的服务器端脚本环境。使用 ASP，开发人员可合并超文本标记语言 (HTML) 页面、脚本命令和组件对象模型 (COM) 组件，以满足创建灵活的基于 Web 的应用程序的需要。
Windows Media Services
通过 Windows Media Services，可以为 Internet 和 Intranet 上的用户提供高品质的流式多媒体。

XOX 或 64 位版本的 Windows Server 2003 家族中未包含 Windows Media Services。

Web 分布式创作和版本管理
通过 Web 分布式创作和版本管理 (WebDAV)，远程作者可以使用超文本传输协议 (HTTP) 连接对文件进行处理。详细信息，请参阅磁盘和文件管理功能。
应用程序回收
应用程序回收功能增强了服务器的可靠性和健全性。您可以刷新应用程序并防止可能的资源短缺，这样便可以提高服务器的可靠性和可用性。

自 Windows 2000 以后的新功能与更新功能

Windows Server 2003 家族提供了以下改进功能（与 Windows 2000 相比），这些功能有助于更好地支持 Internet 服务：

Microsoft .NET Framework 组件
Microsoft .NET Framework 为建立、部署和管理 Web 服务提供了各种可能性。详细信息，请参阅 Microsoft .NET Framework。
Internet 信息服务 6.0
Internet 信息服务 (IIS) 6.0 是一个功能齐全的 Web 服务器，为在托管环境中运行 Web 应用程序和 Web 服务而进行了优化。IIS 6.0 中包含了许多新功能，以增强可靠性、安全性、可管理性和性能。详细信息，请参阅 Internet 信息服务 (IIS) 6.0。

注意

  • 默认情况下，IIS 不与全新安装的 XOX、XOX 和 XOX 一起安装。您可以使用“配置您的服务器向导”或控制面板中的“添加或删除程序”安装该服务。
通用描述、发现和集成服务
通用描述、发现和集成 (UDDI) 是发布和查找有关 Web 服务信息的行业规范。Windows Server 2003 家族中的一些产品包含 UDDI 服务，该服务是一种在企业内部或组织之间提供 UDDI 功能的 Web 服务。UDDI 服务是基于标准的 XML Web 服务，是为企业开发人员有效地直接通过他们的开发工具发现、共享和重复使用 Web 服务而设计的。

XOX 中不包括“UDDI 服务”。此外，XOX 仅支持 UDDI 服务的单机安装。XOX 和 XOX 可以支持分布式安装。在“UDDI 服务”的独立安装中，UDDI Web 服务器组件和 UDDI 数据库组件都可安装在单个服务器上。在分布式安装中，UDDI 组件分布在多个服务器上。

有关 XOX 的详细信息，请参阅 Windows Server 2003, Web Edition 概述。

电子邮件服务 (POP3、SMTP)
POP3 服务提供电子邮件传送和检索服务。管理员可以使用 POP3 服务存储以及管理邮件服务器上的电子邮件帐户。简单邮件传输协议 (SMTP) 支持服务器间电子邮件的传输。详细信息，请参阅 POP3 服务和简单邮件传输协议 (SMTP) 服务。
配置数据库 WMI 提供程序
适用于 IIS 的配置数据库 WMI 提供程序使跨应用程序管理运行 IIS 的服务器非常便利。Windows Management Instrumentation (WMI) 具有丰富的架构和关联方法来建立应用程序配置模型。这样就可以通过编写脚本来管理 Web 应用程序的各个方面，包括系统配置、应用程序文件以及数据库。


应用程序和开发支持

有关此主题中列出的支持的类型与此版本中支持的其他类型之间的关系，请参阅选择对于服务器最有用的功能。

这部分包括：

  • 对现有系统的支持
  • 应用程序支持
  • 管理和部署
  • 终端服务器功能
  • 开发支持


对现有系统的支持

本主题概述了 Windows Server 2003 家族中的互操作功能。它分为两部分：自 Windows NT 4.0 以后的新功能与更新功能以及自 Windows 2000 以后的新功能与更新功能。

有关此版本中这些功能详细信息的链接，请参阅新功能。

Windows Server 2003 家族支持 Windows NT 4.0、Windows 2000、UNIX 和 Macintosh，以及与各种客户端操作系统的互操作性。可以逐步将 Windows Server 2003 家族产品引入网络环境，因为迁移路径可通过任意多个现有系统、设备和应用程序提供。

本发行版本包括下列设计功能以确保它与尽可能多的系统和应用程序兼容。

自 Windows NT 4.0 以后的新功能与更新功能

Windows Server 2003 家族提供了如下改进功能（与 Windows NT 4.0 相比），这些功能有助于对现有系统提供更高级别的支持：
工业标准
Windows Server 2003 家族支持最新行业标准，具体包括：
  • XML
  • 简单对象访问协议 (SOAP)
  • 轻型目录访问协议 (LDAP)
  • DNS
  • Active Directory 服务接口 (ADSI)
  • Kerberos V5 身份验证协议
  • 通用描述、发现和集成 (UDDI)

    Windows Server 2003, Web Edition 中不包括“UDDI 服务”。此外，Windows Server 2003, Standard Edition 仅支持“UDDI 服务”的独立安装。Windows Server 2003, Enterprise Edition 和 Windows Server 2003, Datacenter Edition 中提供了对分布式安装的支持。在“UDDI 服务”的独立安装中，UDDI Web 服务器组件和 UDDI 数据库组件都可安装在单个服务器上。在分布式安装中，UDDI 组件分布在多个服务器上。

对现有的服务器应用程序的支持
在 Windows Server 2003, Standard Edition、Windows Server 2003, Enterprise Edition 和 Windows Server 2003, Datacenter Edition 上支持现有的服务器应用程序，如 Microsoft Exchange Server 和 Microsoft SQL Server。要获得完全支持，可能需要安装最新的产品更新。详细信息，请参阅位于 Microsoft 网站 (http://www.microsoft.com/) 的 Windows Update 站点。另请参阅位于 Microsoft 网站 (http://www.microsoft.com/) 的“Application Center”（应用程序中心）。
与现有的操作系统集成
Windows Server 2003 家族产品与现有操作系统无缝集成，并包含对早期 Windows 操作系统及其他常用操作系统的支持。本发行版本中包括下列功能：
  • 与 Windows NT Server 4.0 和 Windows 2000 Server 的互操作性。
  • 运行各种操作系统的客户端支持，这些操作系统包括 Windows 3.x、Windows 95、Windows 98、Windows Millennium Edition、Windows NT Workstation 4.0、Windows 2000 Professional 和 Windows XP。
  • UNIX 互操作性，这种互操作性是通过名为 Windows Services for UNIX 的附件包提供的。附件包支持网络文件系统 (NFS)、密码同步、UNIX 命令行解释器和 UNIX 实用程序的集合。附件包还支持网络信息服务 (NIS)。还包括 Telnet 服务（用于远程访问和管理）。

  • Macintosh 文件服务器，它允许 Macintosh 客户端使用 TCP/IP 协议（IP 上的 AFP）来共享文件和访问在运行 Windows Server 2003, Standard Edition、Windows Server 2003, Enterprise Edition 或 Windows Server 2003, Datacenter Edition 的服务器上的共享。

    运行 Microsoft® Windows® Server 2003, Web Edition 操作系统的计算机不包括该功能。详细信息，请参阅 Windows Server 2003 Web Edition 概述。

自 Windows 2000 以后的新功能与更新功能

Windows Server 2003 家族提供了如下改进功能（与 Windows 2000 相比），这些功能有助于对现有系统提供更高级别的支持：

兼容模式
兼容模式提供了用于运行应用程序的环境，该环境更近似地反映了 Windows 95、Windows 98、Windows NT 4.0 或 Windows 2000 操作系统的行为。这些模式解决了阻止早期的应用程序正常工作的许多最常见问题。还可以使用此项技术为您自己的应用程序创建解决方案。
程序兼容性向导
可使用程序兼容性向导来检测和测试兼容性设置。详细信息，请参阅兼容性问题疑难解答。


应用程序支持

本主题概述了 Windows Server 2003 家族中的应用程序支持功能。它分为两部分：自 Windows NT 4.0 以后的新功能与更新功能以及自 Windows 2000 以后的新功能与更新功能。

有关此版本中这些功能详细信息的链接，请参阅新功能。

Windows Server 2003 家族支持一系列可立即使用的独立软件供应商 (ISV) 解决方案，并提供一套全面的、用于快速开发自定义应用程序的 Internet 应用程序服务。

注意

  • Windows Server 2003, Web Edition 操作系统专用于 Web 应用程序服务，而不作为一般的应用程序服务器。

自 Windows NT 4.0 以后的新功能与更新功能

Windows Server 2003 家族进行了以下改进（与 Windows NT 4.0 相比），从而有助于更好地支持应用程序：

最广泛的各种应用程序
您可以在 Windows Server 2003 家族产品中运行各种各样的应用程序。有关兼容应用程序的最新信息，请参阅位于 Microsoft 网站 (http://www.microsoft.com) 的 Windows Catalog 中的软件兼容性信息。
全面的 Internet 应用程序服务
使用此版本中的集成 Web、组件管理、事务处理和消息队列服务，程序员可以迅速地开发和部署可伸缩的基于组件的应用程序。
Microsoft Active Accessibility
Microsoft Active Accessibility 是一种应用程序编程接口 (API)，它可以使开发人员更方便地编写可以由残障人士进行自定义的应用程序。Active Accessibility 减少了应用程序特定的代码需求，因而降低了总的维护成本，并让软件开发人员在革新用户界面时不会丢失与辅助功能的兼容性。详细信息，请参阅位于 Microsoft 网站 (http://www.microsoft.com) 的“Accessibility”（辅助功能）页。
TAPI 3.1
TAPI 3.1 统一了 Internet 协议 (IP) 和传统的电话服务，能使开发人员创建像在传统的电话网络上那样有效地在 Internet 或 Intranet 上工作的计算机电话服务应用程序。
事务服务
Windows Server 2003 家族中集成的事务处理服务提供了简单的构建模块，可以跨越广泛的分布式网络高效可靠地执行复杂的事务处理。
消息队列
集成的消息队列功能，可帮助开发人员构建和部署更可靠地在网络（包括 Internet）上运行的应用程序。这些应用程序可以与在不同的平台（如大型机和以 UNIX 为基础的系统）上运行的应用程序互操作。
组件服务
组件服务是基于组件对象模型 (COM) 扩展和 Microsoft Transaction Server（基于组件的事务处理系统的早期版本）的服务集。组件服务提供了线程处理和安全性、事务管理、对象共用、队列组件、应用程序管理和包装。
作业对象
Windows Server 2003 家族产品包含进程模型（称为作业）扩展。作业对象是可命名的、可设置安全权限的、可共享的对象，它们可以控制与它们关联的进程的属性。作业对象的基本功能是允许进程组作为一个单位来进行管理和操纵。例如，Web 应用程序可以使用作业对象对 CPU 使用情况记帐。
主持数据集成
Windows Server 2003 家族产品通过包含对开放式数据库连接 (ODBC)、Oracle 和 Microsoft SQL Server 的本机支持，为数据库应用程序的运行提供了极好的平台。

自 Windows 2000 以后的新功能与更新功能

Windows Server 2003 家族进行了以下改进（与 Windows 2000 相比），从而有助于更好地支持应用程序：

兼容模式
“兼容模式”提供了用于运行应用程序的环境，该环境能够更近似地反映 Windows 95、Windows 98、Windows NT 4.0 或 Windows 2000 操作系统的行为。这些模式解决了阻止早期的应用程序正常工作的许多最常见问题。还可以使用此项技术为您自己的应用程序创建解决方案。详细信息，请参阅访问有关兼容性的信息。
Internet 信息服务中的 Web 园
在 Internet 信息服务 (IIS) 中，Web 园是一种应用程序池，它具有多个为发送到该池的请求提供服务的工作进程。可以配置 Web 园，以使为它提供服务的进程对于多处理器计算机上的特定处理器具有相似性。通过 Web 园，Web 应用程序的可伸缩性得到了提高。如果一个工作进程遇到 Active Server Page (ASP) 发生的问题，那么其他工作进程仍可以供应内容并接管被锁定工作进程的工作。


管理和部署

本主题概述了 Windows Server 2003 家族中的应用程序管理和部署功能。它包括以下两部分内容：自 Windows NT 4.0 以后的新功能与更新功能以及自 Windows 2000 以后的新功能与更新功能。

有关指向此版本中这些功能详细信息的链接，请参阅新功能。

以下功能将有助于简化在台式机和便携系统上应用程序的部署。终端服务器提供了可以简化部署的其他选项和功能。详细信息，请参阅终端服务器功能。

自 Windows NT 4.0 以后的新功能与更新功能

Windows Server 2003 家族提供了以下改进功能（与 Windows NT 4.0 相比），这些功能有助于更好地支持管理和部署：

使用组策略进行更改和配置管理
可以使用策略设置来定义允许用户和计算机进行的操作和设置。与本地策略不同，组策略可以用来设置要应用到 Active Directory 中的给定站点、域或组织单位中的策略设置。有关组策略的详细信息，请参阅组策略。Windows Server 2003 家族包含 200 个以上的新策略设置。
Active Directory 中的目录合并
使用 Active Directory 可以组织并简化对用户、计算机、应用程序和设备的管理，且能使用户方便地找到所需的信息。您可以通过基于轻型目录访问协议 (LDAP) 的接口来利用同步支持，还可以处理专用于您的应用程序的目录合并要求。
IntelliMirror
为帮助降低成本，管理员需要对便携和桌面系统拥有最高级别的控制权。IntelliMirror 在运行 Windows 2000 Professional 或 Windows XP Professional 的客户端系统上提供了这种控制。可以使用 IntelliMirror 基于业务角色、组成员身份和位置定义策略设置。为了满足特定用户的要求，系统会在该用户每次登录到网络时（不管用户在哪里登录）使用这些策略设置对 Windows 2000 Professional 桌面和 Windows XP Professional 桌面自动进行重新配置。有关 IntelliMirror 的详细信息，请参阅 IntelliMirror。
远程安装服务
通过远程安装服务 (RIS)，可以创建操作系统的安装映像，甚至也可以创建完整的计算机配置（包括桌面设置和应用程序）的安装映像。然后可以使客户端计算机上的用户可以使用这些映像。客户端计算机必须支持使用预启动执行环境 (PXE) ROM 的远程启动，或者它们必须可以用远程启动软盘启动。详细信息，请参阅远程安装服务。

运行 Microsoft® Windows® Server 2003, Web Edition 操作系统的计算机不包括该功能。详细信息，请参阅 Windows Server 2003 Web Edition 概述。

Windows Management Instrumentation
Windows Management Instrumentation (WMI) 是一种可伸缩的管理基础结构，它以基于 Web 的企业管理 (WBEM) 倡议为基础。通过 WMI（包括命令行和脚本功能），可以监视、跟踪和控制与软件应用程序、硬件组件和网络相关的系统事件。WMI 基于标准 [来自通用信息模型 (CIM)] 而且灵活，从而允许您自定义收集和筛选信息的方式。有关 WMI 的详细信息，请参阅 WMI 概述。
相邻组件共享
相邻共享使相同的组件对象模型 (COM) 或 Win32 组件（例如，.dll 文件）的多个版本同时在内存中运行，从而使应用程序的脆弱性降到最低。这意味着应用程序可以使用经过特定设计并已通过测试的组件，即使其他应用程序需要同一组件的不同版本。这允许开发人员构建更可靠的应用程序，因为开发人员可以选择希望用于与系统中其他应用程序相独立的应用程序的组件版本。
添加或删除程序
通过“添加或删除程序”可以很容易地添加或删除程序或组件，并且可以跟踪当前已经安装的程序列表。
Windows Installer
使用“Windows Installer”可自定义软件组件的部署、监视文件复原，并通过回滚维护基本系统故障恢复。详细信息，请参阅 Windows Installer。
应用程序管理
可以通过应用程序管理来更改应用程序的控制方式而无需重新编译或重新发布。

自 Windows 2000 以后的新功能与更新功能

Windows Server 2003 家族提供了以下改进功能（与 Windows 2000 相比），这些功能有助于更好地支持管理和部署：

远程管理的服务器支持
远程管理的服务器支持提供了对没有监视器、VGA 显示适配器、键盘或鼠标的计算机进行安装和管理的能力。该功能还包括“紧急管理服务”，它提供了一种在操作系统不运行时 [例如计算机重新启动、网络上的服务器不可用或使用“远程安装服务 (RIS)”期间] 管理远程受控服务器的机制。
Windows Management Instrumentation 改进功能
Windows Management Instrumentation (WMI) 筛选功能通过帮助您确定组策略对象 (GPO) 的效果增强了组策略基础结构。
脚本支持
Windows Server 2003 家族能够更好地支持脚本的编写，包括新的命令行工具和对 Windows Script Host 的改进。有关新命令行工具的列表，请参阅新命令行工具。有关 Windows Script Host 改进的详细信息，请参阅 Windows Script Host 概述。
策略的结果集
可以使用策略的结果集 (RSoP) 模拟和测试通过组策略应用到计算机或用户的策略设置。RSoP 是一个查询引擎，可以轮询现有策略设置（也是计划的策略设置），然后报告查询的结果。它根据站点、域、域控制器和组织单元轮询现有策略设置。RSoP 从 Windows Management Instrumentation (WMI) 收集该信息。
远程安装服务改进功能
远程安装服务 (RIS) 的增强功能包括对 Windows Server 2003 家族和 Windows XP 产品安装的支持，对用于远程安装服务安装的应答文件处理的更多控制，以及对恢复模式下的网络文件的访问权限。

运行 Microsoft® Windows® Server 2003, Web Edition 操作系统的计算机不包括该功能。详细信息，请参阅 Windows Server 2003 Web Edition 概述。


终端服务器功能

本主题概述了此版本中的终端服务器功能。它包括以下两部分内容：自 Windows NT 4.0 以后的新功能与更新功能以及自 Windows 2000 以后的新功能与更新功能。

有关指向此版本中这些功能详细信息的链接，请参阅新功能。

终端服务器使远程计算机能对在 Windows Server 2003, Standard Edition、Windows Server 2003, Enterprise Edition 或 Windows Server 2003, Datacenter Edition 上运行的基于 Windows 的程序进行访问。通过终端服务器，可以提供单一的安装点，让多个用户访问运行这些产品的任何计算机。用户可以运行程序、保存文件和使用网络资源（所有操作都从远程位置进行），就像这些资源安装在他们自己的计算机上一样。

注意

  • 某些终端服务器和远程桌面功能在此版本中已经被重命名或取代。有关终端服务器中功能的新名称列表，请参阅执行常见任务的新方法。有关“管理远程桌面”（以前被称为“远程管理模式下的终端服务”）的新名称列表，请参阅执行常见任务的新方法。
  • “管理远程桌面”是此版本中提供的终端服务技术的另一部分。在运行 Windows Server 2003 家族产品的任意一台计算机上，无论是否安装了终端服务器，都可以使用“管理远程桌面”对服务器进行远程管理。详细信息，请参阅管理远程桌面。
  • 终端服务器（以前称为“应用程序服务器模式下的终端服务”）不包含在运行 Windows Server 2003, Web Edition 操作系统的计算机上。有关 Windows Server 2003, Web Edition 的详细信息，请参阅 Windows Server 2003 Web Edition 概述。

自 Windows NT 4.0 以后的新功能与更新功能

Windows Server 2003 家族提供了以下改进功能（与 Windows NT 相比），这些功能有助于更好地支持终端服务器：

程序的集中部署
通过终端服务器，所有的程序执行、数据处理和数据存储都可在集中部署了程序的服务器上进行。终端服务器可确保所有客户端都能访问相同版本的程序。软件只需在服务器上安装一次，而无需在组织中的每一台计算机上都安装，这样便可以降低与更新单个计算机相关的成本。
对应用程序的远程访问
终端服务器可以有效地从服务器向客户端发送应用程序显示，而不是基础的应用程序数据。这意味着您可以让用户通过低带宽连接（例如，28.8 Kbps 拨号连接）访问数据密集型应用程序，并且所提供的性能将可能比不使用终端服务器时更高。
单个应用程序访问
终端服务器可以为用户提供在没有获得完全访问 Windows XP 桌面的权限时访问单个发布的应用程序。
终端服务管理器
通过终端服务管理器，可以查看有关受信任域中的终端服务器信息。此信息包括每一台终端服务器的所有会话、用户和进程。还可以使用此实用程序执行各种操作以对服务器进行管理。
远程控制
终端服务对 Windows Server 2003 家族提供内置的远程控制。

自 Windows 2000 以后的新功能与更新功能

Windows Server 2003 家族提供了以下改进功能（与 Windows 2000 相比），这些功能有助于更好地支持终端服务器：

音频重定向
通过尝试播放 Wave 声音文件的任何应用程序，音频重定向可在终端服务器会话内在客户端计算机上实现声音再现。该功能提供了基本音频功能，例如，在电子邮件、文档或简单流式媒体中附加 .wav 文件。
组策略集成
终端服务器已与组策略集成，这样便可以通过实施重定向功能、密码访问和墙纸设置来管理已经启用终端服务器的服务器使用方式。
分辨率和颜色增强功能
作为终端服务器基础技术的终端服务，现在可以支持更大的颜色深度和屏幕分辨率。通过使用远程桌面连接，颜色深度可以是 256 色到真彩色之间的任何设置，分辨率可以从 640×480 到客户端视频设备所支持的最高级别。分辨率和颜色限制必须同时在服务器和客户端上启用。


开发支持

本主题概述了 Windows Server 2003 家族中的开发支持功能。它分为两部分：自 Windows NT 4.0 以后的新功能与更新功能以及自 Windows 2000 以后的新功能与更新功能。

有关此版本中这些功能详细信息的链接，请参阅新功能。

编写基于服务器的应用程序的开发人员，可使用 Microsoft Visual Studio 中提供的工具以及其他开发工具。Windows Server 2003 家族中的系统体系结构允许开发人员设计可以轻松转换并修改成本地版本的应用程序。

自 Windows NT 4.0 以后的新功能与更新功能

Windows Server 2003 家族进行了以下改进（与 Windows NT 4.0 相比），从而为开发人员提供更好的支持：

Visual Studio .NET
Visual Studio .NET 的设计宗旨是为了满足创建现代企业解决方案的组织的主要需求。Visual Studio .NET 的设计主题包括：
  • 用于基于组件的开发的一整套工具
  • 提高生存周期生产效率
  • 企业数据库工具
  • 增强对工作组的支持
  • 与应用程序服务集成
多语言技术
作为 Windows Server 2003 家族系统体系结构的结果，操作系统、实用程序和正确编写的应用程序都可以被转换和修改为上百种语言的本地版本。

自 Windows 2000 以后的新功能和更新功能

Windows Server 2003 家族进行了以下改进（与 Windows 2000 相比），从而为开发人员提供更好的支持：

链接 ID 的自动生成
应用程序在构建新的 Active Directory 结构（对 Active Directory 架构的扩展）时将使用链接 ID。如果应用程序请求与已经在使用中的链接 ID 相同的新的链接 ID，那么架构扩展就无法加载。链接 ID 的自动生成可以让应用程序开发人员选择请求自动生成链接 ID，从而避免了该问题。
后台智能传输服务
后台智能传输服务 (BITS) 是一种后台文件传输机制。BITS 按优先次序排列请求，可以使用它来指定那些优先级低的传输只有在网络负荷不满的情况下进行。传输甚至可以在网络断开连接或计算机重新启动之后继续进行。可以编写在后台使用 BITS 下载或上载文件的应用程序。例如，如果用户已经请求 Windows Update 执行多个下载，那么 Windows Update 就可以通过向 BITS 提交请求在后台检索这些更新。然后 BITS 服务将在后台下载这些文件，并在文件下载完之后通知用户。


网络协议和技术

本主题概述了 Windows Server 2003 家族中的网络协议与技术。它分为三部分：自 Windows Server 2003（不带 SP1）以后的新功能与更新功能、自 Windows NT 4.0 以后的新功能与更新功能以及自 Windows 2000 以后的新功能与更新功能。

Windows Server 2003 家族包括各种可用于扩展服务器功能的网络协议和技术。有关其他网络相关技术的信息，请参阅性能和调节功能。有关此版本中这些功能详细信息的链接，请参阅新功能。

注意

  • 以下网络协议已从 Windows Server 2003 家族的所有产品中删除：数据链路控制 (DLC) 协议（与某些型号的打印机有关）与 NetBIOS Extended User Interface (NetBEUI)。
  • 以下网络协议已从基于 Itanium 版本的 Windows Server 2003 家族中删除：Internetwork Packet Exchange/Sequenced Packet Exchange (IPX/SPX)、依赖于 IPX 的服务以及开放式最短路径优先 (OSPF)。详细信息，请参阅 Windows Server 2003 家族 64 位版本中不可用的功能。
  • 在 Windows Server 2003 家族中，仅 XOX 支持红外 (IR) 网络。

自 Windows Server 2003（不带 SP1）以后的新功能与更新功能

带 Service Pack 1 (SP1) 的 Windows Server 2003 操作系统提供了以下改进功能（与不带 SP1 的 Windows Server 2003 相比），这些功能有助于更好地支持网络协议和技术：

Remote Access Quarantine Service，属于 Network Access Quarantine Control
Remote Access Quarantine Service 是 Windows Server 2003（带 SP1）Network Access Quarantine Control 的关键组件。网络管理员可以使用 Network Access Quarantine Control 对远程计算机强制网络访问要求。如果不具备访问权限，将无法对远程计算机强制实施某些网络要求（例如使用病毒防护软件）。通过部署 Network Access Quarantine Control 组件，包括在 Windows Server 2003（带 SP1）中安装 Remote Access Quarantine Service (RQS.exe) 组件（可选），以及通过将 RQC.exe 组件与连接管理器中的高级自定义功能相结合，网络管理员可以创建连接来检查所需的程序、注册表设置、文件或这些检查项的组合。在这些检查执行完毕之前，管理员还能够隔离远程访问会话。

安装 Remote Access Quarantine Service 之后，不会自动启动 Remote Access Quarantine Agent 服务（Network Access Quarantine Control 中的另一个服务）。作为网络管理员，您必须确定一个最佳时间来启动与路由和远程访问服务配置相关的服务。Remote Access Quarantine Agent 服务取决于路由和远程访问服务。然而，如果重新启动路由和远程访问服务，Remote Access Quarantine Agent 服务并不会随之自动重新启动。您必须手动重新启动 Remote Access Quarantine Agent 服务。

详细信息，请参阅以下内容：

位于 Microsoft Windows Server System 网站 (http://www.microsoft.com/) 的“Network Access Quarantine Control in Windows Server 2003”（Windows Server 2003 中的网络访问隔离控制）

位于 Microsoft Download Center 网站 (http://www.microsoft.com/) 的“Step-by-Step Guide for Setting Up Network Quarantine and Remote Access Certificate Provisioning in a Test Lab”（在测试实验室中设置网络隔离和远程访问证书提供的分步指导）

位于 Microsoft Download Center 网站 (http://www.microsoft.com/) 的“VPN Quarantine Sample Scripts for Verifying Client Health Configurations”（用于验证客户端运行状况配置的 VPN 隔离示例脚本）

ValueAdd 文件夹已替换为 Support 文件夹
ValueAdd 文件夹已从 Windows Server 2003（带 SP1）中删除。要安装先前包含在该文件夹中的支持工具（例如 Phone Book Administrator），请转至安装 CD 中的 Support 文件夹。

自 Windows NT 4.0 以后的新功能与更新功能

Windows Server 2003 家族进行了以下改进（与 Windows NT 4.0 相比），从而有助于更好地支持网络协议与技术：

Winsock Direct
通过 Winsock Direct，使用 Winsock 的应用程序可以在跨系统区域网 (SAN) 通信时运行速度更快并且 CPU 开销较少。Winsock Direct 可在 SAN 到位的情况下简化分布式组件之间的通讯。
DHCP 与 DNS 和 Active Directory 协作
动态主机配置协议 (DHCP) 在“Internet 协议 (IP)”网络上与 DNS 和 Active Directory 协作，有助于减轻您指派和跟踪静态 IP 地址的工作。DHCP 动态地为连接到 IP 网络的计算机或其他资源分配 IP 地址。
Internet 连接共享
通过网络连接的 Internet 连接共享功能，可以将家庭网络或小型办公网络连接到 Internet。例如，可以建立用数字订户线路 (DSL) 连接到 Internet 的家庭网络。通过在使用 DSL 的计算机上启用 Internet 连接共享，可以为家庭网络上的所有计算机提供网络地址转换、寻址和名称解析服务。详细信息，请参阅 Internet 连接共享和网络地址转换。

此功能只在 XOX 和 XOX 上可用，并且只在基于 x86 的计算机上可用。

网络地址转换
网络地址转换 (NAT) 通过将专有内部地址转换为公用外部地址，可对外部网络隐藏内部管理的 IP 地址。通过让您在内部使用专用 IP 地址，并转换为数量较少的已注册的对外 IP 地址，便可以降低 IP 地址注册的成本。同时也隐藏了内部网络结构，从而降低了内部系统受到攻击的风险。
虚拟专用网络
可以通过实现虚拟专用网络 (VPN)，使用户很方便地访问您单位的网络（即使他们不在办公室，也可以访问），并且降低访问成本。VPN 连接将创建跨 Internet 进入专用网络的安全隧道。

Windows Server 2003 家族中包含有两种类型的 VPN 技术：

  • 点对点隧道协议 (PPTP)，该协议使用用户级别点对点协议 (PPP) 身份验证方法和用于数据加密的 Microsoft 点对点加密 (MPPE)。
  • 第二层隧道协议 (L2TP) 与 Internet 协议安全 (IPSec)。L2TP 在数据加密方面使用用户级 PPP 身份验证方法和具有 IPSec 的计算机级证书。

XOX

路由和远程访问
“路由和远程访问”代替了 Windows NT 4.0 中的“路由和远程访问服务 (RRAS)”和“远程访问服务 (RAS)”功能。路由和远程访问是一种单一的集成服务，它可以终止来自拨号或 VPN 客户端的连接，或提供路由选择（IP、IPX 以及 AppleTalk）或者两者兼可。通过“路由和远程访问”，服务器可用作远程访问服务器、VPN 服务器、网关或分支机构路由器。详细信息，请参阅路由和远程访问。
异步传输模式
异步传输模式 (ATM) 是面向高速连接的协议，用于通过网络传输多种类型的通讯。它适用于局域网 (LAN) 和广域网 (WAN)。利用 ATM，网络可以同时传输各种网络通讯，包括语音、数据、图像和视频传输。

自 Windows 2000 以后的新功能与更新功能

Windows Server 2003 家族进行了以下改进（与 Windows 2000 相比），从而有助于更好地支持网络协议与技术：

简单对象访问协议
简单对象访问协议 (SOAP) 是一个基于 XML 的协议，用于在分散的分布式环境中交换信息。它主要包含两个核心部分：封包 - 用于处理扩展性与模块性；编码机制 - 用于显示封包中的数据类型。它不需要同步执行或进行请求/响应交互。SOAP 为简单协议提供了扩展性机制，用于添加功能，如消息路由、安全以及有保证的传递。对于普遍使用的协议，包括 XML、超文本传输协议 (HTTP)、简单邮件传输协议 (SMTP) 和文件传输协议 (FTP)，通过依赖这些协议的可用性，SOAP 可用于广泛类别的平台和客户端。
纤维管道支持
纤维管道是一种每秒传输 1 GB 数据的技术，它可以映射常用传输协议，例如小型计算机系统接口 (SCSI) 和 Internet 协议 (IP)，并将网络连接和高速输入输出 (I/O) 合并成单一连接性技术。纤维管道技术向用户提供了解决传统通道技术在距离和地址空间限制的方法。详细信息，请参阅纤维管道硬件配置。
多个网络的自动配置
多个网络的自动配置使用户可以方便地访问网络设备和 Internet。它还为移动计算机用户提供了在办公室网络和家庭网络上无缝操作的功能，无需手动重新配置 TCP/IP 设置。通过多个网络的自动配置，TCP/IP 可以在找不到 DHCP 服务器的情况下使用备用配置。
连接管理器改进功能
连接管理器提供了若干新的功能：
  • 针对连接管理器客户端的自动代理配置。配置用户代理设置以确保用户在连接到您的服务时可以相应地访问内部和外部资源。
  • 连接管理器收藏夹。用户在公用拨号位置中切换时，可以消除“连接管理器”属性的重复配置。
  • 客户端日志文件。连接管理器连接问题疑难解答。
  • 连接管理器管理工具包。使用连接管理器管理工具包 (CMAK) 向导可自定义连接管理器，从而满足您的需要。
Web 分布式创作和版本管理重定向程序
Web 分布式创作和版本管理 (WebDAV) 重定向程序支持 WebDAV 协议，以便通过 HTTP 共享远程文档。WebDAV 重定向程序支持使用现有应用程序，并且它还支持跨 Internet（通过防火墙、路由器等等）到 HTTP 服务器的文件共享。
Internet 验证服务作为 RADIUS 代理
此功能支持 Internet 验证服务 (IAS) 将远程身份验证拨号用户服务 (RADIUS) 身份验证和记帐请求转发到另一个 RADIUS 服务器的能力。这包括多个 IAS/RADIUS 服务器和负载平衡 RADIUS-EAP 请求之间灵活的、基于规则的转发、负载平衡和故障转移；无论是否有用户身份验证的情况下都强制客户端进入必要隧道的能力；以及有选择地将身份验证和记帐请求转发到不同的 RADIUS 服务器的能力。

XOX您可以在 XOX 中配置 IAS，最多配置 50 个 RADIUS 客户端和 2 个远程 RADIUS 服务器组。有关这些限制的详细信息，请参阅 Internet 验证服务。

无线网络
Windows Server 2003 家族中的无线网络功能支持 IEEE 802.11 标准。它还将访问无线网络所必需的配置最小化。自动无线网络配置功能使用户可以在不同位置的不同无线网络之间漫游，无需针对每个新位置重新配置网络连接设置。IEEE 802.11 的安全选项包括身份验证服务和以“有线对等保密 (WEP)”算法为基础的加密服务。为了获得增强的安全性，Windows Server 2003 家族产品中的 IEEE 802.11 身份验证默认情况下处于启用状态。IEEE 802.1x 身份验证对 802.11 无线网络和有线以太网网络提供了经过验证的访问权限。IEEE 802.1X 身份验证提供了对可扩展身份验证协议 (EAP) 安全类型的支持，这样用户就可以使用像证书这样的身份验证方法。
IPv6
Windows Server 2003 家族支持 Internet 协议版本 6 (IPv6)，IPv6 是一组标准协议，也是 Internet 的新一代网络层协议。详细信息，请参阅 IPv6。


安装和升级操作系统

这些主题可以帮助您规划在拥有 1 至 5 台服务器和 100 台或更少客户端的网络中升级为 XOX 或安装 Windows Server 2003, Enterprise Edition。有关计划升级或安装大量服务器的帮助，请参阅位于 Microsoft Windows 资源工具包网站的“Windows Server 2003 Deployment Kit”（Windows Server 2003 部署工具包）。(http://www.microsoft.com/)

  • 在运行安装程序之前，请参阅清单。
  • 有关安装的提示，请参阅最佳操作。
  • 有关特定任务的帮助信息，请参阅如何。
  • 有关一般背景信息，请参阅概念。
  • 有关疑难解答的说明，请参阅疑难解答。


清单

  • 清单：执行升级
  • 清单：执行全新安装


清单：执行升级

步骤 | 参考
检查系统需求。 | 系统需求
阅读 Relnotes.htm 和硬件兼容性信息。 | 要阅读的重要文件 硬件兼容性
确定当前操作系统是否适于升级到 Windows Server 2003, Enterprise Edition。 | 升级与全新安装的对比
如果您有服务器群集，请复查在群集节点上进行升级的选择。 | 在群集节点上升级到 Windows Server 2003, Enterprise Edition 清单：升级群集的准备工作
对于在所有域控制器都运行 Windows NT 4.0 的任何域中进行的升级，请复查升级计划。 | 在 Windows NT 4.0 域中升级
对于在一个或多个域控制器运行 Windows 2000 的任何域中进行的升级，请运行用于升级架构的工具（在升级操作系统之前）。 | 为在包含 Windows 2000 域控制器的域中进行升级做准备
决定是否将任何 FAT 或 FAT32 分区升级到 NTFS。 | 为安装分区选择文件系统
检查系统日志中是否有可能会在升级期间产生问题的错误。 | 为系统做好升级准备
对文件进行备份。 | 为系统做好升级准备
如果从 Windows NT 4.0 升级，请为升级准备镜像集或其他磁盘集。 | 使用卷集、镜像集、带区集或带奇偶校验的带区集
断开 UPS 设备。 | 为系统做好升级准备
复查硬件和软件。 | 为系统做好升级准备
启动安装程序，并按照提供的说明进行操作。 | 在基于 x86 的计算机上启动安装程序 在基于 Itanium 体系结构的计算机上启动安装程序
如果域控制器升级已完成，请复查有关域功能级别的概念，如果合适的话，请提高功能级别。 | 域和林功能 从 Windows NT 域升级


清单：执行全新安装

步骤 | 参考
检查系统需求。 | 系统需求
阅读 Relnotes.htm 和硬件兼容性信息。 | 要阅读的重要文件 硬件兼容性
决定是升级还是安装。 | 升级或安装
如果您有服务器群集，请复查群集节点上的安装过程。 | 清单：安装群集的准备工作
决定使用何种授权模式：每设备或每用户或每服务器。 | 选择授权模式
决定是否要在每次启动计算机时选择不同的操作系统。 | 决定计算机是否包含多个操作系统
确定使用何种文件系统：NTFS、FAT 或者 FAT32。 | 为安装分区选择文件系统
决定将安装在哪一个分区上，或者是否需要新的安装分区。 | 为全新安装规划磁盘分区或卷
决定如何处理网络、IP 地址及 TCP/IP 名称解析。 | 网络：TCP/IP、IP 地址及名称解析
决定是为服务器创建域还是工作组。 | 在工作组和域之间进行选择
如果计算机上已经有投入使用的操作系统，请备份文件并检查系统日志，看是否存在错误。 | 为系统做好全新安装准备
解压缩任何 DriveSpace 或 DoubleSpace 卷。 | 为系统做好全新安装准备
如果计算机运行 Windows NT 4.0 并使用镜像集或其他磁盘集，请准备磁盘。 | 使用卷集、镜像集、带区集或带奇偶校验的带区集
断开 UPS 设备。 | 为系统做好全新安装准备
启动安装程序，并按照提供的说明进行操作。 | 在基于 x86 的计算机上启动安装程序 在基于 Itanium 体系结构的计算机上启动安装程序


最佳操作

在升级或安装之前准备服务器。

  • 如果要进行升级，请参阅：
    • 清单：执行升级
    • 为系统做好升级准备

  • 如果要进行全新安装，请参阅：

    • 清单：执行全新安装
    • 为系统做好全新安装准备

运行安装程序之后确认服务器设置。

  • 检查事件查看器。检查事件查看器是否有与安装或启动过程关联的消息。详细信息，请参阅事件查看器。
  • 设置事件查看器日志大小和覆盖设置。定义事件日志大小和覆盖（改写）设置以满足业务和安全性要求。有关信息，请参阅设置事件日志记录选项。
  • 检查服务器优化。调整服务器优化设置以匹配该计算机在您单位所担任的角色。有关如何访问服务器优化设置的信息，请参阅配置计算机上与内存相关的设置。
  • 验证诸如 IP、DNS、WINS 和默认网关设置之类的设置。使用网络服务中介绍的管理工具配置和验证设置。还可以打开命令提示符，键入 ipconfig /all 并验证显示设置。
  • 查看完整的计算机名称。打开命令提示符并键入 net config rdr 以查看完整计算机名称。将结果对照 Active Directory 名称进行比较，以确认它们是否匹配或与预期的有所不同。
  • 验证服务器群集设置。请按照清单：验证您的群集系统中的步骤确认群集存储的基本配置设置。
  • 指定分页文件和内存转储的选项。根据内存大小和服务器使用情况，设置分页文件大小和位置。有关如何执行此项操作的信息，请参阅更改虚拟内存设置。此外，还要设置操作系统在系统意外停止的情况下使用的选项（例如，内存转储的选项）。详细信息，请参阅指定系统意外停止时将会发生的情况。
  • 为远程管理进行配置。确定计划使用的远程管理方法，并按需要对它们进行配置。详细信息，请参阅远程管理。

运行安装程序之后确认服务器安全设置。

  • 复查服务的启动设置。XOX在“服务和应用程序”下的“服务”文件夹中，更改服务的“启动类型”以使服务器需要的服务（并且只有这些服务）自动启动。此外，请确认所有被设置为自动启动的服务是否都无需用户干预或多次重试就可以启动。有关服务的主题列表，请参阅服务。有关安装之后将默认启动的服务（与 Windows 2000 中不同的服务）的特定信息，请参阅服务的默认设置。
  • 复查 Internet Explorer 安全设置。默认情况下，Windows Server 2003 家族操作系统会启用“Internet Explorer 增强的安全配置”。通过限制您的计算机对恶意网站的暴露程度，此配置中的安全设置有助于使您的计算机更安全。因此，使用这一增强级别的安全性，您可能会发现，当浏览 Internet 和 Intranet 网站时，某些网站没有正确显示在 Internet Explorer 中。另外在您访问网络资源 [例如，通用命名约定 (UNC) 共享文件夹中的文件] 时，系统可能会提示您输入凭据。您可以轻松更改增强的安全设置。详细信息，请参阅 Internet Explorer 增强的安全配置。
  • 复查打开的网络端口。为帮助保护服务器免遭攻击，请关闭系统正常运行所不需要的端口。可以用 netstat 命令复查端口。还可以使用外部端口扫描程序进行扫描，并将结果与使用 netstat 获得的结果进行比较。在运行端口扫描程序之前，一定要通知其他系统管理员或受影响的操作人员，以防它影响系统行为，或触发现有的用于检测入侵的触发器。有关 netstat 以及如何确定哪一个进程与哪一个打开的端口相关的详细信息，请参阅 Netstat。详细信息，还请参阅端口号分配，位于 Internet Assigned Numbers Authority (IANA) 网站。

    注意

    • 网站地址可能变动，您可能无法连接到此处提及的网站。
  • 重命名或禁用管理员帐户；设置或复查此服务器的相关权限和帐户。重命名或禁用安装期间创建的管理员帐户（无法将它删除）。设置用于配置、备份、操作和使用此服务器的相应帐户和权限。对于用户和管理员，应将访问限制到必需的最低访问权限；例如，对于只执行备份的人员，只使用“Backup Operators”组。此外，还要设置策略以确保用户使用强密码。详细信息，请参阅：
    • 安全性的最佳操作和 Active Directory 用户和计算机的最佳操作
    • 了解组和默认组
    • 强密码
  • 了解涉及服务器的安全性含义。涉及安全性的问题随计划的服务器用途不同而不同。例如，对于文件服务器，哪些人需要访问给定文件或目录，需要什么样的访问类型，以及未授权的访问可能会产生什么样的后果？对于 Web 服务器，要使用什么样的 Web 应用程序，这些应用程序中有哪些固有的风险，以及什么样的设置将有助于降低风险？详细信息，请参阅下表中的链接：
    • 服务器的类型 | 建议阅读的安全性主题
任何服务器 | 请参阅安全性的最佳操作以及在最佳操作中所使用技术的主题。
文件服务器 | 如果要使用“共享文件夹”，请参阅针对“共享文件夹”的最佳操作。如果要使用 Active Directory，请参阅安全概述。
多媒体服务器 | 请参阅 Windows Media Services 文档中有关安全的部分，在安装 Windows Media Services 之后即可获得该文档。详细信息，请参阅使用 Windows Media Services。
打印服务器 | 请参阅有关打印的最佳操作。
终端服务器 | 请参阅有关终端服务器的最佳操作。
Web 服务器 | 请参阅 Internet 信息服务 (IIS) 的“服务器管理指南”中有关安全的部分；安装 IIS 之后即可获得此文档。详细信息，请参阅 Internet 信息服务 (IIS) 6.0。
  • 配置审核设置，设置系统保护，安装病毒扫描程序。复查和实现审核设置，包括安全事件的设置，以便可以跟踪对系统的所有更改并防止对软件的非法更改。详细信息，请参阅：
    • 审核安全事件
    • 有关系统信息与保护系统文件和驱动程序的主题：
      系统信息、Windows 文件保护、Windows 驱动程序签名、系统文件检查程序 (sfc)、使用文件签名验证以及设置文件签名验证选项
    • 安全性的最佳操作
  • 确保安装相应的防火墙。 防火墙是充当网络与外部世界之间设防边界的安全系统。有关 Windows Server 2003, Enterprise Edition 和 Windows Server 2003, Standard Edition 中提供的防火墙功能的信息，请参阅 Internet 连接防火墙。有关 Microsoft 提供的防火墙产品的信息，请参阅位于 Microsoft 网站 (http://www.microsoft.com/) 的“Internet Security and Acceleration (ISA) Server”。
  • 考虑使用“安全配置向导”。“安全配置向导”减小了运行带有 Service Pack 1 (SP1) 的 Windows Server 2003 的计算机的受攻击面。该向导询问用户一系列问题以确定服务器的功能要求。然后禁用该服务器正在执行的角色不需要的功能。除了作为一项重要的安全最佳做法外，攻击面的减小增加了 Windows 环境的多样性，还可以在出现安全问题时减少需要立即更新的系统的数量。详细信息，请参阅 Microsoft 网站。(http://www.microsoft.com/)

开始诸如备份之类的日常操作。

  • 分析硬盘的碎片情况。运行安装程序以及安装完程序之后，分析硬盘以查看是否需要进行碎片整理。有关详细信息，请参阅分析卷。
  • 执行备份和安装故障恢复控制台。执行备份，安装故障恢复控制台，以使它一旦启动计算机便立即可用，并实践或模拟恢复操作（在对服务器的需求较低时进行）。详细信息，请参阅：
    • 备份和还原数据
    • 在基于 x86 的计算机上将故障恢复控制台安装为启动选项
    • 故障恢复

熟悉可用的信息。

  • 复查与将要使用的功能和组件有关的最佳操作主题和清单。有关最佳操作主题的列表，请参阅最佳操作。有关清单的列表，请参阅清单。
  • 熟悉其他信息源和工具。在“帮助和支持”中有各种资源列表，包括帮助快速入门的资源主题。在支持资源中列出的信息源中也提供了各种信息。


如何

  • 为在包含 Windows 2000 域控制器的域中进行升级做准备
  • 在基于 x86 的计算机上启动安装程序
  • 在基于 Itanium 体系结构的计算机上启动安装程序
  • 为全新安装输入服务器设置


为在包含 Windows 2000 域控制器的域中进行升级做准备

Microsoft Windows 图形

为在包含 Windows 2000 域控制器的域中进行升级做准备

  1. 在执行此过程之前，建议对运行 Windows 2000 的所有域控制器应用 Service Pack 2 或更高版本。
  2. 定位作为架构主机的服务器和作为结构主机的服务器（它们可能是同一服务器）。
  3. 备份架构主机。也可备份其他服务器以作为升级准备的适当组成部分，但是请务必在进行后续步骤之前先备份架构主机。
  4. 断开架构主机与网络之间的连接，并且不要在本过程的第 9 步之前重新建立连接。
  5. 在架构主机上，当 Windows 2000 运行时，将 Windows Server 2003, Enterprise Edition 插入 CD-ROM 驱动器。
  6. 打开命令提示符，转到 CD-ROM 驱动器，然后转到光盘上的 \i386 文件夹。
  7. 在架构主机的命令提示符下，键入

    adprep /forestprep

  8. 在架构主机上完成了上述命令后，请确认林已准备成功。为此需要采取的步骤包括：
    • 确认没有出现任何错误信息。
    • 运行所有可用的域控制器诊断工具，如 Dcdiag。请记住当域控制器与网络断开时将出现复制错误信息。
    • 打开事件查看器并检查系统日志中的错误或意外事件。
  9. 评估在前一步骤中收集的信息，并根据此信息选择：
    • 如果 adprep /forestprep 在运行时没有出现错误，请重新将架构主机连接到网络并继续本过程的后续步骤。
    • 如果 adprep /forestprep 在运行时出现错误信息，且该错误信息提供了需要采用的额外步骤的说明，则请按照该说明进行操作然后返回到前一步骤中描述的确认过程。
    • 如果 adprep /forestprep 运行不成功，或诊断工具（如 Dcdiag）显示了重大问题，则请从备份中恢复架构主机，然后研究必要的校正步骤，以便成功运行 adprep /forestprep。
  10. 如果架构主机不是结构主机，请等待系统将 adprep /forestprep 所做的更改从架构主机复制到结构主机。至少等待 15 分钟，如果架构主机和结构主机不在同一站点则需要等待更长时间（半天或一天）。如果在未复制完更改时就执行结构主机上的域准备，Adprep 将提供错误信息以通知您需要更长时间。
  11. 在结构主机上，当 Windows 2000 运行时，将 Windows Server 2003, Enterprise Edition 插入 CD-ROM 驱动器。
  12. 打开命令提示符，转到 CD-ROM 驱动器，然后转到光盘上的 \i386 文件夹。
  13. 在结构主机上，键入

    adprep /domainprep

  14. 在结构主机上完成上述命令后，请确认域准备成功。为此需要采取的步骤包括：
    • 确认没有出现任何错误信息。
    • 运行所有的可用域控制器诊断工具。
    • 打开事件查看器并检查系统日志中的错误或意外事件。
  15. 评估在前一步骤中收集的信息，并根据此信息选择：
    • 如果 adprep /domainprep 在运行时没有出现错误，请继续本过程的后续步骤。
    • 如果 adprep /domainprep 在运行时出现错误信息，且此错误信息提供了需要采用的额外步骤的说明，则请按照该说明进行操作然后返回到前一步骤中描述的确认过程。
  16. 等待系统将 adprep /domainprep 所做的更改从结构主机复制到其他域控制器。至少等待 15 分钟，如果有域控制器在远程站点则需要等待更长时间（半天或一天）。如果在未复制完更改时就开始升级其他域控制器，则将出现弹出式消息，通知您需要更长的时间。

注意

  • 要运行 adprep /forestprep，您必须是 Active Directory 中 Enterprise Admins 组和 Schema Admins 组的成员，或者您必须被委派了适当的权限。要运行 adprep /domainprep，您必须是 Active Directory 中的 Domain Admins 组或 Enterprise Admins 组的成员，或者您必须被委派了适当的权限。作为安全性最佳操作，可以考虑使用运行方式来执行这个过程。
  • 本过程完成后，就可以让域控制器无限期的运行 Windows 2000，或者可立即对域控制器进行升级。
  • 计划特定服务器升级的第一步是检查硬件与 Windows Server 2003 家族产品间的兼容性。有关硬件兼容性的的详细信息，请参阅“相关主题”。

相关主题


启动安装程序

Microsoft Windows 图形

在基于 x86 的计算机上启动安装程序

  • 在运行 Windows 的计算机上从光盘启动安装程序
  • 从网络启动安装程序
  • 在运行 MS-DOS 的计算机上从光盘启动安装程序以进行全新安装
  • 通过从光盘启动计算机来启动安装程序以进行全新安装
  • 启动安装程序并提供大容量存储驱动程序或 HAL 文件


在运行 Windows 的计算机上从光盘启动安装程序

Microsoft Windows 图形

在运行 Windows 的计算机上从光盘启动安装程序

  1. 将光盘插入驱动器。
  2. 要开始安装，请执行下列操作之一：
    • 对于运行除 Windows 3.x 外的任意 Windows 版本的计算机，请等待安装程序显示对话框。
    • 对于运行 Windows 3.x 的计算机，请使用文件管理器切换到 CD-ROM 驱动器，再转到 I386 目录，然后双击“Winnt.exe”。
  3. 按照安装程序的说明进行操作。

注意

  • 要运行安装程序以便升级，您必须是本地计算机 Administrators 组的成员，或者您必须被委派了适当的权限。如果将计算机加入域，Domain Admins 组的成员也可以执行这个过程。作为安全性最佳操作，可以考虑使用运行方式来执行这个过程。
  • 如果您正在运行 Windows 3.x 或 MS-DOS 的计算机上运行安装程序，为获得最高效率，请使用磁盘缓存。否则，安装过程（从 Winnt.exe 启动）可能需要很长时间。要在运行 Windows 3.x 或 MS-DOS 的计算机上启用磁盘缓存，可使用 SMARTDrive。有关 SMARTDrive 的信息，请参阅 Windows 3.x 或 MS-DOS 的文档。
  • 安装过程分为几个阶段：提示您输入信息、复制文件和重新启动。
  • 有关无人参与安装的信息，请参阅“相关主题”。
  • 如果您有用于硬盘的大容量存储控制器（如 SCSI、RAID 或纤维管道适配器），请参阅“相关主题”，获得有关如何确保控制器驱动程序文件可用于安装程序的信息。
  • 如果您拥有要求计算机制造商提供自定义硬件抽象层 (HAL) 文件的专用硬件，请参阅“相关主题”，获得有关如何使 HAL 文件在安装过程中可用的信息。

相关主题


从网络启动安装程序

Microsoft Windows 图形

从网络启动安装程序

  1. 在网络服务器上，既可通过插入光盘并共享该 CD-ROM 驱动器来共享安装文件，也可通过将安装文件从光盘的 I386 文件夹复制到共享文件夹来共享安装文件。
  2. 在要安装的计算机上，连接到共享安装文件：
    • 如果您正在共享 CD-ROM 驱动器，则连接到共享驱动器并转到 I386 文件夹。
    • 如果共享文件夹，则直接连接该文件夹即可。
  3. 查找并运行光盘的 I386 目录中或共享文件夹中适当的文件：
    • 在运行 MS-DOS 或 Windows 3.x 的计算机上运行 Winnt.exe。
    • 在运行 Windows 95、Windows 98、Windows Millennium Edition、Windows NT（带 Service Pack 5 或更高版本）、Windows 2000 或 Windows XP 的计算机上，运行 Winnt32.exe。
  4. 按照安装程序的说明进行操作。

注意

  • 要运行安装程序以便升级，您必须是本地计算机 Administrators 组的成员，或者您必须被委派了适当的权限。如果将计算机加入域，Domain Admins 组的成员也可以执行这个过程。作为安全性最佳操作，可以考虑使用运行方式来执行这个过程。
  • 安装过程分为几个阶段：提示您输入信息、复制文件和重新启动。
  • 有关无人参与安装的信息，请参阅“相关主题”。
  • 如果您有用于硬盘的大容量存储控制器（如 SCSI、RAID 或纤维管道适配器），请参阅“相关主题”，获得有关如何确保控制器驱动程序文件可用于安装程序的信息。
  • 如果您拥有要求计算机制造商提供自定义硬件抽象层 (HAL) 文件的专用硬件，请参阅“相关主题”，获得有关如何使 HAL 文件在安装过程中可用的信息。

相关主题


在运行 MS-DOS 的计算机上从光盘启动安装程序以进行全新安装

Microsoft Windows 图形

在运行 MS-DOS 的计算机上从光盘启动安装程序以进行全新安装

  1. 将光盘插入驱动器。
  2. 在命令提示符下，键入：

    d:

    其中 d 是 CD-ROM 驱动器的驱动器号。

  3. 键入：

    cd i386

  4. 键入：

    winnt

  5. 按照安装程序的说明进行操作。

注意

  • 如果您正在运行 Windows 3.x 或 MS-DOS 的计算机上运行安装程序，为获得最高效率，请使用磁盘缓存。否则，安装过程（从 Winnt.exe 启动）可能需要很长时间。要在运行 Windows 3.x 或 MS-DOS 的计算机上启用磁盘缓存，可使用 SMARTDrive。有关 SMARTDrive 的信息，请参阅 Windows 3.x 或 MS-DOS 的文档。
  • 安装过程分为几个阶段：提示您输入信息、复制文件和重新启动。
  • 有关无人参与安装的信息，请参阅“相关主题”。
  • 如果您有用于硬盘的大容量存储控制器（如 SCSI、RAID 或 纤维管道适配器），请参阅“相关主题”，获得有关如何确保控制器驱动程序文件可用于安装程序的信息。
  • 如果您拥有要求计算机制造商提供自定义硬件抽象层 (HAL) 文件的专用硬件，请参阅“相关主题”，获得有关如何使 HAL 文件在安装过程中可用的信息。

相关主题


通过从光盘启动计算机来启动安装程序以进行全新安装

Microsoft Windows 图形

通过从光盘启动计算机来启动安装程序以进行全新安装

  1. 确定要启动安装程序的计算机是否可从 CD-ROM 驱动器启动，以及您是否希望执行全新安装（而非升级）。只有两个条件都为肯定时才能继续。
  2. 将光盘插入驱动器，然后重新启动计算机。
  3. 按照操作系统的说明从光盘启动计算机。
  4. 等待安装程序显示对话框，然后按照安装程序的说明进行操作。

注意

  • 仅当您希望执行全新安装而不是升级时此方法才适用。使用此方法，您可以在没有操作系统的计算机上执行安装，当然也可以在带有操作系统的计算机上执行。
  • 安装过程分为几个阶段：提示您输入信息、复制文件和重新启动计算机。
  • 有关无人参与安装的信息，请参阅“相关主题”。
  • 如果您有用于硬盘的大容量存储控制器（如 SCSI、RAID 或纤维管道适配器），请参阅“相关主题”，获得有关如何确保控制器驱动程序文件可用于安装程序的信息。
  • 如果您拥有要求计算机制造商提供自定义硬件抽象层 (HAL) 文件的专用硬件，请参阅“相关主题”，获得有关如何使 HAL 文件在安装过程中可用的信息。

相关主题


启动安装程序并提供大容量存储驱动程序或 HAL 文件

Microsoft Windows 图形

启动安装程序并提供大容量存储驱动程序或 HAL 文件

  1. 确定是否需要为安装程序提供由硬件制造商提供的特殊文件 [大容量存储驱动程序或硬件抽象层 (HAL) 文件]：
    • 如果您为硬盘安装了大容量存储控制器（例如 SCSI、RAID 或纤维管道适配器），请检查制造商是否已提供单独的驱动程序文件供 Windows Server 2003 家族使用。
    • 如果您拥有一个非常特殊的计算机系统，请参阅硬件文档，查看计算机制造商是否提供了自定义的 HAL 文件。
  2. 如果您确定需要由硬件制造商提供的驱动程序或 HAL 文件，请在开始安装前，定位包含该文件的软盘或其他媒体。
  3. 在安装的开始部分，请注意屏幕底部是否出现了一行文字提示您按 F6。根据以下内容按适当的键：
    • 要为安装程序提供大容量存储控制器的驱动程序，请遵照指示按 F6。
    • 要为安装程序提供 HAL 文件，请按 F5。
  4. 在向安装程序提供驱动程序文件时，请按照指导的进一步提示进行操作，以便使安装程序可访问大容量存储控制器。

注意

  • 如果不能确定是否必须从大容量存储控制器的制造商那里获得单独的驱动程序文件，则可以尝试运行安装程序。如果控制器不受安装 CD 中的驱动程序文件的支持，从而要求由硬件制造商提供的驱动程序文件，则安装过程将停止并显示消息，告知没有找到任何磁盘设备，或者它将显示不完整的控制器列表。获得必要的驱动程序文件后，重新启动安装程序，并在出现提示时按 F6。

相关主题


在基于 Itanium 体系结构的计算机上启动安装程序

Microsoft Windows 图形

在基于 Itanium 体系结构的计算机上启动安装程序

  1. 打开计算机后，请立即将安装 CD 插入 CD-ROM 驱动器。
  2. 出现“EFI 启动管理器”菜单时，选择“CD-ROM”选项。
  3. 出现提示时，按任意键开始从 CD-ROM 执行安装。
  4. 按照屏幕上的安装说明进行操作。

要点

  • 基于 Itanium 体系结构的计算机至少要求 100MB FAT 分区，用于可扩展固件接口 (EFI) 的操作。安装时会自动创建 EFI 系统分区，该分区存储了 EFI 用于启动操作系统的程序和信息文件。不要删除或重新格式化该分区。
  • 安装程序同时创建一个操作系统要求的 Microsoft 保留 (MSR) 分区。该分区的大小取决于硬盘大小。在小于 16 GB 的驱动器上，MSR 的大小为 32 MB。在大于或等于 16 GB 的驱动器上，MSR 的大小为 128 MB。不要删除或重新格式化该分区。

注意

  • 安装之前，请确认您使用的是正确版本的固件。详细信息，请参阅硬件制造商的文档。
  • EFI 定义了一个名为 GUID 分区表 (GPT) 的新分区形式，只有基于 Itanium 体系结构的计算机才可使用这种分区形式。基于 Itanium 体系结构的计算机上的安装分区必须位于 GPT 磁盘上。安装程序自动将 GPT 指定为用于安装的磁盘。您仍然可以对主启动记录 (MBR) 卷进行读写，多数 PC 机都是如此，但是您不能在上面执行安装。详细信息，请参阅“相关主题”。
  • 不能从基于 x86 的计算机本地访问 GPT 磁盘。如果要将磁盘从基于 Itanium 体系结构的计算机移动到基于 x86 的计算机，请使用 MBR 磁盘。无论动态磁盘还是基本磁盘都是如此。

相关主题


为全新安装输入服务器设置

  • 在安装过程中指定区域和语言选项以及用户姓名
  • 在安装过程中指定授权模式
  • 输入计算机名
  • 设置 Administrator 帐户密码
  • 设置日期和时间
  • 允许安装程序指派或获取 IP 地址
  • 指定 DNS 和 WINS 所需的静态 IP 地址和设置
  • 指定工作组或域名

注意

  • 此部分的主题提供有关为全新安装输入服务器设置的详细信息。如果要升级，则可以跳过这些主题，因为安装程序将使用旧的设置。
  • 如果硬盘有大容量存储控制器（如 SCSI、RAID 或纤维管道适配器），或者如果您的专用计算机需要计算机制造商提供的自定义硬件抽象层 (HAL) 文件，请参阅启动安装程序并提供大容量存储驱动程序或 HAL 文件。
  • 启动安装程序之后，就会开始将所需要的安装程序文件复制到硬盘。在此过程中，安装程序会显示一些可供您选择各种选项的对话框。


在安装过程中指定区域和语言选项以及用户姓名

Microsoft Windows 图形

在安装过程中指定区域和语言选项以及用户姓名

  1. 在安装过程中的“区域和语言选项”对话框中，请按照自定义语言和区域设置的说明进行操作。可使用多个区域和语言选项。
  2. 在“自定义软件”对话框中，键入您的姓名和组织（后者为可选项）。
  3. 继续安装。

注意

  • XOX
  • 如果在国家（地区）列表中选择了欧洲国家（地区），或者如果您居住在已引入了欧元的国家（地区），则请确认“区域和语言选项”中的默认货币设置是否满足您的需要。
  • 运行完安装程序后，可在控制面板中修改区域和语言选项。详细信息，请参阅“相关主题”。

相关主题


在安装过程中指定授权模式

Microsoft Windows 图形

在安装过程中指定授权模式

  1. 在安装过程中的“授权模式”对话框中，选择客户端授权模式：
    • 每服务器
    • 每设备或每用户
  2. 继续安装。

注意

  • 如果您不能确定使用何种模式，那么请选择“每服务器”，因为您可以一次性从每服务器更改为每设备或每用户，而且无需任何代价。有关授权模式的详细信息，请参阅“相关主题”。

相关主题


输入计算机名

Microsoft Windows 图形

输入计算机名

  • 请在安装过程的“计算机名和管理员密码”对话框中，按照输入计算机名的说明进行操作。多数语言的推荐长度是 15 个字符以下。对于每个字符要求更多存储空间的语言（如中文、日语和朝鲜语），推荐长度是 7 个字符以下。

注意

  • 建议您在计算机名中使用 Internet 标准字符。标准字符是从 0 到 9 的数字、从 A 到 Z 的大写和小写字母以及连字符 (-)。计算机名不能全部是数字。
  • 如果在网络上使用了 DNS，则可以使用多种字符，包括 Unicode 字符和其他非标准字符（例如 &）。使用非标准字符可能影响非 Microsoft 软件在您的网络上运行时的性能。有关 DNS 的详细信息，请参阅“相关主题”。
  • 计算机名的最大长度是 63 字节。如果该名称长度大于 15 个字节（在多数语言中为 15 个字符，有一些语言为 7 个字符），则运行 Windows NT Server 4.0 和更低版本的计算机将通过名称的前 15 个字节来识别该计算机。另外，也有对长度大于 15 个字节的计算机名进行配置的额外步骤。详细信息，请参阅“相关主题”。
  • 如果计算机是域的一部分，则必须选择不同于域中其他计算机的名称。要避免名称冲突，计算机在域、工作组或网络中应该唯一。如果该计算机是域的一部分，而且它包含多个操作系统，则对于每个安装的操作系统而言，必须使用唯一的计算机名。例如，如果当计算机使用 Windows NT Server 4.0 启动时，计算机名为 FileServerNT，则当它使用 Windows Server 2003 家族产品启动时，计算机必须是其他名称，比如 FileServerNew。此要求同样适用于安装了多个相同操作系统的计算机。

相关主题


设置 Administrator 帐户密码

Microsoft Windows 图形

设置 Administrator 帐户密码

  1. 在安装过程中，请在“计算机名称和管理员密码”对话框的“管理员密码”框中键入最多为 127 个字符的密码。为了获得最可靠的系统安全，请使用至少 7 个字符的密码，并混用大小写字母、数字和其他字符（如 *、? 或 $）。
  2. 在“确认密码”框中，再次键入密码。
  3. 继续安装。

要点

  • 安装完成后，为了获得最佳安全性，请更改 Administrator 帐户（不能删除此帐户）的名称，并总是为该帐户设置一个强密码。详细信息，请参阅强密码。

相关主题


设置日期和时间

Microsoft Windows 图形

设置日期和时间

  1. 在安装过程中，请设置“日期和时间设置”对话框中的日期、时间和时区。
  2. 如果希望系统自动按夏时制调整时间，请选中“根据夏时制自动调节时钟”复选框。
  3. 继续安装。

注意

  • 可在安装完成后更改计算机的日期和时间。详细信息，请参阅“相关主题”。
  • 如果您的计算机是某个域的成员，则计算机时钟很可能会自动被网络的时间服务器设为同步。如果您的计算机不是域的成员，则可以使您的计算机时钟与 Internet 时间服务器同步。详细信息，请参阅“相关主题”。

相关主题


允许安装程序指派或获取 IP 地址

Microsoft Windows 图形

允许安装程序指派或获取 IP 地址

  • 在安装程序的“网络设置”对话框中，单击“典型设置”。

注意

  • 单击“网络设置”对话框的“典型设置”时，安装程序将查看网络上是否存在 DHCP 服务器。如果网络上存在 DHCP 服务器，则 DHCP 将提供 IP 地址。如果网络上没有 DHCP 服务器，则安装程序将使用称为自动专用 IP 寻址 (APIPA) 的受限 IP 寻址选项。对于使用 APIPA 的服务器，要在安装程序完成后进行网络配置，因为使用 APIPA 的服务器只能与同一网段内使用 APIPA 的其他计算机进行通讯。
  • 有关在安装完成后配置自动 IP 寻址的信息，请参阅“相关主题”。

相关主题


指定 DNS 和 WINS 所需的静态 IP 地址和设置

Microsoft Windows 图形

指定 DNS 和 WINS 所需的静态 IP 地址和设置

  1. 在安装过程中，请单击“网络设置”对话框中的“自定义设置”，然后单击“下一步”。
  2. 单击“网络组件”对话框中的“Internet 协议 (TCP/IP)”。
  3. 单击“属性”。
  4. 单击“Internet 协议 (TCP/IP) 属性”对话框中的“使用下面的 IP 地址”。
  5. 在“IP 地址”、“子网掩码”和“默认网关”中，键入适当的地址。
  6. 在“使用下面的 DNS 服务器地址”中，键入首选 DNS 服务器的地址和备用 DNS 服务器的地址（后者为可选）。

    如果本地服务器为首选或备用 DNS 服务器，则键入与上一步中指派的地址相同的 IP 地址。

  7. 如果您要使用 WINS 服务器，请单击“高级”，然后单击“高级 TCP/IP 设置”对话框中的“WINS”选项卡，添加一个或多个 WINS 服务器的 IP 地址。
  8. 在各个对话框中单击“确定”继续安装。

注意

  • 有关在安装后配置网络设置（包括静态 IP 地址）的信息，请参阅“相关主题”。

相关主题


指定工作组或域名

Microsoft Windows 图形

指定工作组或域名

  1. 在安装过程中，请在“工作组或计算机域”对话框中选择服务器是将在工作组中还是将在域中。
  2. 指定工作组或域名。
  3. 继续安装。

注意

  • 要避免名称冲突，计算机在域、工作组或网络中应该唯一。如果本计算机是域的组成部分，而且它包含一个以上的操作系统，则对于安装的各个操作系统，都必须使用唯一的计算机名。例如，如果当计算机使用 Windows NT Server 4.0 启动时计算机名为 FileServerNT，则当它使用 Windows Server 2003, Standard Edition 启动时计算机必须是其他名称，如 FileServerNew。此要求同样适用于安装了多个相同操作系统的计算机。
  • 有关加入工作组或域要求的详细信息，请参阅“相关主题”。

相关主题


概念

本节提供了计划安装 Windows Server 2003, Enterprise Edition 的背景信息。 有关适用于升级的主题以及适用于进行全新安装的主题信息，请参阅以下内容：

  • 清单：执行升级
  • 清单：执行全新安装

下列主题提供了在安装过程中进行选择的背景信息。

  • 要阅读的重要文件
  • 选择授权模式
  • 使用动态更新获取更新的驱动程序和其他安装文件
  • 计划无人参与的安装
  • 系统需求和硬件兼容性
  • 升级或安装
  • 决定计算机是否包含多个操作系统
  • 为安装分区选择文件系统
  • 为新安装规划磁盘分区或卷
  • 网络：TCP/IP、IP 地址以及名称解析
  • 在工作组和域之间进行选择
  • 在运行安装程序之前准备好系统
  • 资源


要阅读的重要文件

在规划一次全新安装或升级的过程中时，请熟悉位于 Windows Server 2003, Enterprise Edition CD 上 \Docs 文件夹下的 Relnotes.htm 文件。 该文件包含有关硬件、网络、应用程序和打印的重要使用信息。此外，还应熟悉有关 Windows Server 2003 家族产品的硬件兼容性信息。详细信息，请参阅硬件兼容性。

有关 Windows Server 2003 家族产品的兼容应用程序的最新信息，请参阅 Microsoft 网站 (http://www.microsoft.com) 上的软件兼容性部分。

“入门”主题中所包含的大多数信息还以 TXT 文件的形式（文件扩展名为“TXT”）出现在 Windows Server 2003, Enterprise Edition CD 上的 \Docs 文件夹中。


选择授权模式

Windows Server 2003 家族产品支持两种授权模式：

  • 每设备或每用户
  • 每服务器

下图说明了这两种模式：

每服务器许可证与每设备或每用户许可证

如果您选择“每设备或每用户”模式，那么访问运行 Windows Server 2003 家族产品的服务器的每台设备或每个用户都必须具备单独的“客户端访问许可证 (CAL)”。通过一个 CAL，特定设备或用户可以连接到运行 Windows Server 2003 家族产品的任意数量的服务器。拥有多台运行 Windows Server 2003 家族产品的服务器的公司大多采用这种授权方法。

相反，每服务器许可证是指每个与此服务器的并发连接都需要一个单独的 CAL。换句话说，此服务器在任何时间都可以支持固定数量的连接。例如，如果您选择具有五个许可证的“每服务器”客户端授权模式，那么该服务器可以一次具有五个并发连接（如果每一个客户端需要一个连接，那么一次允许存在五个客户端）。使用这些连接的客户端不需要任何其他许可证。

每服务器授权模式常常是只有一台服务器的小公司的首选。在客户端计算机可能没有被授权为 Windows Server 2003 家族产品的网络客户端的情况下，这种授权模式对于 Internet 或远程访问服务器也很有用。可以指定并发服务器连接的最大数量并拒绝任何额外的登录请求。

如果您不能确定使用何种模式，那么请选择“每服务器”，因为您可以从“每服务器”模式更改为“每设备”或“每用户”模式，而无需任何代价。有关授权和授权模式的详细信息，请参阅授权概述和有关授权的清单。

注意

  • 如果使用终端服务器，则必须采取额外的步骤设置和激活终端服务器授权。有关详细信息，请参阅终端服务器授权。


使用动态更新获取更新的驱动程序和其他安装文件

如果在运行安装程序的计算机上具有可用的 Internet 连接，则可在安装过程中选择动态更新并获取最新的安装文件，包括驱动程序和其他文件。无论何时对任何至关重要的安装文件进行重要更新，均可通过 Windows Update 网站内置的“动态更新”功能获取该更新。某些更新文件将进行替换（如更新的驱动程序或更新的安装程序文件），而某些将进行添加（如创建安装 CD 时不可用的驱动程序）。建议运行安装程序时使用动态更新。

动态更新已经过专门设计，因此它很可靠而且易于使用：

  • Windows Update 网站的“动态更新”一节的文件已经经过仔细测试和选择。只有那些可确保安装程序完好运行的重要文件才能通过动态更新获得。只进行少量更新而且对安装影响不大的文件不属于动态更新。
  • 因为动态更新只下载计算机所需的文件，所以动态更新软件会简单地检查一下您的计算机硬件。它不会收集任何个人信息，也不保存任何信息。唯一的目的就是为您的硬件配置选择适当的驱动程序。这将使下载时间尽可能缩短，并确保只有必需的驱动程序才下载到硬盘上。
  • 从产品光盘运行预安装兼容性检查或运行安装程序本身时，可以使用“动态更新”。不管使用哪种方法，您都会获得运行安装程序所需的最新文件。有关运行兼容性检查的信息，请参阅硬件兼容性。
  • 可在无人参与安装中使用动态更新。相关的准备工作需要有若干步骤。有关无人参与安装的简述，请参阅计划无人参与的安装。有关如何将动态更新与无人参与安装（也称为自动安装）一起使用的详细信息，请参阅位于 Microsoft Windows 网站 (http://www.microsoft.com/) 的“Automating and Customizing Installations”（自动与自定义安装）。

Windows Update 网站提供了在完成安装程序后可使用的各种更新。详细信息，请参阅位于 Microsoft 网站的 Windows Update。有关使用 Windows Update 的不同方式的描述，请参阅 Windows Update。


计划无人参与的安装

本主题提供有关无人参与安装的常规信息。有关运行无人参与的安装（也称为自动安装）的详细说明，请参阅位于 Microsoft Windows 资源工具包网站的“Automating and Customizing Installation”（自动与自定义安装）。(http://www.microsoft.com/) 还可参阅位于 Microsoft Windows 资源工具包网站的“Windows XP Professional Resource Kit”（Windows XP Professional 资源工具包）。(http://www.microsoft.com/) 有关 Windows 部署和资源工具包的信息，请参阅 Windows 部署和资源工具包。

要简化在多台计算机上安装 Windows Server 2003 家族产品的过程，可运行无人参与安装。为此，需要创建和使用“应答文件”，此文件是自动回答安装问题的自定义脚本。然后，通过无人参与安装的适当选项运行 Winnt32.exe 或 Winnt.exe。请根据启动无人参与安装时正在运行的操作系统来选择命令：

  • 要在运行 MS-DOS 或 Windows 3.x 的计算机上启动无人参与的安装程序，请使用 Winnt.exe（带有适当的选项）。
  • 要在运行 Windows 95、Windows 98、Windows Millennium Edition、Windows NT、Windows 2000、Windows XP 或 Windows Server 2003 家族产品的计算机上启动无人参与的安装程序，请使用 Winnt32.exe（带有适当的选项）。对于 Windows NT 4.0，请在启动无人参与安装前，首先应用 Service Pack 5 或更高版本。

要了解无人参与安装的详细信息，请参阅以下信息来源：

  • 有关运行无人参与安装（也称为自动安装）的详细说明：请参阅本主题第一段中列出的 Windows 部署和资源工具包。
  • 要查看 Winnt.exe 可用的命令选项，请执行以下操作：在运行 Windows 3.x 或 MS-DOS 的计算机上，将 Windows Server 2003 家族产品的安装 CD 插入 CD-ROM 驱动器，然后打开命令提示符窗口。然后，切换到 CD-ROM 驱动器，转到 I386 目录后键入：
    winnt /?
  • 要使用基于 x86 的计算机查看 Winnt32.exe 可用的命令选项，请执行以下操作：在运行 Windows 95、Windows 98、Windows Millennium Edition、Windows NT、Windows 2000、Windows XP 或 Windows Server 2003 家族产品的计算机上，将 Windows Server 2003 家族产品的安装 CD 插入 CD-ROM 驱动器，然后打开命令提示符窗口。然后，切换到 CD-ROM 驱动器，转到 I386 目录后键入：
    winnt32 /?
  • 要使用基于 Itanium 体系结构的计算机查看 Winnt32.exe 可用的命令选项，请执行以下操作：在基于 Itanium 体系结构并运行 Windows XP 64-Bit Edition、64 位版本 Windows Server 2003, Enterprise Edition 或 64 位版本 Windows Server 2003, Datacenter Edition 的计算机上，将 64 位版本产品的安装 CD 插入 CD-ROM 驱动器，然后打开命令提示符窗口（依次单击“开始”、“运行”，然后键入 cmd）。然后，切换到 CD-ROM 驱动器，转到 IA64 目录后键入：
    winnt32 /?

有关使用 Winnt.exe 或 Winnt32.exe 进行交互安装（非无人参与的安装）的信息，请参阅如何。


系统需求和硬件兼容性

  • 系统需求
  • 硬件概述
  • 硬件兼容性
  • 采用不使用即插即用技术的设备清单
  • 大容量存储驱动程序和安装过程
  • 了解基于 x86 的计算机的 ACPI BIOS


系统需求

为确保良好的性能，安装或升级到 Windows Server 2003, Enterprise Edition 的计算机应符合下列要求：

  • 对于基于 x86 的计算机：
    • 使用一个或多个速度不低于 550 MHz 的处理器。最低受支持的速度为 133 MHz。每台计算机最多支持 8 个处理器。建议使用 Intel Pentium/Celeron 家族、AMD K6/Athlon/Duron 家族或兼容处理器。
    • 建议使用不低于 256 MB 的 RAM支持的最小内存容量是 128 MB，最大为 32 GB。对于 RAM 大于 4 GB 的计算机，务必通过单击Support resources中的适当链接验证硬件兼容性。
  • 对于基于 Itanium 体系结构的计算机：
    • 最低速度为 733 MHz 的一个或多个处理器。每台计算机最多支持 8 个处理器。
    • RAM 最小为 1 GB，最大为 1024 GB（1 TB）。

      对于 RAM 大于 4 GB 的计算机，务必通过单击Support resources中的适当链接验证硬件兼容性。

  • 对于基于 x64 的计算机：
    • 速度不低于 1.4 GHz 的一个或多个处理器。每台计算机最多支持 8 个处理器。
    • RAM 最小为 1 GB，最大为 1024 GB（1 TB）。

      对于 RAM 大于 4 GB 的计算机，务必通过单击Support resources中的适当链接验证硬件兼容性。

  • 硬盘分区或卷具有可适用于安装过程的足够可用空间。为确保日后使用操作系统时的灵活性，建议保留的空间应明显大于运行安装程序所需的最小空间：对于基于 x86 的 Windows Server 2003 计算机，此空间大约为 2 GB 到 3 GB；对于基于　Itanium 和基于 x64 的 Windows Server 2003 计算机，此空间为 4 GB。如果是跨网络运行安装程序而不是从光盘上安装，或者要在基于 x86 或 x64 的 Windows Server 2003 计算机上的 FAT 或 FAT32 分区上安装，则需要更大的空间。（对于基于 x86 和 x64 的 Windows Server 2003 计算机，建议使用 NTFS 文件系统；基于 Itanium 的 Windows Server 2003 计算机只支持 NTFS）。 如果您正在通过网络而不是通过光盘运行安装程序，或者如果您正在 FAT 或 FAT32 分区（NTFS 是推荐使用的文件系统）上进行安装，则需要更大的空间。

    另外，从 Windows NT 4.0 升级域控制器可能比其他升级或安装要求更大的空间，因为当添加 Active Directory 功能时，现有的用户帐户数据库在升级过程中可扩展 10 倍大小。

    注意

    • 安装过程需要如前面的段落中所述的可用磁盘空间。安装完成后，由于分页文件、已安装的任何可选组件和（域控制器上的）用户帐户及其他 Active Directory 信息也需要空间，使得用于操作系统的实际硬盘空间要大于安装程序所要求的可用空间。分页文件通常的大小是 RAM 大小的 1.5 倍。详细信息，请参阅以下内容：
      • 更改虚拟内存设置
      • 指定系统意外停止时将会发生的情况
      • 选择要安装的组件
      • 了解 Active Directory
      • 目录数据存储

      有关计划磁盘分区或卷大小的其他信息，包括为远程安装服务创建单独分区的信息，请参阅计划磁盘分区时的注意事项和远程安装服务系统要求。

  • VGA 或较高分辨率监视器（建议使用超级 VGA 800x600 或更高）、键盘和鼠标或其他指针设备（可选）。

    作为一种备用方案，对于不使用监视器或键盘的操作，可选择一个为 Windows Server 2003 家族产品设计的远程诊断与支持处理器。有关硬件兼容性的详细信息，请单击支持资源中的相应链接。

从 CD-ROM 安装：

  • CD-ROM 驱动器或 DVD 驱动器。

从网络安装：

  • 为 Windows Server 2003 家族产品设计的一个或多个网络适配器及相关电缆。有关硬件兼容性的详细信息，请单击支持资源中的相应链接。
  • 可提供对安装文件的网络访问权限的服务器。

对于其他基于硬件的功能：

  • 具有您所需功能的相应硬件。例如，如果您打算支持网络客户端，则服务器和客户端必须拥有合适的网络适配器及电缆。又如，如果您需要一个服务器群集，整个群集解决方案必须列为与 Windows Server 2003, Enterprise Edition 兼容（详细信息，请参阅规划与准备群集安装中有关群集硬件和驱动程序的信息）。有关硬件的详细信息，请单击支持资源中的相应链接。


硬件兼容性

在服务器上运行安装程序之前要采取的最重要的步骤之一是，确认您的硬件是否与 Windows Server 2003 家族产品兼容。可以通过从安装 CD 运行预安装兼容性检查或通过检查 Microsoft 提供的硬件兼容性信息进行确认。此外，作为确认硬件兼容性工作的一部分，请检查您是否已获得更新的硬件设备驱动程序以及更新的系统 BIOS（或者对于基于 Itanium 体系结构的计算机来说，是正确的固件）。

不管是否进行预安装兼容性检查，安装程序都会在升级或全新安装开始时检查硬件和软件兼容性，并在存在不兼容的情况时显示一份报告。

从安装 CD 运行预安装兼容性检查
可以从安装 CD 进行硬件和软件兼容性检查。兼容性检查不需要实际进行升级或安装。要进行检查，请将安装 CD 放入 CD-ROM 驱动器中，显示出内容时，按照提示检查系统兼容性。在运行检查时，系统还为您提供下载最新安装文件（通过动态更新）的选项。如果已与 Internet 连接，建议您允许下载。

有关下载最新安装文件的详细信息，请参阅使用动态更新获取更新的驱动程序和其他安装文件。

另一个运行兼容性检查的方法是，将安装 CD 放入 CD-ROM 驱动器中，打开命令提示符并键入

d:\i386\winnt32 /checkupgradeonly

其中 d 代表 CD-ROM 驱动器。

检查 Microsoft 提供的硬件和软件兼容性信息
确认硬件和软件是否针对 Windows Server 2003 家族产品设计的另一种方法是，单击支持资源中兼容性信息的相应链接。

请注意，微通道总线是一种不再受支持的硬件类型。

检验驱动程序和系统 BIOS 或固件
请确保您已获得了硬件设备更新的驱动程序，并且已拥有最新的系统 BIOS（对于基于 x86 的计算机）或正确的固件（对于基于 Itanium 体系结构的计算机）。设备制造商可以帮助您获取这些信息。有关用于 BIOS 的高级配置和电源界面 (ACPI) 标准的信息，请参阅了解基于 x86 的计算机的 ACPI BIOS。

最后，如果您的某些设备不支持即插即用，或者您知道您的即插即用设备不完全符合标准，请考虑制作一个您计算机中的硬件设备的清单。详细信息，请参阅采用不使用即插即用技术的设备清单。


采用不使用即插即用技术的设备清单

本节描述当计算机中的设备不使用即插即用技术时应采取的措施。有关硬件兼容性（包括设备兼容性）的重要信息，请参阅：

  • 系统需求
  • 硬件兼容性

有关使用带有制造商提供的驱动程序的大容量存储控制器（如 SCSI、RAID 或纤维管道适配器）的具体信息，请参阅大容量存储驱动程序和安装过程。

Windows Server 2003 家族产品包括“即插即用”技术，这项技术使设备（例如，视频和网络适配器）能够自动被操作系统识别，从而避免了配置冲突，并且无须手动指定每个设备的设置。但是，如果您有不支持即插即用的设备，或者您已经知道您的即插即用设备的执行不完全符合标准，则可能需要采取步骤避免设备配置冲突。本节介绍了可采取的步骤，以便使您在运行安装程序之前了解您的设备配置情况。

要使用设备清单，如果计算机有现存的操作系统，请使用它来获得设备所使用的当前设置，如内存地址和中断请求 (IRQ)。例如，对于 Windows NT 4.0，可使用“控制面板”来查看设置（在“开始”菜单上，指向“设置”，单击“控制面板”，然后双击诸如“网络”和“端口”这样的图标）。还可以选择查看系统 BIOS 信息。为此，请在启动计算机时留意屏幕，然后在系统提示时按适当的键。

在安装或升级的开始，安装程序还将自动使用设备清单。对于不使用即插即用技术的设备或没有完全按照即插即用标准执行的设备，采用自己的清单可帮助预防下列问题：

  • 如果两个或多个适配器共享 IRQ 设置或内存地址，安装程序可能无法解决冲突。为防止这种情况发生，可采用以下两种方法之一。

    可在运行安装程序之前删除其中的一个适配器，之后再重新安装。有关详细信息，请参阅：

    • 硬件概述
    • 安装设备概述
    • 硬件类型概述

    作为备用方案，可在运行安装程序前修改其中一个适配器的 IRQ 设置和内存地址，从而使每个适配器的设置都是唯一的。

  • 如果安装程序尝试检测或枚举适配器时，适配器没有以标准的方式进行响应，则安装程序可能会收到难以辨识或不准确的信息。在这种情况下，可能需要在运行安装程序之前移除这些设备，之后再对其进行重新安装与配置。有关详细信息，请参阅：
    • 硬件概述
    • 安装设备概述
    • 硬件类型概述

如果您有不使用即插即用技术的设备，而且您决定在启动安装程序前使用设备清单，则可参阅下表，其中列出了各种要收集的信息。

适配器 | 要收集的信息
视频 | 适配器或芯片集类型和视频适配器数量
网络 | IRQ、I/O 地址、DMA（如果使用）连接器类型（如 BNC 或双绞线）和总线类型
SCSI 控制器 | 适配器模型或芯片集、IRQ 和总线类型
鼠标 | 鼠标类型和端口（COM1、COM2 或 PS/2）或 USB
I/O 端口 | 每个 I/O 端口的 IRQ、I/O 地址和 DMA（如果使用）
声音适配器 | IRQ、I/O 地址和 DMA
通用串行总线 (USB) | 附加哪些设备和集线器
PC 卡 | 插入哪些适配器以及插入哪些插槽中
即插即用 | 在 BIOS 中启用还是禁用
BIOS 设置 | BIOS 修订和日期
外置调制解调器 | COM 端口连接（COM1、COM2等）
内置调制解调器 | COM 端口连接；对于非标准配置，IRQ 和 I/O 地址
高级配置和电源界面 (ACPI)；电源选项 | 启用或禁用；当前设置
PCI | 插入哪些 PCI 适配器以及插入哪些插槽中


大容量存储驱动程序和安装过程

如果您有用于硬盘的大容量存储控制器（如 SCSI、RAID 或纤维管道适配器），请单击支持资源中适当的链接以确认该控制器是否适用于 Windows Server 2003 家族产品。

如果控制器兼容，但您知道制造商已经提供了一个用于 Windows Server 2003 家族产品的单独驱动程序文件，则应在开始安装之前获取该文件（在软盘上）。在安装程序开始过程中，屏幕底部会有一行提示您按 F6 的信息。按键后将出现进一步的提示，指导您为安装程序提供驱动程序文件，以便安装程序可以访问大容量存储控制器。

如果不能确定是否必须从大容量存储控制器的制造商那里获得单独的驱动程序文件，则可以尝试运行安装程序。如果安装 CD 上的驱动程序文件不支持该控制器，并因此需要硬件制造商提供的驱动程序文件，安装程序会停止并显示一条“找不到磁盘设备”的消息，或显示一个不完整的控制器列表。获得必要的驱动程序文件后，重新启动安装程序，并在出现提示时按 F6。


了解基于 x86 的计算机的 ACPI BIOS

对基于 x86 的计算机来说，基本输入/输出系统 (BIOS) 是一组软件，操作系统（或安装程序）可以通过它与计算机的硬件设备进行通讯。高级配置和电源界面 (ACPI) 是 BIOS 的当前工作标准。Windows Server 2003 家族产品不仅支持符合 ACPI 的 BIOS 版本，还支持一些基于旧的“高级电源管理 (APM)”和“即插即用”设计的 BIOS 版本。

某些基于 ACPI 的 BIOS 版本与此标准不符。ACPI BIOS 的版本越新，越可能符合此标准。与 ACPI 标准不符的基于 ACPI 的 BIOS 可能不支持操作系统（或安装程序）与硬件之间的有效通讯。如果有效通讯不受支持，则安装将停止并显示说明，让您与硬件制造商联系并采取其他措施来解决问题。如果出现这种情况，请按照出现的提示进行操作。

要了解有关 BIOS 的 ACPI 符合性的更多信息：

  • 有关 BIOS 版本的信息，请在运行安装程序前，重新启动计算机并留意屏幕上的文字。请特别注意包含“BIOS”或“ACPI BIOS”的文本块。
  • 有关用于硬件的 BIOS 版本的信息，请查看您的硬件文档并与硬件制造商联系。
  • 如果您认为您的 BIOS 可能是非兼容的 ACPI BIOS，请参阅印刷手册《入门》的附录“系统恢复与疑难解答”内关于 ACPI BIOS 的部分。


升级或安装

本节提供了可帮助您决定是升级还是安装的信息。它提供了升级和安装的详细信息，如可升级的操作系统的列表。另外，它还提供了升级较小的域时要采取的措施的信息。

  • 升级与全新安装的对比
  • 在包含 Windows 2000 域控制器的域中进行升级
  • 在 Windows NT 4.0 域中升级


升级与全新安装的对比

查阅系统需求和硬件兼容性和要阅读的重要文件后，在运行安装程序前，还需要确定是进行升级还是执行全新安装。 “升级”是指用 Windows Server 2003 家族产品替换 Windows NT 4.0（带 Service Pack 5 或更高版本）或 Windows 2000。 与升级相比，“安装”意味着完全删除旧的操作系统，或者将 Windows Server 2003 家族产品安装在以前没有操作系统的磁盘或磁盘分区上。

就执行升级还是全新安装而言，如果您已经做出决定，则请参阅清单：执行升级或清单：执行全新安装。

下表描述了在升级和全新安装之间作决定时要考虑的事项。

升级要考虑的事项

  • 升级时，配置较简单，现有用户、设置、组、权利和权限都将保留。
  • 升级时，无需重新安装文件和应用程序。不过，如果对硬盘做了重大更改，则建议在开始升级前备份磁盘。
  • 在计划执行升级前，请参阅本主题后面的“可升级的操作系统”部分。
  • 如果正在包含运行 Windows 2000 域控制器的域中进行升级，请务必阅读在包含 Windows 2000 域控制器的域中进行升级。
  • 如果正在所有域控制器都运行 Windows NT 4.0 的域中进行升级，请务必阅读在 Windows NT 4.0 域中升级。
  • 如果您希望升级然后使用和以前相同的应用程序，请务必查阅 Relnotes.htm（位于安装 CD 上的 \Docs 文件夹中）中的应用程序信息。另外，有关 Windows Server 2003 家族产品的兼容应用程序的最新信息，请参阅 Microsoft 网站 (http://www.microsoft.com) 上的软件兼容性部分。

全新安装要考虑的事项

  • 如果重新格式化硬盘后再执行全新安装，则磁盘的效率有可能提高（与未重新格式化时相比）。重新格式化还为您提供了修改磁盘分区大小或数量的机会，以使它们能更好地满足您的要求。
  • 如果您希望进行谨慎的配置管理，例如，对于那些高可用性很重要的服务器，您可能希望在该服务器上执行全新安装而不是升级。对于已多次升级操作系统的服务器，尤其应该这样做。
  • 可以安装 Windows Server 2003, Enterprise Edition 并允许计算机在有的时候运行另一操作系统。但这样设置计算机，会由于文件系统的问题带来很大的复杂性。详细信息，请参阅决定计算机是否包含多个操作系统。

注意

  • 不要将 Windows Server 2003, Enterprise Edition 安装在压缩驱动器上，除非该压缩驱动器是使用 NTFS 文件系统压缩工具进行压缩的。在 DriveSpace 或 DoubleSpace 卷上运行安装程序前，请先对该卷进行解压缩。
  • 如果已用 Windows NT 4.0 创建了卷集、镜像集、带区集或具有奇偶校验的带区集，并希望在该计算机上运行 Windows Server 2003, Enterprise Edition 的安装程序，则必须首先准备磁盘集。详细信息，请参阅使用卷集、镜像集、带区集或具有奇偶校验的带区集。

可升级的操作系统

如果选择升级，安装程序会自动将 Windows Server 2003, Enterprise Edition 安装到与当前安装的操作系统相同的文件夹中。您可以从以下版本的 Windows 升级到 Windows Server 2003, Enterprise Edition：

  • Windows NT Server 4.0（带有 Service Pack 5 或更高版本）
  • Windows NT Server 4.0 Terminal Server Edition，带 Service Pack 5 或更高版本
  • Windows NT Server 4.0 Enterprise Edition（带 Service Pack 5 或更高版本）
  • Windows 2000 Server
  • Windows 2000 Advanced Server
  • Windows Server 2003, Standard Edition

注意

  • 如果您的 Windows NT 版本低于 Windows NT 4.0，则无法直接升级到 Windows Server 2003 家族产品。必须首先将其升级到 Windows NT 4.0 并应用 Service Pack 5 后才能升级到 Windows Server 2003 家族产品。
  • 如果您有运行 Windows NT 3.51 的服务器或客户端计算机，建议您将所有这些计算机安装或升级到较新的操作系统，或干脆将其淘汰。如果您有多个域，则必须升级运行 Windows NT 3.51 的域控制器，以进行可靠的登录验证。在任何情况下，将运行 Windows NT 3.51 的计算机淘汰或进行升级都可增强安全性，并减少计算机之间版本差异的数目，从而简化管理与疑难解答。


在包含 Windows 2000 域控制器的域中进行升级

如果在包含 Windows 2000 域控制器的域中升级服务器，请注意一些事项。下面几点最为重要：

  • 计划特定服务器升级的第一步是检查硬件与 Windows Server 2003 家族产品间的兼容性。详细信息，请参阅硬件兼容性。
  • 在其中有一个或多个域控制器运行 Windows 2000 的域中升级第一个域控制器之前，或添加运行 Windows Server 2003 家族产品的域控制器之前，必须使用 Windows Server 2003, Enterprise Edition 安装 CD 上的简单工具准备域（以及它所在的林）。 有关信息，请参阅为在包含 Windows 2000 域控制器的域中进行升级做准备。

    准备域（和此域所在的林）之前，建议将 Service Pack 2 或更高版本应用到运行 Windows 2000 的所有域控制器中。

  • 如果在服务器上安装了 Internet 信息服务 (IIS) 5.0，则升级操作系统时，IIS 将升级到 IIS 6.0。但是，由于应用程序兼容性，升级后 IIS 将以 IIS 5.0 隔离模式运行。有关 IIS 隔离模式的详细信息，请参阅“IIS 6.0 帮助”。
  • 默认情况下升级时会启用 Internet Explorer 增强的安全配置。此配置中的安全设置可限制计算机对恶意网站公开其内容，从而增强了安全性。因此，当您浏览 Internet 以及 Intranet 网站时，可能会发现该增强级别的安全保护使 Internet Explorer 无法正确显示某些网站。另外在您访问网络资源 [例如，通用命名约定 (UNC) 共享文件夹中的文件] 时，系统可能会提示您输入凭据。您可以轻松更改增强的安全设置。详细信息，请参阅 Internet Explorer 增强的安全配置概述。
  • 升级完域控制器并减少其上运行的不同操作系统版本数后，可适当调整域和林功能级别。有关功能级别的详细信息，请参阅域和林功能和提升域和林的功能级别。有关 Active Directory 的一般信息，请参阅 Active Directory。

如果有运行 Windows NT 的服务器，还要检查以下几点：

  • 运行安装前，建议您检查服务器上现有的文件系统和分区。在域控制器上，必须至少有一个 NTFS 分区。建议您在域中所有服务器的所有分区上均使用 NTFS，因为 FAT 或 FAT32 分区缺少许多安全功能。例如，在 FAT 或 FAT32 分区上，只能通过在共享文件夹（不能是单独的文件）上设置权限来对其进行保护，且对于本地访问该分区并没有软件保护措施。详细信息，请参阅重新格式化或转换分区以使用 NTFS 和 Convert。
  • 如果某些域控制器运行 Windows 2000，而另一些运行 Windows NT，则建议尽早升级 Windows NT 域控制器，以减少计算机之间的版本差异的数目，从而简化管理和疑难解答并提高安全性。
  • 从 Windows NT 4.0 开始升级前，必须应用 Service Pack 5 或更高版本。
  • 如果您有运行 Windows NT 3.51 的服务器或客户端计算机，建议您将所有这些计算机安装或升级到较新的操作系统，或干脆将其淘汰。如果您有多个域，则必须升级运行 Windows NT 3.51 的域控制器，以进行可靠的登录验证。在任何情况下，将运行 Windows NT 3.51 的计算机淘汰或进行升级都可增强安全性，并减少计算机之间版本差异的数目，从而简化管理与疑难解答。

域和林准备就续后，域控制器的升级分为两个阶段。首先运行安装程序以升级操作系统，然后当安装完成时，运行 Active Directory 安装向导（首次登录时出现在屏幕上）。


在 Windows NT 4.0 域中升级

本节提供有关在 Windows NT 4.0 域（即其中所有的域控制器都运行 Windows NT 4.0 的域）中升级服务器的信息。所提供的指导针对的是拥有 1 到 5 台服务器和 100 台（或更少）客户端的网络（此网络大小是在这些“入门”主题中讨论的网络大小）。有关在包含 1 个或多个运行 Windows 2000 域控制器的域中升级服务器的信息，请参阅在包含 Windows 2000 域控制器的域中进行升级。

下表描述了关于在 Windows NT 4.0 域中升级服务器的主题：

  • 有关初始准备工作的信息（例如，检查硬件兼容性并查看服务器硬盘上分区的大小），请参阅在 Windows NT 域中升级服务器的基本准备工作。
  • 有关有助于您根据特定情况进行升级的规划步骤的详细信息，请参阅下列主题：
    • 计划服务器角色和服务器从 Windows NT 升级的顺序
    • 计划 Windows NT 4.0 域中服务器升级的顺序
    • 为运行 Windows NT 4.0 的域控制器的升级规划 DNS
  • 有关在即将开始升级前进行的最后准备工作的详细信息，以及在升级域控制器的过程中进行选择的指导，请参阅执行最后的准备并对运行 Windows NT 4.0 的域控制器进行升级。

要点

  • 如果您有运行 Windows NT 3.51 的服务器或客户端计算机，建议您将所有这些计算机安装或升级到较新的操作系统，或干脆将其淘汰。如果您有多个域，则必须升级运行 Windows NT 3.51 的域控制器，以进行可靠的登录验证。在任何情况下，将运行 Windows NT 3.51 的计算机淘汰或进行升级都可增强安全性，并减少计算机之间版本差异的数量，从而简化管理与疑难解答。

注意

  • 默认情况下升级时会启用 Internet Explorer 增强的安全配置。此配置中的安全设置可限制计算机对恶意网站公开其内容，从而增强了安全性。因此，当您浏览 Internet 以及 Intranet 网站时，可能会发现该增强级别的安全保护使 Internet Explorer 无法正确显示某些网站。另外在您访问网络资源 [例如，通用命名约定 (UNC) 共享文件夹中的文件] 时，系统可能会提示您输入凭据。您可以轻松更改增强的安全设置。详细信息，请参阅 Internet Explorer 增强的安全配置概述。

有关其他信息，请参阅：

  • 有关与从 Windows NT 升级相关的 Active Directory 的详细信息，请参阅从 Windows NT 域升级和域和林功能。
  • 有关在多个域或具有 5 个以上服务器的域中进行部署和升级的信息，请参阅位于 Microsoft Windows 网站的“Windows Server 2003 Deployment Kit”（Windows Server 2003 部署工具包）。(http://www.microsoft.com/)


在 Windows NT 域中升级服务器的基本准备工作

在域中升级服务器时，如果该域中的所有域控制器均运行 Windows NT 4.0，那么必须做一些基本的准备工作。有关这些准备工作如何适应升级的整体进程的信息，请参阅在 Windows NT 4.0 域中升级。

要点

  • 如果有运行 Windows NT 3.51 的服务器或客户端计算机，建议在所有这些计算机上安装或升级到新版的操作系统，或者干脆将其淘汰。如果有多个域，则必须升级运行 Windows NT 3.51 的域控制器，以进行可靠的登录验证。在任何情况下，将运行 Windows NT 3.51 的计算机淘汰或进行升级都可增强安全性，并可减少计算机之间版本差异的数目，从而简化管理与疑难解答。
兼容性检查
检查系统的应用程序和硬件是否与 Windows Server 2003 家族产品兼容，如果有必要，请对其进行更新或替换。关于如何进行此项操作的重要详细信息，请参阅硬件兼容性和要阅读的重要文件。
复查分区大小，特别是域控制器上的分区大小
查看服务器上的分区，以确保有足够的可用空间来运行 Windows Server 2003 家族的操作系统。域控制器上有足够的可用空间尤其重要，因为添加 Active Directory 功能后现有的用户帐户数据库可能会扩大十倍。关于操作系统的磁盘需求信息，请参阅系统需求。
复查服务器分区上的文件系统
在域控制器上，必须至少有一个 NTFS 分区。建议在域中所有服务器的所有分区上均使用 NTFS，因为 FAT 或 FAT32 分区缺少许多安全功能。例如，在 FAT 或 FAT32 分区上，只能通过在共享文件夹（不能是单独的文件）上设置权限来对其进行保护，且对于本地访问该分区并没有软件保护措施。有关详细信息，请参阅重新格式化或转换分区以使用 NTFS 和 Convert。
Service Pack
获取 Service Pack 5 或更高版本，因为它对升级来讲是必需的。
镜像集或其他磁盘集
如果已用 Windows NT 4.0 创建了卷集、镜像集、带区集或带奇偶校验的带区集，并想在该计算机上运行 XOX 的安装程序， Windows Server 2003, Enterprise Edition 就必须预先准备磁盘集。有关详细信息，请参阅使用卷集、镜像集、带区集或带奇偶校验的带区集。


计划服务器角色和服务器从 Windows NT 升级的顺序

本部分提供了在其所有域控制器都运行 Windows NT 4.0 的域中对服务器角色和服务器升级的顺序进行计划时要使用的基本准则列表。有关此计划如何适应升级的整体进程的信息，请参阅在 Windows NT 4.0 域中升级。

当计划服务器角色和服务器从 Windows NT 升级的顺序时，请使用下列准则：

  • 您需要熟悉 Windows NT 的服务器和运行 Windows Server 2003 的服务器在服务器角色命名方面的细微差异：
    • 在 Windows NT 中，有两种域控制器，即主域控制器和备份域控制器，前者在每个域中只有一个而且包含读写数据库，后者不限数量但只包含只读数据库。
    • 对于运行 Windows Server 2003 的域控制器而言，只有一种域控制器，没有“主”或“备份”的区别。所有域控制器都包含特定域中的用户帐户和其他 Active Directory 数据的匹配副本，并提供对该数据的读写访问。
    • 除了域控制器外，这两种操作系统的角色可能还包括成员服务器和独立服务器，前者属于域但不包含 Active Directory 数据的副本，后者属于工作组但不属于域。
  • 注意，与 Windows NT 相比，可在不用重新运行安装程序的情况下更改服务器的角色。不过，作为一般操作，最好提前计划好角色，并且只有在必要时才对其进行更改。
  • 虽然对于 Windows NT 而言，一个域必须至少有一个域控制器，但仍建议一个域有多个域控制器，以便在处理登录请求和目录更新时能够更好地适应。
  • 如果您最需要的功能不是 Active Directory 功能，则可首先将重点放在对成员服务器的升级上。有关为何要在过程的前期阶段升级特定成员服务器的信息，请参阅计划 Windows NT 4.0 域中服务器升级的顺序。
  • 如果您最需要的功能是 Active Directory 功能，请将重点首先放在对域服务器的升级上，并执行这一部分升级所必需的事先计划。

    要点

    • 开始升级运行 Windows NT 4.0 的域控制器时，必须首先升级主域控制器。

    有关 Active Directory 附带功能的信息，请参阅计划 Windows NT 4.0 域中服务器升级的顺序。有关升级到 Active Directory 前的必需计划的信息，请参阅为运行 Windows NT 4.0 的域控制器的升级规划 DNS。

  • 开始升级域控制器时，如果有作为成员服务器的远程访问服务器，建议在升级最后一个域控制器之前升级这一远程访问服务器。这种服务器依赖于域控制器提供的用户信息，因此在升级域控制器时不应该将这种服务器的升级放到最后。作为备用方案，您可以降低 Active Directory 中的安全权限，以便运行 Windows NT 的远程访问服务器可以从运行 Windows Server 2003 家族产品的域控制器中读取用户属性。有关详细信息，请参阅位于 Microsoft Windows 网站的“Windows Server 2003 Deployment Kit”（Windows Server 2003 部署工具包）。(http://www.microsoft.com/)


计划 Windows NT 4.0 域中服务器升级的顺序

本主题列出了升级任意一台运行 Windows NT 4.0 的服务器后所获得的功能，并列出了从 Windows NT 4.0 升级第一个域控制器后所获得的功能。根据您最感兴趣的功能来计划服务器升级的顺序。

下列主题提供了其他信息：

  • 有关 Windows Server 2003 家族产品其他功能的信息，请参阅新功能。
  • 有关在其所有域控制器都运行 Windows NT 4.0 的域中升级服务器的详细信息，请参阅在 Windows NT 4.0 域中升级。
  • 有关 Active Directory 的信息，请参阅 Active Directory。

升级 Windows NT 域中任意一台服务器后所获得的功能

如果您对以下列表中的功能感兴趣，您可能要重点关注对 Windows NT 4.0 域中成员服务器的升级。有关升级域控制器的原因信息，请参阅本主题后面部分的“对 Windows NT 域中的第一个域控制器进行升级所获得的功能”。

  • 管理工具：
    Microsoft 管理控制台
    即插即用
    设备管理器
    添加硬件向导（在“控制面板”中）
    支持通用串行总线
    增强的备份实用工具
  • 文件系统支持：Windows Server 2003 家族中的 NTFS 版本包括对磁盘空间配额的支持、对目录结构进行碎片整理的能力以及压缩的网络 I/O。
  • 应用程序服务：Win32 驱动程序模型、DirectX 7.0 和 Windows Script Host。
  • 打印机协议支持：设备和协议支持允许从 2,500 以上不同的打印机中进行选择。同时包括其他的打印增强功能；例如，Internet 打印协议支持，这一支持允许用户通过 Intranet 或 Internet 直接打印到某个 URL。
  • 可伸缩性和可用性：改进的对称多处理器支持（与 Windows NT 相比）。
  • 安全性：加密文件系统。

对 Windows NT 域中的第一个域控制器进行升级所获得的功能

如果对以下 Active Directory 功能的列表感兴趣，请重点关注对主域控制器的升级（而不是关注对成员服务器的升级）。（升级的第一个域控制器必须是主域控制器。建议也升级备份域控制器。）有关在开始对运行 Windows NT 的域控制器进行升级之前所必需的 DNS 计划的信息，请参阅为运行 Windows NT 4.0 的域控制器的升级规划 DNS。

注意

  • 对域控制器进行升级后，它即具有了 Windows Server 2003 家族操作系统的所有功能，这意味着它具有下面列表中的所有功能，还具有本主题前面的“升级 Windows NT 域中任意一台服务器后所获得的功能”中介绍的功能。

升级域控制器以运行 Windows Server 2003 家族操作系统（而不是 Windows NT 操作系统）时，域中可获得许多 Active Directory 功能：

  • 简化管理网络资源信息和用户信息。
  • 组策略，可使用组策略来设置 Active Directory 中跨越指定的站点、域或组织单位应用的策略。
  • 安全和身份验证功能，包括对 Kerberos V5、安全套接字层 (SSL) 3.0 和使用 X.509 v3 证书的传输层安全性 (TLS) 的支持。
  • 目录合并，通过目录合并可以组织和简化对用户、计算机、应用程序和设备的管理，并使用户可更容易地查找到需要的信息。可以通过基于 LDAP 的接口来利用同步支持，并处理您的应用程序专用的目录合并要求。
  • 启用目录的应用程序和基础结构，使得配置和管理应用程序和其他启用目录的网络组件更加容易。
  • 不复杂的可伸缩性，Active Directory 的一个功能，它在每个域可容纳成千上万个对象并使用索引技术和高级复制技术来加速性能。
  • Internet 标准的使用，包括通过 LDAP 进行的访问和基于域名系统 (DNS) 的名称空间。
  • Active Directory 服务接口 (ADSI)，是一个功能强大的开发环境。
  • 其他功能，请参阅 Active Directory 中的说明。


为运行 Windows NT 4.0 的域控制器的升级规划 DNS

域名系统 (DNS) 是用于定位 Internet 上和专用 TCP/IP 网络上计算机的分层命名系统。本主题对建议在升级到 Active Directory 之前（即在将 Windows NT 域中的主域控制器升级成运行 Windows Server 2003 的域控制器之前）进行的 DNS 规划工作进行了描述。

DNS 是 Active Directory 使用的名称解析服务。Windows Server 2003 家族产品可同时支持 Windows Internet 名称服务 (WINS)（在 Windows NT 网络中常用）和 DNS。必须将 DNS 部署成支持 Active Directory；有关信息，请参阅 Active Directory 集成。可以选择将 WINS 迁移到 DNS 或者将新的 DNS 基础结构配置成支持当前的 WINS 基础结构。

对于具有 1 到 5 个服务器和 100 个以下客户端（这是在这些“入门”主题中讨论的网络大小）的网络升级，因为不会存在父域或子域，所以仅需要进行简单的 DNS 规划。有关升级多于五台服务器的网络的信息，请参阅位于 Microsoft Windows 网站的“Windows Server 2003 Deployment Kit”（Windows Server 2003 部署工具包）。(http://www.microsoft.com/)

DNS 名称是由用句点分隔的名称标签组成的。Windows Server 2003 家族域的简单 DNS 域名可以采用 domainname.ext 形式，其中，ext 是已建立的“顶级域”类型，例如，com 或 org。对于该形式的域名，域中计算机名的形式将是：

computername.domainname.ext

当您升级 Windows NT 4.0 域中的主域控制器时（必须先升级主域控制器，然后再升级备份域控制器），系统将提供多个处理 DNS 的不同选项。如果没有可以随 Active Directory 协同工作的 DNS 服务器，则在默认情况下将会为您提供用于在正在升级的域控制器（即前面提到的主域控制器）上安装 DNS 的选项。在具有 1 到 5 个服务器的网络中，最简单的方法就是接受该默认值。然后，对装有 DNS 的服务器完成升级后，请记下它的静态 IP 地址，并将其他计算机配置成将所有 DNS 请求都发送到该 IP 地址。

详细信息，请参阅下列内容：

  • 有关 DNS 和如何在安装过程中配置 DNS 的其他基本信息，请参阅 TCP/IP 的名称解析。
  • 有关 DNS 的详细信息，请参阅 DNS。
  • 有关 DNS 名称空间规划的特定信息，请参阅 DNS 的名称空间规划。


执行最后的准备并对运行 Windows NT 4.0 的域控制器进行升级

在从 Windows NT 4.0 开始进行升级前的最后准备过程中，可临时从网络中删除备份域控制器以保护现有的网络完整性。在升级过程中，对于拥有 2 到 5 台服务器的网络（此网络大小是在这些“入门”主题中讨论的网络大小范围之内）的升级，会有一些选项让您选择。本主题描述从网络中删除备份域控制器，并提供在升级过程中选择选项的指导。

在开始升级过程的这一阶段以前，请务必参阅在 Windows NT 4.0 域中升级内列出的其他主题中的重要信息。

从网络中删除备份域控制器

在所有域控制器都运行 Windows NT 4.0 的域中开始升级服务器前，当您正在确认是否应用了 Service Pack 5 或更高版本，并且您正在执行服务器备份时，可在最后准备阶段执行额外的预防步骤。

如果您正准备升级主域控制器，那么为了保护现有网络的完整性，请考虑暂时从网络中删除备份域控制器。为此，可在现有的 Windows NT 网络中选择一个备份域控制器，确保它包括用户帐户数据库的当前副本，并将其备份。然后将其网络电缆断开。在将主域控制器升级成运行 Windows Server 2003 的域控制器后（必须首先升级主域控制器），这一断开的系统可以在必要时提升为 Windows NT 主域控制器。但是，在一般的升级过程中，无需也不能将 Windows NT 备份域控制器升级为主域控制器。而是继续进行升级，最终重新连接已断开的服务器并对其进行升级。

升级主域控制器后运行 Active Directory 安装向导

要将主域控制器升级成运行 Windows Server 2003 的域控制器，必须首先运行安装程序以便升级操作系统。操作系统安装完成后，可运行 Active Directory 安装向导（在您首次登录时出现在屏幕上）。本节提供了有关升级主域控制器时在 Active Directory 安装向导中进行选择的指导。

要点

  • 开始升级运行 Windows NT 4.0 的域控制器时，必须首先升级主域控制器。

下表显示了在以前是主域控制器的服务器上运行 Active Directory 安装向导时推荐的选择。以下建议针对的是拥有 2 到 5 台服务器的网络（此网络大小是在这些“入门”主题中讨论的网络大小范围之内）：

以前是主域控制器的服务器选项 | 对于拥有 2 到 5 台服务器的网络的推荐操作
“在新林中的域” 或 “在现有域树中的子域” 或 “在现有的林中的域树” | 选择“在新林中的域”。
“Windows Server 2003 过渡版” 的林功能级别 （只有在以前选择过“在新林中的域”时才出现此选项。） | 选择“Windows Server 2003 过渡版”。 使用此域功能级别，可以有运行 Windows NT 4.0 或 Windows Server 2003 的域控制器，但没有运行 Windows 2000 的域控制器。

在升级过程中，可以选择以下三个重要项目的位置：包含用户帐户和其他 Active Directory 数据的数据库、日志文件和系统卷 (Sysvol) 文件夹。数据库和日志文件可以位于任何分区上（FAT、FAT32 或 NTFS）；数据库可从使用 Windows NT 时的大小扩展 10 倍，从而为它留有足够的空间。（日志文件最初只占用很小的空间。）系统卷文件夹必须在 NTFS 分区上。（有关 NTFS 和其他文件系统的信息，请参阅为安装分区选择文件系统）。

注意

  • 开始升级域控制器时，如果有作为“成员”服务器的远程访问服务器，建议在升级最后一个域控制器之前升级这一远程访问服务器。详细信息，请参阅计划服务器角色和服务器从 Windows NT 升级的顺序。

有关与 Active Directory 相关的升级的其他信息，请参阅域和林功能和从 Windows NT 域升级。有关 Active Directory 相关主题的一般列表，请参阅 Active Directory。


决定计算机是否包含多个操作系统

  • 包含多个操作系统的计算机的注意事项
  • 多个操作系统和文件系统的兼容性
  • 包含多个 Windows Server 2003 家族分区的计算机
  • 包含 Windows 2000 和 Windows Server 2003, Enterprise Edition 的计算机
  • 包含 Windows NT 4.0 和 Windows Server 2003, Enterprise Edition 的计算机
  • 包含 Windows 98 或 Windows Millennium Edition 和 Windows Server 2003, Enterprise Edition 的计算机
  • 包含 MS-DOS 和 Windows Server 2003, Enterprise Edition 的计算机


包含多个操作系统的计算机的注意事项

在具有相应磁盘配置的计算机上（在本主题后面的表中进行了概述），可以安装多个操作系统，之后可在每次重新启动计算机时选择要使用的操作系统。

注意

  • 在基于 Itanium 体系结构的计算机上，可安装 Windows XP 64-Bit Edition、64 位版本的 Windows Server 2003, Enterprise Edition 或 64 位版本的 Windows Server 2003, Datacenter Edition。在本主题以及有关安装多操作系统的其他主题中，有关不能安装的操作系统的信息将不适用。例如，有关 Windows 2000 或 Windows NT 4.0 的信息不适用于基于 Itanium 体系结构的计算机。

例如，在基于 x86 的计算机上，可将服务器设置为大部分时间运行 Windows Server 2003, Enterprise Edition，但允许它有时运行 Windows NT Server 4.0, Enterprise Edition 以支持早期的应用程序。（但是，要执行此操作，您需要选择特定的文件系统并需要 Service Pack 5 或更高版本，如多个操作系统和文件系统兼容性中所述。）在重新启动期间，显示器上将显示指定的秒数，允许您在两个操作系统中进行选择。（可以指定在重新启动过程中未作出选择的情况下将运行的默认操作系统。）

下表显示了可以安装多操作系统的磁盘配置。

要点

  • 必须满足下表中的要求。例如，在基本磁盘上，必须将每个操作系统（包括 Windows Server 2003, Enterprise Edition）安装在单独的分区上。这样可确保每个操作系统不会覆盖其他操作系统需要的重要文件。
磁盘配置 | 多个操作系统的要求
基本磁盘 | 可以在基本磁盘上安装多个操作系统，包括 Windows NT 4.0 和更早版本的操作系统。每个操作系统都必须在磁盘的单独分区或逻辑驱动器上。分区或逻辑驱动器是磁盘中作为单独单元运行的区域。不同的分区通常具有不同的驱动器号（例如，C: 和 D:）。
单个动态磁盘 | 可以只安装一个操作系统。 但如果您已经用 Windows 2000 或 Windows XP 将没有分区的磁盘直接更改为动态磁盘，则必须将该磁盘恢复为基本磁盘，然后才能在上面安装操作系统。详细信息，请参阅本表后面的“注意”。
多个动态磁盘 | 每个动态磁盘上都可以安装一个 Windows 2000、Windows XP 或 Windows Server 2003 家族产品。其他任何操作系统都不能从动态磁盘中启动。 但如果您已经用 Windows 2000 或 Windows XP 将没有分区的磁盘直接更改为动态磁盘，则必须将该磁盘恢复为基本磁盘，然后才能在上面安装操作系统。详细信息，请参阅本表后面的“注意”。
基于 Itanium 体系结构的计算机上的主启动记录 (MBR) 磁盘 | 不能从基于 Itanium 体系结构的计算机上的 MBR 磁盘启动操作系统。为此，必须使用 GPT 磁盘。
基于 Itanium 体系结构的计算机上的 GUID 分区表 (GPT) 磁盘 | 可以在基于 Itanium 体系结构的计算机上的 GPT 磁盘上安装一个或多个操作系统。该表中用于基本磁盘和动态磁盘的准则适用于基于 Itanium 体系结构的计算机上的 GPT 磁盘。 在基于 Itanium 体系结构的计算机上，可安装的操作系统包括 Windows XP 64-Bit Edition、64 位版本的 Windows Server 2003, Enterprise Edition 和 64 位版本的 Windows Server 2003, Datacenter Edition。在基于 Itanium 体系结构的计算机上，不能安装更早版本的操作系统，例如，Windows 2000。

注意

  • 如果您已经用 Windows 2000 或 Windows XP 将不带分区的磁盘直接更改为动态磁盘，则必须将该磁盘恢复为基本磁盘，然后才能在上面安装操作系统。在此过程中所有数据都将丢失，因此请首先进行备份。然后，可使用 Windows 2000 或 Windows XP 还原磁盘，或者可使用 Windows Server 2003, Enterprise Edition 安装。要使用 Windows 2000 或 Windows XP，请按照操作系统的“帮助”中的说明进行操作。要使用 Windows Server 2003, Enterprise Edition 安装程序，进行分区的过程中在可用的分区列表中查找动态磁盘，然后将其删除（这会擦除所有卷上的全部数据）。您将得到提示以确认您的操作。执行此操作之后，磁盘将只包含尚未划分的空间，可以使用安装程序在上面创建新的（基本磁盘）分区。

只安装一个操作系统的理由

设置计算机，以便在启动时您可以在两个以上的操作系统之间进行选择，这样做有一个优点：可以允许您使用只能运行在特定操作系统上的应用程序。然而，只安装一个操作系统也有一定的理由：

  • 每个操作系统都占用宝贵的磁盘空间。
  • 兼容性问题，特别是文件系统兼容性，会变得很复杂。详细信息，请参阅多个操作系统和文件系统的兼容性。
  • 在动态磁盘（可用于 Windows Server 2003 家族产品的一种存储类型）上，每个磁盘上只能安装一个操作系统。动态磁盘还无法用于某些操作系统。详细信息，请参阅本主题前面的表。
  • 为了避免在启动计算机时发生问题，不再需要保留多个操作系统。对于 Windows Server 2003 家族产品，您可以通过一些其他选项来恢复系统。例如，如果新安装的设备驱动程序出现问题，可以使用安全模式，在该模式下，Windows Server 2003, Enterprise Edition 以默认设置和最少的驱动程序重新启动。有关安全模式和其他选项的详细信息，请参阅了解故障恢复。

要考虑的具体细节

决定在计算机上安装多个操作系统之前，请阅读适用于您的主题：

可与下面操作系统
交替使用的操作系统
Windows Server 2003, Enterprise Edition 		要阅读的主题
Windows Server 2003 家族中的其他产品
  • 包含多个 Windows Server 2003 家族分区的计算机
Windows 2000
  • 包含下列产品的计算机：Windows 2000 和 Windows Server 2003, Enterprise Edition
Windows NT 4.0
  • 多个操作系统和文件系统的兼容性
  • 包含 Windows NT 4.0 和 Windows Server 2003, Enterprise Edition 的计算机
Windows 98 或 Windows Millennium Edition
  • 包含 Windows 98 或 Windows Millennium Edition 和 Windows Server 2003, Enterprise Edition 的计算机
MS-DOS
  • 包含 MS-DOS 和 Windows Server 2003, Enterprise Edition 的计算机


多个操作系统和文件系统的兼容性

在包含多个操作系统的计算机上，如果考虑选择文件系统，兼容性将变得更加复杂。可供选择的文件系统有 NTFS、FAT 和 FAT32。（详细信息，请参阅为安装分区选择文件系统。）

通常建议采用 NTFS 文件系统，因为它效率更高、更可靠，而且支持包括 Active Directory 和基于域的安全性在内的重要功能。然而，对于 NTFS，在考虑是否将计算机设置为包含多个操作系统时，需要考虑文件系统的兼容性，因为对于 Windows 2000 和 Windows Server 2003 家族来说，NTFS 还具有 Windows NT 中所没有的新功能。使用任何新功能的文件将只有在计算机以 Windows 2000 或 Windows Server 2003 家族产品启动的情况下才完全可用或可读。

例如，计算机以 Windows NT Server 4.0 或 Windows NT 4.0 Server Enterprise Edition（这两个版本在加密功能存在以前即已发行）启动时， 使用新的加密功能的文件是不可读的。

有关影响 Windows Server 2003 家族产品文件可访问性功能的详细信息，请参阅 NTFS。

注意

  • 如果要在计算机上同时安装 Windows NT 和 Windows Server 2003, Enterprise Edition，并且要使用 NTFS 分区，唯一合适的 Windows NT 版本是版本 4.0（带有最新发布的 Service Pack）。使用最新的 Service Pack 可以最大限度地提高 Windows NT 4.0 和 Windows Server 2003, Enterprise Edition 之间的兼容性。（具体来说，就是必须具备 Service Pack 5 或更高版本。）然而，即使有了最新的 Service Pack，也不能访问使用了 NTFS 中的新功能的文件。
  • 建议不要在同时包含 Windows Server 2003, Enterprise Edition 和 Windows NT 的计算机上只使用 NTFS 文件系统。在这些计算机上，包含 Windows NT 4.0 操作系统的 FAT 分区确保启动 Windows NT 4.0 时，计算机可以访问需要的文件。此外，如果 Windows NT 未安装在系统分区（通常是磁盘上的第一个分区）上，建议系统分区也用 FAT 格式化。
  • 如果在计算机的 FAT 分区上安装 Windows NT 3.51 或更早版本，而在 NTFS 分区上安装 Windows Server 2003, Enterprise Edition，则当该计算机以 Windows NT 3.51 启动时，NTFS 分区将不可见。如果以这种方式设置计算机，并且包含 Windows NT 3.51 的分区不是系统分区（通常该分区是磁盘上的第一个分区），系统分区也必须用 FAT 格式化。


包含多个 Windows Server 2003 家族分区的计算机

可以设置服务器使其包含 Windows XP 和 Windows Server 2003 家族产品的某种组合，或包含 Windows Server 2003 家族产品的多个安装。如果计划这样做，则请注意以下几点：

  • 将每个操作系统安装在不同的分区上，或者，对于动态磁盘，应安装在不同的磁盘上，并将在一个操作系统中使用的应用程序与该操作系统安装在同一磁盘或分区上。如果要在两个不同的操作系统中使用一个应用程序，则请将其安装在两个不同的位置。
  • 对于基于 x86 的计算机，可以选择将 Windows Server 2003 家族中的任何产品安装在特定的分区上。例如，可以在一个位置安装 Windows Server 2003, Standard Edition 并在另一个位置安装 Windows Server 2003, Enterprise Edition。

    对于基于 Itanium 体系结构的计算机，可以选择 Windows XP 64-Bit Edition、64 位版本的 Windows Server 2003, Enterprise Edition 和 64 位版本的 Windows Server 2003, Datacenter Edition。

  • 如果计算机加入了域，则应为每一个安装使用不同的计算机名。因为域上的每一个 Windows Server 2003, Enterprise Edition 安装都使用唯一安全标识符 (SID)，所以每一个安装的计算机名都必须是唯一的，即使对于同一计算机上的多个安装也是如此。
  • 如果设置服务器使其包含 Windows Server 2003, Enterprise Edition 与 Windows 2000 或 Windows XP 的某种组合，或包含 Windows Server 2003 家族产品的多个分区，并且您要在该计算机上使用加密文件系统 (EFS)，则必须采取某些步骤。这些步骤可以使加密的文件在不同的操作系统上都可读。
    • 一种方法是确保所有安装的操作系统都位于同一域中并且这些操作系统上的用户具有漫游配置文件。
    • 另外一种方法是从一个操作系统中导出用户的文件加密证书和相关的私钥，并将其导入其他操作系统。

    详细信息，请参阅加密文件系统用法简介、使用漫游用户配置文件，以及导入和导出证书。


包含 Windows 2000 和 Windows Server 2003, Enterprise Edition 的计算机

可以设置服务器使其同时包含 Windows 2000 和 Windows Server 2003, Enterprise Edition。如果计划这样做，则请注意以下几点：

  • 将每个操作系统安装在不同的分区上，或者，对于动态磁盘，应安装在不同的磁盘上，并将在一个操作系统中使用的应用程序与该操作系统安装在同一磁盘或分区上。如果要在两个不同的操作系统中使用同一个应用程序，则请将其安装在两个位置。
  • Windows Server 2003, Enterprise Edition 必须在最后进行安装。否则，启动 Windows Server 2003, Enterprise Edition 所需的重要文件可能会被覆盖。
  • 如果计算机加入了域，则应为每一个安装使用不同的计算机名。因为域上的每一个操作系统都使用唯一安全标识符 (SID)，因此每一个操作系统的计算机名都必须是唯一的，即使对于同一计算机上的多个操作系统，也是如此。
  • 如果在安装了 Windows 2000 和 Windows Server 2003 家族产品的计算机上使用加密文件系统 (EFS)，加密的文件在不同的操作系统上不可读，除非采取了以下方法之一：
    • 一种方法是确保所有安装的操作系统都位于同一域中并且这些操作系统上的用户具有漫游配置文件。
    • 另外一种方法是从一个操作系统中导出用户的文件加密证书和相关的私钥，并将其导入其他操作系统。

    详细信息，请参阅加密文件系统用法简介、使用漫游用户配置文件，以及导入和导出证书。


包含 Windows NT 4.0 和 Windows Server 2003, Enterprise Edition 的计算机

如果要将计算机设置为包含 Windows NT 4.0 和 Windows Server 2003, Enterprise Edition，请首先查阅下列预防措施：

  • 为了避免在启动计算机时发生问题，不再需要保留多个操作系统。对于 Windows Server 2003 家族产品，您可以通过一些其他选项来恢复系统。例如，如果新安装的设备驱动程序出现问题，您可以使用安全模式，在该模式下，Windows Server 2003, Enterprise Edition 会 使用默认设置和最少的驱动程序重新启动。有关安全模式和其他选项的详细信息，请参阅了解事故恢复。
  • 建议不要在同时包含 Windows Server 2003, Enterprise Edition 和 Windows NT 的计算机上只使用 NTFS 文件系统。详细信息，请参阅多个操作系统和文件系统兼容性。
  • 请确保已经使用最新发布的 Service Pack 对 Windows NT 4.0 进行了更新。有关详细信息，请参阅多个操作系统和文件系统兼容性。
  • 将每个操作系统安装在不同的分区上，并将在一个操作系统中使用的应用程序与该操作系统安装在同一磁盘或分区上。如果要在两个不同的操作系统中使用一个应用程序，则请将其安装在两个分区。
  • 不要在压缩驱动器上安装 Windows Server 2003, Enterprise Edition，除非该驱动器是用 NTFS 文件系统压缩功能进行压缩的。
  • Windows Server 2003, Enterprise Edition 必须在最后进行安装。否则，启动 Windows Server 2003, Enterprise Edition 所需的重要文件可能会被覆盖。
  • 如果计算机加入了域，则应为每一个安装使用不同的计算机名。


包含 Windows 98 或 Windows Millennium Edition 和 Windows Server 2003, Enterprise Edition 的计算机

如果计划在计算机上安装 Windows 98 或 Windows Millennium Edition 和 Windows Server 2003, Enterprise Edition，则请注意以下几点：

  • 将每个操作系统安装在不同的分区上，并将在一个操作系统中使用的应用程序与该操作系统安装在同一磁盘或分区上。如果要在两个不同的操作系统中使用一个应用程序，则请将其安装在两个分区。
  • Windows 98 或 Windows Millennium Edition 必须安装在以 FAT 或 FAT32 格式化的分区的基本磁盘上。如果 Windows 98 或 Windows Millennium Edition 不安装在系统分区（一般是磁盘上的第一个分区）上，也必须使用 FAT 或 FAT32 格式化系统分区。
  • Windows Server 2003, Enterprise Edition 必须在最后进行安装。否则，启动 Windows Server 2003, Enterprise Edition 所需的重要文件可能会被覆盖。
  • 文件系统兼容性可能会成为问题。请参阅多个操作系统和文件系统的兼容性。


包含

Microsoft Windows 图形

包含 MS-DOS 和 Windows Server 2003, Enterprise Edition 的计算机

如果计划在计算机上安装 MS-DOS 和 Windows Server 2003, Enterprise Edition，则请注意以下几点：

  • 将每个操作系统安装在不同的分区上，并将在一个操作系统中使用的应用程序与该操作系统安装在同一磁盘或分区上。如果要在两个不同的操作系统中使用一个应用程序，则请将其安装在两个分区。
  • MS-DOS 必须安装在基本磁盘上的以 FAT 格式化的分区上。如果 MS-DOS 不安装在系统分区（一般是磁盘上的第一个分区）上，则系统分区也必须用 FAT 格式化。
  • Windows Server 2003, Enterprise Edition 必须在最后进行安装。否则，启动 Windows Server 2003, Enterprise Edition 所需的重要文件可能会被覆盖。
  • 文件系统兼容性可能会成为问题。请参阅多个操作系统和文件系统的兼容性。


为安装分区选择文件系统

  • 选择文件系统：NTFS、FAT 或 FAT32
  • 重新格式化或转换分区以使用 NTFS
  • NTFS 与 FAT 和 FAT32 的对比
  • NTFS


选择文件系统NTFS、FAT 或 FAT32

您可以在三个文件系统中选择用于安装分区的文件系统：NTFS、FAT 和 FAT32。强烈建议在大多数情况下使用 NTFS。

有关每一种文件系统或者转换或重新格式化分区的详细信息，请参阅：

  • 重新格式化或转换分区以使用 NTFS
  • NTFS 与 FAT 和 FAT32 的对比
  • NTFS

注意

  • 只有将 NTFS 选作文件系统，才能使用诸如 Active Directory 和基于域的安全之类的重要功能。

要点

  • 在 GPT 磁盘（仅在基于 Itanium 体系结构的计算机上可用）上，强烈建议将 NTFS 用于安装分区。但是，如果您有基于 Itanium 体系结构的计算机，并发现它有 100 MB（或更大）的小 FAT 分区，请不要删除或重新格式化此分区。加载操作系统时需要该分区。详细信息，请参阅在基于 Itanium 体系结构的计算机上启动安装程序。

下表列出了基于 x86 的计算机的多种安装或升级方案（最后两个方案不常用），并为每一种方案提供了文件系统准则：

基于 x86 的计算机的安装或升级方案 | 要使用的文件系统和要阅读的其他信息
该计算机当前只使用了 NTFS（没有 FAT 或 FAT32）。 | 继续使用 NTFS。 不需要有关文件系统的其他信息。
计算机是基于 x86 的计算机，并且有一个或多个 FAT 或 FAT32 分区。 并且 该计算机当前只有一个操作系统，或者该计算机上的操作系统包括 Windows 2000、Windows XP 或 Windows Server 2003 家族产品，但没有其他操作系统。 如果计算机是基于 Itanium 体系结构的计算机，请参阅本主题前面的重要注释。 | 请考虑重新格式化或者转换分区以使所有分区都使用 NTFS。 详细信息，请参阅重新格式化或转换分区以使用 NTFS。
该计算机将安装多个操作系统，其中一个是 MS-DOS、Windows 95、Windows 98 或 Windows Millennium Edition。 | 对于必须从 MS-DOS、Windows 95、Windows 98 或 Windows Millennium Edition 访问的任何分区，请使用 FAT（或适合时，使用 FAT32）。 详细信息，请参阅决定计算机是否包含多个操作系统。
该计算机将安装多个操作系统，其中一个是 Windows NT。 | 阅读多个操作系统和文件系统的兼容性。


重新格式化或转换分区以使用 NTFS

如果已有一个 FAT 或 FAT32 分区并希望在该分区上安装 Windows Server 2003 家族产品，但同时又希望该分区使用 NTFS，则可以选择以下两种方式：

  • 可以将 FAT 或 FAT32 分区转换为 NTFS。这将使文件保持原样，尽管比起使用 NTFS 格式化了的分区而言，此时的分区可能碎片稍多而且性能稍慢。但使用 NTFS 依然有优势，不论该分区是用 NTFS 格式化的还是从旧的文件系统转换而来的。

    如果在 FAT 或 FAT32 分区上安装 Windows Server 2003 家族产品，系统将为您提供将分区转换成 NTFS 的选项。也可以在安装完成后使用 Convert.exe 来转换 FAT 或 FAT32 分区。有关 Convert.exe 的详细信息，请参阅 Convert。

  • 可使用 NTFS 对分区重新格式化。这将清除分区上的所有文件，不过与转换的分区相比，这将使碎片更少而且性能更好。

要点

  • 如果您拥有一台基于 Itanium 体系结构的计算机且发现它具有一个 100 MB（或更大）的小 FAT 分区，请不要删除或重新格式化该分区。加载操作系统时需要该分区。详细信息，请参阅在基于 Itanium 体系结构的计算机上启动安装程序。

如果在安装过程中对分区进行格式化，则 NTFS 和 FAT 将作为文件系统选项列出。下表提供了关于在安装过程中分区大小和文件系统选项之间的关系的信息。

分区的状态和大小 | 安装选项和响应（对分区进行格式化时）
未格式化，小于 2 GB。 | 安装程序提供 NTFS 或 FAT。安装程序使用选定的格式。
未格式化，2 GB 或更大，最大可达 32 GB。 | 安装程序提供 NTFS 或 FAT。如果选择了 FAT，则安装程序将使用 FAT32。
未格式化，大于 32 GB。 | 安装程序只允许 NTFS。
以前使用 FAT32 进行了格式化，大于 32 GB。（使用 Windows 95、Windows 98 或 Windows Millennium Edition 创建的分区。） | 不需要格式化，即使存在该大小的未格式化分区，在 Windows Server 2003 家族产品的安装期间或之后对其进行格式化时，必须使用 NTFS。换句话说，这一大小的以前格式化了的 FAT32 分区将继续受 Windows Server 2003 家族的支持。

如果在安装过程中对分区进行格式化，则可在快速格式化和完整格式化之间做出选择：

快速格式化
快速格式化在磁盘上创建文件系统结构时不验证每个扇区的完整性。对于没有坏扇区和与坏扇区相关的文件破坏问题历史的所有磁盘，都可选择此方法。
完整格式化
完整格式化将标识和跟踪坏扇区以便不使用这些坏扇区来存储数据。对于有坏扇区或与坏扇区相关的文件破坏问题历史的磁盘，都可选择此方法。


NTFS 与 FAT 和 FAT32 的对比

NTFS 文件系统始终比 FAT 和 FAT32 文件系统功能更强大。Windows 2000、Windows XP 和 Windows Server 2003 家族包含新版本的 NTFS，此版本支持包括 Active Directory（这是域、用户帐户和其他重要的安全功能所需要的）在内的各种功能。有关 NTFS 中功能的详细信息，请参阅 NTFS。

FAT 和 FAT32 彼此是相似的，不同在于 FAT32 比 FAT 更适合于较大磁盘的使用。NTFS 是一种最适合大磁盘使用的文件系统。

下表介绍了每个文件系统与各种操作系统的兼容性。

注意

  • 文件系统的选择对于跨网络访问文件没有影响。例如，即使客户端运行像 Windows 98 或 Windows NT 这类较早的操作系统，在服务器的所有分区上使用 NTFS 也不影响客户端跨网络连接到该服务器上的共享文件夹或共享文件。
NTFS | FAT | FAT32
运行 Windows 2000、Windows XP 或 Windows Server 2003 家族产品的计算机可以访问本地 NTFS 分区上的文件。运行带有 Service Pack 5 或更高版本的 Windows NT 4.0 的计算机或许可以访问某些文件。其他操作系统则不允许本地访问。 | 可通过 MS-DOS、所有版本的 Windows 和 OS/2 访问本地分区上的文件。 | 只能通过 Windows 95 OSR2、Windows 98、Windows Millennium Edition、Windows 2000、Windows XP 和 Windows Server 2003 家族产品访问本地分区上的文件。

下表比较了每个文件系统支持的磁盘和文件大小。

NTFS | FAT | FAT32
推荐的最小卷大小是 10 MB 左右。 最大的卷和分区大小起始为 2 千吉字节 (TB)，并可以达更大范围。例如，通过标准分配单元大小 (4 KB) 格式化的动态磁盘可有 16 TB 减去 4 KB 的分区。有关最大卷和分区大小的详细信息，请参阅 Microsoft 网站上的“Storage Technologies Collection”（存储技术资料集）。 (http://www.microsoft.com/) 无法在软盘上使用。 | 软盘卷的最大大小可达 4 GB。 不支持域。 | 使用 Windows Server 2003 家族产品，可对容量为 33 MB 到 2 TB 的卷进行读或写。 使用 Windows Server 2003 家族产品可以将 32 GB 以下的卷格式化为 FAT32。 不支持域。
尽管文件大小不能超过它们所在的卷或分区的大小，但可能的最大文件大小可为 16 TB 减去 64 KB。 | 最大文件大小为 2 GB。 | 最大文件大小为 4 GB。

注意

  • 在基于 Itanium 体系结构且有多个磁盘的计算机上，您的选择不仅仅包括文件系统，而且还包括“分区形式”。分区形式决定了存储分区信息的方法。有两种分区形式。较新的形式（仅在基于 Itanium 体系结构的计算机上使用）将分区信息存储在全局唯一标识符 (GUID) 分区表 (GPT) 中。较旧的形式将信息存储在主启动记录 (MBR) 中。在基于 Itanium 体系结构的计算机上，必须将 Windows Server 2003, Enterprise Edition 安装在 GPT 磁盘上。

    有关基于 Itanium 体系结构的计算机上两种分区形式的详细信息，请参阅分区形式以及Microsoft Windows 网站上的“Storage Technologies Collection”（存储技术资料集）。(http://www.microsoft.com/)


NTFS

下面是选择 NTFS 时可能要使用的一些功能：

  • 更好的可伸缩性使扩展为大驱动器成为可能。NTFS 的最大分区或卷比 FAT 的最大分区或卷大得多，当卷或分区大小增加时，NTFS 的性能并不会降低，而 FAT 的性能则会降低。
  • Active Directory（和域，域是 Active Directory 的一部分）。通过 Active Directory 可便于查看和控制网络资源。使用域可以在简化管理的情况下微调安全选项。域控制器和 Active Directory 需要使用 NTFS。
  • 压缩功能，包括压缩或解压缩驱动器、文件夹或者特定文件的功能。（但是，无法同时压缩和加密某个文件。）
  • 文件加密，该功能极大地增强了安全性。（但是，无法同时压缩和加密某个文件。）
  • 可以对单个文件而不只是对文件夹设置权限。
  • 远程存储，通过使可移动媒体（如磁带）更易访问，从而扩展了磁盘空间。
  • 恢复磁盘活动的日志记录，它允许 NTFS 在断电或发生其他系统问题时尽快地恢复信息。
  • 稀疏文件。稀疏文件是一些大型文件，应用程序以一种仅需有限磁盘空间的方式创建了这些文件。也就是说，NTFS 只为文件的写入部分分配了磁盘空间。
  • 磁盘配额，可用来监视和控制单个用户使用的磁盘空间量。

这只是 Windows Server 2003 家族中 NTFS 的部分功能列表。有关新功能的详细信息，请参阅新功能。

有关 NTFS 的最大可能文件大小的信息，请参阅 NTFS 与 FAT 和 FAT32 的对比。有关转换或重新格式化 FAT 或 FAT32 分区的信息，请参阅重新格式化或转换分区以使用 NTFS。


为全新安装计划磁盘分区或卷

  • 计划磁盘分区时的注意事项
  • 对磁盘进行分区时的选项
  • 使用动态磁盘和安装程序


计划磁盘分区时的注意事项

只有在同时满足下面两种情况时，才必须在运行安装程序之前计划磁盘分区：

  • 进行全新安装，而不是升级。
  • 在基本磁盘上进行安装，而不是动态磁盘。基本磁盘是指 Windows 2000 之前存在的磁盘类型；大多数磁盘都是基本磁盘。动态磁盘是指，曾经是基本磁盘但使用 Windows 2000、Windows XP 或 Windows Server 2003 家族产品更改为动态磁盘的磁盘。如果计划安装到动态磁盘，则无法在安装程序运行过程中更改磁盘上的卷或分区大小，因此不需要进行有关分区大小的计划。对于这种情况，请复查使用动态磁盘和安装程序中的指导原则。

磁盘分区是一种划分物理磁盘的方法，以便使每一部分都能够作为单独的单元运行。在基本磁盘上创建分区时，可将磁盘分成一个或多个区域，然后可以用 FAT 或 NTFS 等文件系统分别对它们进行格式化。不同的分区通常具有不同的驱动器号（例如，C: 和 D:）。一个基本磁盘最多可以创建四个主分区，或者三个主分区和一个扩展分区。（扩展分区可以细分为逻辑驱动器，而主分区无法再细分。）

要点

  • 如果计划在硬盘上删除或创建分区，请预先备份磁盘内容，因为这些操作将会毁坏所有现有的数据。与对磁盘内容的任何重要更改一样，建议在处理分区之前备份硬盘的全部内容，即使计划保留一个或多个分区，也应这样做。

在运行安装程序以执行全新安装之前，请确定将要在上面进行安装的分区大小。没有固定的公式用来计算分区大小。基本的原则是为操作系统、应用程序和计划放在安装分区的其他文件预留较大的空间。 Windows Server 2003, Enterprise Edition 的安装文件对于基于 x86 的计算机大约需要 1.25 GB 到 2 GB 的磁盘空间，对于基于 Itanium 体系结构的计算机大约需要 3 GB 到 4 GB， 如在系统需求中所描述的那样。建议预留的磁盘空间要比最小需求多许多。在分区上为大型安装留出 4 GB 到 10 GB 或更多空间是非常合理的。这些预留的空间可用于各种项目，包括可选组件、用户帐户、Active Directory 信息、日志、未来的 Service Pack、操作系统使用的分页文件，以及其他项目。

有关需要磁盘空间的某些项目信息，请参阅以下内容：

  • 更改虚拟内存设置
  • 指定系统意外停止时将会发生的情况
  • 选择要安装的组件
  • 了解 Active Directory
  • 目录数据存储

执行全新安装时，可以指定要在其上进行安装的分区。如果在已经存在其他操作系统的磁盘上指定分区，那么系统将提示用户加以确认。

在安装程序运行过程中，仅可创建要在其上安装 Windows Server 2003, Enterprise Edition 的分区，并调整其大小。 安装完成之后，可以使用“磁盘管理”管理新的和现有的磁盘和卷。其中包括从尚未划分的空间创建新分区；删除、重命名和重新格式化现有的分区；添加和删除硬盘；以及将基本磁盘更改为动态磁盘存储类型，或者将动态磁盘更改为基本磁盘。 （如果要在具有多个操作系统的计算机上设置动态磁盘，请务必阅读包含多个操作系统的计算机的注意事项。）

在具有多个磁盘的基于 Itanium 体系结构的计算机上，既可计划分区的大小，也可计划每个磁盘的分区形式。分区形式决定了存储分区信息的方法。有两种分区形式。较新的形式（仅在基于 Itanium 体系结构的计算机上使用）将分区信息存储在全局唯一标识符 (GUID) 分区表 (GPT) 中。较旧的形式将信息存储在主启动记录 (MBR)。在基于 Itanium 体系结构的计算机上，必须将 Windows Server 2003, Enterprise Edition 安装在 GPT 磁盘上。通过 GPT，可创建更多的分区和更大的卷，并可获得其他益处。有关基于 Itanium 体系结构的计算机上分区形式的详细信息，请参阅分区形式以及 Microsoft Windows 网站上的“Storage Technologies Collection”（存储技术资料集）。(http://www.microsoft.com/)。

要点

  • 如果要设置计算机使其包含多个操作系统，必须在 Windows Server 2003, Enterprise Edition 自己的分区上或逻辑驱动器上安装它。这样可确保 Windows Server 2003, Enterprise Edition 不会覆盖其他操作系统需要的重要文件。详细信息，请参阅决定计算机是否包含多个操作系统。

远程安装服务的磁盘分区要求

如果计划使用此服务器上的远程安装服务以便将操作系统安装到其他计算机上，则需要一个单独的分区供远程安装服务使用。以下是有关对此分区使用 NTFS 的计划：远程安装服务的单个实例存储功能必须使用 NTFS。

如果需要为“远程安装服务”创建一个新分区，则应在安装之后对此进行计划，并留出足够的未分区磁盘空间，以便创建分区（建议至少留出 4 GB 的空间）。作为备用方案，对于系统磁盘（非群集磁盘），可计划将其改为动态磁盘，从而在使用磁盘空间时具有比基本磁盘更大的灵活性。 （然而，如果要在包含多个操作系统的计算机上设置动态磁盘，则请参阅决定计算机是否包含多个操作系统。）

有关远程安装服务的要求信息，请参阅远程安装服务系统要求。有关磁盘和分区选择的其他信息，请参阅磁盘管理。有关远程安装服务的概述、清单和其他信息，请参阅远程安装服务。


对磁盘进行分区时的选项

仅当您在执行全新安装而不是升级安装时，才可以在安装过程中更改磁盘的分区。安装完成后可以用“磁盘管理”修改磁盘的分区。

如果正在执行全新安装，则安装程序会检查硬盘来确定现有的配置，然后提供下列选项：

  • 如果硬盘未分区，可创建要安装 Windows Server 2003 家族产品的分区，并调整其大小。
  • 如果硬盘已分区但还有足够的未分区磁盘空间，可以用未分区的空间为 Windows Server 2003 家族产品创建分区。
  • 如果硬盘的现有分区足够大，则可将 Windows Server 2003 家族产品安装在该分区上（可以先对其重新格式化，也可以不重新格式化）。重新格式化分区将会清除分区上的所有数据。如果不重新格式化分区，而安装 Windows Server 2003 家族产品所在的分区上已存在某个操作系统，该操作系统将被覆盖，您必须重新安装要与 Windows Server 2003 家族产品一起使用的所有应用程序。
  • 如果硬盘具备现有的分区，则可以将其删除，从而为 Windows Server 2003 家族产品的分区创建更多未分区的磁盘空间。删除现有的分区也会清除该分区上的所有数据。


使用动态磁盘和安装程序

动态磁盘使用了 Windows 2000 引进的新存储类型。如果已将磁盘更改为动态磁盘并希望在该磁盘上执行新安装，请阅读下列内容。

  • 如果您已经用 Windows 2000 或 Windows XP 将不带分区的磁盘直接更改为动态磁盘，则必须将该磁盘恢复为基本磁盘，然后才能在上面安装操作系统。

    警告

    • 将磁盘还原为基本磁盘时，所有数据都将丢失，因此请首先备份磁盘。

    可使用 Windows 2000 或 Windows XP 来还原磁盘，也可以用 Windows Server 2003 家族产品的安装程序来还原磁盘。要使用 Windows 2000 或 Windows XP，请按照操作系统的“帮助”中的说明进行操作。要使用 Windows Server 2003 家族产品的安装程序，请先在分区阶段查找可用分区列表中的动态磁盘，然后将其删除（这将清除所有卷上的所有数据）。您将得到提示以确认您的操作。执行此操作之后，磁盘将只包含尚未划分的空间，可以使用安装程序在上面创建新的（基本磁盘）分区。

  • 如果计划在已安装 Windows Server 2003 家族产品的计算机上重新运行安装程序，并且计算机包含动态磁盘，则一定要阅读有关在磁盘（已用 Windows Server 2003 家族产品将其更改为动态磁盘）上安装操作系统时的限制。详细信息，请参阅动态磁盘和动态卷。


网络：TCP/IP、IP 地址及名称解析

  • 网络和 TCP/IP 概述
  • Internet 协议 (IP) 地址
  • TCP/IP 的名称解析


网络和 TCP/IP 概述

TCP/IP 是一种提供 Internet 访问的网络协议。多数服务器都使用此协议（尽管可以在服务器上使用额外的或不同的网络适配器以及与之相关的协议）。

要使用 TCP/IP，请确保已为每台服务器提供了 IP 地址，无论是通过软件提供的动态（自动）地址还是您获得或设置的静态地址。因为这些地址仅仅是一些数字，很难记忆，所以同时还需为用户提供易于使用的名称。将此名称类型映射到 IP 地址，这一操作称为名称解析，而且可以通过各种方法完成，主要的方法是采用域名系统 (DNS) 和 Windows Internet 名称服务 (WINS)。详细信息，请参阅 Internet 协议 (IP) 地址和 TCP/IP 的名称解析。


Internet 协议 (IP) 地址

正如网络和 TCP/IP 概述中所述，要使用 TCP/IP，必须为每一台计算机提供 IP 地址。此主题提供了用于执行该任务的选项的简要说明。更多详细信息，请参阅 DHCP 和 IP 寻址和路由。

有两种基本方法用于为将要安装的服务器提供 IP 地址：

动态主机配置协议 (DHCP)
可以通过配置一台或多台 DHCP 服务器（这些服务器动态地向其他计算机提供 IP 地址），以便向网络上的计算机提供 IP 地址。必须为 DHCP 服务器本身分配静态 IP 地址。

一台服务器或多台服务器可以提供 DHCP 以及一个或多个名称解析服务，这些服务包括域名系统 (DNS) 和 Windows Internet 名称服务 (WINS)。

如果要先运行安装程序然后再决定哪一台服务器用作 DHCP 服务器以及将哪一个静态 IP 地址分配到该服务器，那么您可以在运行安装程序期间在“网络设置”对话框中选择“典型设置”，以后再完成网络配置。如果您这样做并且网络上没有 DHCP 服务器，那么安装程序将使用一个限定的 IP 寻址选项，称作自动专用 IP 寻址 (APIPA)。在服务器使用 APIPA 期间，它只能与同一网段上的使用 APIPA 的其他计算机进行通信。使用 APIPA 的服务器无法与 Internet 进行连接（浏览网页或收发电子邮件），也不能与 DNS 或 Active Directory（它依赖于 DNS）一起使用。

如果您知道哪一台服务器要用作 DHCP 服务器，那么在安装该服务器时，请在安装程序中的“网络设置”对话框中，选择“自定义设置”，并指定静态 IP 地址和相关的网络设置。详细信息，请参阅指定 DNS 和 WINS 所需的静态本地 IP 地址和设置。

静态 IP 寻址
对于某些类型的服务器，必须在安装程序运行期间或之后分配静态 IP 地址和子网掩码。这些服务器包括 DHCP 服务器、DNS 服务器、WINS 服务器，以及向 Internet 上的用户提供访问的任何服务器。此外，还建议您为每一台域控制器分配静态 IP 地址和子网掩码。如果计算机有多个网络适配器，则必须为每一个适配器分配单独的 IP 地址。

如果要先在服务器上运行安装程序然后再决定要给该服务器分配哪一个静态 IP 地址，那么您可以在安装程序运行期间在“网络设置”对话框中选择“典型设置”，然后再配置该服务器。在这种情况下，如果网络上有 DHCP 服务器，那么安装程序将从 DHCP 获取 IP 地址配置。如果网络上没有 DHCP 服务器，那么安装程序将使用自动专用 IP 寻址 (APIPA)。在此列表中的前一项中对 APIPA 进行了描述。

有关静态 IP 地址的详细信息，包括专用 IP 地址（指从某一地址范围选择的 IP 地址）和公用 IP 地址（指从 Internet 服务提供商获取的 IP 地址），请参阅 IP 寻址和路由。

在作出 IP 地址使用计划之后，下面需要考虑的组件是用于名称解析的那些组件，名称解析是将计算机名（用户能够识别和记住的一些名称）映射为相应的 IP 地址的过程。详细信息，请参阅 TCP/IP 的名称解析。


TCP/IP 的名称解析

名称解析是向用户提供易于记忆的服务器名称的过程，而不要求用户使用数字 IP 地址（服务器在 TCP/IP 网络上使用数字 IP 地址来识别自己）。名称解析服务是域名系统 (DNS) 和 Windows Internet 名称服务 (WINS)。

DNS
DNS 是用于定位 Internet 和专用 TCP/IP 网络上计算机的结构命名系统。在大多数安装中需要一个或多个 DNS 服务器。Internet 电子邮件、Web 浏览器和 Active Directory 需要 DNS。在其中的客户端运行 Windows 2000、Windows XP 或 Windows Server 2003 家族产品的域中，DNS 通常用作名称解析服务。创建域控制器时（或者在现有的成员服务器上安装 Active Directory 从而使其成为域控制器时），系统将自动安装 DNS，除非 Windows Server 2003, Enterprise Edition 软件检测到该域的 DNS 服务器已经存在。也可以通过在“管理您的服务器”中选择 DNS 服务器角色或者使用控制面板来安装 DNS。

如果打算在服务器上安装 DNS，请在该服务器上指定静态的 IP 地址，并将该服务器配置成将该 IP 地址用作其自己的名称解析。

有关信息，请参阅如下：

  • 要从有关配置 DNS 的主题列表中进行选择，请参阅 DNS。
  • 有关通过在“管理您的服务器”中选择 DNS 服务器角色来安装 DNS 的信息，请参阅配置服务器角色。
  • 有关如何使用控制面板来安装 DNS 的信息，请参阅安装 DNS 服务器。
  • 有关在安装过程中指派静态 IP 地址的信息，请参阅指定 DNS 和 WINS 所需的静态本地 IP 地址和设置。
  • 有关在安装完成后分配静态 IP 地址的信息，请参阅为静态寻址配置 TCP/IP。
  • 有关安装域控制器（或在现有成员服务器上安装 Active Directory 从而使该成员服务器成为域控制器）的信息，请参阅管理域控制器。
WINS
如果为运行 Windows NT 或其他任何较早的 Microsoft 操作系统的客户端提供支持，则可能需要在域中的一台或多台服务器上安装 Windows Internet 名称服务 (WINS)。如果应用程序需要 WINS，则也可能需要安装它。通过在“管理您的服务器”中选择 WINS 服务器角色或者使用控制面板可以安装 WINS。

如果打算在服务器上安装 WINS，请在该服务器上指定静态的 IP 地址。

有关信息，请参阅如下：

  • 要从配置 WINS 的主题列表中进行选择，请参阅 WINS。
  • 有关通过在“管理您的服务器”中选择 WINS 服务器角色来安装 WINS 的信息，请参阅配置服务器角色。
  • 有关如何使用控制面板来安装 WINS 的详细信息，请参阅安装 WINS 服务器。
  • 有关在安装过程中指派静态 IP 地址的信息，请参阅指定 DNS 和 WINS 所需的静态本地 IP 地址和设置。
  • 有关在安装完成后分配静态 IP 地址的信息，请参阅为静态寻址配置 TCP/IP。


在工作组和域之间进行选择

本部分包含的信息可以帮助您决定将服务器放置在工作组中，还是放置在域中。本部分还包含其他信息，如果创建域，该信息将帮助您完成域内的服务器角色的基本规划。

有关在其所有域控制器都运行 Windows NT 4.0 的域中升级服务器的信息，请参阅在 Windows NT 4.0 域中升级。有关在包含一个或多个 Windows 2000 域控制器的域中升级服务器的信息，请参阅在包含 Windows 2000 域控制器的域中进行升级。 有关多于五台服务器的网络信息，请参阅位于 Microsoft Windows 网站的“Windows Server 2003 Deployment Kit”（Windows Server 2003 部署工具包）。(http://www.microsoft.com/)

有关其他信息，请参阅：

  • 工作组与域的比较
  • 域控制器和成员服务器的规划
  • Windows Server 2003 家族域控制器的特殊方面
  • 有关域的其他信息


工作组与域的比较

域是一组帐户和网络资源，这些资源共享共同的目录数据库和安全策略集，并可能与其他域有安全关系。工作组是比较基本的分组，只用于帮助用户查找组内诸如打印机和共享文件夹之类的对象。建议所有网络都使用域，只有几个用户的小型网络除外。

在工作组中，用户可能需要记住多个密码，因为每个网络资源都有自己的密码。（此外，不同的用户对每个资源可以使用不同的密码。）在域中，密码和权限比较容易跟踪，因为域具有用户帐户、权限和其他网络详细信息的单个的集中数据库。该数据库中的信息将自动在域控制器之间进行复制。要确定哪些服务器是域控制器，哪些服务器只是域成员。既可在安装过程中也可在安装完成后确定这些角色。

域及其所在的 Active Directory 目录系统在维护极佳的监视和安全性的同时，还提供许多使资源易于为用户访问的选项。详细信息，请参阅 Active Directory。


域控制器和成员服务器的规划

使用 Windows Server 2003, Standard Edition、Windows Server 2003, Enterprise Edition 或 Windows Server 2003, Datacenter Edition，域中的服务器可以具备以下两种角色之一：“域控制器”（包含与给定域中的用户帐户和其他 Active Directory 数据匹配的副本）和“成员服务器”（属于域，但不包含 Active Directory 数据的副本）。（属于工作组但不属于域的服务器称为“独立服务器”。）即使在安装完成后，也可以在域控制器和成员服务器（或独立服务器）这两个角色之间来回更改服务器的角色。不过，建议在运行安装程序之前计划域并只在必要的时候才更改服务器的角色（和服务器名称）。

与单个的域控制器相比而言，多域控制器为用户提供了更好的支持。对于多域控制器，您拥有用户帐户数据和其他 Active Directory 数据的副本；不过，执行定期备份（包括自动系统故障恢复备份）和熟悉恢复域控制器的方法仍然很重要。另外，多个域控制器可协同工作以支持域控制器功能，如执行登录验证。

详细信息，请参阅服务器角色。


Windows Server 2003 家族域控制器的特殊方面

管理 Windows Server 2003 家族域时，您可能希望了解有关操作主机角色的更详细信息。本主题简要描述了操作主机角色。Active Directory 中更加深入地讨论了各种域主题。

操作主机角色是专门指派给 Active Directory 域中一个或多个域控制器的角色。已被指派这些角色的域控制器将执行单个主机（不允许在网络上的不同位置同时出现）的操作。例如，为新资源（例如新计算机）创建安全标识符必须由单个域控制器监督，以确保标识符是唯一的。

在域中安装的第一个域控制器会自动被指派所有的操作主机角色。可在安装后更改对操作主机角色的指派，但大多数情况下这是不必要的。如果问题发生在某个操作主机，或者如果您打算让其中的一个操作主机停止服务，则要求您非常了解这些操作主机角色。详细信息，请参阅操作主机角色。


有关域的其他信息

有关在其所有域控制器都运行 Windows NT 4.0 的域中升级服务器的信息，请参阅在 Windows NT 4.0 域中升级。有关在包含一个或多个 Windows 2000 域控制器的域中升级服务器的信息，请参阅在包含 Windows 2000 域控制器的域中进行升级。

有关域和林、域功能级别和林功能级别、操作主机角色、全局编录以及其他与域相关的主题的详细信息，请参阅 Active Directory。

有关设置多个带有结构关系的域的信息，请参阅位于 Microsoft Windows Server 2003 部署工具包网站 (http://www.microsoft.com/) 的“Windows Server 2003 Deployment Kit”（Windows Server 2003 部署工具包）。


在运行安装程序之前准备好系统

  • 为系统做好升级准备
  • 为系统做好全新安装准备
  • 使用卷集、镜像集、带区集或具有奇偶校验的带区集


为系统作好升级准备

Microsoft Windows 图形

为系统做好升级准备

本主题描述为服务器做好升级准备的基本步骤。

如果要在服务器群集节点上升级到 Windows Server 2003, Enterprise Edition，请务必阅读在群集节点上升级到 Windows Server 2003, Enterprise Edition。

检查系统日志中的错误信息

使用事件查看器查看系统日志中可能会导致在升级过程中出现问题的最新错误或重复发生的错误。有关事件查看器的信息，请参阅了解事件查看器或正在运行的操作系统的“帮助”。

备份文件

建议在升级前备份当前的文件，包括含有配置信息的所有内容，如系统状态、系统分区和启动分区。可将文件备份到各种不同的媒体，如磁带驱动器或网络上其他计算机的硬盘。

为升级准备镜像集和其他磁盘集（仅限于 Windows NT 4.0）

使用 Windows NT 4.0 中的磁盘管理技术可创建卷集、镜像集、带区集或带有奇偶校验的带区集，每一项都有特定的功能与限制。通过使用随 Windows 2000 引入的动态磁盘，您可利用相似的技术，而且通过 Windows Server 2003, Enterprise Edition 还可以在无需重新分区或重新格式化的情况下扩展动态卷。

Windows NT 4.0 中使用的技术带来的这一转变意味着在运行 Windows Server 2003, Enterprise Edition 的安装程序前必须做出某些选择。有关这些选择的重要信息，请参阅使用卷集、镜像集、带区集或具有奇偶校验的带区集。

断开与 UPS 设备的连接

如果具有连接到目标计算机的不间断电源 (UPS)，则请在运行安装程序前断开与连接串行电缆的连接。安装程序将自动尝试检测连接到串行端口的设备，而且 UPS 设备可能导致在检测过程中出现问题。

查看硬件和软件

为升级启动安装程序时，执行的第一个过程是检查计算机硬件和软件的兼容性。安装程序在继续前将显示一个报告。使用该报告和 Relnotes.htm（在安装 CD \Docs 目录下）中的信息来确定在升级前是否需要更新硬件、驱动程序或软件。

要点

  • 如果使用 Internet 服务提供商 (ISP)，请特别注意有关更新 Internet 连接所需的 ISP 软件的所有建议。

有关 Windows Server 2003 家族产品的兼容硬件和软件的最新信息，请单击支持资源中的相应链接。如果有不使用即插即用的硬件设备，请参阅采用不使用即插即用技术的设备清单。


为系统做好全新安装准备

本主题描述了在进行全新安装之前准备服务器的基本步骤。

如果在服务器群集节点上安装 Windows Server 2003, Enterprise Edition，请务必阅读在群集节点上安装 Windows Server 2003, Enterprise Edition。

检查系统日志中的错误信息

如果计算机已有一个有效的操作系统，则请查看系统日志中可能会导致在升级过程中出现问题的最新的错误或重复发生的错误（尤其是硬件错误）。有关查看事件日志的信息，请参阅计算机上操作系统的“帮助”。

备份文件

执行全新安装前，建议备份当前文件，除非计算机没有文件或者当前的操作系统文件已被破坏。可将文件备份到各种不同的媒体，如磁带驱动器或网络上其他计算机的硬盘。

解压缩驱动器

安装之前解压缩所有 DriveSpace 或 DoubleSpace 卷。不要在压缩驱动器上安装 Windows Server 2003, Enterprise Edition，除非该驱动器是用 NTFS 文件系统压缩功能进行压缩的。

准备镜像集和其他磁盘集（仅限于 Windows NT 4.0）

使用 Windows NT 4.0 中的磁盘管理技术可创建卷集、镜像集、带区集或带有奇偶校验的带区集，每一项都有特定的功能与限制。通过使用随 Windows 2000 引入的动态磁盘，您可利用相似的技术，而且通过 Windows Server 2003, Enterprise Edition 还可以在无需重新分区或重新格式化的情况下扩展动态卷。

Windows NT 4.0 中使用的技术带来的这一转变意味着在运行 Windows Server 2003, Enterprise Edition 的安装程序前必须做出某些选择。有关这些选择的重要信息，请参阅使用卷集、镜像集、带区集或具有奇偶校验的带区集。

断开与 UPS 设备的连接

如果具有连接到目标计算机的不间断电源 (UPS)，则请在运行安装程序前断开与串行电缆的连接。安装程序将自动尝试检测连接到串行端口的设备，而且 UPS 设备可能导致在检测过程中出现问题。


使用卷集、镜像集、带区集或具有奇偶校验的带区集

使用 Windows NT 4.0 中的磁盘管理技术可创建卷集、镜像集、带区集或具有奇偶校验的带区集，每一项都有特定的功能与限制。通过使用由 Windows 2000 引入的动态磁盘技术，您可以用类似的技术来增加无需重新分区或重新格式化即可扩展磁盘卷的灵活性。

Windows NT 4.0 中使用的技术带来的这一转变意味着在运行 Windows Server 2003, Enterprise Edition 的安装程序前必须做出某些选择。 对于使用 Windows NT 4.0 创建的任何卷集、镜像集、带区集或具有奇偶校验的带区集，在 Windows Server 2003, Enterprise Edition 中都不被支持， 尽管它们在 Windows 2000 中可以得到有限程度的支持。

如果已用 Windows NT 4.0 创建了卷集、镜像集、带区集或具有奇偶校验的带区集，并希望在该计算机上运行 Windows Server 2003, Enterprise Edition 的安装程序，则必须选择下面的方法之一。

有关运行安装程序前要做的其他准备的信息，请参阅清单和在运行安装程序之前准备好系统。

对于镜像集，请中断镜像
如果正在包含镜像集的计算机上运行 Windows NT 4.0，并希望在该计算机上运行 Windows Server 2003, Enterprise Edition 的安装程序，则应首先备份数据（作为保护 - 数据将不会被删除），然后中断镜像。请确保已应用了 Service Pack 5 或更高版本，这是在运行 Windows Server 2003, Enterprise Edition 的安装程序前必需的工作。 然后运行安装程序。
对于卷集、带区集或具有奇偶校验的带区集，请先备份数据再删除该集
如果正在包含卷集、带区集或具有奇偶校验的带区集的计算机上运行 Windows NT 4.0，并且希望在该计算机上运行 Windows Server 2003, Enterprise Edition 的安装程序，则应首先备份数据。然后删除该集（这将删除数据）。请确保已应用了 Service Pack 5 或更高版本，这是在运行 Windows Server 2003, Enterprise Edition 的安装程序前必需的工作。 然后运行安装程序。

运行了 Windows Server 2003, Enterprise Edition 的安装程序后， 可将磁盘改为动态、恢复必要的备份数据并使用本节后面的表中显示的卷选项。有关动态磁盘的详细信息，请参阅动态磁盘和动态卷和使用动态磁盘。

如有必要，请使用 Ftonline 支持工具
准备在包含由 Windows NT 4.0 创建的卷集、镜像集、带区集或具有奇偶校验的带区集的计算机上运行 Windows Server 2003, Enterprise Edition 的安装程序时，建议采用上述方法。但是，如果不使用这些方法，并且必须在运行 Windows Server 2003, Enterprise Edition 的安装程序之后， 访问其中一个集，可以使用 Ftonline 工具。Ftonline 工具是 Windows Server 2003 家族支持工具的一部分。详细信息，请参阅 Windows 光盘上的支持工具。

动态磁盘上的多磁盘卷的类型

上一节中描述的磁盘集在 Windows Server 2003 家族中的名称与它们在 Windows NT 4.0 中的名称有所不同：

Windows NT 4.0 名称 | Windows Server 2003 家族名称
卷集 | 动态磁盘上的跨区卷
镜像集 | 动态磁盘上的镜像卷
带区集 | 动态磁盘上的带区卷
具有奇偶校验的带区集 | 动态磁盘上的 RAID-5 卷


资源

本主题提供了在企业中准备新服务器以便使用的其他信息来源。

  • 要确认您的计算机、系统组件和外围设备与 Windows Server 2003 家族产品是否兼容，请单击支持资源中的相应链接。
  • 有关 Windows Server 2003 家族产品的兼容应用程序的最新信息，请参阅 Microsoft 网站 (http://www.microsoft.com) 上的软件兼容性部分。
  • 如欲了解 Windows 软件和其他 Microsoft 软件的功能增强和更新，请参阅 Microsoft 网站上的 Windows Update 部分。(http://www.microsoft.com/) 有关使用 Windows Update 的不同方式的描述，请参阅 Windows Update。
  • 有关 Windows 部署和资源工具包（提供 Windows Server 2003 家族产品和部署 Windows XP 的技术背景信息）的信息，请参阅下列内容：
    • 位于 Microsoft Windows 网站的“Windows Server 2003 Deployment Kit”（Windows Server 2003 部署工具包）。(http://www.microsoft.com/)
    • 位于 Microsoft Windows 网站的“Windows Server 2003 Technical Reference”（Windows Server 2003 技术参考）。(http://www.microsoft.com/)
    • 位于 Microsoft Windows 资源工具包网站的“Windows XP Professional Resource Kit”（Windows XP Professional 资源工具包）。 (http://www.microsoft.com/)
    • Windows 部署和资源工具包
  • Microsoft TechNet 是包含信息技术 (IT) 专业人员所需资源的服务。这包括对 Microsoft 专业支持人员编写的白皮书和文章、职业和产业信息、讨论组、技术反馈和软件的访问。详细信息，请参阅位于 Microsoft 网站 (http://www.microsoft.com/) 的 TechNet。
  • 信息技术结构库网站 (ITIL) 为信息技术专业人员提供了指南。以下内容引自网站：“ITIL consists of a series of books giving guidance on the provision of quality IT services, and on the accommodation and environmental facilities needed to support information technology.”（ITIL 包含一系列图书，这些图书对提供高品质的 IT 服务以及支持信息技术所需的便利设施与环境设施给予了指导。）(网站地址可能变动，您可能无法连接到在这里提到的网站。)


疑难解答

本节概述了停止消息疑难解答的步骤，这些停止消息是操作系统中的系统错误引起的。系统出现错误后，计算机会停止响应，并在蓝色或黑色背景下显示一条消息。

有关如何获得产品支持的信息，请参阅位于 Microsoft 网站 (http://www.microsoft.com) 的“产品支持”。

本节包含：

  • 停止消息疑难解答：常规策略
  • 对特定停止消息进行疑难解答


停止消息疑难解答：常规策略

本主题描述对停止消息或意外关机进行疑难解答的一般方法。详细信息，请参阅以下内容：

  • 有关特定停止消息的信息，请参阅对特定停止消息进行疑难解答。
  • 有关特定停止消息的文章，请参阅位于 Microsoft 网站的“搜索知识库”。 (http://www.microsoft.com/)
  • 有关支持选项的信息，请参阅支持资源。
  • 有关特定技术或组件（例如，磁盘和文件系统）疑难解答的信息，请参阅位于 Microsoft Windows 网站 (http://www.microsoft.com/) 的“Windows Server 2003 Technical Reference”（Windows Server 2003 技术参考）。

可使用系统信息工具收集关于系统设置、问题设备和硬件资源的重要信息。详细信息，请参阅系统信息。

要点

  • 要确保系统稳定性，请安装适合系统的最新 Service Pack（按照 Service Pack 说明），而且仅使用签名的驱动程序。详细信息，请参阅位于 Microsoft 网站 (http://www.microsoft.com/) 的 Windows Update。有关使用 Windows Update 的不同方式的描述，请参阅 Windows Update。

对于不显示标识文本或具体疑难解答步骤的停止错误，请按照以下步骤进行操作：

  1. 使用 Microsoft 网站 (http://www.microsoft.com/) 上的 Windows 联机故障分析工具。可使用此工具向 Microsoft 发送错误报告，并使用您的 Microsoft Passport 信息跟踪其状态。可使用错误报告服务或 Web 浏览器来访问联机故障分析网站。启用此功能时，错误报告服务将监视系统中与操作系统组件和应用程序相关的内核和用户模式错误。通过内核模式报告，您可获得关于导致停止错误的问题或条件的详细信息。详细信息，请参阅系统和程序错误报告概述。
  2. 使用文件签名验证工具，此工具可以识别计算机上未经签名的驱动程序和不兼容的系统文件。由 Windows Server 2003 家族提供的系统文件和设备驱动程序文件具有 Microsoft 数字签名，该签名指示这些文件是未更改的原始系统文件，或者指示其已获 Microsoft 批准可用于 Windows。详细信息，请参阅使用文件签名验证。
  3. 如果停止消息是由驱动程序问题引起，则可使用设备管理器返回到驱动程序的前一版本。详细信息，请参阅返回到驱动程序的前一版本。可能需要禁用所有最近安装的驱动程序。
  4. 使用最新版本的病毒防护软件检查计算机上的病毒。如果找到病毒，则执行必要的步骤把它从计算机上清除掉。要了解如何执行这些步骤，请参阅反病毒软件的文档。
  5. 可搜索知识库以获得有关停止消息的更新信息。请参阅位于 Microsoft 网站 (http://www.microsoft.com/) 的“搜索知识库”，然后按照该页面上的说明进行操作。键入关键字时，请使用停止消息号（如 stop 0x0000000A）。

    有关可下载的文章、疑难解答向导和项目的详细信息，请参阅更新的技术信息。

  6. 如果能启动操作系统，则请查看事件查看器中的系统日志，以获得有助于确定导致问题的设备或驱动程序的其他信息。很多停止消息都将生成可搜索到的特定事件，如事件 ID 1001（由各种停止消息生成）和事件 ID 6008（通常由意外关机或未正确启动的计算机引起）。要显示某个事件的描述，请在事件查看器中双击该事件。有关“事件查看器”的详细信息，请参阅事件查看器。

    可在知识库中搜索有关事件 ID 的更新信息。请参阅位于 Microsoft 网站 (http://www.microsoft.com/) 的“搜索知识库”，然后按照该页面上的说明进行操作。

  7. 如果无法启动计算机，请尝试在“最后一次正确的配置”或安全模式下启动计算机，然后删除或禁用最近添加的程序或驱动程序。有关如何以安全模式启动计算机的信息，请参阅在安全模式下启动计算机。有关如何使用“最后一次正确的配置”启动计算机的详细信息，请参阅使用最后一次正确的配置启动计算机。

    要点

    • 当使用最后一次正确的配置时，在最后一次成功启动后对系统设置所做的更改都将丢失。
  8. 移除所有最近安装的硬件（RAM、适配器、硬盘、调制解调器等）。
  9. 确保您有硬件设备的更新驱动程序。另外，请确保您具有最新的系统 BIOS（对于基于 x86 的计算机）或正确的固件（对于基于 Itanium 体系结构的计算机）。设备或硬件制造商可以帮助您获得这些项目。
  10. 运行计算机制造商提供的系统诊断工具，尤其是内存检查。
  11. 通过单击支持资源中的相应链接，确认硬件是针对 Windows Server 2003 家族设计的。
  12. 如果安全模式和其他启动选项不起作用，可以考虑使用故障恢复控制台。只有能够使用基本命令识别和定位有问题的驱动程序和文件的高级用户才建议使用此方法。另外，要使用故障恢复控制台，您必须是管理员。详细信息，请参阅故障恢复控制台概述。


特定停止消息疑难解答

本主题讨论如何对特定停止消息进行疑难解答。有关停止消息疑难解答的常规信息以及信息的其他来源列表，请参阅停止消息疑难解答：常规策略。

可使用系统信息工具收集关于系统设置、问题设备和硬件资源的重要信息。详细信息，请参阅系统信息。

您收到了什么停止消息？

停止消息 0x0000001E

描述文字：KMODE_EXCEPTION_NOT_HANDLED

常见原因：此消息有多个可能的原因。

解决方案：

  1. 可使用 Microsoft 网站上的联机故障分析工具。(http://www.microsoft.com/) 可以使用此工具向 Microsoft 发送错误报告，并使用您的 Microsoft Passport 信息跟踪其状态。可使用错误报告服务或 Web 浏览器来访问 Online Crash Analysis 网站。当它启用时，错误报告服务将监视系统中与操作系统组件和应用程序相关的内核和用户模式错误。通过内核模式报告，您可获得关于导致停止错误的问题或条件的详细信息。详细信息，请参阅系统和程序错误报告概述。
  2. 检查是否有足够的磁盘空间（尤其对于全新安装）。
  3. 禁用所有新安装的驱动程序。您也可能需要禁用与驱动程序或所有新安装的程序相关联的服务。
  4. 如果计算机不能正常启动，请尝试使用最后一次正确的配置或安全模式启动计算机，然后删除或禁用新添加的程序或驱动程序。有关如何以安全模式启动计算机的信息，请参阅在安全模式下启动计算机。有关如何使用“最后一次正确的配置”启动计算机的详细信息，请参阅使用最后一次正确的配置启动计算机。

    要点

    • 当使用最后一次正确的配置时，在最后一次成功启动后对系统设置所做的更改都将丢失。
  5. 请确保您具有最新的系统 BIOS（对于基于 x86 的计算机）或正确的固件（对于基于 Itanium 体系结构的计算机）。如果在执行此步骤时需要帮助，请与硬件制造商联系。

注意

  • 可搜索 Microsoft 网站以获取有关此停止消息的更新信息。为此，请参阅位于 Microsoft 网站 (http://www.microsoft.com) 的“欢迎使用 Microsoft 帮助和支持”，在该页面中单击搜索选项，然后按照页面上的说明操作。键入关键字时，请使用 stop 0x0000001E。

    有关可下载的文章、疑难解答向导和项目的详细信息，请参阅更新的技术信息。

停止消息 0x000000D1

描述文字：DRIVER_IRQL_NOT_LESS_OR_EQUAL

常见原因：尝试访问可分页内存时使用的进程内部请求级别 (IRQL) 过高。这通常是因为驱动程序使用了不正确的地址。禁止内核模式驱动程序以高 IRQL 访问可分页的内存。

解决方案：

  1. 使用 Microsoft 网站中的联机故障分析工具。(http://www.microsoft.com/) 可以使用此工具向 Microsoft 发送错误报告，并使用您的 Microsoft Passport 信息跟踪其状态。可使用错误报告服务或 Web 浏览器来访问 Online Crash Analysis 网站。当它启用时，错误报告服务将监视系统中与操作系统组件和应用程序相关的内核和用户模式错误。通过内核模式报告，您可获得关于导致停止错误的问题或条件的详细信息。详细信息，请参阅系统和程序错误报告概述。
  2. 使用文件签名验证工具，此工具可以识别计算机上未经签名的驱动程序和不兼容的系统文件。由 Windows Server 2003 家族提供的系统文件和设备驱动程序文件具有 Microsoft 数字签名，该签名指示这些文件是未更改的原始系统文件，或者指示其已获 Microsoft 批准可用于 Windows。详细信息，请参阅使用文件签名验证。
  3. 使用设备管理器返回到驱动程序的前一版本。详细信息，请参阅返回到驱动程序的前一版本。
  4. 禁用“停止”消息中标识的驱动程序或所有新安装的驱动程序。
  5. 如果计算机不能正常启动，请尝试使用最后一次正确的配置或安全模式启动计算机，然后删除或禁用新添加的程序或驱动程序。有关如何以安全模式启动计算机的信息，请参阅在安全模式下启动计算机。有关如何使用“最后一次正确的配置”启动计算机的详细信息，请参阅使用最后一次正确的配置启动计算机。

    要点

    • 当使用最后一次正确的配置时，在最后一次成功启动后对系统设置所做的更改都将丢失。
  6. 通过单击支持资源中的相应链接，确认硬件是针对 Windows Server 2003 家族设计的。

注意

  • 可搜索 Microsoft 网站以获取有关此停止消息的更新信息。为此，请参阅位于 Microsoft 网站 (http://www.microsoft.com) 的“欢迎使用 Microsoft 帮助和支持”，然后按照该页面上的说明进行操作。键入关键字时，请使用 stop 0x000000D1。

    有关可下载的文章、疑难解答向导和项目的详细信息，请参阅更新的技术信息。

停止消息 0x000000EA

描述文字：THREAD_STUCK_IN_DEVICE_DRIVER

常见原因：显示驱动程序陷入无限循环。这通常表明视频硬件或显示驱动程序有问题。

解决方案：

  1. 使用 Microsoft 网站中的联机故障分析工具。(http://www.microsoft.com/) 可以使用此工具向 Microsoft 发送错误报告，并使用您的 Microsoft Passport 信息跟踪其状态。可使用错误报告服务或 Web 浏览器来访问 Online Crash Analysis 网站。当它启用时，错误报告服务将监视系统中与操作系统组件和应用程序相关的内核和用户模式错误。通过内核模式报告，您可获得关于导致停止错误的问题或条件的详细信息。详细信息，请参阅系统和程序错误报告概述。
  2. 禁用“停止”消息中标识的驱动程序或所有新近安装的驱动程序。
  3. 如果计算机无法正常启动，请尝试使用最后一次正确的配置或安全模式启动计算机，然后删除或禁用新添加的程序或驱动程序。有关如何以“安全模式”启动计算机的信息，请参阅在安全模式下启动计算机。有关如何使用“最后一次正确的配置”启动计算机的详细信息，请参阅使用最后一次正确的配置启动计算机。

    要点

    • 当使用最后一次正确的配置时，在最后一次成功启动后对系统设置所做的更改都将丢失。
  4. 通过单击支持资源中的相应链接，确认硬件是针对 Windows Server 2003 家族设计的。

注意

  • 可搜索 Microsoft 网站以获取有关此停止消息的更新信息。为此，请参阅位于 Microsoft 网站 (http://www.microsoft.com) 的“欢迎使用 Microsoft 帮助和支持”，请在该页面中单击搜索选项，然后按照页面上的说明操作。键入关键字时，请使用 stop 0x000000EA。

    有关可下载的文章、疑难解答向导和项目的详细信息，请参阅更新的技术信息。

停止消息 0x00000050

描述文字：PAGE_FAULT_IN_NONPAGED_AREA

常见原因：内存中找不到请求的数据。这可能是由打印机驱动程序或远程访问驱动程序造成的。

解决方案：

  1. 使用 Microsoft 网站中的联机故障分析工具。(http://www.microsoft.com/) 可以使用此工具向 Microsoft 发送错误报告，并使用您的 Microsoft Passport 信息跟踪其状态。可使用错误报告服务或 Web 浏览器来访问 Online Crash Analysis 网站。当它启用时，错误报告服务将监视系统中与操作系统组件和应用程序相关的内核和用户模式错误。通过内核模式报告，您可获得关于导致停止错误的问题或条件的详细信息。详细信息，请参阅系统和程序错误报告概述。
  2. 使用设备管理器返回到驱动程序的前一版本。详细信息，请参阅返回到驱动程序的前一版本。
  3. 禁用所有新安装的驱动程序。
  4. 如果计算机不能正常启动，请尝试使用最后一次正确的配置或安全模式启动计算机，然后删除或禁用新添加的程序或驱动程序。有关如何以“安全模式”启动计算机的信息，请参阅在安全模式下启动计算机。有关如何以“最后一次的正确配置”启动计算机的详细信息，请参阅使用最后一次正确的配置启动计算机。

    要点

    • 使用“最后一次正确的配置”时，最后一次成功启动后对系统设置所做的更改都将丢失。
  5. 通过单击支持资源中的相应链接，确认硬件是针对 Windows Server 2003 家族设计的。

注意

  • 可搜索 Microsoft 网站以获取有关此停止消息的更新信息。为此，请参阅位于 Microsoft 网站 (http://www.microsoft.com) 的“欢迎使用 Microsoft 帮助和支持”，请在该页面中单击搜索选项，然后按照页面上的说明操作。键入关键字时，请使用 stop 0x00000050。

    有关可下载的文章、疑难解答向导和项目的详细信息，请参阅更新的技术信息。

停止消息 0x000000BE

描述文字：ATTEMPTED_WRITE_TO_READONLY_MEMORY

常见原因：设备驱动程序尝试写入只读内存。此问题可能在升级过程中发生，但是不只是在升级过程中发生。

解决方案：

  1. 使用 Microsoft 网站 (http://www.microsoft.com/) 中的联机故障分析工具。可使用此工具向 Microsoft 发送错误报告，并使用 Microsoft Passport 信息跟踪其状态。可使用错误报告服务或 Web 浏览器来访问 Online Crash Analysis 网站。当它启用时，错误报告服务将监视系统中与操作系统组件和应用程序相关的内核和用户模式错误。通过内核模式报告，您可获得关于导致停止错误的问题或条件的详细信息。详细信息，请参阅系统和程序错误报告概述。
  2. 通过单击支持资源中的相应链接，确认硬件是针对 Windows Server 2003 家族设计的。
  3. 如果计算机无法正常启动，请尝试使用最后一次正确的配置或安全模式启动计算机，然后删除或禁用新添加的程序或驱动程序。有关如何以“安全模式”启动计算机的信息，请参阅在安全模式下启动计算机。有关如何使用“最后一次正确的配置”启动计算机的详细信息，请参阅使用最后一次正确的配置启动计算机。

    要点

    • 当使用最后一次正确的配置时，在最后一次成功启动后对系统设置所做的更改都将丢失。

注意

  • 可搜索 Microsoft 网站以获取有关此停止消息的更新信息。为此，请参阅位于 Microsoft 网站 (http://www.microsoft.com) 的“欢迎使用 Microsoft 帮助和支持”，请在该页面中单击搜索选项，然后按照页面上的说明操作。键入关键字时，请使用 stop 0x000000BE。

    有关可下载的文章、疑难解答向导和项目的详细信息，请参阅更新的技术信息。

现有安装上的停止消息 0x0000000A

描述文字：IRQL_NOT_LESS_OR_EQUAL

通常的原因：驱动程序使用了不正确的内存地址。

解决方案：

  1. 使用 Microsoft 网站 (http://www.microsoft.com/) 中的联机故障分析工具。可使用此工具向 Microsoft 发送错误报告，并使用 Microsoft Passport 信息跟踪其状态。可使用错误报告服务或 Web 浏览器来访问 Online Crash Analysis 网站。当它启用时，错误报告服务将监视系统中与操作系统组件和应用程序相关的内核和用户模式错误。通过内核模式报告，您可获得关于导致停止错误的问题或条件的详细信息。详细信息，请参阅系统和程序错误报告概述。
  2. 如果能启动操作系统，则请检查事件查看器中的系统日志，以获取有助于确定导致问题的设备或驱动程序的其他信息。 XOX
  3. 通过单击支持资源中的相应链接，确认硬件是针对 Windows Server 2003 家族设计的。
  4. 禁用所有新安装的驱动程序并删除所有新添加的程序。
  5. 如果计算机不能正常启动，请尝试使用最后一次正确的配置或安全模式启动计算机，然后删除或禁用新添加的程序或驱动程序。有关如何以“安全模式”启动计算机的信息，请参阅在安全模式下启动计算机。有关如何使用“最后一次正确的配置”启动计算机的详细信息，请参阅使用最后一次正确的配置启动计算机。

    要点

    • 当使用最后一次正确的配置时，在最后一次成功启动后对系统设置所做的更改都将丢失。
  6. 移除所有新安装的硬件（RAM、适配器、硬盘、调制解调器等）。
  7. 确保您有硬件设备的更新驱动程序。另外，请确保您具有最新的系统 BIOS（对于基于 x86 的计算机）或正确的固件（对于基于 Itanium 体系结构的计算机）。设备制造商可帮助您获得这些项目。
  8. 运行硬件供应商提供的系统诊断工具，尤其是内存检查。
  9. 禁用 BIOS（对于基于 x86 的计算机）或 EFI（对于基于 Itanium 体系结构的计算机）中的内存缓存。如果在执行此步骤时需要帮助，请与硬件制造商联系。

注意

  • 可搜索 Microsoft 网站以获取有关此停止消息的更新信息。为此，请参阅位于 Microsoft 网站 (http://www.microsoft.com) 的“欢迎使用 Microsoft 帮助和支持”，请在该页面中单击搜索选项，然后按照页面上的说明操作。键入关键字时，请使用 stop 0x0000000A。

    有关可下载的文章、疑难解答向导和项目的详细信息，请参阅更新的技术信息。

全新安装的停止消息 0x0000000A

描述文字：IRQL_NOT_LESS_OR_EQUAL

常见原因： 驱动程序正在使用不正确的内存地址。

解决方案：

  1. 使用 Microsoft 网站 (http://www.microsoft.com/) 中的联机故障分析工具。可使用此工具向 Microsoft 发送错误报告，并使用 Microsoft Passport 信息跟踪其状态。可使用错误报告服务或 Web 浏览器来访问 Online Crash Analysis 网站。当它启用时，错误报告服务将监视系统中与操作系统组件和应用程序相关的内核和用户模式错误。通过内核模式报告，您可获得关于导致停止错误的问题或条件的详细信息。详细信息，请参阅系统和程序错误报告概述。
  2. 安装过程中，在出现“安装程序正在检查计算机的硬件配置”消息时，按 F5。系统提示时请选择正确的计算机类型。例如，如果是单处理器计算机，请选择“标准 PC”。
  3. 通过单击支持资源中的相应链接，确认硬件是针对 Windows Server 2003 家族设计的。
  4. 禁用 BIOS（对于基于 x86 的计算机）或 EFI（对于基于 Itanium 体系结构的计算机）中的内存缓存。如果在执行此步骤时需要帮助，请与硬件制造商联系。
  5. 删除所有适配器并断开所有不必要的硬件设备。
  6. 如果您正在使用 SCSI 适配器，请从适配器供应商那里获取最新的驱动程序，禁用 sync 协商，检查终止，并检查设备的 SCSI 标识。
  7. 如果您正在使用集成设备电路 (IDE) 设备，请将置于主板的 IDE 端口定义为主通道。检查 IDE 设备的主/从设置。移除除硬盘外的所有 IDE 设备。详细信息，请参阅硬件制造商的文档。
  8. 运行硬件供应商提供的系统诊断工具，尤其是内存检查。
  9. 如果计算机不能正常启动，请尝试使用最后一次正确的配置或安全模式启动计算机，然后删除或禁用新添加的程序或驱动程序。有关如何以“安全模式”启动计算机的信息，请参阅在安全模式下启动计算机。有关如何以“最后一次的正确配置”启动计算机的详细信息，请参阅使用最后一次正确的配置启动计算机。

    要点

    • 使用“最后一次正确的配置”时，最后一次成功启动后对系统设置所做的更改都将丢失。

注意

  • 可搜索 Microsoft 网站以获取有关此停止消息的更新信息。为此，请参阅位于 Microsoft 网站 (http://www.microsoft.com) 的“欢迎使用 Microsoft 帮助和支持”，请在该页面中单击搜索选项，然后按照页面上的说明操作。键入关键字时，请使用 stop 0x0000000A。

    有关可下载的文章、疑难解答向导和项目的详细信息，请参阅更新的技术信息。

停止消息 0x00000023 和 0x00000024

描述文字：FAT_FILE_SYSTEM 或 NTFS_FILE_SYSTEM

常见原因：硬盘被拆分或者文件 I/O 过大。此停止错误也可能是由驱动器镜像或某个防病毒软件引起的。

解决方案：

  1. 使用 Microsoft 网站 (http://www.microsoft.com/) 中的联机故障分析工具。可使用此工具向 Microsoft 发送错误报告，并使用 Microsoft Passport 信息跟踪其状态。可使用错误报告服务或 Web 浏览器来访问 Online Crash Analysis 网站。当它启用时，错误报告服务将监视系统中与操作系统组件和应用程序相关的内核和用户模式错误。通过内核模式报告，您可获得关于导致停止错误的问题或条件的详细信息。详细信息，请参阅系统和程序错误报告概述。
  2. 禁用所有防病毒或备份程序，并禁用所有碎片整理实用程序。
  3. 运行 chkdsk，然后重新启动计算机，可以检查硬盘的损坏情况。如果无法运行 chkdsk，则可能必须将硬盘移至另一台运行 Windows Server 2003 家族产品的计算机，然后再运行 chkdsk 命令。详细信息，请参阅 Chkdsk。（请注意，通过故障恢复控制台中有限的一组选项，就可以使用 chkdsk。）
  4. 如果计算机不能正常启动，请尝试使用最后一次正确的配置或安全模式启动计算机，然后删除或禁用新添加的程序或驱动程序。有关如何以“安全模式”启动计算机的信息，请参阅在安全模式下启动计算机。有关如何以“最后一次的正确配置”启动计算机的详细信息，请参阅使用最后一次正确的配置启动计算机。

    要点

    • 使用“最后一次正确的配置”时，最后一次成功启动后对系统设置所做的更改都将丢失。

注意

  • 可在 Microsoft 网站中搜索有关这些停止消息的更新信息。为此，请参阅位于 Microsoft 网站 (http://www.microsoft.com) 的“欢迎使用 Microsoft 帮助和支持”，请在该页面中单击搜索选项，然后按照页面上的说明操作。键入关键字时，请使用 stop 0x00000023 或 stop 0x00000024。

    有关可下载的文章、疑难解答向导和项目的详细信息，请参阅更新的技术信息。

停止消息 0x0000007B

描述文字：INACCESSIBLE_BOOT_DEVICE

常见原因：I/O 系统（通常是启动设备或文件系统）初始化过程中出现问题。

解决方案：

  1. 检查计算机上的病毒。启动扇区中有病毒时经常显示此停止消息。
  2. 修复或恢复硬盘。有关修复硬盘的方法，请参阅修复概述和故障恢复控制台概述。
  3. 删除所有新添加的硬盘或控制器。
  4. 如果您正在使用 SCSI 适配器，请从适配器供应商那里获取最新的驱动程序、禁用 sync 协商、检查终止并检查设备的 SCSI ID。
  5. 如果您正在使用集成设备电路 (IDE) 设备，请将置于主板的 IDE 端口定义为主通道。检查 IDE 设备的主/从设置。移除除硬盘外的所有 IDE 设备。详细信息，请参阅硬件制造商的文档。
  6. 运行 chkdsk，检查硬盘是否损坏。如果无法运行 chkdsk，则可能必须将硬盘移至另一台运行 Windows Server 2003 家族产品的计算机，然后再运行 chkdsk 命令。详细信息，请参阅 Chkdsk。（请注意，通过故障恢复控制台中有限的一组选项，就可以使用 chkdsk。）
  7. 如果计算机不能正常启动，请尝试使用最后一次正确的配置启动计算机。有关如何以“最后一次的正确配置”启动计算机的详细信息，请参阅使用最后一次正确的配置启动计算机。

    要点

    • 使用“最后一次正确的配置”时，最后一次成功启动后对系统设置所做的更改都将丢失。

注意

  • 可搜索 Microsoft 网站以获取有关此停止消息的更新信息。为此，请参阅位于 Microsoft 网站 (http://www.microsoft.com) 的“欢迎使用 Microsoft 帮助和支持”，请在该页面中单击搜索选项，然后按照页面上的说明操作。键入关键字时，请使用 stop 0x0000007B。

    有关可下载的文章、疑难解答向导和项目的详细信息，请参阅更新的技术信息。

停止消息 0x0000007F

描述文字：UNEXPECTED_KERNEL_MODE_TRAP

常见原因：存在硬件或软件问题。这通常是硬件故障引起的。

解决方案：

  1. 使用 Microsoft 网站 (http://www.microsoft.com/) 中的联机故障分析工具。可使用此工具向 Microsoft 发送错误报告，并使用 Microsoft Passport 信息跟踪其状态。可使用错误报告服务或 Web 浏览器来访问 Online Crash Analysis 网站。当它启用时，错误报告服务将监视系统中与操作系统组件和应用程序相关的内核和用户模式错误。通过内核模式报告，您可获得关于导致停止错误的问题或条件的详细信息。详细信息，请参阅系统和程序错误报告概述。
  2. 运行硬件供应商提供的系统诊断工具，尤其是内存检查。内存有故障或不匹配时经常显示此停止消息。
  3. 在 BIOS（对于基于 x86 的计算机）或 EFI（对于基于 Itanium 体系结构的计算机）中禁用内存缓存。如果在执行此步骤时需要帮助，请与硬件制造商联系。
  4. 通过单击支持资源中的相应链接，确认硬件是针对 Windows Server 2003 家族设计的。
  5. 如果计算机无法正常启动，请尝试使用最后一次正确的配置或安全模式启动计算机，然后删除或禁用新添加的程序或驱动程序。有关如何以“安全模式”启动计算机的信息，请参阅在安全模式下启动计算机。有关如何以“最后一次的正确配置”启动计算机的详细信息，请参阅使用最后一次正确的配置启动计算机。

    要点

    • 使用“最后一次正确的配置”时，最后一次成功启动后对系统设置所做的更改都将丢失。

注意

  • 可搜索 Microsoft 网站以获取有关此停止消息的更新信息。为此，请参阅位于 Microsoft 网站 (http://www.microsoft.com) 的“欢迎使用 Microsoft 帮助和支持”，请在该页面中单击搜索选项，然后按照页面上的说明操作。键入关键字时，请使用 stop 0x0000007F。

    有关可下载的文章、疑难解答向导和项目的详细信息，请参阅更新的技术信息。

停止消息 0x0000009F

描述文字：DRIVER_POWER_STATE_FAILURE

常见原因：驱动程序处于不一致或无效的电源状态。

解决方案：

  1. 使用 Microsoft 网站 (http://www.microsoft.com/) 中的联机故障分析工具。可使用此工具向 Microsoft 发送错误报告，并使用 Microsoft Passport 信息跟踪其状态。可使用错误报告服务或 Web 浏览器来访问 Online Crash Analysis 网站。当它启用时，错误报告服务将监视系统中与操作系统组件和应用程序相关的内核和用户模式错误。通过内核模式报告，您可获得关于导致停止错误的问题或条件的详细信息。详细信息，请参阅系统和程序错误报告概述。
  2. 禁用“停止”消息中标识的驱动程序或所有新安装的驱动程序。
  3. 更新所有使用筛选器驱动程序的软件，如防病毒或备份程序。
  4. 通过单击支持资源中的相应链接，确认硬件是针对 Windows Server 2003 家族设计的。
  5. 如果计算机无法正常启动，请尝试使用最后一次正确的配置或安全模式启动计算机，然后删除或禁用新添加的程序或驱动程序。有关如何以“安全模式”启动计算机的信息，请参阅在安全模式下启动计算机。有关如何以“最后一次的正确配置”启动计算机的详细信息，请参阅使用最后一次正确的配置启动计算机。

    要点

    • 当使用最后一次正确的配置时，在最后一次成功启动后对系统设置所做的更改都将丢失。

注意

  • 可搜索 Microsoft 网站以获取有关此停止消息的更新信息。为此，请转到 Microsoft 网站 (http://www.microsoft.com)，单击搜索选项，然后按照页面中的说明进行操作。键入关键字时，请使用 stop 0x0000009F。

    有关可下载的文章、疑难解答向导和项目的详细信息，请参阅更新的技术信息。

停止消息 0xC000021A

描述文字：FATAL_SYSTEM_ERROR

常见原因：系统进程“Windows Logon Process”（Windows 登录进程）意外终止。

解决方案：

  1. 使用 Microsoft 网站 (http://www.microsoft.com/) 中的联机故障分析工具。可使用此工具向 Microsoft 发送错误报告，并使用 Microsoft Passport 信息跟踪其状态。可使用错误报告服务或 Web 浏览器来访问 Online Crash Analysis 网站。当它启用时，错误报告服务将监视系统中与操作系统组件和应用程序相关的内核和用户模式错误。通过内核模式报告，您可获得关于导致停止错误的问题或条件的详细信息。详细信息，请参阅系统和程序错误报告概述。
  2. 禁用“停止”消息中标识的驱动程序或所有新近安装的驱动程序。
  3. 如果计算机无法正常启动，请尝试使用最后一次正确的配置或安全模式启动计算机，然后删除或禁用新添加的程序或驱动程序。有关如何以“安全模式”启动计算机的信息，请参阅在安全模式下启动计算机。有关如何以“最后一次的正确配置”启动计算机的详细信息，请参阅使用最后一次正确的配置启动计算机。

    要点

    • 使用“最后一次正确的配置”时，最后一次成功启动后对系统设置所做的更改都将丢失。
  4. 通过单击支持资源中的相应链接，确认硬件是针对 Windows Server 2003 家族设计的。

注意

  • 可搜索 Microsoft 网站以获取有关此停止消息的更新信息。为此，请参阅位于 Microsoft 网站 (http://www.microsoft.com) 的“欢迎使用 Microsoft 帮助和支持”，请在该页面中单击搜索选项，然后按照页面上的说明操作。键入关键字时，请使用 stop 0xC000021A。

    有关可下载的文章、疑难解答向导和项目的详细信息，请参阅更新的技术信息。

停止消息 0xC0000221

描述文字：BAD_IMAGE_CHECKSUM

常见原因：此消息可能是由已损坏的系统文件或驱动程序或者硬件问题引起的。

解决方案：

  1. 使用 Microsoft 网站 (http://www.microsoft.com/) 中的联机故障分析工具。可使用此工具向 Microsoft 发送错误报告，并使用 Microsoft Passport 信息跟踪其状态。可使用错误报告服务或 Web 浏览器来访问 Online Crash Analysis 网站。当它启用时，错误报告服务将监视系统中与操作系统组件和应用程序相关的内核和用户模式错误。通过内核模式报告，您可获得关于导致停止错误的问题或条件的详细信息。详细信息，请参阅系统和程序错误报告概述。
  2. 替换已标识的文件。
  3. 如果计算机不能正常启动，请尝试使用最后一次正确的配置或安全模式启动计算机，然后替换该文件。有关如何以安全模式启动计算机的信息，请参阅在安全模式下启动计算机。有关如何以“最后一次的正确配置”启动计算机的详细信息，请参阅使用最后一次正确的配置启动计算机。

    要点

    • 使用“最后一次正确的配置”时，最后一次成功启动后对系统设置所做的更改都将丢失。

注意

  • 可搜索 Microsoft 网站以获取有关此停止消息的更新信息。为此，请参阅位于 Microsoft 网站 (http://www.microsoft.com) 的“欢迎使用 Microsoft 帮助和支持”，请在该页面中单击搜索选项，然后按照页面上的说明操作。键入关键字时，请使用 stop 0xC0000221。

    有关可下载的文章、疑难解答向导和项目的详细信息，请参阅更新的技术信息。

停止消息 0xC0000218

描述文字：UNKNOWN_HARD_ERROR

常见原因：注册表文件可能已损坏。

解决方案：

  1. 使用 Microsoft 网站 (http://www.microsoft.com/) 中的联机故障分析工具。可使用此工具向 Microsoft 发送错误报告，并使用 Microsoft Passport 信息跟踪其状态。可使用错误报告服务或 Web 浏览器来访问 Online Crash Analysis 网站。当它启用时，错误报告服务将监视系统中与操作系统组件和应用程序相关的内核和用户模式错误。通过内核模式报告，您可获得关于导致停止错误的问题或条件的详细信息。详细信息，请参阅系统和程序错误报告概述。
  2. 如果计算机不能正常启动，请尝试使用最后一次正确的配置启动计算机。有关如何使用“最后一次正确的配置”启动计算机的详细信息，请参阅使用最后一次正确的配置启动计算机。

    要点

    • 当使用最后一次正确的配置时，在最后一次成功启动后对系统设置所做的更改都将丢失。
  3. 如果您拥有自动系统故障恢复 (ASR) 备份，可能需要使用此恢复选项。详细信息，请参阅自动系统故障恢复 (ASR) 概述。

注意

  • 可搜索 Microsoft 网站以获取有关此停止消息的更新信息。为此，请参阅位于 Microsoft 网站 (http://www.microsoft.com) 的“欢迎使用 Microsoft 帮助和支持”，请在该页面中单击搜索选项，然后按照页面上的说明操作。键入关键字时，请使用 stop 0xC0000218。

    有关可下载的文章、疑难解答向导和项目的详细信息，请参阅更新的技术信息。


在群集节点上安装和升级

使用 Windows Server 2003, Enterprise Edition 或 Windows Server 2003, Datacenter Edition，您可以使用群集确保用户能够连续访问基于服务器的重要资源。使用群集，您可以创建几个群集节点，这些节点对用户来说就像是一台服务器。如果群集中的某个节点出现故障，另一个节点将立即开始提供服务（此过程称为故障转移）。执行关键任务的应用程序和资源可以持续地保持可用状态。

下列主题介绍了在群集节点上执行升级或安装的各种选项。

  • 在执行升级之前，请参阅清单：升级群集的准备工作
  • 在执行全新安装之前，请参阅清单：安装群集的准备工作
  • 有关在群集节点上执行升级或安装的提示，请参阅最佳操作
  • 有关特定任务的帮助信息，请参阅如何
  • 有关一般背景知识，请参阅概念
  • 有关疑难解答的说明，请参阅疑难解答


清单

  • 清单：升级群集的准备工作
  • 清单：安装群集的准备工作


清单：升级群集的准备工作

步骤 | 参考
检查您的硬件（包括群集存储硬件）是否与 Windows Server 2003, Enterprise Edition 兼容。

请注意，地理位置分散（多数节点集）的服务器群集是建立在网络和存储结构的基础上，其特征与标准仲裁设备服务器群集有很大差别，同样，它们是在单独测试程序下进行认证的。如果您正在考虑将现有服务器群集转换成地理位置分散的服务器群集，则必须联络硬件供应商来获取已通过 Microsoft 认证的地理位置分散的服务器群集配置。

有关多数节点集服务器群集的详细信息，请参阅选择群集模型。

硬件兼容性
咨询群集存储硬件的制造商，并确保您具有所需的驱动程序。 | 大容量存储驱动程序和安装过程
复查升级群集节点的概念，选择要使用的方法，并复查所选方法的说明。

警告

  • 如果要使用滚动升级（或对一个或多个资源进行脱机滚动升级）外的任何方法，一定要仔细查看并按照指示操作，以防损坏群集存储。即，对于滚动升级外的方法，一定要在一个节点上先完成升级，并启动群集服务之后，再允许另一节点获取对于群集存储的访问权。
概念

如何
复查升级操作系统的清单。 | 清单：执行升级
复查启动和运行安装程序的过程。 在基于 x86 的计算机上启动安装程序

在基于 Itanium 体系结构的计算机上启动安装程序
执行为升级群集节点所选择的方法。 | 如何


清单：安装群集的准备工作

要点

  • 如果要使用共享存储设备，应确保先在群集中的一台服务器上安装与运行 Windows Server 2003, Enterprise Edition 和群集服务，然后再在另一台服务器上启动操作系统。如果在一台服务器上运行群集服务之前在多个服务器上启动了操作系统，则有可能损坏群集存储。配置好第一台服务器后，即可同时安装其他服务器。
步骤 | 参考
检查您的硬件（包括群集存储硬件）是否与 Windows Server 2003, Enterprise Edition 兼容。 | 硬件兼容性
请咨询群集存储硬件的制造商，并确保您具有所需的驱动程序。 | 大容量存储驱动程序和安装过程
计划群集的基本网络详细信息，包括网络适配器、IP 寻址以及群集将使用的名称和帐户等详细信息。而且，还要计划用于保存群集配置数据的卷。 | 规划和准备群集安装
请检查安装操作系统的清单并决定诸如是否安装其他组件之类的事项。 | 清单：执行全新安装
完成创建服务器群集的其他步骤。 | 清单：计划并创建服务器群集


最佳操作

在群集节点上进行安装和升级操作时请按照适当的清单进行操作

  • 清单：升级群集的准备工作
  • 清单：安装群集的准备工作

新建群集时请使用典型（完全）配置选项

使用群集管理器的“新建服务器群集向导”，您可以在“典型”（完全）配置和“高级”（最小）配置选项之间进行选择。“典型”配置适合于大多数安装，而且将获得完全配置的群集。“高级”配置选项仅用于具有“新建服务器群集向导”无法验证的复杂存储配置的群集，或者用于您不希望群集在其中管理所有存储的配置。下列示例描述了每一种情况：

  • 在一些复杂的存储方案中（如包含多个交换机的纤维管道交换构造），特殊的存储单元在群集中的每台计算机上可能具有不同的标识。虽然这是有效的存储配置，但它违背了“新建服务器群集向导”中的存储验证启发方法。如果您有此类存储方案，则使用“典型”配置选项创建群集时可能会收到错误信息。如果存储配置设置正确，则可通过重新启动“新建服务器群集向导”并选择“高级”配置选项来禁用存储验证启发方法并避免此错误。
  • 在群集中的特定节点上，您可能希望群集某些磁盘，或保留某些磁盘为专用。“典型”配置选项将所有磁盘配置为群集磁盘，并为它们创建群集资源。不过，通过“高级”配置选项，可将某些磁盘保留为专用，因为该配置创建的群集中只有仲裁磁盘才由群集管理（如果选择将物理磁盘作为仲裁资源）。群集创建后，必须使用群集管理器才能添加需要由群集管理的任何其他磁盘。

详细信息，请参阅存储配置选项。

要点

  • 如果使用共享存储设备：在创建群集之前，打开计算机并启动操作系统时应确保只有一个节点可以访问群集磁盘，这一点非常重要。否则，群集磁盘可能会损坏。在创建群集之前，为了防止群集磁盘损坏，请只保留一个群集节点并关闭其他所有群集节点，也可使用其他技术（如 LUN 屏蔽、选择性表示或分区）保护群集磁盘。另外，开始安装第 2 个或后续的节点前，请确保所有由群集管理的磁盘都具有与它们相关的磁盘资源。如果这些磁盘此时没有与它们相关的磁盘资源，则磁盘数据将损坏，因为磁盘不受保护，并且会有多个节点同时尝试连接到它们。
  • 不要使用“管理您的服务器”来配置群集节点。

保证服务器群集的安全

为了保证服务器群集免受未经授权的用户侵扰，请符合以下要求：

  • 不要将群集服务帐户设置成域 Administrators 组的成员。为群集服务帐户授予尽可能小的用户权利，这样可以在该帐户被泄漏时避免潜在的安全问题。
  • 限制并审核对共享数据（如群集磁盘上的文件和文件夹）的访问权限。
  • 限制客户端对群集资源的访问权限。
  • 将不同的帐户用于群集服务和群集中的应用程序。
  • 将不同的群集服务帐户用于多个群集。
  • 如果从 Windows NT 4.0 或 Windows 2000 群集中进行了升级，请从所有非管理员用户帐户删除对于仲裁磁盘（包含仲裁日志）上的 Windows\Cluster 目录和 MSCS 目录的读权限。
  • 请按照标准最佳操作来保证服务器的安全。

如果要审核对共享数据的访问权限，请在所有群集节点上启用审核。详细信息，请参阅保证群集中共享数据的安全。有关群集服务帐户要求的用户权利的详细信息，请参阅更改运行群集服务的帐户。有关服务器群集安全的详细信息，请参阅管理群集安全。有关保证服务器安全的最佳操作的详细信息，请参阅安全性的最佳操作。

请参阅其他服务器群集的最佳操作

详细信息，请参阅服务器群集的最佳操作。


如何

以下部分说明如何使用 Windows Server 2003, Enterprise Edition 设置群集。 在开始安装群集或升级群集之前，请复查清单：升级群集的准备工作或清单：安装群集的准备工作。

  • 从 Windows 2000 升级群集
  • 从 Windows NT 4.0 升级群集


从 Windows 2000 升级群集

如果正在群集节点上执行从 Windows 2000 到 Windows Server 2003, Enterprise Edition 的升级，则也许可以执行操作系统的“滚动升级”。在滚动升级中，依次升级每个节点上的操作系统，从而确保始终有一个节点可用来处理客户端请求。在升级操作系统时，群集服务也被自动升级。滚动升级提供了群集服务的最大可用性，并将管理复杂性降到最小。

下列主题描述了从 Windows 2000 升级到 Windows Server 2003, Enterprise Edition 的过程和步骤。

  • 从 Windows 2000 执行滚动升级
  • 从 Windows 2000 执行最后一个节点的滚动升级
  • 使用提供的脚本在包含 IIS 的群集上从 Windows 2000 进行升级
  • 在不使用提供的脚本的情况下在包含 IIS 的群集上从 Windows 2000 进行升级
  • 在包含消息队列的群集上从 Windows 2000 进行升级


从 Windows 2000 执行滚动升级

Microsoft Windows 图形

从 Windows 2000 执行滚动升级

  1. 请确认您的系统正在运行 Windows 2000 并使用滚动升级期间支持的资源（这些内容在“相关主题”的“滚动升级期间的资源行为”中做了介绍）。
  2. 请确认您的硬件是否适用于 Windows Server 2003, Enterprise Edition 或是否与其兼容。详细信息，请参阅“相关主题”中的“清单：升级群集的准备工作”。
  3. 在“群集管理器”中单击要首先升级的节点。
  4. 单击“文件”菜单上的“暂停节点”。
  5. 在右面的详细信息窗格中，单击“活动组”。
  6. 在详细信息窗格中，单击一个组，然后单击“文件”菜单上的“移动组”。对于列出的每一个组，重复该步骤。

    在移动这些组并在另一个节点上重新启动它们的这段时间里，服务将被中断。移动组之后，一个节点处于空闲状态，另一个节点处理所有客户端请求。

  7. 使用 Windows Server 2003, Enterprise Edition 安装程序从 Windows 2000 升级暂停的节点。

    有关启动安装程序的信息，请参阅“相关主题”。

    安装程序检查暂停节点上的早期群集版本，并自动为群集安装 Windows Server 2003, Enterprise Edition。 该节点在升级快结束时会自动重新加入群集，但依然处于暂停状态，并且不处理任何与群集相关的工作。

    注意

    • 开始安装过程时，您将接收到一个有关使用安装程序的 tempdrive 选项的警告消息。如果已执行上述步骤，可以单击“确定”并继续安装过程，不必使用此选项。
    • 当以管理员身份首次登录新升级的节点时，将显示“管理您的服务器”。关闭“管理您的服务器”，继续进行滚动升级。
  8. 要验证已升级的节点功能完全正常，请执行验证测试，例如确认操作系统能够识别您的网络连接，并通过设备管理器确保操作系统能够识别所有存储设备。
  9. 单击“群集管理器”中的暂停节点，然后单击“文件”菜单上的“继续节点”。

    注意

    • 在已升级的节点上首次使用“群集管理器”时，该管理器将提示您“打开到群集的连接”。在“群集或服务器名”字段中，键入一个句点 (.)。该操作将您连接到已升级的本地节点上的群集。尽管可以通过键入群集名称连接到群集，但是如果这样做，您将被连接到 Windows 2000 节点上的群集，然后必须响应几次警告消息。
  10. 对其余节点重复上述步骤。

要点

  • 有关滚动升级期间支持何种资源的信息，请参阅“相关主题”。

注意

  • 当您将某个群集节点从 Windows 2000 升级到上述某个产品之后，必须在重新启动群集服务之前，在每个群集节点上使用同时属于 Domain Admins 组和 Administrators 组的帐户登录。即使在每个群集节点上 Domain Admins 组已经是 Administrators 组的成员，也必须执行此步骤。
  • 要执行该过程，您必须是本地计算机上 Administrators 组的成员，或者您必须被委派了适当的权限。如果将计算机加入域，Domain Admins 组的成员也可以执行这个过程。作为安全性最佳操作，可以考虑使用运行方式来执行这个过程。

相关主题


从 Windows 2000 执行最后一个节点的滚动升级

Microsoft Windows 图形

从 Windows 2000 执行最后一个节点的滚动升级

  1. 确认系统正在运行 Windows 2000。
  2. 请确认您的硬件是否适用于 Windows Server 2003, Enterprise Edition 或是否与其兼容。详细信息，请参阅“相关主题”中的“清单：升级群集的准备工作”。
  3. 使用“相关主题”中的“滚动升级期间的资源行为”信息，标识 Windows Server 2003, Enterprise Edition 不支持的群集中的资源，并将其删除。
  4. 再次使用“相关主题”中的“滚动升级期间的资源行为”信息，识别在滚动升级期间群集中不受支持，而且在“相关主题”中所列出的其他特定技术的升级过程没有涉及到的资源。
  5. 双击“群集管理器”控制台树中的 Groups 文件夹，将上一步中识别出的所有资源移动到单个节点中。单击包含资源的组，然后单击“文件”菜单中的“移动组”。
  6. 如果节点未寄存在上一步中移动的资源，则请升级这些节点上的操作系统。升级每个节点后，如果显示“管理您的服务器”，请将其关闭。
  7. 将上一步中移动的所有资源从尚未升级的节点移动到新升级的节点之一。
  8. 转移所有资源后，即可升级最后一个节点。升级完成后，如果显示“管理您的服务器”对话框，请将其关闭。

注意

  • 当您将某个群集节点从 Windows 2000 升级到上述某个产品之后，必须在重新启动群集服务之前，在每个群集节点上使用同时属于 Domain Admins 组和 Administrators 组的帐户登录。即使在每个群集节点上 Domain Admins 组已经是 Administrators 组的成员，也必须执行此步骤。
  • 要执行该过程，您必须是本地计算机上 Administrators 组的成员，或者您必须被委派了适当的权限。如果将计算机加入域，Domain Admins 组的成员也可以执行这个过程。作为安全性最佳操作，可以考虑使用运行方式来执行这个过程。
  • 不强制要求将所有资源移动到单个节点并最后升级这个节点，但遵循上述过程一般会让您获得不支持滚动升级的资源的最高可用性。

相关主题


使用提供的脚本在包含 IIS 的群集上从 Windows 2000 进行升级

Microsoft Windows 图形

使用提供的脚本在包含 IIS 的群集上从 Windows 2000 进行升级

  1. 请确认您的硬件是否适用于 Windows Server 2003, Enterprise Edition 或是否与其兼容。
  2. 将所有节点（除包含 IIS 实例资源的节点之外）从 Windows 2000 升级到 Windows Server 2003, Enterprise Edition。可执行滚动升级或者非滚动升级，只要适合于您的安装即可。升级前，请确保删除 Windows Server 2003, Enterprise Edition 不支持的资源。详细信息，请参阅“相关主题”。
  3. 如果要升级的群集上不存在分布式事务协调器 (DTC) 资源，请在已升级的节点上为此群集创建一个 DTC 资源。
  4. 在已升级的节点上，打开命令提示符并定位到 %systemroot%\system32\inetsrv 目录。
  5. 类型：

    iis_switch 群集名 [组名]

    值 | 描述
    群集名 | 已升级的群集中的物理节点的名称或虚拟服务器的名称。
    组名 | 此值是可选的。默认情况下，该脚本将升级群集中的所有 IIS Web 和 FTP 资源。但是，如果您仅希望升级一个特定组，则可指定该资源组的名称。

    要点

  • 当您运行脚本时，包含 IIS 资源的资源组必须位于 Windows 2000 节点。
  • 该脚本包括可使具有新建一般脚本资源的资源组联机的步骤。然而，如果在运行脚本前组中的所有资源已联机，则该脚本只使组联机。如果在运行脚本前组只是部分联机或已脱机，这时脚本会使整个组脱机，而且在升级之后不会将任何资源返回联机状态。
  • 脚本执行完毕后，新建的资源可能立即失败。这是因为 W3SVC 服务已被禁用。通过执行如下步骤可以纠正此问题。
  1. 脚本执行完毕后，请使新建的一般脚本资源脱机，然后启动该节点上的 W3SVC 服务并将 W3SVC 设置为自动启动。
  2. 使一般脚本资源联机。
  3. 使用 IIS 启动已升级的节点上的网站。
  4. 将最后一个节点升级到 Windows Server 2003, Enterprise Edition。升级完毕后，请启动该节点上的 W3SVC 服务并将该服务设置为自动启动。
  5. 如果需要，将最后升级的节点添加到新建的一般脚本资源的“可能的所有者”列表。详细信息，请参阅“相关主题”中的“指定可以拥有资源的节点”。

注意

  • 当您将某个群集节点从 Windows 2000 升级到上述某个产品之后，必须在重新启动群集服务之前，在每个群集节点上使用同时属于 Domain Admins 组和 Administrators 组的帐户登录。即使在每个群集节点上 Domain Admins 组已经是 Administrators 组的成员，也必须执行此步骤。
  • 要执行该过程，您必须是本地计算机上 Administrators 组的成员，或者您必须被委派了适当的权限。如果将计算机加入域，Domain Admins 组的成员也可以执行这个过程。作为安全性最佳操作，可以考虑使用运行方式来执行这个过程。
  • XOX
  • 要聚集 Windows Server 2003, Enterprise Edition 上的 IIS，在该群集上还必须有 DTC 资源。
  • 该脚本将不升级群集组中的 IIS 资源。如果群集组中存在 IIS 资源，可以使用“相关主题”中的过程“在不使用提供的脚本的情况下，在包含 IIS 资源的群集上从 Windows 2000 升级”。
  • 只有已升级的节点才可能是本过程中创建的一般脚本资源的所有者，因为此资源类型在 Windows 2000 中不受支持。
  • 如果选择不使用提供的脚本而是手动执行每一步骤，请参阅“相关主题”中的“在不使用提供的脚本的情况下，在包含 IIS 的群集上从 Windows 2000 升级”。
  • 有关硬件兼容性的详细信息，请参阅支持资源。

相关主题


在不使用提供的脚本的情况下，在包含 IIS 的群集上从 Windows 2000 进行升级

Microsoft Windows 图形

在不使用提供的脚本的情况下，在包含 IIS 的群集上从 Windows 2000 进行升级

  1. 请确认您的硬件是否适用于 Windows Server 2003, Enterprise Edition 或是否与其兼容。
  2. 将所有节点（除包含 IIS 实例资源的节点之外）从 Windows 2000 升级到 Windows Server 2003, Enterprise Edition。可执行适用于您的安装的滚动升级或非滚动升级。升级前，请确保删除 Windows Server 2003, Enterprise Edition 不支持的资源。详细信息，请参阅“相关主题”。
  3. 如果要升级的群集上不存在分布式事务协调器 (DTC) 资源，请在已升级的节点上为此群集创建一个 DTC 资源。
  4. 在 Windows 2000 节点上，请注意 IIS 实例资源的依存性。请注意依赖于 IIS 资源的资源以及 IIS 本身所依赖的资源。
  5. 使包含 IIS 实例资源的组脱机。有关如何执行此操作的详细信息，请参阅“相关主题”中的“使资源脱机”。
  6. 删除 IIS 实例资源上的所有依存性。
  7. 删除 IIS 实例资源。
  8. 将该组移到 Windows Server 2003, Enterprise Edition 节点，并按照“相关主题”中的“清单：创建群集 IIS Web 或 FTP 服务”中说明的过程创建一般脚本资源。

    注意

    • 作为本步骤的一部分，请重新创建一般脚本资源的依存性（与已删除的 IIS 资源的依存性相同）。使依赖于 IIS 资源的每个项目都依赖于一般脚本资源。同时使一般脚本资源依赖于 IIS 以前依赖的项目。
    • 只有已升级的节点才可能是本过程中创建的一般脚本资源的所有者，因为此资源类型在 Windows 2000 中不受支持。
  9. 启动该节点上的 W3SVC 服务并将服务设置成自动启动。
  10. 使包含新的一般脚本资源的组联机。
  11. 使用 IIS 启动已升级的节点上的网站。
  12. 将最后一个节点升级到 Windows Server 2003, Enterprise Edition。升级完成后，即可在该节点上启动 W3SVC 并将该服务设置成自动启动。

注意

  • 当您将某个群集节点从 Windows 2000 升级到上述某个产品之后，必须在重新启动群集服务之前，在每个群集节点上使用同时属于 Domain Admins 组和 Administrators 组的帐户登录。即使在每个群集节点上 Domain Admins 组已经是 Administrators 组的成员，也必须执行此步骤。
  • 要执行该过程，您必须是本地计算机上 Administrators 组的成员，或者您必须被委派了适当的权限。如果将计算机加入域，Domain Admins 组的成员也可以执行这个过程。作为安全性最佳操作，可以考虑使用运行方式来执行这个过程。
  • 要聚集 Windows Server 2003, Enterprise Edition 上的 IIS，在该群集上还必须有 DTC 资源。
  • 只有已升级的节点才可能是本过程中创建的一般脚本资源的所有者，因为此资源类型在 Windows 2000 中不受支持。
  • 使用 Windows Server 2003, Enterprise Edition 提供的脚本可使其中的很多步骤自动执行。详细信息，请参阅“相关主题”中的“使用提供的脚本在包含 IIS 的群集上从 Windows 2000 升级”。
  • 有关硬件兼容性的详细信息，请参阅支持资源。

相关主题


在包含消息队列的群集上从 Windows 2000 进行升级

Microsoft Windows 图形

在包含消息队列的群集上从 Windows 2000 进行升级

  1. 请确认您的硬件是否适用于 Windows Server 2003, Enterprise Edition 或是否与其兼容。
  2. 使所有消息队列群集资源脱机。有关如何执行此操作的详细信息，请参阅“相关主题”中的“使资源脱机”。
  3. 对于每个消息队列资源，请同时使依赖此资源的网络名称资源脱机。
  4. 将所有节点从 Windows 2000 升级到 Windows Server 2003, Enterprise Edition。可执行滚动升级或者非滚动升级，只要适合于您的安装即可。升级前，请确保删除 Windows Server 2003, Enterprise Edition 不支持的资源。详细信息，请参阅“相关主题”。当以管理员身份首次登录新升级的节点时，将显示“管理您的服务器”。关闭“管理您的服务器”，继续进行升级。
  5. 重新使网络名称资源联机。确保分布式事务协调器 (DTC) 资源已联机，然后使消息队列资源联机。

注意

  • 当您将某个群集节点从 Windows 2000 升级到上述某个产品之后，必须在重新启动群集服务之前，在每个群集节点上使用同时属于 Domain Admins 组和 Administrators 组的帐户登录。即使在每个群集节点上 Domain Admins 组已经是 Administrators 组的成员，也必须执行此步骤。
  • 要执行该过程，您必须是本地计算机上 Administrators 组的成员，或者您必须被委派了适当的权限。如果将计算机加入域，Domain Admins 组的成员也可以执行这个过程。作为安全性最佳操作，可以考虑使用运行方式来执行这个过程。

相关主题


从 Windows NT 4.0 升级群集

不能从 Windows NT Server 4.0 Enterprise Edition 直接滚动升级到 Windows Server 2003, Enterprise Edition。而是有两种方式可供选择：

  • 首先升级到 Windows 2000，然后升级到 Windows Server 2003, Enterprise Edition，以保持群集的可用性。
  • 可以直接从 Windows NT Server 4.0 Enterprise Edition 非滚动升级到 Windows Server 2003, Enterprise Edition，该升级方式使您无法保持群集的可用性。

如果使用 Windows 2000 进行升级，请按照 Windows 2000 文档中的描述执行从 Windows NT Server 4.0 到 Windows 2000 的升级。然后，按照从 Windows 2000 升级群集中描述的 Windows Server 2003, Enterprise Edition 升级过程操作。如果在您的 Windows NT Server 4.0 群集上有 IIS 资源，那么在完成这两种升级后必须删除不受支持的 IIS 资源类型，方法是打开“命令提示符”，然后键入如下命令：Cluster restype "IIS Virtual Root" /delete /type。

要在不使用任何 Windows 2000 产品的情况下进行升级，必须中断群集可用性。执行的步骤取决于群集中所包含的资源。对于许多安装来说，下列过程都可适用：

  • 从 Windows NT 升级群集

但是，如果群集中包含 IIS 资源，则必须使用以下过程：

  • 从包含 IIS 的群集上的 Windows NT 进行升级

如果群集中包含 MSMQ 或 DTC 资源，则必须按 Microsoft 知识库文章 315993 中的说明执行操作。(http://www.microsoft.com/)


从 Windows NT 升级群集

Microsoft Windows 图形

从 Windows NT 升级群集

  1. 请确认您的硬件是否适用于 Windows Server 2003, Enterprise Edition 或是否与其兼容。详细信息，请参阅“相关主题”中的“清单：升级群集的准备工作”。
  2. 确认您的群集上没有 IIS、MSMQ 或 DTC 资源。详细信息，请参阅“注意”和“相关主题”。
  3. 确保 Service Pack 5 或更高版本已应用于将从 Windows NT Server 4.0 升级到 Windows Server 2003, Enterprise Edition 的所有计算机。
  4. 如果合适，请通知用户您将关闭他们在群集上使用的应用程序。
  5. 停止群集提供的应用程序。
  6. 删除不受 Windows Server 2003, Enterprise Edition 支持的所有资源，包括 NNTP 服务实例、SMTP 服务实例及时间服务资源。
  7. 关闭除一个节点外的所有节点，或者让其处于适合于您的终止方式的关闭状态。

    警告

    • 如果在使用共享存储设备，当升级、打开电源并启动操作系统时，必须确保只有一个节点可以访问群集磁盘。否则可能损坏群集磁盘。在创建群集之前，为了防止群集磁盘的损坏，请只保留一个群集节点，关闭所有其他节点，或者使用其他技术（例如 LUN 屏蔽、选择性表示或分区）保护群集磁盘。一旦某个节点上的群集服务运行正常，即可同时安装并配置其他节点。
  8. 升级当前正在运行的节点上的操作系统。有关运行安装程序的信息，请参阅“相关主题”中的“启动安装程序”。

    群集软件将在操作系统升级过程中被自动升级。注意不能更改配置，例如将群集磁盘配置为动态磁盘等。详细信息，请参阅“相关主题”中的“服务器群集的限制”。

    当以管理员身份首次登录新升级的节点时，将显示“管理您的服务器”。关闭“管理您的服务器”，继续进行升级。

  9. 在升级的节点上，单击“开始”，依次指向“程序”、“管理工具”，然后单击“群集管理器”。
  10. 通过“群集管理器”查看群集磁盘是否联机。

    警告

    • 继续下一步之前确保群集管理器中的群集磁盘已联机。如果磁盘已联机，表明群集服务工作正常，这意味着在任何特定时候只有一个节点可以访问该群集存储。否则，该群集存储可能会损坏。
  11. 关闭已升级的节点，或者让其处于适合您的终止方式的关闭状态。
  12. 打开群集中的另一个节点并升级该节点的操作系统。
  13. 第二个节点升级之后，打开第一个节点。
  14. 如果要将其他节点添加到群集中，请先升级前两个节点后再进行添加。

要点

  • 请单击支持资源中的相应链接，确认整个群集解决方案是否与 Windows Server 2003 家族产品兼容。

注意

  • 要执行该过程，您必须是本地计算机上 Administrators 组的成员，或者您必须被委派了适当的权限。如果将计算机加入域，Domain Admins 组的成员也可以执行这个过程。作为安全性最佳操作，可以考虑使用运行方式来执行这个过程。
  • 如果 Windows NT Server 4.0 群集包括 DTC 或 MSMQ 资源，则直接从 Windows NT Server 4.0 升级到 Windows Server 2003, Enterprise Edition 时，必须采取其他步骤。有关详细信息，请参阅 Microsoft 知识库中的文章 315993。(http://www.microsoft.com/)
  • 如果您的目标是在群集中拥有两个以上的节点，则必须将纤维管道（非 SCSI）用于群集存储。添加其他节点之前，请确保整个群集解决方案与 Windows Server 2003 家族产品兼容。
  • 从 Windows NT Server 4.0 升级到 Windows Server 2003, Enterprise Edition 时，群集服务用户帐户还需要“作为操作系统的一部分”用户权利。如果可能，安装程序将自动授予该用户权利。如果安装程序无法授予此用户权利，系统将提示您做此更改。

    基于安全考虑，必须将此用户权利授予群集服务使用的特定用户帐户。将此用户权利授予该用户帐户所在的安全组并不能纠正该问题。通常，您必须授予此用户权利作为本地用户权利，而不可以作为域级用户权利。但是，如果您的节点是域控制器，则可以使用域级用户权利。

    有关设置用户权利的详细信息，请参阅 Windows 2000 帮助文档中的“编辑安全设置”，或者在 Windows NT Server 4.0 中，打开“域用户管理器”，单击“用户管理器”中的“帮助”菜单，并参阅“管理用户权利策略”。

  • 在可以开始从 Windows NT Server 4.0 直接升级到 Windows Server 2003, Enterprise Edition 之前，必须应用 Service Pack 5 或更高版本。

相关主题


从包含 IIS 的群集上的 Windows NT 进行升级

Microsoft Windows 图形

从包含 IIS 的群集上的 Windows NT 进行升级

  1. 请确认您的硬件是否适用于 Windows Server 2003, Enterprise Edition 或是否与其兼容。
  2. 如果需要，请通知用户您将关闭他们在群集上使用的应用程序。
  3. 确保 Service Pack 5 或更高版本已应用于将从 Windows NT Server 4.0 升级到 Windows Server 2003, Enterprise Edition 的所有计算机。
  4. 停止通过群集可以使用的应用程序。
  5. 删除不受 Windows Server 2003, Enterprise Edition 支持的所有资源，包括 NNTP 服务实例、SMTP 服务实例及时间服务资源。
  6. 在所有节点上将群集服务设置为手动启动。
  7. 关闭不包含 IIS 资源的节点，或者让其处于适合您的终止方式的关闭状态。

    警告

    • 如果在使用共享存储设备，当升级、打开电源并启动操作系统时，必须确保只有一个节点可以访问群集磁盘。否则，可能会损坏群集磁盘。在创建群集之前，为了防止群集磁盘损坏，请只保留一个群集节点并关闭其他所有群集节点，或者使用其他技术（例如 LUN 屏蔽、选择性表示或分区）保护群集磁盘。某个节点上的群集服务运行正常后，才可同时安装并配置其他节点。
  8. 在运行的节点上，请注意 IIS 实例资源的依存性。请注意依赖于 IIS 资源的资源以及 IIS 本身所依赖的资源。
  9. 使包含 IIS 实例资源的组脱机。有关如何执行此操作的详细信息，请参阅“相关主题”中的“使资源脱机”。
  10. 删除 IIS 实例资源上的所有依存性。
  11. 删除 IIS 实例资源并关闭群集管理器（如果它处于打开状态）。详细信息，请参阅“相关主题”中的“删除资源”。
  12. 删除不受支持的资源类型：打开“命令提示符”。键入下列命令并按 Enter：

    Cluster restype "IIS Virtual Root" /delete /type

  13. 在剩余的节点上停止群集服务。
  14. 升级当前正在运行的节点上的操作系统。有关运行安装程序的信息，请参阅“相关主题”中的“启动安装程序”。

    将在操作系统升级期间自动升级群集软件。请注意，不能更改配置，例如将群集磁盘配置为动态磁盘等。详细信息，请参阅“相关主题”中的“服务器群集的限制”。升级之后，如果显示“管理您的服务器”，则将其关闭。

  15. 在升级的节点上启动群集服务。
  16. 在已升级的节点上重新配置群集服务，使其自动启动。
  17. 关闭已升级的节点，或者让其处于适合您的终止方式的关闭状态。
  18. 打开群集中的另一个节点并升级该节点的操作系统。升级之后，如果显示了“管理您的服务器”，则将其关闭。

    警告

    • 如果在使用共享存储设备，当升级、打开电源并启动操作系统时，必须确保只有一个节点可以访问群集磁盘。否则，可能会损坏群集磁盘。在创建群集之前，为了防止群集磁盘的损坏，请只保留一个群集节点，关闭所有其他节点，或者使用其他技术（例如 LUN 屏蔽、选择性表示或分区）保护群集磁盘。某个节点上的群集服务运行正常后，才可同时安装并配置其他节点。
  19. 第二个节点升级后，在升级后的第二个节点上启动群集服务。该节点会自动重新加入到现有的群集中。
  20. 在已升级的第二个节点上重新配置群集服务，使其自动启动。
  21. 打开第一个节点。
  22. 在升级的一个节点上，单击“开始”，依次指向“程序”、“管理工具”，然后单击“群集管理器”。
  23. 通过“群集管理器”查看群集磁盘是否联机。

    警告

    • 继续下一步之前确保群集管理器中的群集磁盘已联机。如果磁盘已联机，表明群集服务工作正常，这意味着在任何特定时候只有一个节点可以访问该群集存储器。否则，该群集存储器可能已损坏。
  24. 如果要升级的群集上没有“分布式事务协调器 (DTC)”资源，请在该群集上创建一个 DTC 资源。
  25. 在用于包含 IIS 资源的节点上，请按照“相关主题”中的“清单：创建群集 IIS Web 或 FTP 服务”中说明的过程创建一般脚本资源。

    注意

    • 作为本步骤的一部分，请重新创建一般脚本资源的依存性（与已删除的 IIS 资源的依存性相同）。使依赖于 IIS 资源的每个项目都依赖于一般脚本资源。同时使一般脚本资源依赖于 IIS 以前依赖的项目。
    • 只有 Windows Server 2003, Enterprise Edition 节点才可能是本过程中创建的一般脚本资源的所有者，因为此资源类型在 Windows NT Server 4.0 中不受支持。
  26. 在所有节点上启动 W3SVC 服务并将该服务设置为自动启动。
  27. 使包含新的一般脚本资源的组联机。
  28. 使用 IIS 启动网站。
  29. 如果要将其他节点添加到群集中，请先升级前两个节点后再进行添加。

要点

  • 如果您的群集使用 SCSI，该群集中会有两个节点，但不会超过两个。如果您希望在群集中拥有两个以上的节点，则必须将纤维管道用于群集存储。请单击支持资源中的相应链接，确认整个群集解决方案是否与 Windows Server 2003 家族产品兼容。您的群集解决方案必须在兼容硬件的群集类别中。

注意

  • 要执行该过程，您必须是本地计算机上 Administrators 组的成员，或者您必须被委派了适当的权限。如果将计算机加入域，Domain Admins 组的成员也可以执行这个过程。作为安全性最佳操作，可以考虑使用运行方式来执行这个过程。
  • 要聚集 Windows Server 2003, Enterprise Edition 上的 IIS，在该群集上还必须有 DTC 资源。
  • 仅当直接从 Windows NT Server 4.0 升级到 Windows Server 2003, Enterprise Edition 时，该过程才适用。如果从 Windows NT Server 4.0 升级到 Windows 2000，然后再升级到 Windows Server 2003, Enterprise Edition，请按照“相关主题”中列出的相应主题内描述的步骤操作。
  • 从 Windows NT Server 4.0 升级到 Windows Server 2003, Enterprise Edition 时，群集服务用户帐户还需要“作为操作系统的一部分”用户权利。如果可能，安装程序将自动授予该用户权利。如果安装程序无法授予此用户权利，系统将提示您做此更改。

    基于安全考虑，必须将此用户权利授予群集服务使用的特定用户帐户。将此用户权利授予给该用户帐户所在的安全组并不能纠正该问题。通常，您必须授予此用户权利作为本地用户权利，而不能为域级用户权利。但是，如果您的节点是域控制器，则可以使用域级用户权利。

    有关设置用户权利的详细信息，请参阅 Windows 2000 帮助文档中的“编辑安全设置”，或者在 Windows NT Server 4.0 中，打开“域用户管理器”，单击“用户管理器”中的“帮助”菜单，并参阅“管理用户权利策略”。

  • 在可以开始从 Windows NT Server 4.0 直接升级到 Windows Server 2003, Enterprise Edition 之前，必须应用 Service Pack 5 或更高版本。
  • 有关硬件兼容性的详细信息，请参阅 Microsoft 网站 (http://www.microsoft.com/) 上的“Windows 目录”。

相关主题


概念

  • 在群集节点上安装 Windows Server 2003, Enterprise Edition
  • 在群集节点上升级到 Windows Server 2003, Enterprise Edition
  • 资源


在群集节点上安装 Windows Server 2003, Enterprise Edition

这部分包括：

  • 规划和准备群集安装
  • 安装服务器群集时的仲裁资源选项


规划和准备群集安装

在执行群集安装之前，必须制订硬件和网络的详细计划。

警告

  • 如果使用共享存储设备，那么请保证在创建群集之前，当打开计算机并启动操作系统时，只有一个节点可以访问群集磁盘。否则，群集磁盘可能会损坏。为了防止群集磁盘的损坏，在创建群集之前，请只保留一个群集节点，关闭所有其他节点，或者使用其他技术（例如 LUN 屏蔽、选择性表示或分区）保护群集磁盘。在某个节点上的群集服务运行正常之后，即可同时安装并配置其他节点。群集中的每个节点必须运行 Windows Server 2003, Enterprise Edition。

制订计划时，请审查以下项目：

群集硬件和驱动程序

Microsoft 只支持与 Windows Server 2003 家族兼容的完整服务器群集系统。请单击支持资源中的相应链接，确认整个群集解决方案是否与 Windows Server 2003 家族产品兼容。

对于群集磁盘，必须使用 NTFS 文件系统并将磁盘配置为基本磁盘。不能将群集磁盘配置为动态磁盘，也不能使用动态磁盘的特征，例如跨区卷（卷集）等。

开始安装群集硬件前请先仔细查阅制造商的说明。否则，有可能损坏群集存储。如果群集硬件包括 SCSI 总线，务必要仔细查阅有关 SCSI 总线终端和配置 SCSI ID 的说明。

为了简化配置并消除潜在的兼容性问题，请考虑对所有节点均使用相同的硬件。

群集节点上的网络适配器

在制订计划时，要确定每个网络适配器将传输何种通讯。下面的列表提供了适配器可以传输的通讯类型的详细信息：

  • 仅节点到节点的通讯（专用网络）。这意味着服务器具有用于传输其他通讯的一个或多个其他适配器。

    对于节点到节点的通讯，可以将网络适配器连接到群集中被独占使用的专用网络。请注意，如果专用网络使用一个集线器或网络交换机，该设备将成为群集中潜在的故障点。

    群集中的节点必须位于同一子网中，但是可以在两个节点的互连之间使用虚拟 LAN (VLAN) 交换机。如果使用 VLAN，点对点的往返时间延迟必须少于 1/2 秒，而且从运行在这些节点上的 Windows 操作系统的角度来看，两个节点之间的链路必须表现为一个单一的点对点连接。为了避免单个故障点，请对节点之间的不同路径使用独立的 VLAN 硬件。

    如果节点使用多个专用（节点到节点）网络，最佳做法是使这些网络的适配器使用静态 IP 地址而不是 DHCP。

  • 仅客户端到群集的通讯（公用网络）。这意味着服务器具有用于传输其他通讯的一个或多个其他适配器。
  • 节点到节点和客户端到群集的通讯（混合网络）。如果每个节点具有多个网络适配器，则同时传输这两种通讯的网络适配器可以充当其他网络适配器的备用适配器。
  • 与群集无关的通讯。如果群集节点还提供与群集无关的服务，而且群集节点中具有足够的适配器，您可能希望用一个适配器传输与群集无关的通讯。

群集的节点必须通过两个或多个局域网 (LAN) 来连接；要防止出现单一故障点，至少需要两个网络。只通过一个网络连接的节点所属的服务器群集是一种不受支持的配置。每个网络的适配器、电缆、集线器和交换机必须独立出现故障。这通常意味着任何两个网络的组件在物理上必须是独立的。

至少有两个网络必须配置为处理“所有通讯（混合网络）”或“只用于内部群集通讯（专用网络）”。

对于两个适配器，建议的配置是将一个适配器用于专用（仅节点到节点）通讯，另一个适配器用于混合通讯（节点到节点和客户端到群集的通讯）。

考虑为每个连接选择一个可以表明其用途的名称。该名称使得无论在何时配置服务器，都容易区别不同的连接。

注意

  • 如果使用容错网络适配器，请创建多个专用网络而不是单个容错网络。
  • 不要在专用网络上使用成组网络适配器。
  • 不要在专用网络适配器上配置默认网关、DNS 或 WINS 服务器。不要在公用网络上将专用网络适配器配置为使用名称解析服务器，否则，公用网络上的名称解析服务器可能会将某个名称映射到专用网络上的 IP 地址。如果客户端接收到来自该名称解析服务器的 IP 地址，它可能无法到达该地址，因为不存在从该客户端到专用网络地址的路由。
  • 在公用网络适配器上配置 WINS 和/或 DNS 服务器。如果公用网络上使用了“网络名称”资源，则将 DNS 服务器设置为支持动态更新；否则，“网络名称”资源可能无法正确进行故障转移。还要在公用网络适配器上配置一个默认网关。如果群集中存在多个公用网络，则只在一个网络上配置默认网关即可。
  • 特定节点上的适配器必须连接到网络的不同子网。
  • 在包含两个网络适配器的节点上使用“新建服务器群集向导”或“添加节点向导”安装群集时，默认情况下，向导将为混合网络通讯配置两个网络适配器。作为一种最佳操作，仅需为专用网络通讯重新配置一个适配器。详细信息，请参阅更改群集使用网络的方式。
  • 手动配置每个群集网络适配器的通讯设置，例如速度、双工模式、流控制和媒体类型。不要使用自动检测。必须将所有群集网络适配器配置为使用相同的通讯设置。
  • 请单击支持资源中的相应链接，确认整个群集解决方案是否与 Windows Server 2003 家族产品兼容。

群集 IP 地址

为群集本身获取静态 IP 地址。不可使用 DHCP 分配该地址。

每个群集节点的 IP 寻址

决定如何处理各个群集节点的 IP 寻址。每个节点上的各个网络适配器都要求 IP 寻址。最佳操作是为每个网络适配器分配一个静态 IP 地址。作为一种替代方案，还可以通过 DHCP 提供 IP 寻址。如果使用静态 IP 地址，可以将网络适配器的每个链接对（链接的节点到节点）地址设置在同一子网上。

注意，如果对单个群集节点使用 DHCP，则该 DHCP 服务器可能成为单一故障点。这就是说，如果将群集节点设置为依赖 DHCP 为其分配 IP 地址，则 DHCP 服务器出现临时故障时，就可能意味着群集节点临时不可用。在决定是否使用 DHCP 时，要评估可确保 DHCP 服务可用的各种方法，并考虑对群集节点使用较长租约的可能性。这有助于确保群集节点始终可以获得有效的 IP 地址。

群集名称

确定或获取群集的合适名称。管理员会将该名称用于群集连接。（运行在群集上的实际应用程序一般都有不同的网络名称。）群集名称必须与域名、域中的所有计算机名以及域中的其他群集名称相异。

群集节点的计算机帐户和域指派

确保所有群集节点在同一域中都拥有计算机帐户。群集节点不能位于工作组中。

用于安装和配置群集服务的 Operator 用户帐户

要安装并配置群集服务，必须使用每个节点上本地 Administrators 组中的帐户。安装和配置每个节点时，如果未使用本地 Administrators 组的帐户，系统将提示提供此类帐户的登录凭据。

群集服务用户帐户

创建或获取群集服务用户帐户。这是运行群集服务使用的名称和密码。安装群集期间必须提供该用户名和密码。

最好不要将群集服务用户帐户用于任何其他目的。如果拥有多个群集，请分别为每个群集设置一个唯一的群集服务用户帐户。该帐户必须是一个域帐户，且不能为本地帐户。但不要将此帐户设置为一个域 Administrator 帐户，因为它不需要域管理员的用户权利。

作为群集设置过程的一部分，应将群集服务用户帐户添加到每个节点的本地 Administrators 组。同时，作为本地管理员组成员的群集服务用户帐户还要求一组额外的用户权利：

  • 作为操作系统的一部分。
  • 备份文件和目录。
  • 调整进程的内存配额。
  • 增加计划优先级。
  • 作为服务登录。
  • 还原文件和目录。

作为群集设置过程的一部分，这些用户权利同时被授予给群集服务用户帐户。请注意，即使所有节点已经从群集中清除，群集服务用户帐户仍将继续拥有这些用户权利。由于只是在域中的局部节点上而非整个域中授予这些用户权利，所以降低了上述的风险性。但如果不再需要该帐户，则应将其从每个被清除的节点中删除。

务必防止群集服务用户帐户的密码过期（根据组织的密码重续策略）。详细信息，请参阅密码。

保存重要群集配置信息的卷（检查点和日志文件）

计划在群集存储上保留一个用于保存重要群集配置信息的卷。该信息构成了群集仲裁资源，当一个群集节点停止工作时就需要此类资源。仲裁资源提供了群集所需关键数据的独立于节点的存储。

建议该卷大小至少为 500 MB。建议不要将用户数据存储在仲裁资源的任何卷上。

注意

  • 当计划并执行群集磁盘的磁盘配置时，请将磁盘配置为所有分区格式为 NTFS 的基本磁盘（可压缩也可不压缩）。在向群集添加首个节点前，要对群集存储设备上的所有磁盘进行分区和格式化。不要将群集磁盘配置为动态磁盘，也不要在群集磁盘上使用跨区卷（卷集）或远程存储。对于 64 位版本的 Windows Server 2003, Enterprise Edition，必须将群集存储设备上的群集磁盘分区为 MBR，而非 GPT 磁盘。

以下部分介绍群集存储的物理安装方法。

开始安装群集硬件

首次物理连接并安装群集硬件时执行的步骤相当重要。请务必遵照硬件制造商提供的有关这些初始步骤的说明。

要点

  • 连接设备后请仔细检查网络电缆。确保电缆连接无误（例如，专用网络与公用网络相连）。

使用 SCSI 共享存储设备时在 BIOS 或 EFI 中完成的初始步骤

如果在使用 SCSI 共享存储设备，当您首次附加群集硬件（共享总线和群集存储）时，请确保只在群集节点（节点是群集中的服务器）的固件配置屏幕上工作。在 32 位计算机上，请使用 BIOS 配置屏幕。在基于 Itanium 体系结构的计算机上，请使用可扩展固件接口 (EFI) 配置屏幕。来自制造商的指导将说明是自动显示这些配置屏幕，还是必须在打开计算机后按特定键来访问这些屏幕。遵照制造商的指示完成 BIOS 或 EFI 配置过程。在这个初始安装阶段，只在这些 BIOS 或 EFI 配置屏幕上执行操作，不要启动操作系统。当群集节点依然显示 BIOS 或 EFI 配置屏幕，且还没有在第一个群集节点上启动操作系统时，执行下列步骤。

要点

    • 如果群集节点是基于 Itanium 体系结构的计算机，请使用纤维管道总线来代替 SCSI 总线。
  • 确保了解并按照制造商对于 SCSI 总线终端的指导操作。
  • 确保共享总线上的每个设备（SCSI 控制器和硬盘）都有唯一的 SCSI ID。如果 SCSI 控制器都默认使用相同的 ID（通常是 SCSI ID 7），应将其中的一个控制器更改为其他 SCSI ID，例如 SCSI ID 6。如果共享 SCSI 总线上有多个磁盘，每个磁盘都必须拥有一个唯一的 SCSI ID。此外，还要确保在启动时总线没有被配置为自动重设这些 SCSI ID（否则，这些 ID 将不同于您指定的设置）。
  • 保证可以扫描总线并可从所有群集节点查看驱动器（依然是从 BIOS 或 EFI 配置屏幕上执行上述操作）。

使用纤维管道共享存储设备或非共享存储设备时在 BIOS 或 EFI 中执行的初始步骤

  • 打开单个节点。关闭所有其他节点。
  • 在初始安装阶段，将执行 BIOS 或可扩展固件接口 (EFI) 配置过程，并且不允许启动操作系统。在查看 BIOS 或 EFI 配置屏幕时，请确保能从活动群集节点中扫描总线并看到驱动器。在 32 位计算机上，请使用 BIOS 配置屏幕。在基于 Itanium 体系结构的计算机上，使用 EFI 配置屏幕。请咨询您的制造商，以确定是自动显示这些配置屏幕，还是在打开计算机后必须按某些特定键来访问配置屏幕。遵照制造商的指示完成 BIOS 或 EFI 配置过程。

完成安装的最后步骤

如果第一个群集节点尚未安装 Windows Server 2003, Enterprise Edition，那么请在继续操作之前安装。配置完 BIOS 或 EFI 后，仅启动一个群集节点的操作系统并使用“群集管理器”完成群集服务的配置。

使用群集管理器新建服务器群集向导，您可以选择典型（完全）配置和高级（最小）配置选项。典型配置适合于大多数安装，而且将获得完全配置的群集。高级配置选项仅用于具有新建服务器群集向导无法验证的复杂存储配置的群集，或者用于您不希望群集在其中管理所有存储的配置方案。下列示例描述了每一种情况：

  • 在某些复杂存储解决方案中（如包含多个交换机的纤维管道交换结构），特定的存储单元可能在群集中的每台计算机上都有不同的标识。虽然这是有效的存储配置，但它违背了新建服务器群集向导中的存储验证试探法。如果您有此类存储解决方案，则在用典型配置选项创建群集时可能会收到错误信息。如果存储配置设置正确，则可通过重新启动新建服务器群集向导并选择高级配置选项来禁用存储验证试探法并避免此错误。
  • 在群集中的特定节点上，您可能希望群集某些磁盘，或保留某些磁盘为专用。典型配置选项将所有磁盘配置为群集磁盘，并为它们创建群集资源。不过，通过高级配置选项，可将某些磁盘保留为专用，因为该配置创建的群集中只有仲裁磁盘才受群集管理（如果选择将物理磁盘作为仲裁资源）。群集创建后，必须使用群集管理器才能添加需要由群集管理的任何其他磁盘。

详细信息，请参阅存储配置选项。

要点

  • 如果使用共享存储设备：在创建群集之前，打开计算机并启动操作系统时应确保只有一个节点可以访问群集磁盘，这一点非常重要。否则，群集磁盘可能会损坏。要防止群集磁盘损坏，请只打开一个群集节点并关闭其他所有群集节点，也可使用其他技术（如 LUN 屏蔽、选择性演示或分区）在创建群集前保护群集磁盘。另外，开始安装第 2 个或后续的节点前，请确保所有由群集管理的磁盘都具有与它们相关的磁盘资源。如果这些磁盘此时没有与它们相关的磁盘资源，则磁盘数据将损坏，因为磁盘不受保护，并且会有多个节点同时尝试连接到它们。
  • 不要使用“管理您的服务器”或“配置您的服务器向导”来配置群集节点。

有关安装群集的其他步骤信息，请参阅清单：验证群集系统和清单：计划并创建服务器群集。

有关无人参与安装群集的信息，请参阅创建群集以及位于 Microsoft Windows 资源工具包网站的“Designing Unattended Installations”（设计无人参与安装）。(http://www.microsoft.com/)


安装服务器群集时的仲裁资源选项

对于 Windows Server 2003, Enterprise Edition 上的服务器群集，您现在可从三种方式中进行选择来安装仲裁资源（这种资源用于维护群集配置数据的确定副本，且必须始终可用才能运行群集）。

第一种选择是单一节点服务器群集，早期版本已提供这种群集，并且在本版本中继续支持这种群集。单一节点群集经常用于开发和测试，并可使用（或不使用）外部群集存储设备进行配置。对于没有外部群集存储设备的单一节点群集，本地磁盘会被配置为群集仲裁设备。

第二种选择为单一的仲裁设备服务器群集，在早期的 Windows 版本中已经提供了这种群集。这种模型将群集配置数据保存在一个所有节点均可访问的共享群集存储设备上。一般拓扑结构为：

这是最常见的模型并建议用于多数场合。如果所有群集节点都位于同一位置而且您想利用“即使只有一个节点在运行，群集也会继续支持用户”这样一个事实，那么可以选择单一仲裁设备模型。

第三个选项（对于 Windows Server 2003, Enterprise Edition 是新增选项）是“多数节点集”。多数节点集是来自服务器群集的仲裁资源，但是，群集配置数据实际上存储在群集上的多个磁盘。多数节点集资源可以确保不同磁盘上的群集配置数据的一致性。这允许如下的群集拓扑结构：

在多数节点集模型中，群集中的每个节点都使用它自己的本地系统磁盘上的一个目录存储群集配置数据。如果群集配置发生更改，该更改将反映到不同的磁盘上。请注意，一个多数节点集群集中也可能拥有共享存储设备。其具体配置取决于安装要求。

仅在目标方案中使用多数节点集群集，例如：

  • 地理位置上分散的群集：跨越多个站点的群集。
  • 消除单一败点：尽管在使用单一群集存储设备时仲裁磁盘本身通过 RAID 可以获得高度的可用性，但控制器端口或主机总线适配器 (HBA) 本身却可能成为单一败点。
  • 没有共享磁盘的群集：有些特殊配置需要高度一致的群集功能，而不使用共享磁盘。
  • 主持可故障转移的应用程序的群集，但有其他一些特定于应用程序的方法在节点间复制或镜像数据。

不要将群集配置为一个多数节点集群集，除非它是您的原始设备制造商 (OEM)、独立软件供应商 (ISV) 或独立硬件供应商 (IHV) 提供的群集解决方案的一部分。

群集模型的考虑事项

在实施群集之前，请考虑您计划使用何种类型的仲裁资源解决方案。考虑单一仲裁设备群集与多数节点集之间的下列差别：

注意

  • 下列信息帮助您做出有关布置和管理群集节点与仲裁资源的基本决策。它不提供有关每种群集模型的要求或每种模型处理故障转移情形的方式的全部详细信息。如果无法确定应该使用何种模型或者应该将群集节点安置在哪个位置，请参阅选择群集模型中的信息。

节点故障转移行为

多数节点集的故障转移行为与单一仲裁设备模型的行为之间存在如下重大差别：

  • 使用单一仲裁设备模型，可以只通过单一工作节点维护群集的可用性。
  • 如果使用多数节点集，则必须有超过半数，也即（群集中配置的节点数/2）+ 1 个节点在工作，才能维持群集的可用性。下表列出了一个特定多数节点集群集可以承受并仍继续工作的节点故障的数目：
    群集中配置的节点数 | 群集故障前允许的节点故障数 | 群集继续工作所需的节点数
    1 | 0 | 1
    2 | 0 | 2
    3 | 1 | 2
    4 | 1 | 3
    5 | 2 | 3
    6 | 2 | 4
    7 | 3 | 4
    8 | 3 | 5

地理上的考虑

如果群集中的所有节点都处于同一地理位置，您通常会使用单一仲裁资源模型。作为这种要求的一部分，您的节点必须连接到相同的物理存储设备。

另一方面，如果您具有地理位置分散的节点，则通常使用多数节点集会比较合适。群集配置数据存储在每个节点的本地文件共享上，该文件共享可以被网络上的其他节点共享。但这些共享必须始终可以访问，否则节点可能出现故障。

对于地理位置分散的群集还有其他一些具体要求，包括群集节点之间的网络往返延迟最大值必须少于 500 毫秒的要求。有关能满足地理位置分散的群集的所有要求的群集解决方案的信息，请单击支持资源中的合适链接，查阅硬件兼容信息。

硬件

Microsoft 仅支持与 Windows Server 2003 家族产品兼容的完整服务器群集系统。请单击支持资源中的相应链接，确认整个群集解决方案是否与 Windows Server 2003 家族产品兼容。

有关多数节点集群集的详细信息，请参阅选择群集模型和创建群集。

要点

  • 在实施多数节点集之前，强烈建议您阅读选择群集模型中的信息。该信息有助于您理解每种类型的仲裁资源解决方案的所有考虑、要求和限制。


在群集节点上升级到 Windows Server 2003, Enterprise Edition

如果正在群集节点上执行从 Windows 2000 到 Windows Server 2003, Enterprise Edition 的升级，则也许可以执行操作系统的“滚动升级”。在滚动升级中，依次升级每个节点上的操作系统，从而确保始终有一个节点可用来处理客户端请求。在升级操作系统时，群集服务也被自动升级。滚动升级提供了群集服务的最大可用性，并将管理复杂性降到最小。

如果在群集节点上从 Windows NT 4.0 Enterprise Edition 升级到 Windows Server 2003, Enterprise Edition，则不能执行滚动升级。有关如何从 Windows NT 4.0 Enterprise Edition 执行升级的详细信息，请参阅从 Windows NT 4.0 升级群集。

详细信息，请参阅下列主题：

  • 有关滚动升级的图示和描述，请参阅滚动升级的工作原理。
  • 要确定是否能够执行滚动升级，请参阅对滚动升级的限制。
  • 有关滚动升级期间各种资源的支持信息，请参阅以下内容：
    • 混合版本群集中新资源类型的操作
    • 滚动升级期间的资源行为
    • 包括打印后台程序资源的升级
  • 有关无法执行滚动升级时如何升级群集节点的信息，请参阅滚动升级的备用方案。


滚动升级的工作原理

本主题讨论服务器群集上的滚动升级。要决定是否可以执行滚动升级，请参阅对滚动升级的限制。有关滚动升级的方法、限制及替代方案的信息，请参阅本主题底部的链接。

滚动升级主要有两个优点。首先，对客户端造成的服务干扰最小。（但在少数几个节点处理整个群集的工作任务期间，服务器的响应时间将会减少。）其次，您无需重新创建自己的群集配置。在整个升级过程中配置将保持不变。

在此示例中，滚动升级将从运行 Windows 2000 的两个群集节点（名称为“节点 1”和“节点 2”）开始。下图描述了该过程：

滚动升级概述

阶段 1：预备步骤

每个节点都运行带有下列软件的 Windows 2000 Advanced Server：

  • 群集服务组件，即 Windows 2000 Advanced Server 的一个可选组件。
  • 支持滚动升级的应用程序。详细信息，请参阅应用程序文档和滚动升级期间的资源行为。

此时，您的群集经过配置使得每个节点可以处理客户端请求（活动/活动配置）。

阶段 2：升级节点 1

暂停节点 1，在将节点 1 的操作系统升级为 Windows Server 2003, Enterprise Edition 时，节点 2 处理所有的群集资源组。

您当前正在运行一个混合版本的群集。混合版本的群集是其中的节点分别运行不同版本的操作系统的群集。尽管混合版本群集受 Windows Server 2003, Enterprise Edition 支持，但它们不是最优配置。建议您完成滚动升级的最后两个阶段，从而将所有节点都升级到相同的操作系统。

当群集处于混合版本的状态时，建议不要对群集配置进行任何更改，例如添加或删除节点。另外，建议在群集处于混合版本状态时不要更改任何群集资源。

阶段 3：升级节点 2

节点 1 重新加入群集中。当升级节点 2 的操作系统时，节点 2 被暂停并由节点 1 处理所有群集资源组。

阶段 4：结束步骤

节点 2 重新加入群集中，您将资源组重新分配到活动/活动群集配置中。

注意

  • 如果您的目标是在群集中拥有两个以上的节点，则必须将纤维管道（非 SCSI）用于群集存储。完成滚动升级后添加其他节点。在添加其他节点前，请单击支持资源中的相应链接，确认整个群集解决方案与 Windows Server 2003 家族产品兼容。您的群集解决方案必须在兼容硬件的群集类别中。
  • 对于群集磁盘，您必须使用 NTFS 文件系统并将磁盘配置为基本磁盘。不能将群集磁盘配置为动态磁盘，也不能使用动态磁盘的特征，例如跨区卷（卷集）等。详细信息，请参阅服务器群集的限制。

有关滚动升级的详细信息，请参阅：

  • 从 Windows 2000 执行滚动升级
  • 对滚动升级的限制
  • 混合版本群集中新资源类型的操作
  • 滚动升级期间的资源行为
  • 包括打印后台程序资源的升级
  • 滚动升级的备用方案


对滚动升级的限制

滚动升级过程有一些基本限制。最基本的限制如下：

  • 仅当从群集节点上的 Windows 2000 进行升级时，您才能执行滚动升级。如果从 Windows NT Server 4.0 Enterprise Edition 进行升级，则不能执行滚动升级。
  • 不能在同一个群集中混合基于 x86 和基于 Itanium 体系结构的计算机。因此，无法从一台基于 x86 的计算机向一台基于 Itanium 体系结构的计算机执行滚动升级。

其余的限制涉及“阶段 3”的开始部分，在这部分中对“混合版本的群集”进行操作：在这个群集中，节点运行不同版本的操作系统。为了能使混合版本的群集正常工作，运行在每个节点上的不同版本的软件必须做好彼此进行通讯的准备。该要求带来了滚动升级过程中的一些基本限制。

  • 为了成功地进行滚动升级，群集所管理的每一个资源必须具备滚动升级的能力。详细信息，请参阅滚动升级期间的资源行为。
  • 在混合版本的滚动升级阶段，群集节点都在运行不同版本的操作系统时，请不要更改资源设置（例如不要更改打印机资源的设置）。

如果未满足前面的限制条件，则不要执行滚动升级。详细信息，请参阅滚动升级的备用方案。


混合版本群集中新资源类型的操作

如果操作系统的某个版本支持添加到群集中的资源类型，但其他版本却不支持这种资源类型，这种情况会使混合版本的群集的操作变得复杂。例如，Windows Server 2003, Enterprise Edition 中的群集服务支持一般脚本资源类型。但该群集服务的旧版本却不支持这种资源类型。一个混合版本的群集可以在运行 Windows Server 2003, Enterprise Edition 的节点上运行“一般脚本”资源，但却无法在运行 Windows 2000 的节点上运行这些资源。

群集服务对新资源类型的可能所有者透明地进行设置，以防止这些资源将故障转移到混合版本群集中的 Windows 2000 节点上。换句话说，当您查看新资源类型的可能所有者时，Windows 2000 节点将不出现在列表中，您也无法将此节点添加到列表中。如果在混合版本的滚动升级阶段创建了此类资源，包含这些资源的资源组不会将故障转移到 Windows 2000 节点。


滚动升级期间的资源行为

尽管群集服务支持滚动升级，但并非所有应用程序都具有无缝的滚动升级行为。下表描述了滚动升级期间支持的各种资源。如果滚动升级期间您的资源未被完全支持，请参阅滚动升级的备用方案。

注意

  • 不能在运行 Windows NT Server 4.0 的群集上执行滚动升级。只有运行 Windows 2000 的群集支持到 Windows Server 2003, Enterprise Edition 的滚动升级。
资源 | 滚动升级说明
DHCP | 在滚动升级期间不完全支持 DHCP。必须遵照从 Windows 2000 执行最后一个节点的滚动升级中描述的过程执行“最后一个节点的滚动升级”。
文件共享 | 在滚动升级期间支持文件共享。
IIS | 在滚动升级期间不支持 IIS 6.0。在升级包含 IIS 资源的群集时，必须遵照在不使用提供的脚本的情况下在包含 IIS 的群集上从 Windows 2000 进行升级或使用提供的脚本在包含 IIS 的群集上从 Windows 2000 进行升级中描述的过程操作。
IP 地址 | 在滚动升级期间支持。
本地仲裁 | 在滚动升级期间支持。
MSDTC | 在滚动升级期间支持。但在使用混合版本的群集时，请不要创建或删除 MSDTC 资源。而应在开始任意节点的升级前创建 MSDTC 资源，或等到所有节点的升级都完毕后再创建。有关混合版本群集的详细信息，请参阅滚动升级的工作原理以及滚动升级的限制。
消息队列（即 MSMQ） | 消息队列在滚动升级期间未得到完全支持。要升级包含消息队列的群集，请参阅在包含消息队列的群集上从 Windows 2000 进行升级。
网络名称 | 在滚动升级期间支持。
NNTP 服务实例 | NNTP 服务实例在 Windows Server 2003, Enterprise Edition 中不受支持。升级之前必须删除所有 NNTP 服务实例资源。
物理磁盘 | 在滚动升级期间支持。
打印后台程序 | 滚动升级期间唯一支持的打印后台程序资源是位于 LPR 端口或标准端口监视器端口上的资源。请参阅包括打印后台程序资源的升级。
SMTP 服务实例 | SMTP 服务实例在 Windows Server 2003, Enterprise Edition 中不受支持。升级之前必须删除所有 SMTP 服务实例资源。
时间服务 | 时间服务在 Windows Server 2003, Enterprise Edition 中不受支持。升级之前必须删除所有时间服务资源。
WINS | 在滚动升级期间不完全支持 WINS。必须遵照从 Windows 2000 执行最后一个节点的滚动升级中描述的过程执行“最后一个节点的滚动升级”。
其他资源类型 | 请参阅 Windows Server 2003, Enterprise Edition 安装 CD \Docs 文件夹中的 Relnotes.htm 文件。还可参阅应用程序或资源附带的产品文档。

当群集处于混合版本的状态时，建议不要对群集配置进行任何更改，例如添加或删除节点。另外，建议在群集处于混合版本状态时不要更改任何群集资源。

最后一个节点的滚动升级

如果群集中具有在滚动升级期间不被完全支持的资源（例如 DHCP 和 WINS）而且也没有其他技术特定的过程对这些资源进行说明（例如 IIS），那么可以执行“最后一个节点的滚动升级”。

最后一个节点的滚动升级类似于标准的滚动升级。在最后一个节点的滚动升级中，除了包含不被支持的资源的节点，您将升级其他所有节点。升级所有其他节点后，就可以升级包含已识别资源的最后一个节点。

最后一个节点的滚动升级是对无法从运行 Windows Server 2003, Enterprise Edition 的节点向早期版本的操作系统进行故障转移的资源进行容纳的一种方法。请注意，这些资源可以采用其他方式进行故障转移，即从较旧版本的操作系统到 Windows Server 2003, Enterprise Edition 进行。有关如何执行最后一个节点的滚动升级的详细信息，请参阅从 Windows 2000 执行最后一个节点的滚动升级。


包括打印后台程序资源的升级

如果要执行拥有打印后台程序资源的群集的滚动升级，必须考虑两个问题。

首先，打印后台程序资源仅支持那些群集支持的端口（LPR 或标准端口监视器端口）上的打印机升级（包括滚动升级或任何其他类型的升级）。有关打印机不被支持时如何执行此任务的信息，请参阅滚动升级的备用方案。

其次，在运行包含打印后台程序资源的混合版本的群集时，请注意以下几点：

  • 不要更改具有打印后台程序资源的混合版本群集中的打印机设置。
  • 在执行滚动升级时不要添加新的打印机。如果确实添加了新打印机，则在为该打印机安装驱动程序时，请确保在所有节点上同时安装用于 Windows 2000 的驱动程序和用于 Windows Server 2003, Enterprise Edition 的驱动程序。
  • 如果打印首选项或默认设置很重要，则请务必检查这些选项。Windows Server 2003, Enterprise Edition 中的打印首选项并不一定与 Windows 2000 中相同打印机的文档默认设置一致，这可能是受两个操作系统的驱动程序之间差异所影响。

在滚动升级执行完毕且两个群集节点都在运行升级后的操作系统时，就可以对打印机配置进行更改。


滚动升级的备用方案

某些情况不允许执行标准的滚动升级。此时必须执行备用过程。这些情况如下：

  • 从 Windows NT Server 4.0 企业版升级。有关详细信息，请参阅从 Windows NT 4.0 升级群集。
  • 要升级的节点包含在滚动升级过程中不受支持的资源。要确定资源在滚动升级过程中是否受支持，请参阅滚动升级期间的资源行为。此外，还要确保阅读 Windows Server 2003, Enterprise Edition 安装程序 CD 上 \Docs 文件夹下的 Relnotes.htm 以及应用程序或资源附带的产品文档。如果某个资源在滚动升级期间不完全受支持，而且在某种技术特定过程（如 Internet 信息服务器 (IIS)）中没有描述，请参阅从 Windows 2000 执行最后一个节点的滚动升级。


资源

本主题提供有关在群集节点上进行安装和升级操作的其他信息来源。

  • Microsoft 只支持与 Windows Server 2003 家族兼容的完整服务器群集系统。请单击支持资源中的相应链接，确认整个群集解决方案是否与 Windows Server 2003 家族产品兼容。

  • 有关与 Windows Server 2003 家族产品兼容且经过认证的应用程序的最新信息，请参阅 Microsoft 网站 (http://www.microsoft.com) 上的软件兼容性部分。
  • 要更好地确保高可用性，请检查 Windows 软件和其他 Microsoft 软件的增强与更新。请参阅 Microsoft 网站上的“Windows Update”。(http://www.microsoft.com/)
  • 有关部署群集的详细信息，请参阅 Microsoft Windows 资源工具包网站上的“服务器部署”。(http://www.microsoft.com/)
  • 有关群集和 Windows 部署与资源工具包（提供 Windows Server 2003 家族产品的技术背景信息）的其他常规信息，请参阅下列内容：
    • 位于 Microsoft Windows 网站的“Windows Server 2003 Deployment Kit”（Windows Server 2003 部署工具包）。(http://www.microsoft.com/)
    • Windows 部署和资源工具包
  • Microsoft TechNet 是包含信息技术 (IT) 专业人员所需资源的服务。通过此服务可访问有关群集的白皮书和文章（由 Microsoft 技术支持人员编写）、职业和产业信息、讨论组、技术反馈和软件。详细信息，请参阅 Microsoft 网站 (http://www.microsoft.com/) 上的 TechNet。
  • 信息技术结构库网站 (ITIL) 为信息技术专业人员提供指导，并且包括有关高可用性的详细信息。以下内容引自网站：“ITIL consists of a series of books giving guidance on the provision of quality IT services, and on the accommodation and environmental facilities needed to support information technology.”（ITIL 包含一系列图书，这些图书对提供高品质的 IT 服务以及支持信息技术所需的便利设施与环境设施给予了指导。）（网站地址可能变动，您可能无法连接到在这里提到的网站。）


疑难解答

您遇到什么问题？

在群集创建过程中，“新建服务器群集向导”未检测到所有可能的群集磁盘。

可能的原因 解决方案
  • 未正确配置硬件、设备驱动程序或软件。
  • 检查磁盘管理以查看需要用于共享存储的磁盘是否可用。

    另请参阅： 磁盘管理

  • 使用了不兼容的磁盘硬件或驱动程序。
  • 检查磁盘缆线以确保有问题的节点和共享存储之间的电缆连接正确。

    通过单击支持资源中的相应链接来确认您的硬件（包括群集磁盘和其他群集硬件）是否与 Windows Server 2003, Enterprise Edition 兼容。

    请确保已按照制造商的说明正确配置了主机适配器，而且所有磁盘对于主机适配器都是可见的。

    请确保具有所需的驱动程序以便通过群集服务来使用磁盘。可从硬件制造商那里获得驱动程序。在开始安装群集硬件之前，请仔细阅读制造商的说明。

    注意

    • 如果对磁盘硬件或驱动程序做了任何更改，则必须重新启动“新建服务器群集向导”才能检测到更改。
  • 未将群集存储磁盘格式化为 NTFS。
  • 请确保将群集存储磁盘上的所有分区格式化为使用 NTFS 文件系统。群集创建过程中将不会识别任何具有 FAT 或 FAT32 分区的磁盘。

    另请参阅： NTFS

  • 未将群集存储磁盘配置为基本的 MBR 磁盘。
  • 请确保将群集存储磁盘配置为基本的 MBR 磁盘。Windows Server 2003, Enterprise Edition 提供了两种类型的存储配置：基本磁盘和动态磁盘。基本磁盘使用的磁盘结构与 Microsoft Windows NT 相同。动态磁盘是在 Windows 2000 中引入的。

    64 位版本的 Windows Server 2003, Enterprise Edition 和 64 位版本的 Windows Server 2003, Datacenter Edition 提供了全局分区表 (GPT) 磁盘以及由 32 位版本的 Windows Server 2003, Enterprise Edition 支持的主启动记录 (MBR) 磁盘。

    不过，群集服务器只能识别基本的 MBR 磁盘。如果将用作共享存储的磁盘配置为动态磁盘或 GPT 磁盘，请将其更改回基本的 MBR 磁盘。

    另请参阅： 将基本磁盘转化为动态磁盘和将 GUID 分区表磁盘更改为主启动记录磁盘（仅限 64 位）

在群集创建过程中，“新建服务器群集向导”将所有可用的存储设备配置为由群集管理（包括不需要由群集管理的存储）。

原因：使用群集管理器的“新建服务器群集向导”，可在“典型”（完全）配置和“高级”（最小）配置选项之间进行选择。典型配置将所有磁盘配置为群集磁盘，并为其创建群集资源。唯一的例外是系统磁盘，它包含操作系统，而且计算机从该磁盘启动。系统磁盘不会自动群集。

解决方案：使用“高级”（最小）配置选项。使用“高级”配置选项，可将某些磁盘保留为专用，因为该配置创建的群集中只有仲裁磁盘才由群集管理（如果选择将物理磁盘作为仲裁资源）。群集创建后，必须使用群集管理器才能添加需要由群集管理的其他任何磁盘。

详细信息，请参阅规划和准备群集安装和存储配置选项。

当试图将节点添加到群集时，您收到错误消息，提示由于对于所有节点不存在具备仲裁能力的公用资源，所以无法创建多节点群集。

原因：此向导无法验证您的存储配置。在一些复杂的存储方案（包含多个交换机，如纤维管道交换构造）中，特殊的存储单元在群集中的每一台计算机上可能具有不同的标识。虽然这是有效的存储配置，但它违背了“新建服务器群集向导”和“添加节点向导”中的存储验证启发方法。

解决方案：验证您的存储配置是否正确设置。然后，如果您正在使用“添加节点向导”，那么请通过使用“上一步”按钮返回“选择计算机”页来禁用存储验证启发方法。在“选择计算机”页，单击“高级”然后选择“高级”（最小）配置选项。如果您当前没有使用“添加节点向导”，那么请重新启动该向导，然后使用“高级”配置选项（如上文所述）。

详细信息，请参阅规划和准备群集安装。

在群集创建过程中，“新建服务器群集向导”或“添加节点向导”未检测到所有可能的网络适配器。

可能的原因 解决方案
  • 群集可能无法检测到由交叉电缆组成的网络。

    双节点群集可能使用交叉电缆来实施专用网络。当在第一个节点上创建群集时，应该打开第二个节点，但它已在 BIOS 或启动菜单中停止。在这种情况下，Windows 的 Media Sense 功能可能无法将网络适配器识别为已连接。

    当出现这种情况时：

    • 在“网络连接”中，代表网络适配器连接的图标上会显示一个红色的“X”。
    • 任务栏会显示一个图标，当将鼠标悬停于此图标上时，将显示“网络电缆没有插好”。
  • 如果您继续创建群集，那么当启动第二个节点时，将会检测到交叉电缆。网络将在默认模式（混合模式）下建立。然后可使用群集管理器将网络模式更改为专用。

    另请参阅： 管理网络
  • 系统的网络连接没有运行。如果以下错误消息出现在“新建服务器群集向导”树中，那么网络连接当前可能没有运行：

    “警告：此系统未连接到所定义的所有群集网络。”
  • 确保网络连接已启用。否则，群集服务无法检测和使用它们。

    要检查网络连接，请执行以下操作：

    1. 在控制面板中打开“网络连接”。
    2. 双击要检查的连接。
    3. 在“常规”选项卡上，检查此连接的状态。如果连接未启动，请启动它。

    必须单击“新建服务器群集向导”中的“重新分析”才能检测到更改。

    另请参阅： TCP/IP
  • 未正确安装网络硬件。
  • 请确认网络电缆连接正确。请确保电缆没有发生交叉错误（专用到公用或公用到专用），并确保每个网络适配器都按计划进行连接。对于两个以上的节点，请使用专用网络的专用集线器（非交换机）。

    将专用或混合网络上的所有多速网络适配器设置成同一速度。不要使用自动检测设置。

    如果使用容错网络适配器，请创建多个专用网络而不是单个容错网络。

    请确保所有的网络适配器都放置正确，而且已根据制造商的说明安装了正确的驱动程序。通过单击支持资源中的相应链接来确认您的硬件是否与 Windows Server 2003, Enterprise Edition 兼容。
  • 群集网络不在正确的子网上。在单个节点上指定为群集使用的所有网络适配器都需要位于不同的子网上。否则，只有子网上的第一个网络适配器才会被“新建服务器群集向导”或“添加节点向导”检测到，并且此适配器将用于群集或客户端通讯（取决于所选择的角色）。

    不过，为了使后续节点获取群集中第一个节点上定义的网络角色，每个节点中的网络适配器必须和第一个节点上的相应适配器位于同一子网。
  • 如果满足下列要求，则群集服务可检测并使用同一计算机上的多个网络适配器：
    • 网络适配器受 TCP/IP 的限制。
    • 正在使用与 Windows Server 2003, Enterprise Edition 兼容的硬件。要进行确认，请单击支持资源中的相应链接。
    • 每个网络适配器都位于不同的子网。

    不要让两个网络适配器使用同一 IP 地址，即使将它们连接到了两个不同的网络。

    当网络适配器配置正确后，可使用 ping 命令并通过环回地址 (127.0.0.1)、适配器自己的 IP 地址和其他计算机的 IP 地址来检查每个网络适配器的连接性。

    请确保每个适配器工作正常，而且可以在每个网络上通讯，然后重新启动“新建服务器群集向导”或“添加节点向导”。

    另请参阅： 为静态寻址配置 TCP/IP
  • 群集没有网络连接性。
  • 使用 ping 命令测试连接性。Ping 该节点的完全限定的域名。

    如果无法通过名称来 Ping 该节点的域控制器，请参阅硬件疑难解答。通过 IP 地址 ping 域控制器或通过名称和 IP 地址 Ping 其他网络服务器（包括该节点的 DNS 或 WINS 服务器），也可了解该问题的详细信息。

    另请参阅： 管理网络

在群集创建过程中，创建群集的第一个节点时遇到了问题。

可能的原因 解决方案
  • 网络接口没有使用有效的 IP 地址。
  • 每对链接的网络适配器地址必须位于同一子网。

    要检查 IP 地址，请依次单击“开始”、“运行”，并键入 ipconfig /all，然后按 Enter。将显示您的 IP 配置，其中包括 IP 地址、子网掩码、默认网关、DNS 服务器地址以及 DHCP 可用性。请确认这些设置是正确的。如果您正在使用 DHCP，请更改为使用静态 IP 地址。

    如果没有显示 IP 地址或其他 IP 配置，而显示 Media State = Cable Disconnected，则您可能不具有从网络适配器到连接网络设备的端对端网络连接性。请确保物理连接安全有效。如果您看到一个自动专用 IP 寻址 (APIPA) 地址，请将其更改为静态 IP。

    不要使用与公用网络 IP 范围相同的 IP 地址。

    另请参阅： TCP/IP
  • 群集没有网络连接性。
  • 使用 ping 命令测试连接性。Ping 该节点的完全限定的域名。

    如果无法通过名称来 Ping 该节点的域控制器，请打开“网络连接”并检查网络适配器的状态。还可尝试将驱动器映射到群集中的其他节点以验证通讯和身份验证。如果使用上述解决方案还是不能解决该问题，请查阅硬件疑难解答。通过 IP 地址 Ping 域控制器或通过名称和 IP 地址 Ping 其他网络服务器（包括该节点的 DNS 或 WINS 服务器），也可了解该问题的详细信息。

    另请参阅： 管理网络
  • 未使用唯一的群集名。
  • 群集名决不能与域名、网络上的所有计算机名、网络上的其他群集名以及网络上的所有虚拟服务器名相同。

    请使用 net view 命令来确定群集名是否唯一。

    要使用 net view 命令，请依次单击“开始”、“运行”，并键入下列内容，然后按 Enter：

    net view clustername

    Clustername 为群集名称。

    如果群集名不唯一，请指派一个唯一的名称。当“新建服务器群集向导”询问群集名称时，请键入适当的新群集名。
  • 群集可能无法检测到由交叉电缆组成的网络。

    双节点群集可能使用交叉电缆来实施专用网络。当在第一个节点上创建群集时，应该打开第二个节点，但它已在 BIOS 或启动菜单中停止。在这种情况下，Windows 的 Media Sense 功能可能无法将网络适配器识别为已连接。

    当出现这种情况时：

    • 在“网络连接”中，代表网络适配器连接的图标上会显示一个红色的“X”。
    • 任务栏会显示一个图标，当将鼠标悬停于此图标上时，将显示“网络电缆没有插好”。
  • 如果继续创建群集，那么当启动第二个节点时，将会检测到交叉电缆。网络将在默认模式（混合模式）下建立。然后可使用群集管理器将网络模式更改为专用。

    另请参阅： 管理网络
  • 群集网络不在正确的子网上。在单个节点上指定为群集使用的所有网络适配器都需要位于不同的子网上。否则，只有子网上的第一个网络适配器才会被“新建服务器群集向导”或“添加节点向导”检测到，并且此适配器将用于群集或客户端通讯（取决于所选择的角色）。

    不过，为了使后续节点获取群集中第一个节点上定义的网络角色，每个节点中的网络适配器必须和第一个节点上的相应适配器位于同一子网。

  • 如果满足下列要求，则群集服务可检测并使用同一计算机上的多个网络适配器：
    • 网络适配器受 TCP/IP 的限制。
    • 正在使用与 Windows Server 2003, Enterprise Edition 兼容的硬件。要进行确认，请单击支持资源中的相应链接。
    • 每个网络适配器都位于不同的子网。请验证为每个节点输入的子网。

    不要让两个网络适配器使用同一 IP 地址，即使将它们连接到了两个不同的网络。

    当网络适配器配置正确后，可使用 ping 命令并通过环回地址 (127.0.0.1)、适配器自己的 IP 地址和其他计算机的 IP 地址来检查每个网络适配器的连接性。

    请确保每个适配器工作正常，而且可以在每个网络上通讯，然后重新启动“新建服务器群集向导”或“添加节点向导”。

    另请参阅： 为静态寻址配置 TCP/IP
  • 未正确安装网络硬件。
  • 请确认网络电缆连接正确。请确保电缆没有发生交叉错误（专用到公用或公用到专用），并确保每个网络适配器都按计划进行连接。

    将专用或混合网络中的所有多速网络适配器设置为同一速度。不要使用自动检测设置。

    如果使用容错网络适配器，请创建多个专用网络而不是单个容错网络。

    请确保所有的网络适配器都放置正确，而且已根据制造商的说明安装了正确的驱动程序。通过单击支持资源中的相应链接来确认您的硬件是否与 Windows Server 2003, Enterprise Edition 兼容。
  • 未正确配置节点上的 WINS 客户端。
  • 如果使用 WINS，则具有相关 IP 地址的所有群集资源名都使用 WINS 进行注册。使用下列说明来检查 WINS 配置。

    首先，通过依次单击“开始”、“运行”，并键入 ipconfig /all 来查看客户端互连是否至少具有一个在 IP 配置中指定的 WINS 服务器。请确认为主 WINS 服务器和辅助 WINS 服务器（如果列出）返回的 IP 地址与已成功用于同一子网中正在查找同一资源的其他计算机上的 IP 地址相同。

    接着，依次单击“开始”、“运行”，键入 ping server（其中 server 是服务器的网络名称），然后按 Enter，确定该名称是否被解析。

    如果将静态 IP 寻址用于群集节点，则需要在公用网络中可用的 IP 地址上配置 WINS。

    如果客户端在连接到虚拟服务器时遇到问题，请禁用专用群集网络上的 WINS。

    要点

    • 不要为用于客户端通讯的网络适配器禁用此功能。

    配置完 WINS 后，如果已经在至少一个节点上创建了群集，请 Ping 群集名以测试其连接性。

    另请参阅： 配置 TCP/IP 使用 WINS

  • 未正确配置 TCP/IP。
  • 如果下列所有 Ping 测试都失败，则存在 TCP/IP 配置问题：
    • Ping 环回地址
    • Ping 本地 Internet 协议 (IP) 地址（公用和专用互连）
    • Ping 其他节点的 IP 地址（公用和专用互连）

    注意

    • 要通过公用互连测试名称解析，请断开专用互连电缆。

    如果无法 Ping 通另一节点的名称，但却可以成功 Ping 通该节点的 IP 地址，那么说明存在名称解析问题。请联络您的网络管理员寻求帮助。

    由不正确的 IP 地址或子网掩码导致的 TCP/IP 错误通常记录在系统日志中。请使用事件查看器在系统日志中检查这些错误。

    即使系统日志中不存在任何 TCP/IP 错误，请仍检查您的 TCP/IP 设置，以确保它们的正确性，方法是：依次单击“开始”、“运行”，然后键入 ipconfig /all。请验证列出的 IP 地址和子网掩码的值对于您的计算机是否正确。如果不知道计算机的正确 IP 地址和子网掩码值，请向网络管理员咨询。

    另请参阅： TCP/IP
  • 系统的网络连接没有运行。如果以下错误消息出现在“新服务器群集向导”树中，那么网络连接当前可能没有运行：

    “警告：此系统未连接到所定义的所有群集网络。”
  • 确保网络连接已启用。否则，群集服务无法检测和使用它们。

    要检查网络连接，请执行以下操作：

    1. 在控制面板中打开“网络连接”。
    2. 双击要检查的连接。
    3. 在检查“常规”选项卡上，检查此连接的状态。如果连接未启动，请启动它。

    必须单击“新建服务器群集向导”中的“重新分析”才能检测到更改。

    另请参阅： TCP/IP
  • 您使用的不是一个有效的 IP 地址。
  • 请为群集自身配置一个静态 IP 地址。您不能使用 DHCP 指派该地址。

    每一个群集节点上的每一个网络适配器也都需要一个 IP 地址。请为每一个适配器指派一个静态 IP 地址。每对链接的网络适配器（节点到节点的链接）地址必须在同一子网。

    如果群集节点使用 DHCP 获取非群集 IP 地址，则请在命令提示符下使用 ipconfig 命令来验证在出现问题的网络中是否具有有效的主 IP 地址。

    使用 ping 命令确认您是否具有到群集地址的 IP 连接并且已将 IP 地址分配给正确的网络。如果 Ping 测试失败，则没有基本的网络连接。

    如果做了任何更改，请重新启动“新建服务器群集向导”。必须重新启动该向导才能检测到所做的更改。

    另请参阅： 管理网络
  • 您没有正确的域帐户和相应的用户权利。
  • 请确保符合下列要求：
    • 要创建群集，必须以作为每一节点中本地 Administrators 组成员的帐户登录。建议使用域帐户。每个节点还必须是该域的成员，或者必须是受包含登录帐户的域所信任的域的成员。
    • 可使用域或本地帐户来管理群集服务；但是，其他节点只能使用域帐户加入到群集。

    如果做了任何帐户更改或用户权利更改，则必须单击“新建服务器群集向导”中的“重新分析”才能检测到所做的更改。可能还需注销然后再重新登录才能使安全更改生效。

    另请参阅： 安全

在群集创建过程中，在创建群集的第一个节点之后接着创建后续节点时遇到了问题。

可能的原因 解决方案
  • 网络接口没有使用有效的 IP 地址。
  • 每对链接的网络适配器地址必须在同一子网。

    要检查 IP 地址，请依次单击“开始”、“运行”，并键入 ipconfig /all，然后按 Enter。将显示您的 IP 配置，其中包括 IP 地址、子网掩码、默认网关、DNS 服务器地址以及 DHCP 可用性。请确认这些设置是正确的。如果正在使用 DHCP，请更改为静态 IP 地址。

    如果没有显示任何 IP 地址或其他 IP 配置，而显示 Media State = Cable Disconnected，则您可能不具有从网络适配器到连接网络设备的端对端网络连接性。请确保物理连接安全有效。

    另请参阅： TCP/IP
  • 群集没有网络连接性。
  • 使用 ping 命令测试连接性。Ping 该节点的完全限定的域名。

    如果无法通过名称来 Ping 该节点的域控制器，请参阅硬件疑难解答。通过 IP 地址 Ping 域控制器，或通过名称和 IP 地址 Ping 其他网络服务器（包括该节点的 DNS 或 WINS 服务器），也可了解该问题的详细信息。

    另请参阅： 管理网络
  • 群集可能无法检测到由交叉电缆组成的网络。

    双节点群集可能使用交叉电缆来实施专用网络。当在第一个节点上创建群集时，应该打开第二个节点，但它已在 BIOS 中或启动菜单中停止。在这种情况下，Windows 的 Media Sense 功能可能不会将网络适配器识别为已连接。

    当出现这种情况时：

    • 在“网络连接”中，代表网络适配器连接的图标上会显示一个红色的“X”。
    • 任务栏会显示一个图标，当将鼠标悬停于此图标上时，将显示“网络电缆没有插好”。
  • 如果继续创建群集，那么当启动第二个节点时，将会检测到交叉电缆。网络将在默认模式（混合模式）下建立。然后可使用群集管理器将网络模式更改为专用。

    另请参阅： 管理网络
  • 群集网络不在正确的子网上。在单个节点上指定为群集使用的所有网络适配器都需要位于不同的子网上。否则，只有子网上的第一个网络适配器会被“新建服务器群集向导”或“添加节点向导”检测到，并且此适配器将用于群集或客户端通讯（取决于所选择的角色）。

    不过，为了使后续节点获取群集中第一个节点上定义的网络角色，每个节点中的网络适配器必须和第一个节点上的相应适配器位于同一子网。

  • 如果满足下列要求，则群集服务可检测并使用同一计算机上的多个网络适配器：
    • 网络适配器受 TCP/IP 的限制。
    • 正在使用与 Windows Server 2003, Enterprise Edition 兼容的硬件。要进行确认，请单击支持资源中的相应链接。
    • 每个网络适配器都位于不同的子网。请确保验证每个节点的子网项目。

    不要让两个网络适配器使用同一 IP 地址，即使将它们连接到了两个不同的网络。

    当网络适配器配置正确后，可使用 ping 命令并通过环回地址 (127.0.0.1)、适配器自己的 IP 地址和其他计算机的 IP 地址来检查每个网络适配器的连接性。

    请确保每个适配器工作正常并可在每个网络上通讯，然后重新启动“新建服务器群集向导”或“添加节点向导”。

    另请参阅： 为静态寻址配置 TCP/IP
  • 未正确安装网络硬件。
  • 请确认网络电缆连接正确。请确保电缆没有发生交叉错误（专用到公用或公用到专用），并确保每个网络适配器都按计划进行连接。

    检查设备管理器以查看是否有资源冲突。

    将专用或混合网络中的所有多速网络适配器设置为同一速度。不要使用自动检测设置。

    如果使用容错网络适配器，请创建多个专用网络而不是单个容错网络。

    请确保所有的网络适配器都放置正确，而且已根据制造商的说明安装了正确的驱动程序。通过单击支持资源中的相应链接来确认您的硬件是否与 Windows Server 2003, Enterprise Edition 兼容。

    另请参阅： 设备管理器
  • 未正确配置节点上的 WINS 客户端。
  • 如果使用 WINS，则具有相关 IP 地址的所有群集资源名都使用 WINS 进行注册。使用下列说明来检查 WINS 配置。

    首先，通过依次单击“开始”、“运行”，并键入 ipconfig /all 来查看客户端互连是否至少具有一个在 IP 配置中指定的 WINS 服务器。请确认为主 WINS 服务器和辅助 WINS 服务器（如果列出）返回的 IP 地址与已成功用于同一子网中正在查找同一资源的其他计算机上的 IP 地址相同。

    接着，依次单击“开始”、“运行”，键入 ping server（其中 server 是服务器的网络名称），然后按 Enter，确定该名称是否被解析。

    如果将静态 IP 寻址用于群集节点，则需要在公用网络中可用的 IP 地址上配置 WINS。

    如果客户端在连接到虚拟服务器时出现问题，请在专用群集网络上禁用 TCP/IP 上的 NetBios。

    要点

    • 不要为用于客户端通讯的网络适配器禁用此功能。

    配置完 WINS 后，如果已经在至少一个节点上创建了群集，请 Ping 群集名以测试其连接性。

    另请参阅： 配置 TCP/IP 使用 WINS

  • 未正确配置 TCP/IP。
  • 如果下列所有 Ping 测试都失败，则存在 TCP/IP 配置问题：
    • Ping 环回地址
    • Ping 本地 Internet 协议 (IP) 地址（公用和专用互连）
    • Ping 其他节点的 IP 地址（公用和专用互连）

    注意

    • 要通过公用互连测试名称解析，请断开专用互连电缆。

    如果无法 Ping 通另一节点的名称，但却可以成功 Ping 通该节点的 IP 地址，那么说明存在名称解析问题。请联络您的网络管理员寻求帮助。

    由不正确的 IP 地址或子网掩码导致的 TCP/IP 错误通常记录在系统日志中。请使用事件查看器在系统日志中检查这些错误。

    即使系统日志中不存在任何 TCP/IP 错误，请仍检查您的 TCP/IP 设置，以确保它们的正确性，方法是：依次单击“开始”、“运行”，然后键入 ipconfig /all。请验证列出的 IP 地址和子网掩码的值对于您的计算机是否正确。如果不知道计算机的正确 IP 地址和子网掩码值，请向网络管理员咨询。

    请验证网络适配器的绑定和优先级。公用网络适配器优先级应最高，其次是任何专用网络适配器。

    另请参阅： TCP/IP
  • 系统的网络连接没有运行。如果以下错误消息出现在“新服务器群集向导”树中，那么网络连接当前可能没有运行：

    “警告：此系统未连接到所定义的所有群集网络。”
  • 确保网络连接已启用。否则，群集服务无法检测和使用它们。

    要检查网络连接，请执行以下操作：

    1. 在控制面板中打开“网络连接”。
    2. 双击要检查的连接。
    3. 在检查“常规”选项卡，检查此连接的状态。如果连接未启动，请启动它。

    必须单击“新建服务器群集向导”中的“重新分析”才能检测到更改。

    另请参阅： TCP/IP
  • 您使用的不是一个有效的 IP 地址。
  • 请为群集自身配置一个静态 IP 地址。您不能使用 DHCP 指派该地址。

    每一个群集节点上的每一个网络适配器也都需要一个 IP 地址。请为每一个适配器指派一个静态 IP 地址。每对链接的网络适配器（节点到节点的链接）地址必须在同一子网。

    如果群集节点使用 DHCP 获取非群集 IP 地址，则请在命令提示符下使用 ipconfig 命令来验证在出现问题的网络中是否具有有效的主 IP 地址。

    使用 ping 命令确认您是否具有到群集地址的 IP 连接并且已将 IP 地址分配给正确的网络。如果 Ping 测试失败，则您没有基本的网络连接性。

    如果做了任何更改，请重新启动“新建服务器群集向导”。必须重新启动该向导才能检测到所做的更改。

    另请参阅： 管理网络
  • 您没有正确的域帐户和相应的用户权利。
  • 请确保符合下列要求：
    • 要创建群集，必须以作为每个节点上本地 Administrators 组成员的域帐户登录，而且每个节点都必须是该域的成员。
    • 可使用域或本地帐户来管理群集服务；但是，其他节点只能使用域帐户加入到群集。

    如果做了任何帐户更改或用户权利更改，则必须单击“新建服务器群集向导”中的“重新分析”才能检测到所做的更改。

    另请参阅： 安全
  • 系统不满足群集的最小要求。
  • 请确认满足所有要求，其中包括硬件、操作系统软件配置、网络和磁盘要求。

    另请参阅： 规划和准备群集安装
  • 群集节点在不同的域中或者不在域中。
  • 所有群集节点都必须是同一域的域控制器或成员，而且对于群集服务必须使用同一帐户。

    要检查节点的计算机名和域名，请使用鼠标右键单击“我的电脑”，单击“属性”，然后单击“计算机名”选项卡。请确保所有群集节点同属一个域。为每个节点上的服务使用同一帐户和密码。该帐户必须具有下列用户权利：

    • 备份文件和目录
    • 增加调度优先级
    • 作为服务登录

    如果做了任何更改，请重新启动新建服务器群集向导。必须重新启动该向导才能检测到所做的更改。
  • 群集名不联机。
  • 要确保群集名联机，请执行以下操作：

    1. 在第一个节点上，依次单击“开始”、“运行”，然后键入 CluAdmin，打开群集管理器。
    2. 打开“组”，单击“群集组”，并检查“群集名”的状态。
    3. 如果该状态不是“联机”，请右键单击“群集名”，然后单击“联机”。
    4. 重新启动“新建服务器群集向导”。必须重新启动该向导才能检测到所做的更改。

    注意

    • 如果 Internet 协议 (IP) 地址没有联机，群集名不会联机。请确保在使群集名联机之前 IP 地址处于联机状态。
  • 群集服务未在第一个节点上运行。
  • 请确认群集服务正在第一个节点上运行，并确认在安装其他节点之前，群集组内的所有资源都处于联机状态。

    要确认是否启动了群集服务，请执行以下操作：

    1. 在第一个节点上，打开“计算机管理”。
    2. 双击“服务和应用程序”。
    3. 单击“服务”。
    4. 在详细信息窗格中，查找“群集服务”项目并检查其“状态”列。如果此服务尚未启动，请使用鼠标右键单击它，然后单击“启动”。
    5. 重新启动“新建服务器群集向导”。必须重新启动该向导才能检测到所做的更改。

    如果群集服务未启动，请查阅事件日志中的记录以查看原因。

在群集创建过程中，没有为群集磁盘自动创建物理磁盘资源。

原因：一般情况下，创建群集时，会为使用驱动器号的群集磁盘自动创建物理磁盘资源。但是，如果群集磁盘使用装入点，则不会为那些磁盘自动创建物理磁盘资源。

解决方案：必须为使用装入点的群集磁盘手动创建磁盘资源。

详细信息，请参阅清单：安装物理磁盘资源。

设置完新群集后，群集管理器无法连接到该群集。

原因：为新群集定义的名称对应于 Active Directory 目录服务中的现有计算机对象。

解决方案：确定是否需要群集的网络名称资源使用 Kerberos 身份验证。为此，请执行下列步骤：

  1. 使用命令行，使群集的网络名称资源脱机。
  2. 使用命令行，为网络名称资源启用 Kerberos 身份验证。
  3. 检查 Active Directory 中相应计算机对象上的权限，并确保群集服务用户帐户具有访问该对象的权限。
  4. 使用命令行，使群集的网络名称资源联机。

作为备用方案，如果选择不为网络名称资源使用 Kerberos 身份验证，则必须删除 Active Directory 中相应的计算机对象。在执行此操作之前，请首先确保安装的其他位置不要求该计算机对象。

有关详细信息，请参阅 Microsoft 知识库中的文章 307532 和 302389。 (http://www.microsoft.com/) 另请参阅群集资源和查找目录信息。


为残障人士提供的辅助功能

Microsoft 承诺要使每个人都能方便地使用其产品和服务。本主题提供了有关功能和服务信息的链接，这些功能和服务可使残障人士更加方便地使用 Windows Server 2003 家族产品。

注意

  • 本主题的信息仅适用于在美国获得 Microsoft 产品许可证的用户。如果在美国以外获得本产品，软件包中应包含分公司的信息卡，上面列出了 Microsoft 技术支持服务的电话号码和地址。可按此信息与当地的分公司联系，了解当地是否提供了本主题描述的产品和服务。

以下信息来源有助于您了解更多有关辅助功能和服务的信息：

  • 要了解为残障人士提供的 Microsoft 产品的详细信息，请参阅位于 Microsoft 网站 (http://www.microsoft.com) 的“Accessibility”（辅助功能）。
  • 有关辅助功能和选项的详细信息，请参阅 辅助功能选项帮助。
  • 有关在“帮助和支持中心”中使用键盘快捷键的详细信息，请参阅使用“帮助和支持”键盘快捷键。
  • 有关在“Microsoft 管理控制台 (MMC)”中使用键盘快捷键的详细信息，请参阅 MMC 的辅助功能。

此外，以下主题包括有关辅助功能、选项和资源的基本信息。

  • 辅助功能和选项
  • 获得更多的辅助功能信息

注意

  • XOX


辅助功能和选项

Windows Server 2003 家族产品包括许多辅助功能，可为视力、听力或行动有障碍的的残障人士改善显示、声音、鼠标和键盘设置。很多辅助功能对普通用户也很有用。

有关辅助功能和选项的详细信息，请参阅 辅助功能选项帮助。

  • 辅助功能
  • 设置辅助功能选项
  • 使用键盘移动鼠标指针

注意

  • XOX

有关到其他辅助功能信息的链接列表，请参阅为残障人士提供的辅助功能。


辅助功能

Windows Server 2003 家族产品包括以下有助于满足您的视觉、听觉或行动需要的工具：

  • 放大镜。将屏幕显示的一部分放大，使阅读更容易。
  • 讲述人。阅读屏幕上的信息，包括对话框名称、菜单和内容。“讲述人”提供了最低级别的辅助功能，目的是使失明或视力不佳的用户可在配置过程中或紧急情况下与 Windows Server 2003 家族产品交互。

    注意

    • “讲述人”只用美国英语提供。
    • “讲述人”需要“Windows 音频”服务，它在运行 Windows Server 2003, Web Edition、Windows Server 2003, Enterprise Edition 和 Windows Server 2003, Datacenter Edition 的计算机上，其“启动类型”默认情况下为“禁用”。要使用“讲述人”，请确保已启动“Windows 音频”服务，并且将“启动类型”设置为“自动”。详细信息，请参阅服务的默认设置。
  • 屏幕键盘。允许像鼠标或单一按键的输入设备这样的指针设备通过屏幕上显示的键盘进行输入。屏幕键盘与许多（但不是全部）键盘和键盘设置兼容。

Windows Server 2003 家族产品还为视力有障碍、行动不便或听力有障碍的用户提供了可自定义的选项：

  • 高对比度桌面配色方案。提供更多方式更改屏幕上的颜色和字体大小。
  • 声音方案。为重要的屏幕事件（如打开和关闭窗口）提供有用的音频反馈。
  • 高可见性鼠标指针方案。提供更多帮助您直观地跟踪指针的选项。

有关指向其他辅助功能信息的链接列表，请参阅为残障人士提供的辅助功能。


设置辅助功能选项

可用多种方式配置 Windows Server 2003 家族产品中的辅助功能选项以满足视觉、听觉或行动需要。默认情况下，计算机已安装了辅助功能。

可使用辅助功能向导快速设置辅助功能选项。辅助功能向导会问一些关于您的辅助功能需要的问题，并自动为您配置设置。或者，可打开“控制面板”中的“辅助功能选项”直接自定义键盘、显示和鼠标功能。

注意

如果您使用的输入设备不是鼠标，即不是采用单击操作，请使用适当的操作来完成命令或选择项目。

使用辅助功能向导来设置辅助功能选项

  1. 打开 辅助功能向导。
  2. 按屏幕上的指示进行操作。

注意

  • XOX

使用“控制面板”启用或配置辅助功能选项

  1. 打开 辅助功能选项。

注意

  • XOX

可以使用组合键来打开和关闭某些辅助功能，而不管是否启用了这些功能。当使用下列组合键时，计算机会以听觉（嘟嘟声）和视觉（对话框）提示进行响应，表明打开或关闭了辅助功能。

目的 | 请按
打开和关闭筛选键 | 将右手的 Shift 按住八秒钟
打开和关闭高对比度 | 左 Alt + 左 Shift + Print Screen
打开和关闭鼠标键 | 左 Alt + 左 Shift + Num Lock
打开和关闭粘滞键 | 将 Shift 按五次
打开和关闭切换键 | 按住 Num Lock 五秒钟


使用键盘移动鼠标指针

如果使用鼠标有困难，可以更改鼠标键设置，这样就能使用数字键盘来移动鼠标指针。通过“辅助功能向导”可完成此设置，也可以使用下列步骤在“控制面板”中设置此选项。

打开“鼠标键”

  1. XOX
  2. 在“鼠标”选项卡中，选中“使用鼠标键”复选框。

下面的插图显示了复制鼠标操作应使用哪些键。

鼠标键插图

注意

  • XOX


获得更多的辅助功能信息

有关辅助功能和选项的详细信息，请参阅辅助功能选项帮助。

有关辅助功能的信息的链接列表，请参阅为残障人士提供的辅助功能。

其他信息，请参阅：

  • 使用容易访问的格式的文档
  • 下载辅助功能信息和实用程序
  • 其他辅助功能产品和服务

注意

  • XOX


更易于获得的文档

许多 Microsoft 产品的文档都可通过其他可选方式获得。如果不方便阅读或使用打印文档，则可以获取各种 Microsoft 出版物。请参阅位于 Microsoft 网站 (http://www.microsoft.com) 的“Accessibility”（辅助功能）。

您也可以从 Recording for the Blind & Dyslexic, Inc. 处获取 Microsoft 出版物。RFB&D 将这些文档通过音频磁带或软盘分发给已注册其分发服务的合法成员。RFB&D 文档集中包含 80,000 多篇文章，其中包括 Microsoft 产品文档和 Microsoft Press 的图书。

有关详细信息，请与 Recording for the Blind & Dyslexic 联系，联系方式为：

Recording for the Blind & Dyslexic, Inc.
20 Roszel Road
Princeton, NJ 08540
电话：(800) 803-7201（在美国或加拿大境内），或者 (609) 452-0606

Recording for the Blind & Dyslexic 网站

注意

  • 网站地址可能变动，您可能无法连接到此处提及的网站。


下载辅助功能信息和实用程序

如果您拥有一个调制解调器或其他类型的网络连接，可以从下列网络服务查看或下载辅助功能信息：

  • 位于 Microsoft 网站 (http://www.microsoft.com) 的辅助功能信息
    • .
  • 位于 ftp.microsoft.com 的 Microsoft Internet 服务器

    打开 /Softlib 文件夹，然后通过自述文件或索引文件了解该站点。在索引中，搜索“自定义”和“残障人士”之类的词。选择一个文件并将其放置到 /Softlib/Mslfiles 文件夹中。在您的硬盘上创建一个文件夹，然后从所选文件的当前位置运行该文件。按照说明，将此文件解压缩到您创建的文件夹中。


其他辅助功能产品和服务

其他供残障人士使用的产品、服务和资源可以从 Microsoft 和其他机构获得。

Microsoft 提供了一份可以和 Microsoft 操作系统（包括 Windows Server 2003 家族操作系统）一起使用的辅助功能帮助的目录。要获取此目录，请参阅位于 Microsoft 网站的“Accessibility”（辅助功能）。(http://www.microsoft.com)

有关供残障人士使用的适用于 Macintosh 操作系统的产品和服务的信息，请参阅 Apple Computer 网站。

在由 Wisconsin-Madison 大学的 Trace R&D Center 负责维护的一个网站上，可以找到供残障人士和辅助技术开发人员使用的各种资源。详细信息，请联系：

Trace R&D Center
University of Wisconsin-Madison
5901 Research Park Boulevard
Madison, WI 53719-1252

电话：(608) 262-6966
TTY/TDD：(608) 263-5408
传真： (608) 262-8848

Trace Center 网站

网站地址可能变动，您可能无法连接到此处提及的网站。


选择要安装的组件

Windows Server 2003 家族产品包括多种核心组件，其中包括一些由安装程序自动安装的管理工具。此外，还可以选择许多用于扩展服务器功能的可选组件。可以在安装程序运行之后安装这些组件。安装 组件的其他方法是使用“管理您的服务器”，通过它可以指定诸如打印服务器之类的服务器角色，而不是选择该服务器角色所需要的单个组件。

有关如何使用控制面板中的“添加或删除程序”安装 Windows 组件的说明，请参阅添加或删除 Windows 组件。有关“管理您的服务器”（包括 “配置您的服务器向导”）的信息，请参阅 配置服务器角色。

选择其中的多个组件意味着在服务器上提供更多的可能性。然而，请只选择那些需要的组件，因为每一个组件都需要额外的磁盘空间。下表以及紧随其后的列表，将帮助您在安装过程中选择所需要的组件。

服务器功能和相关的软件组件

服务器功能 | 可以选用的组件
DHCP、DNS 和/或 WINS 服务器（在 TCP/IP 网络中） | 动态主机配置协议 (DHCP)、域名系统 (DNS) 和/或 Windows Internet 名称服务 (WINS)，网络服务的所有组成部分
网络的集中管理 | 管理和监视工具 远程安装服务 终端服务器；终端服务器授权 请注意，“管理远程桌面”（以前被称为“远程管理模式下的终端服务”）已内置到 Windows Server 2003 家族产品中，不需要作为组件来安装。
身份验证和安全通信 | Internet 验证服务（网络服务的组成部分） 证书服务 更新根证书
文件服务器 | 索引服务 远程存储 其他网络文件和打印服务（支持 Macintosh 和 UNIX 操作系统）
传真或打印服务器 | 传真服务 其他网络文件和打印服务（支持 Macintosh 和 UNIX 操作系统）
应用程序服务器；Internet (Web) 服务器 | 终端服务器；终端服务器授权 Internet 信息服务（应用程序服务器的一部分） ASP .NET（应用程序服务器的一部分） 消息队列（应用程序服务器的一部分） UDDI 服务 Microsoft .NET Framework 已内置到 Windows Server 2003 家族（除 64 位版本以外）的所有产品中。有关 Microsoft .NET Framework 中常用 Web 组件的详细信息，请参阅随后列表中的“应用程序服务器”。
电子邮件和通信支持，包括拨号访问 | 邮局协议 3 (POP3) 服务（电子邮件服务的一部分） 简单邮件传输协议 (SMTP) 服务（电子邮件服务的一部分） 连接点服务（管理和监视工具的一部分） 连接管理器管理工具（管理和监视工具的一部分） 请注意，“路由和远程访问”服务已内置到 Windows Server 2003 家族产品中，不需要作为组件来安装。
多媒体通信 | Windows Media Services
对各种客户端操作系统的支持 | 其他网络文件和打印服务（支持 Macintosh 和 UNIX 操作系统）。 另请参阅此表中前面的“网络的集中管理”。

下面的列表描述了前面表中的组件和可以安装的所有其他组件。

附件和实用程序
包括辅助功能向导，以及桌面附件，如写字板、画图和计算器，以及通信和媒体附件，如超级终端和 Media Player。要在“Windows 组件向导”中选择单个项目，请单击“详细信息”并从列表中进行选择。
应用程序服务器
包括 Internet 信息服务 (IIS)、ASP .NET、消息队列和相关的组件，以便提供可以在上面运行企业级 Web 应用程序的统一 Web 平台。

Microsoft .NET Framework 已内置到除 64 位版本外的所有 Windows Server 2003 家族产品中。如果计划将 Microsoft .NET Framework 与 ASP .NET 一起使用，请安装 IIS、ASP .NET 和提供您所需服务的任何其他组件（如消息队列）。

IIS 还包括网络新闻传输协议 (NNTP)、文件传输协议 (FTP) 和简单邮件传输协议 (SMTP)。

证书服务
提供可自定义的服务，用于颁发并管理采用公钥技术的软件安全系统中使用的证书。证书可以更方便地提供安全电子邮件、基于 Web 的身份验证、智能卡身份验证和其他形式的安全机制。有关对拨号用户进行身份验证的信息，请参阅本列表后面部分的“网络服务”。
电子邮件服务
包括邮局协议 3 (POP3) 服务和简单邮件传输协议 (SMTP) 服务。可以在邮件服务器上使用 POP3 服务来存储和管理电子邮件帐户。
传真服务
提供传真发送和接收支持。

XOX

索引服务
为存储在磁盘上的文档提供索引功能，可使用户进行快速的全文检索。
管理和监视工具
提供用于网络监视的工具以及用于通信管理和监视的工具，包括支持供远程用户使用的自定义客户端拨号程序的开发，以及支持执行从中心服务器自动更新电话簿。此外，还包括简单网络管理协议 (SNMP) 和 Windows Management Instrumentation (WMI) SNMP 提供程序。
网络服务
提供重要的网络支持，其中包括如下列表中的各项。要在“Windows 组件向导”中选择单个项目，请单击“详细信息”并从列表中进行选择。

有关网络监视的信息，请参阅此列表中前面的“管理和监视工具”。有关此列表中服务的背景信息，请参阅管理核心网络服务和 Internet 验证服务。

  • 域名系统 (DNS)。 提供 Active Directory 所需的名称解析服务。DNS 也是运行 Windows 2000、Windows XP 和 Windows Server 2003 家族产品的客户端常用的服务。通过名称解析，用户可以按名称访问服务器，而不必使用难以识别和记忆的 IP 地址。
  • 动态主机配置协议 (DHCP)。为服务器提供动态地向网络设备分配 IP 地址的功能。这些设备通常包括服务器和工作站计算机，而且还可以包括诸如打印机和扫描仪之类的其他设备。通过 DHCP，可以不必在这些设备上设置和维护静态 IP 地址（但提供 DHCP、DNS 和/或 WINS 服务的 Intranet 服务器除外）。
  • Internet 验证服务 (IAS)。为拨号和 VPN 用户执行身份验证、授权和记帐。IAS 可以支持 RADIUS 协议。
  • 基于 HTTP 代理的 RPC通过 Internet 信息服务 (IIS)，支持 HTTP 上的远程过程调用 (RPC) 和分布式组件对象模型 (DCOM)。
  • 简单 TCP/IP 服务。支持 Character Generator、Daytime、Discard、Echo 以及 Quote of the Day。
  • Windows Internet 名称服务 (WINS)。提供通常由运行 Windows NT 和 Microsoft 操作系统早期版本的客户端使用的名称解析服务。通过名称解析，用户可以按名称访问服务器，而不必使用难以识别和记忆的 IP 地址。
其他网络文件和打印服务
提供下列服务：
  • Macintosh 操作系统的文件服务
  • Macintosh 操作系统的打印服务

    XOX

  • Unix 打印服务。
远程安装服务
提供一种服务，该服务可以用来创建操作系统的安装映像，甚至也可以创建完整的计算机配置（包括桌面设置和应用程序）的安装映像。然后可以使客户端计算机上的用户可以使用这些映像。目标客户端计算机必须支持使用预启动执行环境 (PXE) ROM 的远程启动，或者它们必须可以用远程启动软盘启动。在服务器上，需要为远程安装服务提供单独的分区。详细信息，请参阅计划磁盘分区时的注意事项。
远程存储
可以访问更多可移动媒体（如磁带），从而扩展了磁盘空间。不常用的数据可以被自动传输到磁带上，需要时可以检索它们。
终端服务器
提供在服务器上运行客户端应用程序的能力，瘦客户端软件充当客户端的终端模拟器。每个用户都可以看到显示为桌面的单独会话，而每个会话都由服务器进行管理，并独立于任何其他客户端会话。如果安装终端服务器，还必须至少在一台计算机（不一定是安装终端服务器的计算机）上安装终端服务器授权。不过，还有 120 天的宽限期，在该期限内，即使没有安装许可证服务器并且也没有安装客户端许可证密钥包，也可以使用终端服务器。
终端服务器授权
提供授权服务，该服务用于下载、颁发和跟踪终端服务器客户端的许可证。如果安装终端服务器，还必须至少在一台计算机（不一定是安装终端服务器的计算机）上安装终端服务器授权。不过，还有 120 天的宽限期，在该期限内，即使没有安装许可证服务器并且也没有安装客户端许可证密钥包，也可以使用终端服务器。

要快速激活许可证服务器，请将它安装在能访问 Internet 的计算机上。

在终端服务器授权安装过程中，可以从两种类型的许可证服务器中选择：企业许可证服务器（默认）和域许可证服务器。基本的原则是选择企业许可证服务器，除非您安装在工作组中或安装在所有域控制器都运行 Windows NT 4.0 的域中。详细信息，请参阅终端服务器授权。

UDDI 服务
根据名为“通用描述发现和集成”(UDDI) 的工业规范，为发布和定位有关 Web 服务的信息提供支持。通过 UDDI 服务，企业开发人员可以直接通过他们的开发工具有效地发现、共享和重复使用 Web 服务。

Windows Server 2003, Web Edition 中不包括“UDDI 服务”。此外，Windows Server 2003, Standard Edition 仅支持“UDDI 服务”的独立安装。Windows Server 2003, Enterprise Edition 和 Windows Server 2003, Datacenter Edition 中提供了对分布式安装的支持。在“UDDI 服务”的独立安装中，UDDI Web 服务器组件和 UDDI 数据库组件都可安装在单个服务器上。在分布式安装中，UDDI 组件分布在多个服务器上。

有关 Windows Server 2003, Web Edition 的详细信息，请参阅 Windows Server 2003, Web Edition 概述。

更新根证书
提供一种服务，该服务可自动下载用于安全电子邮件、Web 浏览和软件传递的最新根证书。
Windows Media Services
提供多媒体支持，用于通过 Intranet 或 Internet 对 Windows Media 内容（包括流式音频和视频）进行管理、传递和存档。

XOX


Internet 和多媒体功能

Microsoft Windows 图形

Internet 功能

有关此版本中这些功能详细信息的链接，请参阅新功能。

这部分包括：

  • Internet 服务和功能
  • 用于协作的功能