Microsoft 管理控制台

Microsoft 管理控制台 (MMC) 集成了用来管理网络、计算机、服务及其他系统组件的管理工具。

  • 有关特定任务的帮助信息，请参阅如何。
  • 有关 MMC 的背景信息，请参阅概念。
  • 有关辅助特性的信息，请参阅 MMC 的辅助功能。
  • 有关问题解答的指导，请参阅 MMC 疑难解答。
  • 有关 Windows Server 2003 家族操作系统的帮助信息，请参阅访问 Windows 帮助。
  • 有关安全性的建议，请参阅最佳操作和 Runas。


最佳操作

以一般用户登录

  • 当使用管理权利登录时，就打开了您可以控制对其进行攻击的系统。详细信息，请参阅为什么您不应该以管理员身份运行计算机。
  • 使用 Runas 命令打开特定工具（如果需要）。详细信息，请参阅 Runas。
  • 对于经常使用的工具，创建可以使用 Runas 命令的快捷方式，这些快捷方式可以在不损坏安全性的前提下帮您提高工作效率。详细信息，请参阅用 runas 命令创建快捷方式。
  • 完成任务时，请关闭工具。这将消除由于任何具有管理凭据的用户访问系统或计算机而造成的安全漏洞的机会。

遵守所使用的工具的安全规范。

  • 单击每个工具的“帮助”以查阅安全规范。

有关安全性的详细信息，请参阅安全性最佳操作、安全概述以及本地安全性的最佳操作。


如何

  • 访问 Windows 帮助
  • 打开 MMC 和保存的控制台文件
  • 创作 MMC 控制台文件
  • 修改保存的 MMC 控制台文件
  • 使用 MMC 和保存的控制台文件
  • 为 MMC 和管理单元设置策略


访问 Windows 帮助

Microsoft Windows 图形

访问 Windows 帮助

  1. 单击“开始”，然后单击“帮助和支持”，访问“帮助和支持中心”。

注意

  • 打开帮助和支持中心后，就可以浏览所有帮助主题。
  • 还可以在“相关主题”中参阅“查看标准帮助”。标准帮助是 Windows 2000 随带的帮助格式，它与“帮助和支持中心”中的内容相同，只是格式不同。

    • 相关主题


打开 MMC 和保存的控制台文件

  • 打开 MMC
  • 打开本地和远程计算机上已保存的 MMC 控制台
  • 创建桌面快捷方式来打开 MMC


打开 MMC

Microsoft Windows 图形

打开 MMC

  • 执行以下任一操作：
    • 依次单击“开始”、“运行”，键入 mmc，然后单击“确定”。
    • 在命令提示符中键入 mmc，然后按 Enter。

完整的 MMC 命令行语法是：

mmc path\filename.msc [/a] [/64] [/32]

path\filename.msc

该命令将启动 MMC 并打开保存的控制台。需要为保存的控制台文件指定完整的路径和文件名。如果没有指定控制台文件，则 MMC 将打开新的控制台。

可以使用环境变量来创建不依赖于控制台文件实际位置的命令行或快捷方式。例如，如果到控制台文件的路径在系统文件夹中（例如，mmc c:\winnt\system32\console_name.msc），则可使用可展开的数据串 %systemroot% 来指定位置 (mmc %systemroot%\system32\console_name.msc)。这可以用于对组织中在不同计算机上工作的人员分配任务。

/a

该开关以作者模式打开保存的控制台，并用来更改保存的控制台。如果以该选项打开控制台，那么不管其默认模式是什么，它们都将在作者模式中打开。这样不会永久性地更改文件的默认模式设置。如果省略该选项，MMC 将根据其默认模式设置打开控制台文件。

/64

打开 64 位版本的 MMC (MMC64)。只有当您正在运行 Microsoft 64 位操作系统时，才能使用该选项。详细信息，请参阅在 Windows Server 2003 家族操作系统中运行 32 位和 64 位的管理单元。

/32

打开 32 位版本的 MMC (MMC32)。运行 Microsoft 64 位操作系统时，如果用该命令行选项打开 MMC，就可以运行 32 位管理单元。详细信息，请参阅在 Windows Server 2003 家族操作系统中运行 32 位和 64 位的管理单元。

注意

  • 在以作者模式打开 MMC 或控制台文件之后，通过单击“文件”菜单上的“打开”可以打开任何已有的控制台。
  • 可以使用该命令行为打开 MMC 和保存的控制台创建快捷方式。命令行命令用于“开始”菜单的“运行”命令、任何命令提示符窗口、快捷方式、调用该命令的任何批处理文件或程序中。
  • 默认值是 32 位。

相关主题


打开本地和远程计算机上已保存的 MMC 控制台

Microsoft Windows 图形

打开本地和远程计算机上已保存的 MMC 控制台

  1. 如果正在使用 XOX 或 XOX，请单击 此处查阅有关说明：
  • 单击“开始”，
  • 单击“控制面板”，
  • 单击“管理工具”，
  • 单击控制台。

注意

  • 可以打开控制台的其他选项：
    • 还可以使用“运行方式”命令打开控制台文件。使用该命令，可以用用户权限登录计算机来执行日常任务，但是只有在需要的时候才用管理员权限打开控制台文件来执行管理任务。要使用该命令，请在命令提示符下键入 runas，或者右键单击 .msc 文件，然后单击“运行方式”。
    • 打开控制台所在的文件夹，然后双击控制台。
    • 如果正在使用 Windows 2000，请单击 此处查阅有关说明：
  • 单击“开始”，
  • 单击“设置”，
  • 单击“控制面板”，
  • 单击“管理工具”，
  • 单击控制台。
  • 默认情况下，控制台文件不在“程序”菜单上的“管理工具”文件夹中。然而，如果创建了自定义控制台并将其保存到每个用户的“管理工具”文件夹（位于 systemdrive \Documents and Settings\user\「开始」菜单\程序\管理工具），那么，该文件夹将出现在该用户的“程序”菜单中。

相关主题


创建桌面快捷方式来打开 MMC

Microsoft Windows 图形

创建桌面快捷方式来打开 MMC

  1. 右键单击桌面上的空白区域，指向“新建”，然后单击“快捷方式”。
  2. 请按照屏幕上的指导进行操作。桌面上会出现一个快捷方式。

注意

  • 可以将在桌面上创建的快捷方式拖到操作系统的其他文件夹，例如存放 .msc 文件的文件夹或者“开始”菜单的文件夹。
  • 还可以使用 Windows 资源管理器在文件夹中创建指向 MMC 的快捷方式。要完成此操作，请单击需要创建快捷方式的文件夹，在“文件”菜单上，指向“新建”，单击“快捷方式”，然后遵循屏幕上的指示操作。

相关主题


创作 MMC 控制台文件

  • 为本地计算机添加管理单元到新 MMC 控制台
  • 将发布的管理单元添加到新 MMC 控制台
  • 将扩展管理单元添加到 MMC 控制台
  • 将发布的扩展管理单元添加到 MMC 控制台
  • 在保存的 MMC 控制台中创建任务板视图
  • 在保存的 MMC 控制台中创建任务板视图的任务
  • 在保存的 MMC 控制台中编辑任务板视图
  • 编辑保存的 MMC 控制台里任务板视图中的任务
  • 将项目添加到 MMC 控制台里的收藏夹列表中
  • 整理 MMC 控制台的收藏夹列表
  • 安装由 MMC 管理单元管理的程序
  • 设置 MMC 控制台选项
  • 保存 MMC 控制台文件


为本地计算机添加管理单元到新 MMC 控制台

Microsoft Windows 图形

为本地计算机添加管理单元到新 MMC 控制台

  1. 打开 MMC。
  2. 在“文件”菜单上，单击“添加/删除管理单元”，然后单击“添加”。
  3. 在“管理单元”下，双击要添加的项目，如果提示，执行以下的某项操作：
    • 单击“本地计算机：（运行该控制台的计算机）”，然后单击“完成”。
    • 如果出现向导，请根据指示操作。
  4. 要将其他项目添加到控制台，请重复步骤 3。

注意

  • 要打开 MMC，请单击“开始”，再单击“运行”，键入 mmc，然后单击“确定”。
  • 如果向控制台添加管理单元，并且该管理单元损坏，那么尝试将此管理单元的其他实例添加到控制台中。根据需要配置管理单元，然后删除它的第一个实例。
  • 如果将控制台保存到每个用户的“管理工具”文件夹（位于 systemdrive\Documents and Settings\users\「开始」菜单\程序\管理工具），那么，它将出现在该用户“程序”菜单的“管理工具”文件夹中。
  • 只能访问 Active Directory 中发布的管理单元。
  • 远程计算机包含一套完全特定的管理单元。
  • 如果某个管理单元未出现在列表中，必须首先安装由管理单元管理的程序、设备或服务。可以访问不是从 Active Directory 目录服务的“添加/删除管理单元”对话框中本地安装的管理单元。必须使用下列操作系统之一才能执行该过程（请参阅 此处的操作系统列表）：
    • 正在运行安装了 Windows Installer 的 Windows 98；

      • -或-

    • 正在运行安装了 Windows Installer 的 Windows NT 4.0；

      • 或

    • 正在运行 Windows Millennium Edition；

      • -并且-

    • 是 Windows 域的一部分。
    • 详细信息，请参阅“帮助”。
  • 要使项目从属于控制台树而不是控制台根节点的某一项目，请在步骤 2 中首先单击“管理单元添加到”中的相应项目，然后单击“添加”。

相关主题


将发布的管理单元添加到新 MMC 控制台

Microsoft Windows 图形

将发布的管理单元添加到新 MMC 控制台

  1. 打开 MMC。
  2. 在“文件”菜单上，单击“添加/删除管理单元”，然后单击“添加”。
  3. 单击要添加的发布管理单元，然后单击“添加”。
  4. 如果出现 Windows Installer 向导，请遵循屏幕上的指示操作，然后执行如下操作之一：
    • 单击“本地计算机：（运行该控制台的计算机）”，然后单击“完成”。
    • 如果出现管理单元向导，请遵循指示操作。
  5. 要将其他项目添加到控制台，请重复步骤 3。

注意

  • 要打开 MMC，请单击“开始”，再单击“运行”，键入 mmc，然后单击“确定”。
  • 对于 Active Directory 目录服务中可用的管理单元，“供应商”列中将显示“未安装的”。
  • 如果使用的计算机在运行 Windows 98（带有 Windows Installer）、Windows NT 4.0（带有 Windows Installer）或 Windows Millennium Edition，那么只能访问在 Active Directory 中发布的扩展管理单元。此外，该计算机必须成为 Windows 域的一部分。有关发布应用程序和 Windows Installer 的详细信息，请参阅“帮助”。
  • 如果将控制台保存到每个用户的“管理工具”文件夹（位于 systemdrive\Documents and Settings\users\「开始」菜单\程序\管理工具），那么，它将出现在该用户“程序”菜单的“管理工具”文件夹中。
  • 要使某项目从属于控制台树（而不是控制台根节点）中的某一项目，请在步骤 2 中先单击“管理单元添加到”中的相应项目，然后单击“添加”。
  • 有关 Windows Installer 的详细信息，请转到 MSDN 联机下载 (http://www.microsoft.com/china)。

相关主题


将扩展管理单元添加到 MMC 控制台

Microsoft Windows 图形

将扩展管理单元添加到 MMC 控制台

  1. 通过执行以下的某项操作，按作者模式打开保存的控制台：
    • 右键单击该 .msc 文件，然后单击“作者”。
    • 依次单击“开始”、“运行”，键入 mmc path\filename.msc /a，然后单击“确定”。
  2. 在“文件”菜单上，单击“添加/删除管理单元”，然后单击要扩展的项目。
  3. 在“扩展”选项卡上的“可扩展的管理单元”中，选中要添加的扩展旁边的复选框，然后单击“确定”。

注意

  • 要为给定项目添加每个可用的扩展，请在“扩展”选项卡上，选中“添加所有扩展”复选框。如果只添加某些扩展，请清除此复选框。
  • 您还可以用该过程从控制台中删除扩展，方法是通过清除以前所选扩展的复选框。

相关主题


将发布的扩展管理单元添加到 MMC 控制台

Microsoft Windows 图形

将发布的扩展管理单元添加到 MMC 控制台

  1. 通过执行以下的某项操作，按作者模式打开保存的控制台：
    • 右键单击该 .msc 文件，然后单击“作者”。
    • 依次单击“开始”、“运行”，键入 mmc path\filename.msc /a，然后单击“确定”。
  2. 在“文件”菜单上，单击“添加/删除管理单元”。
  3. 在“扩展”选项卡上，单击“可扩展的管理单元”中需要扩展的管理单元。
  4. 在“可用的扩展”中，选中要添加的发布扩展旁边的复选框，然后单击“下载”。
  5. 如果出现一个或多个向导，请遵循屏幕上的指示操作，然后单击“确定”。

要点

  • 如果选中“扩展”选项卡上的“添加所有扩展”复选框，那么只有在本地安装和注册的扩展管理单元才被添加到控制台中。必须专门从目录服务下载扩展管理单元，使其在控制台中可用。因此，要为给定项目添加所有发布扩展，请不要选中“添加所有扩展”复选框，而是选中每个发布扩展旁边的复选框。

注意

  • 对于 Active Directory 目录服务可用的扩展管理单元，管理单元名称后将跟一句短语“（未安装的）”。
  • 如果使用的计算机在运行 Windows 98（带有 Windows Installer）、Windows NT 4.0（带有 Windows Installer）或 Windows Millennium Edition，那么只能访问在 Active Directory 中发布的扩展管理单元。此外，该计算机必须成为 Windows 域的一部分。有关发布应用程序和 Windows Installer 的详细信息，请参阅“帮助”。

相关主题


在保存的 MMC 控制台中创建任务板视图

Microsoft Windows 图形

在保存的 MMC 控制台中创建任务板视图

  1. 通过执行以下的某项操作，按作者模式打开保存的控制台：
    • 右键单击该 .msc 文件，然后单击“作者”。
    • 单击“开始”，再单击“运行”，键入 mmc path\filename.msc /a，然后单击“确定”。
  2. 在控制台树中，单击管理单元项。
  3. 在“操作”菜单上，单击“新任务板视图”。
  4. 遵循新任务板视图向导中的指示操作。
  5. 如果要在创建新任务板视图之后立即创建任务，请在向导的最后屏幕上选中“启动新任务向导”复选框。

注意

  • 您还可以在新控制台里创建任务板视图，但是必须首先将管理单元添加到控制台中。

相关主题


在保存的 MMC 控制台中创建任务板视图的任务

Microsoft Windows 图形

在保存的 MMC 控制台中创建任务板视图的任务

  1. 通过执行以下的某项操作，按作者模式打开保存的控制台：
    • 右键单击该 .msc 文件，然后单击“作者”。
    • 依次单击“开始”、“运行”，键入 mmc path\filename.msc /a，然后单击“确定”。
  2. 在控制台树中，单击与任务板视图关联的项目，然后单击“操作”菜单上的“编辑任务板视图”。
  3. 单击“任务”选项卡上的“新建”按钮。
  4. 遵循新任务向导中的指示操作。

注意

  • 如果创建了新任务板视图并要添加任务，可以通过在新任务板视图向导的最后屏幕上选中“启动新任务向导”复选框启动新任务向导。
  • 在新任务向导的快捷菜单命令页上，在“命令源”中，如果选中“树项目任务”，但不能查看控制台树中的所有项目，则必须在启动新任务向导之前手动展开控制台树。

相关主题


在保存的 MMC 控制台中编辑任务板视图

Microsoft Windows 图形

在保存的 MMC 控制台中编辑任务板视图

  1. 通过执行以下的某项操作，按作者模式打开保存的控制台：
    • 右键单击该 .msc 文件，然后单击“作者”。
    • 依次单击“开始”、“运行”，键入 mmc path\filename.msc /a，然后单击“确定”。
  2. 在控制台树中单击与任务板视图相关的项目。在“操作”菜单上，单击“编辑任务板视图”。
  3. 在“常规”选项卡上，执行以下操作：
    • 要更改任务板视图的名称，请在“名称”中键入新名称。名称位于任务板视图的左上角，在选项卡上位于任务板视图的底部边缘。
    • 要更改任务板视图的说明，请在“描述”中键入新描述。说明出现在任务板视图的名称下面。
    • 要更改列表格式，或者将任务板视图配置为只包含任务，请单击“细节窗格的样式”中的新列表格式或“无列表”。
    • 要从视图中删除“标准”选项卡，请选中“隐藏标准选项卡”。
    • 要配置任务说明，请单击“任务描述的样式”下的“文本”或“信息提示”。文本说明显示在任务的右侧。“信息提示”说明在用户用鼠标指向任务时在弹出窗口中显示。
    • 要更改列表的大小，请在“列表大小”中，单击列表的宽度（垂直列表）或高度（水平列表）的新大小。
  4. 单击“选项”，然后执行以下的某项操作：
    • 要关联只显示控制台树中当前所选项目的任务板视图，请单击“所选的树项目”。
    • 要将任务板视图同控制台树中全部与当前所选项目类型相同的项目关联，请单击“所有与所选树项目类型相同的树项目”。

      注意

      • 如果单击该选项并想让任务板视图按默认方式显示，而不是按“标准”选项卡上的视图显示，请选中“将这些树项目的默认显示更改为此任务板视图”复选框。

相关主题


编辑保存的 MMC 控制台里任务板视图中的任务

Microsoft Windows 图形

编辑保存的 MMC 控制台里任务板视图中的任务

  1. 通过执行以下的某项操作，按作者模式打开保存的控制台：
    • 右键单击该 .msc 文件，然后单击“作者”。
    • 依次单击“开始”、“运行”，键入 mmc path\filename.msc /a，然后单击“确定”。
  2. 在控制台树中，单击与任务板视图关联的项目，然后单击“操作”菜单上的“编辑任务板视图”。
  3. 在“任务”选项卡上，单击“显示这些任务”下的任务，然后执行以下操作：
    • 要将所选任务在任务板视图的显示列表中上移，请单击“上移”。
    • 要将所选任务在任务板视图的显示列表中下移，请单击“下移”。
    • 要从任务板视图中的显示列表中删除任务，请单击“删除”。
    • 单击“修改”，然后执行以下操作：
      • 要更改任务名称，请在“常规”选项卡上的“任务名”中键入新名称。
      • 要更改任务说明，请在“常规”选项卡上的“描述”中键入新描述。根据配置任务板视图的方式，结果或者位于任务右侧，或者当用户用鼠标指向该任务时弹出。
      • 要更改任务图标，请单击“任务图标”选项卡上的新图标，然后单击“确定”。

相关主题


将项目添加到 MMC 控制台里的收藏夹列表中

Microsoft Windows 图形

将项目添加到 MMC 控制台里的收藏夹列表中

  1. 通过执行以下的某项操作，按作者模式打开保存的控制台：
    • 右键单击该 .msc 文件，然后单击“作者”。
    • 依次单击“开始”、“运行”，键入 mmc path\filename.msc /a，然后单击“确定”。
  2. 在控制台树中，单击要添加到收藏夹列表中的项目。
  3. 在详细信息窗格中，单击“标准”选项卡或者想添加任务板视图的选项卡。
  4. 在“收藏夹”菜单上，单击“添加到收藏夹”。
  5. 在“创建于”中，请执行以下的某项操作：
    • 要将项目添加到已有的文件夹，单击要保存项目的文件夹，然后单击“确定”。
    • 要将项目添加到新文件夹，单击作为父文件夹的文件夹，然后单击“新建文件夹”。在“文件夹名”中键入名称，单击“确定”，然后再单击“确定”。

注意

  • 如果单击配置有任务板视图的控制台树中的某个项目，“标准”选项卡和任务板视图的选项卡只有在控制台的详细信息窗格中可以使用。否则，详细信息窗格中看不到选项卡。

相关主题


整理 MMC 控制台的收藏夹列表

Microsoft Windows 图形

整理 MMC 控制台的收藏夹列表

  1. 通过执行以下的某项操作，按作者模式打开保存的控制台：
    • 右键单击该 .msc 文件，然后单击“作者”。
    • 依次单击“开始”、“运行”，键入 mmc path\filename.msc /a，然后单击“确定”。
  2. 在“收藏夹”菜单上，单击“整理收藏夹”，然后执行以下操作：
    • 要添加文件夹，请单击“创建文件夹”，在“文件夹名”中键入名称，然后单击“确定”。
    • 要把项目移动到文件夹，请单击“收藏夹”文件夹下面的项目，然后单击“移动到文件夹”，再单击显示项目的文件夹，最后单击“确定”。
    • 要更改项目名称，请单击收藏夹文件夹下面的项目，单击“重命名”，键入新名称，然后按 Enter。
    • 要删除项目，请单击“收藏夹”文件夹下面的项目，然后单击“删除”。

相关主题


安装由 MMC 管理单元管理的程序

Microsoft Windows 图形

安装由 MMC 管理单元管理的程序

  1. 如果使用 XOX 或 XOX，请 单击：
    • 单击“开始”，
    • 单击“控制面板”，
    • 单击“添加或删除程序”，
    • 请按照屏幕上的指导进行操作。
  2. 如果使用 Windows 2000，请 单击：
    • 单击“开始”，
    • 单击“设置”，
    • 单击“控制面板”，
    • 单击“添加或删除程序”。
    • 请依照屏幕上的指导进行操作。


设置 MMC 控制台选项

Microsoft Windows 图形

设置 MMC 控制台选项

  1. 通过执行以下的某项操作，按作者模式打开保存的控制台：
    • 右键单击 .msc 文件，然后单击“作者”。
    • 单击“开始”，再单击“运行”，键入 mmc path\filename.msc /a，然后单击“确定”。
  2. 在“文件”菜单上，单击“选项”。
  3. 要更改控制台的标题，请在框中键入新标题。
  4. 要更改控制台的图标，请单击“更改图标”。在“文件名”中键入包含图标的文件的路径。
  5. 单击“当前图标”下的图标，然后单击“确定”。
  6. 要更改控制台的默认模式，请在“控制台模式”中，单击要打开控制台的模式。
  7. 如果控制台的默认控制台模式是用户模式之一，那么进行下列操作：
    • 要防止用户编辑控制台，请选中“不要保存更改到此控制台”复选框。
    • 要让用户能访问“自定义视图”对话框，请选中“允许用户自定义视图”复选框。

注意

  • 如果更改控制台标题，那么标题栏将不显示通过单击控制台树中的项目显示的路径。然而，如果不更改标题或者删除标题，则显示路径。
  • 许多文件都含有可用于自定义控制台的图标。例如，您可以在位于 %systemroot%\System32 文件夹中的 Shell32.dll 文件中找到更多图标。
  • 要停止接收消息“将控制台设置存入控制台名称 吗？”（每次关闭以作者模式打开的控制台时该消息都出现），请设置控制台的默认模式为用户模式，并清除“不要保存更改到此控制台”复选框。默认情况下，对控制台的任何更改都保存下来。

相关主题


保存 MMC 控制台文件

Microsoft Windows 图形

保存 MMC 控制台文件

  • 在以作者模式打开的 MMC 控制台中，单击“文件”菜单上的“保存”。

注意

  • 要打开作者模式下已保存的控制台，请右键单击 .msc 文件，然后单击“作者”，或者单击“开始”，然后单击“运行”，键入 mmc path\filename.msc /a。
  • 如果控制台不是作者模式，就不可以使用“文件”菜单上的“保存”选项。这时，保存操作是通过配置控制台时是否选中“不要保存更改到此控制台”复选框决定的。单击“文件”菜单上的“选项”，可以访问此选项卡。如果未选中此复选框，那么在关闭 MMC 时将自动保存对控制台的更改。反之，在关闭 MMC 时将不保存对控制台的更改。
  • 如果将控制台保存到每个用户的“管理工具”文件夹（位于 %systemdrive%\Documents and Settings\users\「开始」菜单\程序\管理工具），那么，它将出现在该用户“程序”菜单的“管理工具”文件夹中。

相关主题


修改保存的 MMC 控制台文件

  • 重命名 MMC 控制台的控制台树上的项目
  • 从 MMC 控制台删除管理单元或其他项目
  • 从 MMC 控制台产生新控制台窗口
  • 从 MMC 控制台树的一部分产生新控制台窗口


重命名 MMC 控制台的控制台树上的项目

Microsoft Windows 图形

重命名 MMC 控制台的控制台树上的项目

  1. 通过执行以下的某项操作，按作者模式打开保存的控制台：
    • 右键单击该 .msc 文件，然后单击“作者”。
    • 依次单击“开始”、“运行”，键入 mmc path\filename.msc /a，然后单击“确定”。
  2. 在控制台树中，单击要重命名的项目。
  3. 在“操作”菜单上，单击“重命名”，然后键入新名称。

注意

  • 不是所有控制台树中的项目都能重命名。如果“重命名”命令没有出现在“操作”菜单上，那么该项目不能重命名。

相关主题


从 MMC 控制台删除管理单元或其他项目

Microsoft Windows 图形

从 MMC 控制台删除管理单元或其他项目

  1. 通过执行以下的某项操作，按作者模式打开保存的控制台：
    • 右键单击该 .msc 文件，然后单击“作者”。
    • 依次单击“开始”、“运行”，键入 mmc path\filename.msc /a，然后单击“确定”。
  2. 在“文件”菜单上，单击“添加/删除管理单元”。
  3. 在“独立”选项卡上，单击要删除的项目，然后单击“删除”。

相关主题


从 MMC 控制台产生新控制台窗口

Microsoft Windows 图形

从 MMC 控制台产生新控制台窗口

  1. 通过执行以下的某项操作，按作者模式打开保存的控制台：
    • 右键单击该 .msc 文件，然后单击“作者”。
    • 依次单击“开始”、“运行”，键入 mmc path\filename.msc /a，然后单击“确定”。
  2. 在“窗口”菜单上，单击“新建窗口”。

注意

  • 新控制台窗口位于所保存控制台的控制台根节点上。

相关主题


从 MMC 控制台树的一部分产生新控制台窗口

Microsoft Windows 图形

从 MMC 控制台树的一部分产生新控制台窗口

  1. 通过执行以下的某项操作，按作者模式打开保存的控制台：
    • 右键单击该 .msc 文件，然后单击“作者”。
    • 依次单击“开始”、“运行”，键入 mmc path\filename.msc /a，然后单击“确定”。
  2. 在控制台树中，单击想成为新控制台的控制台根节点的项目。
  3. 在“操作”菜单上，单击“从这里创建窗口”。

相关主题


使用 MMC 和保存的控制台文件

  • 查看管理单元的扩展
  • 使用磁盘清理选项卡
  • 隐藏或显示保存的 MMC 控制台功能
  • 隐藏或显示管理单元菜单和工具栏
  • 在 MMC 控制台中重新安排列
  • 在 MMC 控制台中隐藏或显示列
  • 在 MMC 控制台中筛选行
  • 将 MMC 控制台中的列导出为文本文件
  • 查看属性页关联的管理单元和项目


查看扩展

Microsoft Windows 图形

查看管理单元的扩展

  • 单击“开始”，转到“其他程序”或“所有程序”，转到“管理工具”，然后单击控制台文件名。
  • 在“添加/删除管理单元”对话框中，转到“管理单元添加到：”并选择要使用的管理单元。
  • 单击“扩展”选项卡。
  • 扩展将显示在“可用的扩展”框中。
  • 其他管理单元的扩展可以从“可扩展的管理单元：”项目列表中选择显示。

注意

  • 要查看“添加/删除管理单元”菜单，必须处于作者模式下。
  • 默认情况下，用户添加的管理单元保存在“管理工具”（%SystemDrive%/Documents and Settings/%UserName%/「开始」菜单/程序/管理工具）之中。用户也可以将它们保存在其他地方。
  • 要打开作者模式的控制台文件，请右键单击控制台文件名并选择“作者”。
  • 在打开的 MMC 控制台中，单击“文件”。从下拉菜单中，选择“添加/删除管理单元”。
  • “添加/删除管理单元”菜单不可以在任何用户模块中使用。

相关主题


使用磁盘清理选项卡

Microsoft Windows 图形

使用磁盘清理选项卡

  1. 打开 MMC。
  2. 单击菜单栏上的“文件”。
  3. 单击下拉菜单上的“选项”。打开“选项”对话框，显示了两个选项卡。
  4. 单击“磁盘清理”选项卡。
  5. 要删除控制台文件，请单击“删除文件”。
  6. 单击“确定”，关闭对话框。
  7. 要取消，请单击对话框底部的“取消”。

注意

  • 要打开 MMC，请依次单击“开始”、“运行”，键入 mmc，然后单击“确定”。
  • “磁盘清理”选项卡上的文本说明对控制台文件视图的更改会保存在用户的配置文件中。“磁盘清理”选项卡上显示了计算机上用于进行这些控制台更改的磁盘空间大小。


隐藏或显示保存的 MMC 控制台功能

Microsoft Windows 图形

隐藏或显示保存的 MMC 控制台功能

  1. 打开保存的控制台。
  2. 在“查看”菜单上，单击“自定义”。
  3. 在“MMC”下面，执行以下操作：
    • 要显示或隐藏控制台树，请选中或清除“控制台树”复选框。
    • 要显示或隐藏“操作”和“查看”菜单，请选中或清除“标准菜单（操作和查看）”复选框。
    • 要显示或隐藏控制台工具栏，请选中或清除“标准工具栏”复选框。
    • 要显示或隐藏控制台窗口底部的状态栏，请选中或清除“状态栏”复选框。
    • 要显示或隐藏详细信息窗格上的说明栏，请选中或清除“描述栏”复选框。
    • 要显示或隐藏详细资料窗格底部的选项卡，请选中或清除“任务板导航选项卡”复选框。

要点

  • 如果清除“标准菜单（操作和查看）”复选框并关闭“自定义视图”对话框，就不能访问“操作”和“查看”菜单中的命令，包括“自定义”命令。这种情况下，要访问“自定义视图”对话框，请单击系统菜单（控制台左上角的图标），然后单击“自定义视图”。

注意

  • 要以作者模式打开保存的控制台，请右键单击 .msc 文件，然后单击“作者”。
  • 单击“开始”，然后单击“运行”并键入 mmc path\filename.msc /a。
  • 当选中或清除复选框时，请查看控制台来确认所作更改是所期望的。
  • 如果隐藏“控制台树”，菜单栏上仍然可以看到“收藏夹”菜单（如果可用）。
  • 显示或隐藏详细资料窗格底部的选项卡也可以从任何以前存在的任务板视图执行。从菜单中选择“操作”，单击“编辑任务板视图”，选择或撤消选择“隐藏标准选项卡”复选框，然后单击“确定”。

相关主题


隐藏或显示管理单元菜单和工具栏

Microsoft Windows 图形

隐藏或显示管理单元菜单和工具栏

  1. 打开保存的控制台。
  2. 在“查看”菜单上，单击“自定义”。
  3. 在“管理单元”下，进行下列的一个或多个操作：
    • 要显示或隐藏指定管理单元的菜单，请选中或清除“菜单”复选框。
    • 要显示或隐藏指定管理单元的工具栏，请选中或清除“工具栏”复选框。

注意

  • 要以作者模式打开保存的控制台，请右键单击 .msc 文件，然后单击“作者”。单击“开始”，然后单击“运行”并键入 mmc path\filename.msc /a。
  • 选中或清除“菜单”和“工具栏”复选框时，不单是当前选择的管理单元，控制台中所有管理单元的菜单和工具栏都被显示或隐藏。如果锁定复选框不更改视图，当前选择的管理单元就没有自定义菜单或工具栏。

相关主题


在 MMC 控制台中重新安排列

Microsoft Windows 图形

在 MMC 控制台中重新安排列

  1. 在打开的 MMC 控制台中，单击在详细信息窗格中按列显示的控制台树中的项目。
  2. 在“查看”菜单上，单击“添加/删除列”。
  3. 在“添加/删除列”对话框中，单击“显示列”下的列名，然后单击“上移”或“下移”更改列的位置。

注意

  • 还可以使用鼠标将列标题拖到原来位置的左边或右边，重新安排详细信息窗格中的列。当拖动列时，列标题之间的突出显示表示列的新位置。
  • 可以使用鼠标拖动列标题来改变列的大小。
  • 不是所有项目都能使用该功能。如果“查看”菜单上没有“添加/删除列”选项，就不能对所选项目使用该功能。

相关主题


在 MMC 控制台中隐藏或显示列

Microsoft Windows 图形

在 MMC 控制台中隐藏或显示列

  1. 在打开的 MMC 控制台中，单击在详细信息窗格中按列显示的控制台树中的项目。
  2. 在“查看”菜单上，单击“添加/删除列”。
  3. 在“添加/删除列”对话框中，执行如下操作：
    • 要隐藏列，请单击“显示列”中要隐藏的列，然后单击“删除”。
    • 要显示列，在“可用列”中单击要显示的列，然后单击“添加”。

注意

  • 详细信息窗格中的某些列可能不能隐藏。
  • 隐藏或显示列的功能并非对所有的项目都启用。如果“查看”菜单上没有“选择列”选项，就不能对所选项目使用该功能。

相关主题


在 MMC 控制台中筛选行

Microsoft Windows 图形

在 MMC 控制台中筛选行

  1. 在打开的 MMC 控制台中，单击在详细信息窗格中按列显示的控制台树中的项目。
  2. 在“查看”菜单上，单击“筛选”。
  3. 根据需要修改“应用程序属性”对话框的“筛选器”选项卡上的选项。

    4. 筛选器显示在详细信息窗格中的列标题下面。

注意

  • 不是所有项目都能使用该功能。如果“查看”菜单上没有“筛选”选项，就不能对所选项目使用该功能。

相关主题


将 MMC 控制台中的列导出为文本文件

Microsoft Windows 图形

将 MMC 控制台中的列导出为文本文件

  1. 在打开的 MMC 控制台中，单击在详细信息窗格中按列显示的控制台树中的项目。
  2. 在“操作”菜单上，单击“导出列表”。
  3. 在“导出列表”对话框中，输入以下信息：
    • 在“保存在”中，单击要保存文件的位置。
    • 在“文件名”中，键入文件名。
    • 在“保存类型”中，单击列表中的文件格式。
    • 要只导出某些行，请选中“只保存选定行”复选框。
  4. 单击“保存”。

注意

  • 要只导出详细信息窗格中的某些行，请选中这些行。
  • 如果想导出详细信息窗格中的全部内容，请略过上一步。
  • 有些管理单元没有提供在详细信息窗格中选择多行的功能。对于这些管理单元，可以导出详细信息窗格中的所有行，而不只是选中的行。
  • “保存类型”中没有早于 Windows NT 4.0 的操作系统可用的 Unicode 文件格式。

相关主题


查看属性页关联的管理单元和项目

Microsoft Windows 图形

查看属性页关联的管理单元和项目

  1. 在打开的 MMC 控制台的控制台树或详细信息窗格中，右键单击需要查看属性的项目，再单击“属性”。
  2. 在属性对话框中，进行如下操作：
    • 要在对话框中查看提供特定属性页的管理单元，请在按住 Ctrl 键的同时指向其中一个选项卡的标签。
    • 要查看附带有属性对话框的项目在控制台树中的位置，请在按住 Ctrl 键的同时指向属性对话框的标题框。


为 MMC 和管理单元设置策略

  • 限制访问 MMC 中的作者模式
  • 限制在域的 MMC 中访问作者模式
  • 限制访问管理单元的许可列表
  • 限制访问域管理单元的允许列表
  • 允许或限制访问管理单元
  • 允许或限制访问域的管理单元


限制访问 MMC 中的作者模式

Microsoft Windows 图形

限制访问 MMC 中的作者模式

  1. 打开 MMC。
  2. 在“文件”菜单上，单击“添加/删除管理单元”，然后单击“添加”。
  3. 在“管理单元”下，单击“组策略对象编辑器”，再单击“添加”。
  4. 在“选择组策略对象”对话框中，执行下面的某个操作：
    • 要编辑本地组策略对象编辑器，请单击“本地计算机”。
    • 要编辑不同的组策略对象编辑器，请单击“浏览”。
  5. 然后依次单击“完成”、“关闭”、“确定”。

    组策略对象编辑器管理单元将打开指定的组策略对象编辑器。

  6. 在控制台树中，单击“Microsoft Management Console”。

    位置

    • 策略名策略
    • 用户配置
    • 管理模板
    • Windows 组件
    • Microsoft Management Console
  7. 在详细信息窗格中，双击“限制用户进入作者模式”。
  8. 在“设置”选项卡上，进行以下任一项操作：
    • 要允许用户在 MMC 中使用作者模式，单击“未配置”或“已禁用”。
    • 要限制用户在 MMC 中使用作者模式，单击“已启用”。

注意

  • 要打开 MMC，请单击“开始”，再单击“运行”，键入 mmc，然后单击“确定”。
  • 启用“限制用户进入作者模式”后，任何重新访问该控制台的尝试会导致出现一条错误消息，指明阻止以作者模式访问控制台。具有管理员凭据的用户可以单击“开始/运行/gpedit.msc”，打开本地计算机策略的组策略对象编辑器，这样就可以重新获得以作者模式进行访问的权限。接下来，请单击“用户配置/管理模板/Windows 组件/Microsoft Management Console”。然后，在详细细信息窗格中，双击“限制用户进入作者模式”。取消选中“已启用”单选按钮，选中“未配置”或“已禁用”。
  • 该功能只适用于已配置组策略对象编辑器的网络；系统管理员必须启用组策略对象编辑器。在 XOX 中没有提供此功能。
  • 详细信息，请在“限制用户进入作者模式”的属性对话框中单击“说明”选项卡，并请参阅“帮助”。

相关主题


限制在域的 MMC 中访问作者模式

Microsoft Windows 图形

限制在域的 MMC 中访问作者模式

  1. 打开 Active Directory 用户和计算机。
  2. 在控制台树中，右键单击要配置策略的组织单位，然后单击“属性”。
  3. 在“组策略”选项卡上，单击属性页上的“编辑”。
  4. 在控制台树中，单击 Microsoft Management Console。

    位置

    • 策略名策略
    • 用户配置
    • 管理模板
    • Windows 组件
    • Microsoft Management Console
  5. 在详细信息窗格中，双击“限制用户进入作者模式”。
  6. 在“策略”选项卡上，执行以下某项操作：
    • 要允许用户在 MMC 中使用作者模式，单击“未配置”或“已禁用”。
    • 要限制用户在 MMC 中使用作者模式，单击“已启用”。

注意

  • 要打开“Active Directory 用户和计算机”，请单击“开始”，依次指向“程序”、“管理工具”，然后单击“Active Directory 用户和计算机”。
  • Active Directory 只适用于已配置“组策略对象编辑器”的网络。您必须是域管理员或具有同等权利，并使用配置为域控制器的计算机，才能配置域的“组策略对象编辑器”。
  • 详细信息，请在“限制用户进入作者模式”的属性对话框中单击“说明”选项卡，并请参阅“帮助”。

相关主题


限制访问管理单元的许可列表

Microsoft Windows 图形

限制访问管理单元的许可列表

  1. 打开 MMC。
  2. 在“文件”菜单上，单击“添加/删除管理单元”，然后单击“添加”。
  3. 在“管理单元”下，单击“组策略对象编辑器”，再单击“添加”。
  4. 在“选择组策略”对话框中，执行下列操作之一：
    • 要编辑本地组策略对象，请单击“本地计算机”。
    • 要编辑不同的组策略对象，请单击“浏览”。
  5. 然后依次单击“完成”、“关闭”、“确定”。

    组策略对象编辑器管理单元提供了访问指定的组策略对象的方式。

  6. 在控制台树中，单击 Microsoft Management Console。

    位置

    • 策略名策略
    • 用户配置
    • 管理模板
    • Windows 组件
    • Microsoft Management Console
  7. 在详细信息窗格中，双击“限制用户只能使用列表中明确允许的管理单元”。
  8. 在“策略”选项卡上，执行以下某项操作：
    • 要允许用户访问未经明确限制的管理单元，请单击“未配置”或“已禁用”。
    • 要限制用户访问未经明确许可的任何管理单元，请单击“已 启用”。

注意

  • 要打开 MMC，请单击“开始”，再单击“运行”，键入 mmc，然后单击“确定”。
  • XOX 中没有提供该功能。
  • 该功能只适用于已配置组策略对象的网络；系统管理员必须启用组策略对象。
  • 如果启用该策略，只有许可的管理单元才出现在 MMC“添加独立的管理单元”对话框的可用管理单元列表中。
  • 详细信息，请单击“限制用户只使用列表中明确允许的管理单元属性”对话框中的“说明”选项卡，并请参阅“帮助”。

相关主题


限制访问域管理单元的允许列表

Microsoft Windows 图形

限制访问域管理单元的允许列表

  1. 打开 Active Directory 用户和计算机。
  2. 在控制台树中，右键单击要配置策略的组织单位，然后单击“属性”。
  3. 在“组策略”选项卡上，单击“编辑”。

    出现“组策略对象编辑器”。

  4. 在控制台树中，单击 Microsoft Management Console。

    位置

    • PolicyName 策略
    • 用户配置
    • 管理模板
    • Windows 组件
    • Microsoft Management Console
  5. 在详细信息窗格中，双击“限制用户只使用列表中明确允许的管理单元”。
  6. 在“策略”选项卡上，执行以下某项操作：
    • 要允许用户访问未经特别限制的管理单元，请单击“未配置”或“已禁用”。
    • 要限制用户访问未经特别许可的任何管理单元，请单击“已启用”。

注意

  • 要打开“Active Directory 用户和计算机”，请单击“开始”，依次指向“程序”、“管理工具”，然后单击“Active Directory 用户和计算机”。
  • Active Directory 只适用于已配置“组策略对象编辑器”的网络。您必须是域管理员或具有管理凭据的用户，并使用配置为域控制器的计算机，才能配置域的“组策略对象编辑器”。
  • 如果启用该策略，只有许可的管理单元才出现在 MMC “添加独立的管理单元”对话框的可用管理单元列表中。
  • 详细信息，请单击“限制用户只使用列表中明确允许的管理单元属性”对话框中的“说明”选项卡，并请参阅“帮助”。

相关主题


允许或限制访问管理单元

Microsoft Windows 图形

允许或限制访问管理单元

  1. 打开 MMC。
  2. 在“文件”菜单上，单击“添加/删除管理单元”，然后单击“添加”。
  3. 在“管理单元”下，单击“组策略对象编辑器”，再单击“添加”。
  4. 在“选择组策略对象”对话框中，执行下面的某个操作：
    • 要编辑本地组策略对象，请单击“本地计算机”。
    • 要编辑不同的组策略对象，请单击“浏览”。
  5. 单击“完成”，再单击“关闭”，然后单击“确定”。
  6. 在控制台树中，单击“受限的/许可的管理单元”。

    7. 位置

    • PolicyName 策略
    • 用户配置
    • 管理模板
    • Microsoft Management Console
    • 受限的/许可的管理单元
  7. 在详细信息窗格中，双击要允许或限制的管理单元，然后执行以下的一项操作：
    • 要使用户能够访问该管理单元（除非用户受到“限制用户只使用列表中明确允许的管理单元”策略的限制），请单击“未配置”。
    • 要允许用户访问该管理单元，请单击“已启用”。
    • 要限制用户访问该管理单元，请单击“已禁用”。

注意

  • 要打开 MMC，请单击“开始”，再单击“运行”，键入 mmc，然后单击“确定”。
  • 该功能只适用于已配置组策略对象的网络；系统管理员必须启用组策略对象。
  • 详细信息，请单击“管理单元属性”对话框中的“说明”选项卡，并请参阅“帮助”。

相关主题


允许或限制访问域的管理单元

Microsoft Windows 图形

允许或限制访问域的管理单元

  1. 打开 Active Directory 用户和计算机。
  2. 在控制台树中，右键单击要配置策略的组织单位，然后单击“属性”。
  3. 在“组策略”选项卡上，单击“编辑”。

    出现“组策略对象编辑器”。

  4. 在控制台树中，单击“受限的/许可的管理单元”。

    位置

    • PolicyName 策略
    • 用户配置
    • 管理模板
    • Windows 组件
    • Microsoft Management Console
    • 受限的/许可的管理单元
  5. 在详细信息窗格中，双击要允许或限制的管理单元，然后执行以下的一项操作：
    • 要使用户能够访问该管理单元（除非用户受到“限制用户只使用列表中明确允许的管理单元”策略的限制），请单击“未配置”。
    • 要允许用户访问该管理单元，请单击“已启用”。
    • 要限制用户访问该管理单元，请单击“已禁用”。

注意

  • 要打开“Active Directory 用户和计算机”，请单击“开始”，依次指向“程序”、“管理工具”，然后单击“Active Directory 用户和计算机”。
  • XOX 或 XOX 中没有提供 Active Directory。
  • 该功能只适用于已配置“组策略对象编辑器”的网络。您必须是域管理员或具有管理凭据的用户，并使用配置为域控制器的计算机，才能配置域的“组策略对象编辑器”。
  • 当限制或明确允许访问管理单元时，管理单元将添加到受限的或许可的管理单元列表中。受限列表的优先级大于许可列表，因此如果在两个列表中都有相同的管理单元时，则对该管理单元的访问将受到限制。
  • 详细信息，请单击“管理单元属性”对话框中的“说明”选项卡，并请参阅“帮助”。

相关主题


概念

  • MMC 概述
  • MMC 安全性
  • 了解 MMC
  • 使用 MMC
  • 在 Windows Server 2003 家族操作系统中运行 32 位和 64 位的管理单元
  • MMC 命令行选项
  • 资源


MMC 概述

可以使用 Microsoft 管理控制台 (MMC) 创建、保存并打开管理工具（称为 MMC 控制台），这些管理工具用来管理硬件、软件和 Windows 系统的网络组件。MMC 可以运行在各种 Windows 9x 和 Windows NT 操作系统上，以及 XOX、XOX 和 Windows Server 2003 家族的操作系统上。

MMC 不执行管理功能，但集成管理工具。可以添加到控制台的主要工具类型称为管理单元，其他可添加的项目包括 ActiveX 控件、网页的链接、文件夹、任务板视图和任务。

使用 MMC 有两种方法：在用户模式中使用已有的 MMC 控制台管理系统；或在作者模式中，创建新控制台或修改已有的 MMC 控制台。有关用户模式和作者模式之间差异的详细信息，请参阅控制台访问选项。

时刻记住安全性。一种比较好的做法是，管理员可以使用一个权限受限制的帐户执行日常、非管理性的任务，只有在执行特定管理任务时，才使用具有管理凭据的帐户。要不经过注销再重新登录就完成此任务，可以使用一般帐户登录，然后使用 runas 命令来运行需要管理凭据的工具。详细信息，请参阅 Runas。

有关所有安全选项的详细信息，请参阅安全性最佳操作、安全概述以及本地安全性的最佳操作。

有关 Windows Server 2003 家族操作系统其他方面的帮助，请单击“开始”、“帮助和支持”，访问“帮助和支持中心”。


MMC 安全性

始终保证安全性。

有关安全性选项的详细信息，请参阅：

  • 为什么您不应该以管理员身份运行计算机。
  • 通过管理凭据运行程序。
  • 用 runas 命令创建快捷方式。
  • 在 MMC 中使用 runas 命令。
  • 安全性最佳操作、安全概述以及本地安全性的最佳操作提供了有关安全性的广泛讨论和链接信息。


了解 MMC

这部分包含：

  • MMC 控制台
  • 组策略和 MMC
  • 作者模式的 MMC


MMC 控制台

新建的 MMC 控制台由分成两个窗格的窗口组成。左边窗格显示控制台树。控制台树显示控制台中可以使用的项目。右边的窗格包括详细信息窗格。详细信息窗格列出这些项目的信息和有关功能。随着单击控制台树中的不同项目，详细信息窗格中的信息也将变化。详细信息窗格可以显示不同的信息，包括网页、图形、图表、表格和列。

每个控制台都有自己的菜单和工具栏，与主 MMC 窗口的菜单和工具栏分开，这有利于用户执行任务。有关主 MMC 窗口的详细信息，请参阅 MMC 窗口。

使用的操作系统可能已经有预配置并且保存的控制台文件，这些控制台文件可以在“程序”菜单上或“控制面板”的“管理工具”文件夹中找到。

利用旧版 MMC（1.1 版和 1.2 版）创建的控制台可由 MMC 2.0 版读取。然而，当文件通过 MMC 2.0 版保存时，它们将被自动转换，且不能还原为早期的版本。详细信息，请参阅在 MMC 2.0 中使用早期版本的 MMC 创建的文件。


组策略和 MMC

只有管理员才可使用组策略来限制或允许访问特定管理单元，或者限制用户或组在 MMC 中使用作者模式的能力。这适用于已配置组策略的网络中。

要设置特定计算机的用户策略，必须是该计算机的管理员或有相等的权利。要设置域中组织单元的策略，必须是该域的管理员或有相等的权利。不能使用 MMC 创建计算机策略，只能创建用户策略。

有关组策略的详细信息，请参阅“帮助”。

有关对 MMC 应用组策略的详细信息，请参阅设置 MMC 中的组策略。


作者模式的 MMC

可以按作者模式使用 MMC 来创建新控制台或修改现有的控制台。要创建管理工具，请将管理单元及其他项目添加到控制台中。可以创建其他的控制台窗口，它提供组成控制台的不同项目的视图。还可以创建任务板视图，它包含从控制台的不同位置和不同工具运行菜单命令的快捷方式链接，以及运行命令行功能。保存控制台之后，就可以将其分发给用户。

这部分包含：

  • MMC 窗口
  • 管理单元
  • 任务板视图和任务
  • 控制台树和控制台根节点
  • 收藏夹列表
  • 控制台访问选项


MMC 窗口

MMC 控制台组件包含在 MMC 窗口中。该窗口有许多菜单和一个工具栏，提供打开、创建和保存 MMC 控制台的命令。MMC 窗口上的菜单和工具栏分别称为主菜单栏和主工具栏。此外，在窗口底部还有状态栏，详细信息窗格顶部有说明栏。要查看 MMC 窗口，可以通过单击“开始”和“运行”，键入 mmc 然后单击“确定”，打开 MMC。

当打开新建的 MMC 控制台时，控制台窗口出现在 MMC 窗口的工作区中。在控制台窗口中，可以组织和配置新控制台，然后使用控制台中的工具。将项目添加到控制台后，可以隐藏主菜单栏、主工具栏、说明栏和状态栏，以防止用户更改控制台。详细信息，请参阅隐藏或显示保存的 MMC 控制台功能和隐藏或显示管理单元菜单和工具栏。


管理单元

管理单元是 MMC 控制台的基本组件。管理单元总在控制台中，自己不能在 MMC 之外运行。

当安装了一个与管理单元关联的组件时，任何在该计算机上创建控制台的人员都可以使用该管理单元（除非受到用户策略的限制）。有关用户策略的信息，请参阅组策略和 MMC。

独立和扩展的管理单元

MMC 支持两种类型的管理单元：独立管理单元和扩展管理单元。可以将独立管理单元，通常称为管理单元，添加到控制台树中，而无需首先添加其他的项目。扩展管理单元，通常称为扩展，总是被添加到已存在于控制台树中的独立管理单元或扩展管理单元。当启用管理单元的扩展时，它们操作由管理单元控制的对象，如计算机、打印机、调制解调器或其他设备。

将管理单元或扩展添加到控制台时，它可能显示为控制台树的新项目，或者可能将快捷方式菜单项、附加工具栏、附加属性页或向导添加到已安装在控制台的管理单元中。

将管理单元添加到控制台

可以将单个或多个管理单元以及其他项目添加到控制台中。此外，可以将多个特定管理单元的实例添加到同一个控制台来管理不同的计算机或修复遭到损坏的控制台。每次向控制台添加新的管理单元实例时，该管理单元的所有变量都按默认值设置，直到配置了该管理单元。例如，如果先配置一个特定的管理单元来管理远程计算机，然后又添加该管理单元的第二个实例，那么系统并不自动配置第二个实例来管理远程计算机。

通常地，只能添加安装在用来创建控制台的计算机上的管理单元。然而，如果计算机是域的一部分，则可以使用 MMC 下载任何本地还没有安装的管理单元，但必须在 Active Directory 目录服务中可用。有关向控制台添加已发布管理单元和扩展的详细信息，请参阅创建控制台。有关使用 Active Directory 分发软件的详细信息，请参阅委派管理。


任务板视图和任务

任务板视图是能添加控制台详细信息窗格视图的页面，也是指向给定控制台之内和之外功能的快捷方式。可以使用这些快捷方式运行任务，如启动向导、打开属性页、执行菜单命令、运行命令行和打开网页。可以配置任务板视图，以便包含给定用户可能需要的所有任务。另外，可以在控制台中创建多个任务板视图，这样可以按功能或用户对任务分组。

任务板视图可以让初学用户更容易执行作业。例如，可以将可应用的任务添加到任务板视图，然后隐藏控制台树，这样用户能够在熟悉控制台树或操作系统中特定项目的位置之前就能开始使用工具。

还可以使用任务板视图让复杂任务变得更容易。例如，如果用户必须经常执行涉及多个管理单元和其他工具的任务，可以将任务放到一个单独的位置来打开或运行必要的对话框、属性页、命令行和脚本。

有关创建任务板视图和任务的详细信息，请参阅创建控制台。


控制台树和控制台根节点

控制台树是 MMC 控制台左边窗格中的分层结构。控制台树显示控制台中可以使用的项目。这些项目包括文件夹、管理单元、控件、网页以及其他一些工具。

要查看新控制台的控制台树，可以通过单击“开始”和“运行”，键入 mmc，然后单击“确定”，打开 MMC。

在新控制台里，控制台树上的唯一一项是标记为控制台根节点的文件夹。可以通过向控制台添加项目来创建控制台的管理功能。有关向控制台添加项目的命令，请参阅创建控制台。

不必将控制台窗口放在控制台根节点上。可以定位到控制台树中任何项目的控制台窗口中。这隐藏了控制台树中旧的根节点以上的项目，并且着重于新控制台根节点上的窗口和下面的管理工具。

有关更改控制台根节点位置的指导，请参阅从 MMC 控制台树的一部分产生新控制台窗口。

控制台树上的树枝

树枝是控制台树中添加了对象的任何项目。双击 加号图形 展开一个树枝并查看其内容，减号 减号图形 可以关闭树枝。默认树枝是一个文件夹 文件夹图形 ，可用来将控制台树上的相关项组合在一起。但是，还可使用 MMC 将工具添加到项目而不是文件夹，然后它也变成树枝。

控制台根节点是一个树枝。它唯一的功能是包含控制台树。管理单元顶部的项目通常是文件夹或其他树枝。

另外一种可以容纳其他项目的项是可查看项目。当单击可查看的项目时，它会在详细信息窗格中而不是在附加项中显示列表、文本或图形信息。网页是可查看项目，因为它们需要浏览器，只有在详细信息窗格中才能打开。不要将项目添加到可查看的项目，因为用户可能会隐藏控制台树。如果是这样，他们可能不知道可查看的项目包含有其他项目。相反，如果有可查看项目集合，便可以向控制台树中添加文件夹并把文件夹中的可查看项目组合起来。然后当控制台树被隐藏起来时，用户就可以从所有的项目中选择。

有关隐藏控制台树的指导，请参阅隐藏或显示保存的 MMC 控制台功能。

一种不能包含其他项的项目类型是树叶。单击某个树叶时，它便在详细信息窗格中列出所有项目。一般地，这些是单独包含在控制台树上的项目。然而，当项目的数量成百上千时，管理单元使用树叶而不是树枝。

向控制台添加新功能

您或许发现通过“添加/删除管理单元”命令提供的管理单元没有一个可以完全满足需求。可以尝试下面的可能方案：

  • 检查由 Microsoft 或其他厂商在网站上发布的其他管理单元或扩展。
  • 制作自己的扩展来增强已有的管理单元，或者制作新的独立管理单元。

有关这些操作的详细信息，请参阅资源。


收藏夹列表

收藏夹列表位于“收藏夹”菜单上。可以使用收藏夹列表来创建指向控制台树中项目的快捷方式。为了方便，可以添加指向经常使用工具的快捷方式，或者添加指向控制台树中许多级以下工具的快捷方式。还可以使用收藏夹列表来方便初学用户更容易地完成任务。例如，可以创建一个控制台，其收藏夹列表中只包含指向某些控制台树项目的快捷方式，这些控制台树项目是特定用户需要执行的作业。然后可以隐藏控制台树来进一步简化视图。

还可以使用收藏夹列表来整理任务板视图。例如，一个复杂的控制台可能有多个任务板视图，分布在控制台树中的多个项目中。但是，可以将所有这些任务板视图添加到收藏夹列表，这样用户就可以从一个位置访问它们。

详细信息，请参阅创建控制台。


控制台访问选项

创建自定义控制台时，可以给控制台指派两种访问选项中的一种：作者模式或用户模式。依次有三个级别的用户模式，因此共有四种默认访问控制台的选项：

    模式 | 描述
作者模式 | 启用 MMC 控制台的完全自定义功能（包括添加或删除管理单元的能力），创建新窗口，创建收藏夹和任务板，以及访问“自定义视图”和“选项”对话框中的所有选项。为自己或他人创建自定义控制台文件的用户通常使用这种模式。最终的控制台通常以下列用户模式之一保存。
用户模式－完全访问 | 与作者模式相同，只是用户无法添加或删除管理单元，更改控制台选项，创建收藏夹或任务板。
用户模式－受限访问，多窗口 | 仅提供对保存控制台文件时控制台树中可见部分的访问。用户可以创建新窗口，但是不能关闭任何现有窗口。
用户模式－受限访问，单窗口 | 仅提供对保存控制台文件时控制台树中可见部分的访问。用户不能创建新窗口。

可以在 MMC 中的“选项”对话框中配置这些选项。有关打开该对话框的指导，请参阅设置 MMC 控制台选项。

在作者模式下和用户模式下对控制台的更改，其保存方式不同。如果在作者模式下使用控制台，则关闭控制台时会提示保存更改。然而，如果在用户模式下使用控制台并且已清除“不要保存更改到此控制台”复选框（可以通过单击“文件”菜单上的“选项”找到），关闭控制台时将保存所做的更改。

如果产生下列任一情况，将忽略控制台的默认模式并且控制台以作者模式打开：

    • 打开控制台时 MMC 已经打开。
    • 通过快捷方式菜单命令“作者”打开控制台。
    • 在命令提示符下用 /a 选项打开控制台。

有关 MMC 控制台模式和命令行语法的详细信息，请参阅打开 MMC。

对于不必创建或更改 MMC 控制台的用户，不需要以 MMC 作者模式访问。系统管理员可以通过配置用户配置文件设置来防止用户在作者模式下打开 MMC，方法是通过禁用 /a 选项或者快捷方式菜单选项。另外，管理员可以使用“组策略”设置防止用户在作者模式下打开 MMC 和保存的控制台。详细信息，请参阅组策略和 MMC。


使用 MMC

这部分包含：

  • Runas
  • 在 MMC 2.0 中使用早期版本的 MMC 创建的文件
  • 使用 MMC 控制台
  • 使用所保存控制台中的属性页
  • 设置 MMC 中的组策略
  • 使用 MMC 帮助系统
  • 创作 MMC 控制台
  • 在 Windows Server 2003 家族操作系统中运行 32 位和 64 位的管理单元


在 MMC 中使用 runas 命令

管理员可以使用一个权限受限制的帐户执行日常、非管理性的任务，只有在执行特定管理任务时，才使用一个权限更大的帐户。要不经过注销再重新登录就完成这样的任务，可以用一般帐户登录，然后使用 runas 命令来运行需要更大权限的工具。

runas 命令允许您运行程序 (*.exe)、保存的 MMC 控制台 (*.msc)、程序和保存的 MMC 控制台的快捷方式及“控制面板”项。作为另一组（例如“Users”或“Power Users”组）的成员登录到计算机时，可以以管理员的身份运行。

可以使用 runas 命令来启动任何程序、MMC 控制器或“控制面板”项。只要提供适当的用户帐户和密码信息，用户帐户就具有登录到计算机的能力，并且程序、MMC 控制台、“控制面板”项在系统中及对该用户帐户均可用。

runas 命令允许您管理其他域的服务器（运行工具的计算机和要管理的服务器在不同的域中）。

如果尝试使用 runas 从网络位置启动程序、MMC 控制台或控制面板项，可能会因为用来连接网络文件共享的凭据与用来启动程序的凭据不同而失败。后者的凭据可能无法访问同一网络文件共享。

有些项，例如“打印机”文件夹和桌面项，是间接打开的，而不能使用 runas 命令启动。

如果 runas 命令失败，则可能是没有运行 Secondary Logon 服务或使用的用户帐户无效。要检查 Secondary Logon 服务的状态，请在“计算机管理”中单击“服务和应用程序”，然后单击“服务”。要测试用户帐户，请尝试使用该帐户登录合适的域。

有关 runas 命令的详细内容，请参阅 Runas。


在 MMC 2.0 中使用早期版本的 MMC 创建的文件

MMC 2.0 可以读取旧版 MMC 创建的控制台。

保存旧版 MMC 创建的文件的方法包括：

  • 如果以 MMC 2.0 作者模式使用旧版 MMC 创建的文件，可以将文件只保存在 MMC 2.0 中。
  • 可以在任何用户模式下在 MMC 2.0 中使用 MMC 1.2 文件。
  • 在用户模式下，MMC 2.0 以新格式将早期版本中的控制台更改保存在用户配置文件目录中。被转换的文件拥有所有用户更改，例如窗口的大小调整。此外，原始控制台（来自早期版本的 MMC）以原先的格式保持不变。然而，保存转换后的文件之后，就不可还原为原来的格式。

当从早期版本的 MMC 打开控制台时，MMC 2.0 将使用选择的修改设置打开该文件。然而，如果将此修改的控制台复制到另一个计算机，或通过 MMC 的“文件/选项”菜单删除设置，那么将丢失修改信息。

有关 MMC 的详细信息，请参阅：
  • 为本地计算机添加管理单元到新 MMC 控制台
  • 创建桌面快捷方式来打开 MMC
  • 安装由 MMC 管理单元管理的程序
  • 打开本地和远程计算机上已保存的 MMC 控制台


使用 MMC 控制台

可能需要使用预先配置的 MMC 控制台（一般称为“保存的控制台”，这些控制台是操作系统或应用程序的一部分），并且永远也不需要创建自定义控制台。这种预配置的控制台通常在“控制面板”的“管理工具”文件夹或“开始”菜单中可以获得。如果将自定义控制台保存到每个用户的“管理工具”文件夹中（位于 \\systemdrive\Documents and Settings\user\「开始」菜单\程序\管理工具），那么在“程序”菜单的“管理工具”文件夹中可以获得它。

任何作为操作系统的一部分的预配置控制台，都被配置成以三种用户模式之一打开。默认模式为“用户模式 - 受限访问，单窗口”。有关默认控制台模式设置的详细信息，请参阅控制台访问选项。

自定义 MMC 和保存的控制台的视图

可以使用“查看”菜单上的“自定义”命令访问“自定义视图”对话框来隐藏或显示控制台元素。可以隐藏的一个元素是“查看”菜单本身。如果这样做之后，又想重新配置视图，那么也可以从“系统”菜单的“自定义视图”命令访问“自定义视图”对话框。详细信息，请参阅隐藏或显示保存的 MMC 控制台功能和隐藏或显示管理单元菜单和工具栏。

使用所保存控制台中的列

在详细信息窗格中，对于按列显示的保存的控制台，您可以自定义如何显示列和行。例如，可以重新安排列或隐藏列。还可以通过单击列标题，按字母顺序或时间顺序重新安排行。另外，使用特定的管理单元，可以根据附加属性过滤列。如果启用该功能，那么一行包含有过滤选项的下拉列表框将显示在列标题的下面。详细信息，请参阅在 MMC 控制台中重新安排列、在 MMC 控制台中隐藏或显示列以及在 MMC 控制台中筛选行。

还可以将列的内容导出到文本文件。详细信息，请参阅将 MMC 控制台中的列导出为文本文件。

如果自定义控制台中的列，将分别保存每次会话的设置。

从旧版 MMC 使用控制台

利用旧版 MMC（1.1 版和 1.2 版）创建的控制台可由 MMC 2.0 版读取。然而，在 MMC 2.0 中保存这些文件会自动转换这些文件，以后不能够将其还原为旧格式的文件。详细信息，请参阅在 MMC 2.0 中使用早期版本的 MMC 创建的文件。


使用所保存控制台中的属性页

许多使用控制台的工作是从属性页执行的。事实上，某些控制台中的管理单元或者扩展也许只能从属性页来访问。对于一些选项卡，在按住 Ctrl 键的同时用鼠标指向属性页选项卡的标签，就可以确定提供特定属性页的管理单元。如果按住 Ctrl 键并指向属性页对话框的标题框，也可以确定控制台树中附带有属性页的项目的路径。详细信息，请参阅查看属性页关联的管理单元和项目。

控制台的属性对话框经常会隐藏在控制台和其他工具的后面。如果找不到正在操作的属性页，只需要重新打开属性对话框或者最小化屏幕上的其他工具。


设置 MMC 中的组策略

该功能只适用于已配置组策略的网络；系统管理员必须启用组策略。详细信息，请参阅组策略。

策略 | 操作 | 结果
启用“限制用户进入作者模式”。 打开配置为用作者模式打开的控制台文件。 具有管理员凭据的用户可以访问作者模式。限制访问 MMC 中的作者模式。

出现错误消息，拒绝以作者模式访问控制台。
禁用或不配置“限制用户进入作者模式”。 | 打开配置为用作者模式打开的控制台文件。 | 使用作者模式是不受限制的。
启用“限制用户只能使用列表中明确允许的管理单元”。 打开一个控制台，其中含有不在允许列表上的管理单元，或含有不在允许列表上的管理单元扩展的管理单元。 出现出错信息。

注意

  • 如果启用该策略，只有明确允许的管理单元才出现在可用的管理单元列表中（在 MMC 的“添加独立管理单元”对话框中）－ 所有其他管理单元都受限制。
禁用或不配置“限制用户只能使用列表中明确允许的管理单元”。 | 打开一个控制台，其中含有不在允许列表上的管理单元，或含有不在允许列表上的管理单元扩展的管理单元。
明确允许管理单元。 | 打开一个控制台，其中含有管理单元，或含有由允许的管理单元扩展的管理单元。 | 使用含有无限制管理单元的控制台。
明确限制管理单元。 | 打开一个控制台文件，其中含有管理单元，或含有由限制的管理单元扩展的管理单元。 | 出现出错信息。
不要配置策略来允许或限制管理单元。 | 打开一个控制台文件，其中含有管理单元，或含有该管理单元扩展的管理单元。 | 使用含有管理单元的控制台是不受限制的，除非是明确允许管理单元列表限制的用户、组或组织单元。

要使用作者模式打开 MMC 或打开控制台，请：

    • 在命令提示符中键入 mmc。
    • 在命令提示符中键入 mmc path\filename.msc /a。
    • 右键单击 .msc 文件，然后单击“作者”。
    • 打开配置为用作者模式打开的控制台文件。

要打开一个控制台文件，其中含有管理单元，或含有该管理单元扩展的管理单元，请：

    • 在命令行输入 mmc path\filename.msc
    • 双击该 .msc 文件
    • 右键单击该 .msc，然后单击“打开”


使用 MMC 帮助系统

可以从主工具栏的“帮助”菜单访问 MMC 的帮助，或者使用控制台窗口的工具栏上的 帮助按钮 来访问，或者在 MMC 窗口或控制台窗口的系统菜单上访问，或者通过右键单击控制台树或详细信息窗格上的项目来访问，或者按 F1 键也可以访问。

MMC 帮助显示一个目录，包括常规 MMC 帮助以及包含在控制台中的每个管理单元的帮助。只有那些由作者关联了现有帮助文件的管理单元，才提供管理单元帮助。如果创制控制台，您或许想为控制台相关的任务提供附加文档或者提供和与您网络特别相关的信息。


创作 MMC 控制台

这部分包含：

  • 创建控制台
  • 向控制台树添加项目
  • 添加任务板视图及任务
  • 在控制台窗口中查看控制台树
  • 在控制台树中的项目上定位控制台窗口的根节点
  • 向收藏夹列表添加项目
  • 配置控制台选项
  • 保存控制台
  • 使用自定义控制台

有关作者模式的详细信息，请参阅作者模式的 MMC。


创建控制台

在创制控制台之前，必须确定控制台将要处理的任务、要管理的组件，以及执行任务所必需的管理单元和控件。还应当考虑是否需要创建任务板视图和任务。在决定之后，可以打开新的控制台，开始向控制台树添加项目。

要创建或者编辑控制台，请在作者模式下打开控制台（使用命令行选项/a）。要查看完整的命令行语法，请参阅打开 MMC。


向控制台树添加项目

可以通过调整项目层次结构帮助用户在控制台或控制台组中确定所需组件的位置。要向控制台树添加项目，可以使用 MMC 主工具栏上“文件”菜单中的“添加/删除管理单元”命令。

在“添加/删除管理单元”对话框中，“管理单元添加到”决定要添加的新项目位于控制台树上的哪个项目下面。默认值是“控制台根节点”。单击“管理单元添加到”中的项目可定位控制台树之外的对象。

“添加独立管理单元”对话框显示可用管理单元的列表。对于域成员计算机，该列表包括本地安装的管理单元和在 Active Directory 目录服务下发布的管理单元。对于 Active Directory 中可以使用的管理单元，“未安装的”显示在“供应商”列中。

如果已安装管理单元，并想启用其扩展管理单元，可以在“添加/删除管理单元”对话框中使用“扩展”选项卡。在该选项卡中，选择控制台树中能扩展的任意项目，并查看可以启用或禁用的扩展管理单元。当启用扩展管理单元时，它将自动插入在控制台树中的选定项下面。如果在控制台树上有多个管理单元实例，那么所有的管理单元实例都将被扩展。

启用扩展管理单元之后，可能注意到它与独立管理单元一起出现在“可扩展的管理单元”之中。这意味着扩展管理单元也可以有能启用的扩展。

就像独立管理单元，系统管理员也可以在 Active Directory 下发布扩展管理单元。来自 Active Direcotry 的用户可使用的扩展管理单元和所有本地已安装的扩展管理单元一起出现在可用扩展管理单元的列表中，除了后跟“（未安装的）”的短语之外。必须专门从目录服务下载扩展管理单元，使其在控制台中可用。因此，要下载某个给定项目的所有扩展，就不必选中“添加/删除管理单元”对话框中的“扩展”选项卡上的“添加所有扩展”复选框。相反，清除该确认框，并选中需要下载的每个扩展旁边的复选框即可。

要将同一个管理单元的多个实例添加到控制台，以便从同一个控制台管理多个远程计算机或修复损坏的控制台，请向控制台中添加一个新实例，根据需要对其进行配置，然后从控制台删除管理单元的旧实例。如果您发现工具操作与预期不同，这表明配置过期，或者由于资源被删除而超时，这时您可能需要执行此任务。

有关向控制台树添加项目的信息，请参阅将管理单元添加到新 MMC 控制台、将发布的管理单元添加到新 MMC 控制台、将扩展管理单元添加到 MMC 控制台以及将发布的扩展管理单元添加到 MMC 控制台。


添加任务板视图及任务

在向控制台添加任务板视图和任务之前，先确定需要多少个任务板视图。如果需要多个任务板视图，还必须确定如何在任务板视图中分配任务。另外，必须决定需要使用哪种任务板视图显示列表和任务，或者只显示任务。

要为控制台创建任务板视图，控制台必须包括至少一个管理单元。使用新建任务板视图向导来配置标题、头和出现在任务板视图中的列表，并定义控制台树中任务板视图是与一个项目还是多个项目相关。

完成新建任务板视图向导之后，可以使用新建任务向导向任务板视图中添加任务。任务可以包括控制台中项目的菜单命令，还有从命令提示运行的命令。可以创建只对控制台树或详细信息窗格的部分区域起作用的命令，或者创建可以在计算机中打开另外一个组件的命令。然而，如果从菜单命令给在控制台树中的项目创建一个任务，然后删除该项，那么任务也将被禁用。

有关创建和编辑任务板视图及任务的信息，请参阅在保存的 MMC 控制台中创建任务板视图、在保存的 MMC 控制台中创建任务板视图的任务、在保存的 MMC 控制台中编辑任务板视图以及编辑保存的 MMC 控制台里任务板视图中的任务。


在控制台窗口中查看控制台树

当控制台树可见时，它位于控制台窗口的左边窗格。可以选择隐藏控制台树。有关隐藏控制台树的信息，请参阅隐藏或显示保存的 MMC 控制台功能。

控制台窗口中的所见是由控制台窗口从控制台树上的什么地方作为根节点来决定的。新控制台中的初始窗口是以控制台根节点为根节点的，如同用主工具栏上的“窗口”菜单中的“新建窗口”命令创建的任意窗口。

可以关闭控制台窗口以隐藏控制台根节点或控制台树的整个部分。然后，可以配置控制台阻止用户查看树的隐藏部分。但是，当保存控制台时整个控制台树总是被保存。


在控制台树中的项目上定位控制台窗口的根节点

当使用 MMC 为组制作满足每个管理需求的控制台时，也可以为缺乏经验的用户设计简单的控制台。例如，向控制台树添加项目之后，可以打开以控制台树的任何项为根节点的其他控制台窗口。可以使用该方法创建用于显示控制台树上特定管理组件的控制台窗口。然后，可以关闭显示用户不需要的控制台树部分区域的窗口。

关闭窗口不会删除控制台树上的任何项；当关闭窗口时，只是去掉了控制台树的视图。当保存控制台时整个树也被保存，可以始终查看控制台根节点。

有关更改控制台根节点的信息，请参阅从 MMC 控制台树的一部分产生新控制台窗口。

有关查看隐藏的控制台根节点的信息，请参阅从 MMC 控制台产生新控制台窗口。


向收藏夹列表添加项目

可以使用收藏夹列表创建指向控制台树里的项目和任务板视图的快捷方式。然后，可以从“收藏夹”菜单访问这些项目。

注意控制台范围窗格中的“收藏夹”选项卡已经从 MMC 2.0 中删除，但是存在于 MMC 1.2 中。

有关创建收藏夹列表的详细信息，请参阅将项目添加到 MMC 控制台里的收藏夹列表中以及整理 MMC 控制台的收藏夹列表。

配置控制台选项

可以使用“选项”对话框（位于“文件”菜单），选择控制台图标、更改控制台标题，以及选择控制台的默认模式。

可以从许多来源使用图标，其中包括位于 systemroot\system32 文件夹中的 Shell32.dll 文件。

当更改控制台标题时，请记住默认情况下，单击控制台树中的项目时，标题栏会显示到所选项目的路径。但是如果更改控制台的标题，标题框不会显示该路径。然而，如果删除标题，将恢复默认操作。

当考虑将哪种模式设为控制台的默认模式时，请记住如果使用其中一种用户模式，则可以在任何时候使用“作者”或“运行方式”命令打开控制台，不必使用作者模式运行大部分管理任务。

有关控制台选项的详细信息，请参阅设置 MMC 控制台选项以及控制台访问选项。


配置控制台选项

可以使用“选项”对话框（位于“文件”菜单），选择控制台图标、更改控制台标题，以及选择控制台的默认模式。

可以从许多来源使用图标，其中包括位于 systemroot\system32 文件夹中的 Shell32.dll 文件。

当更改控制台标题时，请记住默认情况下，单击控制台树中的项目时，标题栏会显示到所选项目的路径。如果更改控制台的标题，标题框不会显示该路径。然而，如果删除标题，将恢复默认操作。

当考虑将哪种模式设为控制台的默认模式时，请记住如果使用其中一种用户模式，则可以在任何时候使用“作者”或“运行方式”命令打开控制台，不必使用作者模式运行大部分管理任务。

有关控制台选项的详细信息，请参阅设置 MMC 控制台选项以及控制台访问选项。


保存控制台

将 MMC 控制台保存到文件，将保留控制台所加载的管理单元列表、主 MMC 窗口中的控制台窗口的排列和内容、默认模式及权限信息。所有对工具和控件的配置都将和控制台一起保存，当打开控制台文件时将被还原。可以在不同的计算机甚至是不同的网络上打开控制台文件，并还原所保存的对所有工具的设置。

控制台文件以 .msc （管理保存的控制台）为文件扩展名。正在使用的操作系统或许已经有预配置的控制台文件，这些文件可以从控制面板的“管理工具”文件夹中得到。许多应用程序还包括预配置的控制台，一般可以从“开始”菜单访问此控制台。如果您创建控制台文件并将其保存在每个用户的“管理工具”文件夹（位于 %systemdrive%\Documents and Settings\user\「开始」菜单\程序\管理工具）中，那么只有您可以从“程序”菜单上的“管理工具”文件夹中使用这些控制台文件，而该计算机上的其他用户都不可以使用。保存控制台之后，可以使用软盘、电子邮件或网络来分发。

如果以作者模式使用控制台，可以使用“文件”菜单上的“保存”命令将更改保存到此控制台。如果以用户模式使用控制台，将更改保存到此控制台是由配置控制台时是否选中“不要保存更改到此控制台”复选框（在“文件”菜单上，单击“选项”）决定。如果没选中该复选框，关闭 MMC 时会自动将更改保存到此控制台；如果选中该复选框，关闭 MMC 时将放弃对控制台的更改。有关保存控制台的详细信息，请参阅保存 MMC 控制台文件。有关控制台模式的详细信息，请参阅控制台访问选项。


使用自定义控制台

创建和保存 MMC 控制台之后，可以在本地计算机上使用，也可通过电子邮件将其发送给其他用户，也可在网络上或网站上发布，或者将它复制到软盘并安装在其他计算机上。另外，还可以使用 MMC 和 Active Direcotry 目录服务来发布控制台或向用户指派控制台。有关分发软件的详细信息，请参阅 Active Directory。

使用控制台的要求

要使用控制台，必须具有访问服务的权限和使用包括在控制台中的管理工具的权限，不管它安装在本地计算机中，还是从网络上获得。还必须具有管理控制台所管理系统组件的权限。

打开保存的控制台

如果将控制台保存到每个用户的“管理工具”文件夹（位于 systemdrive \Documents and Settings\user\「开始」菜单\程序\管理工具），那么，它将出现在“程序”菜单的“管理工具”文件夹中。

如果知道控制台文件的名称和位置，那么可以像打开其他任何文档那样打开它：

  • 双击 .msc 文件
  • 右键单击 .msc 文件，然后单击“打开”
  • 从命令提示符

在运行 Windows 2000、XOX 或 Windows Server 2003 家族操作系统的计算机上，可以使用用户权限登录计算机并执行例行的任务。然而，必须使用“运行方式”命令打开控制台文件并执行需要管理员权限的管理任务。要使用该命令，请在命令提示符下键入 runas，或者右键单击 .msc 文件，然后单击“运行方式”。

有关打开控制台的详细信息，请参阅打开本地和远程计算机上已保存的 MMC 控制台以及打开 MMC。


在 Windows Server 2003 家族操作系统中运行 32 位和 64 位的管理单元

Microsoft 64 位操作系统既可以运行 32 位 MMC (MMC32)，也可以运行 64 位 MMC (MMC64)。MMC64 不能运行 32 位管理单元，并且 MMC32 不能运行 64 位管理单元。如果调用 MMC 时未指定操作系统，则会根据运行的操作系统显示 MMC32 或 MMC64。该主题描述了如何确定和控制在 Microsoft 的 64 位操作系统中执行 MMC 的哪个版本。

可以通过命令行参数执行 MMC，例如，控制台文件名。

此外，MMC 识别如下命令行开关。

  • /32
  • /64

如果在命令行指定了前述的两个开关，则后一个开关有效。

如果 /32 或者 /64 有效，则需要考虑的启动事项。

如果 MMC 在不使用任何命令行参数的情况下启动，或者如果采用 /64 命令行选项启动，则将作为 MMC64 应用程序运行。如果通过 /32 命令行选项启动 MMC，则使用最初传递到 MMC 的相同参数启动 MMC32（/32 命令行选项除外），并终止 MMC64。

如果指定控制台文件，则需要考虑的启动事项。

如果 MMC 命令行不包含 /32 或 /64 命令行选项，但该命令行确实包含一个控制台文件名，则 MMC64 在确定执行哪个版本之前将检查该控制台文件。MMC 使用如下算法。

  1. 如果所有由控制台文件引用的管理单元可以按照 64 位的形式使用，则 MMC64 将运行（不执行剩余的算法步骤）。如果某个管理单元在作为 HKEY_CLASSES_ROOT\CLSID\snap-in clsid\InprocServer32 项值存在于注册表（其中 snap-in clsid 为该管理单元的注册的 CLSID）中，则该管理单元可以以 64 位形式使用。
  2. 如果并不是所有由该控制台文件引用的管理单元都可以以 64 位形式使用，但是所有这些管理单元却可以以 32 位的形式使用，则 MMC64 启动 MMC32。MMC32 使用在命令行指定的控制台文件运行，并且 MMC64 终止（不执行剩余的算法步骤）。如果某个管理单元在作为 HKEY_CLASSES_ROOT\Wow6432Node\CLSID\snap-in clsid\InprocServer32 项值存在于注册表（其中 snap-in clsid 为该管理单元的注册的 CLSID）中，则该管理单元可以以 32 位形式使用。
  3. 如果不可用的 64 位管理单元的数量少于不可用的 32 位管理单元的数量，则 MMC64 将运行（不执行剩余的算法步骤）。
  4. 如果不可用的 32 位管理单元的数量少于不可用的 64 位管理单元的数量，则 MMC64 将启动 MMC32，并且 MMC64 关闭（不执行剩余的算法步骤）。
  5. 如果前面的步骤都没有结果，则用户可以看到一个用户界面，提示用户指定要运行哪个版本的 MMC（同时向用户显示一个要取消的选项）。

如果 MMC64 未成功启动 MMC32，则 MMC64 将继续运行。如果 MMC64 成功启动 MMC32，则 MMC64 关闭。如果 MMC32 启动成功后才出现错误，则 MMC64 不会得到通知，因为它已关闭。


MMC 命令行选项

利用 MMC 命令行选项，可以打开特定 MMC 控制台，以作者模式打开 MMC，或者指定打开 MMC 的 32 位或 64 位版本。

语法

mmc path\filename.msc [/a] [/64] [/32]

参数

path\filename.msc
启动 MMC 并打开保存的控制台。需要为保存的控制台文件指定完整的路径和文件名。如果没有指定控制台文件，则 MMC 将打开新的控制台。
/a
在作者模式中打开保存的控制台。用来对保存的控制台进行更改。
/64
打开 64 位版本的 MMC (MMC64)。只有当您在运行 Microsoft 64 位操作系统并想使用 64 位管理单元时才使用该选项。
/32
打开 32 位版本的 MMC (MMC32)。运行 Microsoft 64 位操作系统时，如果使用只有 32 位管理单元的命令行选项打开 MMC，就可以运行 32 位管理单元。

注释

  • 使用 path\filename.msc 命令行选项

    可以使用环境变量来创建不依赖于控制台文件实际位置的命令行或快捷方式。例如，如果到控制台文件的路径在系统文件夹里（例如，mmc c:\winnt\system32\console_name.msc），可使用能展开的数据串 %systemroot% 来指定位置 (mmc %systemroot%\system32\console_name.msc)。这可以用于对组织中在不同计算机上工作的人员分配任务。

  • 使用 /a 命令行选项

    如果以该选项打开控制台，那么不管其默认模式是什么，它们都将以作者模式打开。这并不会一直改变文件设置的默认模式；当忽略该选项时，MMC 根据其默认模式设置打开控制台文件。

  • 以作者模式打开 MMC 或控制台文件后，可以通过单击“控制台”菜单中的“打开”打开任何现有的控制台。
  • 可以使用该命令行为打开 MMC 和保存的控制台创建快捷方式。命令行命令可以用于“开始”菜单的“运行”命令、任何命令提示符窗口、快捷方式、任何批处理文件或调用该命令的程序。

格式图例

格式 | 意义
斜体 | 用户必须提供的信息
粗体 | 用户必须像显示的一样准确键入的元素
省略号 (...) | 可在命令行中重复多次的参数
在括号 ([]) 之间 | 可选项目
在大括号 ({}) 之间；将选项用管线 (|) 隔开。例如：{even|odd} | 用户必须从中只选择一个选项的选项组
Courier 字体 | 程序输出

相关主题


资源

有关 MMC 的详细信息，请参阅下列参考信息：

  • 位于 Microsoft 网站 (http://www.microsoft.com/) 的个人支持中心网站包含了由 Microsoft 支持人员书写的一般支持信息和文章。
  • 详细信息，请参阅 Microsoft 网站 (http://www.microsoft.com/) 上的 Windows Server 2003 资源工具包。


MMC 的辅助功能

除了 Microsoft Windows 辅助产品和服务之外，MMC 还提供键盘快捷方式来选择命令及在控制台窗口之间导航：

  • 在 MMC 中导航
  • MMC 主窗口键盘快捷方式
  • MMC 控制台窗口键盘快捷方式

添加到 MMC 控制台的管理单元和其他项目也可能提供辅助功能。详细信息，请参考控制台项目的帮助或其他文档。


在 MMC 中导航

单击加号 加号图形 和减号 减号图形 图标，或双击鼠标，展开或关闭树枝，从而浏览 MMC 控制台树。下表列出可以用来在控制台窗口间移动的按键。

按键动作 | 结果
Tab 或 F6 | 在活动控制台窗口中的窗格之间向前移动。
Shift + Tab 或 Shift + F6 | 在活动控制台窗口中的窗格之间向后移动。
Ctrl + Tab 或 Ctrl + F6 | 在控制台窗口之间向前移动。
Ctrl + Shift + Tab 或 Ctrl + Shift + F6 | 在控制台窗口之间向后移动。
数字键盘上的加号 (+) | 扩展所选的项目。
数字键盘上的减号 (-) | 折叠所选的项目。
数字键盘上的星号 (*) | 扩展活动控制台窗口中根节点项目下面的整个控制台树。
向上键 | 将选项在窗格中上移一个项目。
向下键 | 将选项在窗格中下移一个项目。
Page Up | 将选项移到窗格中可见项目的顶部。
Page Down | 将选项移到窗格中可见项目的底部。
Home | 将选项移到窗格中的第一项。
End | 将选项移到窗格中的最后一项。
向右键 | 扩展所选的项目。如果所选项目不包括隐藏项，作用和向下键一样。
向左键 | 折叠所选的项目。如果所选项目不包括展开项，作用和向上键一样。
Alt + 向右键 | 将选项移到后一个项目。执行和工具栏上的前进箭头相同的功能。
Alt + 向左键 | 将选项移到前一个项目。执行和工具栏上的后退箭头相同的功能。

下表列出可以用来在 MMC 控制台树间移动的鼠标操作。

鼠标操作 | 结果
单击 | 选择项目。
双击 | 显示或隐藏所选项目包含的项目。显示项目属性或打开项目。
右键单击 | 显示所选项目的“操作”快捷菜单。

注意

  • 如果鼠标按钮没有执行预期的操作，则左右按钮可能交换。您使用的计算机可能已被配置过，要获取默认的操作方式，把鼠标的左右键颠倒即可。


MMC 主窗口键盘快捷方式

下表列出菜单命令的键盘快捷方式，在整个控制台或控制台的主窗口中起作用。

操作 | 结果
Ctrl + O | 打开保存的控制台。
Ctrl + N | 打开新控制台。
Ctrl + S | 保存打开的控制台。
Ctrl + M | 添加或删除控制台项。
Ctrl + W | 打开新窗口。
F5 | 刷新所有控制台窗口的内容。
Alt + 空格键 | 显示 MMC 窗口菜单。
Alt + F4 | 关闭控制台。
Alt + A | 显示“操作”菜单。
Alt + V | 显示“查看”菜单。
Alt + F | 显示“文件”菜单。
Alt + O | 显示“收藏夹”菜单。

注意

  • Ctrl + W 键盘快捷方式对以“作者模式”或“用户模式 - 完全访问”打开的控制台都可用。其他 Ctrl + 快捷方式只能用于以作者模式打开的控制台。


MMC 控制台窗口键盘快捷方式

下表列出菜单命令的键盘快捷方式，在控制台的活动控制台窗口或控制台窗口的内容中起作用。

操作 | 结果
Ctrl + P | 只有当管理单元执行打印功能时才打印当前页或活动窗格。
Alt + -（减号） | 显示活动控制台窗口的窗口菜单。
Shift + F10 | 显示所选项目的“操作”快捷菜单。
F1 | 打开所选项目的“帮助”主题，如果有的话。
F5 | 刷新所有控制台窗口的内容。
Ctrl + F10 | 最大化活动控制台窗口。
Ctrl + F5 | 还原活动控制台窗口。
Alt + Enter | 显示所选项目的属性对话框，如果有的话。
F2 | 重命名所选项目。
Ctrl + F4 | 关闭活动的控制台窗口。当控制台只有一个控制台窗口时，这个命令将关闭该控制台。


疑难解答

您有什么问题？

有关找不到管理单元的帮助。

原因： 该管理单元可能没有提供将合并到 MMC 帮助目录中的帮助文件。然而，管理单元可能使用不同的方法来提供帮助。

解决方案： 以作者模式打开含有管理单元的控制台，单击控制台树中需要帮助的项，然后单击“帮助”菜单。管理单元帮助的单独命令可能出现在“帮助”菜单的“帮助主题”命令上面。如果看不到单独的命令，请查看工具栏和详细资料窗格中的内容，看有没有帮助按钮或其他 帮助按钮 图标。如果找不到任何单独命令、按钮或图标，那么 MMC 中没有可用的管理单元帮助。

管理单元没有列在“添加独立管理单元”对话框。

原因： 计算机上可能没有安装相应的服务或软件。

解决方案： 必须安装组件以便查看管理单元。

另请参阅： 安装由 MMC 管理单元管理的程序。

原因： 如果使用运行 Windows 2000、XOX 或 Windows Server 2003 家族操作系统的计算机，系统管理员可能设置了限制访问管理单元的策略。

解决方案： 请向系统管理员咨询。

另请参阅： 设置 MMC 中的组策略

当使用控制台时，发生一个或多个以下错误：控制台行为不是所预期的，控制台超时，或者显示以前没见过的错误信息。

原因： 原因是以下之一。控制台文件可能已损坏。或者，由于更改了网络，使得控制台配置已经过期。

解决方案： 确定控制台中的哪个管理单元引起问题，然后查找管理单元文档中的疑难解答信息以便找出如何修复或者重新配置管理单元的方法。要确定哪个管理单元出了问题，可以右键单击控制台树或详细信息窗格中的项目，然后单击“属性”。按住 Ctrl 键的同时指向对话框中的选项卡标签。

如果不能直接修复或者重新配置该控制台，试着向控制台添加使用的管理单元的另外一个实例，需要的话再对其进行配置，然后删除旧的管理单元实例。

另请参阅： 将管理单元添加到新 MMC 控制台、管理单元以及查看属性页关联的管理单元和项目。


请求的工具不可用

要使用该工具，请尝试以下操作：

配置计算机。

要访问某些管理工具，必须使用以下某项：

  • 运行 Windows Server 2003 家族操作系统的计算机，已配置为一个域控制器。
  • 具备以下条件的客户端计算机：运行 XOX，已被添加到域中，已安装 Windows Server 2003 管理工具包。
  • 运行 Windows Server 2003 的服务器，已添加到域中。

有关配置域控制器和安装 Windows Server 2003 管理工具包的详细信息，请参阅“帮助”。

安装必要的硬件。

当安装硬件时，某些相关的应用程序将自动安装。例如，当安装传真设备时，Windows Server 2003 家族的操作系统将安装“传真”。要安装新硬件，请单击“开始”，指向“设置”，单击“控制面板”，然后双击“添加/删除硬件”。

安装工具。

工具可能无法安装在您的计算机上，因为：

  • 它是一个可选组件。要安装可选组件，请单击“开始”，指向“设置”，单击“控制面板”，然后双击“添加或删除程序”。
  • 如果计算机在网络上，系统管理员可能已删除该应用程序或设置了防止您启动它的策略。
  • 已经安装了“管理工具包”，但该工具是还没有添加的可选组件之一。

需要访问 Active Directory 管理单元。

可以使用 XOX 上的远程桌面访问运行 Windows Server 2003 家族操作系统的计算机上的终端服务（其管理单元可用）。有关使用远程桌面和终端服务的详细信息，请参阅：

  • 创建新的连接
  • Windows Server 2003 家族操作系统主页。(http://www.microsoft.com/)

与系统管理员联系。

如果计算机在网络上，系统管理员可能已删除该工具。


在保存的 MMC 控制台自定义列

在详细信息窗格中显示列的保存的 MMC 控制台中，可以自定义列和行如何显示。例如，可以重新安排列或隐藏列。还可以通过单击列标题，按字母顺序或时间顺序重新安排行。另外，使用特定的管理单元，可以根据附加属性过滤列。如果启用该功能，包含要筛选选项的下拉列表框将显示在列标题的下面。有关自定义列的详细信息，请参阅在 MMC 控制台中重新安排列、在 MMC 控制台中隐藏或显示列以及在 MMC 控制台中筛选行。

还可以将列的内容导出到文本文件。详细信息，请参阅将 MMC 控制台中的列导出为文本文件。

如果自定义控制台中的列，设置将在每次会话中自动保存。


使用 MMC 控制台文件

Microsoft 管理控制台 (MMC) 集成了各种工具（包括管理单元），可用来管理本地和远程计算机。Windows 系统可能已包含了保存为控制台文件（以 .msc 为扩展名）的工具。这些工具可以在“控制面板”和“程序”菜单的“管理工具”文件夹中获得。另外，您可以使用 MMC 创建自定义管理工具并将这些工具分发给用户。可以在 XOX 和 Windows Server 2003 家族操作系统中保存这些工具，这样就可以在“程序”菜单的“管理工具”文件夹中获取它们。

  • 管理本地计算机

    • 将项目添加到本地计算机的新 MMC 控制台

    1. 依次单击“开始”、“运行”，键入 mmc，然后单击“确定”。
    2. 在“文件”菜单上，单击“添加/删除管理单元”，然后单击“添加”。
    3. 在“管理单元”下，双击要添加的项目，然后执行下面的任一操作：
      • 单击“本地计算机：（运行该控制台的计算机）”，然后单击“完成”。
      • 如果出现向导，请按照屏幕上的指导说明进行操作。
    4. 要将其他项目添加到控制台，请重复步骤 3。

    注意

    • 如果将控制台保存到每个用户的“管理工具”文件夹（位于 systemdrive \Documents and Settings\All users\「开始」菜单\程序\管理工具），那么，它将出现在“程序”菜单的“管理工具”文件夹中。
    • 如果列表中没有管理单元，那么就必须首先安装由该管理单元管理的程序、设备或服务。
    • 要使某项目从属于控制台树（而不是控制台根节点）中的某一项目，请在步骤 2 中先单击“管理单元添加到”中的相应项目，然后单击“添加”。

    打开本地计算机所保存的 MMC 控制台

    • 执行以下任一操作：
      • 单击“开始”，指向“设置”，单击“控制面板”，双击“管理工具”，然后双击控制台。
      • 单击“开始”，指向“程序”，指向“管理工具”，然后单击控制台。
      • 单击“程序”菜单上的控制台。
      • 打开控制台所在的文件夹，然后双击控制台。
  • 管理远程计算机

    • 将项目添加到远程计算机的新 MMC 控制台

    1. 依次单击“开始”、“运行”，键入 mmc，然后单击“确定”。
    2. 在“文件”菜单上，单击“添加/删除管理单元”，然后单击“添加”。
    3. 在“管理单元”下，双击要添加的项目，然后执行以下操作：
      • 单击“另一台计算机”，键入该管理单元要管理的计算机名，然后单击“完成”。
      • 如果出现向导，请按照屏幕上的指导说明进行操作。
    4. 要将其他项目添加到控制台，请重复步骤 3。

    注意

    • 如果列表中没有管理单元，那么必须首先在远程计算机上安装由管理单元管理的程序、设备或服务。
    • 如果在步骤 3 中没有出现对话框或向导，就只能使用控制台项目来管理本地计算机。
    • 如果将控制台保存到每个用户的“管理工具”文件夹（位于 systemdrive \Documents and Settings\All users\「开始」菜单\程序\管理工具），那么，它将出现在“程序”菜单的“管理工具”文件夹中。
    • 要使某项目从属于控制台树（而不是控制台根节点）中的某一项目，请在步骤 2 中先单击“管理单元添加到”中的相应项目，然后单击“添加”。

    打开远程计算机保存的 MMC 控制台

    • 执行以下任一操作：
      • 单击“开始”，指向“程序”，再指向“管理工具”，然后单击控制台。
      • 打开控制台所在的文件夹，然后双击相应的控制台。
  • 常规步骤

    • 打开 MMC

    • 在命令提示符下，键入：

      • mmc

    安装由 MMC 管理单元管理的程序

    1. 单击“开始”，指向“设置”，再单击“控制面板”，然后双击“添加或删除程序”。
    2. 请按照屏幕上的指导进行操作。


Support Online

Online support
and information
  • Download updates, new features, and drivers from Windows Update (http://windowsupdate.microsoft.com)
  • Microsoft Product Support Services (http://support.microsoft.com)
  • Microsoft Accessibility Web site (http://www.microsoft.com/enable)