安装 Windows Server 2003 R2

此文档提供如何安装或升级 Microsoft® Windows Server™ 2003 R2 操作系统及其组件的信息。

Windows Server 2003 R2 包含两张产品光盘。光盘 1 包含 Windows Server 2003 的最新版本。光盘 2 包含 Windows Server 2003 R2 可选组件的安装文件。

注意

安装光盘 2 时不会自动安装 Windows Server 2003 R2 可选组件。安装完成之后，可以使用“控制面板”中的“添加/删除 Windows 组件”来安装可选组件。也可以选择使用“管理您的服务器”来添加或升级服务器角色。有关这些选项的详细信息，请参阅安装可选组件和服务器角色。

本主题内容

  • 安装之前

  • 安装或升级到 Windows Server 2003 R2

  • 安装可选组件和服务器角色

  • 从运行 Windows XP 的计算机管理组件

  • Windows Server 2003 R2 安装问题疑难解答

© 2006 Microsoft Corporation。保留所有权利。


安装之前

在安装 Windows Server 2003 R2 之前，请执行以下操作：

  • 如果要升级，应完整备份您的服务器。在您的备份中应当包括计算机运行所需的全部数据和配置信息。对服务器，尤其是那些提供网络基础结构（例如动态主机配置协议 (DHCP)）的服务器进行配置信息的备份是十分重要的。执行备份时，请务必包括启动分区和系统分区以及“系统状态”数据。备份配置信息的另一种方法是创建用于自动系统恢复的备份集。

  • 更新域控制器上的 Active Directory 架构。在 Windows Server 2003 Active Directory 网络中，在执行下列操作之前将需要更新 Active Directory 架构：

    • 在域控制器上安装 Windows Server 2003 R2。

    • 使用 Active Directory 安装向导 (Dcpromo.exe) 将 Windows Server 2003 R2 服务器配置为域控制器。

    要更新架构，在架构主机域控制器上插入光盘 2 并打开命令提示符。然后，切换到光盘 2 上的 Cmpnents\R2\Adprep 文件夹，并键入：adprep.exe /forestprep

  • 断开 UPS 设备。如果目标计算机与不间断电源 (UPS) 相连，那么在运行安装程序之前请断开正在连接的串行电缆。安装程序将自动尝试检测连接到串行端口的设备，而且 UPS 设备可能导致在检测过程中出现问题。

  • 考虑光盘 1 上可能影响安全性的下列功能：

    • Windows 防火墙。默认情况下，Windows 防火墙处于关闭状态，必须将其打开以开始保护系统。在启用 Windows 防火墙之前，应了解 Windows 防火墙将对您的环境所作的更改。如果选择启用 Windows 防火墙，应使用安全配置向导 (SCW) 进行配置，或基于 SCW 安全策略的配置。

    • 安全配置向导 (SCW)。SCW 是配置 Windows 防火墙并基于服务器的角色为它们创建安全策略的首选方法。SCW 提供了配置 Windows 防火墙的指导方法。在为服务器部署 SCW 策略之前，应研究 SCW、Windows 防火墙以及两者的最佳操作。有关详细信息，请参阅 Microsoft 网站上的“Security Configuration Wizard for Windows Server 2003”(http://go.microsoft.com/fwlink/?LinkId=45503)（英文）。

      此外，应对 SCW 和 Windows 防火墙（或任何其他您可能正在使用的防火墙）进行试验部署测试。

    • Internet Explorer。如果正在从 Windows Server 2003 升级，应该注意对光盘 1 上的 Microsoft Internet Explorer 进行的许多更改。例如，Internet Explorer 已经过更新，可以防止无意下载虚假的恶意代码。还禁止自动调整浏览器窗口的大小（该操作有时用于从计算机提取敏感数据）。有关这些更改的详细信息，请参阅 Microsoft 网站上的“Changes to Functionality in Microsoft Windows Server 2003 Service Pack 1”(http://go.microsoft.com/fwlink/?LinkId=47557)（英文）。

  • 检查最低系统要求。检查 Windows Server 2003 的最低系统要求和建议系统要求。要进行检查，请参阅 Microsoft 网站上的“System Requirements and Hardware Compatibility”(http://go.microsoft.com/fwlink/?LinkId=51190)（英文）。除了这些要求之外，您将需要为光盘 2 留出大约 100 MB 的硬盘空间。

  • 阅读两张产品光盘上的发行说明。光盘 1 上的发行说明 (Relnotes.htm) 包含有关 Windows Server 2003 的最新问题的信息。光盘 2 上的发行说明 (R2relnotes.htm) 包含有关 Windows Server 2003 R2 的最新问题的信息。

  • 提供大容量存储驱动程序。如果拥有用于硬盘的大容量存储控制器（例如 SCSI、RAID 或光纤通道适配器），请查阅 Microsoft 网站上 Windows Server Catalog 中的硬件和软件兼容性信息 (http://go.microsoft.com/fwlink/?LinkId=37823)（英文），确认该控制器的设计是否适用于 Windows Server 2003 家族产品。

    如果控制器兼容，但您知道制造商已经提供了一个用于 Windows Server2003 家族产品的单独驱动程序文件，则应在开始安装之前获取该文件（在软盘或光盘上）。在安装程序开始过程中，屏幕底部会有一行提示您按 F6 的信息。按键后将出现进一步的提示，指导您为安装程序提供驱动程序文件，以便安装程序可以访问大容量存储控制器。

    如果不能确定是否必须从大容量存储控制器的制造商那里获得单独的驱动程序文件，则可以尝试运行安装程序。如果安装光盘上的驱动程序文件不支持该控制器，并因此需要硬件制造商提供的驱动程序文件，安装程序会停止并显示一条“找不到磁盘设备”的消息，或显示一个不完整的控制器列表。获得必要的驱动程序文件后，重新启动安装程序，并在出现提示时按 F6。

  • 准备镜像集或其他磁盘集。如果已使用 Microsoft Windows NT® 4.0 操作系统创建了卷集、镜像集、带区集或具有奇偶校验的带区集，并希望运行光盘 1 上的安装程序，则必须首先准备磁盘集。有关详细信息，单击光盘 1 上 Readme.htm 中的“升级前的准备工作”。此问题在“使用卷集、镜像集、带区集或带有奇偶校验的带区集”部分说明。

  • 提供自定义硬件抽象层 (HAL) 文件。如果您拥有计算机制造商提供的自定义硬件抽象层 (HAL) 文件，则应在运行光盘 1 的安装程序之前找到包含该文件的软盘或其他介质。在安装程序开始过程中，屏幕底部会有一行提示您按 F6 的信息；但是在此时按 F5（而不是 F6）。按 F5 之后，请按照提示在安装过程中包含 HAL 文件。

  • 如果要远程安装光盘 2，请启用终端服务。在安装光盘 1 之后，将需要手动在目标计算机上启用终端服务。这是由于默认情况下禁用终端服务。要启用终端服务，右键单击“我的电脑”，再单击“属性”。在“远程”选项卡上，选中“允许用户远程连接到此计算机”复选框。

重要安装信息

在安装 Windows Server 2003 R2 之前，请考虑以下事项：

  • Windows Server 2003 R2 可选组件不会自动安装。在完成光盘 2 的安装时，不会安装 Windows Server 2003 R2 可选组件。安装完成之后，可以使用“控制面板”中的“添加/删除 Windows 组件”来安装可选组件。也可以选择使用“管理您的服务器”来添加或升级服务器角色。

    注意

    Microsoft 管理控制台 (MMC) 3.0 在安装 Windows Server 2003 R2 时自动安装。

  • 可能需要升级组件。如果您的计算机上已安装了 Active Directory 应用程序模式 (ADAM) 或 Windows SharePoint Services，可以升级到 Windows Server 2003 R2 中包含的新版本。有关升级某个组件的详细信息，请参阅 Windows Server 2003 R2 TechCenter 网站上有关该组件的帮助 (http://go.microsoft.com/fwlink/?LinkId=45560)（英文）。

  • 无法卸载 Windows Server 2003 R2。Windows Server 2003 R2 源文件是永久性的，但是可以卸载您安装的任何可选组件。

  • 64 位版本的重要信息。只可以在运行光盘 1 上 64 位版本的 Windows Server 2003 的计算机上安装 64 位版本的光盘 2。换句话说，不能在运行 64 位版本的 Windows Server 2003 的计算机上安装 32 位版本的 Windows Server 2003 R2。


安装或升级到 Windows Server 2003 R2

Windows Server 2003 R2 包含两张产品光盘。光盘 1 包含 Windows Server 2003。光盘 2 包含 Windows Server 2003 R2 可选组件的安装文件。两张光盘使用相同的产品密钥。

注意

安装光盘 2 时不会自动安装 Windows Server 2003 R2 可选组件。安装完成之后，可以使用“控制面板”中的“添加/删除 Windows 组件”来安装可选组件。也可以选择使用“管理您的服务器”来添加或升级服务器角色。有关这些选项的详细信息，请参阅安装可选组件和服务器角色。

本主题内容

  • 执行 Windows Server 2003 R2 的全新安装

  • 升级到 Windows Server 2003 R2

  • 用于安装 Windows Server 2003 R2 的命令行选项


执行 Windows Server 2003 R2 的全新安装

Windows Server 2003 R2 包含两张产品光盘。光盘 1 包含 Windows Server 2003 的最新版本。光盘 2 包含 Windows Server 2003 R2 可选组件的安装文件。两张光盘使用相同的产品密钥。

本主题内容

  • 从产品光盘安装

  • 从共享网络资源安装

  • 执行无人参与的安装

  • 使用远程安装服务安装


从产品光盘安装

要使用产品光盘执行 Windows Server 2003 R2 的全新安装，将需要安装光盘 1 和光盘 2。

注意

安装 Windows Server 2003 R2 时不会自动安装 Windows Server 2003 R2 可选组件。安装完成之后，可以使用“控制面板”中的“添加/删除 Windows 组件”来安装可选组件。也可以选择使用“管理您的服务器”来添加或升级服务器角色。有关这些选项的详细信息，请参阅安装可选组件和服务器角色。

从产品光盘安装 Windows Server 2003 R2

  1. 将光盘 1 插入您的 CD-ROM 驱动器，然后重新启动计算机。

  2. 按照计算机启动例程中的指示从光盘启动计算机。

  3. 按照屏幕上的指示进行操作。系统提示您输入产品密钥时，键入两张产品光盘提供的产品密钥。

    注意

    有关安装 Windows Server 2003（光盘 1）的详细信息，请参阅光盘 1 的根目录中的 Readme.htm。

    注意

    计算机在安装光盘 1 后重新启动时，不要按任意键从光盘启动。

  4. 安装光盘 1 之后，以管理员身份登录到计算机。

  5. 在提示符下，插入光盘 2，然后单击“确定”。

  6. 按照屏幕上的指示进行操作。


从共享网络资源安装

要使用共享网络资源执行 Windows Server 2003 R2 的全新安装，将需要安装光盘 1 和光盘 2 上的文件。

注意

安装 Windows Server 2003 R2 时不会自动安装 Windows Server 2003 R2 可选组件。安装完成之后，可以使用“控制面板”中的“添加/删除 Windows 组件”来安装可选组件。也可以选择使用“管理您的服务器”来添加或升级服务器角色。有关这些选项的详细信息，请参阅安装可选组件和服务器角色。

从共享网络资源安装 Windows Server 2003 R2

  1. 在网络服务器上，创建一个称为 \\ServerName\FolderName 的共享资源，其中 ServerName 是服务器的名称，FolderName 是您创建的共享资源的名称。

    要点

    确保只有系统管理员才具有此文件夹的完全访问权限。其他用户应当仅具有读取和执行权限。

  2. 将光盘 1 中的所有文件和文件夹复制到 \\ServerName\FolderName。

  3. 将光盘 2 中的所有文件和文件夹复制到 \\ServerName\FolderName。

  4. 单击“是”覆盖 Autorun.inf 文件。

  5. 在要安装 Windows Server 2003 R2 的计算机上，以管理员身份登录并连接到包含安装程序文件的共享文件夹。

  6. 要首先安装 Windows Server 2003，请在 i386 文件夹中单击 Winnt32.exe。对于 64 位版本，此文件位于 Amd64 文件夹中。

  7. 按照屏幕上的指示进行操作。系统提示您输入产品密钥时，键入两张产品光盘提供的产品密钥。

  8. Windows Server 2003 安装完成之后，以管理员身份登录到计算机。光盘 2 的安装程序应自动启动。如果没有自动启动，请连接到包含安装程序文件的共享文件夹上，并在 \Cmpnents\R2 文件夹中单击 Setup2.exe。

  9. 按照屏幕上的指示进行操作。


执行无人参与的安装

要了解无人参与的安装，请参阅以下内容：

  • 如果要执行光盘 1 光盘 2 的无人参与安装，请在光盘 2 \Docs 的文件夹中参阅 Deploy.chm 中的“自动完成 Windows Server 2003 R2 的安装”。此文档将帮助您创建和修改 Unattend.txt 文件。

  • 如果只希望从命令行执行光盘 2 的无人参与安装，请参阅用于安装 Windows Server 2003 R2 的命令行选项。

  • 有关运行无人参与安装（也称为自动安装）的详细信息，请参阅 Microsoft 网站上的“Windows Server 2003 Deployment Kit: Automating and Customizing Installations”(http://go.microsoft.com/fwlink/?LinkId=50476)（英文）。

  • 如果要升级到 Windows Server 2003 R2 批量授权版本，并希望对产品密钥进行加密，请参阅 Microsoft 网站(http://go.microsoft.com/fwlink/?LinkId=55123)（英文）。


使用远程安装服务安装

可以使用远程安装服务 (RIS) 在远程计算机上安装 Windows Server 2003 R2。

如果是初次使用 RIS，将需要先安装并配置 RIS，然后再执行这些过程。要了解如何安装和配置 RIS，请参阅 Microsoft 网站上的“How To Use Remote Installation Services to Install Windows Server 2003 on Remote Computers”(http://go.microsoft.com/fwlink/?LinkId=50199)（英文）。

使用 RIS 安装

在本部分的第一个过程中，将创建 Windows Server 2003（光盘 1）的映像。在第二个过程中，将 Windows Server 2003 R2 安装文件（Windows Server 2003 R2 光盘 2）添加到已创建的映像。

  • 创建 Windows Server 2003（光盘 1）的映像

  • 将 Windows Server 2003 R2 安装文件（光盘 2）添加到映像

创建 Windows Server 2003（光盘 1）的映像

  1. 在运行 RIS 的计算机上，以具有管理权限的用户身份登录。

  2. 单击“开始”，单击“运行”，再键入 risetup.exe，然后单击“确定”启动“RIS 安装向导”。

  3. 当出现欢迎使用屏幕时，单击“下一步”。

  4. 选择“将新的操作系统映像添加到此远程安装服务器”，然后单击“下一步”。

  5. 然后，系统提示您输入客户端操作系统安装文件的位置。将 Windows Server 2003 R2 光盘 1 插入 CD-ROM 驱动器，然后单击“下一步”。

    注意

    在创建客户端操作系统映像时，Microsoft 只支持使用 Microsoft 介质。不支持使用非 Microsoft 介质。

  6. 键入 RIS 服务器上的光盘 1 安装文件的文件夹名称，然后单击“下一步”。

  7. 为操作系统映像键入易懂的说明。例如，可以键入 Windows-Server-2003。在用户启动远程客户端并运行“客户端安装向导”之后，将向用户显示此说明。

  8. 单击“下一步”。

  9. 如果以前在此服务器上创建了操作系统映像，系统将提示您指定安装程序应如何处理旧的客户端安装屏幕。选择以下某项：

    • 如果要以后使用旧的安装屏幕，选择“使用新的客户端安装屏幕，并使用 .bak 扩展名重命名旧的客户端安装屏幕”。

    • 如果要删除旧的安装屏幕，选择“使用新的客户端安装屏幕，并覆盖旧的客户端安装屏幕”。

    • 如果已对要保留的安装屏幕进行了修改，选择“使用旧的客户端安装屏幕”。

  10. 单击“下一步”。

  11. 单击“完成”，然后单击“完成”。
将 Windows Server 2003 R2 安装文件（光盘 2）添加到映像

  1. 导航到在前面的过程中创建的映像。映像将位于 Drive:\RemoteInstallFolder\Setup\Language\Images\ImageName。例如 E:\RemoteInstall\Setup\English\Images\Windows-Server-2003。

  2. 在此目录中，创建一个 $OEM$ 文件夹和一个 Cmpnents 文件夹。例如，应包含如下目录：

    E:\RemoteInstall\Setup\English\Images\Windows-Server-2003\i386

    E:\RemoteInstall\Setup\English\Images\Windows-Server-2003\$OEM$

    E:\RemoteInstall\Setup\English\Images\Windows-Server-2003\Cmpnents

  3. 在 $OEM$ 文件夹中，创建以下目录：$OEM$\$1\R2。

  4. 在 $OEM$\$1\R2 目录中创建名为 R2comp.inf 的文件。

  5. 在 R2comp.inf 中，创建 [Version] 部分，然后创建 [Components] 部分，列出要安装的组件。例如，以下示例安装 Active Directory 应用程序模式 (ADAM) 和公用日志文件系统：

    [Version]
Signature = "$Windows NT$"
[Components]
ADAM=on
CLFS=on

    有关可以安装的组件的完整列表，请参阅 Windows Server 2003 R2 光盘 2 的 \Docs 文件夹中的 Deploy.chm。

  6. 将光盘 2 上的 Cmpnents 文件夹的内容复制到 E:\RemoteInstall\Setup\English\Images\Windows-Server-2003\Cmpnents

  7. 打开位于以下文件夹中的 RISstndrd.sif 文件：

    E:\RemoteInstall\Setup\English\Images\Windows-Server-2003\i386\templates。

    注意

    对于基于 x64 的计算机，此文件位于 Amd64\Templates 文件夹中。

  8. 在 RISstndrd.sif 中进行以下更改。此更改指定安装程序应复制 $OEM$ 文件夹中包含的子文件夹和文件。

    [Unattended]
OemPreinstall = yes

  9. 在 RISstndrd.sif 中，添加 [GuiRunonce] 部分。[GuiRunonce] 部分包含管理员首次登录到计算机时要执行的命令。在以下示例中，/q 选项指定安装程序应在安静模式下运行，/cs 选项在桌面上为说明新的 Windows Server 2003 R2 组件的文档创建快捷方式，/a 选项指定您接受 EULA。此外，将命令以“cmd /c”开头可以确保在执行下一个命令之前完成 Windows Server 2003 R2 的安装，“ProductID”是两张产品光盘提供的产品密钥。有关可以添加到此部分的选项的完整列表，请参阅 Windows Server 2003 R2 光盘 2 的 \Docs 文件夹中的 Deploy.chm。

    [GuiRunonce]
Command0="cmd /c \\RISServer\reminst\setup\Language\ImageName\Cmpnents\R2\setup2.exe /q /cs /a"
Command1="%windir%\system32\sysocmgr.exe /i:sysoc.inf /u:C:\R2\r2comp.inf"
[UserData]
ProductID = "XXXXX-XXXXX-XXXXX-XXXXX-XXXXX"

  10. 如果希望管理员以后能够安装 Windows Server 2003 R2 组件，请将光盘 2 的内容复制到 E:\RemoteInstall\Setup\English\Images\Windows-Server-2003\$OEM$\$1\R2。安装之后，这些文件将位于客户端计算机的 C:\R2 中。


升级到 Windows Server 2003 R2

Windows Server 2003 R2 包含两张产品光盘。光盘 1 包含 Windows Server 2003。光盘 2 包含 Windows Server 2003 R2 可选组件的安装文件。两张光盘使用相同的产品密钥。

升级方案随操作系统版本的不同而不同。

  • 如果您拥有包含 Service Pack 1 (SP1) 的第一版 Windows Server 2003 R2，请参阅升级到 Windows Server 2003 R2 的 SP1 版本。如果您的光盘未指定包含哪个 Service Pack，则说明只包含 SP1。

  • 如果您拥有包含 Service Pack 2 的第二版 Windows Server 2003 R2，请参阅升级到 Windows Server 2003 R2 的 SP2 版本。要确保是否拥有此版本，请确认产品光盘上贴有“包括 Service Pack 2”标签。如果您的光盘未指定包含哪个 Service Pack，则说明只包含 SP1。

    注意

    在安装 Windows Server 2003 R2 时，不会安装 Windows Server 2003 R2 可选组建。安装完成之后，可以使用“控制面板”中的“添加/删除 Windows 组件”来安装可选组件。此外，还可以选择使用“管理您的服务器”来添加或升级服务器角色。有关这些选项的详细信息，请参阅安装可选组件和服务器角色。


升级到 Windows Server 2003 R2 的 SP1 版本

要点

本主题适用的前提是您拥有第一版 Windows Server 2003 R2，其中光盘 1 包含 Service Pack 1 (SP1)。如果您的产品光盘未指定包含哪个 Service Pack，则说明只包含 SP1。

可以从运行以下操作系统的计算机升级到 Windows Server 2003 R2：

  • 带有 Service Pack 的 Windows Server 2003

  • 不带 Service Pack 的 Windows Server 2003

  • Windows 2000 Server

  • 带有 Service Pack 5 或更高版本的 Windows NT Server 4.0

  • 带有 Service Pack 5 或更高版本的 WindowsNT Server 4.0 Terminal Server Edition

注意

在安装 Windows Server 2003 R2 时，不会安装 Windows Server 2003 R2 可选组建。安装完成之后，可以使用“控制面板”中的“添加/删除 Windows 组件”来安装可选组件。此外，还可以选择使用“管理您的服务器”来添加或升级服务器角色。有关这些选项的详细信息，请参阅安装可选组件和服务器角色。

注意

如果正在运行 Windows Server 2003，并且尚未安装最新版的 Service Pack，可以从 Microsoft 网站 (http://go.microsoft.com/fwlink/?LinkId=5399)（英文）下载并安装 Service Pack。如果不希望安装光盘 1 中包含的集成版本，则使用此方法。Service Pack 包含在操作系统中，因此无法单独卸载。

本主题内容

  • 使用产品光盘升级

  • 从共享网络资源升级

使用产品光盘升级

从下列过程中选择：

  • 使用产品光盘从带有 Service Pack 的 Windows Server 2003 升级

  • 使用产品光盘从 Windows NT、Windows 2000 或不带 Service Pack 的 Windows Server 2003 升级

使用产品光盘从带有 Service Pack 的 Windows Server 2003 升级

  1. 以管理员身份登录到计算机。

  2. 将光盘 2 插入到 CD-ROM 驱动器中。如果光盘不能自动打开，请在命令行键入 D:r2auto.exe。D 是与 CD-ROM 驱动器关联的驱动器号。

  3. 按照屏幕上的指示输入两个产品光盘提供的产品密钥。
使用产品光盘从 Windows NT、Windows 2000 或不带 Service Pack 的 Windows Server 2003 升级

  1. 以管理员身份登录到计算机。

  2. 如果正在运行 Windows NT 或 Windows 2000，首先将光盘 1 插入 CD-ROM 驱动器以升级到 Windows Server 2003。如果光盘没有自动打开，打开该光盘，然后单击 Setup.exe。

  3. 在第一个屏幕上，选择安装操作系统的选项。

  4. 在“安装类型”中，选择“升级（建议）”。

  5. 单击“下一步”，然后继续按照屏幕上的指示操作。输入两个产品光盘提供的产品密钥。

  6. 光盘 1 安装完成之后，以管理员身份登录到计算机。

  7. 系统提示时，插入光盘 2，然后单击“确定”。

  8. 按照屏幕上的指示进行操作。

从共享网络资源升级

要使用共享网络资源升级到 Windows Server 2003 R2，需要将源文件复制到网络共享上。如果已安装带有 Service Pack 的 Windows Server 2003，只需复制并安装光盘 2 的源文件。如果没有安装 Service Pack，请同时复制并安装两张产品光盘的源文件。

从下列过程中选择：

  • 升级运行带有 Service Pack 的 Windows Server 2003 的计算机

  • 升级运行 Windows Server 2003（不带 Service Pack）、Windows NT 或 Windows 2000 的计算机

从共享网络资源升级运行带有 Service Pack 的 Windows Server 2003 的计算机

  1. 以管理员身份登录到计算机。

  2. 在网络服务器上，创建一个称为 \\ServerName\FolderName 的共享资源，其中 ServerName 是服务器的名称，FolderName 是您创建的共享资源的名称。

    要点

    确保只有系统管理员才具有此文件夹的完全访问权限。其他用户应当仅具有读取和执行权限。

  3. 只将光盘 2 中的所有文件和文件夹复制到共享资源上。

  4. 在要升级到 Windows Server 2003 R2 的计算机上打开命令提示符，连接到包含源文件的共享文件夹，然后运行 D:r2auto.exe。D 是与 CD-ROM 驱动器关联的驱动器号。

  5. 按照屏幕上的指示输入两个产品光盘提供的产品密钥。
从共享网络资源升级运行 Windows Server 2003（不带 Service Pack）、Windows NT 或 Windows 2000 的计算机

  1. 以管理员身份登录到计算机。

  2. 在网络服务器上，创建一个称为 \\ServerName\FolderName 的共享资源，其中 ServerName 是服务器的名称，FolderName 是您创建的共享资源的名称。

    要点

    确保只有系统管理员才具有此文件夹的完全访问权限。其他用户应当仅具有读取和执行权限。

  3. 将光盘 1 中的所有文件和文件夹复制到共享资源上。

  4. 将光盘 2 中的所有文件和文件夹复制到共享资源上。

  5. 单击“是”覆盖 Autorun.inf 文件。

  6. 在要升级到 Windows Server 2003 R2 的计算机上，连接到包含源文件的共享文件夹。

  7. 如果正在运行 Windows NT 或 Windows 2000，请首先升级到 Windows Server 2003：在 i386 文件夹中，单击 Winnt32.exe。对于 64 位版本，此文件位于 Amd64 文件夹中。

  8. 按照屏幕上的指示输入两个产品光盘提供的产品密钥。

  9. Windows Server 2003 安装完成之后，以管理员身份登录到计算机。光盘 2 的安装程序应自动启动。如果没有自动启动，请连接到包含源文件的共享文件夹，然后运行 D:r2auto.exe。D 是与 CD-ROM 驱动器关联的驱动器号。

  10. 按照屏幕上的指示进行操作。


升级到 Windows Server 2003 R2 的 SP2 版本

要点

本主题适用的前提是您拥有包含 Service Pack 2 (SP2) 的第二版 Windows Server 2003 R2。 要确保拥有此版本，请确认产品光盘上贴有“包括 Service Pack 2”标签。如果您的光盘未指定包含哪个 Service Pack，则说明只包含 Service Pack 1 (SP1)。

可以从运行以下操作系统的计算机升级到 Windows Server 2003 R2：

  • Windows Server 2003

  • 带有 SP1 的 Windows Server 2003

  • Windows 2000 Server

  • 带有 Service Pack 5 或更高版本的 Windows NT Server 4.0

  • 带有 Service Pack 5 或更高版本的 WindowsNT Server 4.0 Terminal Server Edition

注意

如果正在运行 Windows Server 2003，并且尚未安装最新版的 Service Pack，可以从 Microsoft 网站 (http://go.microsoft.com/fwlink/?LinkId=5399)（英文）下载并进行安装。如果不希望安装光盘 1 中包含的集成版本，则使用此方法。Service Pack 包含在操作系统中，因此无法单独卸载。

注意

在安装 Windows Server 2003 R2 时，不会安装 Windows Server 2003 R2 可选组建。安装完成之后，可以使用“控制面板”中的“添加/删除 Windows 组件”来安装可选组件。此外，还可以选择使用“管理您的服务器”来添加或升级服务器角色。有关这些选项的详细信息，请参阅安装可选组件和服务器角色。

注意

如果安装光盘 1，则只能安装 Windows Server 2003 R2 版本附带的光盘 2 - 不能安装 Windows Server 2003 R2 先前版本附带的光盘 2。

本主题内容

  • 使用产品光盘升级

  • 从共享网络资源升级

  • 升级图表

使用产品光盘升级

要升级到 Windows Server 2003 R2，需要同时安装两张产品光盘。

升级到 Windows Server 2003 R2

  1. 以管理员身份登录到计算机。

  2. 要首先升级到 Windows Server 2003 的最新版本，请将光盘 1 插入 CD-ROM 驱动器。如果光盘没有自动打开，打开该光盘，然后单击 Setup.exe。

  3. 在第一个屏幕上，选择安装操作系统的选项。

  4. 在“安装类型”中，选择“升级（建议）”。

  5. 单击“下一步”，再按照屏幕上的指示输入两个产品光盘提供的产品密钥。

  6. 光盘 1 安装完成之后，以管理员身份登录到计算机。

  7. 系统提示时，插入光盘 2，然后单击“确定”。

  8. 按照屏幕上的指示进行操作。

从共享网络资源升级

要使用共享网络资源升级到 Windows Server 2003 R2，需要将两张光盘中的源文件复制到网络共享上。

升级到 Windows Server 2003 R2

  1. 以管理员身份登录到计算机。

  2. 在网络服务器上，创建一个称为 \\ServerName\FolderName 的共享资源，其中 ServerName 是服务器的名称，FolderName 是您创建的共享资源的名称。

    要点

    确保只有系统管理员才具有此文件夹的完全访问权限。其他用户应当仅具有读取和执行权限。

  3. 将光盘 1 中的所有文件和文件夹复制到共享资源上。

  4. 将光盘 2 中的所有文件和文件夹复制到共享资源上。

  5. 单击“是”覆盖 Autorun.inf 文件。

  6. 在要升级到 Windows Server 2003 R2 的计算机上，连接到包含源文件的共享文件夹。

  7. 要首先安装 Windows Server 2003，请在 i386 文件夹中单击 Winnt32.exe。对于 64 位版本，此文件位于 Amd64 文件夹中。

  8. 按照屏幕上的指示输入两个产品光盘提供的产品密钥。

  9. Windows Server 2003 安装完成之后，以管理员身份登录到计算机。光盘 2 的安装程序应自动启动。如果没有自动启动，请连接到包含源文件的共享文件夹，然后运行 D:r2auto.exe。D 是与 CD-ROM 驱动器关联的驱动器号。

  10. 按照屏幕上的指示进行操作。

升级图表

以下图表显示了 Windows Server 2003 R2 版本所支持的升级途径。


用于安装 Windows Server 2003 R2 的命令行选项

在运行 Setup2.exe 时，可以使用以下命令行选项来定义 Windows Server 2003 R2 的安装方式。这些选项不区分大小写。

选项 说明

/q

或

/quiet

指定 Windows Server 2003 R2 将在安静模式下安装，没有用户界面。使用此选项时，安装过程中不会出现任何提示。

/p: ProductKey

或

/productkey: ProductKey

指定安装 Windows Server 2003 R2 时应使用的产品密钥。如果尚未输入 Windows Server 2003 R2 产品密钥，则必须使用此参数。

ProductKey 必须使用 AAAAA-AAAAA-AAAAA-AAAAA-AAAAA 格式指定。

/a

或

/accepteula

指定您接受 EULA。如果未使用光盘 1 安装 Windows Server 2003，则必须使用此参数。

通过使用此选项，表明您同意已阅读并接受了 Windows Server 2003 R2 适用的最终用户许可协议 (EULA) 的条款。可以在光盘 2 的 \Cmpnents\R2 文件夹中找到以下文件。

  • 如果您是从原始设备制造商 (OEM) 处获得此产品，适用的 EULA 为 Eula_oem.txt。

  • 如果您是在零售店中购买该产品，适用的 EULA 为 Eula_retail.txt。

  • 如果您使用 Windows Server 2003 R2 的评估副本，适用的 EULA 为 Eula_eval.txt。

    要点

    如果您不是此计算机的最终用户，在使用此选项之前，您将需要首先验证最终用户（个人或组织）是否已收到、阅读并接受了 Windows Server 2003 R2 EULA 的条款。

/cs

或

/createshortcut

在桌面上为说明新的 Windows Server 2003 R2 组件的文档创建快捷方式。

/sr

或

/suppressreboot

取消 Windows Server 2003 R2 安装完成之后的重新启动。

/?

显示在安装 Windows Server 2003 R2 时可以使用的命令行选项。
注意

如果要在脚本或应答文件中使用 Setup2.exe，应将命令以 cmd /c 开头。这确保在执行下一个命令（如 cmd /c setup2.exe /q /a /p:XXXXX-XXXXX-XXXXX-XXXXX-XXXXX /cs）之前完成 Windows Server 2003 R2 的安装

注意

有关如何创建和修改 Unattend.txt 文件以及如何执行无人参与的 Windows Server 2003 R2 安装的信息，请在 Windows Server 2003 R2 光盘 2 的 \Docs 文件夹中参阅 Deploy.chm 中的“自动完成 Windows Server 2003 R2 的安装”。


安装可选组件和服务器角色

安装完成之后，可以使用“控制面板”中的“添加/删除 Windows 组件”来安装可选组件。也可以选择使用“管理您的服务器”来添加或升级服务器角色。

注意

有关将 ADAM 或 Windows SharePoint Services 升级到 Windows Server 2003 R2 中包含的新版本的具体说明，请参阅 Windows Server 2003 R2 TechCenter 网站上有关该组件的帮助 (http://go.microsoft.com/fwlink/?LinkId=45560)（英文）。

本主题内容

  • 使用“管理您的服务器”添加或升级服务器角色

  • 使用“添加/删除 Windows 组件”安装可选组件

  • 在“添加/删除 Windows 组件”中查找组件


使用“管理您的服务器”添加或升级服务器角色

安装完成之后，可以使用“管理您的服务器”添加或升级服务器角色。文件服务器角色和打印服务器角色包含 Windows Server 2003 R2 中的更新。此外，Windows® SharePoint® Services 角色是 Windows Server 2003 R2 中的新服务器角色。

注意

有关将 ADAM 或 Windows SharePoint Services 升级到 Windows Server 2003 R2 中包含的新版本的详细说明，请参阅 Windows Server 2003 R2 TechCenter 网站上有关该组件的帮助 (http://go.microsoft.com/fwlink/?LinkId=45560)（英文）。

使用“管理您的服务器”添加或升级服务器角色

  1. 以管理员身份登录到计算机。

  2. 单击“开始”，再单击“管理工具”，然后单击“管理您的服务器”。

  3. 单击“添加或删除角色”。

  4. 按照“配置您的服务器向导”中的指示操作。在进入“服务器角色”页时，选择下列角色之一：

    • 文件服务器

      Windows Server 2003 R2 的文件服务器组件包括文件服务器管理、DFS 管理、DFS 复制服务、文件服务器资源管理器、SAN 存储管理、Microsoft 网络文件系统服务和 Macintosh 服务。

    • SharePoint Services

      Windows Server 2003 R2 的 SharePoint Services 组件包括 Windows SharePoint Services。

    • 打印服务器

      Windows Server 2003 R2 的打印服务器组件是打印管理。

    注意

    在安装期间，系统可能会提示您插入 Windows Server 2003 R2 光盘 2（Windows Server 2003 R2 安装程序文件所在的位置）或指定 Windows Server 2003 R2 安装程序文件在硬盘上的位置。为了避免以后出现此对话框，请参阅Windows Server 2003 R2 安装问题疑难解答。

  5. “配置您的服务器向导”将安装与所选的角色关联的组件。


使用“添加/删除 Windows 组件”安装可选组件

安装完成之后，可以使用“控制面板”中的“添加/删除 Windows 组件”来安装 Windows Server 2003 R2 可选组件。这是一个通用的过程，要安装组件，可能需要更具体的说明。有关安装组件的详细信息，请参阅 Windows Server 2003 R2 TechCenter 网站上有关该组件的帮助 (http://go.microsoft.com/fwlink/?LinkId=45560)（英文）。

注意

有关将 ADAM 或 Windows SharePoint Services 升级到 Windows Server 2003 R2 中包含的新版本的详细说明，请参阅 Windows Server 2003 R2 TechCenter 网站上有关该组件的帮助 (http://go.microsoft.com/fwlink/?LinkId=45560)（英文）。

使用“添加/删除 Windows 组件”安装组件

  1. 以管理员身份登录到计算机。

  2. 在“控制面板”中打开“添加或删除程序”。

  3. 单击“添加/删除 Windows 组件”。

  4. 在“Windows 组件向导”中，找到要安装的组件。要找到某个组件，可以单击“详细信息”。例如，要安装 ADAM，单击“Active Directory”，然后单击“详细信息”。如果无法找到某个组件，请参阅在“添加/删除 Windows 组件”中查找组件。

  5. 选择要安装的组件，然后单击“下一步”。

    注意

    如果某个项目在“Windows 组件向导”中已选中，则表明已安装。

  6. 如果需要，按照“Windows 组件向导”中的指示操作。

    注意

    系统可能会提示您插入 Windows Server 2003 光盘 2（Windows Server 2003 R2 安装程序文件所在的位置）或指定 Windows Server 2003 R2 安装程序文件在硬盘上的位置。为了避免以后出现此对话框，请参阅 Windows Server 2003 R2 安装问题疑难解答。

  7. 安装完成时，单击“完成”。


在“添加/删除 Windows 组件”中查找组件

下表显示“添加/删除 Windows 组件”中的顶级组件与各自的子级组件之间的关系。要查找并安装特定的子级组件，找到关联的顶级组件，然后单击“详细信息”。例如，要安装 ADAM，单击“Active Directory 服务”，然后单击“详细信息”。

顶级组件 子级 1 组件 子级 2 和 3 组件

Active Directory 服务

  • Active Directory 应用程序模式 (ADAM)

不适用

  • Active Directory 联合身份验证服务 (ADFS)
  • ADFS Web 服务代理

    • 声明感知应用程序

    • 基于 Windows NT 令牌的应用程序

  • 联合身份验证服务

  • 联合身份验证服务代理

  • UNIX 身份管理
  • 管理组件

  • 密码同步

  • NIS 服务器

分布式文件系统

  • DFS 管理

  • DFS 复制服务

不适用

管理和监视工具

  • 文件服务器资源管理器

  • 硬件管理

  • 打印管理控制台组件

  • SAN 存储管理器

不适用

Microsoft .NET Framework 2.0

不适用

不适用

其他网络文件和打印服务

  • 公用日志文件系统

不适用

  • Microsoft NFS 服务
  • NFS 客户端

  • Microsoft NFS 管理服务

  • RPC 外部数据表示法

  • RPC 端口映射器

  • NFS 服务器

  • NFS 服务器身份验证

  • 用户名映射

基于 UNIX 的应用程序的子系统

不适用

不适用

Windows SharePoint Services

不适用

不适用


从运行 Windows XP 的计算机管理组件

为了便于远程管理您的服务器，可以安装光盘 2 上 \mgmttls 目录中的 Windows Server 2003 R2 管理工具包。以下每个组件均包含管理工具包：

  • Microsoft 管理控制台 (MMC) 3.0

  • 打印管理

  • 文件服务器资源管理器

  • DFS 复制

  • UNIX 身份管理

  • 文件服务器管理

要管理组件，必须先安装 MMC 3.0 管理工具包。管理工具包可以安装在运行带有 Service Pack 2 (SP2) 的 Windows XP 的计算机上。

安装或重新安装 Windows Server 2003 R2 管理工具包

  1. 将光盘 2 插入到 CD-ROM 驱动器中。

  2. 打开命令提示符，然后键入光盘 2 的 \admin 目录的路径。例如，如果光盘驱动器为驱动器 E，则键入 E:\admin。

  3. 如果您的计算机上没有安装 MMC 3.0，右键单击“MMC 3.0 管理工具包”，单击“打开”，然后按照屏幕上的指示操作。

  4. 右键单击要安装的管理工具包，然后单击“打开”。

  5. 按照屏幕上的指示安装管理包。

    注意

    要执行该过程，您必须是本地计算机上 Administrators 组的成员，或者您必须被委派了适当的权限。如果计算机已加入某个域，则 Domain Admins 组的成员可能会执行该过程。作为安全性最佳操作，请考虑使用“运行方式”执行此过程。

    注意

    可以随时重新安装 Windows Server 2003 R2 管理工具包。重新安装将覆盖此前的所有安装。


Windows Server 2003 R2 安装问题疑难解答

以下是部署此操作系统时可能会遇到的具体问题。查阅这些信息有助于解决部署问题。

停止消息

这部分概述了对停止消息或意外关机进行疑难解答的步骤，这些停止消息或意外关机是操作系统中的系统错误引起的。系统出现错误后，计算机会停止响应，并在蓝色或黑色背景下显示一条消息。

可使用系统信息工具收集关于系统设置、问题设备和硬件资源的重要信息。有关详细信息，请参阅 Microsoft 网站上的“System Information”(http://go.microsoft.com/fwlink/?LinkId=51216)（英文）。

要点

要确保系统稳定性，请安装适合系统的最新的 Service Pack（按照 Service Pack 说明），而且仅使用签名的驱动程序。有关详细信息，请参阅 Microsoft 网站上的“Windows Update”(http://go.microsoft.com/fwlink/?LinkId=284)。

对于不显示标识文本或具体疑难解答步骤的停止错误，请按照以下步骤进行操作：

  1. 使用 Microsoft 网站上的 Microsoft Online Crash Analysis 工具 (http://go.microsoft.com/fwlink/?LinkId=11699)。可使用此工具向 Microsoft 发送错误报告，并使用 Microsoft Passport 信息跟踪其状态。可使用错误报告服务或 Web 浏览器来访问 Online Crash Analysis 网站。当它启用时，错误报告服务将监视系统中与操作系统组件和应用程序相关的内核和用户模式错误。通过内核模式报告，您可获得关于导致停止错误的问题或条件的详细信息。有关详细信息，请参阅 Microsoft 网站上的“System and program error reporting overview”(http://go.microsoft.com/fwlink/?LinkId=51191)（英文）。

  2. 使用“文件签名验证”工具 (Sigverif.exe)，该工具能识别计算机上未签名的驱动程序和不兼容的系统文件。由 Windows Server 2003 家族产品提供的系统文件和设备驱动程序文件有一个 Microsoft 数字签名，该签名指示这些文件是未更改的原始系统文件，或者指明 Microsoft 已批准它们可以用于 Windows。

  3. 如果停止消息的出现是由驱动程序问题造成的，则可使用“设备管理器”返回先前版本的驱动程序。有关详细信息，请参阅 Microsoft 网站上的“Roll back to the previous version of a driver”(http://go.microsoft.com/fwlink/?LinkId=51192)（英文）。可能需要禁用所有新近安装的驱动程序。

  4. 用最新版本的防病毒软件检查计算机中是否有病毒。如果找到病毒，则执行必要的步骤把它从计算机上清除掉。要了解如何执行这些步骤，请参阅反病毒软件的文档。

  5. 有关停止消息的更新信息，可以在 Microsoft 网站上搜索支持知识库 (KB) (http://go.microsoft.com/fwlink/?LinkId=46046)。键入关键字时，请使用停止消息号（如 stop 0x0000000A）。

    有关可以下载的文章、疑难解答向导和项目的详细信息，请参阅 Microsoft 网站上的“Updated technical information”(http://go.microsoft.com/fwlink/?LinkId=51193)（英文）。

  6. 如果能启动操作系统，则请检查事件查看器中的系统日志，以获取有助于确定导致问题的设备或驱动程序的其他信息。很多停止消息都将生成可搜索到的特定事件，如事件 ID 1001（由各种停止消息生成）和事件 ID 6008（通常由意外关机或未正确启动的计算机引起）。要显示某个事件的说明，请在事件查看器中双击该事件。有关事件查看器的详细信息，请参阅 Microsoft 网站上的“Event Viewer”(http://go.microsoft.com/fwlink/?LinkId=51195)（英文）。

    有关事件 ID 的更新信息，可以在 Microsoft 网站上搜索支持知识库 (KB) (http://go.microsoft.com/fwlink/?LinkId=46046)。

  7. 如果不能启动计算机，应尝试以“最后一次正确的配置”或“安全模式”启动它，然后删除或禁用最新添加的程序或驱动程序。有关如何以“安全模式”启动计算机的信息，请参阅 Microsoft 网站上的“Start the computer in Safe Mode”(http://go.microsoft.com/fwlink/?LinkId=51196)（英文）。有关如何以“最后一次正确的配置”启动计算机的详细信息，请参阅 Microsoft 网站上的“Start the computer using the last known good configuration”(http://go.microsoft.com/fwlink/?LinkId=51197)（英文）。

    要点

    使用“最后一次正确的配置”时，最后一次成功启动后对系统设置所做的更改都将丢失。

  8. 移除所有最近安装的硬件（RAM、适配器、硬盘、调制解调器等）。

  9. 确保您有硬件设备的更新驱动程序。此外，确保有最新的系统 BIOS 或正确的固件（对于基于 Itanium 体系结构的计算机）。设备或硬件制造商可以帮助您获得这些项目。

  10. 运行计算机制造商提供的系统诊断工具，尤其是内存检查工具。

  11. 通过在 Microsoft 网站上的“Support resources”(http://go.microsoft.com/fwlink/?LinkId=51198) 中单击相应的链接，确认硬件针对 Windows Server 2003 家族而设计。

  12. 如果“安全模式”和其他启动选项仍然不起作用，可以考虑使用“恢复控制台”。只有可以使用基本命令识别和定位有问题的驱动程序和文件的高级用户才建议使用此方法。另外，要使用恢复控制台，您必须是管理员。有关详细信息，请参阅 Microsoft 网站上的“Recovery Console overview”(http://go.microsoft.com/fwlink/?LinkId=51199)（英文）。

有关详细信息，请参阅以下内容：

  • 有关如何获取产品支持的信息，请参阅 Microsoft 网站上的“Windows Server 2003 Support”(http://go.microsoft.com/fwlink/?LinkId=26478)（英文）。

  • 有关特定停止消息疑难解答的信息，请访问 Microsoft 网站 (http://go.microsoft.com/fwlink/?LinkId=51200)（英文）。

  • 有关特定停止消息的文章，可以在 Microsoft 网站上搜索支持知识库 (KB) (http://go.microsoft.com/fwlink/?LinkId=46046)。

  • 有关支持选项的信息，请参阅 Microsoft 网站上的“Support resources”(http://go.microsoft.com/fwlink/?LinkId=51198)（英文）。

  • 有关特定技术或组件（例如磁盘和文件系统）疑难解答的信息，请参阅 Microsoft 网站上的“Windows Server 2003 Technical Reference”(http://go.microsoft.com/fwlink/?LinkId=4546)（英文）。

计算机不启动

Windows Server 2003 家族中的产品提供可以在系统不启动时使用的各种选项：

  • 第一个选项。尝试使用“安全模式”或相关的启动选项（其中一个是“最后一次正确的配置”）重新启动计算机。这些选项启动只有最少的必要服务的系统。启动选项对于访问设备管理器（例如可以使用“安全模式”启动并回滚设备驱动程序）或备份（例如还原“系统状态”备份）等重要系统工具至关重要。要使用其中一个启动选项启动计算机，重新启动计算机，并在文本或图形屏幕出现又消失后但在 Windows 徽标出现前，按 F8。换言之，在基本输入/输出系统通电自检 (BIOS POST) 后立即按 F8。系统可能会提示您何时按 F8。

    有关详细信息，请参阅 Microsoft 网站上的“Startup options”(http://go.microsoft.com/fwlink/?LinkId=51175)（英文）。

    有关详细说明，请参阅 Microsoft 网站上的“Recover a System That Will Not Start”(http://go.microsoft.com/fwlink/?LinkId=51201)（英文）。

  • 第二个选项。如果“安全模式”不起作用，可以考虑使用恢复控制台。只建议高级用户或管理员使用此选项。通过从安装光盘启动系统，可以使用恢复控制台。在基于 x86（32 位）的计算机上，还可以将恢复控制台安装为启动选项。恢复控制台是一个命令行界面，您可以从中执行如启动和停止服务及访问本地磁盘（包括 NTFS 格式的磁盘）这样的任务。

要点

因为恢复控制台的功能相当强大，因此建议仅由高级用户或管理员使用。

要启动计算机并使用恢复控制台，将光盘 1 插入光盘驱动器并重新启动计算机。如果提示按某个键以从光盘启动计算机，请按相应的键。安装程序的文本部分开始时，按照提示操作。按 R 选择“恢复控制台”选项，然后继续按照屏幕上的指示操作。在进入系统提示符时，键入 help 可得到一个命令列表，或键入 help commandname 可得到特定命令的帮助。

无法登录

  • 问题：我已安装完光盘 1，现在，我无法使用终端服务登录到计算机。

    原因：安装光盘 1 上的 Windows Server 2003 时，默认情况下禁用终端服务。因此，安装光盘 1 之后，首先需要手动启用终端服务，之后才能够连接到计算机。

    解决方案：在目标计算机上，手动启用终端服务。要启用终端服务，右键单击“我的电脑”，再单击“属性”。在“远程”选项卡上，选中“允许用户远程连接到此计算机”复选框。

安装后的问题

以下是在安装此操作系统或安装组件时可能遇到的具体问题以及解决方案。

  • 问题：在安装 Windows Server 2003 R2 组件期间，系统提示我插入 Windows Server 2003 R2 光盘 2 或指定安装程序文件在硬盘上的位置。

    原因：如果安装 Windows Server 2003 的源位置与安装 Windows Server 2003 R2（光盘 1 和/或光盘 2）的源位置不同，将出现此对话框。例如，如果从共享网络资源安装 Windows Server 2003，然后使用产品光盘安装 Windows Server 2003 R2，将出现此对话框。

    解决方案：为了避免出现此对话框，应从相同的位置安装 Windows Server 2003 和 Windows Server 2003 R2。例如，可以使用从 Microsoft 获得的 Windows Server 2003 R2 产品光盘（光盘 1 和光盘 2）安装操作系统。或者，如果要从网络共享安装，将光盘 1 和光盘 2 中的所有文件和文件夹复制到共享网络资源上。出现询问您是否要替换 Autorun.inf 文件的对话框时，单击“是”。

  • 问题：我的安装已成功完成，但是在磁盘 1 的安装完成之后，系统未提示我插入光盘 2。

    原因：如果输入的产品密钥不是 Windows Server 2003 R2 产品光盘提供的产品密钥，可能会出现此情况。

    解决方案：在光盘 1 的安装完成之后，插入光盘 2 以安装 Windows Server 2003 R2。在系统提示时，输入两张产品光盘提供的产品密钥。

  • 问题：我在将组件升级到 Windows Server 2003 R2 中包含的新版本时遇到问题。

    解决方案：有关升级可选组件的具体说明，请参阅 Windows Server 2003 R2 TechCenter 网站上有关该组件的帮助 (http://go.microsoft.com/fwlink/?LinkId=45560)（英文）。可以升级的可选组件为 Active Directory 应用程序模式 (ADAM) 和 Windows SharePoint Services。

  • 问题：我已安装 Windows Server 2003 R2，但是我的计算机上没有安装新组件。

    原因：在安装光盘 2 时，不会安装 Windows Server 2003 R2 可选组件。

    解决方案：安装完成之后，可以使用“控制面板”中的“添加/删除 Windows 组件”来安装可选组件。也可以选择使用“管理您的服务器”来添加或升级服务器角色。有关这些选项的详细信息，请参阅安装可选组件和服务器角色。

    注意

    Microsoft 管理控制台 (MMC) 3.0 在安装 Windows Server 2003 R2 时自动安装。